神奇指标网

通达信绝密量能指标公式-主力量能

浏览 179次浏览 来源:神奇指标网 编辑:神奇指标网 发布日期:2022-09-30


1、放量过顶

两种形式:(1)在长期间隔放量的低位有一条放量达换手5%以上的中阳,冲出盘整区(2)新股上市经过充分换手用放量涨停创出上市新高后面往往伴随一轮中线行情。

2、三线开花

指的是在行情启动的初期,随着中长阳的出现,将5、10、25均线形成三角形多方托的形态,加上macd:DIF和DEA由平走粘合转为向上张口发散,而且5、40日均线金叉向上,阳量做上弦叉过,就构成了“均线,MacD,均量”的“三线开花”往往预示着短线急涨行情的开始。

3、四进二退一

在低位出现一根涨停阳线之后,第二根阳线涨幅超过6%,第三天回调时在昨日均价附近追进,再根据成交量级别决定持股时间。

4、极目远望

指在涨停板前导下,第二日k线上影最高接近涨停,而第三日再度收出低开并列的阳线,类似一对双眼望向远方,是短线追涨的必胜之法。


image.png



通达信指标公式源码介绍:



通达信绝密量能指标公式-主力量能



  万手:vol/10000,LINETHICK0,NODRAW;


  AA:=IF(CURRBARSCOUNT=1ANDPERIOD=5,VOL*240/FROMOPEN,DRAWNULL);


  预测:AA/10000;


  STICKLINE(CURRBARSCOUNT=1ANDPERIOD=5,AA,0,3,1),COLORYELLOW;


  BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));


  主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,


  BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));


  主买:主动买/10000,COLORRED,NODRAW;


  主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),


  IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));


  主卖:-主动卖/10000,COLORGREEN,NODRAW;


  差额:(主动买+主动卖)/10000,NODRAW;


  CC:=(2*C+H+L)/4;


  STICKLINE(CC>REF(CC,1),0,VOL,2,DRAWNULL),COLORRED;


  STICKLINE(CC<REF(CC,1),0,VOL,2,DRAWNULL),COLORCYAN;


  STICKLINE(CC=REF(CC,1),0,VOL,2,DRAWNULL),COLORWHITE;


  {STICKLINE(C>-1,0,VOL,3,1),COLORRED;


  STICKLINE(C<O,0,VOL,3,1),COLORFFFF00;


  STICKLINE(C=OANDC<REF(C,1),0,VOL,2,1),COLORFFFF00;


  STICKLINE(C=OANDC>REF(C,1),0,VOL,2,1),COLORRED;}


  STICKLINE(主动买>0,0,主动买,1,0),COLOR0000FF;


  STICKLINE(主动卖<0,VOL,主动买,1,0),COLOR00FF00;


  持币:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORGREEN;


  持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORMAGENTA;


  {INPUT:N(3,1,10),N2(6,1,10),N3(-23,-50,0),N4(75,50,100),P1(19,1,100),P2(118,1,250),N1(9,1,100);}


  VAR2:=(C-REF(C,1))/REF(C,1)*100;


  VAR3:=(C-LLV(L,18))/(HHV(H,18)-LLV(L,18))*100;


  VAR4:=SMA(VAR3,9,1);


  VAR5:=SMA(VAR4,3,1);


  J:3*VAR4-2*VAR5,COLOR00FFFF;


  VAR6:=J>1*REF(J,1);


  VAR7:=LLVBARS(L,50);


  VAR8:=SUM(V,VAR7);


  VAR9:=HHVBARS(H,50);


  VAR10:=SUM(V,VAR9);


  VAR11:=(C-REF(O,VAR9))/REF(O,VAR9)*100;


  VAR12:=VAR10/CAPITAL*100;


  VAR13:=(C-REF(O,VAR7))/REF(O,VAR7)*100;


  VAR14:=VAR8/CAPITAL*100;


  VAR15:=MA(WINNER(C),N)*100;


  VAR16:=EMA(VAR4,N);


  A2:EMA(VAR4,N),COLORFFDDCC;


  A3:=EMA(A2,N);


  A4:=EMA(A3,N);


  A5:=EMA(A4,N);


  A6:=EMA(A5,N);


  A7:=EMA(A6,N);


  VAR17:=EMA(A7,N);


  VAR18:=EMA(VAR17,N);


  VAR19:=EMA(VAR18,N);


  AA:=EMA(A5,N2);


  中期大底:LLV(J,AA),LINETHICK2,COLOR0000FF;


  上:=IF(MA(H,3)*1.05,30,0)*10-AA;


  下:=IF(MA(L,3)*0.96,30,0)*2/中期大底;


  中:=IF(MA(H,3)*1.05,30,0);


  电:=J;


  DRAWTEXT(CROSS(A4,AA)ANDVAR11<N3,AA,'●底'),COLORFFFF00;


  DRAWTEXT(CROSS(A2,J)ANDA2>N4,A2+4.22,'●峰'),COLOR00FFFF;


  五日:MA(V,5)COLORFFFFFFLINETHICK2;


  三十四日:MA(V,34)COLORFF80FFLINETHICK2;


  一百四十四日:MA(V,144)COLOR00FFFFLINETHICK1;


  回归斜率线A:=Ema(SLOPE(C,4)*20+C,42);


  经典RL:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;


  经典K:=SMA(经典RL,3,1);经典D:=SMA(经典K,3,1);经典J:=3*经典K-2*经典D;


  MAHL1:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20)))/(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));


  MAHL2:=IF(EMA(C,2)>回归斜率线AANDMAHL1>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));{A}


  MAHL3:=IF(EMA(C,2)>回归斜率线AANDMAHL1>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));{A}


  回归斜率带:DRAWBAND(回归斜率线A,RGB(235,0,230),REF(回归斜率线A,2),RGB(0,104,154));


  上线:=SMA(C,6.5,1);


  一号支撑线:SMA(C,14.5,1);


  上线1:=SMA(C,3,1);


  一号支撑线1:=SMA(C,8,1);


  上线2:=SMA(C,3.5,1);


  DRAWTEXT(crOSS(一号支撑线1,上线1),H*1.08,'洗盘'),COLOR00FF00;


  bbi:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,25))/4;


  UPR:=BBI+3*stD(BBI,13),LINETHICK2;


  DWN:=BBI-3*STD(BBI,13);


  安全:=MA(CLOSE,55),LINETHICK2;


  LC:=REF(CLOSE,1);


  rsi:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(Abs(CLOSE-LC),6,1)*100;


  DRAWTEXT(CROSS(82,RSI)ANDCLOSE<上线1,HIGH*1.04,'减仓'),COLORFF9966,LINETHICK2;


  A7:=(2*C+H+L)/4;


  操作:MA(A7,5),COLORBLUE,LINETHICK2;


  操作1:=MA(A7,5)*1.03,LINETHICK2;


  操作2:=MA(A7,5)*0.97,LINETHICK2;


  DRAWTEXT(CROSS(上线1,上线)AND上线1>操作,LOW*0.92,'买进'),COLORYELLOW;


  VAR1:LLV(A7,21);


  VAR2:HHV(A7,30);


  DRAWTEXT(CROSS(上线1,操作)AND上线1<一号支撑线AND上线1<一号支撑线1AND上线1<上线ANDCLOSE>VAR1,LOW*0.98,'见底'),COLORYELLOW;


  YCX:=操作>=REF(操作,1);


  H1:=MAX(MAX(上线,一号支撑线1),一号支撑线);


  L1:=MIN(MIN(上线,一号支撑线1),一号支撑线);


  DRAWTEXT(CROSS(上线1,一号支撑线1)AND上线1>操作,LOW*0.98,'全仓'),COLORYELLOW;


  SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);


  SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);


  M1:=1000*操作/一号支撑线<=1015AND1000*操作/一号支撑线>=975;


  M2:=1000*一号支撑线1/一号支撑线<=1020AND一号支撑线1/一号支撑线>=980;


  M3:=1000*上线/一号支撑线<=1015AND上线/一号支撑线>=985;


  DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10AND


  COUNT(SK>SD,6)ANDREF(LOW,5)=LLV(LOW,120)ANDREF(CLOSE>=OPEN,4)AND


  REF(CLOSE>OPEN,3)ANDREF(CLOSE>OPEN,2)ANDREF(OPEN>CLOSE,1)AND


  OPEN>REF(CLOSE,1),1,0),LOW*0.94,'买进'),COLORYELLOW;


  D:=MA(CLOSE,89)-MA(CLOSE,10)/3;


  DRAWTEXT(IF(CLOSE<DANDvol/240>MA(VOL,5)/240ANDCLOSE>REF(CLOSE,1)*1.08


  ANDCLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.88,'抄底'),COLORBROWN;


  RSV:=(CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100;


  K:=SMA(RSV,3,1);


  D1:=SMA(K,3,1);


  J:=3*K-2*D1;


  VAR3:=(2*CLOSE+HIGH+LOW)/3;{可将3该为4,信号少点}


  VAR4:=EMA(EMA(EMA(VAR3,4),4),4);{可将3该为4,信号少点}


  E:=(VAR4-REF(VAR4,1))/REF(VAR4,1)*100;


  F:=MA(E,3)+0.03;


  G:=MA(E,1);


  DRAWICON(CROSS(F,G)ANDJ>65,HIGH*1.02,15),COLORGREEN;


  DRAWICON(CROSS(G,F),LOW*0.9,9),COLORYELLOW;


  DRAWTEXT(CLOSE>OPENANDH1<CANDO<L1ANDYCXANDCROSS(上线1,操作)ANDLOW>VAR1AND上线1>一号支撑线ANDJ<90,LOW*0.9,'主升'),COLORRED;


  DRAWTEXT(CROSS(上线1,操作)ANDM1ANDM2ANDM3,LOW*0.94,'买进'),COLORYELLOW;


  DRAWTEXT(CLOSE>OPENAND上线>一号支撑线1AND一号支撑线1>一号支撑线ANDCLOSE>MA(CLOSE,一号支撑线)AND操作>=REF(CLOSE,操作)ANDCROSS(上线1,操作)ANDLOW>VAR1ANDJ<90,LOW*0.9,'主升'),COLORRED;


  DRAWTEXT(CLOSE>OPENAND操作>上线AND上线>一号支撑线1AND一号支撑线1>一号支撑线ANDCROSS(上线1,操作)ANDLOW>VAR1ANDJ<90,LOW*0.86,'回踩买进'),COLORRED;


  DRAWTEXT(CLOSE>OPENANDCROSS(上线,一号支撑线)ANDLOW>VAR1ANDJ<90,LOW*0.86,'回踩买进'),COLORRED;


  STICKLINE(CLOSE>REF(CLOSE,1),HIGH,LOW,0,0),COLORRED;


  STICKLINE(C<OANDC>REF(C,1),C,O,3,0),COLORFFCC00;


  STICKLINE(CLOSE>REF(CLOSE,1)ANDC>O,OPEN,CLOSE,3,0),COLOR000055;{红K};


  STICKLINE(CLOSE>REF(CLOSE,1)ANDC>O,OPEN,CLOSE,2.7,0),COLOR000077;{红K};


  STICKLINE(CLOSE>REF(CLOSE,1)ANDC>O,OPEN,CLOSE,2.1,0),COLOR000099;


  STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLOR0000BB;


  STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLOR0000DD;


  STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLOR0000FF;


  STICKLINE(CLOSE=REF(CLOSE,1),H,L,3,1),COLOR999999;


  STICKLINE(CLOSE=REF(CLOSE,1),HIGH,LOW,0,0),COLORWHITE;


  STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,3,0),COLOR555555;


  STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLOR777777;


  STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLOR999999;


  STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLORBBBBBB;


  STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLORDDDDDD;


  STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLORFFFFFF;


  STICKLINE(CLOSE<REF(CLOSE,1),HIGH,LOW,0,1),COLORCYAN;


  STICKLINE(C<REF(C,1)ANDC>O,C,O,3,0),COLORFFCC00;


  STICKLINE(C<REF(C,1)ANDC<O,OPEN,CLOSE,3,0),COLOR990000;


  STICKLINE(C<REF(C,1)ANDC<O,OPEN,CLOSE,2.7,0),COLORCC0000;


  STICKLINE(CLOSE<REF(C,1),OPEN,CLOSE,2.1,0),COLORFF4400;


  STICKLINE(CLOSE<REF(C,1),OPEN,CLOSE,1.5,0),COLORFF8800;


  STICKLINE(CLOSE<REF(C,1),OPEN,CLOSE,0.9,0),COLORFFCC00;


  STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,3.2,0),COLORBB00FF;


  STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,2.7,0),COLORFF33FF;


  STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,2.1,0),COLORFF66FF;


  STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,1.5,0),COLORFF99FF;


  STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,0.9,0),COLORFFBBFF;


  STICKLINE(CROSS(J,D1)ANDJ<70,CLOSE,OPEN,0.3,0),COLORFFddfF;


  


image.png




[源码注释]通达信公式动态翻译结果

输出XG:50日前的最近50日一直存在收盘价<收盘价的250日简单移动平均






神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论
    神奇指标提问

    求助编写

    神奇指标

    神奇指标

    神奇指标
    关注官方
    抖音号
    神奇指标抖音号