神奇指标网
神奇指标网

通达信万能指标公式

浏览 367次浏览
标签: 涨停
来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15

  



相关简介:  通达信万能指标公式                                


     通达信指标公式源码概况:


  指标类别:通达信指标公式


  授权方式:免费版


  指标评级:★★★★★


  指标分类:策略


  画线方法:副图



经典万能选股技巧,掌握即可在股市常胜不败




通达信指标公式源码:



    AAF:=LLV(LOW,34),LINETHICK1,COLOR0000FF;
    BBF:=MA(AAF,4),LINETHICK1,COLORFF00FF;
    TYP:=(HIGH+LOW+CLOSE)/3;
    CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
    差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
    CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
    差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
    CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
    差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
    CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
    差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
    CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
    差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
    CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
    AAA:=(3*C+H+L+O)/6;
    VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
    +4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
    VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
    VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
    VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
    VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
    VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
    短线:=VAR1,COLORWHITE;
    中线:=VAR6,COLORYELLOW;
    DRAWBAND(短线,RGB(255,255,50),中线,RGB(0,0,220));
    下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN;
    TJ1:=CCI1>差值4;
    立桩量:=FILTER(TJ1,0),NODRAW;
    TJ2:=IF(BARSLAST(立桩量)=1,1,0);
    成立1:=TJ2=1;
    条件成立1:=FILTER(成立1,5);
    TJ11:=CCI1<-差值4;
    立桩量2:=FILTER(TJ11,0),NODRAW;
    TJ22:=IF(BARSLAST(立桩量2)=1ANDCLOSE>REF(HIGH,1),1,
    IF(BARSLAST(立桩量2)=2ANDCLOSE>REF(HIGH,2),1,
    IF(BARSLAST(立桩量2)=3ANDCLOSE>REF(HIGH,3),1,0)));
    TJ:=IF(BARSLAST(立桩量2)=1ANDCLOSE>REF(LOW,1),1,0);
    成立2:=TJ=1;
    条件成立2:=FILTER(成立2,5);
    TJ111:=(ABS(CCI1)>CCIANDABS(差值1)>ABS(差值5))
    OR(VOL=HHV(VOL,10)ANDVOL>2*REF(VOL,1)ANDCLOSE>VAR1);
    立桩量3:=FILTER(TJ111,5);
    TJ3:=IF(BARSLAST(立桩量3)=1ANDCLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量3)=2ANDCLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量3)=3ANDCLOSE>REF(LOW,3),1,0)));
    成立:=TJ3=1;
    条件成立:=FILTER(成立,5);
    DRAWICON(条件成立AND下跌!=VAR6{ANDBB13>0},L*0.97,23);
    LC:=REF(CLOSE,1);
    RSI:=((SMA(MAX((CLOSE-LC),0),3,1)/SMA(ABS((CLOSE-LC)),3,1))*100);
    FF:=EMA(CLOSE,3);
    MA15:=EMA(CLOSE,21);
    DRAWICON(CROSS(FF,MA15),LOW*0.97,23);
    DRAWTEXT(CROSS(88,RSI),(HIGH*1.01),'R背'),COLOR00FF00;
    X1:=(C+L+H)/3;
    BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
    EMA8:=EMA(C,8);
    DRAWTEXT(FILTER(BB13>1ANDEMA(X1,13)>REF(EMA(X1,8),1),10),
    EMA8,'∠'),COLORWHITE;
    超买:MA(C,10)*IF(CAPITAL=0,1.04,1.1),POINTDOT,COLORGREEN,LINETHICK2;
    超卖:MA(C,10)*IF(CAPITAL=0,0.95,0.9),POINTDOT,COLORRED,LINETHICK2;
    上:=EMA(C,3),COLORBLUE,LINETHICK1;
    中:=EMA(C,5),COLORWHITE,LINETHICK1;
    下:=EMA(中,5),COLOR00FF00,LINETHICK1;
    QQ:=C<中;
    MM:=上>REF(上,1)ANDREF(上,1)<REF(上,2);
    V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
    V2:=(1-7/100)*(DMA(CLOSE,V1));
    V3:=(1+7/100)*(DMA(CLOSE,V1));
    V5:=MA((LOW+HIGH+CLOSE)/3,5);
    MA1:=MEMA(CLOSE,5);
    MA2:=ATAN((MA1/REF(MA1,1)-1)*100)*180/3.1416;
    MA3:=IF(MA2>0,MA2,MA2);
    MA5:=MA(CLOSE,5),COLOR888899;
    MA13:=MA(CLOSE,13),COLORFF00F0,LINETHICK2;
    VAR01:=CLOSE=HHV(C,4)AND(REF(C,1)>=REF(C,2)ORREF(C,1)>=REF(C,3))
    ORREF(C,1)=HHV(C,4)ANDCLOSE>=REF(C,2)ORREF(C,2)=HHV(C,4)AND
    REF(C,3)=LLV(C,4)ANDC>=REF(C,1)ORREF(C,3)=HHV(C,4)AND
    C>=REF(C,1)ANDC>=REF(C,2);
    {收盘价=4日内收盘价的最高值AND昨收>=2日前的收盘价}
    VAR02:=CLOSE=HHV(C,4)ANDREF(C,1)=LLV(C,4);
    {收盘价=4日内收盘价的最高值AND昨收=4日内收盘价的最低值}
    VAR03:=CLOSE=LLV(C,4)AND(REF(C,1)<REF(C,2)ORREF(C,1)<REF(C,3))OR
    REF(C,1)=LLV(C,4)ANDC<REF(C,2)ORREF(C,2)=LLV(C,4)AND
    REF(C,1)=HHV(C,4)ANDC<REF(C,1)ORREF(C,3)=LLV(C,4)AND
    C<REF(C,1)ANDC<REF(C,2);
    {收盘价=4日内收盘价的最低值AND(昨收<2日前的收盘价}
    VAR04:=REF(C,1)=LLV(C,4)ANDC>=REF(C,2)ORREF(C,2)=LLV(C,4)AND
    REF(C,1)<=REF(C,3)ANDREF(C,2)<REF(C,4)ANDC>=REF(C,1);
    {昨收=4日内收盘价的最低值AND收盘价>=2日前的收盘价}
    VAR05:=REF(C,1)=HHV(C,4)ANDC<REF(C,2)OR(REF(C,2)=HHV(C,4)AND
    REF(C,1)>REF(C,3)ORREF(C,3)=HHV(C,4)ANDREF(C,1)>REF(C,2))AND
    REF(C,2)>=REF(C,4)ANDC<REF(C,1);
    {昨收=4日内收盘价的最高值AND收盘价<2日前的收盘价}
    VAR06:=V5>REF(V5,1)ANDREF(V5,1)<REF(V5,2);
    {今日V5向上形成拐点}
    VAR07:=LOW<HHV(V5,13)ANDHIGH>HHV(V5,13)ANDCLOSE>REF(C,1)ANDCLOSE>OPEN;
    VAR08:=VAR07ANDCOUNT(VAR06,2);
    VAR09:=100*EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6);
    VAR10:=EMA(MA(C,13),13);
    VAR11:=FILTER((LLV(VAR09,2)=LLV(VAR09,7)ANDCOUNT(VAR09<0,2)AND
    CROSS(VAR09,MA(VAR09,2)))=1,5);
    VAR12:=FILTER((HHV(VAR09,2)=HHV(VAR09,7)ANDCOUNT(VAR09>50,2)AND
    CROSS(MA(VAR09,2),VAR09))=1,1);
    VAR13:=SMA(EMA((C-REF(C,1))/REF(C,1),5)*100,3,1)*10;
    VAR14:=FILTER(((CROSS(VAR13,0)ORCROSS(C,VAR10))ANDVAR11)=1,3);
    VAR15:=MA(C,18)>=REF(MA(C,18),3)ANDCROSS(C,MA(C,18));
    VAR16:=VAR08ANDNOT(REF(VAR08,1));
    RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
    K:=SMA(RSV,3,1);
    D:=SMA(K,3,1);
    J:=3*K-2*D;
    金叉:=CROSS(J,D);
    死叉:=CROSS(D,J);
    买1:=(VAR14ORVAR15)ANDVAR11;
    买2:=(VAR14ORVAR15)ANDVAR4;
    买3:=(VAR14ORVAR15)ANDVAR2;
    买4:=(VAR2ANDVAR11)OR(VAR4ANDVAR11);
    买5:=(金叉ANDVAR04)OR(金叉ANDVAR02)OR(金叉ANDVAR11);
    {涨停}
    STICKLINE(CLOSE>REF(CLOSE,1)*1.0985ANDCLOSE=HIGH,CLOSE,OPEN,4,-1),
    COLOR00FFFF;
    {跌停}
    STICKLINE(CLOSE<REF(CLOSE,1)*0.9015ANDCLOSE=LOW,CLOSE,OPEN,4,-1),
    COLORGREEN;
    {蓝}
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3.3,0),COLORFF6600;
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.4,0),COLORFF8800;
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.3,0),COLORFFAA00;
    STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,0.6,0),COLORFFCC00;
    {红}
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3.3,0),COLOR000099;
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.4,0),COLOR0000BB;
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1.3,0),COLOR0000DD;
    STICKLINE(CLOSE>OPEN,CLOSE,OPEN,0.5,0),COLOR0000FF;
    {绿}
    STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,3.3,0),COLOR009900;
    STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,2.4,0),COLOR00BB00;
    STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,1.3,0),COLOR00DD00;
    STICKLINE(VAR03,OPEN,(OPEN+CLOSE)/2,0.5,0),COLOR00FF00;
    {灰}
    STICKLINE(VAR04ANDMM,OPEN,(OPEN+CLOSE)/2,3.3,0),COLOR999999;
    STICKLINE(VAR04ANDMM,OPEN,(OPEN+CLOSE)/2,2.2,0),COLORBBBBBB;
    STICKLINE(VAR04ANDMM,OPEN,(OPEN+CLOSE)/2,1.3,0),COLORDDDDDD;
    STICKLINE(VAR04ANDMM,OPEN,(OPEN+CLOSE)/2,0.5,0),COLORFFFFFF;
    STICKLINE(金叉,OPEN,CLOSE,0.5,0),COLORYELLOW;
    STICKLINE(死叉,OPEN,CLOSE,0.5,0),COLOR000066;
    DRAWICON(VAR16,LOW-0.02,15);
    DRAWICON(买1OR买2OR买3OR买4OR买5ANDMM,LOW-0.05,23);
    DRAWICON(死叉ORCROSS(50,VAR09)ANDQQANDK>50,HIGH+0.01,2);
    TTJ:=CROSS(FF,MA15);
    TTJ0:=VAR16;
    TTJ1:=买1OR买2OR买3OR买4OR买5ANDMM;
    XG0:=TTJANDTTJ0;
    XG1:=TTJANDTTJ1;
    XG:=XG0ORXG1;
    DRAWTEXT(XG,LOW*0.93,'全'),COLORRED;
    DRAWTEXT(XG,LOW*0.93-0.3,'仓'),COLORRED;
    GET:ZIG(3,3),COLORYELLOW;
    PL5:=ZIG(3,5);
    EN1:=ZIG(3,5)>REF(ZIG(3,5),1)ANDREF(ZIG(3,5),1)<=REF(ZIG(3,5),2)ANDREF(ZIG(3,5),2)<=REF(ZIG(3,5),3);
    EX1:=ZIG(3,5)<REF(ZIG(3,5),1)ANDREF(ZIG(3,5),1)>=REF(ZIG(3,5),2)ANDREF(ZIG(3,5),2)>=REF(ZIG(3,5),3);
    PL10:=ZIG(3,10);
    EN2:=ZIG(3,10)>REF(ZIG(3,10),1)ANDREF(ZIG(3,10),1)<=REF(ZIG(3,10),2)ANDREF(ZIG(3,10),2)<=REF(ZIG(3,10),3);
    EX2:=ZIG(3,10)<REF(ZIG(3,10),1)ANDREF(ZIG(3,10),1)>=REF(ZIG(3,10),2)ANDREF(ZIG(3,10),2)>=REF(ZIG(3,10),3);
    PL20:=ZIG(3,20);
    EN3:=ZIG(3,20)>REF(ZIG(3,20),1)ANDREF(ZIG(3,20),1)<=REF(ZIG(3,20),2)ANDREF(ZIG(3,20),2)<=REF(ZIG(3,20),3);
    EX3:=ZIG(3,20)<REF(ZIG(3,20),1)ANDREF(ZIG(3,20),1)>=REF(ZIG(3,20),2)ANDREF(ZIG(3,20),2)>=REF(ZIG(3,20),3);
    PL40:=ZIG(3,40);
    走强1:=BARSLAST(PL5<REF(PL5,1));
    走弱1:=BARSLAST(PL5>REF(PL5,1));
    走强2:=BARSLAST(PL10<REF(PL10,1));
    走弱2:=BARSLAST(PL10>REF(PL10,1));
    走强3:=BARSLAST(PL20<REF(PL20,1));
    走弱3:=BARSLAST(PL20>REF(PL20,1));
    ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0);
    ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0);
    DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0);
    DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0);
    ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0);
    ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0);
    DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0);
    DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0);
    DRAWTEXT(EN1ANDDTJZ5=1,L*0.98,'(A)'),COLORFFFF00;
    DRAWTEXT(EX1ANDDTJD5=2,H*1.02,'(B)'),COLORFF00FF;
    DRAWTEXT(EN2ANDZTJZ5=1,L*0.98,'(C)'),COLOR0000FF;
    DRAWTEXT(EX1ANDPL10>REF(PL10,1)ANDZTJD5=1,H*1.02,'⑴'),COLOR0000FF;
    DRAWTEXT(EN1ANDPL10>REF(PL10,1)ANDZTJZ5=2,L*0.98,'⑵'),COLOR0000FF;
    DRAWTEXT(EX1ANDPL10>REF(PL10,1)ANDZTJZ5=2,H*1.02,'⑶'),COLOR0000FF;
    DRAWTEXT(EN1ANDPL10>REF(PL10,1)ANDZTJZ5=3,L*0.98,'⑷'),COLOR0000FF;
    DRAWTEXT(EX2ANDPL20>REF(PL20,1)ANDZTJD10=1,H*1.02,'⑸'),COLOR0000FF;
    DRAWTEXT(EN2ANDDTJZ10=1,L*0.93,'Ⅰ'),COLORFF00FF;
    DRAWTEXT(EX2ANDDTJD10=2,H*1.05,'Ⅱ'),COLORFFFF00;
    DRAWTEXT(EN3ANDZTJZ10=1,L*0.93,'Ⅲ'),COLOR0000FF;
    DRAWTEXT(EX2ANDPL20>REF(PL20,1)ANDZTJD10=1,H*1.03,'①'),LINETHICK3,COLOR00FFFF;
    DRAWTEXT(EN2ANDPL20>REF(PL20,1)ANDZTJZ10=2,L*0.95,'②'),LINETHICK3,COLOR00FFFF;
    DRAWTEXT(EX2ANDPL20>REF(PL20,1)ANDZTJD10=2OR(ZTJD10=0ORZTJD10=2)
    ANDEX2,H*1.03,'③'),LINETHICK3,COLOR00FFFF;
    DRAWTEXT(EN2ANDPL20>REF(PL20,1)ANDZTJZ10=3,L*0.95,'④'),LINETHICK3,COLOR00FFFF;
    KK0:DRAwrECTREL(993,2,0,0,0);
    KK1:DRAWRECTREL(993,102,0,100,0);
    KK2:DRAWRECTREL(993,202,0,200,0);
    KK3:DRAWRECTREL(993,302,0,300,0);
    KK4:DRAWRECTREL(993,402,0,400,0);
    KK5:DRAWRECTREL(993,502,0,500,0);
    KK6:DRAWRECTREL(993,602,0,600,0);
    KK7:DRAWRECTREL(993,702,0,700,0);
    KK8:DRAWRECTREL(993,802,0,800,0);
    KK9:DRAWRECTREL(993,902,0,900,0);
    KK10:DRAWRECTREL(993,998,0,999,0);
    JJ1:DRAWRECTREL(49,993,50,0,0);
    JJ2:DRAWRECTREL(99,993,100,0,0);
    JJ3:DRAWRECTREL(149,993,150,0,0);
    JJ4:DRAWRECTREL(199,993,200,0,0);
    JJ5:DRAWRECTREL(249,993,250,0,0);
    JJ6:DRAWRECTREL(299,993,300,0,0);
    JJ7:DRAWRECTREL(349,993,350,0,0);
    JJ8:DRAWRECTREL(399,993,400,0,0);
    JJ9:DRAWRECTREL(449,993,450,0,0);
    JJ10:DRAWRECTREL(499,993,500,0,0);
    JJ11:DRAWRECTREL(549,993,550,0,0);
    JJ12:DRAWRECTREL(599,993,600,0,0);
    JJ13:DRAWRECTREL(649,993,650,0,0);
    JJ14:DRAWRECTREL(699,993,700,0,0);
    JJ15:DRAWRECTREL(749,993,750,0,0);
    JJ16:DRAWRECTREL(799,993,800,0,0);
    JJ17:DRAWRECTREL(849,993,850,0,0);
    JJ18:DRAWRECTREL(899,993,900,0,0);
    JJ19:DRAWRECTREL(949,993,950,0,0);
    JJ20:DRAWRECTREL(998,993,999,0,0);





[源码注释]通达信公式动态翻译结果


   AAF赋值:34日内最低价的最低值,线宽为1,COLOR0000FF

   BBF赋值:AAF的4日简单移动平均,线宽为1,COLORFF00FF

   TYP赋值:(最高价+最低价+收盘价)/3

   CCI1赋值:(TYP-TYP的6日简单移动平均)/(0.015*TYP的5日平均绝对偏差)

   差值1赋值:1日前的CCI1-CCI1的绝对值,线宽为0

   CCI2赋值:(TYP-TYP的10日简单移动平均)/(0.015*TYP的10日平均绝对偏差)

   差值2赋值:1日前的CCI2-CCI2的绝对值,线宽为0

   CCI3赋值:(TYP-TYP的20日简单移动平均)/(0.015*TYP的20日平均绝对偏差)

   差值3赋值:1日前的CCI3-CCI3的绝对值,线宽为0

   CCI4赋值:(TYP-TYP的30日简单移动平均)/(0.015*TYP的30日平均绝对偏差)

   差值4赋值:1日前的CCI4-CCI4的绝对值,线宽为0

   CCI5赋值:(TYP-TYP的60日简单移动平均)/(0.015*TYP的60日平均绝对偏差)

   差值5赋值:1日前的CCI5-CCI5的绝对值,线宽为0

   CCI赋值:CCI1+CCI2+CCI3+CCI4+CCI5

   AAA赋值:(3*收盘价+最高价+最低价+开盘价)/6

   VAR1赋值:(8*AAA+7*1日前的AAA+6*2日前的AAA+5*3日前的AAA

   +4*4日前的AAA+3*5日前的AAA+2*6日前的AAA+8日前的AAA)/36

   VAR2赋值:(5日内VAR1的最高值+10日内VAR1的最高值+20日内VAR1的最高值)/3

   VAR3赋值:(5日内VAR1的最低值+10日内VAR1的最低值+20日内VAR1的最低值)/3

   VAR4赋值:(5日内VAR2的最高值+10日内VAR2的最高值+20日内VAR2的最高值)/3

   VAR5赋值:(5日内VAR3的最低值+10日内VAR3的最低值+20日内VAR3的最低值)/3

   VAR6赋值:(2日内VAR1的最低值+4日内VAR1的最低值+6日内VAR1的最低值)/3

   短线赋值:VAR1,画白色

   中线赋值:VAR6,画黄色

   画带状线

   输出

   下跌:如果VAR1=VAR6,返回VAR6,否则返回无效数,画绿色

   TJ1赋值:CCI1>

   差值4

   立桩量赋值:TJ1的历史过滤,NODRAW

   TJ2赋值:如果上次立桩量距今天数=1,返回1,否则返回0

   成立1赋值:TJ2=1

   条件成立1赋值:成立1的5日过滤

   TJ11赋值:CCI1<

   -差值4

   立桩量2赋值:TJ11的历史过滤,NODRAW

   TJ22赋值:如果上次立桩量2距今天数=1ANDCLOSE>,返回?,否则返回?

   1日前的最高价,1,

   如果上次立桩量2距今天数=2ANDCLOSE>,返回?,否则返回?

   2日前的最高价,1,

   如果上次立桩量2距今天数=3ANDCLOSE>,返回?,否则返回?

   3日前的最高价,1,0)))

   TJ赋值:如果上次立桩量2距今天数=1ANDCLOSE>,返回?,否则返回?

   1日前的最低价,1,0)

   成立2赋值:TJ=1

   条件成立2赋值:成立2的5日过滤

   TJ111赋值:(CCI1的绝对值>

   CCIANDABS(差值1)>

   差值5的绝对值)

   OR(成交量(手)=10日内成交量(手)的最高值ANDVOL>

   2*1日前的成交量(手)ANDCLOSE>

   VAR1)

   立桩量3赋值:TJ111的5日过滤

   TJ3赋值:如果上次立桩量3距今天数=1ANDCLOSE>,返回?,否则返回?

   1日前的最低价,1,如果上次立桩量3距今天数=2ANDCLOSE>,返回?,否则返回?

   2日前的最低价,1,如果上次立桩量3距今天数=3ANDCLOSE>,返回?,否则返回?

   3日前的最低价,1,0)))

   成立赋值:TJ3=1

   条件成立赋值:成立的5日过滤

   当满足条件条件成立AND下跌不等于VAR6时,在最低价*0.97位置画23号图标

   LC赋值:1日前的收盘价

   RSI赋值:(((收盘价-LC)和0的较大值的3日[1日权重]移动平均/(收盘价-LC)的绝对值的3日[1日权重]移动平均)*100)

   FF赋值:收盘价的3日指数移动平均

   MA15赋值:收盘价的21日指数移动平均

   当满足条件FF上穿MA15时,在最低价*0.97位置画23号图标

   当满足条件88上穿RSI时,在(最高价*1.01)位置书写文字,COLOR00FF00

   X1赋值:(收盘价+最低价+最高价)/3

   BB13赋值:X1的13日指数移动平均-1日前的X1的13日指数移动平均的反正切*3.1416*10

   EMA8赋值:收盘价的8日指数移动平均

   当满足条件BB13>的?日过滤时,在?位置书写文字

   1ANDEMA(X1,13)>

   1日前的X1的8日指数移动平均,10),

   EMA8,'∠'),画白色

   输出

   超买:收盘价的10日简单移动平均*如果当前流通股本(手)=0,返回1.04,否则返回1.1,POINTDOT,画绿色,线宽为2

   输出

   超卖:收盘价的10日简单移动平均*如果当前流通股本(手)=0,返回0.95,否则返回0.9,POINTDOT,画红色,线宽为2

   上赋值:收盘价的3日指数移动平均,画蓝色,线宽为1

   中赋值:收盘价的5日指数移动平均,画白色,线宽为1

   下赋值:中的5日指数移动平均,COLOR00FF00,线宽为1

   QQ赋值:收盘价<

   中

   MM赋值:上>

   1日前的上ANDREF(上,1)<

   2日前的上

   V1赋值:(2*收盘价+最高价+最低价)/4-收盘价的20日简单移动平均的绝对值/收盘价的20日简单移动平均

   V2赋值:(1-7/100)*(以V1为权重收盘价的动态移动平均)

   V3赋值:(1+7/100)*(以V1为权重收盘价的动态移动平均)

   V5赋值:(最低价+最高价+收盘价)/3的5日简单移动平均

   MA1赋值:收盘价的5日平滑移动平均

   MA2赋值:(MA1/1日前的MA1-1)*100的反正切*180/3.1416

   MA3赋值:如果MA2>,返回?,否则返回?

   0,MA2,MA2)

   MA5赋值:收盘价的5日简单移动平均,COLOR888899

   MA13赋值:收盘价的13日简单移动平均,COLORFF00F0,线宽为2

   VAR01赋值:收盘价=4日内收盘价的最高值AND(1日前的收盘价>

   =2日前的收盘价ORREF(收盘价,1)>

   =3日前的收盘价)

   ORREF(收盘价,1)=4日内收盘价的最高值ANDCLOSE>

   =2日前的收盘价ORREF(收盘价,2)=4日内收盘价的最高值AND

   3日前的收盘价=4日内收盘价的最低值ANDC>

   =1日前的收盘价ORREF(收盘价,3)=4日内收盘价的最高值AND

   收盘价>

   =1日前的收盘价ANDC>

   =2日前的收盘价

   VAR02赋值:收盘价=4日内收盘价的最高值ANDREF(收盘价,1)=4日内收盘价的最低值

   VAR03赋值:收盘价=4日内收盘价的最低值AND(1日前的收盘价<

   2日前的收盘价ORREF(收盘价,1)<

   3日前的收盘价)OR

   1日前的收盘价=4日内收盘价的最低值ANDC<

   2日前的收盘价ORREF(收盘价,2)=4日内收盘价的最低值AND

   1日前的收盘价=4日内收盘价的最高值ANDC<

   1日前的收盘价ORREF(收盘价,3)=4日内收盘价的最低值AND

   收盘价<

   1日前的收盘价ANDC<

   2日前的收盘价

   VAR04赋值:1日前的收盘价=4日内收盘价的最低值ANDC>

   =2日前的收盘价ORREF(收盘价,2)=4日内收盘价的最低值AND

   1日前的收盘价<

   =3日前的收盘价ANDREF(收盘价,2)<

   4日前的收盘价ANDC>

   =1日前的收盘价

   VAR05赋值:1日前的收盘价=4日内收盘价的最高值ANDC<

   2日前的收盘价OR(2日前的收盘价=4日内收盘价的最高值AND

   1日前的收盘价>

   3日前的收盘价ORREF(收盘价,3)=4日内收盘价的最高值ANDREF(收盘价,1)>

   2日前的收盘价)AND

   2日前的收盘价>

   =4日前的收盘价ANDC<

   1日前的收盘价

   VAR06赋值:V5>

   1日前的V5ANDREF(V5,1)<

   2日前的V5

   VAR07赋值:最低价<

   13日内V5的最高值ANDHIGH>

   13日内V5的最高值ANDCLOSE>

   1日前的收盘价ANDCLOSE>

   开盘价

   VAR08赋值:VAR07ANDCOUNT(VAR06,2)

   VAR09赋值:100*收盘价-1日前的收盘价的6日指数移动平均的6日指数移动平均/收盘价-1日前的收盘价的绝对值的6日指数移动平均的6日指数移动平均

   VAR10赋值:收盘价的13日简单移动平均的13日指数移动平均

   VAR11赋值:(2日内VAR09的最低值=7日内VAR09的最低值ANDCOUNT(VAR09<的?日过滤

   0,2)AND

   VAR09上穿VAR09的2日简单移动平均)=1,5)

   VAR12赋值:(2日内VAR09的最高值=7日内VAR09的最高值ANDCOUNT(VAR09>的?日过滤

   50,2)AND

   VAR09的2日简单移动平均上穿VAR09)=1,1)

   VAR13赋值:(收盘价-1日前的收盘价)/1日前的收盘价的5日指数移动平均*100的3日[1日权重]移动平均*10

   VAR14赋值:((VAR13上穿0ORCROSS(收盘价,VAR10))ANDVAR11)=1的3日过滤

   VAR15赋值:收盘价的18日简单移动平均>

   =3日前的收盘价的18日简单移动平均ANDCROSS(收盘价,收盘价的18日简单移动平均)

   VAR16赋值:VAR08ANDNOT(1日前的VAR08)

   RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100

   K赋值:RSV的3日[1日权重]移动平均

   D赋值:K的3日[1日权重]移动平均

   J赋值:3*K-2*D

   金叉赋值:J上穿D

   死叉赋值:D上穿J

   买1赋值:(VAR14ORVAR15)ANDVAR11

   买2赋值:(VAR14ORVAR15)ANDVAR4

   买3赋值:(VAR14ORVAR15)ANDVAR2

   买4赋值:(VAR2ANDVAR11)OR(VAR4ANDVAR11)

   买5赋值:(金叉ANDVAR04)OR(金叉ANDVAR02)OR(金叉ANDVAR11)

   当满足条件收盘价>时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.

   1日前的收盘价*1.0985ANDCLOSE=最高价,收盘价,开盘价,4,-1),

   COLOR00FFFF

   当满足条件收盘价<时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.

   1日前的收盘价*0.9015ANDCLOSE=最低价,收盘价,开盘价,4,-1),

   画绿色

   当满足条件开盘价>时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.

   =收盘价,收盘价,开盘价,3.3,0),COLORFF6600

   当满足条件开盘价>时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.

   =收盘价,收盘价,开盘价,2.4,0),COLORFF8800

   当满足条件开盘价>时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.

   =收盘价,收盘价,开盘价,1.3,0),COLORFFAA00

   当满足条件开盘价>时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.

   =收盘价,收盘价,开盘价,0.6,0),COLORFFCC00

   当满足条件收盘价>时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.

   开盘价,收盘价,开盘价,3.3,0),COLOR000099

   当满足条件收盘价>时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.

   开盘价,收盘价,开盘价,2.4,0),COLOR0000BB

   当满足条件收盘价>时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.

   开盘价,收盘价,开盘价,1.3,0),COLOR0000DD

   当满足条件收盘价>时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.

   开盘价,收盘价,开盘价,0.5,0),COLOR0000FF

   当满足条件VAR03时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3.3,0不为0则画空心柱.,COLOR009900

   当满足条件VAR03时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为2.4,0不为0则画空心柱.,COLOR00BB00

   当满足条件VAR03时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,COLOR00DD00

   当满足条件VAR03时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR00FF00

   当满足条件VAR04ANDMM时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为3.3,0不为0则画空心柱.,COLOR999999

   当满足条件VAR04ANDMM时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为2.2,0不为0则画空心柱.,COLORBBBBBB

   当满足条件VAR04ANDMM时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为1.3,0不为0则画空心柱.,COLORDDDDDD

   当满足条件VAR04ANDMM时,在开盘价和(开盘价+收盘价)/2位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLORFFFFFF

   当满足条件金叉时,在开盘价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,画黄色

   当满足条件死叉时,在开盘价和收盘价位置之间画柱状线,宽度为0.5,0不为0则画空心柱.,COLOR000066

   当满足条件VAR16时,在最低价-0.02位置画15号图标

   当满足条件买1OR买2OR买3OR买4OR买5ANDMM时,在最低价-0.05位置画23号图标

   当满足条件死叉ORCROSS(50,VAR09)ANDQQANDK>时,在?位置画?号图标

   50,最高价+0.01,2)

   TTJ赋值:FF上穿MA15

   TTJ0赋值:VAR16

   TTJ1赋值:买1OR买2OR买3OR买4OR买5ANDMM

   XG0赋值:TTJANDTTJ0

   XG1赋值:TTJANDTTJ1

   XG赋值:XG0ORXG1

   当满足条件XG时,在最低价*0.93位置书写文字,画红色

   当满足条件XG时,在最低价*0.93-0.3位置书写文字,画红色

   输出

   GET:收盘价3%的之字转向,画黄色

   PL5赋值:收盘价5%的之字转向

   EN1赋值:收盘价5%的之字转向>

   1日前的收盘价5%的之字转向ANDREF(收盘价5%的之字转向,1)<

   =2日前的收盘价5%的之字转向ANDREF(收盘价5%的之字转向,2)<

   =3日前的收盘价5%的之字转向

   EX1赋值:收盘价5%的之字转向<

   1日前的收盘价5%的之字转向ANDREF(收盘价5%的之字转向,1)>

   =2日前的收盘价5%的之字转向ANDREF(收盘价5%的之字转向,2)>

   =3日前的收盘价5%的之字转向

   PL10赋值:收盘价10%的之字转向

   EN2赋值:收盘价10%的之字转向>

   1日前的收盘价10%的之字转向ANDREF(收盘价10%的之字转向,1)<

   =2日前的收盘价10%的之字转向ANDREF(收盘价10%的之字转向,2)<

   =3日前的收盘价10%的之字转向

   EX2赋值:收盘价10%的之字转向<

   1日前的收盘价10%的之字转向ANDREF(收盘价10%的之字转向,1)>

   =2日前的收盘价10%的之字转向ANDREF(收盘价10%的之字转向,2)>

   =3日前的收盘价10%的之字转向

   PL20赋值:收盘价20%的之字转向

   EN3赋值:收盘价20%的之字转向>

   1日前的收盘价20%的之字转向ANDREF(收盘价20%的之字转向,1)<

   =2日前的收盘价20%的之字转向ANDREF(收盘价20%的之字转向,2)<

   =3日前的收盘价20%的之字转向

   EX3赋值:收盘价20%的之字转向<

   1日前的收盘价20%的之字转向ANDREF(收盘价20%的之字转向,1)>

   =2日前的收盘价20%的之字转向ANDREF(收盘价20%的之字转向,2)>

   =3日前的收盘价20%的之字转向

   PL40赋值:收盘价40%的之字转向

   走强1赋值:上次PL5<距今天数

   1日前的PL5)

   走弱1赋值:上次PL5>距今天数

   1日前的PL5)

   走强2赋值:上次PL10<距今天数

   1日前的PL10)

   走弱2赋值:上次PL10>距今天数

   1日前的PL10)

   走强3赋值:上次PL20<距今天数

   1日前的PL20)

   走弱3赋值:上次PL20>距今天数

   1日前的PL20)

   ZTJZ5赋值:如果PL10>,返回?,否则返回?

   1日前的PL10,统计走强2日中满足EN1的天数,0)

   ZTJD5赋值:如果PL10>,返回?,否则返回?

   1日前的PL10,统计走强2日中满足EX1的天数,0)

   DTJZ5赋值:如果PL10<,返回?,否则返回?

   1日前的PL10,统计走弱2日中满足EN1的天数,0)

   DTJD5赋值:如果PL10<,返回?,否则返回?

   1日前的PL10,统计走弱2日中满足EX1的天数,0)

   ZTJZ10赋值:如果PL20>,返回?,否则返回?

   1日前的PL20,统计走强3日中满足EN2的天数,0)

   ZTJD10赋值:如果PL20>,返回?,否则返回?

   1日前的PL20,统计走强3日中满足EX2的天数,0)

   DTJZ10赋值:如果PL20<,返回?,否则返回?

   1日前的PL20,统计走弱3日中满足EN2的天数,0)

   DTJD10赋值:如果PL20<,返回?,否则返回?

   1日前的PL20,统计走弱3日中满足EX2的天数,0)

   当满足条件EN1ANDDTJZ5=1时,在最低价*0.98位置书写文字,COLORFFFF00

   当满足条件EX1ANDDTJD5=2时,在最高价*1.02位置书写文字,COLORFF00FF

   当满足条件EN2ANDZTJZ5=1时,在最低价*0.98位置书写文字,COLOR0000FF

   当满足条件EX1ANDPL10>时,在?位置书写文字

   1日前的PL10ANDZTJD5=1,最高价*1.02,'⑴'),COLOR0000FF

   当满足条件EN1ANDPL10>时,在?位置书写文字

   1日前的PL10ANDZTJZ5=2,最低价*0.98,'⑵'),COLOR0000FF

   当满足条件EX1ANDPL10>时,在?位置书写文字

   1日前的PL10ANDZTJZ5=2,最高价*1.02,'⑶'),COLOR0000FF

   当满足条件EN1ANDPL10>时,在?位置书写文字

   1日前的PL10ANDZTJZ5=3,最低价*0.98,'⑷'),COLOR0000FF

   当满足条件EX2ANDPL20>时,在?位置书写文字

   1日前的PL20ANDZTJD10=1,最高价*1.02,'⑸'),COLOR0000FF

   当满足条件EN2ANDDTJZ10=1时,在最低价*0.93位置书写文字,COLORFF00FF

   当满足条件EX2ANDDTJD10=2时,在最高价*1.05位置书写文字,COLORFFFF00

   当满足条件EN3ANDZTJZ10=1时,在最低价*0.93位置书写文字,COLOR0000FF

   当满足条件EX2ANDPL20>时,在?位置书写文字

   1日前的PL20ANDZTJD10=1,最高价*1.03,'①'),线宽为3,COLOR00FFFF

   当满足条件EN2ANDPL20>时,在?位置书写文字

   1日前的PL20ANDZTJZ10=2,最低价*0.95,'②'),线宽为3,COLOR00FFFF

   当满足条件EX2ANDPL20>时,在?位置书写文字

   1日前的PL20ANDZTJD10=2OR(ZTJD10=0ORZTJD10=2)

   ANDEX2,最高价*1.03,'③'),线宽为3,COLOR00FFFF

   当满足条件EN2ANDPL20>时,在?位置书写文字

   1日前的PL20ANDZTJZ10=3,最低价*0.95,'④'),线宽为3,COLOR00FFFF

   输出

   KK0:相对位置上画矩形

   输出

   KK1:相对位置上画矩形

   输出

   KK2:相对位置上画矩形

   输出

   KK3:相对位置上画矩形

   输出

   KK4:相对位置上画矩形

   输出

   KK5:相对位置上画矩形

   输出

   KK6:相对位置上画矩形

   输出

   KK7:相对位置上画矩形

   输出

   KK8:相对位置上画矩形

   输出

   KK9:相对位置上画矩形

   输出

   KK10:相对位置上画矩形

   输出

   JJ1:相对位置上画矩形

   输出

   JJ2:相对位置上画矩形

   输出

   JJ3:相对位置上画矩形

   输出

   JJ4:相对位置上画矩形

   输出

   JJ5:相对位置上画矩形

   输出

   JJ6:相对位置上画矩形

   输出

   JJ7:相对位置上画矩形

   输出

   JJ8:相对位置上画矩形

   输出

   JJ9:相对位置上画矩形

   输出

   JJ10:相对位置上画矩形

   输出

   JJ11:相对位置上画矩形

   输出

   JJ12:相对位置上画矩形

   输出

   JJ13:相对位置上画矩形

   输出

   JJ14:相对位置上画矩形

   输出

   JJ15:相对位置上画矩形

   输出

   JJ16:相对位置上画矩形

   输出

   JJ17:相对位置上画矩形

   输出

   JJ18:相对位置上画矩形

   输出

   JJ19:相对位置上画矩形

   输出

   JJ20:相对位置上画矩形


神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论