神奇指标网
神奇指标网

发家分时抓涨停指标公式

浏览 306次浏览 来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15

  



相关简介:发家分时涨停指标公式                                  


     通达信指标公式源码概况:


  指标类别:通达信指标公式


  授权方式:免费版


  指标评级:★★★★★


  指标分类:策略


  画线方法:副图



天天涨停(信号极少,准确极高)短线打板必备

早盘信号出现必买 涨幅大于5%时观望不追高 st除外




通达信指标公式源码:



    MA5:MA(CLOSE,5),LINETHICK1,COLORFFFFFF;
    MA10:MA(CLOSE,10),LINETHICK1,COLOR00FFFF;
    MA30:MA(CLOSE,30),LINETHICK1,COLORFF00FF;
    MA60:MA(CLOSE,60),LINETHICK1,COLOR0000FF;
    MA120:MA(CLOSE,120),LINETHICK1,COLORFFFF00;
    DRAWTEXT(CROSS(EMA(CLOSE,2),EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42)),(LOW*0.99),'Ψ'),LINETHICK3,COLORF00FF0;
    DRAWTEXT(CROSS(EMA(((SLOPE(CLOSE,21)*20)+CLOSE),42),EMA(CLOSE,2)),(HIGH*1.01),'◎'),LINETHICK3,COLORFFFFFF;
    多空:=(MA(LOW,6)+MA(LOW,13)+MA(LOW,26))/3;
    {STICKLINE(CLOSE<多空,OPEN,CLOSE,1,0),COLORBLUE;
    STICKLINE(CLOSE>=多空ANDCLOSE>=MA(CLOSE,3),OPEN,CLOSE,1,0),COLORYELLOW;}
    VAR22:=(100-((90*(HHV(HIGH,30)-CLOSE))/(HHV(HIGH,30)-LLV(LOW,30))));
    VAR33:=(100-((90*(HHV(HIGH,120)-CLOSE))/(HHV(HIGH,120)-LLV(LOW,120))));
    VAR11:=(100-((90*(HHV(HIGH,6)-CLOSE))/(HHV(HIGH,6)-LLV(LOW,6))));
    短顶预警:=CROSS(VAR11,95);
    短底预报:=CROSS(15,VAR11);
    TJ1:=短底预报;
    TJ2:=REF(TJ1,1)ANDCLOSE>MA(CLOSE,3);
    TJ4:=VAR11>15ANDREF(CLOSE,1)<REF(MA(CLOSE,3),1)ANDCLOSE>MA(CLOSE,3)ANDCLOSE<MA(CLOSE,13);
    TJ5:=短顶预警;
    相对高位:=IF(HIGH=HHV(HIGH,5),HIGH=HHV(HIGH,5),CLOSE=HHV(CLOSE,5));
    相对低位:=IF(LOW=LLV(LOW,5),LOW=LLV(LOW,5),CLOSE=LLV(CLOSE,5));
    TJ6:=(REF(相对低位,1)ORREF(相对低位,2));
    TJ7:=(REF(相对高位,1)ORREF(相对高位,2));
    DRAWTEXT(TJ6ANDREF(CLOSE,1)<REF(MA(CLOSE,3),1)ANDCLOSE>MA(CLOSE,3)ANDCLOSE>=多空,LOW-0.4,'全仓买入'),COLORRED;
    DRAWTEXT(TJ7ANDREF(CLOSE,1)>REF(MA(CLOSE,3),1)ANDCLOSE<MA(CLOSE,3)ANDCLOSE>=多空ANDCLOSE<OPEN,HIGH+0.4,'减仓2/3'),COLORGREEN;
    DRAWTEXT(TJ1,LOW-0.6,'准备'),COLORYELLOW;
    DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIFF,9);
    MACD:=2*(DIFF-DEA);
    MACD1:=CROSS(DIFF,DEA)ANDCOUNT(MACD>0,1)=1;
    RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
    K:=SMA(RSV,9,1);
    D:=SMA(K,9,1);
    J:=3*K-2*D;
    KDJ1:=CROSS(K,D)ANDCROSS(J,D);
    均线:=CROSS(MA(C,5),MA(C,10));
    量线:=CROSS(MA(V,5),MA(V,10));
    SCC:=MACD1ANDKDJ1AND均线AND量线;
    SC1:=MACD1ANDKDJ1;
    SC2:=均线AND量线;
    SC3:=均线ANDMACD1;
    SC4:=量线ANDKDJ1;
    SC5:=均线ANDKDJ1;
    SC6:=MACD1AND量线;
    DRAWICON(SC1ORSC2ORSC3ORSC4ORSC5ORSC6,L-0.20,9);{两个以上指标同时金叉显示9号图标}
    DRAWICON(SCC,L-0.20,1);{四个指标同时金叉显示3号图标,便于区别};
    T31:=BArslAst(TIME2=093100);
    T40:=BARSLAST(TIME2=093500);
    T41:=BARSLAST(TIME2=093600);
    T50:=BARSLAST(TIME2=094000);
    T51:=BARSLAST(TIME2=094100);
    T60:=BARSLAST(TIME2=094500);
    C31:=REF(C,T40);
    O31:=REF(C,T31);
    C40:=REF(C,T50);
    O40:=REF(C,T41);
    C50:=REF(C,T60);
    O50:=REF(C,T51);
    A1:=C31>O31ANDC40>O40ANDC50>O50ANDO40>=C31ANDO50>=C40;
    A2:=C31<O31ANDC40<O40ANDC50<O50ANDO40<=C31ANDO50<=C40;
    A3:=C31>O31ANDC40>O40ANDC50<O50ANDC50<C40ANDO50/C50<C40/O40ANDO50/C50<C31/O31;
    A4:=C31>O31ANDC40<O40ANDC50<O50ANDC40<C31ANDC50<C40ANDC31/O31<O40/C40ANDC31/O31<O50/C50;
    A5:=C31<O31ANDC40<O40ANDC50>O50ANDC40<C31ANDO50>=C40;
    A6:=C31<O31ANDC40>O40ANDC50>O50ANDC40>C31ANDC50>C40ANDO31/C31<C40/O40ANDO31/C31<C50/O50;
    A7:=C31>O31ANDC40<O40ANDC50>O50ANDC31/O31>O40/C40ANDC50/O50>O40/C40;
    A8:=C31<O31ANDC40>O40ANDC50<O50ANDC40/O40<O31/C31ANDC40/O40<O50/C50;
    A9:=maX(C31,O31)>=MAX(C40,O40)ANDMAX(C31,O31)>=MAX(C50,O50);
    A10:=MIN(C31,O31)<=MIN(C40,O40)ANDMIN(C31,O31)<=MIN(C50,O50);
    B1:='连续三上、三阳开泰、飚涨走势可能涨停、量大出货否则守仓、大阳、盯量';
    B2:='连续三下、三只乌鸦、重挫走势可能跌停、只要反弹立即出货、大阴、随逃';
    B3:='二上一下、二阳一小阴、震荡走势后势看好、逢高减磅逢低吸纳、中阳、阴须小';
    B4:='一上二下、二只乌鸦、拉高出货后市看坏、逢高减磅后市下跌、中阴、阳线小';
    B5:='二下一上、二阴一阳、急跌控底后市不明、逢高减磅观望为主、下影阴、阳大小';
    B6:='一下二上、一阴二阳、震荡控底后市趋好、观望为主谨慎吸纳、下影阳、阴大小';
    B7:='一上一下、二阳夹一阴、震荡走市后市看好、持股待涨逢低吸纳、中阳、阴须小再一上';
    B8:='一下一上、二阴夹一阳、跌幅较大尾市杀跌、只要反弹立即出货、中阴、阳须小再一下';
    B9:='三不创新高、可小阴小阳、三次不过短时顶部、层层阻力离场观望、上影阴阳、小k线';
    B10:='三不创新低、可小阴小阳、三次不破短时底部、走势不强逢低少吸、下影阴阳、小K线';
    DRAWTEXT_FIX(A1,0.005,0.005,0,B1),COLORRED;
    DRAWTEXT_FIX(A2,0.005,0.005,0,B2),COLORGREEN;
    DRAWTEXT_FIX(A3,0.005,0.005,0,B3),COLORMAGENTA;
    DRAWTEXT_FIX(A4,0.005,0.005,0,B4),COLORCYAN;
    DRAWTEXT_FIX(A5,0.005,0.005,0,B5),COLORBROWN;
    DRAWTEXT_FIX(A6,0.005,0.005,0,B6),COLORBLUE;
    DRAWTEXT_FIX(A7,0.005,0.005,0,B7),COLORYELLOW;
    DRAWTEXT_FIX(A8,0.005,0.005,0,B8),COLORLIGREEN;
    DRAWTEXT_FIX(A9,0.005,0.05,0,B9),COLORWHITE;
    DRAWTEXT_FIX(A10,0.005,0.1,0,B10),COLORLIMAGENTA;
    IF(BETWEEN(T40,0,4)ANDC31>=O31,C31,DRAWNULL)COLORRED;
    IF(BETWEEN(T40,0,4)ANDC31<O31,C31,DRAWNULL)COLORCYAN;
    IF(BETWEEN(T40,0,4)ANDC31>=O31,O31,DRAWNULL)COLORRED;
    IF(BETWEEN(T40,0,4)ANDC31<O31,O31,DRAWNULL)COLORCYAN;
    STICKLINE((T40=0ORT40=4)ANDC31>=O31,O31,C31,0,0)COLORRED;
    STICKLINE((T40=0ORT40=4)ANDC31<O31,O31,C31,0,0)COLORCYAN;
    IF(BETWEEN(T50,0,4)ANDC40>=O40,C40,DRAWNULL)COLORRED;
    IF(BETWEEN(T50,0,4)ANDC40<O40,C40,DRAWNULL)COLORCYAN;
    IF(BETWEEN(T50,0,4)ANDC40>=O40,O40,DRAWNULL)COLORRED;
    IF(BETWEEN(T50,0,4)ANDC40<O40,O40,DRAWNULL)COLORCYAN;
    STICKLINE((T50=0ORT50=4)ANDC40>=O40,O40,C40,0,0)COLORRED;
    STICKLINE((T50=0ORT50=4)ANDC40<O40,O40,C40,0,0)COLORCYAN;
    IF(BETWEEN(T60,0,4)ANDC50>=O50,C50,DRAWNULL)COLORRED;
    IF(BETWEEN(T60,0,4)ANDC50<O50,C50,DRAWNULL)COLORCYAN;
    IF(BETWEEN(T60,0,4)ANDC50>=O50,O50,DRAWNULL)COLORRED;
    IF(BETWEEN(T60,0,4)ANDC50<O50,O50,DRAWNULL)COLORCYAN;
    STICKLINE((T60=0ORT60=4)ANDC50>=O50,O50,C50,0,0)COLORRED;
    STICKLINE((T60=0ORT60=4)ANDC50<O50,O50,C50,0,0)COLORCYAN;




[源码注释]通达信公式动态翻译结果


   输出MA5:收盘价的5日简单移动平均,线宽为1,COLORFFFFFF

   输出

   MA10:收盘价的10日简单移动平均,线宽为1,COLOR00FFFF

   输出

   MA30:收盘价的30日简单移动平均,线宽为1,COLORFF00FF

   输出

   MA60:收盘价的60日简单移动平均,线宽为1,COLOR0000FF

   输出

   MA120:收盘价的120日简单移动平均,线宽为1,COLORFFFF00

   当满足条件收盘价的2日指数移动平均上穿((收盘价的21日线性回归斜率*20)+收盘价)的42日指数移动平均时,在(最低价*0.99)位置书写文字,线宽为3,COLORF00FF0

   当满足条件((收盘价的21日线性回归斜率*20)+收盘价)的42日指数移动平均上穿收盘价的2日指数移动平均时,在(最高价*1.01)位置书写文字,线宽为3,COLORFFFFFF

   多空赋值:(最低价的6日简单移动平均+最低价的13日简单移动平均+最低价的26日简单移动平均)/3

   VAR22赋值:(100-((90*(30日内最高价的最高值-收盘价))/(30日内最高价的最高值-30日内最低价的最低值)))

   VAR33赋值:(100-((90*(120日内最高价的最高值-收盘价))/(120日内最高价的最高值-120日内最低价的最低值)))

   VAR11赋值:(100-((90*(6日内最高价的最高值-收盘价))/(6日内最高价的最高值-6日内最低价的最低值)))

   短顶预警赋值:VAR11上穿95

   短底预报赋值:15上穿VAR11

   TJ1赋值:短底预报

   TJ2赋值:1日前的TJ1ANDCLOSE>

   收盘价的3日简单移动平均

   TJ4赋值:VAR11>

   15ANDREF(收盘价,1)<

   1日前的收盘价的3日简单移动平均ANDCLOSE>

   收盘价的3日简单移动平均ANDCLOSE<

   收盘价的13日简单移动平均

   TJ5赋值:短顶预警

   相对高位赋值:如果最高价=5日内最高价的最高值,返回最高价=5日内最高价的最高值,否则返回收盘价=5日内收盘价的最高值

   相对低位赋值:如果最低价=5日内最低价的最低值,返回最低价=5日内最低价的最低值,否则返回收盘价=5日内收盘价的最低值

   TJ6赋值:(1日前的相对低位ORREF(相对低位,2))

   TJ7赋值:(1日前的相对高位ORREF(相对高位,2))

   当满足条件TJ6ANDREF(收盘价,1)<时,在?位置书写文字

   1日前的收盘价的3日简单移动平均ANDCLOSE>

   收盘价的3日简单移动平均ANDCLOSE>

   =多空,最低价-0.4,'全仓买入'),画红色

   当满足条件TJ7ANDREF(收盘价,1)>时,在?位置书写文字

   1日前的收盘价的3日简单移动平均ANDCLOSE<

   收盘价的3日简单移动平均ANDCLOSE>

   =多空ANDCLOSE<

   开盘价,最高价+0.4,'减仓2/3'),画绿色

   当满足条件TJ1时,在最低价-0.6位置书写文字,画黄色

   DIFF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均

   DEA赋值:DIFF的9日指数移动平均

   MACD赋值:2*(DIFF-DEA)

   MACD1赋值:DIFF上穿DEAANDCOUNT(MACD>

   0,1)=1

   RSV赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100

   K赋值:RSV的9日[1日权重]移动平均

   D赋值:K的9日[1日权重]移动平均

   J赋值:3*K-2*D

   KDJ1赋值:K上穿DANDCROSS(J,D)

   均线赋值:收盘价的5日简单移动平均上穿收盘价的10日简单移动平均

   量线赋值:成交量(手)的5日简单移动平均上穿成交量(手)的10日简单移动平均

   SCC赋值:MACD1ANDKDJ1AND均线AND量线

   SC1赋值:MACD1ANDKDJ1

   SC2赋值:均线AND量线

   SC3赋值:均线ANDMACD1

   SC4赋值:量线ANDKDJ1

   SC5赋值:均线ANDKDJ1

   SC6赋值:MACD1AND量线

   当满足条件SC1ORSC2ORSC3ORSC4ORSC5ORSC6时,在最低价-0.20位置画9号图标

   当满足条件SCC时,在最低价-0.20位置画1号图标

   T31赋值:上次时间(时分秒)=093100距今天数

   T40赋值:上次时间(时分秒)=093500距今天数

   T41赋值:上次时间(时分秒)=093600距今天数

   T50赋值:上次时间(时分秒)=094000距今天数

   T51赋值:上次时间(时分秒)=094100距今天数

   T60赋值:上次时间(时分秒)=094500距今天数

   C31赋值:T40日前的收盘价

   O31赋值:T31日前的收盘价

   C40赋值:T50日前的收盘价

   O40赋值:T41日前的收盘价

   C50赋值:T60日前的收盘价

   O50赋值:T51日前的收盘价

   A1赋值:C31>O31ANDC40>O40ANDC50>O50ANDO40>=C31ANDO50>=C40

   A2赋值:C31<O31ANDC40<O40ANDC50<O50ANDO40<=C31ANDO50<=C40

   A3赋值:C31>O31ANDC40>O40ANDC50<O50ANDC50<C40ANDO50/C50<C40/O40ANDO50/C50<C31/O31

   A4赋值:C31>O31ANDC40<O40ANDC50<O50ANDC40<C31ANDC50<C40ANDC31/O31<O40/C40ANDC31/O31<O50/C50

   A5赋值:C31<O31ANDC40<O40ANDC50>O50ANDC40<C31ANDO50>=C40

   A6赋值:C31<O31ANDC40>O40ANDC50>O50ANDC40>C31ANDC50>C40ANDO31/C31<C40/O40ANDO31/C31<C50/O50

   A7赋值:C31>O31ANDC40<O40ANDC50>O50ANDC31/O31>O40/C40ANDC50/O50>O40/C40

   A8赋值:C31<O31ANDC40>O40ANDC50<O50ANDC40/O40<O31/C31ANDC40/O40<O50/C50

   A9赋值:C31和O31的较大值>=C40和O40的较大值ANDMAX(C31,O31)>=C50和O50的较大值

   A10赋值:C31和O31的较小值<=C40和O40的较小值ANDMIN(C31,O31)<=C50和O50的较小值

   B1赋值:'连续三上、三阳开泰、飚涨走势可能涨停、量大出货否则守仓、大阳、盯量'

   B2赋值:'连续三下、三只乌鸦、重挫走势可能跌停、只要反弹立即出货、大阴、随逃'

   B3赋值:'二上一下、二阳一小阴、震荡走势后势看好、逢高减磅逢低吸纳、中阳、阴须小'

   B4赋值:'一上二下、二只乌鸦、拉高出货后市看坏、逢高减磅后市下跌、中阴、阳线小'

   B5赋值:'二下一上、二阴一阳、急跌控底后市不明、逢高减磅观望为主、下影阴、阳大小'

   B6赋值:'一下二上、一阴二阳、震荡控底后市趋好、观望为主谨慎吸纳、下影阳、阴大小'

   B7赋值:'一上一下、二阳夹一阴、震荡走市后市看好、持股待涨逢低吸纳、中阳、阴须小再一上'

   B8赋值:'一下一上、二阴夹一阳、跌幅较大尾市杀跌、只要反弹立即出货、中阴、阳须小再一下'

   B9赋值:'三不创新高、可小阴小阳、三次不过短时顶部、层层阻力离场观望、上影阴阳、小K线'

   B10赋值:'三不创新低、可小阴小阳、三次不破短时底部、走势不强逢低少吸、下影阴阳、小K线'

   当满足条件A1时,在横轴0.005纵轴0.005位置书写文字,画红色

   当满足条件A2时,在横轴0.005纵轴0.005位置书写文字,画绿色

   当满足条件A3时,在横轴0.005纵轴0.005位置书写文字,画洋红色

   当满足条件A4时,在横轴0.005纵轴0.005位置书写文字,画青色

   当满足条件A5时,在横轴0.005纵轴0.005位置书写文字,画棕色

   当满足条件A6时,在横轴0.005纵轴0.005位置书写文字,画蓝色

   当满足条件A7时,在横轴0.005纵轴0.005位置书写文字,画黄色

   当满足条件A8时,在横轴0.005纵轴0.005位置书写文字,画淡绿色

   当满足条件A9时,在横轴0.005纵轴0.05位置书写文字,画白色

   当满足条件A10时,在横轴0.005纵轴0.1位置书写文字,画淡洋红色

   如果T40位于0和4之间ANDC31>=O31,返回C31,否则返回无效数画红色

   如果T40位于0和4之间ANDC31<O31,返回C31,否则返回无效数画青色

   如果T40位于0和4之间ANDC31>=O31,返回O31,否则返回无效数画红色

   如果T40位于0和4之间ANDC31<O31,返回O31,否则返回无效数画青色

   当满足条件(T40=0ORT40=4)ANDC31>=O31时,在O31和C31位置之间画柱状线,宽度为0,0不为0则画空心柱.画红色

   当满足条件(T40=0ORT40=4)ANDC31<O31时,在O31和C31位置之间画柱状线,宽度为0,0不为0则画空心柱.画青色

   如果T50位于0和4之间ANDC40>=O40,返回C40,否则返回无效数画红色

   如果T50位于0和4之间ANDC40<O40,返回C40,否则返回无效数画青色

   如果T50位于0和4之间ANDC40>=O40,返回O40,否则返回无效数画红色

   如果T50位于0和4之间ANDC40<O40,返回O40,否则返回无效数画青色

   当满足条件(T50=0ORT50=4)ANDC40>=O40时,在O40和C40位置之间画柱状线,宽度为0,0不为0则画空心柱.画红色

   当满足条件(T50=0ORT50=4)ANDC40<O40时,在O40和C40位置之间画柱状线,宽度为0,0不为0则画空心柱.画青色

   如果T60位于0和4之间ANDC50>=O50,返回C50,否则返回无效数画红色

   如果T60位于0和4之间ANDC50<O50,返回C50,否则返回无效数画青色

   如果T60位于0和4之间ANDC50>=O50,返回O50,否则返回无效数画红色

   如果T60位于0和4之间ANDC50<O50,返回O50,否则返回无效数画青色

   当满足条件(T60=0ORT60=4)ANDC50>=O50时,在O50和C50位置之间画柱状线,宽度为0,0不为0则画空心柱.画红色

   当满足条件(T60=0ORT60=4)ANDC50<O50时,在O50和C50位置之间画柱状线,宽度为0,0不为0则画空心柱.画青色


神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论