神奇指标网
神奇指标网

大智慧自用选股公式

浏览 283次浏览
标签: 选股
来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15

  



相关简介: 大智慧自用选股公式                                


     大智慧自用选股公式源码概况:


  指标类别:大智慧公式


  授权方式:免费版


  指标评级:★★★★★


  指标分类:策略


  画线方法:副图




大智慧自用选股公式源码:


    DIF:EMA(CLOSE,5)-EMA(CLOSE,10);
    DEA:EMA(DIF,5);
    MACD:(DIF),COLORSTICK;
    DIF,COLORGREEN,LINETHICK2;
    DEA,COLORGREEN,LINETHICK2;
    零上金叉买:0,COLORGREEN,LINETHICK2;
    IF(DIF>DEA,DIF,DRAWNULL),COLORRED,LINETHICK2;
    IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;
    DRAWICON(CROSS(DIF,DEA),DEA,25);
    DRAWICON(CROSS(DEA,DIF),DEA,24);
    ZT:=C/REF(C,1)>1.098ANDH=C;
    TS:=BArslAst(ZT);
    T1:=COUNT(L<ma(C,13),TS)=1;
    T2:=L<MA(C,13)ANDT1;
    T3:=MA(C,13)>MA(C,25)ANDMA(C,25)>MA(C,55)ANDMA(C,25)>REF(MA(C,25),1);
    T4:=COUNT(L<MA(C,13),3)=2;
    T5:=REF(T3,1)ANDREF(T2,1)ANDT4ANDL<REF(L,1)ANDREF(MA(C,13),1)>REF(MA(C,13),2);
    XG:FILTER(T5,5);



[源码注释]大智慧自用选股公式翻译结果


   输出DIF:收盘价的5日指数移动平均-收盘价的10日指数移动平均

   输出DEA:DIF的5日指数移动平均

   输出平滑异同平均线:(DIF),COLORSTICK

   DIF,画绿色,线宽为2

   DEA,画绿色,线宽为2

   输出零上金叉买:0,画绿色,线宽为2

   如果DIF>,返回?,否则返回?

   DEA,DIF,无效数),画红色,线宽为2

   如果DEA>,返回?,否则返回?

   1日前的DEA,DEA,无效数),画洋红色,线宽为2

   当满足条件DIF上穿DEA时,在DEA位置画25号图标

   当满足条件DEA上穿DIF时,在DEA位置画24号图标

   ZT赋值:收盘价/1日前的收盘价>1.098ANDH=收盘价

   TS赋值:上次ZT距今天数

   T1赋值:统计TS日中满足最低价<收盘价的13日简单移动平均的天数=1

   T2赋值:最低价<收盘价的13日简单移动平均ANDT1

   T3赋值:收盘价的13日简单移动平均>收盘价的25日简单移动平均ANDMA(收盘价,25)>收盘价的55日简单移动平均ANDMA(收盘价,25)>1日前的收盘价的25日简单移动平均

   T4赋值:统计3日中满足最低价<收盘价的13日简单移动平均的天数=2

   T5赋值:1日前的T3ANDREF(T2,1)ANDT4ANDL<1日前的最低价ANDREF(收盘价的13日简单移动平均,1)>2日前的收盘价的13日简单移动平均

   输出XG:T5的5日过滤




今天的分享就到这里啦,大家感觉怎么样呢?有什么意见建议的朋友欢迎在下方评论区写下你的看法,我们共同学习进步,还请大家多多关注支持哦!!

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论