股票画线指标公式 画线选股指标公式

浏览 92次浏览
标签: 选股
来源:神奇指标网 编辑:神奇指标网 发布日期:2022-09-05

image.png

股票画线指标公式 


该指标能够做到对前期高点和最近高点的连线、 前期低点和最近低点的连线、 阻力

位和支撑位的平行直线的连线, 可以说简单易懂, 一目了然。 这类指标要用到未来函数,

通常不做为买卖信号的参考。 但该指标在一定周期内根据 K 线的走势所画的线已经成立,

因此股价突破前高或颈线的点位还是比较可靠的, 大家不妨在实战中来验证。 所以, 除

了主图以外, 还编制了选股指标。

指标中的实线为高、 低点连线, 虚线为阻力位和支撑位。

该指标可以复制粘贴到任何主图里。 觉得好用请用回复给点支持哦, 谢谢主图指标:

MA7:MA(C,7),COLORWHITE;

MA1 4:MA(C,1 4),COLORYELLOW;

MA25:MA(C,25),COLORFF00FF;

MA1 20:MA(C,1 20),COLORFFCC66;

QA:=REF(H,1 0)=HHV(H,2*1 0+1 );

QB:=BACKSET(QA,1 0+1 );

QC:=FILTER(QB,1 0) AND H=HHV(H,1 0+1 );

QD:=BARSLAST(QC);

QE:=IF(QC,CURRBARSCOUNT,0);

QF:=IF(QD,REF(QE,QD),QE);

QG:=CONST(QF);

QH:=REF(QF,QD+1 );

QW:=CONST(QH);

DRAWLINE(CURRBARSCOUNT=QW,H,CURRBARSCOUNT=QG,H,1 ),COLORGREEN;

DRAWLINE(CURRBARSCOUNT=QW,H,ISLASTBAR,REF(H,QW-1 ),1 ),COLOR0099FF,POINTDOT;

DRAWLINE(CURRBARSCOUNT=QG,H,ISLASTBAR,REF(H,QG-1 ),1 ),COLOR0099FF,POINTDOT;

QM:=INTPART(3*8/5);

QR:=REF(H,QM)=HHV(H,2*QM+1 );

QT:=FILTER(QR,QM);

QY:=BACKSET(QT,QM+1 );

QU:=FILTER(QY,QM);

QI:=BACKSET(ISLASTBAR,BARSLAST(QU)+1 );

QP:=QI>REF(QI,1 );

DRAWLINE(QU,H,QP,H,1 ),COLORRED;

QA1 :=REF(L,8)=LLV(L,2*8+1 );

QB1 :=BACKSET(QA1 ,8+1 );

QC1 :=FILTER(QB1 ,8) AND L=LLV(L,8+1 );

QD1 :=BARSLAST(QC1 );

QE1 :=IF(QC1 ,CURRBARSCOUNT,0);

QF1 :=IF(QD1 ,REF(L,QD1 ),L);

QG1 :=IF(QD1 ,REF(QE1 ,QD1 ),QE1 );

QH1 :=CONST(QG1 );

QW1 :=REF(QF1 ,QD1 +1 );

QM1 :=REF(QG1 ,QD1 +1 );

QR1 :=CONST(QM1 );

DRAWLINE(CURRBARSCOUNT=QR1 ,L,CURRBARSCOUNT=QH1 ,L,1 ),COLORBLUE;

DRAWLINE(CURRBARSCOUNT=QH1 ,L,ISLASTBAR,REF(L,QH1 -1 ),1 ),COLORWHITE,POINTDOT;

DRAWLINE(CURRBARSCOUNT=QR1 ,L,ISLASTBAR,REF(L,QR1 -1 ),1 ),COLORWHITE,POINTDOT;

QT1 :=REF(L,QM)=LLV(L,2*QM+1 );

QY1 :=FILTER(QT1 ,QM);

QU1 :=BACKSET(QY1 ,QM+1 );

QI1 :=FILTER(QU1 ,QM);

QP1 :=BACKSET(ISLASTBAR,BARSLAST(QI1 )+1 );

QJ1 :=QP1 >REF(QP1 ,1 );

DRAWLINE(QI1 ,L,QJ1 ,L,1 ),COLORRED;

SR1 :=REF(HIGH,1 0)=HHV(HIGH,2*1 0+1 );

SR2:=FILTER(SR1 ,1 0);

SR3:=BACKSET(SR2,1 0+1 );

HD:=FILTER(SR3,1 0);

前高:=REF(H,BARSLAST(HD));

DRAWICON(CROSS(C,前高),L-0.20,3);{突破前高的信号}

选股指标

SR1 :=REF(HIGH,1 0)=HHV(HIGH,2*1 0+1 );

SR2:=FILTER(SR1 ,1 0);

SR3:=BACKSET(SR2,1 0+1 );

HD:=FILTER(SR3,1 0);

前高:=REF(H,BARSLAST(HD));

突破前高:CROSS(C,前高);



画线选股指标公式


    A1:=DATE<=13181231;

    七天线:MA(C,7),COLORGRAY;

    工作线:(EMA(C,14))*A1,POINTDOT,LINETHICK4,COLORYELLOW;

    生命线:(MA(C,25))*A1,LINETHICK2,COLORMAGENTA;

    不惑线:(MA(C,40))*A1,COLORCYAN;

    姊妹线:(EMA(C,56))*A1,,POINTDOT,COLORWHITE;

    A3:=EMA((((SLOPE(C,21))*20)+C),68);

    A4:=EMA(C,10);

    A5:=REF(C,2);

    A6:=((SMA((MAX((C-A5),0)),6,1))/(SMA(ABS((C-A5)),6,1)))*100;

    A7:=IF(((A6<(REF(A6,1)))AND(A6>79)),A6,0);

    A8:=LLV(L,21);

    A9:=HHV(H,21);

    A10:=EMA((((CLOSE-A8)/(A9-A8))*100),5);

    A11:=EMA((((CLOSE-A8)/(A9-A8))*50),13);

    A12:=EMA(((0.667*(REF(A10,1)))+(0.333*A10)),2);

    A13:=LLV(L,55);

    A14:=HHV(H,34);

    A15:=EMA((((C-A13)/(A14-A13))*100),3);

    A16:=(A11+A15)/2;

    A17:=EMA(((0.667*(REF(A15,1)))+(0.333*A10)),2);

    A18:=EMA(A16,5);

    A19:=EMA(((0.667*(REF(A18,1)))+(0.333*A18)),2);

    A20:=CROSS(A10,A11);

    A21:=(CROSS(A10,A19))AND(A19<30);

    A22:=A21*0.6;

    A23:=((C+L)+H)/3;

    A24:=EMA(A23,6);

    A25:=EMA(A24,5);

    A26:=CROSS(A24,A25);

    DRAWICON(A26,(LOW/1.015),1),LINETHICK2,COLORMAGENTA;

    DRAWTEXT(CROSS(A4,A3),L*0.9,'线上阴线买|买错也要买!线下阳线卖|卖错也要

    卖!'),LINETHICK4,COLORYELLOW;

    STICKLINE(((C>=工作线)AND(C>=O)),H,L,0,1),COLORRED;

    STICKLINE(((C>=工作线)AND(C>=O)),O,C,2,1),COLORRED;

    STICKLINE(((C>=工作线)AND(C<=O)),H,L,0,0),COLORRED;

    STICKLINE(((C>=工作线)AND(C<=O)),O,C,2,0),COLORRED;

    STICKLINE(((C<工作线)AND(C>=O)),H,L,0,1),COLORGREEN;

    STICKLINE(((C<工作线)AND(C>=O)),O,C,2,1),COLORGREEN;

    STICKLINE(((C<工作线)AND(C<=O)),H,L,0,0),COLORGREEN;

    STICKLINE(((C<工作线)AND(C<=O)),O,C,2,0),COLORGREEN;

    高抛低吸

    EMA5:MA(C,5),COLOR0000FF,LINETHICK2;

    EMA10:MA(C,10),COLOR00FFFF,LINETHICK2;

    EMA21:=MA(C,21),COLORC0FF7F,LINETHICK1;

    EMA60:MA(C,60),COLORFFFFFF,LINETHICK1;

    MA7:=MA(C,7);

    VAR71:=ATAN((MA7/REF(MA7,1)-1)*100)*180/3.1416;

    AA1:=ATAN((MA7/REF(MA7,1)-1)*100)*180/3.1416;

    BB1:=MA(AA1,4);

    AA:=AA1>=BB1;

    BB:=AA1<BB1;

    买入:DRAWICON(CROSS(AA,BB),L-0.1,1);

    卖出:DRAWICON(CROSS(BB,AA),H+0.1,2);

    STICKLINE(AA,C,O,3,0),COLOR000099;

    STICKLINE(AA,H,L,0.5,0),COLOR000099;

    STICKLINE(BB,C,O,3,0),COLORFF0099;

    STICKLINE(BB,H,L,0.5,0),COLOR660099;

    STICKLINE(AA,CLOSE,OPEN,3.0,0),COLOR9900CC;

    STICKLINE(AA,CLOSE,OPEN,2.5,0),COLORFF00CC;

    STICKLINE(AA,CLOSE,OPEN,1.9,0),COLORFF00FF;

    STICKLINE(AA,CLOSE,OPEN,1.0,0),COLORFF33FF;

    STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORFF66FF;

    STICKLINE(AA,CLOSE,OPEN,0.2,0),COLORFF99FF;

    STICKLINE(BB,CLOSE,OPEN,3,0),COLOR006633;

    STICKLINE(BB,CLOSE,OPEN,2.5,0),COLOR339933;

    STICKLINE(BB,CLOSE,OPEN,1.9,0),COLOR669933;

    STICKLINE(BB,CLOSE,OPEN,1.5,0),COLOR33CC33;

    STICKLINE(BB,CLOSE,OPEN,1.0,0),COLOR66CC33;

    STICKLINE(BB,CLOSE,OPEN,0.2,0),COLORCCFF33;

    STICKLINE(买入,O,(C-O)/2+O,3,0),COLOR335555;

    STICKLINE(买入,O,(C-O)/2+O,2.2,0),COLOR338888;

    STICKLINE(买入,O,(C-O)/2+O,1.5,0),COLOR33AAAA;

    STICKLINE(买入,O,(C-O)/2+O,1,0),COLOR33CCCC;

    STICKLINE(买入,O,(C-O)/2+O,0,0),COLOR33EEEE;

    STICKLINE(卖出,O,(C-O)/2+O,3,0),COLOR550055;

    STICKLINE(卖出,O,(C-O)/2+O,2.2,0),COLOR880088;

    STICKLINE(卖出,O,(C-O)/2+O,1.5,0),COLORAA00AA;

    STICKLINE(卖出,O,(C-O)/2+O,1,0),COLORCC00CC;

    STICKLINE(卖出,O,(C-O)/2+O,0.5,0),COLOREE00EE;

    黑马

    个股:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),COLOR1010FF;

    大

    盘:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLOR

    E67010,LINETHICK2;

    STICKLINE(个股>=大盘,个股,大盘,3,0),COLORRED;

    STICKLINE(个股<大盘,个股,大盘,3,0),COLORBLUE;

    STICKLINE(个股>=大盘,0,大盘,3,0),COLORYELLOW;

    STICKLINE(个股<大盘,0,个股,3,0),COLORYELLOW;

    黑马初现:IF(CROSS(个股,9),50,0),STICK,LINETHICK3,COLOR00FF00;

    DRAWTEXT(CROSS(个股,9),66,'黑马'),COLOR00FF00;

    DRAWTEXT(CROSS(个股,9),60,'1'),COLOR00FF00;

    VAR1:=EMA(CLOSE,3);

    VAR2:=EMA(CLOSE,21);

    VAR3:=BARSLAST(CROSS(VAR2,VAR1))>15;

    VAR4:=VOL>MA(VOL,5)*2ANDVOL<MA(VOL,5)*5;

    VAR5:=CROSS(VAR1,VAR2)ANDVAR4ANDVAR3;

    黑马:IF(VAR5,60,0),STICK,LINETHICK3,COLORF00FF0;

    DRAWTEXT(VAR5,78,'黑马!'),COLORF00FF0;

    拉升线:80,COLORGREEN,LINETHICK2;

    试庄线:20,COLORWHITE,LINETHICK2;

    强弱线:50,COLORRED,LINETHICK2;

image.png


神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享