机构操盘指标公式 机构操盘指标公式主图

浏览 114次浏览
标签: 突破
来源:神奇指标网 编辑:神奇指标网 发布日期:2022-09-05

   image.png

   机构操盘指标公式

    {比诺-通达信指标---突破区间和下降区间------};

    NS1:=IF(突破区=0,DRAWNULL,1);{设置显示/隐藏};

    AA1:=EMA(C,5);

    AA2:=EMA(C,10);

    突破:=REF(AA2,1),COLORMAGENTA,DOTLINE;

    AA3:=AA1-突破;

    AA4:=((AA3)/突破*100);

    A:=IF(AA4>=0,REF(AA2,BARSLAST(CROSS(AA4,0))+1),DRAWNULL);

    B:=IF(AA4<0,REF(AA2,BARSLAST(CROSS(0,AA4))+1),DRAWNULL);

    STICKLINE(NS1*A,A,A,4,-1)COLORMAGENTA;{粉红色柱下水平线}

    区间:=IF(A,A,DRAWNULL),COLORYELLOW,LINETHICK2;{上升区底部水平线黄色}

    STICKLINE(NS1*B,B,B,4,-1)COLORGREEN;{绿色柱上水平线}

    STICKLINE(NS1*(AA4>=0),A,突破,0,-1)COLORMAGENTA;{粉红色柱}

    STICKLINE(NS1*(AA4<0),B,突破,0,-1)COLORGREEN;{绿色柱}

    持币:=IF(NS1*(AA4<0),突破,DRAWNULL),COLORFFCC00,DOTLINE;

    DRAWTEXT(NS1*(ISLASTBARANDA),A-0.1,'出击'),COLORMAGENTA;

    DRAWTEXT(NS1*(ISLASTBARANDB),B+0.15,'休假'),COLORGREEN;

    {机构操盘......√...机构操盘黄色信号比股市搏击波段信号提前}

    NT:=IF(资金线=0,DRAWNULL,1);

    H0:=MA(C,8);

    H1:=(55*H0+34*REF(H0,1)+21*REF(H0,2)+13*REF(H0,3)+8*REF(H0,4)+5*REF(H0,5)

    +3*REF(H0,6)+2*REF(H0,7)+REF(H0,8)+REF(H0,9))/143;

    H2:=REF(H1,1);

    游资资金:0.5*(H1+H2),NODRAW,COLORYELLOW;

    DRAWBAND(NT*H1,RGB(255,255,0),NT*H2,RGB(0,0,255));

    I0:=MA(C,34);

    I1:=(55*I0+34*REF(I0,1)+21*REF(I0,2)+13*REF(I0,3)+8*REF(I0,4)+5*REF(I0,5)+3*R

    EF(I0,6)+2*REF(I0,7)+REF(I0,8)+REF(I0,9))/143;

    I2:=REF(I1,1);

    机构资金:0.5*(I1+I2),NODRAW,COLORRED;

    DRAWBAND(NT*I1,RGB(255,0,0),NT*I2,RGB(0,255,0));

    BDGD:=C=HHV(C,13);

    GDSJ:=BARSLAST(FILTER(CROSS(0.8,BDGD),2))+1;

    提示:=STICKLINE(REF(C,GDSJ)/提示搜寻,REF(C,GDSJ),REF(C,GDSJ),6,0),COLORGREEN;

    BDDD:=C=LLV(C,13);

    DDSJ:=BARSLAST(FILTER(CROSS(0.8,BDDD),2))+1;

    搜寻:STICKLINE(REF(C,DDSJ)/提示搜

    寻,REF(C,DDSJ),REF(C,DDSJ),6,0),COLORLIRED,COLORYELLOW;

    假设高:IF(假设高度=0,DRAWNULL,假设高度),COLORLIGRAY;


image.png



   机构操盘指标公式主图


    W1:=FILTER(O<REF(L,1)&&C>O&&VOL>REF(V,1),13);

    JH:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;

    SZ:=FILTER(CROSS(JH,35),13);

    SX:=FILTER(CROSS(JH,30),7);

    SQ:=FILTER(CROSS(71,JH),74);

    SD:=FILTER(CROSS(80,JH),74);

    BB:=IF(CAPITAL<1,SQ,SD);

    AA:=IF(CAPITAL<1,SZ,SX);

    CC:=REF(HHV(CLOSE,120),1);

    DD:=REF(LLV(CLOSE,120),1);

    WW:=((100*(CLOSE-DD))/(CC-DD));

    FF:=(EMA(AMOUNT,5)/REF(EMA(AMOUNT,5),5));

    BZ:=FILTER(((FF>=2&&WW<35&&BARSCOUNT(C)>30)OR(FF>=2&&

    WW<100&&BARSCOUNT(C)<50)),30);

    STICKLINE(C>OORC>REF(C,1),H,L,0,0),COLOR0022FF;

    STICKLINE(C>OORC>REF(C,1),C,O,3.2,0),COLOR002288;

    STICKLINE(C>OORC>REF(C,1),C,O,2.6,0),COLOR0033AA;

    STICKLINE(C>OORC>REF(C,1),C,O,1.9,0),COLOR0044CC;

    STICKLINE(C>OORC>REF(C,1),C,O,1.1,0),COLOR0055EE;

    STICKLINE(C>OORC>REF(C,1),C,O,0.3,0),COLOR0088FF;

    STICKLINE(C<OORC<REF(C,1),H,L,0,1),COLORFF8800;

    STICKLINE(C<OORC<REF(C,1),C,O,3.2,0),COLORFF2200;

    STICKLINE(C<OORC<REF(C,1),C,O,2.6,0),COLORFF4400;

    STICKLINE(C<OORC<REF(C,1),C,O,1.9,0),COLORFF6600;

    STICKLINE(C<OORC<REF(C,1),C,O,1.1,0),COLORFF8800;

    STICKLINE(C<OORC<REF(C,1),C,O,0.3,0),COLORFFAA00;

    STICKLINE(C=REF(C,1),H,L,0,1),COLORFFFFFF;

    STICKLINE(C=REF(C,1),C,O,3.2,0),COLOR555555;

    STICKLINE(C=REF(C,1),C,O,2.6,0),COLOR777777;

    STICKLINE(C=REF(C,1),C,O,1.9,0),COLOR999999;

    STICKLINE(C=REF(C,1),C,O,1.1,0),COLORCCCCCC;

    {STICKLINE(C=REF(C,1),C,O,0.3,0),COLORDDDDDD;}

    STICKLINE(W1,H,L,0,1),COLORFF55FF;

    STICKLINE(W1,C,O,3.2,0),COLOR880088;

    STICKLINE(W1,C,O,2.6,0),COLORAA00AA;

    STICKLINE(W1,C,O,1.9,0),COLORCC00CC;

    STICKLINE(W1,C,O,1.1,0),COLOREE00EE;

    STICKLINE(W1,C,O,0.3,0),COLORFF44FF;

    STICKLINE(AA,H,L,0,1),COLORYELLOW;

    STICKLINE(AA,C,O,3.2,0),COLOR117777;

    STICKLINE(AA,C,O,2.6,0),COLOR119999;

    STICKLINE(AA,C,O,1.9,0),COLOR11BBBB;

    STICKLINE(AA,C,O,1.1,0),COLOR11DDDD;

    STICKLINE(AA,C,O,0.3,0),COLOR44FFFF;

    STICKLINE(BB,H,L,0,1),COLORGREEN;

    STICKLINE(BB,C,O,3.2,0),COLOR006600;

    STICKLINE(BB,C,O,2.6,0),COLOR008800;

    STICKLINE(BB,C,O,1.9,0),COLOR00AA00;

    STICKLINE(BB,C,O,1.1,0),COLOR00CC00;

    STICKLINE(BB,C,O,0.3,0),COLOR00FF00;

    STICKLINE(BZ,H,L,0,1),COLOR0000FF;

    STICKLINE(BZ,C,O,3.2,0),COLOR000066;

    STICKLINE(BZ,C,O,2.6,0),COLOR000088;

    STICKLINE(BZ,C,O,1.9,0),COLOR0000AA;

    STICKLINE(BZ,C,O,1.1,0),COLOR0000CC;

    STICKLINE(BZ,C,O,0.3,0),COLOR2200FF;

    VAR1AA:=((2)*(CLOSE)+OPEN+HIGH+LOW)/(5);

    VAR2AA:=VOL;

    上升价格线:(SUM((VAR1AA)*(VAR2AA),8))/(SUM(VAR2AA,8)),COLORRED;

    下降价格线:LLV(上升价格线,8),COLOR007700;

    VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);

    VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05)AND((HIGH)/(CLOSE)<1.01)

    AND(VAR3AA>0),91,0);

    DRAWTEXT(FILTER((VAR4AA>90),34),(LOW)*(0.99),'*加仓'),COLORRED;

    A1AA:=9;

    A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);

    DRAWTEXT(FILTER((A2AA>0),34),(HIGH)*(1.01),'*警'),COLORGREEN;

    VAR1:=REF(CLOSE,1);

    VAR2:=MA(CLOSE,5);

    VAR3:=SMA(MAX(CLOSE-VAR1,0),6,1)/SMA(ABS(CLOSE-VAR1),6,1)*100;

    VAR4:=SMA(MAX(CLOSE-VAR1,0),12,1)/SMA(ABS(CLOSE-VAR1),12,1)*100;

    VAR5:=SMA(MAX(CLOSE-VAR1,0),24,1)/SMA(ABS(CLOSE-VAR1),24,1)*100;

    VAR6:=IF(CROSS(VAR3,VAR5),LOW,REF(LOW,BARSLAST(CROSS(VAR3,VAR

    5))));

    VAR7:=IF(CROSS(VAR5,VAR3),HIGH,REF(HIGH,BARSLAST(CROSS(VAR5,VA

    R3))));

    VAR8:=IF(CLOSE>=MA(CLOSE,20),80,50);

    VAR9:=IF(CLOSE>=MA(CLOSE,20),50,20);

    VARA:=IF(VAR3<VAR8AND

    REF(VAR3,1)>=VAR8,HHV(REF(HIGH,1),BARSLAST(VAR3>=VAR8AND

    REF(VAR3,1)<VAR8)-1),REF(HHV(REF(HIGH,1),BARSLAST(VAR3>=VAR8

    ANDREF(VAR3,1)<VAR8)-1),BARSLAST(VAR3<VAR8ANDREF(VAR3,1))));

    VARB:=IF(HIGH>VARA,LOW,REF(LOW,BARSLAST(HIGH>VARA)));

    VARC:=IF(HIGH>VARA,VAR3,REF(VAR3,BARSLAST(HIGH>VARA)));

    VARD:=IF(HIGH>VARBANDVAR3<VARCAND

    VAR3<VAR5,HIGH,REF(HIGH,BARSLAST(HIGH>VARBANDVAR3<VARC

    ANDVAR3<VAR5)));

    VARE:=IF(VAR3>VAR9AND

    REF(VAR3,1)<=VAR9,LLV(REF(LOW,1),BARSLAST(VAR3<=VAR9AND

    REF(VAR3,1)>VAR9)-1),REF(LLV(REF(LOW,1),BARSLAST(VAR3<=VAR9AND

    REF(VAR3,1)>VAR9)-1),BARSLAST(VAR3>VAR9ANDREF(VAR3,1))));

    VARF:=IF(LOW<VARE,HIGH,REF(HIGH,BARSLAST(LOW<VARE)));

    VAR10:=IF(LOW<VARE,VAR3,REF(VAR3,BARSLAST(LOW<VARE)));

    VAR11:=IF(LOW<VARFANDVAR3>VAR10AND

    VAR3>VAR5,LOW,REF(LOW,BARSLAST(LOW<VARFANDVAR3>VAR10AND

    VAR3>VAR5)));

    支撑线:VAR11,COLORYELLOW,LINETHICK1;

    压力线:VARD,COLORGREEN,LINETHICK1;


   image.png


神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享