神奇指标网
神奇指标网

七绝剑气指标公式

浏览 167次浏览
标签: 指标公式
来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15

  



     相关简介:  七绝剑气指标公式                                


  授权方式:免费版


  指标评级:★★★★★


  指标分类:策略


  画线方法:副图/主图





未来函数检测结果:

         暂未发现存在未来函数





七绝剑气指标公式源码:



    W:=10;
    W2:=6;
    W3:=1;
    N1:=60;
    100,COLORBLacK;
    80,COLORBLACK;
    volUME:=VOL,VOLSTICK;
    MAVOL1:=MA(VOLUME,5);
    MAVOL2:=MA(VOLUME,10);
    SSTS:=BARSSINCE(C>0);
    N4:=IF(SSTS<N1,SSTS,N1);
    MAV200:=EMA(VOL,N4);
    QD1:=IF(MAVOL1>=MAVOL2,10,0);
    {STICKLINE(MAVOL1>=MAVOL2,66,70,3,0),COLORYELLOW;
    STICKLINE(MAVOL1<MAVOL2,66,70,3,1),COLOR333333;
    STICKLINE(VOLUME>=2*REF(VOLUME,1)ANDC>=REF(C,1),60,95,1,0),COLORYELLOW;
    STICKLINE(VOLUME>=2*REF(VOLUME,1)ANDC<REF(C,1),60,95,1,0),COLORGREEN;
    DRAWTEXT(CURRBARSCOUNT=W3,68,'★量'),COLORFFFFFF;}
    PJJ:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
    JJ:=REF(EMA(PJJ,3),1);
    QJJ:=VOL/((HIGH-LOW)*2-Abs(CLOSE-OPEN));
    XVL:=IF(CLOSE>OPEN,QJJ*(HIGH-LOW),IF(CLOSE<OPEN,QJJ*(HIGH-OPEN+CLOSE-LOW),VOL/2))+IF
    (CLOSE>OPEN,0-QJJ*(HIGH-CLOSE+OPEN-LOW),IF(CLOSE<OPEN,0-QJJ*(HIGH-LOW),0-VOL/2));
    HSL:=(XVL/20)/1.15;
    攻击流量:=((HSL*0.55+(REF(HSL,1)*0.33))+(REF(HSL,2)*0.22));
    GJJ:=EMA(攻击流量,8);
    LLJX:=EMA(攻击流量,3);
    资金流量:=LLJX,LINETHICK0,COLOR0000FF;
    A10:=资金流量>0;
    {STICKLINE(资金流量>=0,72,76,3,0),COLORLIRED;
    STICKLINE(资金流量<0,72,76,3,1),COLOR333333;
    DRAWTEXT(CURRBARSCOUNT=W3,74,'★流'),COLORFFFFFF;}
    QD2:=IF(资金流量>=0,10,0);
    DIF60:=EMA(CLOSE,12/2)-EMA(CLOSE,26/2);
    DEA60:=EMA(DIF60,9/2);
    {STICKLINE(DIF60>=DEA60,54,58,3,0),COLORYELLOW;
    STICKLINE(DIF60<DEA60,54,58,3,1),COLOR696969;
    DRAWTEXT(CURRBARSCOUNT=W3,56,'★60M'),COLORFFFFFF;}
    QD3:=IF(DIF60>=DEA60,10,0);
    RSV60:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36));
    K60:=SMA(RSV60,3,1);
    D60:=SMA(K60,3,1);
    {STICKLINE(K60>=D60,60,64,3,0),COLORRED;
    STICKLINE(K60<D60,60,64,3,1),COLOR696969;
    DRAWTEXT(CURRBARSCOUNT=W2,62,'★60K'),COLORWHITE;}
    QD4:=IF(K60>=D60,10,0);
    DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIF,9);
    {STICKLINE(DIF>=DEA,48,52,3,0),COLORYELLOW;
    STICKLINE(DIF<DEA,48,52,3,1),COLOR696969;
    DRAWTEXT(CURRBARSCOUNT=W3,50,'★日M'),COLORFFFFFF;}
    QD5:=IF(DIF>=DEA,10,0);
    周MD:=macd.DIF#WEEK;
    周MA:=MACD.DEA#WEEK;
    {STICKLINE(周MD>=周MA,30,34,3,0),COLORYELLOW;
    STICKLINE(周MD<周MA,30,34,3,1),COLOR696969;
    DRAWTEXT(CURRBARSCOUNT=W3,32,'★周M'),COLORFFFFFF;}
    QD6:=IF(周MD>=周MA,10,0);
    月MD:=MACD.DIF#MONTH;
    月MA:=MACD.DEA#MONTH;
    {STICKLINE(月MD>=月MA,12,16,3,0),COLORYELLOW;
    STICKLINE(月MD<月MA,12,16,3,1),COLOR696969;
    DRAWTEXT(CURRBARSCOUNT=W3,14,'★月M'),COLORFFFFFF;}
    QD7:=IF(月MD>=月MA,10,0);
    RSV:=(CLOSE-LLV(LOW,12))/(HHV(HIGH,12)-LLV(LOW,12));
    K:=SMA(RSV,3,1);
    D:=SMA(K,3,1);
    J:=3*K-2*D;
    {STICKLINE(K>=D,42,46,3,0),COLORLIRED;
    STICKLINE(K<D,42,46,3,1),COLOR696969;
    DRAWTEXT(CURRBARSCOUNT=W2,44,'★日K'),COLORFFFFFF;}
    QD8:=IF(K>=D,10,0);
    周K:=MA("kdj.K#WEEK"(9,3,3),5);
    周D:=MA("kdJ.D#WEEK"(9,3,3),5);
    周J:=MA("KDJ.J#WEEK"(9,3,3),5);
    {STICKLINE(周K>=周D,24,28,3,0),COLORLIRED;
    STICKLINE(周K<周D,24,28,3,1),COLOR696969;
    DRAWTEXT(CURRBARSCOUNT=W2,26,'★周K'),COLORFFFFFF;}
    QD9:=IF(周K>=周D,10,0);
    {STICKLINE(周K>=REF(周K,1),-6,-2,3,0),COLORYELLOW;
    STICKLINE(周K<REF(周K,1),-6,-2,3,0),COLOR333333;
    DRAWTEXT(CURRBARSCOUNT=W2,-4,'★周K拐'),COLORFFFFFF;}
    QD10:=IF(周K>=周D,10,0);
    {STICKLINE(周J>=REF(周J,1),-12,-8,3,0),COLORRED;
    STICKLINE(周J<REF(周J,1),-12,-8,3,0),COLOR333333;
    DRAWTEXT(CURRBARSCOUNT=W2,-10,'★周J拐'),COLORWHITE;}
    QD11:=IF(周J>=REF(周J,1),10,0);
    DRAWICON(周K>=REF(周K,1)ANDDIF60>=DEA60,85,25);
    月K:="KDJ.K#MONTH";
    月D:="KDJ.D#MONTH";
    {STICKLINE(月K>=月D,6,10,3,0),COLORLIRED;
    STICKLINE(月K<月D,6,10,3,1),COLOR696969;
    DRAWTEXT(CURRBARSCOUNT=W2,8,'★月K'),COLORWHITE;}
    QD12:=IF(月K>=月D,10,0);
    {rsi日}
    日RSI1:="RSI.RSI1#DAY"(9);
    日RSI2:="RSI.RSI2#DAY"(9);
    {STICKLINE(日RSI1>=日RSI2,36,40,3,0),COLORFF00FF;
    STICKLINE(日RSI1<日RSI2,36,40,3,1),COLOR696969;
    DRAWTEXT(CURRBARSCOUNT=W,38,'★日R'),COLORFFFFFF;}
    QD13:=IF(日RSI1>=日RSI2,10,0);
    {RSI周}
    周RSI1:="RSI.RSI1#WEEK"(9);
    周RSI2:="RSI.RSI2#WEEK"(9);
    {STICKLINE(周RSI1>=周RSI2,18,22,3,0),COLORFF00FF;
    STICKLINE(周RSI1<周RSI2,18,22,3,1),COLOR696969;
    DRAWTEXT(CURRBARSCOUNT=W,20,'★周R'),COLORFFFFFF;}
    QD14:=IF(周RSI1>=周RSI2,10,0);
    {RSI月}
    月RSI1:="RSI.RSI1#MONTH"(9);
    月RSI2:="RSI.RSI1#MONTH"(9);
    {STICKLINE(月RSI1>=月RSI2,0,4,3,0),COLORFF00FF;
    STICKLINE(月RSI1<月RSI2,0,4,3,1),COLOR696969;
    DRAWTEXT(CURRBARSCOUNT=W,2,'★月R'),COLORFFFFFF;}
    QD15:=IF(月RSI1>=月RSI2,10,0);
    XH1:=IF(DIF60>=DEA60,1,0);
    XH2:=IF(K60>=D60,1,0);
    XH3:=IF(DIF>=DEA,1,0);
    XH4:=IF(周MD>=周MA,1,0);
    XH5:=IF(月MD>=月MA,1,0);
    XH6:=IF(K>=D,1,0);
    XH7:=IF(周K>=REF(周K,1),1,0);
    XH8:=IF(周J>=REF(周J,1),1,0);
    XH9:=IF(月K>=月D,1,0);
    XH10:=IF(MAVOL1>MAVOL2,1,0);
    XH11:=IF(资金流量>0,1,0);
    XH12:=IF(日RSI1>=日RSI2,1,0);
    XH13:=IF(周RSI1>=周RSI2,1,0);
    XH14:=IF(月RSI1>=月RSI2,1,0);
    XH15:=IF(周K>=周D,1,0);
    ZTB:=COUNT(C/REF(C,1)>=1.09,5)>=1;
    XHHJ:XH1+XH2+XH3+XH4+XH6+XH7+XH8+XH5+XH9+XH10+XH11+XH12+XH13+XH14+XH15,NODRAW;
    {IF(XHHJ<8,XHHJ*10,DRAWNULL),LINETHICK2,COLORGREEN;
    IF(XHHJ>=8ANDXHHJ<10,XHHJ*10,DRAWNULL),LINETHICK2,COLORLIRED;
    IF(XHHJ>=10,XHHJ*10,DRAWNULL),LINETHICK2,COLORYELLOW;
    IF(XHHJ<REF(XHHJ,1)ANDXHHJ>=10,XHHJ*10,DRAWNULL),LINETHICK2,COLORGREEN;}
    STICKLINE(XHHJ<8,0,XHHJ*5,2,0),COLORLIGREEN;
    STICKLINE(XHHJ>=8ANDXHHJ<10,0,XHHJ*5,2,0),COLORLIRED;
    STICKLINE(XHHJ>=10,0,XHHJ*5,2,0),COLORYELLOW;
    {1指.能量线}
    能量线:=EMA(100*(C-LLV(L,34))/(HHV(H,34)-LLV(L,34)),3),LINETHICK0;
    {2指.RSI}
    RSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100,LINETHICK0;
    {3指.KDJ}
    RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,LINETHICK0;
    K1:=SMA(RSV1,3,1);
    D1:=SMA(K1,3,1);
    J1:=3*K1-2*D1,LINETHICK0;
    {4指.W&R}
    威廉wr:=(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))*100,LINETHICK0;
    {5指.cci}
    TYP:=(HIGH+LOW+CLOSE)/3;
    CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;
    五指A:WMA((能量线+RSI+J-威廉WR+CCI)/5,5);
    五指B:WMA((能量线+RSI+J-威廉WR+CCI)/5,13);
    WMA((能量线+RSI+J-威廉WR+CCI)/5,5),COLOR00FF00,LINETHICK3;
    IF(五指A>REF(五指A,1),五指A,DRAWNULL),COLOR0000FF,LINETHICK3;
    {DRAWTEXT_FIX(1,0.02,0,0,'能量线,RSI3.KDJ,W&R,CCI,五个指标共振线.[红].[绿].变化是买卖信号.颜色及标记是配合信号,重点关注60分MACD和周K拐头,周K金叉'),COLORRED,LINETHICK3;}
    KC:=FORCAST(((2*C+H+L)/4*0.618+C*0.382),3);
    AAX:=(KC-MA(KC,9))/MA(KC,9)*100;
    VAR0:=MIN(EXIST(KC,55),9);
    AAX1:=EMA(AAX,VAR0)*VAR0;
    AAX2:=MA(AAX1,3);
    AAX3:=MA(AAX1,5);
    卖:=AAX3>3ANDAAX1<REF(AAX1,1)ANDcrOSS(AAX2,AAX1);
    VBA:=FILTER(卖,5);
    DRAWTEXT(VBA,五指A*1.08,'★减仓'),COLORYELLOW;
    DRAWICON(FILTER(VBA=1,3),五指A,2),COLORFFFF00;
    DRAWTEXT(CROSS(REF(五指A,1),五指A)AND五指B<REF(五指B,1)AND五指A>-20,五指A*1,'★空仓'),COLORFFFF00;
    {STICKLINE(FILTER(VBA=1,5),36,0,1.25,0),COLORBLUE;
    STICKLINE(FILTER(VBA=1,5),35,0,0.35,1),COLORBLUE,COLORGREEN;}
    VB2:=EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6)*100;
    VB3:=IF(LLV(VB2,3)=LLV(VB2,11)ANDCOUNT(VB2<0,2)ANDCROSS(VB2,MA(VB2,2)),1,0);
    VB4:=FILTER(VB3=1,5);
    DRAWTEXT(VB4,五指A*1,'★建仓'),COLORD9D919;
    DRAWTEXT(CROSS(五指A,五指B),五指A*1,'★加仓'),COLORYELLOW;
    DRAWICON(FILTER(VB4=1,3),五指A,1),COLORFFFF00;
    {STICKLINE(FILTER(VB4=1,5),36,0,1.25,0),COLORRED;
    STICKLINE(FILTER(VB4=1,5),35,0,0.35,1),COLORRED,COLORYELLOW;}
    震幅0:=(H-L)/REF(C,1)*100;
    震幅:震幅0,NODRAW,COLORRED;
    超级大盘股:FINANCE(7)>=8000000000,COLORRED,NODRAW;
    大盘股:FINANCE(7)<8000000000ANDFINANCE(7)>=800000000,COLORYELLOW,NODRAW;
    中盘股:FINANCE(7)<800000000ANDFINANCE(7)>=400000000,COLORGREEN,NODRAW;
    小盘股:FINANCE(7)<400000000,COLORWHITE,NODRAW;
    盘小绩优:FINANCE(7)<1000000000ANDDYNAINFO(39)>0ANDDYNAINFO(39)<=28,COLOR9933FF,NODRAW;
    获利:WINNER(C)*100,COLORLIBLUE,LINETHICK2,NODRAW;
    {IF(获利>=90,获利,DRAWNULL),COLORYELLOW,LINETHICK2;
    IF(获利>80AND获利<90,获利,DRAWNULL),COLORRED,LINETHICK2;
    IF(获利>50AND获利<80,获利,DRAWNULL),COLORLIRED,LINETHICK2;}
    STICKLINE(获利<=5,-50,-48,2,0),COLORBLUE;
    STICKLINE(获利>=5AND获利<10,-50,-46,2,0),COLORLIBLUE;
    STICKLINE(获利>=10AND获利<20,-50,-44,2,0),COLORLIGREEN;
    STICKLINE(获利>=20AND获利<50,-50,-42,2,0),COLORWHITE;
    STICKLINE(获利>=50AND获利<80,-50,-40,2,0),COLORLIRED;
    STICKLINE(获利>=80AND获利<90,-50,-38,2,0),COLORRED;
    STICKLINE(获利>=90AND获利<=100,-50,-36,2,0),COLORYELLOW;
    XHHJ1:=XH2+XH6+XH9+XH15;
    XHHJ2:=XH3+XH4+XH5+XH1;
    XHHJ3:=XH12+XH13+XH14+XH2;
    XG1:=(XHHJ1=4);
    XG2:=(XHHJ2=4);
    XG3:=(XHHJ3=4);
    DRAWTEXT(XG1,-18,'K');DRAWTEXT(XG2,-25,'M');DRAWTEXT(XG3,-32,'R');
    {DRAWICON(XG2ANDCROSS(DIF60,DEA60),90,26);}
    DRAWICON(CROSS(XHHJ1,3)ORCROSS(XHHJ2,3),94,23);
    DRAWTEXT(VOL>=MAV200*2ANDVOL<MAV200*3,96,'2');
    DRAWTEXT(VOL>=MAV200*3ANDVOL<MAV200*4,96,'3');
    DRAWTEXT(VOL>=MAV200*4ANDVOL<MAV200*5,96,'4');
    DRAWTEXT(VOL>=MAV200*5ANDVOL<MAV200*6,96,'5');
    DRAWTEXT(VOL>=MAV200*6ANDVOL<MAV200*7,96,'6');
    DRAWTEXT(VOL>=MAV200*7ANDVOL<MAV200*8,96,'7');
    DRAWTEXT(VOL>=MAV200*8ANDVOL<MAV200*9,96,'8');
    DRAWTEXT(VOL>=MAV200*9ANDVOL<MAV200*10,96,'9');
    DRAWTEXT(VOL>=MAV200*10,96,'10');
    量比:DYNAINFO(17),NODRAW;





七绝剑气指标公式源码注释翻译结果




    W赋值:10
    W2赋值:6
    W3赋值:1
    N1赋值:60
    100,画黑色
    80,画黑色
    VOLUME赋值:成交量(手),VOLSTICK
    MAVOL1赋值:VOLUME的5日简单移动平均
    MAVOL2赋值:VOLUME的10日简单移动平均
    SSTS赋值:首次收盘价>0距今天数
    N4赋值:如果SSTS<N1,返回SSTS,否则返回N1
    MAV200赋值:成交量(手)的N4日指数移动平均
    QD1赋值:如果MAVOL1>=MAVOL2,返回10,否则返回0
    PJJ赋值:以0.9为权重(最高价+最低价+收盘价*2)/4的动态移动平均
    JJ赋值:1日前的PJJ的3日指数移动平均
    QJJ赋值:成交量(手)/((最高价-最低价)*2-收盘价-开盘价的绝对值)
    XVL赋值:如果收阳线,返回QJJ*(最高价-最低价),否则返回如果收阴线,返回QJJ*(最高价-开盘价+收盘价-最低价),否则返回成交量(手)/2+如果收阳线,返回0-QJJ*(最高价-收盘价+开盘价-最低价),否则返回如果收阴线,返回0-QJJ*(最高价-最低价),否则返回0-成交量(手)/2
    HSL赋值:(XVL/20)/1.15
    攻击流量赋值:((HSL*0.55+(1日前的HSL*0.33))+(2日前的HSL*0.22))
    GJJ赋值:攻击流量的8日指数移动平均
    LLJX赋值:攻击流量的3日指数移动平均
    资金流量赋值:LLJX,线宽为0,COLOR0000FF
    A10赋值:资金流量>0
    QD2赋值:如果资金流量>=0,返回10,否则返回0
    DIF60赋值:收盘价的12/2日指数移动平均-收盘价的26/2日指数移动平均
    DEA60赋值:DIF60的9/2日指数移动平均
    QD3赋值:如果DIF60>=DEA60,返回10,否则返回0
    RSV60赋值:(收盘价-36日内最低价的最低值)/(36日内最高价的最高值-36日内最低价的最低值)
    K60赋值:RSV60的3日[1日权重]移动平均
    D60赋值:K60的3日[1日权重]移动平均
    QD4赋值:如果K60>=D60,返回10,否则返回0
    DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
    DEA赋值:DIF的9日指数移动平均
    QD5赋值:如果DIF>=DEA,返回10,否则返回0
    周MD赋值:MACD.DIF[取周线数据]
    周MA赋值:MACD.DEA[取周线数据]
    QD6赋值:如果周MD>=周MA,返回10,否则返回0
    月MD赋值:MACD.DIF[取月线数据]
    月MA赋值:MACD.DEA[取月线数据]
    QD7赋值:如果月MD>=月MA,返回10,否则返回0
    RSV赋值:(收盘价-12日内最低价的最低值)/(12日内最高价的最高值-12日内最低价的最低值)
    K赋值:RSV的3日[1日权重]移动平均
    D赋值:K的3日[1日权重]移动平均
    J赋值:3*K-2*D
    QD8赋值:如果K>=D,返回10,否则返回0
    周K赋值:"KDJ的K[取周线数据]"(9,3,3)的5日简单移动平均
    周D赋值:"KDJ的D[取周线数据]"(9,3,3)的5日简单移动平均
    周J赋值:"KDJ的J[取周线数据]"(9,3,3)的5日简单移动平均
    QD9赋值:如果周K>=周D,返回10,否则返回0
    QD10赋值:如果周K>=周D,返回10,否则返回0
    QD11赋值:如果周J>=1日前的周J,返回10,否则返回0
    当满足条件周K>=1日前的周KANDDIF60>=DEA60时,在85位置画25号图标
    月K赋值:"KDJ的K[取月线数据]"
    月D赋值:"KDJ的D[取月线数据]"
    QD12赋值:如果月K>=月D,返回10,否则返回0
    日RSI1赋值:"RSI的RSI1[取日线数据]"(9)
    日RSI2赋值:"RSI的RSI2[取日线数据]"(9)
    QD13赋值:如果日RSI1>=日RSI2,返回10,否则返回0
    周RSI1赋值:"RSI的RSI1[取周线数据]"(9)
    周RSI2赋值:"RSI的RSI2[取周线数据]"(9)
    QD14赋值:如果周RSI1>=周RSI2,返回10,否则返回0
    月RSI1赋值:"RSI的RSI1[取月线数据]"(9)
    月RSI2赋值:"RSI的RSI1[取月线数据]"(9)
    QD15赋值:如果月RSI1>=月RSI2,返回10,否则返回0
    XH1赋值:如果DIF60>=DEA60,返回1,否则返回0
    XH2赋值:如果K60>=D60,返回1,否则返回0
    XH3赋值:如果DIF>=DEA,返回1,否则返回0
    XH4赋值:如果周MD>=周MA,返回1,否则返回0
    XH5赋值:如果月MD>=月MA,返回1,否则返回0
    XH6赋值:如果K>=D,返回1,否则返回0
    XH7赋值:如果周K>=1日前的周K,返回1,否则返回0
    XH8赋值:如果周J>=1日前的周J,返回1,否则返回0
    XH9赋值:如果月K>=月D,返回1,否则返回0
    XH10赋值:如果MAVOL1>MAVOL2,返回1,否则返回0
    XH11赋值:如果资金流量>0,返回1,否则返回0
    XH12赋值:如果日RSI1>=日RSI2,返回1,否则返回0
    XH13赋值:如果周RSI1>=周RSI2,返回1,否则返回0
    XH14赋值:如果月RSI1>=月RSI2,返回1,否则返回0
    XH15赋值:如果周K>=周D,返回1,否则返回0
    ZTB赋值:统计5日中满足收盘价/1日前的收盘价>=1.09的天数>=1
    输出XHHJ:XH1+XH2+XH3+XH4+XH6+XH7+XH8+XH5+XH9+XH10+XH11+XH12+XH13+XH14+XH15,NODRAW
    当满足条件XHHJ<8时,在0和XHHJ*5位置之间画柱状线,宽度为2,0不为0则画空心柱.,画淡绿色
    当满足条件XHHJ>=8ANDXHHJ<10时,在0和XHHJ*5位置之间画柱状线,宽度为2,0不为0则画空心柱.,画淡红色
    当满足条件XHHJ>=10时,在0和XHHJ*5位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
    能量线赋值:100*(收盘价-34日内最低价的最低值)/(34日内最高价的最高值-34日内最低价的最低值)的3日指数移动平均,线宽为0
    RSI赋值:收盘价-1日前的收盘价和0的较大值的6日[1日权重]移动平均/收盘价-1日前的收盘价的绝对值的6日[1日权重]移动平均*100,线宽为0
    RSV1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100,线宽为0
    K1赋值:RSV1的3日[1日权重]移动平均
    D1赋值:K1的3日[1日权重]移动平均
    J1赋值:3*K1-2*D1,线宽为0
    威廉WR赋值:(14日内最高价的最高值-收盘价)/(14日内最高价的最高值-14日内最低价的最低值)*100,线宽为0
    TYP赋值:(最高价+最低价+收盘价)/3
    CCI赋值:(TYP-TYP的14日简单移动平均)/(0.015*TYP的14日平均绝对偏差),线宽为0
    输出五指A:(能量线+RSI+J-威廉WR+CCI)/5的5日加权移动平均
    输出五指B:(能量线+RSI+J-威廉WR+CCI)/5的13日加权移动平均
    (能量线+RSI+J-威廉WR+CCI)/5的5日加权移动平均,COLOR00FF00,线宽为3
    如果五指A>1日前的五指A,返回五指A,否则返回无效数,COLOR0000FF,线宽为3
    KC赋值:((2*收盘价+最高价+最低价)/4*0.618+收盘价*0.382)的3日线性回归预测值
    AAX赋值:(KC-KC的9日简单移动平均)/KC的9日简单移动平均*100
    VAR0赋值:最近55日存在KC和9的较小值
    AAX1赋值:AAX的VAR0日指数移动平均*VAR0
    AAX2赋值:AAX1的3日简单移动平均
    AAX3赋值:AAX1的5日简单移动平均
    卖赋值:AAX3>3ANDAAX1<1日前的AAX1ANDCROSS(AAX2,AAX1)
    VBA赋值:卖的5日过滤
    当满足条件VBA时,在五指A*1.08位置书写文字,画黄色
    当满足条件VBA=1的3日过滤时,在五指A位置画2号图标,COLORFFFF00
    当满足条件1日前的五指A上穿五指AAND五指B<1日前的五指BAND五指A>-20时,在五指A*1位置书写文字,COLORFFFF00
    VB2赋值:收盘价-1日前的收盘价的6日指数移动平均的6日指数移动平均/收盘价-1日前的收盘价的绝对值的6日指数移动平均的6日指数移动平均*100
    VB3赋值:如果3日内VB2的最低值=11日内VB2的最低值ANDCOUNT(VB2<0,2)ANDCROSS(VB2,VB2的2日简单移动平均),返回1,否则返回0
    VB4赋值:VB3=1的5日过滤
    当满足条件VB4时,在五指A*1位置书写文字,COLORD9D919
    当满足条件五指A上穿五指B时,在五指A*1位置书写文字,画黄色
    当满足条件VB4=1的3日过滤时,在五指A位置画1号图标,COLORFFFF00
    震幅0赋值:(最高价-最低价)/1日前的收盘价*100
    输出震幅:震幅0,NODRAW,画红色
    输出超级大盘股:流通股本(股)>=8000000000,画红色,NODRAW
    输出大盘股:流通股本(股)<8000000000ANDFINANCE(7)>=800000000,画黄色,NODRAW
    输出中盘股:流通股本(股)<800000000ANDFINANCE(7)>=400000000,画绿色,NODRAW
    输出小盘股:流通股本(股)<400000000,画白色,NODRAW
    输出盘小绩优:流通股本(股)<1000000000ANDDYNAINFO(39)>0ANDDYNAINFO(39)<=28,COLOR9933FF,NODRAW
    输出获利:以收盘价计算的获利盘比例*100,画淡蓝色,线宽为2,NODRAW
    当满足条件获利<=5时,在-50和-48位置之间画柱状线,宽度为2,0不为0则画空心柱.,画蓝色
    当满足条件获利>=5AND获利<10时,在-50和-46位置之间画柱状线,宽度为2,0不为0则画空心柱.,画淡蓝色
    当满足条件获利>=10AND获利<20时,在-50和-44位置之间画柱状线,宽度为2,0不为0则画空心柱.,画淡绿色
    当满足条件获利>=20AND获利<50时,在-50和-42位置之间画柱状线,宽度为2,0不为0则画空心柱.,画白色
    当满足条件获利>=50AND获利<80时,在-50和-40位置之间画柱状线,宽度为2,0不为0则画空心柱.,画淡红色
    当满足条件获利>=80AND获利<90时,在-50和-38位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
    当满足条件获利>=90AND获利<=100时,在-50和-36位置之间画柱状线,宽度为2,0不为0则画空心柱.,画黄色
    XHHJ1赋值:XH2+XH6+XH9+XH15
    XHHJ2赋值:XH3+XH4+XH5+XH1
    XHHJ3赋值:XH12+XH13+XH14+XH2
    XG1赋值:(XHHJ1=4)
    XG2赋值:(XHHJ2=4)
    XG3赋值:(XHHJ3=4)
    当满足条件XG1时,在-18位置书写文字
    当满足条件XG2时,在-25位置书写文字
    当满足条件XG3时,在-32位置书写文字
    当满足条件XHHJ1上穿3ORCROSS(XHHJ2,3)时,在94位置画23号图标
    当满足条件成交量(手)>=MAV200*2ANDVOL<MAV200*3时,在96位置书写文字
    当满足条件成交量(手)>=MAV200*3ANDVOL<MAV200*4时,在96位置书写文字
    当满足条件成交量(手)>=MAV200*4ANDVOL<MAV200*5时,在96位置书写文字
    当满足条件成交量(手)>=MAV200*5ANDVOL<MAV200*6时,在96位置书写文字
    当满足条件成交量(手)>=MAV200*6ANDVOL<MAV200*7时,在96位置书写文字
    当满足条件成交量(手)>=MAV200*7ANDVOL<MAV200*8时,在96位置书写文字
    当满足条件成交量(手)>=MAV200*8ANDVOL<MAV200*9时,在96位置书写文字
    当满足条件成交量(手)>=MAV200*9ANDVOL<MAV200*10时,在96位置书写文字
    当满足条件成交量(手)>=MAV200*10时,在96位置书写文字
    输出量比:量比,NODRAW


神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论