神奇指标网
神奇指标网

通达信买入止盈指标公式

浏览 497次浏览
标签: 指标公式
来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15

  

以下是通达信买入止盈指标公式源码和注释翻译结果


使用说明:


   当买入止盈指标达到或超过预设的盈利百分比阈值时,表示股票的盈利潜力已经实现,投资者可以考虑卖出以保护盈利。

   当买入止盈指标持续下跌或逼近零轴附近时,可能意味着股票的盈利空间有限或出现盈利回吐的风险,投资者可以考虑及时了结盈利或调整止盈点位。


通达信买入止盈指标公式源码:


    A=ZIG(2,5);
    fxdd=A>REF(A,1)ANDREF(A,2)>REF(A,1);
    gddz=IF(fxdd,REF(LOW,1),0);
    支撑位:=IF(gddz=0,REF(LOW,BARSLAST(fxdd)+1),REF(LOW,1));
    zcw:=IF(支撑位=REF(支撑位,1),支撑位,DRAWNULL);
    B=ZIG(1,5);
    fxgd=B<REF(B,1)ANDREF(B,2)<REF(B,1);
    ggdz=IF(fxgd,REF(HIGH,1),0);
    压力位:=IF(ggdz=0,REF(HIGH,BARSLAST(fxgd)+1),REF(HIGH,1));
    ylw:=IF(压力位=REF(压力位,1),压力位,DRAWNULL);
    scmd1:=BARSLAST((支撑位>REF(支撑位,1)OR支撑位<REF(支撑位,1))ANDCLOSE>支撑位);
    scmd2:=BARSLAST(压力位>REF(压力位,1)OR压力位<REF(压力位,1));
    IF(scmd1<scmd2)
    mmsj:LOW-zcw;
    ELSE
    mmsj:HIGH-ylw;
    IF((支撑位>REF(支撑位,1)OR支撑位<REF(支撑位,1))ANDCLOSE>支撑位)
    {
    DRAWTEXT(1,-0.2,'介入'),colorred;
    VERLINE(1,1),colorred;
    }
    IF(压力位>REF(压力位,1)OR压力位<REF(压力位,1))
    {
    DRAWTEXT(1,0.2,'止盈'),coloryellow;
    VERLINE(1,1),coloryellow;
    }
    IF(mmsj<0ANDREF(mmsj,2)>0ANDscmd2>2)
    {
    DRAWTEXT(1,0.2,'止损'),coloryellow;
    VERLINE(1,1),coloryellow;
    }
    P1:=10;P2:=10;P3:=20;
    Var1:=INDEXA/100000000;
    Var2:=INDEXADV;
    Var3:=INDEXDEC;
    Var4:=Var2/(Var2+Var3)*Var1;
    Var5:=Var3/(Var2+Var3)*Var1;
    Var6:=EMA(Var4,P1);
    Var7:=EMA(Var5,P1);
    Var8:=EMA(Var6,P2);
    Var9:=EMA(Var7,P3);
    A1:=EMA(Var6,3);
    X1:=EMA(Var8,6);
    Y1:=EMA(Var9,2);
    VarA:=X1-Y1;
    VarB:=X1-REF(X1,1)>0ANDREF(X1,1)-REF(X1,2)<0;
    VarC:=IF(CROSS(a1,X1)ANDX1<=20,30,0);
    if(a1>X1,A1,X1),stick,linethick2,COLORRED;X1,stick,linethick2,COLOR000000;
    if(a1<X1,a1,X1),COLORGREEN;
    A:A1;
    X:X1;
    Y:Y1;
    80,POINTDOT;
    20,POINTDOT;
    抄:=VarC;
    排序:if(抄>0,80,0),STICK,COLORWHITE;
    出击:if(排序>0,80,1);
    {RAWTEXT(排序>0,60,'★出击')COLORWHITE;}






通达信买入止盈指标公式源码注释翻译结果



    A=最低价5%的之字转向
    FXDD=A>
    1日前的AANDREF(A,2)>
    1日前的A
    GDDZ=如果FXDD,返回1日前的最低价,否则返回0
    支撑位赋值:如果GDDZ=0,返回上次FXDD距今天数+1日前的最低价,否则返回1日前的最低价
    ZCW赋值:如果支撑位=1日前的支撑位,返回支撑位,否则返回无效数
    B=最高价5%的之字转向
    FXGD=B<
    1日前的BANDREF(B,2)<
    1日前的B
    GGDZ=如果FXGD,返回1日前的最高价,否则返回0
    压力位赋值:如果GGDZ=0,返回上次FXGD距今天数+1日前的最高价,否则返回1日前的最高价
    YLW赋值:如果压力位=1日前的压力位,返回压力位,否则返回无效数
    SCMD1赋值:上次(支撑位>距今天数
    1日前的支撑位OR支撑位<
    1日前的支撑位)ANDCLOSE>
    支撑位)
    SCMD2赋值:上次压力位>距今天数
    1日前的压力位OR压力位<
    1日前的压力位)
    如果SCMD1<,返回?,否则返回?
    输出SCMD2)MMSJ:最低价-ZCW
    输出ELSEMMSJ:最高价-YLW
    如果(支撑位>,返回?,否则返回?
    1日前的支撑位OR支撑位<
    1日前的支撑位)ANDCLOSE>
    支撑位)如果压力位>,返回?,否则返回?
    1日前的压力位OR压力位<
    1日前的压力位)如果MMSJ<,返回?,否则返回?
    0ANDREF(MMSJ,2)>
    0ANDSCMD2>
    P1赋值:10
    P2赋值:10
    P3赋值:20
    VAR1赋值:大盘的成交额/100000000
    VAR2赋值:大盘的上涨家数
    VAR3赋值:大盘的下跌家数
    VAR4赋值:VAR2/(VAR2+VAR3)*VAR1
    VAR5赋值:VAR3/(VAR2+VAR3)*VAR1
    VAR6赋值:VAR4的P1日指数移动平均
    VAR7赋值:VAR5的P1日指数移动平均
    VAR8赋值:VAR6的P2日指数移动平均
    VAR9赋值:VAR7的P3日指数移动平均
    A1赋值:VAR6的3日指数移动平均
    X1赋值:VAR8的6日指数移动平均
    Y1赋值:VAR9的2日指数移动平均
    VARA赋值:X1-Y1
    VARB赋值:X1-1日前的X1>0ANDREF(X1,1)-2日前的X1<0
    VARC赋值:如果A1上穿X1ANDX1<=20,返回30,否则返回0
    如果A1>X1,返回A1,否则返回X1,STICK,线宽为2,画红色
    X1,STICK,线宽为2,COLOR000000
    如果A1<X1,返回A1,否则返回X1,画绿色
    输出A:A1
    输出X:X1
    输出Y:Y1
    80,POINTDOT
    20,POINTDOT
    抄赋值:VARC
    输出排序:如果抄>0,返回80,否则返回0,STICK,画白色
    输出出击:如果排序>0,返回80,否则返回1




通达信买入止盈指标公式截图


神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论