神奇指标网
神奇指标网

通达信七彩神龙指标公式-通达信指标公式

浏览 325次浏览
标签: 指标公式
来源:神奇指标网 编辑:神奇指标网 发布日期:2024-01-03

  

以下是通达信七彩神龙指标公式源码和截图


通达信七彩神龙指标公式源码:

   VAR1:=(Ema(AMOUNT,5)/EMA(vol,5)/100-EMA(AMOUNT,125)/EMA(VOL,125)/100)/(EMA(AMOUNT,5)/EMA(VOL,5)/100)<-0.4;

   VAR2:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;

   VAR3:=SMA(VAR2,3,1);

   VAR4:=SMA(VAR3,3,1);

   VAR5:=(-100)*(HHV(HIGH,52)-CLOSE)/(HHV(HIGH,52)-LLV(LOW,52));

   VAR6:=COUNT(VAR1,5)>=1AND(VAR5<-99.9ORVAR4<15ANDVAR3<12);

   VAR7:=VOL/FINANCE(7);

   VAR8:=100*WINNER(CLOSE);

   VAR9:=MA(VAR8,3);

   VARA:=MA(VAR7,34);

   VARB:=VAR9<VARA*100ANDVAR8<VAR7;

   VARC:=SUM(IF(CLOSE>REF(CLOSE,1),1,0),0);

   VARD:=SUMBARS(VOL,CAPITAL);

   VARE:=IF(CLOSE>LLV(CLOSE,VARD),1,-1)*IF(VARC>LLV(VARC,VARD),1,-1);

   VARF:=COUNT(IF(VARE=-1,1,0)=1,8)>2;

   VAR10:=(CLOSE-DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100)))/DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100))*100<-18;

   VAR11:=(CLOSE-MIN(REF(CLOSE,5)*0.865,REF(CLOSE,21)*0.772))/CLOSE<0.01;

   VAR12:=VARFANDVAR10ANDVAR11;

   VAR13:=VOL/CAPITAL>=0.02ANDVOL/CAPITAL<=0.2ANDOPEN=1.105;

   VAR14:=VAR13ANDCOUNT(VAR13,5)=1;

   VAR15:=VAR12ORVAR13;

   VAR16:=REF(CLOSE,1);

   VAR17:=SMA(MAX(CLOSE-VAR16,0),7,1)/SMA(Abs(CLOSE-VAR16),7,1)*100;

   VAR18:=SMA(MAX(CLOSE-VAR16,0),13,1)/SMA(ABS(CLOSE-VAR16),13,1)*100;

   VAR19:=VAR17<20ANDVAR18<25;

   VAR1A:=VAR19;

   VAR1B:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),0-VOL,0)),0);

   VAR1C:=IF(CLOSE>LLV(CLOSE,VARD),1,-1);

   VAR1D:=IF(VAR1B>LLV(VAR1B,VARD),1,-1);

   VAR1E:=VAR1C*VAR1D;

   VAR1F:=IF(VAR1E=-1,1,0);

   VAR20:=VAR1FANDCLOSE=LLV(CLOSE,120)ANDVAR8<VAR7;

   VAR21:=IF(FILTER(VAR6ANDVARBANDVAR15ANDVAR1AANDVAR20>0,4),70,0);

   VAR22:=IF(VARBANDVAR1AANDVAR20>0,50,0);

   持仓区:stICKLINE(CLOSE>EMA(CLOSE,20),80,85,8,1);

   空仓区:STICKLINE(CLOSE<EMA(CLOSE,20),80,85,8,1);

   VAR23:=HHV(HIGH,9)-LLV(LOW,9);

   VAR24:=HHV(HIGH,9)-CLOSE;

   VAR25:=CLOSE-LLV(LOW,9);

   VAR26:=VAR24/VAR23*100-70;

   VAR27:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;

   VAR28:=(2*CLOSE+HIGH+LOW)/4;

   VAR29:=SMA(VAR25/VAR23*100,3,1);

   VAR2A:=LLV(LOW,34);

   VAR2B:=SMA(VAR29,3,1)-SMA(VAR26,9,1);

   VAR2C:=IF(VAR2B>100,VAR2B-100,0);

   VAR2D:=HHV(HIGH,34);

   VAR2E:=EMA((VAR28-VAR2A)/(VAR2D-VAR2A)*100,13);

   VAR2F:=EMA(0.667*REF(VAR2E,1)+0.333*VAR2E,2);

   神龙飞天:VAR2F;

   STICKLINE(VAR2E-VAR2F>0,VAR2E,VAR2F,8,0),COLORRED;

   STICKLINE(VAR2E-VAR2F<0,VAR2E,VAR2F,8,0),COLORGREEN;

   潜龙能量:(VAR2E-VAR2F)*5;

   STICKLINE(潜龙能量>=0,0,潜龙能量*1,4,0);

   STICKLINE(潜龙能量>=0,0,潜龙能量*0.8,4,0);

   STICKLINE(潜龙能量>=0,0,潜龙能量*0.6,4,0);

   STICKLINE(潜龙能量>=0,0,潜龙能量*0.4,4,0);

   STICKLINE(潜龙能量>=0,0,潜龙能量*0.2,4,0);

   STICKLINE(潜龙能量<0,0,潜龙能量*1,4,0);

   STICKLINE(潜龙能量<0,0,潜龙能量*0.8,4,0);

   STICKLINE(潜龙能量<0,0,潜龙能量*0.6,4,0);

   STICKLINE(潜龙能量<0,0,潜龙能量*0.4,4,0);

   STICKLINE(潜龙能量<0,0,潜龙能量*0.2,4,0);

   M:=13;N:=30;

   A01:=(C+O+L+H)/4;

   A02:=(WINNER((A01*1.04))*100.000);

   A03:=(WINNER((A01*0.96))*100.000);

   A04:A03,NODRAW;

   A08:A02-A03,NODRAW;

   A06:(100.000-A02),NODRAW;

   STICKLINE(1.000,0,A04,2,0),COLORRED;

   STICKLINE(1.000,100.000,A02,2,0),COLORGREEN;

   STICKLINE(1.000,A04,(100-A06),2,0),COLORYELLOW;

   A0A:=(((((HHV(A04,15.000)-A03)/A03)*100.000)>N)AND(HHV(A04,15.000)>50.000));

   STICKLINE(A0A,(0-2.000),2.000,4,0),COLORYELLOW;

   STICKLINE(NOT(A0A),(0-2.000),2.000,4,0),COLORMAGENTA;

   获利:MA(A03,M),COLORRED,LINETHICK3;

   浮动:(MA(A02,M)-MA(A03,M)),COLORYELLOW,LINETHICK3;

   套牢:(100.000-MA(A02,M)),COLORGREEN,LINETHICK3;

   A3:(EMA(CLOSE,5)+MA(CLOSE,10)+MA(CLOSE,15))/3,COLORRED;

   A4:(EMA(CLOSE,20)+MA(CLOSE,25)+MA(CLOSE,30))/3,COLOR00FF00;

   A5:(EMA(CLOSE,40)+MA(CLOSE,50)+MA(CLOSE,60))/3,COLORBLUE;

   A6:(EMA(CLOSE,80)+MA(CLOSE,85)+MA(CLOSE,90))/3,COLORFF9900;

   A7:(EMA(CLOSE,120)+MA(CLOSE,130)+MA(CLOSE,150))/3,COLOR0000FF;

   A8:(EMA(CLOSE,160)+MA(CLOSE,170)+MA(CLOSE,180))/3,COLORBLUE;

   A9:(EMA(CLOSE,200)+MA(CLOSE,225)+MA(CLOSE,250))/3,COLOR00FF00;

   V1:EMA(CLOSE,5),COLORBLUE;

   V2:EMA((EMA(CLOSE,29))*(1.01),10),COLORFF00FF;

   DRAWICON(CROSS(V1,V2),V2,1),COLOR00FF00;

   DRAWTEXT(CROSS(V1,V2),L,'买入');

   V3:EMA(CLOSE,10),COLORFFFFFF;

   V4:EMA((EMA(CLOSE,60))*(0.99),10),COLORFFFF00;

   DRAWICON(CROSS(V3,V4),V2,1),COLOR0000FF;

   VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;

   DRAWTEXT(IF(CLOSE<VF1ANDVOL/240>MA(VOL,5)/240ANDCLOSE>=REF(CLOSE,1)*1.08ANDCLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'☆'),COLORRED;

   VARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

   VARB:=EMA(0.667*REF(VARA,1)+0.333*VARA,5);

   DRAWTEXT(IF(VOL>=1.3*MA(VOL,5)ANDCOUNT(VARA>=VARBANDVARA<-17,3)ANDREF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入');

   VARR1:=SMA(MAX(CLOSE-REF(C,1),0),12,1)/SMA(ABS(CLOSE-REF(C,1)),15,1)*100;

   DRAWTEXT(CROSS(82,VARR1),HIGH,'卖出');

   DRAWICON(CROSS(82,VARR1),HIGH,2);




通达信七彩神龙指标公式截图

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论