神奇指标网
神奇指标网

通达信区间历史资料主图指标公式_通达信指标公式

浏览 134次浏览
标签: 主图
来源:神奇指标网 编辑:神奇指标网 发布日期:2024-01-12

  

以下是通达信区间历史资料主图指标公式源码和截图


通达信区间历史资料主图指标公式源码:


   超:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

   指:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;

   GGFFF1:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

   BIAS:=(超+2*指+3*GGFFF1)/6;

   AA:=MA(BIAS,3);

   BB:STICKLINE(AA<-12ANDAA>=-18,2,0,6,0),COLORRED;

   CC:IF(AA<-18,3,0),COLORFF35FF,LINETHICK1;

   STICKLINE(AA<-18,3,0,6,0),COLORFF35FF;

   GFFCC1:=DMA(CLOSE,vol/MA(VOL,4)/4);

   GFFCC2:=DMA(CLOSE,VOL/MA(VOL,31)/31);

   GFFCC3:=(CLOSE-GFFCC1)/GFFCC1*100<-10;

   GFFCC4:=(GFFCC1-GFFCC2)/GFFCC2*100<-16;

   GFFCC5:=(CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100<-23;

   GFFCC6:=SMA(MAX(CLOSE-REF(CLOSE,1),0),3,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),3,1)*100>16;

   GFFCC7:=100*(HHV(HIGH,27)-CLOSE)/(HHV(HIGH,27)-LLV(LOW,27));

   GFFCC8:=INDEXC;

   GFFCC9:=MA(GFFCC8,6);

   GFFCCA:=MA(GFFCC8,24);

   GFFCCB:=MA(GFFCC8,32);

   GFFCCC:=GFFCCB>GFFCC9*1.11ANDGFFCCA>GFFCC9*1.095;

   SSS:=(GFFCC3ANDGFFCC4AND(OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07ORGFFCC5ANDGFFCC6ANDCROSS(GFFCC7,79)ORGFFCCC)*100;

   DD:SSS>0,COLORWHITE,LINETHICK1;

   N:=8;

   趋势:=zig(3,N);

   DRAWBAND(趋势,RGB(255,255,255),趋势,RGB(255,255,255));

   ↑转向:=TROUGHBARS(3,N,1);

   ↓转向:=PEAKBARS(3,N,1);

   L低:=IF(↑转向=0,C,IF(↓转向<↑转向,TROUGH(3,N,1),REF(TROUGH(3,N,1),1)));

   H高:=IF(↓转向=0,C,IF(↑转向<↓转向,PEAK(3,N,1),REF(PEAK(3,N,1),1)));

   低高运行:=REF(BArslAst(趋势<REF(趋势,1)),BARSLAST(↓转向=0));

   高低运行:=REF(BARSLAST(趋势>REF(趋势,1)),BARSLAST(↑转向=0));

   现区间运行天数:IF(↑转向<↓转向,BARSLAST(趋势<REF(趋势,1)),BARSLAST(趋势>REF(趋势,1))),COLORFF00FF,NODRAW;

   前1区间运行:=IF(↑转向<↓转向,高低运行,低高运行);

   高低距:=REF(H高-L低,BARSLAST(↓转向<↑转向AND↓转向>0AND趋势>L低));

   低高距:=REF(H高-L低,BARSLAST(↑转向<↓转向AND↑转向>0AND趋势<H高));

   前1区间距:=IF(↑转向>↓转向,高低距,低高距);

   区间涨%:=IF(↑转向<↓转向,(C/L低-1)*100,REF((C/L低-1)*100,↓转向));

   区间跌%:=IF(↓转向<↑转向,(C/H高-1)*100,REF((C/H高-1)*100,↑转向));

   现区间涨跌:IF(ISLASTBARAND趋势<REF(趋势,1),区间跌%,区间涨%),COLORFFFF00,NODRAW;

   上:IF(趋势>REF(趋势,1),趋势,DRAWNULL),COLORRED,LINETHICK2;

   下:IF(趋势<REF(趋势,1),趋势,DRAWNULL),COLORGREEN,LINETHICK2;

   STICKLINE(↑转向=0,L*0.95,H高,0,0),COLOR00FF00;

   STICKLINE(↓转向=0,H*1.03,L低,0,0),COLORFF00FF;

   STICKLINE(BETWEEN(↑转向,0,7),L低,L低,3,1),COLOR00FFFF;

   STICKLINE(BETWEEN(↓转向,0,7),H高,H高,3,1),COLOR00FF00;

   STICKLINE(↑转向<↓转向,L低,L低,1,1),COLOR00FFFF;

   STICKLINE(↓转向<↑转向,H高,H高,1,1),COLOR00FF00;

   DRAWNUMBER(↑转向=0,L*0.98,前1区间运行),COLORFFFFFF;

   DRAWNUMBER(↑转向=0,H高,Abs(H高-L低)),COLORFF0000;

   DRAWNUMBER(↑转向=0,(H高+L低)/2,区间跌%),COLORFFFF00;

   DRAWNUMBER(↓转向=0,H*1.02,前1区间运行),COLORFFFFFF;

   DRAWNUMBER(↓转向=0,(H高+L低)/2,区间涨%),COLORFFFF00;

   DRAWNUMBER(↓转向=0,L低,ABS(H高-L低)),COLORFF0000;

   DRAWNUMBER(ISLASTBARAND趋势<REF(趋势,1),(H高+趋势)/2,区间跌%),COLORFFFF00;

   DRAWNUMBER(ISLASTBARAND趋势>REF(趋势,1),(趋势+L低)/2,区间涨%),COLORFFFF00;

   DRAWTEXT_FIX(ISLASTBAR,0,0.01,0,'■前区间运行天数。'),COLORFFFFFF;

   DRAWTEXT_FIX(ISLASTBAR,0,0.05,0,'■前区间运行价差。'),COLORFF0000;

   DRAWTEXT_FIX(ISLASTBAR,0,0.09,0,'■前区间涨跌幅度。'),COLORFFFF00;

   DRAWGBKLAst(DATE>900101,STRIP(RGB(5,5,5),RGB(5,4,100),1));

   现价:if(DYNAINFO(4)=0,C,DYNAINFO(7)),color0077FF,POINTDOT;

   X:=BArslAST(DISPSTATUS=1)+1;

   DRAWTEXTAbs(500,10,'★['+STKLABEL+']'+STKNAME+':【可视:'+X+'天,】'),Color00FFFF,LINETHICK7,LAYER0;

   ma5:MA(C,5),COLOR00FFFF,PRECIS2;

   MA10:MA(C,10),PRECIS2;

   MA20:MA(C,20),PRECIS2;

   MA30:MA(C,30),PRECIS2;

   MA60:MA(C,60),PRECIS2;

   MA120:MA(C,120),PRECIS2,LINETHICK0;

   partline(MA5,MA5>ref(MA5,1),rgb(255,0,0),MA5<ref(MA5,1),rgb(0,255,0)),LINETHICK2;

   bbi:EMA((WMA(CLOSE,3)+WMA(CLOSE,6)+WMA(CLOSE,12)+WMA(CLOSE,24))/4,13),COLOR00FF00,LINETHICK0;;

   partline(BBI,BBI>ref(BBI,1),rgb(255,0,0),BBI<ref(BBI,1),rgb(0,255,0)),LINETHICK2;

   FILLRGN(MA5,BBI,(MA5>REF(MA5,1))-1,rgb(60,0,60),1,rgb(0,0,255)),LINETHICK2,LAYER7;

   {k线}

   STICKLINE(CLOSE>OPEN,HIGH,LOW,0.5,0),COLOR0000FF;

   STICKLINE(OPEN>=CLOSE,HIGH,LOW,0.5,0),COLOR00FF00;

   STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,8,0),COLOR006600;

   STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,7,0),COLOR009900;

   STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,5,0),COLOR00BB00;

   STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLOR00DD00;

   STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1,0),COLOR00FF00;

   STICKLINE(CLOSE>OPEN,CLOSE,OPEN,8,0),COLOR000566;

   STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0),COLOR000499;

   STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0),COLOR0003bb;

   STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0),COLOR0002dd;

   STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0),COLOR0001ff;

   DRAwrECTABS(5,2,99,396,rgb(0,60,0)),COLOR44FF00,LINETHICK2,LAYER0;;

   DRAWRECTABS(100,2,420,396,rgb(40,0,50)),COLOR0044FF,LINETHICK2,LAYER0;;

   DRAWTEXTABS(20,15,'今日【C】'+NUMTOSTRN((C),2)+'元。'+NUMTOSTRN((h),2)+'元。'),COLOR44FF00,LINETHICK2,LAYER0;

   DRAWTEXTABS(20,45,'5日【C】'+NUMTOSTRN((hhv(C,5)),2)+'元。'+NUMTOSTRN((hhv(h,5)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,75,'10日【C】'+NUMTOSTRN((hhv(C,10)),2)+'元。'+NUMTOSTRN((hhv(h,10)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,105,'20日【C】'+NUMTOSTRN((hhv(C,20)),2)+'元。'+NUMTOSTRN((hhv(h,20)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,135,'30日【C】'+NUMTOSTRN((hhv(C,30)),2)+'元。'+NUMTOSTRN((hhv(h,30)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,165,'60日【C】'+NUMTOSTRN((hhv(C,60)),2)+'元。'+NUMTOSTRN((hhv(h,60)),2)+'元。'),COLOR4477FF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,195,'90日【C】'+NUMTOSTRN((hhv(C,90)),2)+'元。'+NUMTOSTRN((hhv(h,90)),2)+'元。'),COLOR00FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,225,'120日【C】'+NUMTOSTRN((hhv(C,120)),2)+'元'+NUMTOSTRN((hhv(h,120)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,255,'240日【C】'+NUMTOSTRN((hhv(C,240)),2)+'元。'+NUMTOSTRN((hhv(h,240)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,285,'480日【C】'+NUMTOSTRN((hhv(C,480)),2)+'元。'+NUMTOSTRN((hhv(h,480)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,315,'2400日【C】'+NUMTOSTRN((hhv(C,2400)),2)+'元。'+NUMTOSTRN((hhv(h,2400)),2)+'元。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,345,'最高【C】'+NUMTOSTRN((hhv(C,0)),2)+'元。'+NUMTOSTRN((hhv(h,0)),2)+'元。'),COLOR00FF00,LINETHICK2,LAYER0;

   DRAWTEXTABS(10,375,''+X+'日【C】'+NUMTOSTRN((hhv(C,X)),2)+'元。'+NUMTOSTRN((hhv(h,X)),2)+'元。'),COLOR0000FF,LINETHICK2,LAYER0;

   DRAWRECTABS(100,4,100+(C)/C*100,14,rgb(255,0,0)),LAYER0;

   DRAWRECTABS(100,34,100+(hhv(C,5))/C*100,44,rgb(0,255,0)),LAYER0;

   DRAWRECTABS(100,64,100+(hhv(C,10))/C*100,74,rgb(0,155,100)),LAYER0;

   DRAWRECTABS(100,94,100+(hhv(C,20))/C*100,104,rgb(250,55,0)),LAYER0;

   DRAWRECTABS(100,124,100+(hhv(C,30))/C*100,134,rgb(250,155,0)),LAYER0;

   DRAWRECTABS(100,154,100+(hhv(C,60))/C*100,164,rgb(0,205,200)),LAYER0;

   DRAWRECTABS(100,184,100+(hhv(C,90))/C*100,194,rgb(255,0,100)),LAYER0;

   DRAWRECTABS(100,214,100+(hhv(C,120))/C*100,224,rgb(0,155,100)),LAYER0;

   DRAWRECTABS(100,244,100+(hhv(C,240))/C*100,254,rgb(50,255,20)),LAYER0;

   DRAWRECTABS(100,274,100+(hhv(C,480))/C*100,284,rgb(250,55,0)),LAYER0;

   DRAWRECTABS(100,304,100+(hhv(C,2400))/C*100,314,rgb(0,205,20)),LAYER0;

   DRAWRECTABS(100,334,100+(hhv(C,0))/C*100,344,rgb(255,255,0)),LAYER0;

   DRAWRECTABS(100,364,100+(hhv(C,X))/C*100,374,rgb(255,0,0)),LAYER0;

   DRAWTEXTABS(280,15,''+NUMTOSTRN(vol/CAPITAL*100,2)+'%。'),COLOR00FF00,LINETHICK3,LAYER0;

   DRAWTEXTABS(280,45,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,5),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,5)/5,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,75,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,10),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,10)/10,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,105,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,20),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,20)/20,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,135,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,30),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,30)/30,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,165,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,60),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,60)/60,2)+'%。'),COLOR44FF00,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,195,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,90),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,90)/90,2)+'%。'),COLOR00FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,225,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,120),0)+'%'+NUMTOSTRN(SUM(VOL/CAPITAL*100,120)/120,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,255,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,240),0)+'%'+NUMTOSTRN(SUM(VOL/CAPITAL*100,240)/240,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,285,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,480),0)+'%'+NUMTOSTRN(SUM(VOL/CAPITAL*100,480)/480,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,315,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,2400),0)+'%'+NUMTOSTRN(SUM(VOL/CAPITAL*100,2400)/2400,2)+'%。'),COLOR44FFFF,LINETHICK2,LAYER0;

   DRAWTEXTABS(280,345,''+NUMTOSTRN((hhv(VOL/CAPITAL*100,0)),2)+'%'),COLOR00FF00,LINETHICK3,LAYER0;

   DRAWTEXTABS(280,375,''+NUMTOSTRN(SUM(VOL/CAPITAL*100,X),0)+'%。'+NUMTOSTRN(SUM(VOL/CAPITAL*100,X)/X,2)+'%。'),COLOR0044FF,LINETHICK2,LAYER0;



通达信区间历史资料主图指标公式截图

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论