神奇指标网
神奇指标网

通达信指标王之看色操作主图指标公式-通达信指标公式

浏览 140次浏览
标签: 主图
来源:神奇指标网 编辑:神奇指标网 发布日期:2024-01-15

  

以下是通达信指标王之看色操作主图指标公式源码和截图


通达信指标王之看色操作主图指标公式源码:

   今:VOL,VOLSTICK;

   五:MA(今,5);

   三十五:MA(今,35),COLORGREEN;

   一三五:MA(今,135)COLORMAGENTA,LINETHICK1;

   DRAWICON(CROSS(五,一三五),今,13);

   DRAWICON(COUNT(CROSS(五,一三五),20)=1ANDCOUNT(五<REF(五,1),5)>=3AND

   CROSS(今,五)ANDMA(C,5)>MA(C,20),今,17);

   换手:VOL/CAPITAL*100,COLORWHITE,NODRAW;

   十日换:SUM(换手,10),COLORWHITE,NODRAW;

   HS:=换手;

   HF:=HHV(今,120)/2;

   DRAWTEXT(HS<1ANDISLASTBAR,HF,'地量'),COLORYELLOW;

   DRAWTEXT(HS<2ANDHS>=1ANDISLASTBAR,HF,'低靡'),COLORMAGENTA;

   DRAWTEXT(HS<3ANDHS>=2ANDISLASTBAR,HF,'温和'),COLORYELLOW;

   DRAWTEXT(HS<5ANDHS>=3ANDISLASTBAR,HF,'活跃'),COLORRED;

   DRAWTEXT(HS<8ANDHS>=5ANDISLASTBAR,HF,'带量'),COLORGREEN;

   DRAWTEXT(HS<15ANDHS>=8ANDISLASTBAR,HF,'放量'),COLORMAGENTA;

   DRAWTEXT(HS<25ANDHS>=15ANDISLASTBAR,HF,'巨量'),COLORGREEN;

   DRAWTEXT(HS<100ANDHS>=25ANDISLASTBAR,HF,'怪异'),COLORYELLOW;

   {DRAWTEXT(CURRBARSCOUNT=40,2.5*HF,'换手<1=地量<2=低靡<3=温和<5=活跃<8=带量<15=放量<25=巨量'),COLORWHITE;}

   DRAWTEXT(CROSS(0.9,1/VOL*1000>0.01AND"KDJ.J"<0),今,'地买'),COLORGREEN;

   N:=80;M:=3;

   VAR11:=MA(C,9),COLORRED;

   上升通道:IF(VAR11>REF(VAR11,1),VAR11,DRAWNULL),LINETHICK4,COLORRED;

   下降通道:IF(VAR11<REF(VAR11,1),VAR11,DRAWNULL),LINETHICK4,COLORGREEN;

   A0:=(L+H+C*2)/4;

   AA:=EMA(A0,14)COLORYELLOW,LINETHICK1;

   BB:=EMA(A0,25)COLORYELLOW,LINETHICK2;

   A1X:=(AA-REF(AA,1))/REF(AA,1)*100;

   A2X:=(BB-REF(BB,1))/REF(BB,1)*100;

   G:=BArslAst(crOSS(A1X,0));

   必卖止损:REF(A0,G),COLORCYAN,LINETHICK1;

   A5:=EMA(CLOSE,12)-EMA(CLOSE,26);

   A6:=EMA(A5,9);

   A7:=(A5<-0.1ANDA5>A6);

   见底:IF(A7,LLV(L,21),DRAWNULL)COLORRED,CIRCLEDOT;

   见顶:IF(H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,DRAWNULL),COLORGREEN,CIRCLEDOT;

   MA5:=MA(C,5);

   MA13:=MA(C,13);

   高:=REF(HHV(H,N),M);

   低:=REF(LLV(L,N),M);

   H19:=高-(高-低)*0.191;

   H38:=高-(高-低)*0.382;

   H中:=高-(高-低)*0.5;

   H61:=高-(高-低)*0.618;

   H80:=高-(高-低)*0.809;

   顶点:REFDATE(高,DATE),COLORRED;

   %19.8:REFDATE(H19,DATE),COLORYELLOW;

   %38.2:REFDATE(H38,DATE),COLORMAGENTA;

   %50:REFDATE(H中,DATE),COLORBLUE;

   %61.8:REFDATE(H61,DATE),COLORMAGENTA;

   %80.9:REFDATE(H80,DATE),COLORYELLOW;

   低点:REFDATE(低,DATE),COLORWHITE;

   DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORRED;

   DRAWTEXT(ISLASTBAR,%19.8,'%19.8'),COLORYELLOW;

   DRAWTEXT(ISLASTBAR,%38.2,'%38.2'),COLORMAGENTA;

   DRAWTEXT(ISLASTBAR,%50,'%50'),COLORBLUE;

   DRAWTEXT(ISLASTBAR,%61.8,'%61.8'),COLORMAGENTA;

   DRAWTEXT(ISLASTBAR,%80.9,'%80.9'),COLORYELLOW;

   DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE;

   DIFF:=(EMA(CLOSE,7)-EMA(CLOSE,19));

   DEA:=EMA(DIFF,9);

   macd:=0.90*(DIFF-DEA);

   TJ:=(DIFF>=DEA);

   TJ1:=(DIFF>=0);

   STICKLINE(TJ,H,L,0.4,0),COLORYELLOW;

   STICKLINE(TJ,O,C,4,1),COLOR0088FF;

   STICKLINE(TJ,O,C,3.4,1),COLOR00AAFF;

   STICKLINE(TJ,O,C,2.8,1),COLOR00CCFF;

   STICKLINE(TJ,O,C,2,1),COLOR00ddfF;

   STICKLINE(TJ,O,C,1.2,1),COLOR55FFFF;

   STICKLINE(TJ,O,C,0.4,1),COLOR99FFFF;

   STICKLINE(TJ1ANDTJ,H,L,0.4,0),COLORF00FF0;

   STICKLINE(TJ1ANDTJ,O,C,4,1),COLORFF33FF;

   STICKLINE(TJ1ANDTJ,O,C,3.4,1),COLORFF55FF;

   STICKLINE(TJ1ANDTJ,O,C,2.8,1),COLORFF77FF;

   STICKLINE(TJ1ANDTJ,O,C,2,1),COLORFF99FF;

   STICKLINE(TJ1ANDTJ,O,C,1.2,1),COLORFFBBFF;

   STICKLINE(TJ1ANDTJ,O,C,0.4,1),COLORFFDDFF;

   STICKLINE(DIFF<DEA,H,L,0.4,0),COLORF0F000;

   STICKLINE(DIFF<DEA,O,C,4,1),COLORFF3300;

   STICKLINE(DIFF<DEA,O,C,3.4,1),COLORFF6600;

   STICKLINE(DIFF<DEA,O,C,2.8,1),COLORFF9900;

   STICKLINE(DIFF<DEA,O,C,2,1),COLORFFBB00;

   STICKLINE(DIFF<DEA,O,C,1.2,1),COLORFFDD00;

   STICKLINE(DIFF<DEA,O,C,0.4,1),COLORFFFF00;

   VAR1:=(CLOSE*2+HIGH+LOW)/4;

   SK:=EMA(VAR1,13)-EMA(VAR1,73);

   SD:=EMA(SK,2);

   SJ:=(CROSS(SK,SD)ANDSK<-0.04AND(C-REF(C,1))/REF(C,1)>=0.03)OR(CROSS(SK,SD)

   ANDSK<=-0.14)OR(CROSS(SK,SD)ANDSK<=0.05AND(V/MA(V,5)>2ORC/REF(C,1)>0.035));

   STICKLINE(SJ,H,L,0.5,0),COLORRED;

   STICKLINE(SJ,O,C,5.5,0),LINETHICK3,COLOR000055;

   STICKLINE(SJ,O,C,4.5,0),LINETHICK3,COLOR000077;

   STICKLINE(SJ,O,C,3.5,0),LINETHICK3,COLOR000099;

   STICKLINE(SJ,O,C,2.5,0),LINETHICK3,COLOR0000BB;

   STICKLINE(SJ,O,C,1.5,0),LINETHICK3,COLOR0000DD;

   STICKLINE(SJ,O,C,0.5,0),LINETHICK3,COLOR0000FF;

   EMA13:=EMA(C,13),COLORWHITE;

   EMA21:=EMA(C,21),COLORYELLOW;

   EMA34:=EMA(C,34),COLORFF00FF;

   EMA60:=MA(C,60),COLORFFCC66;

   VAR2:=(2*CLOSE+HIGH+LOW)/4;

   VAR3:=IF(YEAR>=2099ANDMONTH>2,0,1);

   VAR4:=LLV(LOW,5);VAR5:=HHV(HIGH,4);

   散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;

   庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;

   LC:=REF(CLOSE,1);

   rsi:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(Abs(CLOSE-LC),6,1)*100;

   DRAWTEXT(CROSS(84,RSI),HIGH,'←-----逃'),COLORGREEN;

   VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);

   VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05)AND((HIGH)/(CLOSE)<1.01)AND(VAR3AA>0),91,0);

   DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'←---大胆搏'),COLORYELLOW;

   VAR51:=3;

   VAR52:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));

   DRAWTEXT(CROSS(VAR52,VAR51),LOW,'←启动')COLORMAGENTA;

   ma5:MA(C,5),COLORRED,LINETHICK2;

   NOTEXT5:IF(C<MA5ORINDEXC<MA(INDEXC,5)ORMA5<REF(MA5,1),MA5,DRAWNULL),COLORGREEN,LINETHICK2;

   XG:=MA5>REF(MA5,1)ANDC<MA(C,5)ANDINDEXC>MA(INDEXC,5);

   DRAWICON(XG,L*0.98,38);

   EM3:EMA(L,3),NODRAW;

   {

   选股公式:

   XG:MA(C,5)>REF(MA(C,5),1)ANDINDEXC>MA(INDEXC,5)ANDC<MA(C,5)ANDC<L*1.005;

   }




通达信指标王之看色操作主图指标公式截图

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论