神奇指标网
神奇指标网

通达信绝佳的趋势通道指标-通达信指标公式

浏览 467次浏览
标签: 趋势
来源:神奇指标网 编辑:神奇指标网 发布日期:2024-02-28

  

以下是通达信绝佳的趋势通道指标源码和截图


通达信绝佳的趋势通道指标源码:

   N:=46;

   XX:=CLOSE;

   X1:=(MA(XX,3)+MA(XX,5)+MA(XX,8)+MA(XX,13)+MA(XX,21))/5;

   LO:=X1+5*SLOPE(X1,3);

   LL:=SMA((LO-LLV(LO,N))/(HHV(LO,N)-LLV(LO,N))*100,3,1),COLORRED;

   X:=IF(CROSS(LL,10),5,0);

   J:=EMA(LL,5);

   Y5:J-2*STD(J,10),COLORLIGRAY;

   Y2:EMA(LL,13)*1.2,COLORLIGRAY;

   DRAWBAND(Y5+3,RGB(76,76,76),Y2-3,RGB(76,76,76));{外}

   STICKLINE(LL>=90ORLL>=80,50,60,5,1),COLORBLUE;

   DRAWTEXT(IF(X>REF(X,1),-8,0),-8,'KKKK'),COLOR00FFFF,LINETHICK4;

   DRAWTEXT(CROSS(10,LL),-10,'买警'),COLORMAGENTA;

   DRAWTEXT(CROSS(LL,80),55,'卖警'),COLORYELLOW;

   STICKLINE(Y2<20,-20,-15,5,1),COLORCYAN;

   底部区域:STICKLINE(1,20,10,0,0),COLORBROWN;

   DRAWTEXT(CROSS(20,Y2),40,'入底'),COLORWHITE;

   短线:SMA((LO-LLV(LO,N))/(HHV(LO,N)-LLV(LO,N))*100,3,1),COLORRED;

   趋势:3*SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,5,1)-2*

   SMA(SMA((CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-

   LLV(LOW,N))*100,5,1),3,1),COLORGREEN;

   118,POINTDOT,COLORCYAN;

   -30,POINTDOT,COLORCYAN;

   _红柱:IF("macd.MacD">REF("maCD.MACD",1),"MACD.MACD",DRAWNULL),

   stICK,COLORRED;

   绿柱:IF("MACD.MACD"<REF("MACD.MACD",1),"MACD.MACD",DRAWNULL),

   STICK,COLORYELLOW;

   _抄底:Abs((crOSS("MACD.DIF","MACD.DEA")

   &&"MACD.DEA"<=-0.07)*"MACD.DIF")*1.50,COLORLIMAGENTA;

   _DIF:"MACD.DIF",COLORWHITE;

   _DEA:"MACD.DEA",COLORYELLOW;

   __强度:IF(_DIF>_DEA,_DIF,DRAWNULL),COLORRED,LINETHICK2;

   _强度:IF(_DEA<_DIF,_DEA,DRAWNULL),COLORMAGENTA,LINETHICK2;

   DRAWTEXT(ABS(_抄底)>0,_抄底*1.20,'抄底'),COLORYELLOW;

   DRAWICON(ABS(_抄底)>0,_抄底*1.10,4);

   DRAWICON(CROSS(_DIF,_DEA),_DEA,1);

   DRAWICON(CROSS(_DEA,_DIF),_DEA,2);

   DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);

   DEA:EMA(DIFF,9);

   MACD:2*(DIFF-DEA),COLORSTICK;

   A1:=BArslAST(REF(CROSS(DIFF,DEA),1));

   B1:=REF(C,A1+1)>CANDREF(DIFF,A1+1)<DIFFANDCROSS(DIFF,DEA);

   A2:=BARSLAST(REF(CROSS("kdj.K"(9,3,3),"kdJ.D"(9,3,3)),1));

   B2:=REF(C,A2+1)>CANDREF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3)ANDCROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));

   A3:=BARSLAST(REF(CROSS("rsi.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));

   B3:=REF(C,A3+1)>CANDREF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24)ANDCROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));

   C1:=BARSLAST(REF(CROSS(DEA,DIFF),1));

   D1:=REF(C,C1+1)<CANDREF(DIFF,C1+1)>DIFFANDCROSS(DEA,DIFF);

   C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));

   D2:=REF(C,C2+1)<CANDREF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3)ANDCROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));

   C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));

   D3:=REF(C,C3+1)<CANDREF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24)ANDCROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));

   MD底背:IF(B1>0,-0.1,0),COLORRED,POINTDOT;

   KDJ底背:IF(B2>0,-0.1,0),COLORFF00FF,POINTDOT;

   RSI底背:IF(B3>0,-0.1,0),COLORYELLOW,POINTDOT;

   MD顶背:IF(D1>0,0.1,0),COLOR00FF00,POINTDOT;

   KDJ顶背:IF(D2>0,0.1,0),COLORFFCC66,POINTDOT;

   RSI顶背:IF(D3>0,0.1,0),COLORWHITE,POINTDOT;

   STICKLINE(B1>0,-0.1,0,2,0),COLORRED;

   STICKLINE(B2>0,-0.1,0,2,0),COLORFF00FF;

   STICKLINE(B3>0,-0.1,0,2,0),COLORYELLOW;

   STICKLINE(D1>0,0.1,0,2,0),COLOR00FF00;

   STICKLINE(D2>0,0.1,0,2,0),COLORFFCC66;

   STICKLINE(D3>0,0.1,0,2,0),COLORWHITE;

   顶压:HHV(MA(H,11),50),COLOR00FFFF;

   短压:HHV(MA(H,11),15),COLOR0090E0;

   XL1:=LLV(MA(H,11),1);

   趋势:IF(XL1>=短压,短压,XL1),COLORFFFFFF;

   X1:=(3*C+H+L+O)/6;

   X2:=EMA(X1,10);

   X3:=REF(X2,1);

   X4:=(REF(HIGH,1)+REF(LOW,1))/2;

   X5:=MA(CLOSE,21)+2*STD(CLOSE,21);

   X6:=REF(CLOSE,1);{出货}

   X7:=SMA(MAX(CLOSE-X6,0),7,1)/SMA(ABS(CLOSE-X6),7,1)*100;

   X8:=CROSS(79,X7);

   X9:=FILTER(X8,4);{40}

   WZ1:=POW(MA(CLOSE,5),2)+MA(CLOSE,5);{减}

   WZ2:=POW(MA(LOW,5),2)+MA(LOW,5);

   WZ3:=POW(MA(HIGH,5),2)+MA(HIGH,5);

   WZ4:=(WZ1-LLV(WZ2,9))/(HHV(WZ3,9)-LLV(WZ2,9))*150+65;

   DK:=SMA(WZ4,3,1)*1.5;

   DD:=SMA(DK,3,1);

   DJ:=3*DK-2*DD;

   WZ5:=EMA(CLOSE,12)-EMA(CLOSE,26);

   WZ6:=EMA(WZ5,9);

   WZ7:=2*(WZ5-WZ6);{50}

   WZ8:=REF(WZ7,1);

   WZ9:=CROSS(WZ8,WZ7)ANDWZ8>0;

   DRAWTEXT(WZ9ANDDJ>250,H,'←减'),COLORBCFF8B;

   VAR11:=EMA(CLOSE,8);{起步}

   VAR2:=EMA(VAR11,20);

   VAR3:=CROSS(VAR11,VAR2);

   VAR4:=VAR11<MA(CLOSE,120);

   VAR5:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;{逃命}

   VAR6:=SMA(VAR5,5,1);

   VAR7:=SMA(VAR6,8,1);{60}

   VAR8:=CROSS(VAR6,VAR7)ANDVAR7<20;

   VAR9:=CLOSE>LLV(CLOSE,60)+0.3*LLV(CLOSE,60)ANDVAR8;

   VARA:=IF(CLOSE>1000,VAR8,VAR9);

   起步:=VAR3ANDVAR4;

   逃遁:=VARA;

   STICKLINE(X2>X3,X2*0.98,X2,6,1),COLOR0000FF;

   STICKLINE(X2<X3,X2*0.98,X2,6,1),COLORF10011;

   WW1:=SUM(MA(C,10),9)/10.110;

   XX1:=MA(LOW,2)*0.96;

   XX2:=MA(LOW,26)*0.85;

   XX3:=REF(XX1,1)<XX2ANDREF(XX1,1)<XX1ANDREF(XX1,1)<REF(XX1,2);

   VAR1:=INDEXC;

   VAR12:=MA(VAR1,6);

   VAR13:=MA(VAR1,24);

   VAR14:=MA(VAR1,32);

   VAR15:=MA(VAR1,62);

   VAR16:=MA(VAR1,105);

   VAR17:=VAR15<REF(VAR15,1)ANDVAR6<REF(VAR16,1)ANDVAR15<VAR6*0.98;

   VAR18:=VAR14>VAR12*1.11ANDVAR13>VAR12*1.095;

   VAR19:=VAR12>VAR1*0.95;

   VAR111:=EMA(WINNER(CLOSE)*70,3);

   VAR112:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);

   VAR113:=CLOSE/MA(CLOSE,40)*100<76;

   VAR114:=CLOSE/MA(CLOSE,60)*100<74;

   VAR115:=HIGH>LOW*1.051;

   VAR116:=VAR115ANDCOUNT(VAR15,5)>1;

   VAR117:=VAR17ANDVAR8ANDVAR19ANDCLOSE/COST(8)<=0.8

   AND(CLOSE>OPENORCLOSE<OPEN)

   AND(REF(CLOSE,1)>REF(OPEN,1)ORREF(CLOSE,1)<REF(OPEN,1))

   ANDCLOSE>0.1ORVAR16

   AND(VAR113ORVAR114)ANDVAR112<20ANDVAR111<20

   AND(WINNER(CLOSE*125/100)-WINNER(CLOSE))*100<7.5OR

   TROUGHBARS(3,15,1)<4ANDCROSS(EMA(CLOSE,21)-EMA(CLOSE,8),

   EMA(EMA(CLOSE,21)-EMA(CLOSE,8),5));

   XL11:=EMA(CLOSE,10)/100;{70}

   XL2:=MA((XL11-REF(XL11,10))/REF(XL11,10),3)*100;

   XL3:=MA(XL2,3);

   XL4:=SMA((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,3,1);

   DRAWTEXT(IF(CROSS(3*XL4-2*SMA(XL4,3,1),8),87,0)

   ANDX2>X3,L-0.1,'←●反弹'),COLORGREEN;

   DRAWTEXT(IF(CROSS((VAR11-LLV(VAR1,4))/(HHV(VAR11,4)-LLV

   (VAR11,4))*4*25,87.5)AND

   VAR1<40,87,0)ANDX2>X3,L-0.2,'←●短买'),COLORFFBBD8;

   DRAWTEXT(CROSS(VAR1,10)ANDX2>X3,L-0.3,'←●买'),COLOR89B2FF;

   DRAWTEXT(IF(CROSS(2*(EMA((CLOSE*2+HIGH+LOW)/4,12)-EMA

   ((CLOSE*2+HIGH+LOW)/4,26)-EMA(EMA((CLOSE*2+HIGH+LOW)/

   4,12)-EMA((CLOSE*2+HIGH+LOW)/4,26),2))*5.8,0.47),LOW,0)

   ANDX2>X3,L-0.4,'←●加仓'),COLORFF5ED8;{80}

   LL1:=(EMA(CLOSE,3)-EMA(CLOSE,13));

   LL2:=EMA(LL1,9);

   LL3:=BARSLAST(CROSS(LL1,LL2));

   LL4:=REF(LL3,LL3+1);

   LL5:=LL2<REF(LL2,LL4);

   变盘:=CROSS(LL1,LL2)ANDLL5;

   DRAWTEXT(起步>0,L,'★起步?'),COLOR00FF00;

   STICKLINE(起步>0,C*1.05,C,7,0),COLORRED;

   DRAWTEXT(逃遁>0,H*1.04,'●←逃'),COLOR7FFFD6;




通达信绝佳的趋势通道指标截图

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论