神奇指标网
神奇指标网
  • 神奇指标

    通达信趋势DMI 趋势一目了然副图源码

    以下是通达信趋势DMI 趋势一目了然副图源码 通达信趋势DMI 趋势一目了然副图源码 N:=21;M:=6;M1:=20; TR1:=EMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),N); HD :=HIGH-REF(HIGH,1); LD :=REF(LOW,1)-LOW; DMP:=EMA(IF(HD>0 AND HD>LD,HD,0),N); DMM:=EMA(IF(LD>0 AND LD>HD,LD,0),N); PDI:= DMP*100/TR1; MDI:= DMM*100/TR1; ADX: EMA((PDI-MDI)/(MDI+PDI)*100,M)*2; ADXR:EMA(ADX,M); ADMA:EMA(ADX,M1); OMD:(ADX-2*ADMA+ADXR)/2, COLORSTICK; DRAWBAND(ADX,RGB(155,50,50),ADXR,RGB(0,100,50)); STICKLINE(OMD>REF(OMD,1) AND OMD>0,0,OMD,1,0),COLORRED; STICKLINE(OMD>REF(OMD,1) AND OMD<0,0,OMD,1,0),COLORGREEN; STICKLINE(OMD<REF(OMD,1),0,OMD,1,0),COLORCBCBC0; STICKLINE(OMD>=0 OR OMD<=0,0,0,50,1),COLORWHITE; ADX1:ADX,COLORRED; ADXR1:ADXR,COLORGREEN; ADMA1:ADMA; 强:IF(ADX1>=ADXR1,ADX1,DRAWNULL),COLORRED,LINETHICK3; 买入:IF(OMD>0 AND OMD-REF(OMD,1)>0,30,0); {OMD;} 110; 0; -110;

    浏览8131次浏览
    2022-09-05 09:37
  • 神奇指标

    通达信趋向指标DMI 增加 源码提供

    以下是通达信趋向指标DMI 增加 源码提供 DRAWBAND(20,RGB(0,80,120),0,RGB(0,200,0));  DRAWBAND(95,RGB(0,200,0),100,RGB(0,200,0));  DRAWTEXT_FIX(1,0.8,0.1,0,'绿头底部,翻红转势'),COLORWHITE;  MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);  HD :=HIGH-REF(HIGH,1);  LD :=REF(LOW,1)-LOW;  DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);  DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);  PDI:=DMP*100/MTR;  MDI:=DMM*100/MTR;  ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);  ADXR:=EXPMEMA(ADX,6);  DRAWBAND(ADX,RGB(250,0,00),ADXR,RGB(100,80,200));  MDI1:DMM*100/MTR,COLORGREEN;  98; 黑:IF(ADX<20,19,0);  40;  60;  DRAWBAND(19,RGB(0,200,00),MDI1,RGB(0,200,0));  DRAWBAND(19,RGB(0,0,00),黑,RGB(0,0,0));  PDI1:DMP*100/MTR,LINETHICK2,COLORYELLOW; 神奇筹码:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),NODRAW; 主力筹:=WINNER(C)*100,NODRAW; 散户筹:=(WINNER(C*1.1)-WINNER(C*0.9))*100,NODRAW;  STICKLINE(神奇筹码>散户筹,21,40,0.5,0),COLORRED;  STICKLINE(主力筹>散户筹,41,60,0.5,0),COLORMAGENTA;  STICKLINE(神奇筹码>50,61,80,0.5,0),COLORBLUE;  STICKLINE(主力筹>80 AND 散户筹<REF(散户筹,1),81,100,0.5,0),COLORYELLOW;  LC:=REF(C,1);  RSI1:=SMA(MAX(C-LC,0),6,1)/SMA(ABS(C-LC),6,1)*100;  RSI2:=HHV(FORCAST(RSI1,7),14),COLORLIBLUE;  HJ_1:=HHV(FORCAST(RSI1,7),28);  STICKLINE(RSI1>RSI2,RSI2,RSI1,3,0),COLORWHITE;

    浏览6982次浏览
    2022-09-05 09:36