神奇指标网
神奇指标网
  • 神奇指标

    自用抓主升浪和短线 配合用非常好

    以下是自用抓主升浪和短线 配合用非常好主升浪一A:EMA(C,21)COLORBLUE,LINETHICK3; B:=A<REF(A,1); IF(B-1,A,DRAWNULL)COLORRED,LINETHICK3; AA:=EMA(C,3) > EMA(C,21); BB:=EMA(C,3) < EMA(C,21); CC:= EMA(C,3) > EMA(C,8); CC1:=EMA(C,3) < EMA(C,8); DD:=CLOSE<OPEN; STICKLINE(AA,H,L,0,0),COLOR007FFF; STICKLINE(AA,O,C,3,1),COLOR007FFF; STICKLINE(AA AND DD,O,C,3,0),COLOR007FFF; STICKLINE(BB,H,L,0,0),COLORGREEN; STICKLINE(BB,O,C,3,1),COLORGREEN; STICKLINE(BB AND DD,O,C,3,0),COLORGREEN; STICKLINE(BB AND CC,H,L,0,1),COLORF00FF0; STICKLINE(BB AND CC,O,C,3,1),COLORF00FF0; STICKLINE(BB AND CC AND DD,O,C,3,0),COLORF00FF0; STICKLINE(AA AND CC1,H,L,0,0),COLORBLUE; STICKLINE(AA AND CC1,O,C,3,1),COLORBLUE;STICKLINE(AA AND CC1 AND DD,O,C,3,0),COLORBLUE;买线:=MA(CLOSE,9),LINETHICK2;卖线:=MA(CLOSE,20); BU:=CROSS(买线,卖线);SEL:=CROSS(卖线,买线);DRAWTEXT(BU,L-0.1,'建仓')COLORYELLOW; DRAWTEXT(SEL,H+0.1,'空仓');A2:=(C-REF(C,1))/REF(C,1)*100<1.02; A3:=H>MA(C,5)*1.12; AAA:= A2 AND A3; DRAWTEXT(AAA,H*1.05,'卖点'),COLORWHITE; EMA13:=EMA(C,13),COLOR0000FF,LINETHICK2; EMA34:=EMA(C,34),COLORYELLOW; EMA55:=EMA(C,55),COLORFF00FF; EMA120:=EMA(C,120),COLORFFCC66; AR1:=EMA55>EMA34 AND EMA34>EMA13; AR2:=BARSLAST((C-EMA13)/EMA13*100<-6); AR3:=EMA13>=REF(EMA13,2); AR4:=COUNT(CROSS(C,EMA13),AR2)=1; AR5:=AR1 AND AR2 AND AR3 AND AR4; AR6:=AR5 AND FILTER(AR5,10); DRAWTEXT(AR6,L-0.09,'启动'),COLORYELLOW; STICKLINE(AR6,H,L,3,0),LINETHICK2,COLORYELLOW; BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5; BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2; BR3:=C>EMA55 AND (REF(C,1)<REF(EMA55,1) OR REF(C,2)<REF(EMA55,2) OR REF(C,3)<REF(EMA55,3) OR REF(C,4)<REF(EMA55,4) OR REF(C,5)<REF(EMA55,5)); BR4:=BR1 AND BR2 AND BR3; DRAWTEXT(BR4 AND FILTER(BR4,10),L-0.09,'上升'),COLOR00C5FF; STICKLINE(BR4 AND FILTER(BR4,10),O,C,3,1),LINETHICK2,COLOR00C5FF; CR1:=(C-REF(C,1))/REF(C,1)*100>0.5; CR2:=V>MA(V,5)*0.6; CR3:=COUNT(CROSS(EMA13,EMA55),3)=1; CR4:=ABS(EMA34-EMA55)/EMA55<0.03; CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1); CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2); STICKLINE(CR6,O,C,3,1),LINETHICK2,COLORF00FF0; DRAWTEXT(CR6,L-0.09,'涨升'),COLORF00FF0; DR1:=EMA13>EMA34 AND EMA34<EMA55; DR2:=BARSLAST(CROSS(C,EMA55) ); DR3:=H=HHV(H,DR2); DR4:=BARSLAST(DR3); DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1; DR6:=C>REF(C,1) ; DR7:= DR1 AND DR5 AND DR6 ; DR8:=DR7 AND FILTER(DR7 ,10); DRAWTEXT(DR8,L-0.09,'出击'),COLORD6BA63; ER:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55); DRAWTEXT(ER,L-0.09,'金叉'),COLOR0099FF; FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34); DRAWTEXT(FR,L-0.09,'加仓'),COLORWHITE; GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5) ); GR2:=EMA13>EMA34 AND EMA34>EMA55 AND EMA13>REF(EMA13,1); GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1); GR4:=H=HHV(H,GR1); GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1); GR6:=GR2 AND GR3 AND GR4; GR7:=GR2 AND GR3 AND GR4 AND GR5; DRAWTEXT(GR6 AND GR7,H+0.13,'了结'),COLOR00FF00; HR2:=EMA13>=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13) AND CROSS(C,EMA34) AND CROSS(C,EMA55); DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.3,'推进'),COLORFFC8FF; STICKLINE(HR2 AND FILTER(HR2,10),O,C,3,1),LINETHICK2,COLORFFC8FF; VAR1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3); VAR2:=CROSS(VAR1,0.9); VAR3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3); VAR4:=CROSS(VAR3,0.9);压力:= REF(HIGH,BARSLAST(VAR2)), POINTDOT,COLOREA91B5; STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2)),REF(HIGH,BARSLAST(VAR2)),2,1),COLOREA91B5,LINETHICK3;支撑:= REF(LOW,BARSLAST(VAR4)), POINTDOT,COLOR00B4FF; STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4)),REF(LOW,BARSLAST(VAR4)),2,1),COLOR00B4FF,LINETHICK3;下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100); ARSV:=SMA(下档线,3,1); AK:=SMA(ARSV,3,1); AD:=((3 * ARSV) - (2 * AK)); AJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100); ARSV24:=SMA(AJ12,3,1); AK24:=SMA(ARSV24,3,1); AD24:=((3 * ARSV24) - (2 * AK24));撑:=IF(CROSS(AD24,AD),HIGH,REF(HIGH,BARSLAST(CROSS(AD24,AD))));撑压位:=IF(ISLASTBAR ,撑,DRAWNULL);底底:=LLV(HIGH,30);底:=IF(ISLASTBAR ,底底,DRAWNULL); STICKLINE(ISLASTBAR ,撑压位,撑压位,100,1),LINETHICK1,COLORFFFFFF; STICKLINE(ISLASTBAR ,底,底,80,1),COLOR00FF00,LINETHICK1;主升浪2 RSV:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*200-100)/2; K:SMA(SMA( RSV,3,1),3,1),LINETHICK2; D:MA(EMA(K,3),3),LINETHICK2; J:=3*K-2*D,COLORSTICK,LINETHICK3; STICKLINE(CROSS(K,D),K+33,K+2,0.5,0),COLORRED;

    浏览7046次浏览
    2022-10-27 16:54
  • 神奇指标

    超级短线 简单而实用的超短线指标

    以下是超级短线 简单而实用的超短线指标超级短线 简单而实用的超短线指标源码T:=(CLOSE*4.0+LOW*1.0+HIGH*1.0)/6;SL:=(T/REF(T,1)-1)*1000;快短势:=XMA(XMA(XMA(SL,3),3),3);慢短势:=XMA(XMA(XMA(XMA(XMA(SL,5),5),5),5),5);X:=XMA(XMA(XMA(SL,3),3),3)-XMA(XMA(XMA(XMA(XMA(SL,5),5),5),5),5);强弱:X;Y:=X,COLOR00FFFF;DRAWBAND(Y,RGB(255,255,0),0,RGB(0,0,220));{增速2:Y,COLORSTICK;}中势:=XMA(XMA(XMA(SL,13),13),13),LINETHICK1,COLORFF00FF;短势:=XMA(XMA(XMA(SL,9),9),9),LINETHICK1,COLOR00FF00;长势:=XMA(XMA(XMA(SL,72),72),72),LINETHICK1,COLORRED;分界:=0,COLORWHITE,LINETHICK2;DRAWICON(CROSS(短势,0),0,25);DRAWICON(CROSS(短势,长势),0,23);DRAWICON(CROSS(Y,0),0,15);

    浏览3122次浏览
    2022-10-25 17:04
  • 神奇指标

    短线 波段 主图

    以下是短线 波段 主图 C/C++ 股票公式指标网提供 Code复制内容到剪贴板JRH:=HHV(C,2); JRL:=LLV(C,2); MA3:=MA(CLOSE,3); YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6; VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2)); VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2)); VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1); VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD); 红色持股:=IF((VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC),1,0); 离场:=IF(红色持股,JRL,0); 明离场价:=离场; 今离场价:REF(离场,1),COLOR0000FF,LINETHICK0; 青色观望:=IF((VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18),1,0); 进:=IF(青色观望,JRH,0); 明进场价:=进; 今进场价:REF(明进场价,1),COLOR00FF00,LINETHICK0; 短买:=VAR19; 品红离场:=VAR1A; 白色急速超跌:=(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14; g:=EMA((C*3+H+L+O)/6,5); 买卖:g,COLORRED,linethick3; A线:HHV(g,13); B线:LLV(g,13); STICKLINE(BARSTATUS=2 AND (红色持股 OR REF(红色持股,1)=1) AND 今离场价<>0,今离场价,今离场价,30,1),COLOR0000FF; STICKLINE(BARSTATUS=2 AND (青色观望 OR REF(青色观望,1)=1) AND 今进场价<>0,今进场价,今进场价,30,1),COLOR00FF00; STICKLINE(C>=O,L,H,0,0),COLOR0000CC; STICKLINE(C<O,L,H,0,0),COLOR999900; STICKLINE(1,C,O,8,0),COLOR858500; STICKLINE(C>=O,C,O,8,0),COLOR0000E5; STICKLINE(红色持股,CLOSE,O,6,0),COLOR000055; STICKLINE(红色持股,CLOSE,O,5,0),COLOR000088; STICKLINE(红色持股,CLOSE,O,4,0),COLOR0000AA; STICKLINE(红色持股,CLOSE,O,3,0),COLOR0000CC; STICKLINE(红色持股,CLOSE,O,2,0),COLOR0000EE; STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000FF; STICKLINE(青色观望,CLOSE,O,6,0),COLOR555500; STICKLINE(青色观望,CLOSE,O,5,0),COLOR888800; STICKLINE(青色观望,CLOSE,O,4,0),COLORAAAA00; STICKLINE(青色观望,CLOSE,O,3,0),COLORCCCC00; STICKLINE(青色观望,CLOSE,O,2,0),COLOREEEE00; STICKLINE(青色观望,CLOSE,O,1,0),COLORFFFF00; CO:=(C-O); STICKLINE(白色急速超跌,O,C-CO/2,6,0),COLOR555555; STICKLINE(白色急速超跌,O,C-CO/2,5,0),COLOR888888; STICKLINE(白色急速超跌,O,C-CO/2,4,0),COLORAAAAAA; STICKLINE(白色急速超跌,O,C-CO/2,3,0),COLORCCCCCC; STICKLINE(白色急速超跌,O,C-CO/2,2,0),COLOREEEEEE; STICKLINE(白色急速超跌,O,C-CO/2,1,0),COLORFFFFFF; STICKLINE(短买,O,O+CO/3,6,0),COLOR335555; STICKLINE(短买,O,O+CO/3,5,0),COLOR338888; STICKLINE(短买,O,O+CO/3,4,0),COLOR33AAAA; STICKLINE(短买,O,O+CO/3,3,0),COLOR33CCCC; STICKLINE(短买,O,O+CO/3,2,0),COLOR33EEEE; STICKLINE(短买,O,O+CO/3,1,0),COLOR33FFFF; DRAWTEXT(短买,LLV(L,3),'←买'),VALIGN0,COLOR00FFFF; STICKLINE(品红离场,O,O+CO/3,6,0),COLOR550055; STICKLINE(品红离场,O,O+CO/3,5,0),COLOR880088; STICKLINE(品红离场,O,O+CO/3,4,0),COLORAA00AA; STICKLINE(品红离场,O,O+CO/3,3,0),COLORCC00CC; STICKLINE(品红离场,O,O+CO/3,2,0),COLOREE00EE; STICKLINE(品红离场,O,O+CO/3,1,0),COLORFF00FF; DRAWTEXT(品红离场,HHV(H,3),'←卖'),VALIGN2,COLOR00FFFF;

    浏览4180次浏览
    2022-10-21 13:37
  • 神奇指标

    用了3年多的主图 适用于短线 抓涨停的好主图

    以下是用了3年多的主图 适用于短线 抓涨停的好主图用了3年多的主图 适用于短线 抓涨停的好主图源码m:=80;n:=3;DRAWKLINE(HIGH,OPEN,LOW,CLOSE);VAR11:=MA(C,9),COLORRED;上升通道:IF(VAR11>REF(VAR11,1),VAR11,DRAWNULL),LINETHICK5,COLORRED;下降通道:IF(VAR11<REF(VAR11,1),VAR11,DRAWNULL),LINETHICK4,COLORGREEN;A0:=(L+H+C*2)/4;AA:=EMA(A0,14)COLORYELLOW,LINETHICK1;BB:=EMA(A0,25)COLORYELLOW,LINETHICK2;A1X:=(AA-REF(AA,1))/REF(AA,1)*100;A2X:=(BB-REF(BB,1))/REF(BB,1)*100;G:=BARSLAST(CROSS(A1X,0));CC:=IF(CURRBARSCOUNT<18,CONST(REF(C,1)),DRAWNULL),COLORBLUE;DRAWKLINE(H,O,L,C);ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL);ZSP:=IF(C>REF(C,1),C,DRAWNULL);DKP:=IF(C<=REF(C,1),REF(C,1),DRAWNULL);DSP:=IF(C<=REF(C,1),C,DRAWNULL);DRAWKLINE(H,DKP,L,DSP);STICKLINE(C<=REF(C,1),DKP,DSP,3.05,0),COLORBLUE;STICKLINE(C<=REF(C,1),DKP,DSP,2.2,0),COLORFF7700;STICKLINE(C<=REF(C,1),DKP,DSP,1.5,0),COLORFF9900;STICKLINE(C<=REF(C,1),DKP,DSP,0.5,0),COLORFFBB00;DRAWKLINE(H,ZKP,L,ZSP);STICKLINE(C>REF(C,1),ZKP,ZSP,3.05,0),COLOR000099;STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC;STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF;STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF;STICKLINE(V/REF(V,1)>2 AND CLOSE>=OPEN,ZKP,ZSP,1,0),COLORYELLOW;TY:=C;A1:=REF(TY,10)=HHV(TY,2*10+1);B1:=FILTER(A1,10);C1:=BACKSET(B1,10+1);HD:=FILTER(C1,10);A2:=REF(TY,10)=LLV(TY,2*10+1);B2:=FILTER(A2,10);C2:=BACKSET(B2,10+1);LD:=FILTER(C2,10);前期高位:REF(C,BARSLAST(HD)),COLOR8000FF,POINTDOT;STICKLINE(C,前期高位,前期高位,8,0),COLOR8000FF;JRH:=HHV(C,2);    JRL:=LLV(C,2);    VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));    VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    VARA:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01);    VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD);    红色持股:=VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;离场:=IF(红色持股,JRL,DRAWNULL);    明离场价:=离场,COLORFF99FF,NODRAW;青色观望:=VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW;    进:=IF(青色观望,JRH,DRAWNULL);今离场价:REF(离场,1),COLOR0000FF,NODRAW;    明进场价:进,COLOR33AACC,NODRAW;    今进场价:REF(明进场价,1),COLORGREEN,NODRAW;必卖止损价位:REF(A0,G),COLORFFFFFF,LINETHICK4;总额:=AMOUNT;买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));买%:=买/AMOUNT*100;流入:=AMOUNT*买%/10000000000;流出:=AMOUNT/100000000-流入;净流:=(流入-流出);总额3:=SUM(AMOUNT,3);流入3:=SUM(流入,3);流出3:=SUM(流出,3);净流3:=SUM(流入-流出,3);总额5:=SUM(AMOUNT,5);流入5:=SUM(流入,5);流出5:=SUM(流出,5);净流5:=SUM(流入-流出,5);总额10:=SUM(AMOUNT,10);流入10:=SUM(流入,10);流出10:=SUM(流出,10);净流10:=SUM(流入-流出,10);画:=CONST(FINDHIGH(总额10,0,190,1));DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK)COLOR00FFFF;DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK)COLOR00FFFF;DRAWTEXT_FIX(1,0.30,0.00,0,'主题投资:')COLOR00FFFF;DRAWTEXT_FIX(1,0.36,0.00,0,EXTERNSTR(0,2))COLOR00FFFF;DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:')COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3))COLOR00FFFF;DRAWTEXT_FIX(1,0.00,0.10,0,'解禁日期:')COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0.10,0,EXTERNSTR(0,4))COLOR00FFFF;DRAWTEXT_FIX(1,0.00,0.15,0,'莸利比例:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.06,0.15,0,CONST(WINNER(C )*100)),COLOR0080FF;DRAWTEXT_FIX(1,0.12,0.15,0,'动态PE:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.17,0.15,0,CONST(DYNAINFO(39))),COLOR0080FF;DRAWTEXT_FIX(1,0.22,0.15,0,'市值:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.26,0.15,0,FINANCE(40)/100000000),COLOR0080FF;DRAWTEXT_FIX  (1,0.31,0.15,0,'公积金(股):'),COLORYELLOW;DRAWNUMBER_FIX(1,0.38,0.15,0,FINANCE(18)),COLOR0080FF;DRAWTEXT_FIX  (1,0.43,0.15,0,'收益:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.47,0.15,0,FINANCE(33)),COLOR0080FF;DRAWTEXT_FIX(1,0.00,0.19,0,'净流入(亿):'),COLORYELLOW;DRAWTEXT_FIX(1,0.06,0.19,0,'1日'),COLORYELLOW;DRAWTEXT_FIX(1,0.12,0.19,0,'3日'),COLORYELLOW;DRAWTEXT_FIX(1,0.18,0.19,0,'5日'),COLORYELLOW;DRAWTEXT_FIX(1,0.24,0.19,0,'10日'),COLORYELLOW;DRAWNUMBER_FIX(1,0.08,0.19,0,CONST((净流))),COLOR0080FF;DRAWNUMBER_FIX(1,0.14,0.19,0,CONST((净流3))),COLOR0080FF;DRAWNUMBER_FIX(1,0.20,0.19,0,CONST((净流5))),COLOR0080FF;DRAWNUMBER_FIX(1,0.265,0.19,0,CONST((净流10))),COLOR0080FF;DRAWTEXT_FIX(1,0.00,0.23,0,'愚民导向:'),COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0.23,0,EXTERNSTR(0,5)),COLOR00FFFF;VAR111:=ZIG(3,13);STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,3,0),COLOR66FF00;DRAWTEXT_FIX(STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,5,0),0.00,0.11,0,''),COLOR00FF00,LINETHICK1; DRAWRECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0));超B:=L2_AMO(0,2)/10000.0;大B:=L2_AMO(1,2)/10000.0;中B:=L2_AMO(2,2)/10000.0;小B:=L2_AMO(3,2)/10000.0;超S:=L2_AMO(0,3)/10000.0;大S:=L2_AMO(1,3)/10000.0;中S:=L2_AMO(2,3)/10000.0;小S:=L2_AMO(3,3)/10000.0;TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);大宗进:=(超B)+(大B),NODRAW;大宗出:=(超S)+(大S),NODRAW;非大宗进:=(中B)+(小B),NODRAW;非大宗出:=(中S)+(小S),NODRAW;大宗进限制:=IF((超B+大B)=0,0,大宗进);大宗出限制:=IF((超S+大S)=0,0,大宗出);非大宗进限制:=IF(中B+小B=0,0,非大宗进);非大宗出限制:=IF(中S+小S=0,0,非大宗出);主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;大单强度限制:=IF(大单强度=0,-100,大单强度);大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;超单强度限制:=IF(超单强度=0,-100,超单强度);超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW;DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50)));DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW;DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,0.99,0,'净流入:(万)'),COLORYELLOW;主力买力度:=LARGEINTRDVOL*1000/VOL;主力卖力度:=LARGEOUTTRDVOL*1000/VOL;AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;DRAWRECTREL(0,515,CONST(ABS(主力买力度)*560/AAD),568,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*560/AAD),623,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0)));DRAWTEXT_FIX(1,0,0.524,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW;DRAWTEXT_FIX(1,0,0.576,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW;{DDE显示}DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*1000/FINANCE(7);DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);DRAWRECTREL(150,500,192,540,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(150,545,192,585,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(150,590,192,630,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));DRAWTEXT_FIX(1,0.153,0.500,0,STRCAT('DDX:',CON2STR(DDX,1))),COLORYELLOW,COLORWHITE;DRAWTEXT_FIX(1,0.153,0.548,0,STRCAT('DDY:',CON2STR(DDY,1))),COLORYELLOW,COLORWHITE;DRAWTEXT_FIX(1,0.153,0.596,0,STRCAT('DDZ:',CON2STR(DDZ,1))),COLORYELLOW,COLORWHITE;T1:=IF (DDX>0 AND REF(DDX,1)<0,1,0);T2:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)<0,2,T1);T3:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)<0,3,T2);T4:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)<0,4,T3);T5:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)<0,5,T4);T6:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)<0,6,T5);T7:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)<0,7,T6);T8:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)<0,8,T7);T9:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)<0,9,T8);T:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)>0,10,T9);DRAWTEXT_FIX(1,0.190,0.500,0,STRCAT(STRCAT(' ',CON2STR(T,0)),' [天] ')),COLORYELLOW;T11:=IF (DDY>0 AND REF(DDY,1)<0,1,0);T21:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)<0,2,T11);T31:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)<0,3,T21);T41:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)<0,4,T31);T51:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)<0,5,T41);T61:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)<0,6,T51);T71:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)<0,7,T61);T81:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)<0,8,T71);T91:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)<0,9,T81);TY01:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)>0,10,T91);DRAWTEXT_FIX(1,0.190,0.548,0,STRCAT(STRCAT(' ',CON2STR(TY01,0)),' [天] ')),COLORYELLOW;T1Z:=IF (DDZ>0 AND REF(DDZ,2)<0,1,0);T2Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)<0,2,T1Z);T3Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)<0,3,T2Z);T4Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)<0,4,T3Z);T5Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)<0,5,T4Z);T6Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)<0,6,T5Z);T7Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)<0,7,T6Z);T8Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)<0,8,T7Z);T9Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)<0,9,T8Z);TZ:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)>0,10,T9Z);DRAWTEXT_FIX(1,0.190,0.596,0,STRCAT(STRCAT(' ',CON2STR(TZ,0)),' [天] ')),COLORYELLOW;DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA:=EMA(DIF,9);MACD:=(DIF-DEA)*2;VAR113:=HHV(HIGH,60);VAR114:=LLV(LOW,30);VAR115:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;VAR116:=(VAR113+VAR114+VAR115)/3;VAR117:=EMA(VAR116,5);K01:=EMA(VAR117,5)*2, COLORFF00FF;D01:=EMA(K01,5),  COLORWHITE;J01:=K01*3-D01*2, COLORYELLOW;ENTERLONG:=CROSS(K01,D01);EXITLONG:=CROSS(D01,K01);B01:=(DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),L*0.98,1))*D01*2/3;B02:=IF(TROUGHBARS(3,15,1)=1 AND HIGH>LOW+0.01,20,0);必买:=(B01 AND B02) AND 净流入>0; 必卖:=IF(PEAKBARS(3,15,1)=1,80,100),COLORGREEN,LINETHICK1;QQ:=必卖=80;B03:=((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)));V1:=EMA(CLOSE,60)-EMA(CLOSE,300);V2:=EMA(V1,300);V3:=(CLOSE-(LOW,8))/((HIGH,8)-LLV(LOW,8))*100;V4:=SMA(V3,2,1),NODRAW;V5:=SMA(V4,2,1),NODRAW;V6:=CLOSE/REF(CLOSE,3)>=1.1;V7:=BACKSET(V6,3);大涨:=(V7 AND COUNT(V7,3)=1);DRAWICON(必买,L-0.16,11);DRAWICON(大涨 AND 必买,L-0.16,9);DRAWICON(大涨,L-0.18,1);DRAWICON(QQ,H+0.1,6);

    浏览7774次浏览
    2022-10-21 09:51
  • 神奇指标

    通达信自用抓主升浪和短线 配合用非常好

    以下是通达信自用抓主升浪和短线 配合用非常好主升浪一A:EMA(C,21)COLORBLUE,LINETHICK3; B:=A<REF(A,1); IF(B-1,A,DRAWNULL)COLORRED,LINETHICK3; AA:=EMA(C,3) > EMA(C,21); BB:=EMA(C,3) < EMA(C,21); CC:= EMA(C,3) > EMA(C,8); CC1:=EMA(C,3) < EMA(C,8); DD:=CLOSE<OPEN; STICKLINE(AA,H,L,0,0),COLOR007FFF; STICKLINE(AA,O,C,3,1),COLOR007FFF; STICKLINE(AA AND DD,O,C,3,0),COLOR007FFF; STICKLINE(BB,H,L,0,0),COLORGREEN; STICKLINE(BB,O,C,3,1),COLORGREEN; STICKLINE(BB AND DD,O,C,3,0),COLORGREEN; STICKLINE(BB AND CC,H,L,0,1),COLORF00FF0; STICKLINE(BB AND CC,O,C,3,1),COLORF00FF0; STICKLINE(BB AND CC AND DD,O,C,3,0),COLORF00FF0; STICKLINE(AA AND CC1,H,L,0,0),COLORBLUE; STICKLINE(AA AND CC1,O,C,3,1),COLORBLUE;STICKLINE(AA AND CC1 AND DD,O,C,3,0),COLORBLUE;买线:=MA(CLOSE,9),LINETHICK2;卖线:=MA(CLOSE,20); BU:=CROSS(买线,卖线);SEL:=CROSS(卖线,买线);DRAWTEXT(BU,L-0.1,'建仓')COLORYELLOW; DRAWTEXT(SEL,H+0.1,'空仓');A2:=(C-REF(C,1))/REF(C,1)*100<1.02; A3:=H>MA(C,5)*1.12; AAA:= A2 AND A3; DRAWTEXT(AAA,H*1.05,'卖点'),COLORWHITE; EMA13:=EMA(C,13),COLOR0000FF,LINETHICK2; EMA34:=EMA(C,34),COLORYELLOW; EMA55:=EMA(C,55),COLORFF00FF; EMA120:=EMA(C,120),COLORFFCC66; AR1:=EMA55>EMA34 AND EMA34>EMA13; AR2:=BARSLAST((C-EMA13)/EMA13*100<-6); AR3:=EMA13>=REF(EMA13,2); AR4:=COUNT(CROSS(C,EMA13),AR2)=1; AR5:=AR1 AND AR2 AND AR3 AND AR4; AR6:=AR5 AND FILTER(AR5,10); DRAWTEXT(AR6,L-0.09,'启动'),COLORYELLOW; STICKLINE(AR6,H,L,3,0),LINETHICK2,COLORYELLOW; BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5) ,5)=5; BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2; BR3:=C>EMA55 AND (REF(C,1)<REF(EMA55,1) OR REF(C,2)<REF(EMA55,2) OR REF(C,3)<REF(EMA55,3) OR REF(C,4)<REF(EMA55,4) OR REF(C,5)<REF(EMA55,5)); BR4:=BR1 AND BR2 AND BR3; DRAWTEXT(BR4 AND FILTER(BR4,10),L-0.09,'上升'),COLOR00C5FF; STICKLINE(BR4 AND FILTER(BR4,10),O,C,3,1),LINETHICK2,COLOR00C5FF; CR1:=(C-REF(C,1))/REF(C,1)*100>0.5; CR2:=V>MA(V,5)*0.6; CR3:=COUNT(CROSS(EMA13,EMA55),3)=1; CR4:=ABS(EMA34-EMA55)/EMA55<0.03; CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1); CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2); STICKLINE(CR6,O,C,3,1),LINETHICK2,COLORF00FF0; DRAWTEXT(CR6,L-0.09,'涨升'),COLORF00FF0; DR1:=EMA13>EMA34 AND EMA34<EMA55; DR2:=BARSLAST(CROSS(C,EMA55) ); DR3:=H=HHV(H,DR2); DR4:=BARSLAST(DR3); DR5:=COUNT(O>C AND C<REF(C,1) AND C>EMA55 AND BETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1; DR6:=C>REF(C,1) ; DR7:= DR1 AND DR5 AND DR6 ; DR8:=DR7 AND FILTER(DR7 ,10); DRAWTEXT(DR8,L-0.09,'出击'),COLORD6BA63; ER:=BARSLAST(REF(CROSS(EMA55,EMA34),1)) AND CROSS(EMA34,EMA55); DRAWTEXT(ER,L-0.09,'金叉'),COLOR0099FF; FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1)) AND CROSS(EMA13,EMA34); DRAWTEXT(FR,L-0.09,'加仓'),COLORWHITE; GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5) ); GR2:=EMA13>EMA34 AND EMA34>EMA55 AND EMA13>REF(EMA13,1); GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10 AND H=HHV(H,GR1),GR1); GR4:=H=HHV(H,GR1); GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1); GR6:=GR2 AND GR3 AND GR4; GR7:=GR2 AND GR3 AND GR4 AND GR5; DRAWTEXT(GR6 AND GR7,H+0.13,'了结'),COLOR00FF00; HR2:=EMA13>=REF(EMA13,3) AND EMA34>=REF(EMA34,1) AND EMA55>=REF(EMA55,1) AND CROSS(C,EMA13) AND CROSS(C,EMA34) AND CROSS(C,EMA55); DRAWTEXT(HR2 AND FILTER(HR2,10),L-0.3,'推进'),COLORFFC8FF; STICKLINE(HR2 AND FILTER(HR2,10),O,C,3,1),LINETHICK2,COLORFFC8FF; VAR1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3); VAR2:=CROSS(VAR1,0.9); VAR3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3); VAR4:=CROSS(VAR3,0.9);压力:= REF(HIGH,BARSLAST(VAR2)), POINTDOT,COLOREA91B5; STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2)),REF(HIGH,BARSLAST(VAR2)),2,1),COLOREA91B5,LINETHICK3;支撑:= REF(LOW,BARSLAST(VAR4)), POINTDOT,COLOR00B4FF; STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4)),REF(LOW,BARSLAST(VAR4)),2,1),COLOR00B4FF,LINETHICK3;下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100); ARSV:=SMA(下档线,3,1); AK:=SMA(ARSV,3,1); AD:=((3 * ARSV) - (2 * AK)); AJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100); ARSV24:=SMA(AJ12,3,1); AK24:=SMA(ARSV24,3,1); AD24:=((3 * ARSV24) - (2 * AK24));撑:=IF(CROSS(AD24,AD),HIGH,REF(HIGH,BARSLAST(CROSS(AD24,AD))));撑压位:=IF(ISLASTBAR ,撑,DRAWNULL);底底:=LLV(HIGH,30);底:=IF(ISLASTBAR ,底底,DRAWNULL); STICKLINE(ISLASTBAR ,撑压位,撑压位,100,1),LINETHICK1,COLORFFFFFF; STICKLINE(ISLASTBAR ,底,底,80,1),COLOR00FF00,LINETHICK1;主升浪2 RSV:=((CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*200-100)/2; K:SMA(SMA( RSV,3,1),3,1),LINETHICK2; D:MA(EMA(K,3),3),LINETHICK2; J:=3*K-2*D,COLORSTICK,LINETHICK3; STICKLINE(CROSS(K,D),K+33,K+2,0.5,0),COLORRED;

    浏览3926次浏览
    2022-10-18 22:51
  • 神奇指标

    通达信超级短线 尾盘选股指标

    以下是通达信超级短线 尾盘选股指标超级短线 尾盘选股指标在收盘前15分钟的炒股方法短线操作的本质是为了规避长期持股中的风险,获得短线利润。短线高手买进是为了1天或3天后的卖出,无论盈亏都必须在短期内轧平账户,不参与沉闷而寂寞的盘整。在目前T 1交易制度下,买进后一旦发生风险当日不得卖出,因此短线客将买入时间选择在收盘前15分钟,此时间段内不跌的话,第二天任何时间感觉有风险可随时卖出。   很多情况下,一只股票早上开盘后进行长时间的横盘,在均价附近窄幅整理,遇大盘下跌,它能坚持不动或被大盘稍有拖累后,也能迅速返回;而均线基本上保持一直线。此类股票往往会在下午耐不住寂寞,选择向上突破。但是如果在下午一开盘就突破的话,最好不要跟进,因为此时多数属于主力试盘动作。   真正上攻的股票,一般都会选择在14:30之后,特别是在14:35-14:40开始上攻。此时要看它的上升角度。如果超过80度的话,就会显得太急,容易产生抛压。有个别强势股14时刚过就展开攻势,这时候必须要放巨量,以接近90度的推升迅速涨停,否则的话容易夭折。最漂亮的走势是先沿30度角运行几分钟,然后在大成交量的推动下改为45度到60度向上攻击,而均线此时也最好紧随股价,呈30度以上的弧形

    浏览1291次浏览
    2022-10-17 15:38
  • 神奇指标

    通达信超级短线 追涨小能手副图/选股预警 源码

    以下是通达信超级短线 追涨小能手副图/选股预警 源码通达信指标公式源码概况:指标类别: 通达信指标公式授权方式: 免费版指标评级: ★★★★★指标分类: 策略画线方法: 副图XA_1:=EMA(CLOSE,7);XA_2:=EMA(XA_1,21);XA_3:=100-90*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14));XA_4:=MA(100-MA(100*(HHV(HIGH,6)-CLOSE)/(HHV(HIGH,6)-LLV(LOW,6)),34),6);XG:CROSS(XA_3,XA_4) AND XA_1>XA_2 AND (C-L)/C*100 >=5 AND C>O;

    浏览2482次浏览
    2022-09-20 10:16
  • 神奇指标

    通达信成功率很高的短线收割机 超短线 源码 副图/选股 无未来

    以下是通达信成功率很高的短线收割机 超短线 源码 副图/选股 无未来通达信指标公式源码概况:指标类别: 通达信指标公式授权方式: 免费版指标评级: ★★★★★指标分类: 策略画线方法: 副图本公式的原理是利用筑底反弹获利,只是做短线用,不是长线指标,当然改改也可以 。测试周期只搞2-3天,反弹目标3-5%。测试成功率是很高的,见图。信号较少。其它的大家自己优化。上柴股份的信号VAR01:=EMA((CLOSE-LLV(LOW,25))/(HHV(HIGH,25)-LLV(LOW,25))*100,5);VAR02:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);VAR03:=CROSS(VAR02,VAR01);VAR04:=REF(VAR02,2)<REF(VAR02,1) AND VAR02<REF(VAR02,1);VAR05:=COUNT(VAR03,7)>0 AND VAR04;VAR06:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);VAR07:=SMA(ABS(LOW-VAR06),13,1)/SMA(MAX(LOW-VAR06,0),10,1);VAR08:=EMA(VAR07,10);VAR09:=EMA(C,5);VAR10:=LLV(LOW,33);VAR11:=EMA(IF(LOW<=VAR10,VAR09,0),3)*40;VAR12:=IF(VAR11>100,VAR11*0.312,VAR11);长期线:VAR02,COLORGREEN;抄底线:VAR01,COLORCYAN;NN1:=HHV(抄底线,30);SG: 抄底线>=0  AND 抄底线<=4 and="" c="">REF(C,1)  AND  V>  REF(V,1);STICKLINE(SG,0,NN1,1,0),COLORRED;DRAWICON(SG,NN1,20); 

    浏览10411次浏览
    2022-09-19 14:36
  • 神奇指标

    主力散户线指标公式【短线 散户线 主力线 趋势】

    以下是主力散户线指标公式【短线 散户线 主力线 趋势】 主力散户线指标公式  自己用过很多公式,就这个公式最经典!极力推荐! 当黄色主力线与绿色散户线金叉时,为买点! =====主力散户线===========  {短线:"KDJ.J"(5,3,3),COLORAAAAAA;} 散户线: 100*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60)),LINETHICK2,COLOR00FF00;  RSV30:=(CLOSE-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100;  K30:=SMA(RSV30,5,1);  D30:=SMA(K30,3,1);  J30:=3*K30-2*D30; 主力线:EMA(J30,6),COLORYELLOW,LINETHICK2;  RSV21:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;  K21:=SMA(RSV21,13,8); 趋势:CEILING(SMA(K21,13,8)),COLORRED,LINETHICK1;  0;20;50;80;100;

    浏览2363次浏览
    2022-09-05 12:10
  • 神奇指标

    通达信超级短线 每天1%(源码说明附图)

    以下是通达信超级短线 每天1%(源码说明附图) ZT:=C/REF(C,1)>=1.093 ;  VA:=EMA(CLOSE,9);  X:=EMA(VA*1.14,5);  TYP:=(HIGH+LOW+CLOSE)/3;  CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));  XN:=ZT AND C>X;  XG:CROSS(CCI,0) AND BARSLAST (XN)>6  AND BARSLAST (XN)<21 AND COUNT((CCI>-100),5)>=5;

    浏览7236次浏览
    2022-09-05 10:15
  • 神奇指标

    很好的短线 中线参考 无双波段风暴 副图指标

    以下是很好的短线 中线参考 无双波段风暴 副图指标 {无双波段风暴} {改编 BY SHUHONG} {背景} DRAWGBK(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0); {大机构MACD}  DIFFF:=EMA(CLOSE,12)-EMA(CLOSE,26);  DEAAA:=EMA(DIFFF,9);  MACD2:=2*(DIFFF-DEAAA);  (CLOSE<0 AND CROSS(DIFFF,0),H*1.3),COLOR000080,NODRAW;  (CLOSE<0 AND CROSS(MACD2,0),H*1.3),COLOR000080,NODRAW;  (CLOSE<0 AND CROSS(0,DIFFF),H*1.3),COLOR808080,NODRAW;  (CLOSE<0 AND CROSS(0,MACD2),H*1.3),COLOR808080,NODRAW;  DU0:=CROSS(DIFFF,0);  UD0:=CROSS(0,DIFFF);  TDU0:=BARSLAST(DU0);  TUD0:=BARSLAST(UD0);  DU3:=REF(DU0,1);  UD3:=REF(UD0,1);  TDU3:=BARSLAST(DU3);  TUD3:=BARSLAST(UD3);  UDGLINE:=IF(TDU3<TUD3,REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3));  JDU0:=REF(CLOSE,1)<=REF(UDGLINE,1) AND CLOSE>UDGLINE AND TDU0<TUD0;  JUD0:=REF(CLOSE,1)>=REF(UDGLINE,1) AND CLOSE<UDGLINE AND TUD0<TDU0;  JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;  JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;  JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);  JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);  JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);  JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);  BSLINE:=IF(BARSLAST(JDU2)<BARSLAST(JUD2),IF(REF(CROSS(0,MACD2),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS(0,MACD2),1)))),IF(REF(CROSS(MACD2,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD2,0),1)))));  {}  STICKLINE(MACD2>=0,0,MACD2,2,0),COLORYELLOW;{0轴上升} STICKLINE(MACD2>=0 AND MACD2<REF(MACD2,1),0,MACD2,2,1),COLORCYAN;{0轴上跌} STICKLINE(MACD2<0,0,MACD2,2,0),COLORCYAN;{0轴下跌} STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,2,1),COLORYELLOW;{0轴下升}  {包络均线—知博陋室交易系统副图指标(21)}  0,DOTLINE,COLORGRAY;  MID:=(7*CLOSE+LOW+OPEN+HIGH)/10;  MA0:=MA(MID,40);  MA1:=MA(MID,1);  A1:=MA1-MA0;  MA2:=MA(MID,2);  A2:=MA2-MA0;  MA3:=MA(MID,3);  A3:=MA3-MA0;  MA4:=MA(MID,4);  A4:=MA4-MA0;  MA5:=MA(MID,5);  A5:=MA5-MA0;  MA6:=MA(MID,6);  A6:=MA6-MA0;  MA7:=MA(MID,7);  A7:=MA7-MA0;  MA8:=MA(MID,8);  A8:=MA8-MA0;  MA9:=MA(MID,9);  A9:=MA9-MA0;  MA10:=MA(MID,10);  A10:=MA10-MA0;  MA11:=MA(MID,11);  A11:=MA11-MA0;  MA12:=MA(MID,12);  A12:=MA12-MA0;  MA13:=MA(MID,13);  A13:=MA13-MA0;  MA14:=MA(MID,14);  A14:=MA14-MA0;  MA15:=MA(MID,15);  A15:=MA15-MA0;  MA16:=MA(MID,16);  A16:=MA16-MA0;  MA17:=MA(MID,17);  A17:=MA17-MA0;  MA18:=MA(MID,18);  A18:=MA18-MA0;  MA19:=MA(MID,19);  A19:=MA19-MA0;  MA20:=MA(MID,20);  A20:=MA20-MA0;  MA21:=MA(MID,21);  A21:=MA21-MA0;  MA22:=MA(MID,22);  A22:=MA22-MA0;  MA23:=MA(MID,23);  A23:=MA23-MA0;  MA24:=MA(MID,24);  A24:=MA24-MA0;  MA25:=MA(MID,25);  A25:=MA25-MA0;  MA26:=MA(MID,26);  A26:=MA26-MA0;  MA27:=MA(MID,27);  A27:=MA27-MA0;  MA28:=MA(MID,28);  A28:=MA28-MA0;  MA29:=MA(MID,29);  A29:=MA29-MA0;  MA30:=MA(MID,30);  A30:=MA30-MA0;  MA31:=MA(MID,31);  A31:=MA31-MA0;  MA32:=MA(MID,32);  A32:=MA32-MA0;  MA33:=MA(MID,33);  A33:=MA33-MA0;  MA34:=MA(MID,34);  A34:=MA34-MA0;  MA35:=MA(MID,35);  A35:=MA35-MA0;  MA36:=MA(MID,36);  A36:=MA36-MA0;  MA37:=MA(MID,37);  A37:=MA37-MA0;  MA38:=MA(MID,38);  A38:=MA38-MA0;  MA39:=MA(MID,39);  A39:=MA39-MA0;  MA40:=MA(MID,40);  A40:=MA40-MA0;  LC:=(A6+A7+A8+A9+A10+A11+A12+A13+A14+A15+A16+A17+A18+A19+A20)/15,LINETHICK0;  VAR1:=LC;  VAR2:=REF(LC,1);  VAR3:=VAR1>VAR2 AND REF(LC,1)<REF(LC,2);  VAR4:=VAR1<VAR2 AND REF(LC,1)>REF(LC,2);  {} 均线发散:STICKLINE(VAR1>VAR2,LC,REF(LC,1),3,0),COLORRED; 均线粘合:STICKLINE(VAR1<VAR2,LC,REF(LC,1),3,0),COLORGREEN;  {}  EMA5:MA(VAR1,5),COLORWHITE;  EMA10:MA(VAR1,10),COLORYELLOW; {DJG波段风暴} DIFF:=EMA(CLOSE,21)-EMA(CLOSE,34);  DEAA:=EMA(DIFF,8);  MACDD:=8*(DIFF-DEAA);  MARDD:=SMA(MACDD,2,1);  {柱线形式} STICKLINE(MACDD>MARDD,MACDD,MARDD,1.8,0),COLORMAGENTA;  STICKLINE(MACDD<MARDD,MACDD,MARDD,1.8,0),COLORFF8000;  {彩条形式}  {DRAWBAND(MACDD,RGB(255,0,255),MARDD,RGB(0,128,255));} {说明} DRAWRECTREL(0,0,190,350,RGB(36,36,36));{矩形大小底色}; DRAWTEXT_FIX(C>0,0,0.03,0,' 洋红和天蓝柱线是DJG波段风暴指标,看短线;'),COLORGRAY;  DRAWTEXT_FIX(C>0,0,0.13,0,' 红绿色柱线是知博包络均线指标,看中长线;'),COLORGRAY;  DRAWTEXT_FIX(C>0,0,0.23,0,' 0轴上下柱线是DJG_MACD指标的柱线;'),COLORGRAY;

    浏览9350次浏览
    2022-09-05 10:11
  • 神奇指标

    快速短线 (源码 副图 通达信 贴图)

    以下是快速短线 (源码 副图 通达信 贴图) 用法:  短线看K,D线,中线看红绿方形指标。  短线可参考中线指标来做,红色持股、   {快速短线}   A6:EMA(CLOSE,5),COLORGREEN; A10:EMA(CLOSE,10),COLORGREEN; RJ:(C+O)*1/2; STICKLINE(A6>REF(A6,3),A6,REF(A6,1),1,1),COLORRED; STICKLINE(A6<REF(A6,3),A6,REF(A6,1),1,1),COLORGREEN; IF(C>A6,A6,DRAWNULL),COLORWHITE,LINETHICK2; IF(C>A10,A10,DRAWNULL),COLORRED,LINETHICK2; JJJ:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3)); DDD:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01); JJJT:=IF(DDD,1,(JJJ<(DYNAINFO(5)+0.01) && JJJ>(DYNAINFO(6)-0.01))); CYC1:IF(JJJT,0.01*EXPMA(AMOUNT,6)/EXPMA(VOL,6),EMA((HIGH+LOW+CLOSE)/3,6)),COLORGREEN; CYC2:IF(JJJT,0.01*EXPMA(AMOUNT,8)/EXPMA(VOL,8),EMA((HIGH+LOW+CLOSE)/3,8)),COLORGREEN; CYC3:IF(JJJT,0.01*EXPMA(AMOUNT,34)/EXPMA(VOL,34),EMA((HIGH+LOW+CLOSE)/3,34)); CYC∞:IF(JJJT,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120)); IF(CYC1>REF(CYC1,1) OR C>CYC1,CYC1,DRAWNULL),COLORWHITE,LINETHICK2; IF(C>CYC2,CYC2,DRAWNULL),COLORRED,LINETHICK2; B:=CROSS(CYC1>REF(CYC1,1) AND CYC2>REF(CYC2,1) AND CYC3>REF(CYC3,1) AND CYC∞>REF(CYC∞,1) AND C>CYC∞ AND RJ>REF(RJ,1) AND A6>REF(A6,1),0.2); 拉升进入:= CROSS(C,CYC∞) AND CYC∞>REF(CYC∞,1) AND CYC1>REF(CYC1,1) AND CYC2>REF(CYC2,1) AND CYC3>REF(CYC3,1); DRAWTEXT(B,LOW-(H-L)*0.6,'升'); DRAWTEXT(拉升进入,LOW-(H-L)*0.96,'拉升');

    浏览1182次浏览
    2022-09-05 10:10
  • 神奇指标

    股神短线 可以一年翻倍短线精典指标

    以下是股神短线 可以一年翻倍短线精典指标 股神短线 可以一年翻倍短线精典指标 这个指标如果用好了,可以一年翻倍没有问题。  大家在使用时一定要好好的研究一下,找到它的特点,这样使用起来才能得心应手。成为你强大的利器。  具体用法:    1 见红色的柱出现就买,    2 黄色出来就卖。    3 还可以等黄色的柱消失的时候卖。    4 每次赚5%就跑。不要贪。    5 记住以上规则,按规则操作 源码 A:0,POINTDOT,COLORMAGENTA,LINETHICK3; DIFF:= EMA(CLOSE,12) - EMA(CLOSE,26),COLORBLUE,LINETHICK2; DEA1:=EMA(DIFF,9);0.10,COLORBLUE,LINETHICK2; MACD: 2*(DIFF-DEA1)*60,LINETHICK0; S1:=MACD<REF(MACD,1)AND MACD>0,COLORBLUE; S2:=MACD<REF(MACD,1)/2 AND MACD<0; STICKLINE(MACD>=0,MACD,0,5,1),COLORRED; STICKLINE(S1,0,MACD,5,1),COLOR00FFFF;  

    浏览10242次浏览
    2022-09-05 10:06
  • 神奇指标

    看长线做短线 准确率超高 副图 指标 通达信 源码 贴图 加密 无未来

    以下是看长线做短线 准确率超高 副图 指标 通达信 源码 贴图 加密 无未来 经过实盘操作,准确率很高的  指标里有具体的使用说明; VAR1S:=(CLOSE*2+HIGH+LOW)/4;  VAR2S:=(EMA(VAR1S,13)-EMA(VAR1S,34))/EMA(VAR1S,34)*100;  VAR3S:=EMA(VAR2S,5); 主力控盘:=2*(VAR2S-VAR3S)*3.8;  SA1:= 主力控盘,COLORWHITE,NODRAW; SA2:=SA1-REF(SA1,1);  SA3:=MA(SA1,3),COLORGREEN;  SAA3:=MA(SA1,7),COLORCYAN;  SAA4:=MA(SA1,13),COLORRED; MM1:=MA(CLOSE,5);  Q5:(MM1-REF(MM1,1))/REF(MM1,1)*100,NODRAW,COLORMAGENTA; MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);  HD2 :=HIGH-REF(HIGH,1);  LD2 :=REF(LOW,1)-LOW;  DMP2:=EXPMEMA(IF(HD2>0&&HD2>LD2,HD2,0),14);  DMM2:=EXPMEMA(IF(LD2>0&&LD2>HD2,LD2,0),14);  PDI2:=DMP2*100/MTR;  MDI2:=DMM2*100/MTR;  ADX:=EXPMEMA(ABS(MDI2-PDI2)/(MDI2+PDI2)*100,6);  ADXR:=EXPMEMA(ADX,6);  SAA31:=SAA3-REF(SAA3,1); ADXR12:=MA(ADX,3);  ADXR13:=ADX-ADXR12;  ADXR14:=ADX-ADXR;  ZK2:=ADX<16;  ZK3:=(ADXR<16&&ADX<20);  ZK31:=ADXR<20&&ADXR>ADX;  ZK4:=(ADX<MDI2&&ADXR<MDI2&&ADX<30);  ZK41:=(ADX<PDI2&&ADXR<PDI2&&PDI2>MDI2&&ADX<30&&ADX<REF(ADX,1));  ZK5:=(ZK2 OR ZK3 OR ZK31);  SWQ1:=MAX(ADX,ADXR);  AD1:=ADX-REF(ADX,1); Y:=(H+O+L+3*C)/6;  X:=EMA(100-(100/(1+SUM(IF(Y>REF(Y,1),Y*VOL,0),13)/SUM(IF(Y<REF(Y,1),Y*VOL,0),13))),5),COLOR00FFFF,LINETHICK2; AA:=30>X,LINETHICK0;  BB:=X>80,LINETHICK0; VAR1:=(C-MA(C,6))/MA(C,6)*100;  VAR2:=(C-MA(C,24))/MA(C,24)*100;  VAR3:=(C-MA(C,32))/MA(C,32)*100;  VAR4:=(VAR1+VAR2+VAR3)/3;  VAR5:=EMA(VAR4,5);  VAR6:=MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;  VAR7:=SMA(SMA(100-3*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1)+SMA(2*(C-LLV(C,75))/(HHV(H,75)-LLV(L,75))*100,20,1),15,1);  VAR8:=VAR7<REF(VAR7,1) AND V>REF(V,1) AND C>REF(C,1);  K:EMA(VAR5,5)*4;  D:EMA(K,5),NODRAW,COLOR38B0DE;  J:K*3-D*2,NODRAW,COLORCC66FF;  MACD:EMA(EMA(VAR1,5),5)*6,NODRAW,COLORWHITE;  {DRAWBAND(J,RGB(238,238,6),K,RGB(256,150,60));}  DRAWBAND(K,RGB(238,238,6),D,RGB(256,150,60)); 按短线卖:IF(EXIST(Q5>2.5,5),-60,DRAWNULL),LINETHICK7,COLORGREEN; 按短线卖2:IF(EVERY(Q5<2.5,5)&&MACD>8,-60,DRAWNULL),LINETHICK7,COLORYELLOW; 按短线买:IF(EXIST(Q5<-2.5,5),-60,DRAWNULL),LINETHICK7,COLORRED; 中线股:IF(SA1>0,-40,DRAWNULL),LINETHICK7,COLORMAGENTA; 中线币:IF(SA1<0,-40,DRAWNULL),LINETHICK7,COLORGREEN; 盘整币:IF(MDI2>ADXR OR ZK5,-30,DRAWNULL),LINETHICK7,COLORGREEN;  DRAWTEXT(EVERY(Q5<1,4)&&Q5>0&&MACD>REF(MACD,1)&&REF(MACD,1)<REF(MACD,2)&&EVERY(Q5>-0.5,4),MACD*1.04,'P卖'),COLORGREEN; STICKLINE(SA1<REF(SA1,1),0,MACD*1.03,2,1),COLORGREEN; STICKLINE(SA1>REF(SA1,1)&&SA1>0,0,MACD*1.03,2,1),COLORRED;  STICKLINE(Q5>5&&SA1>0&&MACD>REF(MACD,1),0,MACD*1.03,2,1),COLORRED;  DRAWTEXT(AA&&SA1>REF(SA1,1),MACD*1.1,'吸货'),COLOR0066FF; DRAWTEXT(BB&&SA1<REF(SA1,1),MACD*1.1,'派发'),COLORFFFF00;  DRAWTEXT(CROSS(3,Q5)&&EXIST(Q5>4,6),MACD*1.1,'卖4'),COLORGREEN;  DRAWTEXT(CROSS(4,Q5)&&EXIST(Q5>5,6),MACD*1.1,'卖5'),COLORGREEN;  DRAWTEXT(CROSS(5,Q5)&&EXIST(Q5>6,6),MACD*1.1,'卖6'),COLORGREEN;  DRAWTEXT(CROSS(6,Q5)&&EXIST(Q5>7,5),MACD*1.1,'卖7'),COLORGREEN;  STICKLINE(MACD>0,0,MACD,1,0),COLORRED;  STICKLINE(MACD>0 AND MACD<REF(MACD,1),0,MACD,1,0),COLORFFFF00;  STICKLINE(MACD<0,0,MACD,1,0),COLORFF9900;  STICKLINE(MACD<0 AND MACD>REF(MACD,1),0,MACD,1,0),COLORFF00FF;  MA3:=MA(CLOSE,3);  YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6; 辰星线:=(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLOR0000FF; 牵牛线:=MA(CLOSE,26),COLORFF00FF;  CX1:=辰星线; QN1:=牵牛线; IF(CX1>REF(CX1,1)&&CX1>QN1,-50,DRAWNULL),LINETHICK7,COLORRED;  IF(CX1>REF(CX1,1)&&CX1<QN1,-50,DRAWNULL),LINETHICK7,COLORMAGENTA;  IF(CX1<REF(CX1,1)&&CX1<QN1,-50,DRAWNULL),LINETHICK7,COLORGREEN;  IF(CX1<REF(CX1,1)&&CX1>QN1,-50,DRAWNULL),LINETHICK7,COLORCYAN; DRAWTEXT(NDAY(SA1,0,2)&&CX1>REF(CX1,1)&&MACD>REF(MACD,1)&&REF(MACD,1)<REF(MACD,2),MACD*1.1,'BBB'),COLORMAGENTA;  DA:=(3*CLOSE+OPEN+LOW+HIGH)/6,POINTDOT;  X2:=(20*DA+19*REF(DA,1)+18*REF(DA,2)+17*REF(DA,3)+16*REF(DA,4)+15*REF(DA,5)+14*REF(DA,6)+13*REF(DA,7)+12*REF(DA,8)+11*REF(DA,9)+10*REF(DA,10)+9*REF(DA,11)+8*REF(DA,12)+7*REF(DA,13)+6*REF(DA,14)+5*REF(DA,15)+4*REF(DA,16)+3*REF(DA,17)+2*REF(DA,18)+REF(DA,20))/210,COLORF0F000;  X3:=(MA(X2,3)+MA(X2,2))/2,COLORYELLOW,LINETHICK1;  DRAWTEXT(SA1>REF(SA1,1)&&SA1>0&&REF(SA1,1)<REF(SA1,2)&&X2>X3,MACD*1.1,'信号1'),COLORMAGENTA;  DRAWTEXT(Q5>5&&SA1>0&&MACD>REF(MACD,1)&&REF(MACD,1)<REF(MACD,2)&&X2>X3,MACD*1.1,'信号2'),COLORRED;  DRAWTEXT(MACD>0&&MACD>REF(MACD,1)&&REF(MACD,1)<REF(MACD,2)&&X2>X3,-3,'信号3'),COLORRED;  DRAWTEXT(MACD<0 AND MACD>REF(MACD,1)&&REF(MACD,1)<REF(MACD,2)&&X2>X3,MACD*1.1,'信号4'),COLORWHITE;  -60;  -50;  -40;  -30;

    浏览9776次浏览
    2022-09-05 10:01
  • 神奇指标

    无敌短线 ( 选股 预警 )

    以下是无敌短线 ( 选股 预警 ) 无敌短线 献上无敌短线,提前祝友友们新年快乐,收益长红! 此指标 ,绝对无未来,你可以沙盘,这个你懂的. 有些股,中长线也不错.

    浏览9170次浏览
    2022-09-05 10:01