神奇指标网
神奇指标网
  • 神奇指标

    大智慧黄金分割 (带压力阻力齐全主图!配图!源码)

    以下是黄金分割 (带压力阻力齐全主图!配图!源码) C/C++ 提供 Code复制内容到剪贴板input:K(1,1,3); T:=BARSLAST(DISPSTATUS=1)+1; A:=DISPSTATUS=2;HH:=HHV(H, T);LL:=LLV(L, T);HL:=HH-LL;wH:=HHVBARS(H, T);wL:=LLVBARS(L, T); KK:=wH-wL;mHL:=HH-HL*0.5; if K=1 then begin HL191:=(HH-LL)*0.191;HL382:=(HH-LL)*0.382;HL618:=(HH-LL)*0.618;HL809:=(HH-LL)*0.809; if KK<0 then begin a1:=HH-HL191;a2:=HH-HL382;a3:=HH-HL618;a4:=HH-HL809; end else begin a1:=LL+HL191;a2:=LL+HL382;a3:=LL+HL618;a4:=LL+HL809; end end if k=1 then begin HL125:=(HH-LL)*0.125;HL250:=(HH-LL)*0.25;HL375:=(HH-LL)*0.375;HL625:=(HH-LL)*0.625;HL750:=(HH-LL)*0.75;HL875:=(HH-LL)*0.875; if kk<0 then begin b1:=HH-HL125;b2:=HH-HL250;b3:=HH-HL375;b4:=HH-HL625;b5:=HH-HL750;b6:=HH-HL875; end else begin b1:=LL+HL125;b2:=LL+HL250;b3:=LL+HL375;b4:=LL+HL625;b5:=LL+HL750;b6:=LL+HL875; end end DRAWTEXT(A and K<>3,HH, '最高价:'+HH),ALIGN2,CulorFF00FF; DRAWTEXT(A and K<>3,LL, '最低价:'+ll),ALIGN2,VALIGN2,Culor00FF00; DRAWTEXT(A and K<>3,mHL,'50%:'+mHL),ALIGN2,CulorFF8000; DRAWTEXT(A and K=1, a1, '0.191:'+NUMTOSTRN(a1,2)),ALIGN2,Culor4080FF; DRAWTEXT(A and K=1, a2, '0.382:'+NUMTOSTRN(a2,2)),ALIGN2,Culor4080FF; DRAWTEXT(A and K=1, a3, '0.618:'+NUMTOSTRN(a3,2)),ALIGN2,Culor4080FF; DRAWTEXT(A and K=1, a4, '0.809:'+NUMTOSTRN(a4,2)),ALIGN2,Culor4080FF; DRAWTEXT(A and K=1, b1, '1/8:'+NUMTOSTRN(b1,2)),ALIGN2,CulorC0C0C0; DRAWTEXT(A and K=1, b2, '1/4:'+NUMTOSTRN(b2,2)),ALIGN2,CulorC0C0C0; DRAWTEXT(A and K=1, b5, '3/4:'+NUMTOSTRN(b5,2)),ALIGN2,CulorC0C0C0; DRAWTEXT(A and K=1, b6, '7/8:'+NUMTOSTRN(b6,2)),ALIGN2,CulorC0C0C0; DRAWTEXT(A and K<>3,HH, ' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,culorred,linethick7; DRAWTEXT(A and K<>3,LL, ' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,culorred,linethick7; DRAWTEXT(A and K<>3,mHL,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN2,CulorFF8000,linethick7; DRAWTEXT(A and K=1, a1, '﹊﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊'),ALIGN2,culor208FFF,linethick0; DRAWTEXT(A and K=1, a2, '﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊'),ALIGN2,culor208FFF,linethick0; DRAWTEXT(A and K=1, a3, '﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊﹊'),ALIGN2,culor208FFF,linethick0; DRAWTEXT(A and K=1, a4, '﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊ ﹊﹊﹊'),ALIGN2,culor208FFF,linethick0; DRAWTEXT(A and K=1, b1, '﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),ALIGN2,CulorC0C0C0; DRAWTEXT(A and K=1, b2, '﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),ALIGN2,CulorC0C0C0; DRAWTEXT(A and K=1, b5, '﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),ALIGN2,CulorC0C0C0; DRAWTEXT(A and K=1, b6, '﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉﹉'),ALIGN2,CulorC0C0C0; 市场成本:DMA(AMOUNT/V/100,V/CAPITAL),Culor0080FF,LINETHICK1; DRAWICON(CROSS(C,市场成本),L,1),ALIGN1; PT:= REF(HIGH,1)-REF(LOW,1); 重心:=(HIGH + LOW + CLOSE)/3; 压力Ⅰ:=2*重心-LOW;压力Ⅱ:= 重心 + PT; 支撑Ⅰ:=2*重心-HIGH;支撑Ⅱ:= 重心 - PT; DRAWTEXTABS(50,68,' 重心:'+重心),Culor208FFF; DRAWTEXTABS(20,87,' 支 撑'),Culor00FF00; DRAWTEXTABS(20,104,' '+支撑Ⅰ),Culor00FF00; DRAWTEXTABS(20,122,' '+支撑Ⅱ),Culor00FF00; DRAWTEXTABS(25,87,' 压 力'),CulorFF00FF; DRAWTEXTABS(25,104,' '+压力Ⅰ),CulorFF00FF; DRAWTEXTABS(25,122,' '+压力Ⅱ),CulorFF00FF; DRAWTEXTABS(25,65,'│'),Culor00FFFF; DRAWTEXTABS(25,77,'│'),Culor00FFFF; DRAWTEXTABS(25,89,'│'),Culor00FFFF; DRAWTEXTABS(25,101,'│'),Culor00FFFF; DRAWTEXTABS(25,113,'│'),Culor00FFFF; DRAWTEXTABS(25,125,'│'),Culor00FFFF; DRAWTEXTABS(170,65,'│'),Culor00FFFF; DRAWTEXTABS(170,77,'│'),Culor00FFFF; DRAWTEXTABS(170,89,'│'),Culor00FFFF; DRAWTEXTABS(170,101,'│'),Culor00FFFF; DRAWTEXTABS(170,113,'│'),Culor00FFFF; DRAWTEXTABS(170,125,'│'),Culor00FFFF; DRAWTEXTABS(96,85,'│'),Culor00FFFF; DRAWTEXTABS(96,89,'│'),Culor00FFFF; DRAWTEXTABS(96,101,'│'),Culor00FFFF; DRAWTEXTABS(96,113,'│'),Culor00FFFF; DRAWTEXTABS(96,125,'│'),Culor00FFFF; DRAWTEXTABS(30,60,'──────────'),Culor00FFFF; DRAWTEXTABS(30,80,'──────────'),Culor00FFFF; DRAWTEXTABS(30,97,'──────────'),Culor00FFFF; DRAWTEXTABS(30,114,'──────────'),Culor00FFFF; DRAWTEXTABS(30,131,'──────────'),Culor00FFFF; G:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3); X:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3); ED:=barslast(G); EF:=barslast(X); DRAWTEXTREL(25,410,'买入:'+NUMTOSTR(ED) +'天'+' 卖出:'+NUMTOSTR(EF) +'天' ),culorFfff00; {K线优化} STICKLINE(close>=open,open,close,8,1),culorred; STICKLINE(open>close,close,open,8,0 ),CulorFFFF00; STICKLINE(close>=open,close,HIGH,0.5 ,0 ),culorred; STICKLINE(close>=open,open,low,0.5 ,0),culorred; STICKLINE(open>close,close,low,0.5 ,0 ),CulorFFFF00; STICKLINE(open>close,open,HIGH,0.5 ,0 ),CulorFFFF00; C2:=REF(C,1); 涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0); STICKLINE(涨停,OPEN,CLOSE,8,0),Culor00FFFF; 跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0); STICKLINE(跌停,OPEN,CLOSE,8,0),CulorFF8000; {粉兰色K线}; F:=100*(C-REF(C,1))/REF(C,1); 今小昨:=IF(C<REF(O,1) AND f<0,1,0); p1:=今小昨; 今小前:=IF(C<REF(O,2) AND f<0,1,0); p2:=今小前; stickline(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,open,CLOSE,6,0),COLORMAGENTA; stickline(P1=1 AND REF(P1,1)=0 AND P2=1 AND REF(P2,1)=0,open,CLOSE,3,0),COLORBLUE; DRAWTEXT(G,L*0.997,'△'),ALIGN1,VALIGN0,Culor00FF00; DRAWTEXT(G,L,' ̄'),ALIGN1,VALIGN0,Culor00ff00; DRAWTEXT(X,H*1.002,'▽'),ALIGN1,VALIGN2,CulorFF00FF; DRAWTEXT(X,H,' ̄'),ALIGN1,VALIGN0,CulorFF00FF; DRAWTEXTREL(130,25,'所属板块:'+BKNAME),COLORFFFFFF; 今市上涨家数:=INDEXADV; 平盘家数:=DYNAINFO(68); 今市下跌家数:=INDEXDEC;

    浏览4328次浏览
    2022-10-20 14:24
  • 神奇指标

    通达信黄金分割 麦克指标 主副图选股公式

    以下是通达信黄金分割 麦克指标 主副图选股公式黄金分割 麦克指标 主副图选股公式突破黄金分割线和麦克指标线可能会有一个起爆。指标不加密,通达信软件导入指标后可看到源码。其中的几条线自己也可以组合使用

    浏览7609次浏览
    2022-10-12 11:15
  • 神奇指标

    通达信黄金通道 黄金分割 主图公式

    以下是通达信黄金通道 黄金分割 主图公式黄金通道 黄金分割 主图公式N2:=5;A1:=REF(H,N2)=HHV(H,2*N2+1); B1:=FILTER(A1,N2); C1:=BACKSET(B1,N2+1); HD:= FILTER(C1,N2);RH:=BACKSET(CURRBARSCOUNT=2,BARSLAST(HD)+1); SH:=RH>REF(RH,1);H1:=REF(H ,BARSLAST(SH));STICKLINE(H1,H1,H1,5,0),LINETHICK2,COLOR00FFFF;DRAWTEXT(ISLASTBAR,H1*1.005,'近期高点'),COLORFFFF00;TTP:=(CURRBARSCOUNT=5-4);DRAWNUMBER(TTP AND H1,H1,H1),COLORFFFF00;A2:=REF(L,N2)=LLV(L,2*N2+1); B2:=FILTER(A2,N2); C2:=BACKSET(B2,N2+1); LD:=FILTER(C2,N2); RL:=BACKSET(CURRBARSCOUNT=2,BARSLAST(LD)+1); SL:=RL>REF(RL,1);L1:=REF(L ,BARSLAST(SL));STICKLINE(L1,L1,L1,5,0),COLORFFFF00,LINETHICK5;DRAWTEXT(ISLASTBAR,L1*1.005,'近期低点'),COLORFFFF00;DRAWNUMBER(TTP AND L1,L1,L1),COLOR00FFFF;VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);VAR2:=REF(VAR1,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR4:=REF(VAR3,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR6:=REF(VAR5,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR8:=REF(VAR7,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VARA:=REF(VAR9,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VARC:=REF(VARB,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);STICKLINE(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 ORVAR8 OR VAR9 OR VARA OR VARB OR VARC,CLOSE,REF(CLOSE,1),3,1),COLORRED;{红1}VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VARF:=REF(VARE,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR11:=REF(VAR10,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR13:=REF(VAR12,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR15:=REF(VAR14,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);VAR17:=REF(VAR16,1) AND CLOSE<=ref(close,1) and="" close="">=REF(CLOSE,2);VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);STICKLINE(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 ORVAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,CLOSE,REF(CLOSE,1),3,0),COLORFFCC66;VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 ORVAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),4,1),COLORYELLOW;VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),4,2),COLOR00FF00{98FD};STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00C8FF;STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLOR10ECFF;STICKLINE(VAR19,REF(CLOSE,1),REF(CLOSE,2),2,0),COLORRED;{黄托底}STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLOR00D900;STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),3,0),COLORBLUE;{蓝压顶}STICKLINE(VAR1A,REF(CLOSE,1),REF(CLOSE,2),0,0),COLOR090FF2;FG:IF (HIGH>PEAK(1,7,1),HHV(HIGH,21),PEAK(1,7,1)),COLORGREEN;FD:IF (LOW<TROUGH(2,7,1),LLV(LOW,21),TROUGH(2,7,1)),COLORRED;分割0.191:(FG-FD)*0.191+FD,DOTLINE,COLORMAGENTA;分割0.382:(FG-FD)*0.382+FD,DOTLINE,COLORCYAN;分割0.5:(FG-FD)*0.5+FD,DOTLINE,COLORGREEN;分割0.618:(FG-FD)*0.618+FD,DOTLINE,COLORCYAN;分割0.809:(FG-FD)*0.809+FD,DOTLINE,COLORYELLOW;DRAWTEXT(ISLASTBAR>0 ,ABS(分割0.191),'F0.191')COLORMAGENTA;DRAWTEXT(ISLASTBAR>0 ,ABS(分割0.382),'F0.382')COLORCYAN;DRAWTEXT(ISLASTBAR>0 ,ABS(分割0.5),'F0.500')COLORGREEN;DRAWTEXT(ISLASTBAR>0 ,ABS(分割0.618),'F0.618')COLORCYAN;DRAWTEXT(ISLASTBAR>0 ,ABS(分割0.809),'F0.809')COLORYELLOW;

    浏览3959次浏览
    2022-09-26 11:36
  • 神奇指标

    黄金分割 KT

    以下是黄金分割 KT {黄金分割 KT(1,99,4);} GD:=HHV(H,30); GG:=HHV(H,30); DD:=LLV(L,30); Z618:=0.618*GG+DD*0.382; Z382:=0.382*GG+DD*0.618; STICKLINE(CURRBARSCOUNT=KT,DD,GG,0,-1); STICKLINE(CURRBARSCOUNT=KT,DD,DD,10,0); STICKLINE(CURRBARSCOUNT=KT,GG,GG,10,0); STICKLINE(CURRBARSCOUNT=KT,Z618,Z618,10,-1); STICKLINE(CURRBARSCOUNT=KT,Z382,Z382,10,-1); DRAWNUMBER(CURRBARSCOUNT=KT+2,GG,GG),COLORWHITE; DRAWNUMBER(CURRBARSCOUNT=KT+2,DD,DD)DRAWABOVE,COLORWHITE; DRAWNUMBER(CURRBARSCOUNT=KT+2,Z618,0.618)DRAWABOVE,COLORWHITE; DRAWNUMBER(CURRBARSCOUNT=KT+2,Z618,Z618),COLORWHITE; DRAWNUMBER(CURRBARSCOUNT=KT+2,Z382,0.382)DRAWABOVE,COLORWHITE; DRAWNUMBER(CURRBARSCOUNT=KT+2,Z382,Z382),COLORWHITE;

    浏览9547次浏览
    2022-09-05 09:39
  • 神奇指标

    通达信百分等比尺 +黄金分割 + 斐波那契周期源码主图说明 )

    以下是通达信百分等比尺 +黄金分割 + 斐波那契周期源码主图说明 ) 又是一翻牛熊,由此得到这次的最牛股,  根据其涨幅作出,以近期最低点百分之十的递增作尺,用四种色彩分标四个区间。 (涨停价为尺码) 下跌同样以最高点的百之十,二十,三十----标尺码。  另指标优化黄金分割,取当前屏的高低位分割。  斐波那契周期也可在小周期正常显示无压缩。  更多的优化,自我体会。 {高点 1 999 22  低点 1 999 1} GD:=CONST(FINDHIGH(H,0,高点*10,1)); DD:=CONST(FINDLOW(L,0,低点*10,1)); GT:=CONST(BARSLAST(GD=H))+1; DT:=CONST(BARSLAST(DD=L))+1; SH:=CONST(IF(GT=1,H,REF(H,GT-1))); SL:=CONST(IF(DT=1,L,REF(L,DT-1))); 下跌周期:BARSLAST(GD=H),COLORWHITE,NODRAW; 下跌幅:IF(CURRBARSCOUNT<=GT,C/SH*100-100,DRAWNULL),NODRAW,COLORGREEN; 下跌均价:IF(CURRBARSCOUNT<=GT,SUM(AMOUNT,GT)/SUM(V,GT)/100,DRAWNULL),NODRAW,COLORLIGRAY; 跌换手%:IF(CURRBARSCOUNT<=GT,SUM(HSL.HSL,GT),DRAWNULL),COLORCYAN,NODRAW; 上涨周期:IF(CURRBARSCOUNT<=DT,BARSLAST(DD=L),DRAWNULL),COLORWHITE,NODRAW; 上涨幅:IF(CURRBARSCOUNT<=DT,C/SL*100-100,DRAWNULL),NODRAW,COLORRED; 上涨均价:IF(CURRBARSCOUNT<=DT,SUM(AMOUNT,DT)/SUM(V,DT)/100,DRAWNULL),NODRAW,COLORLIGRAY; 涨换手%:IF(CURRBARSCOUNT<=DT,SUM(HSL.HSL,DT),DRAWNULL),COLORLIMAGENTA,NODRAW; 星期:=VARCAT(VARCAT('(',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五','')))))),')'); 日期:=VARCAT(VARCAT(VARCAT(VARCAT(VARCAT(VARCAT(VAR2STR(YEAR,0),'年'),VAR2STR(MONTH,0)),'月'),VAR2STR(DAY,0)),'日'),星期); {黄金分割  普通 等系坐标} DRAWRECTREL(990,2,998,188,RGB(0,150,180)),NOFRAME; DRAWRECTREL(990,188,998,375,RGB(200,200,0)),NOFRAME; DRAWRECTREL(990,375,998,491,RGB(100,200,0)),NOFRAME; DRAWRECTREL(990,491,998,607,RGB(200,10,80)),NOFRAME; DRAWRECTREL(990,607,998,794,RGB(150,0,0)),NOFRAME; DRAWRECTREL(990,794,998,982,RGB(150,150,150)),NOFRAME; DRAWKLINE(H,O,L,C); DRAWTEXT_FIX(1,0.005,0.01,0,'云枫添外 2016/05/09'),COLORLIGRAY; {斐波那契周期} DRAWTEXT(CURRBARSCOUNT=GT-2 ,L,'3'),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=GT-4 ,L,'5'),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=GT-7 ,L,'8'),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=GT-12 ,L,'13'),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=GT-20 ,L,'21'),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=GT-33 ,L,'34 '),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=GT-54 ,L,'55'),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=GT-88 ,L,'89'),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=GT-143 ,L,'144'),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=GT-232 ,L,'233'),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=GT-376 ,L,'377'),COLOR00FF00; DRAWTEXT(CURRBARSCOUNT=DT-2,H,'3'),DRAWABOVE,COLORRED; DRAWTEXT(CURRBARSCOUNT=DT-4,H,'5'),DRAWABOVE,COLORRED; DRAWTEXT(CURRBARSCOUNT=DT-7,H,'8'),DRAWABOVE,COLORRED; DRAWTEXT(CURRBARSCOUNT=DT-12,H,'13'),DRAWABOVE,COLORRED; DRAWTEXT(CURRBARSCOUNT=DT-20,H,'21'),DRAWABOVE,COLORRED; DRAWTEXT(CURRBARSCOUNT=DT-33,H,'34'),DRAWABOVE,COLORRED; DRAWTEXT(CURRBARSCOUNT=DT-54,H,'55'),DRAWABOVE,COLORRED; DRAWTEXT(CURRBARSCOUNT=DT-88,H,'89'),DRAWABOVE,COLORRED; DRAWTEXT(CURRBARSCOUNT=DT-143,H,'144'),DRAWABOVE,COLORRED; DRAWTEXT(CURRBARSCOUNT=DT-232,H,'233'),DRAWABOVE,COLORRED; DRAWTEXT(CURRBARSCOUNT=DT-376,H,'377'),DRAWABOVE,COLORRED; {幅度尺} A1:=ZTPRICE(REF(SL,1),0.1); A2:=ZTPRICE(REF(A1,1),0.1); A3:=ZTPRICE(REF(A2,1),0.1); A4:=ZTPRICE(REF(A3,1),0.1); A5:=ZTPRICE(REF(A4,1),0.1); A6:=ZTPRICE(REF(A5,1),0.1); A7:=ZTPRICE(REF(A6,1),0.1); A8:=ZTPRICE(REF(A7,1),0.1); A9:=ZTPRICE(REF(A8,1),0.1); A10:=ZTPRICE(REF(A9,1),0.1); A11:=ZTPRICE(REF(A10,1),0.1); A12:=ZTPRICE(REF(A11,1),0.1); A13:=ZTPRICE(REF(A12,1),0.1); A14:=ZTPRICE(REF(A13,1),0.1); A15:=ZTPRICE(REF(A14,1),0.1); A16:=ZTPRICE(REF(A15,1),0.1); A17:=ZTPRICE(REF(A16,1),0.1); A18:=ZTPRICE(REF(A17,1),0.1); A19:=ZTPRICE(REF(A18,1),0.1); A20:=ZTPRICE(REF(A19,1),0.1); A21:=ZTPRICE(REF(A20,1),0.1); A22:=ZTPRICE(REF(A21,1),0.1); A23:=ZTPRICE(REF(A22,1),0.1); A24:=ZTPRICE(REF(A23,1),0.1); A25:=ZTPRICE(REF(A24,1),0.1); A26:=ZTPRICE(REF(A25,1),0.1); A27:=ZTPRICE(REF(A26,1),0.1); A28:=ZTPRICE(REF(A27,1),0.1); A29:=ZTPRICE(REF(A28,1),0.1); A30:=ZTPRICE(REF(A29,1),0.1); A31:=ZTPRICE(REF(A30,1),0.1); A32:=ZTPRICE(REF(A31,1),0.1); STICKLINE(CURRBARSCOUNT=DT,SH,SL,0,-1),COLORRED; STICKLINE(CURRBARSCOUNT=GT,SH,SL,0,-1),COLORGREEN; DRAWTEXT(CURRBARSCOUNT=DT ,(SL+A1)/2,日期),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=GT ,GD*0.97,日期),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.1,'一10%'),COLORBLUE; DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.15,'一15%'),COLORCYAN; DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.2,'一20%'),COLORGREEN; DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.3,'一30%'),COLORWHITE; DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.4,'一40%'),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.5,'一50%'),COLORRED; DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.6,'一60%'),COLORLIMAGENTA; DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.7,'一70%'),COLORMAGENTA; DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.8,'一80%'),COLORWHITE; DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.9,'一90%'),COLORGREEN; DRAWTEXT(CURRBARSCOUNT=DT,A1,STRCAT('一 ',CON2STR(A1,2))); DRAWTEXT(CURRBARSCOUNT=DT,A2,STRCAT('一 ',CON2STR(A2,2))); DRAWTEXT(CURRBARSCOUNT=DT,A3,STRCAT('一 ',CON2STR(A3,2))); DRAWTEXT(CURRBARSCOUNT=DT,A4,STRCAT('一 ',CON2STR(A4,2))); DRAWTEXT(CURRBARSCOUNT=DT,A5,STRCAT('一 ',CON2STR(A5,2))); DRAWTEXT(CURRBARSCOUNT=DT,A6,STRCAT('一 ',CON2STR(A6,2))); DRAWTEXT(CURRBARSCOUNT=DT,A7,STRCAT('一 ',CON2STR(A7,2))); DRAWTEXT(CURRBARSCOUNT=DT,A8,STRCAT('一 ',CON2STR(A8,2))); DRAWTEXT(CURRBARSCOUNT=DT,A9,STRCAT('一 ',CON2STR(A9,2))),COLORRED; DRAWTEXT(CURRBARSCOUNT=DT,A10,STRCAT('一 ',CON2STR(A10,2))),COLORRED; DRAWTEXT(CURRBARSCOUNT=DT,A11,STRCAT('一 ',CON2STR(A11,2))),COLORRED; DRAWTEXT(CURRBARSCOUNT=DT,A12,STRCAT('一 ',CON2STR(A12,2))),COLORRED; DRAWTEXT(CURRBARSCOUNT=DT,A13,STRCAT('一 ',CON2STR(A13,2))),COLORRED; DRAWTEXT(CURRBARSCOUNT=DT,A14,STRCAT('一 ',CON2STR(A14,2))),COLORRED; DRAWTEXT(CURRBARSCOUNT=DT,A15,STRCAT('一 ',CON2STR(A15,2))),COLORRED; DRAWTEXT(CURRBARSCOUNT=DT,A16,STRCAT('一 ',CON2STR(A16,2))),COLORRED; DRAWTEXT(CURRBARSCOUNT=DT,A17,STRCAT('一 ',CON2STR(A17,2))),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=DT,A18,STRCAT('一 ',CON2STR(A18,2))),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=DT,A19,STRCAT('一 ',CON2STR(A19,2))),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=DT,A20,STRCAT('一 ',CON2STR(A20,2))),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=DT,A21,STRCAT('一 ',CON2STR(A21,2))),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=DT,A22,STRCAT('一 ',CON2STR(A22,2))),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=DT,A23,STRCAT('一 ',CON2STR(A23,2))),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=DT,A24,STRCAT('一 ',CON2STR(A24,2))),COLORYELLOW; DRAWTEXT(CURRBARSCOUNT=DT,A25,STRCAT('一 ',CON2STR(A25,2))),COLORGREEN; DRAWTEXT(CURRBARSCOUNT=DT,A26,STRCAT('一 ',CON2STR(A26,2))),COLORGREEN; DRAWTEXT(CURRBARSCOUNT=DT,A27,STRCAT('一 ',CON2STR(A27,2))),COLORGREEN; DRAWTEXT(CURRBARSCOUNT=DT,A28,STRCAT('一 ',CON2STR(A28,2))),COLORGREEN; DRAWTEXT(CURRBARSCOUNT=DT,A29,STRCAT('一 ',CON2STR(A29,2))),COLORGREEN; DRAWTEXT(CURRBARSCOUNT=DT,A30,STRCAT('一 ',CON2STR(A30,2))),COLORGREEN; DRAWTEXT(CURRBARSCOUNT=DT,A31,STRCAT('一 ',CON2STR(A31,2))),COLORGREEN; DRAWTEXT(CURRBARSCOUNT=DT,A32,STRCAT('一 ',CON2STR(A32,2))),COLORGREEN;  

    浏览7184次浏览
    2022-09-05 09:38
  • 神奇指标

    大智慧集自划线 黄金分割 斐波那契周期 于一体的主图指标 分析K线的利器

    以下是集自划线 黄金分割 斐波那契周期 于一体的主图指标 分析K线的利器 这主图非常不错 不是原创 不知可以发帖不 N年前一位前辈的东西 珍藏好多年  简短说明:  这是一个非常出色的主图 买卖点有未来 所以 作为分析主图是很棒的 千万别改选股  不然会害死你  没有未来的主图 错误有很多 没啥参考意义 所以 作为分析图 就不该有买卖点   input: N(5,1,100);  EMA13:=EMA(C,13);  ma30:=ma(c,30);  ma72:=ma(c,72);  {地心引力:(ma30+ma72)/2,POINTDOT,CulorFF7F93,LINETHICK3;  上引力:(ma30+ma72)/2*0.9,POINTDOT,CulorFF7F93,LINETHICK3;  下引力:(ma30+ma72)/2*1.1,POINTDOT,CulorFF7F93,LINETHICK3;}  {DRAWGBKLAST(CLOSE>0,STRIP(RGB(95,95,95),RGB(0,0,0),0));}  ema17:=ema(c,17);  主筹估算:=EMA(WINNER(c)*70,3);  散筹估算:=EMA((WINNER((c)*1.1)-WINNER((c)*0.9))*70,3);  筹码锁定:=散筹估算-主筹估算 ;  动态底部:=EMA(IF(L<= LLV(l,60),SMA(ABS(L-REF(L,1)),60,1)/SMA(MAX(L-REF(l,1),0),99,1),0)*5,3);  涨:=CROSS(主筹估算,筹码锁定);  强:=CROSS(主筹估算,散筹估算);  STICKLINE(涨,O,C,8,0),COLORYELLOW;  STICKLINE(涨,O,H,0,0),COLORYELLOW;  STICKLINE(涨,L,C,0,0),COLORYELLOW;  STICKLINE(强, O,C,8,0),culormagenta;  STICKLINE(强,O,H,0,0),culormagenta;  STICKLINE(强,L,C,0,0),culormagenta;  {黄金分割线}  lhnh:=BARSLAST(DISPSTATUS=1)+1;  nnl:=DISPSTATUS=2;  Al:=BACKSET(nnl,hhvBARS(h,lhnh)+1);  Bl:=Al>REF(Al,1);  Al2:=BACKSET(nnl,LLVBARS(L,lhnh)+1);  Bl2:=Al2>REF(Al2,1);  前高:REF(H,BARSLAST(bl)),PRECIS2,COLORff00ff,LINETHICK2;  DRAWTEXT(nnl,前高,'前高:'+前高),ALIGN2,COLORGREEN;  前低:REF(L,BARSLAST(Bl2)),PRECIS2,COLORGREEN,LINETHICK2;  DRAWTEXT(nnl,前低*1.009,'前低: '+前低),ALIGN2,COLORGREEN;  Fl1:((前高-前低)*0.191)+前低,POINTDOT,CulorFF7F93,LINETHICK3;  DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl1,'0.236: '+Fl1),Culor938C93;  Fl2:((前高-前低)*0.382)+前低,POINTDOT,Culor5E8C93,LINETHICK3;  DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl2,'0.382: '+Fl2),ALIGN2,COLORGREEN;  Fl3:((前高-前低)*0.5)+前低,POINTDOT,COLOR00ffff,LINETHICK4;  DRAWTEXT(nnl,Fl3,'0.5:'+Fl3),ALIGN2,Culor918C93;  Fl4:((前高-前低)*0.618)+前低,POINTDOT,Culor918C93,LINETHICK3;  DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2)and nnl,Fl4,'0.618: '+Fl4),ALIGN2,COLORGREEN;  Fl5:((前高-前低)*0.809)+前低,POINTDOT,Culor918C67,LINETHICK3;  DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl5,'0.764: '+Fl5),ALIGN2,COLORGREEN;  pp:=MAX( BARSLAST(bl),BARSLAST(Bl2))+1;  k1:=pp-1;  k2:=pp-3;  k3:=pp-5;  k4:=pp-8;  k5:=pp-13;  k6:=pp-21;  k7:=pp-34;  k8:=pp-55;  k9:=pp-89;  k10:=pp-144;  k11:=pp-233;  VERTLINE(FILTER(c=ref(c,k1),0) ,1 );  VERTLINE(FILTER(c=ref(c,k2),0) ,1 );  VERTLINE(FILTER(c=ref(c,k3),0),1 );  VERTLINE(FILTER(c=ref(c,k4),0) ,1 );  VERTLINE(FILTER(c=ref(c,k5),0) ,1 );  VERTLINE(FILTER( c=ref(c,k6),0),1 );  VERTLINE(FILTER( c=ref(c,k7),0),1 );  VERTLINE(FILTER(c=ref(c,k8),0),1 );  VERTLINE(FILTER(c=ref(c,k9),0),1 );  VERTLINE(FILTER(c=ref(c,k10),0),1 );  VERTLINE(FILTER(c=ref(c,k11),0),1 );  DRAWTEXT(FILTER(c=ref(c,k1),0),(HHV( h,80 )+LLV(l ,80 ))/2,'1'),COLORred,LINETHICK2;  DRAWTEXT(FILTER( c=ref(c,k2),0),(HHV( h,80 )+LLV(l ,80 ))/2,'3'),COLORred,LINETHICK2;  DRAWTEXT(FILTER(c=ref(c,k3),0),(HHV( h,80 )+LLV(l ,80 ))/2,'5'),COLORGREEN,LINETHICK2;  DRAWTEXT(FILTER(c=ref(c,k4),0),(HHV( h,80 )+LLV(l ,80 ))/2,'8'),COLORred,LINETHICK2;  DRAWTEXT(FILTER(c=ref(c,k5),0),(HHV( h,80 )+LLV(l ,80 ))/2,'13'),COLORred,LINETHICK2;  DRAWTEXT(FILTER(c=ref(c,k6),0),(HHV( h,80 )+LLV(l ,80 ))/2,'21转'),COLORGREEN,LINETHICK2;  DRAWTEXT(FILTER(c=ref(c,k7),0),(HHV( h,80 )+LLV(l ,80 ))/2,'34'),COLORred,LINETHICK2;  DRAWTEXT(FILTER(c=ref(c,k8),0),(HHV( h,80 )+LLV(l ,80 ))/2,'55'),COLORred,LINETHICK2;  DRAWTEXT(FILTER(c=ref(c,k9),0),(HHV( h,80 )+LLV(l ,80 ))/2,'89'),COLORGREEN,LINETHICK2;  DRAWTEXT(FILTER(c=ref(c,k10),0),(HHV( h,80 )+LLV(l ,80 ))/2,'144'),COLORred,LINETHICK2;  DRAWTEXT(FILTER(c=ref(c,k11),0),(HHV( h,80 )+LLV(l ,80 ))/2,'233'),COLORGREEN,LINETHICK2;  A1:=ref(h,N)=hhv(h,2*N+1);  B1:=filter(A1,N);  C1:=backset(B1,N+1);  D1:=filter(C1,n) or BARSTATUS=2;{高点}  A2:=ref(l,N)=llv(l,2*N+1);  B2:=filter(A2,N);  C2:=backset(B2,N+1);  D2:=filter(C2,N);{低点}  E1:=(ref(llv(l,2*N),1)+ref(hhv(h,2*N),1))/2; E2:=(h+l)/2;{高低点出现在同一K线上时可作取舍}  H1:=(D1 AND not(D2 AND E1>=E2)) OR barstatus=2 OR barscount(c)=1;  L1:=(D2 AND not(D1 AND E1<E2)); H2:=D1 AND not(D2 AND E1>=E2);  X1:=ref(barslast(H1),1)+1; F1:=backset(H1 AND count(L1,X1)>0,llvbars  (if(L1,l,10000),X1));  G1:=F1>ref(F1,1); I1:=backset(G1,2); LD:=I1>ref(I1,1);{过滤后低点}  L2:=LD OR barstatus=2 OR barscount(c)=1;  X2:=ref(barslast(L2),1)+1; F2:=backset(L2 AND count(H2,X2)>0,hhvbars  (if(H2,h,0),X2));  G2:=F2>ref(F2,1); I2:=backset(G2,2); HD:=I2>ref(I2,1);{过滤后高点}  R1:=backset(barstatus=2,barslast(HD)+1); S1:=R1>ref(R1,1); {前一高}  T1:=backset(barstatus=2,barslast(LD)+1); U1:=T1>ref(T1,1); {前一低}  R2:=backset(S1,ref(barslast(HD),1)+2); S2:=R2>ref(R2,1); {前二高}  T2:=backset(U1,ref(barslast(LD),1)+2); U2:=T2>ref(T2,1); {前二低}  T3:=backset(U2,ref(barslast(LD),1)+2); U3:=T3>ref(T3,1); {前三低}  T4:=backset(U3,ref(barslast(LD),1)+2); U4:=T4>ref(T4,1); {前四低}  R3:=backset(S2,ref(barslast(HD),1)+2); S3:=R3>ref(R3,1); {前三高}  R4:=backset(S3,ref(barslast(HD),1)+2); S4:=R4>ref(R4,1); {前四高}  短期压力:drawline(S2,h,S1,h,1),Culorred,LINETHICK2;  短期支撑:drawline(U2,l,U1,l,1),Culorgreen,LINETHICK2;  中期压力:drawline(S3,h,S2,h,1),Culoryellow,LINETHICK2;  中期支撑:drawline(U3,l,U2,l,0),Culorgreen,LINETHICK2;  长期压力:drawline(S4,h,S3,h,1),COLORwhite,LINETHICK2;  长期支撑:drawline(U4,l,U3,l,0),Culorgreen,LINETHICK2;  DRAWICON(S1,H,10);  DRAWICON(S2,H,10);  DRAWICON(S3,H,10);  DRAWICON(S4,H,10);  DRAWICON(U1,L,9);  DRAWICON(U2,L,9);  DRAWICON(U3,L,9);  DRAWICON(U4,L,9);

    浏览9770次浏览
    2022-09-05 09:37
  • 神奇指标

    同花顺K线黄金分割 黄金分割率副源码

    以下是同花顺K线黄金分割 黄金分割率副源码 对于不懂得分割K线黄金分割的朋友非常实用。只需关注白色背离线和K线的背离状况:线上阴线卖、线下阳线买。  注意:由于这个指标是一个主图指标,安装上可能只有黄金分割线没有K线,请在指标上点右键修改指标或者在工具栏选择工具--公式管理找到这个指标,选择“曲线属性”——坐标属性——附图指标——叠加K线,就可以用了!  建议:可以结合QL凤凰线一起用!  买线:=EMA(C,2); 卖线:=EMA(SLOPE(C,21)*20+C,42);  BU:=CROSS(买线,卖线); SEL:=CROSS(卖线,买线); STICKLINE(买线>=卖线,LOW,HIGH,0,1),culorred;  STICKLINE(买线>=卖线,CLOSE,OPEN,3.2,1),culorred;  STICKLINE(买线<卖线,LOW,HIGH,0,1),culorgreen;  STICKLINE(买线<卖线,CLOSE,OPEN,3.2,1),culorgreen;  STICKLINE(BU,OPEN,CLOSE,3.2,0),culoryellow;  STICKLINE(SEL,OPEN,CLOSE,3.2,0),culorblue; 主力:=EMA(CLOSE,10),culorred;散户:=EMA(CLOSE,5),culoryellow;绿降:=(46.18*EMA  (CLOSE,10)-31.82*EMA(CLOSE,4))/14.36,culorgreen,LINETHICK1; 操盘:=MA(CLOSE,9),COLORFF9C65,LINETHICK2;界点:=MA(CLOSE,20);  AH:HHV(H,100);  AL:LLV(L,100);AHL:=AH-AL;A23:AL+AHL*0.236,culorblue;  A38:AL+AHL*0.382,culorgreen;  A61:AL+AHL*0.618,COLORFF9CFF;  A76:AL+AHL*0.764,COLORF0F000;  A77:AL+AHL*0.500,culorred;  DRAWTEXT(ISLASTBAR,AH,'100% '),COLORAAAAAA;  DRAWTEXT(ISLASTBAR,A76,'0.764% '),COLORAAAAAA,LINETHICK2;  DRAWTEXT(ISLASTBAR,A77,'0.500% '),COLORAAAAAA,LINETHICK2;  DRAWTEXT(ISLASTBAR,A61,'0.618% '),COLOR00AAAA,LINETHICK2;  DRAWTEXT(ISLASTBAR,A38,'0.382% '),COLOR00AAAA,LINETHICK2;  DRAWTEXT(ISLASTBAR,A23,'0.236% '),COLORAAAAAA,LINETHICK2;  DRAWTEXT(ISLASTBAR,AL,'最低 '),COLORAAAAAA,LINETHICK2;  DRAWICON(BU,L*0.99,1);  DRAWICON(SEL,H*1.0,2);

    浏览2491次浏览
    2022-09-05 09:36
  • 神奇指标

    大智慧集斐波那契周期 黄金分割 自划线于一体的主图指标 分析K线的利器 源码

    以下是大智慧集斐波那契周期 黄金分割 自划线于一体的主图指标 分析K线的利器 源码 大智慧集斐波那契周期 黄金分割 自划线于一体的主图指标 分析K线的利器 源码 这主图非常不错 不是原创 不知可以发帖不 N年前一位前辈的东西 珍藏好多年 看到大伙这么踊跃发帖 咱也凑个热闹 简短说明: 这是一个非常出色的主图 买卖点有未来 所以 作为分析主图是很棒的 千万别改选股 不然会害死你 没有未来的主图 错误有很多 没啥参考意义 所以 作为分析图 就不该有买卖点 上源码: input: N(5,1,100); EMA13:=EMA(C,13); ma30:=ma(c,30); ma72:=ma(c,72); {地心引力:(ma30+ma72)/2,POINTDOT,CulorFF7F93,LINETHICK3; 上引力:(ma30+ma72)/2*0.9,POINTDOT,CulorFF7F93,LINETHICK3; 下引力:(ma30+ma72)/2*1.1,POINTDOT,CulorFF7F93,LINETHICK3;} {DRAWGBKLAST(CLOSE>0,STRIP(RGB(95,95,95),RGB(0,0,0),0));} ema17:=ema(c,17); 主筹估算:=EMA(WINNER(c)*70,3); 散筹估算:=EMA((WINNER((c)*1.1)-WINNER((c)*0.9))*70,3); 筹码锁定:=散筹估算-主筹估算 ; 动态底部:=EMA(IF(L<= LLV(l,60),SMA(ABS(L-REF(L,1)),60,1)/SMA(MAX(L-REF(l,1),0),99,1),0)*5,3); 涨:=CROSS(主筹估算,筹码锁定); 强:=CROSS(主筹估算,散筹估算); STICKLINE(涨,O,C,8,0),COLORYELLOW; STICKLINE(涨,O,H,0,0),COLORYELLOW; STICKLINE(涨,L,C,0,0),COLORYELLOW; STICKLINE(强, O,C,8,0),culormagenta; STICKLINE(强,O,H,0,0),culormagenta; STICKLINE(强,L,C,0,0),culormagenta; {黄金分割线} lhnh:=BARSLAST(DISPSTATUS=1)+1; nnl:=DISPSTATUS=2; Al:=BACKSET(nnl,hhvBARS(h,lhnh)+1); Bl:=Al>REF(Al,1); Al2:=BACKSET(nnl,LLVBARS(L,lhnh)+1); Bl2:=Al2>REF(Al2,1); 前高:REF(H,BARSLAST(bl)),PRECIS2,COLORff00ff,LINETHICK2; DRAWTEXT(nnl,前高,'前高:'+前高),ALIGN2,COLORGREEN; 前低:REF(L,BARSLAST(Bl2)),PRECIS2,COLORGREEN,LINETHICK2; DRAWTEXT(nnl,前低*1.009,'前低: '+前低),ALIGN2,COLORGREEN; Fl1:((前高-前低)*0.191)+前低,POINTDOT,CulorFF7F93,LINETHICK3; DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl1,'0.236: '+Fl1),Culor938C93; Fl2:((前高-前低)*0.382)+前低,POINTDOT,Culor5E8C93,LINETHICK3; DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl2,'0.382: '+Fl2),ALIGN2,COLORGREEN; Fl3:((前高-前低)*0.5)+前低,POINTDOT,COLOR00ffff,LINETHICK4; DRAWTEXT(nnl,Fl3,'0.5:'+Fl3),ALIGN2,Culor918C93; Fl4:((前高-前低)*0.618)+前低,POINTDOT,Culor918C93,LINETHICK3; DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2)and nnl,Fl4,'0.618: '+Fl4),ALIGN2,COLORGREEN; Fl5:((前高-前低)*0.809)+前低,POINTDOT,Culor918C67,LINETHICK3; DRAWTEXT(BARSLAST(Bl)>BARSLAST(Bl2) and nnl,Fl5,'0.764: '+Fl5),ALIGN2,COLORGREEN; pp:=MAX( BARSLAST(bl),BARSLAST(Bl2))+1; k1:=pp-1; k2:=pp-3; k3:=pp-5; k4:=pp-8; k5:=pp-13; k6:=pp-21; k7:=pp-34; k8:=pp-55; k9:=pp-89; k10:=pp-144; k11:=pp-233; VERTLINE(FILTER(c=ref(c,k1),0) ,1 ); VERTLINE(FILTER(c=ref(c,k2),0) ,1 ); VERTLINE(FILTER(c=ref(c,k3),0),1 ); VERTLINE(FILTER(c=ref(c,k4),0) ,1 ); VERTLINE(FILTER(c=ref(c,k5),0) ,1 ); VERTLINE(FILTER( c=ref(c,k6),0),1 ); VERTLINE(FILTER( c=ref(c,k7),0),1 ); VERTLINE(FILTER(c=ref(c,k8),0),1 ); VERTLINE(FILTER(c=ref(c,k9),0),1 ); VERTLINE(FILTER(c=ref(c,k10),0),1 ); VERTLINE(FILTER(c=ref(c,k11),0),1 ); DRAWTEXT(FILTER(c=ref(c,k1),0),(HHV( h,80 )+LLV(l ,80 ))/2,'1'),COLORred,LINETHICK2; DRAWTEXT(FILTER( c=ref(c,k2),0),(HHV( h,80 )+LLV(l ,80 ))/2,'3'),COLORred,LINETHICK2; DRAWTEXT(FILTER(c=ref(c,k3),0),(HHV( h,80 )+LLV(l ,80 ))/2,'5'),COLORGREEN,LINETHICK2; DRAWTEXT(FILTER(c=ref(c,k4),0),(HHV( h,80 )+LLV(l ,80 ))/2,'8'),COLORred,LINETHICK2; DRAWTEXT(FILTER(c=ref(c,k5),0),(HHV( h,80 )+LLV(l ,80 ))/2,'13'),COLORred,LINETHICK2; DRAWTEXT(FILTER(c=ref(c,k6),0),(HHV( h,80 )+LLV(l ,80 ))/2,'21转'),COLORGREEN,LINETHICK2; DRAWTEXT(FILTER(c=ref(c,k7),0),(HHV( h,80 )+LLV(l ,80 ))/2,'34'),COLORred,LINETHICK2; DRAWTEXT(FILTER(c=ref(c,k8),0),(HHV( h,80 )+LLV(l ,80 ))/2,'55'),COLORred,LINETHICK2; DRAWTEXT(FILTER(c=ref(c,k9),0),(HHV( h,80 )+LLV(l ,80 ))/2,'89'),COLORGREEN,LINETHICK2; DRAWTEXT(FILTER(c=ref(c,k10),0),(HHV( h,80 )+LLV(l ,80 ))/2,'144'),COLORred,LINETHICK2; DRAWTEXT(FILTER(c=ref(c,k11),0),(HHV( h,80 )+LLV(l ,80 ))/2,'233'),COLORGREEN,LINETHICK2; A1:=ref(h,N)=hhv(h,2*N+1); B1:=filter(A1,N); C1:=backset(B1,N+1); D1:=filter(C1,n) or BARSTATUS=2;{高点} A2:=ref(l,N)=llv(l,2*N+1); B2:=filter(A2,N); C2:=backset(B2,N+1); D2:=filter(C2,N);{低点} E1:=(ref(llv(l,2*N),1)+ref(hhv(h,2*N),1))/2; E2:=(h+l)/2;{高低点出现在同一K线上时可作取舍} H1:=(D1 AND not(D2 AND E1>=E2)) OR barstatus=2 OR barscount(c)=1; L1:=(D2 AND not(D1 AND E1<E2)); H2:=D1 AND not(D2 AND E1>=E2); X1:=ref(barslast(H1),1)+1; F1:=backset(H1 AND count(L1,X1)>0,llvbars (if(L1,l,10000),X1)); G1:=F1>ref(F1,1); I1:=backset(G1,2); LD:=I1>ref(I1,1);{过滤后低点} L2:=LD OR barstatus=2 OR barscount(c)=1; X2:=ref(barslast(L2),1)+1; F2:=backset(L2 AND count(H2,X2)>0,hhvbars (if(H2,h,0),X2)); G2:=F2>ref(F2,1); I2:=backset(G2,2); HD:=I2>ref(I2,1);{过滤后高点} R1:=backset(barstatus=2,barslast(HD)+1); S1:=R1>ref(R1,1); {前一高} T1:=backset(barstatus=2,barslast(LD)+1); U1:=T1>ref(T1,1); {前一低} R2:=backset(S1,ref(barslast(HD),1)+2); S2:=R2>ref(R2,1); {前二高} T2:=backset(U1,ref(barslast(LD),1)+2); U2:=T2>ref(T2,1); {前二低} T3:=backset(U2,ref(barslast(LD),1)+2); U3:=T3>ref(T3,1); {前三低} T4:=backset(U3,ref(barslast(LD),1)+2); U4:=T4>ref(T4,1); {前四低} R3:=backset(S2,ref(barslast(HD),1)+2); S3:=R3>ref(R3,1); {前三高} R4:=backset(S3,ref(barslast(HD),1)+2); S4:=R4>ref(R4,1); {前四高} 短期压力:drawline(S2,h,S1,h,1),Culorred,LINETHICK2; 短期支撑:drawline(U2,l,U1,l,1),Culorgreen,LINETHICK2; 中期压力:drawline(S3,h,S2,h,1),Culoryellow,LINETHICK2; 中期支撑:drawline(U3,l,U2,l,0),Culorgreen,LINETHICK2; 长期压力:drawline(S4,h,S3,h,1),COLORwhite,LINETHICK2; 长期支撑:drawline(U4,l,U3,l,0),Culorgreen,LINETHICK2; DRAWICON(S1,H,10); DRAWICON(S2,H,10); DRAWICON(S3,H,10); DRAWICON(S4,H,10); DRAWICON(U1,L,9); DRAWICON(U2,L,9); DRAWICON(U3,L,9); DRAWICON(U4,L,9);

    浏览7340次浏览
    2022-09-05 09:36
  • 神奇指标

    通达信黄金趋势均线画趋势线黄金分割 一体的指标

    以下是通达信黄金趋势均线画趋势线黄金分割 一体的指标 本指标画线用到了未来函数,愿您使用愉快。未来函数其实看你怎么用和看待

    浏览4129次浏览
    2022-09-05 09:35