神奇指标网
  • 神奇指标

    通达信黑牛 (上市天数 重要均线 年季竖线 高手买点 底背黑马 周K线托 三角整理突破)

    以下通达信是黑牛 (上市天数 重要均线 年季竖线 高手买点 底背黑马 周K线托 三角整理突破)SSTS1:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0)); DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0,0,SSTS1),COLORYELLOW;BBI:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORLIGRAY; MA5:MA(CLOSE,5),COLORWHITE; MA10:MA(CLOSE,10),COLORYELLOW; MA33:MA(CLOSE,33),COLORLIMAGENTA; MA99:MA(CLOSE,99),COLORMAGENTA; MA180:MA(CLOSE,180),COLORYELLOW; MA272:MA(CLOSE,272),COLORGREEN;趋势反转线:MA(C,584.92),LINETHICK4,COLORFFCC66; DRAWLINE(CROSS(MA99,MA180),MA99,REF(CROSS(MA99,MA180),1),REF(MA99,1),1),COLORYELLOW,LINETHICK2; DRAWLINE(CROSS(MA180,MA99),MA180,REF(CROSS(MA180,MA99),1),REF(MA180,1),1),COLORWHITE;支撑线:(MA(CLOSE,20)+MA(CLOSE,40)+MA(CLOSE,60))/3,LINETHICK2,COLORYELLOW;十:MA(C,10),COLOR00FFFF,LINETHICK2;涨:IF(MA(CLOSE,10)>REF(MA(CLOSE,10),1),MA(CLOSE,10),DRAWNULL),COLORRED,LINETHICK2;平:IF(MA(CLOSE,10)=REF(MA(CLOSE,10),1),MA(CLOSE,10),DRAWNULL),COLOR00FFFF,LINETHICK3;跌:IF(MA(CLOSE,10)<REF(MA(CLOSE,10),1),MA(CLOSE,10),DRAWNULL),COLORBLUE,LINETHICK2; {每个季度的最后一个交易日画竖线} STICKLINE(REFX(CROSS(MOD(MONTH,3),0.5),1),CONST(HHV(H,120)),CONST(LLV(L,120)),0,-1),COLOR999999; {每年的最后一个交易日画一根垂直线}IF(CROSS(BACKSET(BARSLAST(MONTH<REF(MONTH,1))=0,2),0.5),HHV(H,0),DRAWNULL),STICK,COLORRED; {高手买点}NJ:=9;M1:=3;M2:=3;SHORT:=12;LONG:=26;M:=9; RSV:=(CLOSE-LLV(LOW,NJ))/(HHV(HIGH,NJ)-LLV(LOW,NJ))*100; K:=SMA(RSV,M1,1); D:=SMA(K,M2,1); T1J:=CROSS(K,D) AND D<20; DIFF:=EMA(CLOSE,SHORT) - EMA(CLOSE,LONG); DEA:=EMA(DIFF,M); MACD:=2*(DIFF-DEA); T2:=MACD>=-0.02 AND MACD<=0.03; T3J:=COUNT(T1J AND T2,10) AND COUNT(D<40 AND CLOSE>=MA(CLOSE,7),10) AND CLOSE>=MA(CLOSE,14) AND VOL/REF(VOL,1)>1.5; DRAWTEXT(T3J,LOW*0.97,'B'),COLORYELLOW;{底背黑码}DIFFK:=EMA(DCLOSE,12)-EMA(DCLOSE,26); DEAK:=EMA(DIFFK,9),COLORFFFF00; A1K:=BARSLAST(REF(CROSS(DIFFK,DEAK),1));底背离:=REF(CLOSE,A1K+1)>CLOSE AND DIFFK>REF(DIFFK,A1K+1) AND CROSS(DIFFK,DEAK); DEA0:=EMA(DIFFK*100,9); MACD0:=2*(DIFFK*100-DEA0);黑码:=(MACD>REF(MACD0,1)*2.5 AND MACD0>15); DRAWTEXT(底背离 AND 黑码,L*0.98,'红底'),LINETHICK2,COLORCYAN;{周K线托}MA6:=MA(CLOSE,6),COLORWHITE; MA36:=MA(CLOSE,36),COLORLIMAGENTA,LINETHICK2; MA72:=MA(CLOSE,72),COLORGREEN,LINETHICK2;上穿72:=CROSS(MA6,MA72); MA72托:DRAWLINE(上穿72,C, REF(上穿72,1), REF(C,1), 1),COLORGREEN,LINETHICK2;上穿36:=CROSS(MA6,MA36); MA36托:DRAWLINE(上穿36,C, REF(上穿36,1), REF(C,1), 1),COLORLIGREEN;阻力4Y:REFDATE(REF(HHV(H,110),20),DATE),COLORGREEN;阻力4S:REFDATE(REF(HHV(H,440),5),DATE),COLORYELLOW; {划线带三角整理突破主图}HIGHN:=10;LOWN:=10;HIGHDISPLAY:=0;LOWDISPLAY:=0;ZGDISPLAY:=0;MADISPLAY:=0; AA5:=REF(H,HIGHN)=HHV(H,2*HIGHN+1); QY:=BACKSET(AA5,HIGHN+1); CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1); DDD:=BARSLAST(CC); GDTS:=IF(CC,CURRBARSCOUNT,0); DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS); DINGBU1:=REF(DINGBU,DDD+1); GDCS1:=CONST(DINGBUTS); DINGBUTS1:=REF(DINGBUTS,DDD+1); GDCS2:=CONST(DINGBUTS1);高点压力:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORGREEN,LINETHICK2;

    浏览4167次浏览
    2022-10-17 16:21
  • 神奇指标

    通达信短期平滑均线+长期加权均线 主图指标无未来 无加密

    以下是通达信短期平滑均线+长期加权均线 主图指标无未来 无加密 这是一个短期平滑均线+长期加权均线的组合,对于形态判断有很好的辅助作用,就我个人使用习惯上来说,均线使用其实比很多“神奇”指标的效果要好得多。贴图中很好的描述了股价一个完整的运行过程。 J:=(HIGH + LOW + OPEN + CLOSE+ CLOSE) / 5; J21:EXPMEMA(J,21),COLORFF0033,LINETHICK2; J23:EXPMEMA(J,23),COLORFF0033,LINETHICK2; J34:EXPMEMA(J,34),COLORFF33CC,LINETHICK2; J36:EXPMEMA(J,36),COLORFF33CC,LINETHICK2; J55:EXPMEMA(J,55),COLORLIRED,LINETHICK2; J57:EXPMEMA(J,57),COLORLIRED,LINETHICK2; J59:EXPMEMA(J,59),COLORLIRED,LINETHICK2; J144:EMA(J,144),COLORMAGENTA,LINETHICK2; J146:EMA(J,146),COLORMAGENTA,LINETHICK2; J148:EMA(J,148),COLORMAGENTA,LINETHICK2; A1:=MA(J,3); A2:=MA(J,5); A3:=(A1+A2)/2; IF (A1>A2,A1,A3),COLORRED,LINETHICK2; IF (A1>A2,A2,A3),COLORRED,LINETHICK2; IF (A1<=A2,A1,A3),COLORGREEN,LINETHICK2; IF (A1<=A2,A2,A3),COLORGREEN,LINETHICK2; A3,COLORWHITE,LINETHICK2; _10日涨跌%: (C-REF(CLOSE,10))/REF(CLOSE,10)*100,COLORGREEN,NODRAW;

    浏览8723次浏览
    2022-09-05 10:14
  • 神奇指标

    通达信总算完美解决周K线在副图上显示(含周均线 源码贴图 副图)

    以下是通达信总算完美解决周K线在副图上显示(含周均线 源码贴图 副图) 由于原贴周K线显示在主图并靠左侧,且不易区分,为方便看盘,故将周K线做成副图并加上了周均线,实测一模一样。源码中含有月K线,需要的同学自行修改。   1、新建引用公式“AA” C1:C; O1:O; H1:H; L1:L; V1:V; ZF:(C-REF(C,1))/REF(C,1); DT1:BARSCOUNT(C); ZH:CURRBARSCOUNT; SJ:IF(ISLASTBAR,DATE,0);{最后一天时间}; 2、再建公式“三周期K线” {周K线} PPP:=0;{设定从倒数第PP根K线结束显示周线} Q11:=90;{设定周K线显示根数为Q11} Q12:=00;{设定月K线显示根数为Q12} CCC:=AA.C1#WEEK;HHH:=AA.H1#WEEK;LLL:=AA.L1#WEEK;OO:=AA.O1#WEEK; ZQZ:=TOTALBARSCOUNT; ZQC:=BARSCOUNT(C); KX1:=ZQZ-ZQC;{周K线显示开始位置} K6:=AA.DT1#WEEK;{周K线周期} Q:=IF(CONST(K6)<Q11,CONST(K6)+1,Q11);{如总周K小于Q11,显示根数改为总周K线+1根} PP:=IF(ZQZ<PPP,ZQZ-Q,PPP);{如总K线小于开始位置,改周K线开始位置为总K线周期-Q} K7:=K6>REF(K6,1);{周K线更后} K8:=SUM(K7,0);{当前周K线位置} K9:=CONST(K8)-K8; W2:=KX1<PP+Q AND PERIOD=5;{周K线显示区域} ZH:=ISLASTBAR; SU:=IF(ZH,0,SUMBARS(K7,KX1-K9)-1); C1:=REF(CCC,SU);O1:=REF(OO,SU);H1:=REF(HHH,SU);L11:=REF(LLL,SU); RC:=REFX(C1,PP);RO:=REFX(O1,PP);RH:=REFX(H1,PP);RL:=REFX(L11,PP); TJ4:=RC>=REF(RC,1); TJ5:=RC<REF(RC,1); STICKLINE(W2 AND  TJ4,RH,RL,0,0),COLORRED; STICKLINE(W2 AND   TJ5,RH,RL,0,0),COLORLIBLUE; STICKLINE(W2 AND  TJ4,RC,RO,2,1),COLORRED; STICKLINE(W2 AND  TJ5,RC,RO,2,0),COLORLIBLUE; HH1:=AA.H1#MONTH;LL1:=AA.L1#MONTH; OO1:=AA.O1#MONTH;CCC1:=AA.C1#MONTH; KK6:=AA.DT1#MONTH;{月K线周期} P12:=PP-Q12-3;{设定从周K线结束位置隔3天开始显示月K线} Q1:=IF(PP<PPP,CONST(KK6)+1,Q12);{如总月K小于Q12,显示根数改为总月K线+1根} P1:=IF(PP<PPP,PP-Q1-2,P12);{如总K线小于开始位置,改月K线开始位置为总K线周期-Q1} W22:=KX1<P1+Q1 AND PERIOD=5;{月K线显示区域} KK7:=KK6>REF(KK6,1);{月K线更后} KK8:=SUM(KK7,0);{当前月K线位置} KK9:=CONST(KK8)-KK8; SU1:=IF(ZH,0,SUMBARS(KK7,KX1-KK9)-1); MC1:=REF(CCC1,SU1);MO1:=REF(OO1,SU1);MH1:=REF(HH1,SU1);ML1:=REF(LL1,SU1); MRC:=REFX(MC1,P1);MRO:=REFX(MO1,P1);MRH:=REFX(MH1,P1);MRL:=REFX(ML1,P1); MTJ4:=MRC>=REF(MRC,1); MTJ5:=MRC<REF(MRC,1); STICKLINE(W22 AND MTJ4,MRH,MRL,0,0),COLORFF8080; STICKLINE( W22 AND MTJ5,MRH,MRL,0,0),COLORFF8080; STICKLINE(W22 AND MTJ4,MRC,MRO,3,1),COLORFF8080; STICKLINE( W22 AND MTJ5,MRC,MRO,3,0),COLORFF8080; A:=ALIGNRIGHT(IF(WEEKOFYEAR!=REF(WEEKOFYEAR,1),C#WEEK,DRAWNULL)); MA1:MA(A,5),COLORWHITE; MA2:MA(A,10),COLORRED; MA3:MA(A,20),COLOR6699FF;  

    浏览7989次浏览
    2022-09-05 10:11
  • 神奇指标

    通达信指数平均线 麟龙特色源码附图

    以下是通达信指数平均线 麟龙特色源码附图  麟龙特色指标 EXP1:EMA(C,12),COLORWHITE; EXP2:EMA(C,50),COLORYELLOW; STICKLINE(CLOSE>=O ,H,L-0.008,0,0),COLOR0030FF;  STICKLINE(CLOSE>=O ,C,O,2.5,0),COLOR0030FF; STICKLINE(CLOSE>=O ,C,O,2,0),COLOR0030FF; STICKLINE(CLOSE>=O ,C,O,1,0),COLOR0030FF; STICKLINE(CLOSE>=O ,C,O,0,0),COLOR0030FF;  STICKLINE(CLOSE<O ,L-0.008,H,0,0),COLORGREEN;  STICKLINE(O>C ,C,O,2.5,0 ),COLORGREEN;  STICKLINE(O>C ,C,O,2,0 ),COLORGREEN;  STICKLINE(O>C ,C,O,1,0 ),COLORGREEN;  STICKLINE(O>C,C,O,0,0) ,COLORGREEN;   VOLUME:=MA(VOL,1)/VOL; MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW); EMV:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,9),9); EMVA:=MA(EMV,14); BB:=EMV-EMVA; BIAS :=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100; BIASMA :=MA(BIAS,6); CC:=BIAS-BIASMA; RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; K:=SMA(RSV,3,1); D:=SMA(K,3,1); J:=3*K-2*D; DD:=(K+D+J)/3; KK:=J-DD; DIFF2:=EMA(CLOSE,12)-EMA(CLOSE,26);  DEA2:=EMA(DIFF2,9);  SS:=DIFF2-DEA2; AA:=MA(BB+CC+KK+SS,1)*0.01;   DRAWTEXT(CROSS(AA,0),L*0.95,'B'),LINETHICK4,COLORWHITE; DRAWTEXT(CROSS(0,AA),H*1.06,'S'),LINETHICK4,COLORGREEN;    

    浏览3094次浏览
    2022-09-05 10:09
  • 神奇指标

    通达信缩量回踩55均线 放量拉升公式

    以下是通达信缩量回踩55均线 放量拉升公式 通达信缩量回踩55均线 放量拉升公式 源码 N(5,100,43) 中:=MA(CLOSE,N); 上:=中 + 2*STD(CLOSE,N); 下:=中 - 2*STD(CLOSE,N); 金刚回踩:(REF(中,2)<REF(中,1) AND REF(L,1)<REF(中,1) AND REF(C,1)>REF(中,1) AND (REF(C,1)>O OR REF(C,1)=O)) AND (REF(中,1)<中 AND L<=中 AND C>中 AND (C>O OR C=O)) ;    

    浏览2304次浏览
    2022-09-05 10:08
  • 神奇指标

    通达信季移动平均线 比常规移动平均线更为优秀源码副图无未来

    以下是通达信季移动平均线 比常规移动平均线更为优秀源码副图无未来 季移动平均线是本人对股价的形态分析总结所得精髓,指标简洁清爽比常规移动平均线更为优秀。是否符合你所需只有你去慢慢研究。 指标原理解析,让大家真正明白指标: 1、常规移动平均线只是对每日股价做一段时间内的一个移动平均(软件自带指标MA),比如:5日MA(CLOSE,5),10日MA(CLOSE,10),20日MA(CLOSE,20),60日MA(CLOSE,60)等等,通常而我们在分析股票时是以周,月,季等周期来观察它的趋势。在周期日线下看月,季自然就不方便合理,这是指标的局限性造成的。 2、季移动平均线是由当季的天数来做移动平均,股价在当季的开始时移动平均变化不大,股价变化更能明显反应,可以直观看出大涨的活跃票票;股价在当季的中部或者尾部时移动平均变化跟随当季的天数变化做移动平均,反应出股价的长期趋势变化;如股票长时间调整会在季移动平均线上下浮动也很容易看出来,此时自然弃它换票。一条季移动平均线即可看出当月当季是否上涨,不用老换其他周期观看趋势,此指标同理可用于月天数,个人觉得季比月更好些。   JD:=MONTH=1 OR MONTH=4 OR MONTH=7 OR MONTH=10; JA:=JD AND DAY<REF(DAY,1); JT:=BARSLAST(JA)+1; 季MA:MA(C,JT),COLORFF0000; 季MA1:季MA*1.1,COLORFF0000; {季L:TMA(季MA,0.9,0.1); 季H:TMA(季MA,0.9,0.11);} NOTEXT1:IF(季MA>REF(季MA,1),季MA,DRAWNULL),COLORRED; NOTEXT2:IF(季MA1>REF(季MA1,1),季MA1,DRAWNULL),COLORRED; EMA(C,5); DRAWKLINE(H,O,L,C); 上涨:=(C/REF(C,1)-1)*100; 红柱:=IF(PERIOD>=6,9.9,IF(PERIOD=5,4.9,IF(PERIOD=4,3.9,IF(PERIOD>=3,2.9,IF(PERIOD=2,1.9,IF(PERIOD<=1,0.8,0)))))); STICKLINE(上涨>=红柱,OPEN,CLOSE,3,0),COLORRED; 绿柱:=IF(PERIOD>=6,-9.9,IF(PERIOD=5,-4.9,IF(PERIOD<=4,-2,0))); STICKLINE(上涨<绿柱,OPEN,CLOSE,3,1),COLORLIBLUE;

    浏览2538次浏览
    2022-09-05 10:07
  • 神奇指标

    通达信股海均线 主图源码带有月线时间窗

    以下是通达信股海均线 主图源码带有月线时间窗 有的朋友喜欢在日K线图上参照月线进行选股,现分享带有月线时间窗的日K均线主图指标(也可以你自己将源码中的“时间窗”部分源码提取出来加在你喜欢的主图或副图中),供需要的朋友下载。有的朋友提出不会看图,现解释一下,此时间窗是专供投资中长线而设计的寻找当月最佳买卖点的日均线图,可结合MACD等指标确定买卖点。中长线往往是用月K线级别进行选股的,当月末选出适宜投资的个股许在下个月的20天内逢高卖出或逢低买进。此公式并不是选股公式而是便于观察一个月位置的看盘工具。其他解释见图示。

    浏览5913次浏览
    2022-09-05 10:04
  • 神奇指标

    通达信优化的神秘均线 加了bs点 一目了然

    以下是通达信优化的神秘均线 加了bs点 一目了然 ZJ:EMA(C,13),COLOR0000FF;  HY:EMA(C,20),COLORFF00FF;  ZJ升:IF(ZJ>REF(ZJ,1),ZJ,DRAWNULL),COLORRED,LINETHICK2;  ZJ降:IF(ZJ<=REF(ZJ,1),ZJ,DRAWNULL),COLORBLUE,LINETHICK2;  HY升:IF(HY>REF(HY,1),HY,DRAWNULL),COLORFF00FF,LINETHICK2;  HY降:IF(HY<REF(HY,1),HY,DRAWNULL),COLORFFAA00,LINETHICK2;  STICKLINE(C>ZJ,H,L,0,0),COLORRED;  STICKLINE(C>ZJ,C,O,-1,1),COLORRED;  STICKLINE(C=ZJ,H,L,0,0),COLORFFFFFF;  STICKLINE(C<ZJ,H,L,0,0),COLOR00FFFF;  STICKLINE(C<ZJ,O,C,-1,1),COLOR00FFFF;  STICKLINE(C<HY,O,C,-1,1),COLORFFFF00;  STICKLINE(C<HY,H,L,0,0),COLORCYAN;  DRAWTEXT(CROSS(C,ZJ),L,'B'),COLOR00FFFF;  DRAWTEXT(CROSS(C,HY),L*0.99,'B'),COLORFFFF00;  DRAWTEXT(CROSS(ZJ,C),H,'S'),COLOR00FFFF;  DRAWTEXT(CROSS(HY,C),H*1.01,'S'),COLORFFFF00;  

    浏览5313次浏览
    2022-09-05 10:03
  • 神奇指标

    成本均线 真实反映个股趋势的好指标、源码、主图、说明

    以下是成本均线 真实反映个股趋势的好指标、源码、主图、说明 成本均线 真实反映个股趋势的好指标、源码、主图、说明 说明:只有经过长期实践和在牛、熊市中经得起时间考验的指标才是好指标,现在的5日、10日、20日、60日、120日等常用均线很容易被庄家所利用,只有成本均线才能够真实反映个股的走势,公式简单实用,配合K线的形态和成交量一起使用,送给有缘人,慢慢揣摩,必有收获 源码           {P1  2  30   5} {P2  2  60  13} {P3  2  120 34} {玩股K线} DRAWKLINE(H,O,L,C); ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL); ZSP:=IF(C>REF(C,1),C,DRAWNULL); DKP:=IF(C<=REF(C,1),REF(C,1),DRAWNULL); DSP:=IF(C<=REF(C,1),C,DRAWNULL); DRAWKLINE(H,DKP,L,DSP); STICKLINE(C<=REF(C,1),DKP,DSP,3.05,0),COLORBLUE; STICKLINE(C<=REF(C,1),DKP,DSP,2.2,0),COLORFF7700; STICKLINE(C<=REF(C,1),DKP,DSP,1.5,0),COLORFF9900; STICKLINE(C<=REF(C,1),DKP,DSP,0.5,0),COLORFFBB00; DRAWKLINE(H,ZKP,L,ZSP); STICKLINE(C>REF(C,1),ZKP,ZSP,3.05,0),COLOR000099; STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC; STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF; STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF; STICKLINE(V/REF(V,1)>2 AND CLOSE>=OPEN,ZKP,ZSP,1,0),COLORYELLOW; JJJ:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3)); DDD:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01); JJJT:=IF(DDD,1,(JJJ<(DYNAINFO(5)+0.01) && JJJ>(DYNAINFO(6)-0.01))); CYC5:IF(JJJT,0.01*EXPMA(AMOUNT,P1)/EXPMA(VOL,P1),EMA((HIGH+LOW+CLOSE)/3,P1)),COLORWHITE,LINETHICK2; CYC13:IF(JJJT,0.01*EXPMA(AMOUNT,P2)/EXPMA(VOL,P2),EMA((HIGH+LOW+CLOSE)/3,P2)),COLORMAGENTA,LINETHICK2; CYC34:IF(JJJT,0.01*EXPMA(AMOUNT,P3)/EXPMA(VOL,P3),EMA((HIGH+LOW+CLOSE)/3,P3)),COLOR00FFFF,LINETHICK1; CYC120:IF(JJJT,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120)),COLORCYAN,LINETHICK1; 额:AMOUNT/100000000,NODRAW,COLOR4080FF; VAR1:=AMOUNT/((HIGH-LOW)*2-ABS(CLOSE-OPEN)); 流入亿:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/100000000,COLORRED,NODRAW; 流出亿:IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-AMOUNT/2))/100000000,COLORMAGENTA,NODRAW; 差亿:流入亿+流出亿,COLORFFFF00,NODRAW;

    浏览7166次浏览
    2022-09-05 10:02
  • 神奇指标

    通达信变色双均线 主图源码

    以下是通达信变色双均线 主图源码 P1:=10;  P2:=20;  DRAWGBK(C>0, RGB(0,10,10),RGB(88,0,0),0,'11',0);  DRAWNUMBER(ISLASTBAR,C,C),COLORMAGENTA;  N8:=STRCAT(CON2STR(YEAR,0),' 年 '); Y8:=STRCAT(CON2STR(MONTH,0),' 月 '); R8:=STRCAT(CON2STR(DAY,0),' 日 '); MAR1:=MA(CLOSE,P1);  C1:=C>=MAR1;  C2:=C<MAR1;  AA:=C1>=C2;  BB:=C2>C1;  STICKLINE(AA,C,O,3,0),COLORRED;  STICKLINE(AA,H,L,0,0),COLORRED;  STICKLINE(BB,C,O,3,0),COLOR00FF00;  STICKLINE(BB,H,L,0,0),COLOR00FF00;  STICKLINE(AA,CLOSE,OPEN,3,0),COLOR000099;  STICKLINE(AA,CLOSE,OPEN,2.2,0),COLOR0000CC;  STICKLINE(AA,CLOSE,OPEN,1.5,0),COLOR0000FF;  STICKLINE(AA,CLOSE,OPEN,0.5,0),COLORCC66FF;  STICKLINE(BB,CLOSE,OPEN,3,0),COLORFF7700;  STICKLINE(BB,CLOSE,OPEN,2.2,0),COLORFF9900;  STICKLINE(BB,CLOSE,OPEN,1.5,0),COLORFFBB00;  STICKLINE(BB,CLOSE,OPEN,0.5,0),COLORCYAN;  MAA:MAR1,COLOR00FF00,LINETHICK2;  IF(MAA>=REF(MAA,1),MAA,DRAWNULL),COLORRED,LINETHICK2;  IF(MAA<REF(MAA,1),MAA,DRAWNULL),COLORFFFFFF,LINETHICK2;  MAB:MA(CLOSE,P2),COLOR00FF00,LINETHICK2;  IF(MAB>=REF(MAB,1),MAB,DRAWNULL),COLORMAGENTA,LINETHICK2;  IF(MAB<REF(MAB,1),MAB,DRAWNULL),COLORGREEN,LINETHICK2;  SJ8:=STRCAT(STRCAT(N8,Y8), R8);  VAR2:=(2*CLOSE+HIGH+LOW)/4;  VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1);  VAR4:=LLV(LOW,5);  VAR5:=HHV(HIGH,4);  VAR6:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;  VAR7:=EMA(0.667*REF(VAR6,1)+0.333* VAR6,2)*VAR3;  DRAWTEXT(CROSS(VAR6, VAR7) AND VAR6<30,L-0.05,'←低吸'),COLOR00FFFF;  DRAWTEXT(CROSS(VAR7, VAR6) AND VAR6>70,H+0.05,'←高抛'),COLOR00FFFF;  DRAWICON(CROSS(VAR6, VAR7) AND VAR6<30,L-0.05,13);  DRAWICON(CROSS(VAR7, VAR6) AND VAR6>70,H+0.05,14);  AAA:= MAA>=REF(MAA,1);{C>=MAA;}  BBB:= MAA<REF(MAA,1);{ C<MAA;}  DDD:=MAB>=REF(MAB,1);  EEE:=MAB<REF(MAB,1);  TT:=IF(ISLASTBAR,240/FROMOPEN,1);  NN:=120;  HH:=HHV(V*TT,NN);  LL:=LLV(V,NN); 最高:=CONST(HH); 最低:=CONST(LL); 最高2:=CONST(HHV(H,NN)); 最低2:=CONST(LLV(L,NN));  PP:=IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,20)),0.9,IF((最高2*0.9-(最高2-最低2)*0.5)>CONST(LLV(L,50)),0.7,0.6)),NODRAW;  RCC1:=最高2*0.9-(最高2-最低2)*PP; 最低3:=MIN(RCC1,最低2);  AA1:=最低3;  STICKLINE(AAA,AA1-0.000*AA1,AA1-0.040*AA1,4,0),COLOR0000FF;  STICKLINE(BBB,AA1-0.000*AA1,AA1-0.040*AA1,4,1),COLOR686868;  STICKLINE(EEE,AA1-0.050*AA1,AA1-0.090*AA1,4,1),COLOR686868;  STICKLINE(DDD,AA1-0.050*AA1,AA1-0.090*AA1,4,0),COLORFF00FF;  DRAWTEXT_FIX(C>0,0.5,0,0,SJ8),COLOR00FFFF;  DRAWTEXT_FIX(1,0.5,0.84,0,'★★ A-红色均线持股 ★ ★ B-粉色均线持股★★'),COLOR00FFFF; 今日保护价:(REF(C,2)+REF(C,1)+O)/3,COLOR00FFFF,NODRAW; 顶点:IF(CURRBARSCOUNT<=60,CONST(IF(ISLASTBAR=1,HHV(H,BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,DOTLINE; 低点:IF(CURRBARSCOUNT<=60,CONST(IF(ISLASTBAR=1,LLV(L,BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,DOTLINE;  STICKLINE(CCI>=200 AND H>=顶点,O,C,3,0),COLORBLUE;  STICKLINE(CCI<=100 AND L<=低点,O,C,3,0),COLORYELLOW;  DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORRED;  DRAWTEXT(ISLASTBAR,低点,'低点'),COLORMAGENTA;

    浏览4980次浏览
    2022-09-05 10:00
  • 神奇指标

    通达信突破20均线 主图/选股 源码 贴图

    以下是通达信突破20均线 主图/选股 源码 贴图 M20:MA(C,20),COLORLIRED,DOTLINE;  T1:=BARSLAST(CROSS(C>=M20,0.5));  T2:=BARSLAST(CROSS(C<M20,0.5));  T3:=SUMBARS(T1=0,2);  ZF:=(C-REF(C,T1+1))/REF(C,T1+1)*100;  HZF:=REF(HHV(ZF,T1+1),T2);  DF:=(C-REF(C,T2+1))/REF(C,T2+1)*100;  LDF:=LLV(DF,T2+1);  L1:=LLV(L,T2+1);  L2:=REF(L1,T3-1);  AC:=COUNT(T2=0,T3)=1;  AC1:=O<M20 AND C>=M20 AND HZF<15 AND LDF>-25 AND LDF<-10;  AC2:=REF(T1,T2)>1 AND T2>1 AND MACD.DIF>MACD.DEA AND MACD.MACD>REF(HHV(MACD.DIF,2),1);  AC3:=HSL<REF(HSL,T2) AND LLV(L,T2+1)>BOLL.LB*0.9 AND HHV(L,T2+1)<M20;  AC4:=AMOUNT>REF(AMOUNT,1);  XG:=AC AND AC1 AND AC2 AND AC3 AND AC4;  DRAWICON(XG,L,1);

    浏览7640次浏览
    2022-09-05 09:59
  • 神奇指标

    缩量回踩55均线 放量拉升

    以下是缩量回踩55均线 放量拉升 N(5,100,43) 中:=MA(CLOSE,N); 上:=中 + 2*STD(CLOSE,N); 下:=中 - 2*STD(CLOSE,N); 金刚回踩:(REF(中,2)<REF(中,1) AND REF(L,1)<REF(中,1) AND REF(C,1)>REF(中,1) AND (REF(C,1)>O OR REF(C,1)=O)) AND (REF(中,1)<中 AND L<=中 AND C>中 AND (C>O OR C=O)) ;

    浏览1001次浏览
    2022-09-05 09:59
  • 神奇指标

    通达信突破20均线 主图/选股源码贴图

    以下是通达信突破20均线 主图/选股源码贴图 股价突破20均线后回调洗盘,再次上攻后一般又一波涨幅。  主图源码 M20:MA(C,20),COLORLIRED,DOTLINE;  T1:=BARSLAST(CROSS(C>=M20,0.5));  T2:=BARSLAST(CROSS(C<M20,0.5));  T3:=SUMBARS(T1=0,2);  ZF:=(C-REF(C,T1+1))/REF(C,T1+1)*100;  HZF:=REF(HHV(ZF,T1+1),T2);  DF:=(C-REF(C,T2+1))/REF(C,T2+1)*100;  LDF:=LLV(DF,T2+1);  L1:=LLV(L,T2+1);  L2:=REF(L1,T3-1);  AC:=COUNT(T2=0,T3)=1;  AC1:=O<M20 AND C>=M20 AND HZF<15 AND LDF>-25 AND LDF<-10;  AC2:=REF(T1,T2)>1 AND T2>1 AND MACD.DIF>MACD.DEA AND MACD.MACD>REF(HHV(MACD.DIF,2),1);  AC3:=HSL<REF(HSL,T2) AND LLV(L,T2+1)>BOLL.LB*0.9 AND HHV(L,T2+1)<M20;  AC4:=AMOUNT>REF(AMOUNT,1);  XG:=AC AND AC1 AND AC2 AND AC3 AND AC4;  DRAWICON(XG,L,1); 选股源码 M20:=MA(C,20);  T1:=BARSLAST(CROSS(C>=M20,0.5));  T2:=BARSLAST(CROSS(C<M20,0.5));  T3:=SUMBARS(T1=0,2);  ZF:=(C-REF(C,T1+1))/REF(C,T1+1)*100;  HZF:=REF(HHV(ZF,T1+1),T2);  DF:=(C-REF(C,T2+1))/REF(C,T2+1)*100;  LDF:=LLV(DF,T2+1);  L1:=LLV(L,T2+1);  L2:=REF(L1,T3-1);  AC:=COUNT(T2=0,T3)=1;  AC1:=O<M20 AND C>=M20 AND HZF<15 AND LDF>-25 AND LDF<-10;  AC2:=REF(T1,T2)>1 AND T2>1 AND MACD.DIF>MACD.DEA AND MACD.MACD>REF(HHV(MACD.DIF,2),1);  AC3:=HSL<REF(HSL,T2) AND LLV(L,T2+1)>BOLL.LB*0.9 AND HHV(L,T2+1)<M20;  AC4:=AMOUNT>REF(AMOUNT,1);  XG:AC AND AC1 AND AC2 AND AC3 AND AC4;

    浏览5345次浏览
    2022-09-05 09:55
  • 神奇指标

    通达信带阻力支撑的均线 贴图

    以下是通达信带阻力支撑的均线 贴图 加上了阻力支撑,阻力支撑带有未来函数,图中的买入信号不漂移。

    浏览5114次浏览
    2022-09-05 09:52
  • 神奇指标

    上穿最低均线 选股预警

    以下是上穿最低均线 选股预警 上穿最低均线 选股预警 源码 A1:=MIN(MA(C,20),MA(C,30)); A2:=MIN(A1,MA(C,40)); A3:=MIN(A2,MA(C,60)); A4:=MIN(A3,MA(C,120)); A5:=MIN(A4,MA(C,240)); XG:CROSS(C,A5) AND MA(C,5)>REF(MA(C,5),1) ;

    浏览9399次浏览
    2022-09-05 09:48