神奇指标网
神奇指标网
  • 神奇指标

    通达信三层判断KDJ 最佳买点副图

    通达信三层判断KDJ 最佳买点副图博弈论,又称为对策论(Game Theory)、赛局理论等,既是现代数学的一个新分支,也是运筹学的一个重要学科。博弈论主要研究公式化了的激励结构间的相互作用,是研究具有斗争或竞争性质现象的数学理论和方法。博弈论考虑游戏中的个体的预测行为和实际行为,并研究它们的优化策略。很明显,对照要素定义而言,股市里1.局中人:是多人(多主体)博弈。2.策略:在单一个股,板块,单日之内,是有限博弈。在一个阶段,在整个市场,是趋向于无限博弈。3.得失:在(阶段性)截取某段博弈过程时,每个参与方的得失与其当日策略有关,也与全局人的策略总和有关。4.这种得失结果,不仅仅在账户上,也在心理上,策略上,经验上产生积淀。5.这种均衡时动态的,任何时点都是一种动态均衡,只是下一时点是新矢量方向的动态均衡。VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5; 安全线: EMA(VAR1,55), CIRCLEDOT; K: SLOPE(EMA(VAR1,2),7)*15+VAR1; D: EMA(K,2); J: 2.8*K-1.8*D; 买1: IF(CROSS(K,D) AND K<安全线,9.8,6); 买2: IF(CROSS(K,安全线),9.8,6); 买3: IF(CROSS(K,D) AND K>安全线,9.8,6); V6:=CLOSE/REF(CLOSE,3)>=1.1; V7:=BACKSET(V6,3); 买4:IF((V7 AND COUNT(V7,3)=1),3,0),COLORFF00FF; DRAWTEXT(买4,10,'买4'),COLORFF00FF; 最佳买入: ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2),COLORRED,LINETHICK2; DRAWTEXT(最佳买入=1,1.5,'最佳买点'),COLORRED; VAR3:=PEAKBARS(3,15,1)<10; VAR5:=IF(VAR3=1,2,0);

    浏览4947次浏览
    2024-02-01 16:08
  • 神奇指标

    通达信终极KDJ 战法控盘

    通达信终极KDJ 战法控盘做股票重要的是修心,任何套路都是表象,心法才是核心!而心法是靠修炼而来的!任何技术,图形,手法,套路什么的,都是表象!人们只是困于其中,迷与其中.不变的是心法,万变的是套路!如何看出热点板块是否具有持续性?有些板块是一日游行情,有些却能持续走强,是看量能吧?----持续均匀的量能那就是说要确定是否是热点板块,就必须要关注几天才能最终确定了?对吗?-----如果求稳,是的,但是越稳利润越少,股市如赌场,风险越大,收益越高!我想提醒一下大家,不要盲目的和我学,我的方法不一定适合你!不适合你的方法就不是好方法!做股票很重要的一点:要根据你自己的性格来选一种打法,这种打法要和你的性格匹配!对于90%的股票来说,大盘环境是要看,但对于真正的热点或强势板块,大盘初期的恶劣环境是可以忽略的(当然只是初期),不但可以忽略,反而是低买的良机!真正的强势股在大盘不好(也不能暴跌)的情况下,往往也能冲高!股票不要怕高,往往你觉得越危险,其实越安全!而且股票是有生命的,真正的强势股生命力很强,在恶略的环境中也能生存,能反抗,而一般的股票就不行,生命力弱,环境一不好就完了我是做超短线的,我只关注热点板块,大家的操作以及思路可能各有不同,很难给出好的建议,还是我的那句话:做股票主要要自己研究,领悟,提高。我这样的操作还不叫“猛狠”吗?不顾大盘风险,每天满仓进出一股!我想整个股市应该无法找出一个比我更“猛狠”的了,当然能找出和我一样的!这种“猛狠”的超短线打法做到了极致,而与之匹配的就必须“稳准”也做到极致,要不然后果会很惨!当然“猛狠”做到易,“稳准”做到难,所以目标才会是“稳准”!只有把这“猛狠稳准”四个字都做到了,才算的上是超短线一流高手!超短线最高境界:只攻不守,因为不需要防守!要做就做强势股,要死也要死在强势股上,至少来的痛快,总比被弱势股慢慢耗死强!我现在资金量比较小,一般情况下没有分仓的习惯,分仓不利于超短线的操作!我是比较怕停盘的,不过我是双账号操作,一般不同时买一只股票,还好一点。M:=10; M1:=3; DIFF: EMA(CLOSE,12) - EMA(CLOSE,26),COLORWHITE; DEA: EMA(DIFF,9),COLORYELLOW; MACD:=2*(DIFF-DEA), COLORSTICK; RSV:(DIFF -LLV(DIFF ,M))/(HHV(DIFF ,M)-LLV(DIFF ,M))*100,COLORYELLOW; K:SMA(RSV,M1,1),COLORWHITE; D:SMA(K,M1,1),COLORBLUE; J:3*K-2*D,COLORF00FF0; VAR1:=MA(LOW,1); VAR3:=MA(CLOSE,2); VAR7:=REF(VAR3,1); VAR8:=SMA(MAX(VAR3-VAR7,0),13,1)/SMA(ABS(VAR3-VAR7),13,1)*100; VARB:=MA(INDEXC,3)*100/MA(INDEXC,10)-100; VARE:=IF(VARB>10,10,VARB); VARF:=IF(VARE< -10,-10,VARE); VAR12:=REF(VARB,1); VAR13:=100*(VAR3-REF(VAR3,1))/REF(VAR3,1); VAR14:=INDEXC; VAR15:=REF(VAR14,1); VAR16:=100*(VAR14-VAR15)/VAR14; VAR17:=MA(VAR13,3); VAR18:=MA(VAR16,3); VAR19:=(3*CLOSE+VAR1+OPEN+HIGH)/6; VAR1A:=(20*VAR19+19*REF(VAR19,1)+18*REF(VAR19,2)+17*REF(VAR19,3)+16*REF(VAR19,4)+15*REF(VAR19,5)+14*REF(VAR19,6)+13*REF(VAR19,7)+12*REF(VAR19,8)+11*REF(VAR19,9)+10*REF(VAR19,10)+9*REF(VAR19,11)+8*REF(VAR19,12)+7*REF(VAR19,13)+6*REF(VAR19,14)+5*REF(VAR19,15)+4*REF(VAR19,16)+3*REF(VAR19,17)+2*REF(VAR19,18)+REF(VAR19,20))/210; VAR1B:=MA(VAR1A,12); VAR1D:=ABS(VAR1A-VAR1B); VAR1E:=REF(VAR3,1)*0.015; VAR1F:=REF(INDEXC,1); 【强弱】:=SMA(MAX(VAR3-VAR7,0),5,1)/SMA(ABS(VAR3-VAR7),5,1)*100; DRAWTEXT(DAY=1 AND VAR17>VAR18,100,' 个股强盘!'),COLORFF00FF; DRAWTEXT(DAY=1 AND VAR12>VARF,80,' 盘处下道'),COLORCCFF99; DRAWTEXT(DAY=1 AND VAR18>=VAR17,60,' 个股弱盘!'),COLOR00FFFF; DRAWTEXT(DAY=1 AND VAR1A>VAR1B AND VAR1D>VAR1E AND NOT(CROSS(75,VAR8)),40,' 持股待涨!'),COLOR0099FF; DRAWTEXT(DAY=1 AND VAR1A< VAR1B AND VAR1D>VAR1E AND NOT(CROSS(【强弱】,20)),120,' 下调减持!'),COLORFF9900; DRAWTEXT(DAY=1 AND VAR1D<=VAR1E,90,' 盘整阶段!'),COLORFF9900; DRAWTEXT(DAY=1 AND (INDEXC-VAR1F)/VAR1F>0.035,50,'井喷行情!'),COLORRED;

    浏览13107次浏览
    2023-06-16 17:11
  • 神奇指标

    通达信猎人KDJ 最佳买入共振指标

    通达信猎人KDJ 最佳买入共振指标你要成为强者,就必须自立自强,学会独立思考,学会综合审视,自己强才是真的强。依附,原本就是炒股大忌,你不能改变它的属性,它必将会改变你。自己不改变谁都无法帮到你,迷津要悟只能靠自己。这里给大家献上代码,希望大家都可以成为一个猎人。VAR1:=(2*CLOSE+HIGH+LOW+OPEN)/5;安全线: EMA(VAR1,55), CIRCLEDOT;K: SLOPE(EMA(VAR1,2),7)*15+VAR1;D: EMA(K,2);J: 2.8*K-1.8*D;买1: IF(CROSS(K,D) AND K<安全线,9.8,6);买2: IF(CROSS(K,安全线),9.8,6);买3: IF(CROSS(K,D) AND K>安全线,9.8,6);V6:=CLOSE/REF(CLOSE,3)>=1.1;V7:=BACKSET(V6,3);买4:IF((V7 AND COUNT(V7,3)=1),3,0),COLORFF00FF;DRAWTEXT(买4,10,'买4'),COLORFF00FF;最佳买入: ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<REF(ZIG(3,10),2),colorred,LINETHICK2;DRAWTEXT(最佳买入=1,1.5,'最佳买点'),colorred;VAR3:=PEAKBARS(3,15,1)<10;VAR5:=IF(VAR3=1,2,0);

    浏览9046次浏览
    2022-10-28 17:25
  • 神奇指标

    RSI KDJ MACD CCI 集体共振

    以下是RSI KDJ MACD CCI 集体共振 提供 Code复制内容到剪贴板集体共振 input:n1(6),n2(12),n3(24); DRAWGBK(close>0,STRIP(RGB(25,25,112),RGB(47,79,79),0)); RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; K:SMA(RSV,3,1),LINETHICK3,COLORWHITE; D:SMA(K,3,1),LINETHICK3,COLORyellow; J:3*K-2*D,LINETHICK3,COLORred; DIFF:EMA(CLOSE,12)-EMA(CLOSE,26),linethick2,COLORgreen; DEA :EMA(DIFF,9),linethick2,COLORblue; MACD:2*(DIFF-DEA),linethick2,COLORred; YLZC:=if(close=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(vul+0.01)/100); 阻价:=if(close=INDEXC,YLZC+INDEXC-INDEXl,YLZC+(close-low)); 支价:=if(close=INDEXC,INDEXl+INDEXC-YLZC,low+(close-YLZC)); 今压:REF(阻价,1); 今撑:REF(支价,1); 明压:阻价; 明撑:支价; rsv1:=(hhv(h,9.8)-c)/(hhv(h,9.8)-llv(l,9.8))*101; kk:=sma(rsv1,3,1); dd:=sma(kk,3,1); jj:=3*kk-2*dd; 买卖:=if(jj>=100,100,if(jj<=0,0,jj)); 明天买:if(买卖=100,0-10,0),culor00cccc; 明天卖:if(买卖=0,90,100),culor00ff00; LC := REF(CLOSE,1); SMA(MAX(CLOSE-LC,0),N1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,LINETHICK1,Culorred; SMA(MAX(CLOSE-LC,0),N2,1)/SMA(ABS(CLOSE-LC),N2,1)*100,LINETHICK1,COLORgreen; SMA(MAX(CLOSE-LC,0),N3,1)/SMA(ABS(CLOSE-LC),N3,1)*100,LINETHICK1,COLORblue; KX:=250; KH:=HHV(K,KX); DH:=HHV(D,KX); JH:=HHV(J,KX); KL:=LLV(K,KX); DL:=LLV(D,KX); JL:=LLV(J,KX); HKMAX:=MAX(KH,MAX(DH,JH)); LKMIN:=MIN(KL,MIN(DL,JL)); KHLB:=(HKMAX+LKMIN)/2; KHLC:=HKMAX-LKMIN; MHF:=HHV(DIFF,KX); MHD:=HHV(DEA,KX); MHM:=HHV(MACD,KX); MLF:=LLV(DIFF,KX); MLD:=LLV(DEA,KX); MLM:=LLV(MACD,KX); HMAX:=MAX(MHF,MAX(MHD,MHM)); LMIN:=MIN(MLF,MIN(MLD,MLM)); FHLB:=(HMAX-LMIN)/100; FHLC:=HMAX-LMIN; SH:=(0-FHLB)*(KHLC/FHLC)+KHLB; DIFFA:=(DIFF-FHLB)*(KHLC/FHLC)+KHLB; DEAA:=(DEA-FHLB)*(KHLC/FHLC)+KHLB; MACDA:=(macd-FHLB)*(KHLC/FHLC)+KHLB; CDA:=MACD<ref(MACD,1) and MACD>0; CDB:=MACD>=ref(MACD,1) and MACD>0; CDC:=MACD>ref(MACD,1) and MACD<0; CDD:=MACD<=ref(MACD,1) and MACD<0; STICKLINE(CDA,SH,macda,6,0),COLOR00AAFF;{黄色段} STICKLINE(CDA,SH,macda,6.6,0),COLOR00BBFF; STICKLINE(CDA,SH,macda,4.4,0),COLOR00CCFF; STICKLINE(CDA,SH,macda,3.3,0),COLOR00DDFF; STICKLINE(CDA,SH,macda,2.2,0),COLOR00EEFF; STICKLINE(CDA,SH,macda,1.1,0),COLOR00FFFF; STICKLINE(CDB,SH,macda,6,0),COLOR0000AA; {红色段} STICKLINE(CDB,SH,macda,6.6,0),COLOR0011BB; STICKLINE(CDB,SH,macda,4.4,0),COLOr0022CC; STICKLINE(CDB,SH,macda,3.3,0),COLOR0033DD; STICKLINE(CDB,SH,macda,2.2,0),COLOR0044EE; STICKLINE(CDB,SH,macda,1.1,0),COLOR0055FF; STICKLINE(CDC,SH,macda,6,0),COLORAA00BB;{向上粉红} STICKLINE(CDC,SH,macda,6.6,0),COLORBB11BB; STICKLINE(CDC,SH,macda,4.4,0),COLORCC22BB; STICKLINE(CDC,SH,macda,3.3,0),COLORDD33BB; STICKLINE(CDC,SH,macda,2.2,0),COLOREE44BB; STICKLINE(CDC,SH,macda,1.1,0),COLORFF55BB; STICKLINE(CDD,SH,macda,6,0),COLORFF7700; STICKLINE(CDD,SH,macda,6.6,0),COLORFF8811; STICKLINE(CDD,SH,macda,4.4,0),COLORFFAA22; STICKLINE(CDD,SH,macda,3.3,0),COLORFFBB33; STICKLINE(CDD,SH,macda,2.2,0),COLORFFDD44; STICKLINE(CDD,SH,macda,1.1,0),COLORFFDD55; PARTLINE(DIFFA,DIFF>0,RGB(255,153,153),DIFF<0,RGB(255,153,153)); PARTLINE(DEAA,DEA>0,RGB(65,105,225),DEA<0,RGB(65,105,225)); DRAWTEXT(BARSTATUS=2,SH,'~~0'),culor00aaaa; TYP:=(HIGH+LOW+CLOSE)/3; STICKLINE(diff>ref(diff,1),20,20,2,0),COLORRED; STICKLINE(diff<ref(diff,1),20,20,2,0),COLORGREEN; STICKLINE(K>=ref(K,1) or k>d and diff>ref(diff,1),80,80,2,1),COLORRED; STICKLINE(K<ref(K,1),80,80,2,1),COLORGREEN; MACD金叉:=CROSS(MACD,DIFF) AND MACD>=(0-0.05) AND MACD<=0.02; DRAWTEXT(MACD金叉,40,'▲MACD金叉'),culorRED; XX:=ema(MA(LOW,3)*0.96,30); DIFF金叉:=if(CROSS(DIFF,DEA) AND XX-REF(XX,1)>0 AND MACD>=REF(MACD,1) AND DIFF<=0,1,0); DRAWTEXT(DIFF金叉=1,35,'▲DIFF金叉'),culorRED; 低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1; DRAWTEXT(低位金叉,25,'▲低位金叉'),culorRED; DIFDEA:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0)); 二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(DIFDEA=2,21)=1; DRAWTEXT(二次金叉,20,'▲二次金叉'),culorRED; A1:=BARSLAST(REF(CROSS(DIFF,DEA),1)); MACD底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA); DRAWTEXT(MACD底背离,30,'▲MACD底背离'),culorRED; A2:=BARSLAST(REF(CROSS(DEA,DIFF),1)); MACD顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF); DRAWTEXT(FILTER(MACD顶背离,5),100,'▼MACD顶背离'),COLORBLUE; {周金叉,死叉} 周DIFF:="MACD.DIFF#WEEK"; 周DEA:="MACD.DEA#WEEK"; 周MACD:="MACD.MACD#WEEK"; DIF周金叉:=CROSS(周DIFF,周DEA); DRAWTEXT(DIF周金叉,45,'▲DIFF周金叉'),culorRED; DRAWTEXT(CROSS(周DEA,周DIFF),110,'▼DIFF周死叉'),align0,culorBLUE; MACD周金叉:=CROSS(周MACD,周DIFF) AND 周MACD>=(0-0.05) AND 周MACD<=0.02; DRAWTEXT(MACD周金叉,50,'▲MACD周金叉'),culorRED; {月金叉,死叉} 月DIFF:="MACD.DIFF#MONTH"; 月DEA:="MACD.DEA#MONTH"; 月MACD:="MACD.MACD#MONTH"; DIF月金叉:=CROSS(月DIFF,月DEA); DRAWTEXT(DIF月金叉,55,'▲DIFF月金叉'),culorRED; DRAWTEXT(CROSS(月DEA,月DIFF),105,'▼DIFF月死叉'),align0,culorBLUE; MACD月金叉:=CROSS(月MACD,月DIFF) AND 月MACD>=(0-0.05) AND 月MACD<=0.02; DRAWTEXT(MACD月金叉,60,'▲MACD月金叉'),culorRED; 周K:="KDJ.K#WEEK"(9,3,3); 周D:="KDJ.D#WEEK"(9,3,3); 周J:="KDJ.J#WEEK"(9,3,3); 月K:="KDJ.K#MONTH"(9,3,3); 月D:="KDJ.D#MONTH"(9,3,3); 月J:="KDJ.J#MONTH"(9,3,3); KD月金叉:=cross(月K,月D); KD周金叉:=cross(周K,周D); KD日金叉:=FILTER(cross(K,D) and D<50,4); KD低位金叉:=FILTER(cross(K,D) and D<20,4); DRAWTEXT(KD月金叉,0,'▲KD月金叉'),culorRED; DRAWTEXT(KD周金叉,-5,'▲KD周金叉'),culorRED; DRAWTEXT(KD日金叉,-10,'▲KD日金叉'),culorRED; DRAWTEXT(KD低位金叉,5,'▲KD低位金叉'),culorRED; KD1:=COUNT(CROSS(K,D),BARSLAST(D>=50)); KD二次金叉:=CROSS(K,D) AND D<50 AND COUNT(KD1=2,21)=1; DRAWTEXT(KD二次金叉,10,'▲KD二次金叉'),culorRED; KD2:=COUNT(CROSS(D,K),BARSLAST(D<=50)); KD二次死叉:=CROSS(D,K) AND D>50 AND COUNT(KD2=2,21)=1; DRAWTEXT(KD二次死叉,95,'▼KD二次死叉'),CulorBLUE; KD日死叉:=FILTER(cross(D,K) and D>80,4); DRAWTEXT(KD日死叉,80,'▼KD日死叉'),COLORBLUE; DRAWTEXT(CROSS(周D,周K),85,'KD周死叉'),COLORDDDDDD; DRAWTEXT(CROSS(月D,月K),90,'KD月死叉'),COLORDDDDDD; KDB:=BARSLAST(ref(cross(k,d),1)); KDDB:=ref(close,KDB+1)>close and ref(k,KDB+1)<k and cross(k,d); KDJ底背离:=if(FILTER(KDDB>0,5),1,0); DRAWTEXT(KDJ底背离=1,15,'▲KDJ底背离'),culorRED; KDD:=BARSLAST(ref(cross(d,k),1)); KDJ顶背离:=ref(close,KDD+1)<close and ref(k,KDD+1)>k and cross(d,k); DRAWTEXT(FILTER(KDJ顶背离>0,5),120,'▼kDJ顶背离'),COLORBLUE; MD1:=MA(CLOSE,80)-MA(CLOSE,13)/3; MD2:=MA((CLOSE-MD1)/MD1,3); 买点1:=CROSS(MD2,0) AND LOW/REF(HIGH,1)<1.012 AND J<75 AND J>REF(J,1); ma12:=MA(CLOSE,12); 佳点:=if(FILTER(MACD>=REF(MACD,5) AND open<=ref(close,1) and XX-REF(XX,1)>0 AND MACD<=0 AND ma12-REF(ma12,1)>=0,3) and J<80 and J>ref(J,1) and D>ref(D,1) and (diff>=ref(diff,1) or dea>=ref(dea,1)),1,0); DRAWTEXT(佳点=1,macda*0.98,'佳点'),culor00CC00; DX0:=EMA(CLOSE,2)-EMA(OPEN,5); DX1:=if(CROSS(DX0,MACD) AND LOW<=XX AND MACD<=(0-0.11) and (J<20 or K<20),1,0); DRAWTEXT(FILTER(DX1,3),0,'短10%'),culor00CC00;{短线} MA10:=MA(CLOSE,10); SS:=EMA(MA(HIGH,3)*1.05,30); LQS:=if(FILTER(0.7*(CROSS(DIFF,DEA) AND CLOSE<SS AND XX-REF(XX,1)>0 AND CROSS(MACD,0) AND MACD>=0 AND DIFF>0 AND ma10-REF(ma10,1)>0 AND VOL>REF(VOL,1))>=0.7 AND (CLOSE<SS AND XX-REF(XX,1)>0),5) AND J<80,1,0); DRAWTEXT(LQS=1,macda*0.98,'量价齐上'),culor00CC00;{量价齐上} 最佳点:=IF(COUNT(MD2>REF(MD2,1),3)=3 AND COUNT(MD2<0,10)=10 AND REF(MD2,3)=LLV(MD2,10) and J<80 and J>ref(J,1),1,0); DRAWTEXT(最佳点=1,J,'最佳点'),culor00CC00; 买点2:=REF(MD2,2)=LLV(MD2,20) AND REF(MD2,2)<0.071 AND REF(MD2,2)<REF(MD2,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1) AND J<75 AND J>REF(J,1); DRAWTEXT(买点1 or 买点2,D-1,'买'),culor00CC00; {预涨} AZ:=DYNAINFO(7); AC1:=REF(C,1); ZF1:=(AZ-AC1)/AC1*100; BZ:=DYNAINFO(8); BV1:=REF(VOL,1); ZF2:=BZ/BV1*100; DZ:=REF(CLOSE,1)-REF(OPEN,1); EZ:=DYNAINFO(23)-DYNAINFO(22); FZ:=REF(VOL,1)-REF(VOL,2); 预涨:=ZF1>1 AND ZF1<5 AND ZF2>30 AND DZ>0 AND EZ>0 AND FZ>0 AND D>REF(D,1); DRAWTEXT(预涨,d*0.6,'预涨'),culor00CC00; RSI周金:DRAWTEXT(CROSS("rsi.rsi1#WEEK"(n1,n2,n3),"rsi.rsi2#WEEK"(n1,n2,n3)) ,65,'▲RSI周金'),COLORRED; RSI周死:DRAWTEXT(CROSS("rsi.rsi2#WEEK"(n1,n2,n3),"rsi.rsi1#WEEK"(n1,n2,n3)) ,130,'▼RSI周死'),COLORBLUE; RSI月金:DRAWTEXT(CROSS("rsi.rsi1#MONTH"(n1,n2,n3),"rsi.rsi2#MONTH"(n1,n2,n3)) ,70,'▲RSI月金'),COLORRED; RSI月死:DRAWTEXT(CROSS("rsi.rsi2#MONTH"(n1,n2,n3),"rsi.rsi1#MONTH"(n1,n2,n3)) ,115,'▼RSI月死'),COLORBLUE; A3:=BARSLAST(ref(cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1)); B3:=ref(c,A3+1)>c and ref("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) and cross("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)); RSI底背离:=FILTER(B3>0,5); DRAWTEXT(RSI底背离,75,'▲RSI底背离'),COLORRED; C3:=BARSLAST(ref(cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1)); D3:=ref(c,C3+1)<c and ref("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) and cross("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)); RSI顶背离:=FILTER(D3>0,5); DRAWTEXT(RSI顶背离,125,'▼RSI顶背离'),COLORBLUE; 牛股1:二次金叉 and MACD底背离 and 低位金叉 and kd周金叉 and 月D<20; 牛股2:二次金叉 and MACD底背离 and 低位金叉 and kd月金叉 and 周D<20; 牛股3:KD日金叉 and KD周金叉 and KD月金叉 and DIF周金叉; 牛股6:KD周金叉 and KD月金叉 and DIF周金叉; 大牛股:FILTER(牛股1 and 牛股2 and 牛股3,18); 底背离三合一:MACD底背离 and KDJ底背离 and RSI底背离; 二合一1:MACD底背离 and KDJ底背离 ; 二合一2:MACD底背离 and RSI底背离; 二合一3:KDJ底背离 and RSI底背离; 顶背离:MACD顶背离 or KDJ顶背离 or RSI顶背离; DRAWTEXT(牛股3 OR 大牛股 OR 牛股6 OR 底背离三合一,D-8,'▲▲▲全仓买'),COLORred;

    浏览8986次浏览
    2022-10-20 14:05
  • 神奇指标

    大智慧RSI KDJ MACD 日周月 底背离 金叉

    以下是RSI KDJ MACD 日周月 底背离 金叉RSI KDJ MACD 日周月 底背离 金叉 {KDJ同时金叉}DRAWGBKLAST(CLOSE>0,STRIP(RGB(5,5,5),RGB(90,90,90),0));月K:"KDJ.K"(89,3,3),Culorgreen,linethick0;月D:"KDJ.D"(89,3,3),Culorgreen,linethick0;FILLRGN(月K,月D,月K>月D),Culor00DD00;FILLRGN(月K,月D,月K<月D),Culor009700;周K:"KDJ.K"(27,3,3),Culor00E4F1,linethick0;周D:"KDJ.D"(27,3,3),culoryellow,linethick0;FILLRGN(周K,周D,周K>周D),Culor03f7fa;FILLRGN(周K,周D,周K<周D),Culor009CC3;日K:"kd.k"(5,3,3),culor0538f2,linethick0;日D:"kd.d"(5,3,3),culor052b99,linethick0;FILLRGN(日K,日D,日K<日D),Culor052b99;FILLRGN(日K,日D,日K>日D),culor0538f2;月金叉:IF(CROSS(月K,月D),16,0),stick,linethick1,Culorgreen;DRAWTEXT(月金叉,16,'■'),Culor09DB00;周金叉:IF(CROSS(周K,周D),12,0),stick,linethick1,culoryellow;DRAWTEXT(周金叉,12,'■'),culoryellow;日金叉:IF(CROSS(日K,日D),8,0),stick,linethick1,culorred;DRAWTEXT(日金叉,8,'■'),culorred;VERTLINE(日金叉 and 周金叉 and 月金叉,4),culor5b5b5b;{KD在30以下多次金叉}Jm:=CROSS("kdj.k"(5,3,3),"kdj.d"(5,3,3));JmCOUNT:=COUNT(Jm,BARSLAST("kdj.d"(5,3,3)>=30));Jmtj:=28*("kdj.d"(5,3,3)<30 and COUNT(JmCount=1,21)=1);Jmtj2:=28*("kdj.d"(5,3,3)<30 and COUNT(JmCount=2,21)=1);DRAWICON (Jmtj2,70,13);DRAWICON (Jmtj2,72,13);Jmtj3:=28*("kdj.d"(5,3,3)<30 and COUNT(JmCount=3,21)=1);DRAWICON (Jmtj3,70,13);DRAWICON (Jmtj3,72,13);DRAWICON (Jmtj3,74,13);Jmtj4:=28*("kdj.d"(5,3,3)<30 and COUNT(JmCount=4,21)=1);DRAWICON (Jmtj4,70,13);DRAWICON (Jmtj4,72,13);DRAWICON (Jmtj4,74,13);DRAWICON (Jmtj4,76,13);Jmtj5:=28*("kdj.d"(5,3,3)<30 and COUNT(JmCount=5,21)=1);DRAWICON (Jmtj5,70,13);DRAWICON (Jmtj5,72,13);DRAWICON (Jmtj5,74,13);DRAWICON (Jmtj5,76,13);DRAWICON (Jmtj5,78,13); 0,COLORYELLOW;DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA:=EMA(DIFF,9);MACD:=2*(DIFF-DEA);A1:=BARSLAST(ref(cross(diff,dea),1));B1:=ref(c,A1+1)>c and ref(diff,A1+1)<diff and cross(diff,dea);MACD底背离:STICKLINE(FILTER(B1>0,5),0,0.75,3,0),COLORGREEN;DRAWTEXT(FILTER(B1>0,5),0.57,'MACD底背离'),COLORGREEN;RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K:=SMA(RSV,3,1);D:=SMA(K,3,1);A2:=BARSLAST(ref(cross(k,d),1));B2:=ref(c,A2+1)>c and ref(k,A2+1)<k and cross(k,d);KDJ底背离:STICKLINE(FILTER(B2>0,5),0,1,3,0),COLORYELLOW;DRAWTEXT(FILTER(B2>0,5),0.80,'KDJ底背离'),COLORYELLOW;LC :=REF(CLOSE,1);RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;RSI2:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;A3:=BARSLAST(ref(cross(RSI1,RSI2),1));B3:=ref(c,A3+1)>c and ref(RSI1,A3+1)<RSI1 and cross(RSI1,RSI2);RSI底背离:STICKLINE(FILTER(B3>0,5),0,0.5,3,0),COLORwhite;DRAWTEXT(FILTER(B3>0,5),0.25,'RSI底背离'),COLORwhite;C1:=BARSLAST(ref(cross(dea,diff),1));D1:=ref(c,C1+1)<c and ref(diff,C1+1)>diff and cross(dea,diff);MACD顶背离:STICKLINE(FILTER(D1>0,5),2,1.25,3,0),COLOR0066FF;DRAWTEXT(FILTER(D1>0,5),1.47,'MACD顶背离'),COLOR0066FF;C2:=BARSLAST(ref(cross(d,k),1));D2:=ref(c,C2+1)<c and ref(k,C2+1)>k and cross(d,k);KDJ顶背离:STICKLINE(FILTER(D2>0,5),2,1,3,0),COLORRED;DRAWTEXT(FILTER(D2>0,5),1.2,'KDJ顶背离'),COLORRED;C3:=BARSLAST(ref(cross(RSI2,RSI1),1));D3:=ref(c,C3+1)<c and ref(RSI1,C3+1)>RSI1 and cross(RSI2,RSI1);RSI顶背离:STICKLINE(FILTER(D3>0,5),2,1.5,3,0),COLORff00ff;DRAWTEXT(FILTER(D3>0,5),-4.75,'RSI顶背离'),COLORff00ff;partline(0,C>0),culorffa2af;partline(20,C>0),culorffa2af,pointdot;partline(50,C>0),culorffa2af,pointdot;partline(80,C>0),culorffa2af,pointdot;partline(100,C>0),culorffa2af;

    浏览2927次浏览
    2022-10-18 13:19
  • 神奇指标

    通达信获利KDJ 老张实战小公式

    以下是通达信获利KDJ 老张实战小公式获利KDJ 老张实战小公式说明:1、本公式是获利盘K线与KDJ指标叠加而成;2、公式的精华:技术指标最好不要单独使用、因为存在信号失真状态、这一点很重要、很多股民没有意识到;3、强调一:当获利盘K线长期处于50以下的弱势区时、指标的大多数信号提示只会让你亏损;4、强调二:当获利盘K线长期处于50以上的强势区时、指标的威力将发挥出来、赚钱的可能性较大;5、强调三:当获利盘K线长期处于90以上时、长牛、慢牛股的可能性较大、可一路追踪操作;6、黄K线:获利盘等于100、即所有人都处于赚钱状态;7、纪律:远离毒品、远离弱势股;8、交易模型:可根据公式总结出多种操作方案(附图中的案例供参考)、视个人需要而定;9、KDJ是经典指标、这里尽量保持原貌、不过当K线与其距离太远时、也有一定的实战意义;10、在获利盘K线基础上可叠加相关指标、大家不妨试试、也许有惊喜;公式源码{获利KDJ}DRAWBAND(50,RGB(50,50,100),0,RGB(0,0,0));NOTEXT100:100,COLORGRAY;NOTEXT90:90,COLORGRAY,DOTLINE;NOTEXT80:80,COLORGREEN,DOTLINE;NOTEXT70:=70,COLORGRAY,DOTLINE;NOTEXT60:=60,COLORGRAY,DOTLINE;NOTEXT50:50,COLORGRAY;NOTEXT40:=40,COLORGRAY,DOTLINE;NOTEXT30:=30,COLORGRAY,DOTLINE;NOTEXT20:20,COLORGREEN,DOTLINE;NOTEXT10:=10,COLORGRAY,DOTLINE;NOTEXT0:0,COLORGRAY;NOTEXT120:120,COLORBLACK;NOTEXTD20:-20,COLORBLACK;CH:=WINNER(H)*100;CO:=WINNER(O)*100;CL:=WINNER(L)*100;CC:=WINNER(C)*100,NODRAW;DRAWKLINE(CH,CO,CL,CC);STICKLINE(CC=100,CC,CO,0.5,0),COLORYELLOW;N:=9;M1:=3;M2:=3;RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100,LINETHICK2;K:SMA(RSV,M1,1),COLORWHITE,LINETHICK1;D:SMA(K,M2,1),COLORCYAN,LINETHICK1;J:3*K-2*D,COLORFF00FF,LINETHICK1;NOTEXTA:IF(J<0,J,DRAWNULL),COLORGREEN,LINETHICK1;NOTEXTB:IF(J>100,J,DRAWNULL),COLORGREEN,LINETHICK1;TJ:=CURRBARSCOUNT=25;DRAWTEXT(TJ,25,'→弱势区、不介入'),COLORFFFFFF;

    浏览9317次浏览
    2022-10-17 17:00
  • 神奇指标

    通达信自用新编整合版KDJ 副图源码贴图

    以下是通达信自用新编整合版KDJ 副图源码贴图非 常 好 用 , 多 周 期 K D J 同 图 !STICKLINE(C>0,-20,5,4,0),COLORBLACK;F1:=ZIG(3,15);F2:=IF((F1> REF(F1,1)),100,80); RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100; K:SMA(RSV,3,1); D:SMA(K,3,1); J:3*K-2*D,COLORRED; MA势:=SMA(MAX(C-REF(C,1),0),8,1)/SMA(ABS(C-REF(C,1)),8,1)*100;势:=EMA(MA势,5),COLORLIRED;趋势:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2* SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1); ZZ:=趋势>REF(趋势,1);K1:=DVOL/1000000;K2:=DCLOSE;V1:=EMA(K1,5);V2:=EMA(K2,5);价异动:=K2>REF(V2,1)*1.06;量异动:=K1>REF(V1,1)*1.6&&ZZ;停牌:=DYNAINFO(17)>0; M1:=SUM(价异动,2)>0 AND 停牌;M2:=SUM(量异动,2)>0 AND REF(趋势,1)<89;鸣:(F2=100 AND C>REF(C,1) AND FILTER(M1 AND M2,3))*120,COLORRED,LINETHICK3; DIF:=EMA(CLOSE,12)-EMA(CLOSE,26); DEA:=EMA(DIF,9); MACD:=(DIF-DEA)*2;低2:=IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL); TX:=BARSLAST(C>REF(C,1)*1.095 AND C=H); T2L:=BARSLAST(C<REF(C,1)*1.095 AND C>REF(C,1)*1.08); T3L:=BARSLAST(C<REF(C,1)*1.08 AND C>REF(C,1)*1.07); T4L:=BARSLAST(C<REF(C,1)*1.07 AND C>REF(C,1)*1.06); T5L:=BARSLAST(C<REF(C,1)*1.06 AND C>REF(C,1)*1.05); TJ1X:=COUNT(TX=0,100)=0; TJ2:=COUNT(T2L=0,100)=0; TJ3:=COUNT(T3L=0,100)=0; TJ4:=COUNT(T4L=0,100)=0; TJ5:=COUNT(T5L=0,100)=0; TJA:=C>REF(C,1)*1.05; AA:=REF(TX,1)>100 AND REF(T2L,1)>100 AND REF(T3L,1)>100 AND REF(T4L,1)>100 AND REF(T5L,1)>80 AND TJA; HHM:=HHV(MACD.MACD*100,200); LLM:=LLV(MACD.MACD*100,200); M5:=MA(C,5);M10:=MA(C,10);M20:=MA(C,20);M60:=MA(C,60); D3:=MIN(MIN(M5,M10),M20)>M60; XGT:=BARSLAST(AA AND HHM<60 AND LLM>-55); D6:=BARSSINCEN(MIN(MIN(M5,M10),M20)>M60,XGT+1); XGX:=CROSS((XGT=0 AND D3) OR D6=0,0.5); TJX:=COUNT(XGX,30)=2 AND XGX; SR11:=REF(HIGH,10)=HHV(HIGH,2*10+1); SR21:=FILTER(SR11,10); SR31:=BACKSET(SR21,10+1); HDH:=FILTER(SR31,10); 前高G:=REF(H,BARSLAST(HDH));倍量G:=VOL/REF(VOL,1)>=1.9;突破前高G:=CROSS(C,前高G); YG:= 倍量G AND 突破前高G; SJG:=BARSLAST(YG); H300:=HHVBARS(DIF,300); AL:=BOLL.UB; TQ:=BARSLAST(CROSS(AL>=REF(AL,1),0.5)); E25:=EXPMA(C,25); ZF:=EVERY(RANGE(C/REF(C,1),0.97,1.05),TQ+1); ZFF:=(HHV(H,TQ+1)-LLV(L,TQ+1))/LLV(L,TQ+1)*100; TJQ:=EVERY(MAX(C,O)/AL<1.02 ,TQ+1); XL:=(ATAN((E25/REF(E25,TQ)-1)*100)*180/3.1415926); TJ1Q:=CROSS(DIF>=REF(DIF,H300),0.5) AND ZFF<17 AND ZF AND TJQ;起程:=TJ1Q AND XL>75; A1F:=REF(C,1); A3F:=(DCLOSE-A1F)/A1F*100; AA1F:=(A3F-REF(A3F,1));选股1:=CROSS(AA1F,9.8); A11F:=REF(V,1); A13F:=DVOL/A11F; AA3F:=(A13F-REF(A13F,1));选股2:=CROSS(AA3F,500);潜伏:=选股1 AND 选股2; 爆发点:=(DCLOSE-REF(C,1))/REF(C,1)*100; XB:=CROSS(爆发点,20); TJ1L:=REF(CROSS(MA(C,5),C),1) AND CROSS(C,MA(C,5)); TJ2L:=REF(CROSS(MA(C,10),C),1) AND CROSS(C,MA(C,10)); TJ3L:=REF(CROSS(MA(C,20),C),1) AND CROSS(C,MA(C,20)); TJ4L:=TJ1L OR TJ2L OR TJ3L; TJ5L:=REF(C,2)/REF(C,1)>=1.045 AND REF(C,1)<REF(O,1) AND C/REF(C,1)>1.09 AND C=H AND TJ4L; A:=(3*C+L+O+H)/6; X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+ 14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12) +7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+ REF(A,20))/210;中线:=EMA(X,13); KKA:=EMA(C,5); KKB:=EMA(KKA,8); KKC:=EMA(KKB,13);长线1:=EMA(KKC,50); KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;KBBB3:=C/REF(C,1)>1+0.01*9; KCCC3:=中线/长线1<1+0.01*20;大牛:=KAAA3 AND KBBB3 AND KCCC3 AND TJ5L; VARAA:=LLV(LOW,5); VARBA:=HHV(HIGH,5);确:=EMA((CLOSE-VARAA)/(VARBA-VARAA)*100,4); MA500:=MA(CLOSE,500); MA250:=MA(CLOSE,250); MA120:=MA(CLOSE,120); MA30:=MA(CLOSE,33); MA60:=MA(CLOSE,55);涨停收盘:=(C-REF(C,1))*100/REF(C,1)>=4 AND H-C<0.02; HD30:=FILTER(BACKSET(FILTER(REF(H,30)=HHV(H,2*30+1),30),30+1),30); LD30:=FILTER(BACKSET(FILTER(REF(H,30)=LLV(H,2*30+1),30),30+1),30); AX30:=REF(H,BARSLAST(HD30)); T300:=BARSLAST(HD30)<BARSLAST(LD30) AND NOT(HD30);顶30:=IF(T300,AX30,AX30); JZ:=(CROSS(C,顶30) AND DIF>=-0.21 AND DEA<=0.37 AND MA30>MA60 AND (CROSS(C,MA30)OR CROSS(C,MA120)OR CROSS(C,MA250)OR CROSS(C,MA500) OR LOW< MA30)) AND MA30- MA60<0.7 AND 涨停收盘 AND ABS((顶30-MA30)/顶30*100)<10;信:IF(确>REF(确,1) AND DIF>DEA AND (JZ OR 大牛 OR XB OR 潜伏 OR 起程 OR CURRBARSCOUNT=CONST(SJG)+2 OR TJX OR (CCI<=100 AND L<=低2)),120,0)STICK,LINETHICK5,COLORLIMAGENTA;卖警:=IF(PEAKBARS(3,15,1)=1,80,100),COLORGREEN;泥淖:=IF((F1> REF(F1,1)),100,80),COLORFF9900; Q_1:=C-REF(C,1); Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6); Q_3:=CROSS(EMA(C,19),EMA(C,7)); Q_4:=CROSS(EMA(C,7),EMA(C,19)); Z1:=L=LLV(L,BARSLAST(Q_3)+1); Z2:=LLV(L,BARSLAST(Q_3)+1); Z3:=H=HHV(H,BARSLAST(Q_4)+1); Z4:=HHV(H,BARSLAST(Q_4)+1);上0:=DRAWLINE(Z1,Z2,Z3,Z4,0); Y1:=H=HHV(H,BARSLAST(Q_4)+1); Y2:=HHV(H,BARSLAST(Q_4)+1); Y3:=L=LLV(L,BARSLAST(Q_3)+1); Y4:=LLV(L,BARSLAST(Q_3)+1);下0:=DRAWLINE(Y1,Y2,Y3,Y4,0); TJ:=IF(上0<REF(上0,1) AND 下0=上0,1,0);未来空柱:=IF(REF(TJ,1)=0 AND TJ>=1,100,0); AVAR1:=(C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100; AVAR2:=(C-LLV(L,10))/(HHV(H,10)-LLV(L,10))*100; AVAR3:=(C-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100; AVAR4:=DMA(SMA((AVAR1+AVAR2+AVAR3)/3,2,1),3); K0:=SMA(AVAR4,2,1),COLOR0000FF,LINETHICK2; M0:=SMA(K0,2,1),COLORFFFFFF; SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1); SR2:=FILTER(SR1,10); SR3:=BACKSET(SR2,10+1); HD:=FILTER(SR3,10); 前高:=REF(H,BARSLAST(HD));倍量:=VOL/REF(VOL,1)>=1.9;突破前高:=CROSS(C,前高);Y:= 倍量 AND 突破前高;SJ:=BARSLAST(Y); DRAWTEXT(CURRBARSCOUNT=CONST(SJ)+2,45,'过左峰'),COLORYELLOW; B:=ZIG(3,10); G:=MA(B,2); W:=CROSS(G,B); DRAWTEXT(W=1,70,'卖' ),COLOR00FF00; VARA1:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100); VARA2:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100); VARA3:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100); VARA4:=(((VARA1 + (2 * VARA2)) + (3 * VARA3)) / 6); VARA5:=MA(VARA4,3);底部反转:=CROSS(KDJ.J,0) AND (VARA5 <= (0 - 7)); DRAWTEXT(F2=100 AND 底部反转,50,'反转预警'),COLORRED;值:=(EMA(((CLOSE-LLV(LOW,14))/(HHV(HIGH,35)-LLV(LOW,56)))*(4),4))*(25),COLORGREEN,LINETHICK2; DRAWTEXT(FILTER(CROSS(值,5),10), 40,'超低'),COLORYELLOW; DIFX:=(2*EMA(CLOSE, 12)-EMA(EMA(CLOSE,12),12))-(2*EMA(CLOSE, 26)-EMA(EMA(CLOSE, 26),26)); DEAX:=2*EMA(DIFX, 9) - EMA(EMA(DIFX, 9),9); GG:= DEAX> REF(DEAX,1) AND REF(DEAX> REF(DEAX,1),1)=1; LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;拐点出击:=(NOT(未来空柱=100) AND F2=100 AND LL AND GG)*DEAX; VAR1:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100; VAR2:=SMA(VAR1,3,1); VAR3:=SMA(VAR2,3,1); VAR4:=SMA(VAR3,3,1);山底:=IF(CLOSE>SAR(4,6,20),SAR(4,6,20),DRAWNULL),CIRCLEDOT,COLORGREEN;山顶:=IF(CLOSE<SAR(4,6,20),SAR(4,6,20),DRAWNULL),CIRCLEDOT,COLORRED; DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26),COLORWHITE; DIFF变红:=IF(DIFF>=REF(DIFF,1),DIFF,DRAWNULL),COLORLIRED; {DEA:=EMA(DIFF,9),COLORWHITE;} DEA变红:=IF(DEA>=REF(DEA,1),DEA,DRAWNULL),COLORLIMAGENTA; {MACD:=2*(DIFF-DEA),COLORSTICK;} NOTEXT上买下卖:=CLOSE-REF(CLOSE,49),COLORWHITE; NOTEXT红买绿卖:=MA(NOTEXT上买下卖,49),COLORGREEN;上买下卖:=IF(NOTEXT上买下卖>NOTEXT红买绿卖,NOTEXT上买下卖,DRAWNULL),LINETHICK2,COLORMAGENTA;红买绿卖:=IF(NOTEXT红买绿卖>=REF(NOTEXT红买绿卖,1) AND NOTEXT上买下卖>NOTEXT红买绿卖,NOTEXT红买绿卖,DRAWNULL),LINETHICK3,COLORRED;红买:=上买下卖 AND 红买绿卖 AND DEA变红,COLORRED,NODRAW;绿卖:=红买!=1,COLORGREEN,NODRAW;底:=SMA(VAR2,3,1),COLORGREEN;顶:=SMA(底,3,1),COLORRED;方向:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);方向向下:=(DMA((2*CLOSE+LOW+HIGH)/4,方向)),COLORGREEN;红灯停:=IF(CLOSE<SAR(4,6,20),SAR(4,6,20),DRAWNULL),CIRCLEDOT,COLORRED;向下:=方向向下 AND 红灯停,COLORGREEN,NODRAW;空仓基因:=绿卖 AND 向下,COLORGREEN,NODRAW; B2:=BARSLAST(REF(CROSS(顶,底),1));顶背离:=空仓基因 AND REF(C,B2+1)<HHV(H,3) AND REF(底,B2+1)>底 AND CROSS(顶,底) AND 底>80 AND MA(C,5)>MA(C,377) AND 山顶;DRAWTEXT(顶背离=1,85,'顶背'),COLORFFFF00; DRAWTEXT(FILTER(拐点出击,30), 30,'拐点→'),COLORWHITE;多空:118,COLOR0B0BFF,LINETHICK5;红: IF(K0>M0,118,DRAWNULL),COLORFF00FF,LINETHICK5;青: IF(K0<M0,118,DRAWNULL),COLOR00FF00,LINETHICK5; STICKLINE(CROSS(90,J),88,100,1,0),COLOR00FF00; DRAWTEXT(CROSS(90,J),100,'。逃'),COLORFFFFFF; STICKLINE(CROSS(J,(0 - 5)),0,10,3,0); DRAWTEXT(CROSS(J,(0 - 5)),(0 - 4),'----低吸'),COLORYELLOW;{抄底加仓}IF(REF(COUNT(K<REF(K,1),5)>=5,1) AND COUNT(K<30,5)>=2 AND COUNT(J<0,3)>0 AND CROSS(J,0),100,50),COLOR00FFFF; TJ00:=BARSLAST(REF(CROSS(K,D) AND REF(K,1)<35,1)); TJ11:=C<REF(C,TJ00+1)*1.1 AND REF(K,1)<60 AND (TJ00+1)<25 AND (TJ00+1)>5 AND K>REF(K,TJ00+1) AND CROSS(K,D);仓:=IF(TJ11,35,0),COLORLIRED; A22:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1)); DRAWICON(CROSS(K,D),K,1); DRAWICON(CROSS(D,K),D,2); VAR0002:="KDJ.K#DAY"(9,3,3); VAR0003:="KDJ.D#DAY"(9,3,3); VAR0004:="KDJ.K#WEEK"(9,3,3); VAR0005:="KDJ.D#WEEK"(9,3,3); VAR0006:="KDJ.K#MONTH"(9,3,3); VAR0007:="KDJ.D#MONTH"(9,3,3);日:IF(CROSS(VAR0002,VAR0003),15,0)LINESTICK,COLORGREEN;周:IF(CROSS(VAR0004,VAR0005),60,0)LINESTICK,COLORMAGENTA;月:IF(CROSS(VAR0006,VAR0007),90,0),LINETHICK2,COLORYELLOW; DRAWTEXT(周,18,'周'),COLORYELLOW; DRAWTEXT(月,20,'月'),COLORYELLOW;周日:IF(CROSS(VAR0004,VAR0005) AND CROSS(VAR0002,VAR0003),70,0)LINETHICK2,COLORBLUE;

    浏览5139次浏览
    2022-10-12 10:41
  • 神奇指标

    通达信KDJ 主图最牛指标主图贴图

    以下是通达信KDJ 主图最牛指标主图贴图 论坛高手众多,各人对KDJ指标的理解和结构也各有不同。我的理解KDJ作为一个灵敏的震荡指标,同时也具有趋势判断作用。 共享一个KDJ主图指标,喜欢的朋友可以在副图加上MACD一起使用。用法也不用介绍了。K线首次突显出来做多

    浏览1292次浏览
    2022-09-05 14:57
  • 神奇指标

    强烈推荐 KDJ macd周金叉 周死叉 月金月死 精准把握

    以下是强烈推荐 KDJ macd周金叉 周死叉 月金月死 精准把握 {二指金叉} DIF:(EMA(CLOSE,12)-EMA(CLOSE,26))*100,COLOR0000FF,LINETHICK2;  DEA:EMA(DIF,9),COLORFFFFFF,LINETHICK2;  MACD:(DIF-DEA)*2,COLORSTICK;  RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;  K:SMA(RSV,3,1),COLORYELLOW;  D:SMA(K,3,1),COLORFFFF00;  J:3*K-2*D,COLORMAGENTA;  DIFW:="MACD.DIF#WEEK";  DEAW:="MACD.DEA#WEEK";  FCA:=FILTER(CROSS(DIFW,DEAW),0);  SCA:=FILTER(CROSS(DEAW,DIFW),0);  M周金叉:IF(CROSS("MACD.DIF#WEEK","MACD.DEA#WEEK"),-50,0),COLOR0000FF,LINETHICK2;  DRAWTEXT(FCA,-45,' MACD周金叉'),COLOR0000FF;  M周死叉:IF(CROSS("MACD.DEA#WEEK","MACD.DIF#WEEK"),-50,0),COLOR00FF00,LINETHICK2;  DRAWTEXT(SCA,-45,' MACD周死叉'),COLOR00FF00;  DIFM:="MACD.DIF#MONTH";  DEAM:="MACD.DEA#MONTH";  FCB:=FILTER(CROSS(DIFM,DEAM),0);  SCB:=FILTER(CROSS(DEAM,DIFM),0);  M月金叉:IF(CROSS("MACD.DIF#MONTH","MACD.DEA#MONTH"),-60,0),COLOR00FFFF,LINETHICK2;  DRAWTEXT(FCB,-55,' MACD月金叉'),COLOR00FFFF;  M月死叉:IF(CROSS("MACD.DEA#MONTH","MACD.DIF#MONTH"),-60,0),COLORFF6600,LINETHICK2;  DRAWTEXT(SCB,-55,' MACD月死叉'),COLORFF6600;  KKW:="KD.K#WEEK",COLORRED;  KDW:="KD.D#WEEK",COLORYELLOW;  KCD:=FILTER(CROSS(KKW,KDW),0);  SCD:=FILTER(CROSS(KDW,KKW),0);  K周金叉:IF(CROSS("KDJ.K#WEEK","KDJ.D#WEEK"),50,0),COLOR0000FF,LINETHICK2;  DRAWTEXT(KCD,50,' KDJ周金叉'),COLOR0000FF;  K周死叉:IF(CROSS("KDJ.D#WEEK","KDJ.K#WEEK"),50,0),COLOR00FF00,LINETHICK2;  DRAWTEXT(SCD,50,' KDJ周死叉'),COLOR00FF00;  KKM:="KDJ.K#MONTH",COLORRED;  KDM:="KDJ.D#MONTH",COLORYELLOW;  KDB:=FILTER(CROSS(KKM,KDM),0);  SDB:=FILTER(CROSS(KDM,KKM),0);  K月金叉:IF(CROSS("KDJ.K#MONTH","KDJ.D#MONTH"),60,0),COLOR00FFFF,LINETHICK2;  DRAWTEXT(KDB,60,' KDJ月金叉'),COLOR00FFFF;  K月死叉:IF(CROSS("KDJ.D#MONTH","KDJ.K#MONTH"),60,0),COLORFF6600,LINETHICK2;  DRAWTEXT(SDB,60,' KDJ月死叉'),COLORFF6600;

    浏览4808次浏览
    2022-09-05 11:01
  • 神奇指标

    MACD 加有KDJ RSI金死叉提示

    以下是MACD 加有KDJ RSI金死叉提示 DIFF:EMA(CLOSE,10) - EMA(CLOSE,22),NODRAW;  DEA :EMA(DIFF,7.5),NODRAW;  MACD :2*(DIFF-DEA),NODRAW;  DRAWBAND(DIFF,RGB(255,157,255),DEA,RGB(21,138,255));  STICKLINE(MACD>0,0,MACD,0.01,0) ,COLOR0000FF;  STICKLINE(MACD<0,0,MACD,0.01,0) ,COLORFFF000;  GMB:IF(CROSS(DIFF,DEA) AND DIFF>0,-0.02,DRAWNULL),CROSSDOT,LINETHICK4,COLOR0000FF;  GMC:IF(CROSS(DIFF,DEA) AND DIFF<0,-0.02,DRAWNULL),CROSSDOT,LINETHICK4,COLOR208FFF; 趋势:=(5)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1),2,1);  STICKLINE(趋势<=5,0,MACD,0.01,0) ,COLOR208FFF;  0,COLORFFFF00,LINETHICK1;  DRAWICON(CROSS(DIFF,DEA) AND DIFF>0,DEA,36);  DRAWICON(CROSS(DIFF,DEA) AND DIFF<0,DEA,37);  A1:=BARSLAST(REF(CROSS("MACD.DIF","MACD.DEA"),1));  B1:=REF(C,A1+1)>C AND REF("MACD.DIF",A1+1)<"MACD.DIF" AND CROSS("MACD.DIF","MACD.DEA");  DRAWTEXT(FILTER(B1>0,5),0,'MACD'),COLORGREEN;  A2:=BARSLAST(REF(CROSS("KDJ.K","KDJ.D"),1));  B2:=REF(C,A2+1)>C AND REF("KDJ.K",A2+1)<"KDJ.K" AND CROSS("KDJ.K","KDJ.D");  DRAWTEXT(FILTER(B2>0,5),MACD,'KDJ'),COLORYELLOW;  A3:=BARSLAST(REF(CROSS("RSI.RSI1","RSI.RSI2"),1));  B3:=REF(C,A3+1)>C AND REF("RSI.RSI1",A3+1)<"RSI.RSI1" AND CROSS("RSI.RSI1","RSI.RSI2");  DRAWTEXT(FILTER(B3>0,5),MACD,'RSI'),COLORCYAN;  C1:=BARSLAST(REF(CROSS("MACD.DEA","MACD.DIF"),1));  D1:=REF(C,C1+1)<C AND REF("MACD.DIF",C1+1)>"MACD.DIF" AND CROSS("MACD.DEA","MACD.DIF");  DRAWTEXT(FILTER(D1>0,5),MACD,'MACD'),COLORWHITE;  C2:=BARSLAST(REF(CROSS("KDJ.D","KDJ.K"),1));  D2:=REF(C,C2+1)<C AND REF("KDJ.K",C2+1)>"KDJ.K" AND CROSS("KDJ.D","KDJ.K");  DRAWTEXT(FILTER(D2>0,5),MACD,'KDJ'),COLORWHITE;  C3:=BARSLAST(REF(CROSS("RSI.RSI2","RSI.RSI1"),1));  D3:=REF(C,C3+1)<C AND REF("RSI.RSI1",C3+1)>"RSI.RSI1" AND CROSS("RSI.RSI2","RSI.RSI1");  DRAWTEXT(FILTER(D3>0,5),MACD,'RSI'),COLORMAGENTA;  

    浏览2922次浏览
    2022-09-05 10:14
  • 神奇指标

    成交量KDJ (原创 副图 原码 贴图)

    以下是成交量KDJ (原创 副图 原码 贴图) 量:V,VOLSTICK;  RSV:=MA(V,7)*1.5;  K:SMA(RSV,3,1),COLORFFFFFF,LINETHICK1;  D:SMA(K,3,1),COLORYELLOW,LINETHICK1;  J:(3*K-2*D),COLORFF00FF,LINETHICK1;  IF(K<D,K,DRAWNULL),COLOR00FF00,LINETHICK1;  IF(K<D,D,DRAWNULL),COLORFFFF00,LINETHICK1;  IF(K<D,J,DRAWNULL),COLOR008000,LINETHICK1; 换手率: HSL,COLORYELLOW;  {分级显示换手率} 开关1:=IF(HSL<=1,1,0); 开关2:=IF(HSL>1 AND HSL<=3,1,0); 开关3:=IF(HSL>3 AND HSL<=5,1,0); 开关4:=IF(HSL>5 AND HSL<=8,1,0); 开关5:=IF(HSL>8 AND HSL<=10,1,0); 开关6:=IF(HSL>10 AND HSL<=15,1,0); 开关7:=IF(HSL>15 AND HSL<=25,1,0); 开关8:=IF(HSL>25,1,0);  DRAWTEXT_FIX(1,0.5,0,0,'█████████████'),COLOR3C3C3C;{,COLORBROWN背景} QQ1:=STRCAT(STRCAT('(0,1]换手低迷:● ',CON2STR(HSL,2)),0);  QQ2:=STRCAT(STRCAT('(1,3]换手温和:● ',CON2STR(HSL,2)),0);  QQ3:=STRCAT(STRCAT('(3,5]换手异动:■ ',CON2STR(HSL,2)),0);  QQ4:=STRCAT(STRCAT('(5,8]换手活跃:■ ',CON2STR(HSL,2)),0);  QQ5:=STRCAT(STRCAT('(8,10]换手非常活跃:▲ ',CON2STR(HSL,2)),0);  QQ6:=STRCAT(STRCAT('(10,15]换手高度活跃:▲ ',CON2STR(HSL,2)),0);  QQ7:=STRCAT(STRCAT('(15,25]换手极度活跃:★ ',CON2STR(HSL,2)),0);  QQ8:=STRCAT(STRCAT('(25,...)巨量换手:★ ',CON2STR(HSL,2)),0); 换手开关:=IF(开关1,QQ1,IF(开关2,QQ2,IF(开关3,QQ3,IF(开关4,QQ4,IF(开关5,QQ5,IF(开关6,QQ6,IF(开关7,QQ7,QQ8)))))));  DRAWTEXT_FIX(ISLASTBAR,0.5,0,0,换手开关),COLORYELLOW;

    浏览3653次浏览
    2022-09-05 10:14
  • 神奇指标

    通达信博弈 KDJ 指标源码

    以下是通达信博弈 KDJ 指标源码 金融市场是博弈的场所。 很多技术分析指标都基于博弈原理设计,只要稍做改动就可以明确显示出博弈点。 下图是KDJ 指标的博弈变化指标。希望读者可以举一反三。

    浏览7056次浏览
    2022-09-05 10:14
  • 神奇指标

    通达信傻买傻卖MACD融入kDJ 经典指标改良

    以下是通达信傻买傻卖MACD融入kDJ 经典指标改良 {N=9,M1=3,M2=3}  RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;  K:=SMA(RSV,M1,1),LINETHICK2,COLORWHITE;  D:=SMA(K,M2,1),COLORYELLOW; 量能:=3*K-2*D,LINETHICK2;  RSIE:=EMA(量能,3);  DIFF : EMA(RSIE,12) - EMA(RSIE,26);  BBDIFF:=DIFF-REF(DIFF,1);  DEA : EMA(DIFF,9); BBDEA:=DEA-REF(DEA,1);  MACD : 2*(DIFF-DEA), COLORSTICK;  STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0),COLORFFFF00;  STICKLINE(MACD<REF(MACD,1)AND MACD<0,0,MACD,2,0),COLOR00FF00;  STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0),COLOR0099FF;  STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,2,0),COLORRED;  0,COLORFF8855,LINETHICK2;  IF(DIFF>DEA,DIFF,DRAWNULL),COLORRED,LINETHICK2;  IF(DEA>REF(DEA,1),DEA,DRAWNULL),COLORMAGENTA;  DRAWICON(CROSS(DIFF,DEA),DEA,1);  DRAWICON(CROSS(DEA,DIFF),DEA,2);  DRAWBAND(DIFF,RGB(255,105,180),DEA,RGB(34,139,34)); 低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;  STICKLINE(低位金叉,0,-1.5,2,0),COLORFFFF00;  DRAWTEXT(低位金叉,-1.5,' 低位金叉'),COLORFFFF00;  JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0)); 二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;  STICKLINE(二次金叉,0,-1,5,0),COLORFF00FF;  DRAWICON(二次金叉,DEA*1.2,11) ;  DRAWTEXT(二次金叉,-1,' 二次金叉'),COLORFF00FF;  A1:=BARSLAST(REF(CROSS(DIFF,DEA),1)); 底背离:=REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA);  STICKLINE(底背离,0,1.5,3,0),COLOR00FF00;  DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK2;  DRAWTEXT(底背离,2,' 底背离'),COLOR00FF00;  A2:=BARSLAST(REF(CROSS(DEA,DIFF),1)); 顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);  STICKLINE(顶背离,0,2,3,0),COLORFF8855;  DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFF8855,LINETHICK2;  DRAWTEXT(顶背离,2,' 顶背离'),COLORFF8855;

    浏览1096次浏览
    2022-09-05 10:14
  • 神奇指标

    通达信吸筹反转KDJ 换手2-5% 选股公式

    以下是通达信吸筹反转KDJ 换手2-5% 选股公式 {吸反KDJHS2-5%} {吸筹反转KDJ+温和换手2到5% 选股 冰糖编辑} {吸筹反转KDJ 选股短线回避下跌通道选股} N:=18; M1:=3; M2:=3; {95,COLOR0000FF; -10,COLORFFFF00;} REFLINE:= -10, 20, 50, 80, 110; RSV:=(CLOSE - LLV(LOW,N))/(HHV(HIGH,N) - LLV(LOW,N))*100; K:=EMA(RSV,M1); D:=EMA(K,M2); J:=(3*K-2*D); 火山:=IF(J<=0,20,0),LINETHICK0; {STICKLINE(J<=0,90,100,8,0),COLORRED;} KDJ1:=REF(COUNT(J<REF(J,1),5)>=3,1) AND REF(J,1)<20; KDJ2:=J>REF(J,1); 换手:=VOL/CAPITAL*100; 反转:IF(FILTER(KDJ1 AND KDJ2,3),50,0) AND 换手>2 AND 换手<5; {换手:=VOL/CAPITAL*100; 低换手小于2:=换手<2; 温和换手2到5:换手>2 AND 换手<5;} {热换手5到11:换手>5 AND 换手<11,COLORYELLOW,NODRAW; 烫手换手11到17:换手>11 AND 换手<17,COLORRED,NODRAW; 高潮换手大于17:换手>17,COLORGREEN,NODRAW; 五日均换手:MA(换手,5); 十日均换手:MA(换手,10);};

    浏览3594次浏览
    2022-09-05 10:13
  • 神奇指标

    通达信CCI叠加KDJ 副图源码 说明

    以下是通达信CCI叠加KDJ 副图源码 说明 DRAWGBK(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0);  STICKLINE(C>0,80,100,28,0)COLOR242424;  STICKLINE(C>0,20,0,28,0)COLOR242424;  STICKLINE(C>0,50,50,28,-1)COLORWHITE;  STICKLINE(C>0,100/3+50,100/3+50,28,-1)COLORWHITE;  STICKLINE(C>0,-100/3+50,-100/3+50,28,-1)COLORWHITE;  DRAWTEXT(ISLASTBAR,50,' ██'),COLORBLACK;  DRAWTEXT(ISLASTBAR,50,' 0'),COLORWHITE;  DRAWTEXT(ISLASTBAR,100/3+50,' ███'),COLORBLACK;  DRAWTEXT(ISLASTBAR,100/3+50,' 100'),COLORWHITE;  DRAWTEXT(ISLASTBAR,-100/3+50,' ████'),COLORBLACK;  DRAWTEXT(ISLASTBAR,-100/3+50,' -100'),COLORWHITE;  {}  N1:=9;M1:=3;M2:=3;  RSV:=(CLOSE-LLV(LOW,N1))/(HHV(HIGH,N1)-LLV(LOW,N1))*100;  K:SMA(RSV,M1,1)COLORCYAN,NODRAW;  D:SMA(K,M2,1)COLOR0080FF,NODRAW;  J:3*K-2*D,COLORRED,NODRAW;  DRAWBAND(J,RGB(200,50,50),D,RGB(0,50,150));  {}  N:=14;  TYP:=(HIGH+LOW+CLOSE)/3; 真实CCI:(TYP-MA(TYP,N))/(0.015*AVEDEV(TYP,N)),COLORYELLOW,NODRAW; 真实CCI均线:EXPMA(真实CCI,5),COLORGREEN,NODRAW;  NOTEXT压缩:真实CCI/3+50,COLORYELLOW;  NOTEXT趋势:真实CCI均线/3+50,COLORGREEN;  {}  DRAWTEXT_FIX(C>0,0.5,0,0,'红蓝彩条是KDJ,黄线CCI,绿色CCI均线'),COLORWHITE;

    浏览8182次浏览
    2022-09-05 10:12