神奇指标网
神奇指标网
  • 神奇指标

    同花顺万哥均线私募强势股回调主图

    同花顺万哥均线私募强势股回调主图掌握市场的根本,胜利接踵而至;如果被别人掌握了根,就会失败。买卖那一刻的冷静不仅是对股票走势的信心,更是自身境界的体现。小资金做大需要一些天赋和理解,不是每个人都能做到。短期内可以做到的核心是,首先,如果你的模式是正确的,你就不能没有模式,也不能走弯路。你需要不断地尝试和犯错误,比如经常看你的交割单,哪些赚了钱,哪些赔了钱,你需要不断地纠正和调节自己。我们必须适应市场的方向。我们必须研究市场产生的新事物。只有朝着正确的方向努力,你才能成为时代的引领者,更容易地赚钱。只要你在市场上生存了一天,你就必须接受市场的变化。如果你的行业发生了变化,你不知道如何学习和应用,你最终会进入死胡同。每一个参与市场的优秀人士都不应该有自己的过度偏好。有时偏好是优势,但当时代发生变化,以前的模式不再适用时,偏好将成为你的限制和陷阱。强势股:16日开十分一仓,如果破,在32日线补十分一,弹到16日线出场,再破32线,在64日线补,弹到32日线出。前提:大盘在16日线上.个股特别是创新高后的回落,找上涨波幅度要大,量要放大。整根线跌到16日前不能中间有反弹,要单波直跌。"该强势股做法的要点在于选股和时机的把握,选股一定要根据上述条件筛选。其次一定是要按照具体的均线做对应的仓位调整。 这样做有优有劣,大家也可以根据自身性格进行改进,不过既然是私募大哥给我分享出来,必然是这个条件即最优解,所以不断选股操作并复利就行了。弄好了指标大家可以在软件上翻下前期的强势股,观察位置和力度。U8:=SUM(VOL*CLOSE,8)/SUM(VOL,8); UU8:=IF(U8<=0,CLOSE,U8); MS8:UU8,colorblack; DRAWTEXT(ISLASTBAR,MS8,'8'),ALIGN0,SHIFT2,colorblack; U16:=SUM(VOL*CLOSE,16)/SUM(VOL,16); UU16:=IF(U16<=0,CLOSE,U16); MS16:UU16,coloryellow,LINETHICK1; DRAWTEXT(ISLASTBAR,MS16,'16'),ALIGN0,SHIFT2,coloryellow; U32:=SUM(VOL*CLOSE,32)/SUM(VOL,32); UU32:=IF(U32<=0,CLOSE,U32); MS32:UU32,colorred,LINETHICK1; DRAWTEXT(ISLASTBAR,MS32,'32'),ALIGN0,SHIFT2,colorred; U64:=SUM(VOL*CLOSE,64)/SUM(VOL,64); UU64:=IF(U64<=0,CLOSE,U64); MS64:UU64,COLORCC9900,LINETHICK2; DRAWTEXT(ISLASTBAR,MS64,'64'),ALIGN0,SHIFT2,COLORCC9900; U128:=SUM(VOL*CLOSE,128)/SUM(VOL,128); UU128:=IF(U128<=0,CLOSE,U128); MS128:UU128,COLOR6666CC,LINETHICK1; DRAWTEXT(ISLASTBAR,MS128,'128'),ALIGN0,SHIFT2,COLOR6666CC; U256:=SUM(VOL*CLOSE,256)/SUM(VOL,256); UU256:=IF(U256<=0,CLOSE,U256); MS256:UU256,LINETHICK1; DRAWTEXT(ISLASTBAR,MS256,'256'),ALIGN0,SHIFT2,colorwhite; U512:=SUM(VOL*CLOSE,512)/SUM(VOL,512); UU512:=IF(U512<=0,CLOSE,U512); MS512:UU512,LINETHICK1; DRAWTEXT(ISLASTBAR,MS512,'512'),ALIGN0,SHIFT2,colorblack; WS:=MOD(REF(C,1)*100,10)/100; FD:=REF(C,1)/10-IF(WS<0.05,WS,WS-0.10)/10; 涨停:=C=REF(C,1)+FD; 跌停:=C=REF(C,1)-FD; STICKLINE(涨停,L,C,2,1),colorred; STICKLINE(跌停,L,O,2,1),colorgreen;

    浏览5991次浏览
    2023-01-18 17:34
  • 神奇指标

    有人将它当宝贝,诈称是私募内部专用不便外泄的东西

    以下是有人将它当宝贝,诈称是私募内部专用不便外泄的东西通达信-----主图-----源码东西是很好,忽悠受不了。 网上找到手,分享大家有。DRAWKLINE(H,O,L,C);ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL);ZSP:=IF(C>REF(C,1),C,DRAWNULL);DKP:=IF(C<=REF(C,1),REF(C,1),DRAWNULL);DSP:=IF(C<=REF(C,1),C,DRAWNULL);DRAWKLINE(H,DKP,L,DSP);STICKLINE(C<=REF(C,1),DKP,DSP,3.05,0),COLORBLUE;STICKLINE(C<=REF(C,1),DKP,DSP,2.2,0),COLORFF7700;STICKLINE(C<=REF(C,1),DKP,DSP,1.5,0),COLORFF9900;STICKLINE(C<=REF(C,1),DKP,DSP,0.5,0),COLORFFBB00;DRAWKLINE(H,ZKP,L,ZSP);STICKLINE(C>REF(C,1),ZKP,ZSP,3.05,0),COLOR000099;STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC;STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF; STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF;STICKLINE(V/REF(V,1)>2 AND CLOSE>=OPEN,ZKP,ZSP,1,0),COLORYELLOW;VAR111:=ZIG(3,13);STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,3,0),COLOR66FF00;DRAWTEXT_FIX(STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,5,0),0.00,0.11,0,''),COLOR00FF00,LINETHICK1;MA5:MA(C,5)LINETHICK3,COLOR00CCFF;MA10:=MA(C,10);MA20:=MA(C,20);MA30:=MA(C,30);TY:=C;A1:=REF(TY,10)=HHV(TY,2*10+1);B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1);HD:=FILTER(C1,10);A2:=REF(TY,10)=LLV(TY,2*10+1);B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);前期高位:REF(C,BARSLAST(HD)),COLOR8000FF,POINTDOT;STICKLINE(C,前期高位,前期高位,8,0),COLOR8000FF;JRH:=HHV(C,2); JRL:=LLV(C,2); VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2)); VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARA:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2)); VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01); VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD); 红色持股:=VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;离场:=IF(红色持股,JRL,DRAWNULL); 明离场价:=离场,COLORFF99FF,NODRAW;青色观望:=VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW; 进:=IF(青色观望,JRH,DRAWNULL);今离场价:REF(离场,1),COLOR0000FF,NODRAW; 明进场价:=进,COLOR33AACC,NODRAW; 今进场价:REF(明进场价,1),COLORGREEN,NODRAW;上涨家数:INDEXADV,COLOR0080FF,NODRAW;下跌家数:INDEXDEC,COLORGREEN,NODRAW;五日乖离率:=(C-MA5)/MA5*100;BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1);加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;IF(BB5>30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK3,COLORRED;BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;IF(BB5<0 AND MA5<REF(MA5,1), MA5,DRAWNULL),LINETHICK3,COLORGREEN;三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB5,60),10);加仓:=FILTER(COUNT(CROSS(BB5,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1),10);清仓:=FILTER(COUNT(CROSS(30,BB5),5)>=1 AND (C>MA30 OR O>MA30) AND MA5<REF(MA5,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);DRAWTEXT(加仓 ,LOW*0.96,'加'),COLORYELLOW;JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;减仓:=FILTER(JC,10);MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;买入:=FILTER(MR,10);DRAWTEXT(减仓,HIGH*1.01,'←风险'),COLORCYAN;DRAWTEXT(买入,LOW*0.99,'买'),COLORYELLOW;DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;DRAWTEXT(强势狙击,LOW*0.98,'←狙击'),COLORWHITE;VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;压力:MA(REF(HHV(C,30),1),2),COLORABFF46; 支撑:MA(REF(LLV(C,30),1),2),COLOR9DFFFF;总额:=AMOUNT;买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));买%:=买/AMOUNT*100;流入:=AMOUNT*买%/10000000000;流出:=AMOUNT/100000000-流入;净流:=(流入-流出);总额3:=SUM(AMOUNT,3);流入3:=SUM(流入,3);流出3:=SUM(流出,3);净流3:=SUM(流入-流出,3);总额5:=SUM(AMOUNT,5);流入5:=SUM(流入,5);流出5:=SUM(流出,5);净流5:=SUM(流入-流出,5);总额10:=SUM(AMOUNT,10);流入10:=SUM(流入,10);流出10:=SUM(流出,10);净流10:=SUM(流入-流出,10);画:=CONST(FINDHIGH(总额10,0,190,1));DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK)COLOR00FFFF;DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK)COLOR00FFFF;DRAWTEXT_FIX(1,0.30,0.00,0,'主题投资:')COLOR00FFFF;DRAWTEXT_FIX(1,0.36,0.00,0,EXTERNSTR(0,2))COLOR00FFFF;DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:')COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3))COLOR00FFFF;DRAWTEXT_FIX(1,0.00,0.10,0,'解禁日期:')COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0.10,0,EXTERNSTR(0,4))COLOR00FFFF;DRAWTEXT_FIX(1,0.00,0.15,0,'莸利比例:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.06,0.15,0,CONST(WINNER(C )*100)),COLOR0080FF;DRAWTEXT_FIX(1,0.12,0.15,0,'动态PE:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.17,0.15,0,CONST(DYNAINFO(39))),COLOR0080FF;DRAWTEXT_FIX(1,0.22,0.15,0,'市值:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.26,0.15,0,FINANCE(40)/100000000),COLOR0080FF;DRAWTEXT_FIX (1,0.31,0.15,0,'公积金(股):'),COLORYELLOW;DRAWNUMBER_FIX(1,0.38,0.15,0,FINANCE(18)),COLOR0080FF;DRAWTEXT_FIX (1,0.43,0.15,0,'收益:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.47,0.15,0,FINANCE(33)),COLOR0080FF;DRAWTEXT_FIX(1,0.00,0.19,0,'净流入(亿):'),COLORYELLOW;DRAWTEXT_FIX(1,0.06,0.19,0,'1日'),COLORYELLOW;DRAWTEXT_FIX(1,0.12,0.19,0,'3日'),COLORYELLOW;DRAWTEXT_FIX(1,0.18,0.19,0,'5日'),COLORYELLOW;DRAWTEXT_FIX(1,0.24,0.19,0,'10日'),COLORYELLOW;DRAWNUMBER_FIX(1,0.08,0.19,0,CONST((净流))),COLOR0080FF;DRAWNUMBER_FIX(1,0.14,0.19,0,CONST((净流3))),COLOR0080FF;DRAWNUMBER_FIX(1,0.20,0.19,0,CONST((净流5))),COLOR0080FF;DRAWNUMBER_FIX(1,0.265,0.19,0,CONST((净流10))),COLOR0080FF;DRAWTEXT_FIX(1,0.00,0.23,0,'愚民导向:'),COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0.23,0,EXTERNSTR(0,5)),COLOR00FFFF;DRAWRECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0)); 超B:=L2_AMO(0,2)/10000.0;大B:=L2_AMO(1,2)/10000.0;中B:=L2_AMO(2,2)/10000.0;小B:=L2_AMO(3,2)/10000.0;超S:=L2_AMO(0,3)/10000.0;大S:=L2_AMO(1,3)/10000.0;中S:=L2_AMO(2,3)/10000.0;小S:=L2_AMO(3,3)/10000.0;TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);大宗进:=(超B)+(大B),NODRAW;大宗出:=(超S)+(大S),NODRAW;非大宗进:=(中B)+(小B),NODRAW;非大宗出:=(中S)+(小S),NODRAW;大宗进限制:=IF((超B+大B)=0,0,大宗进);大宗出限制:=IF((超S+大S)=0,0,大宗出);非大宗进限制:=IF(中B+小B=0,0,非大宗进);非大宗出限制:=IF(中S+小S=0,0,非大宗出);主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;大单强度限制:=IF(大单强度=0,-100,大单强度);大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;超单强度限制:=IF(超单强度=0,-100,超单强度);超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW;DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50)));DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW;DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,0.99,0,'净流入:(万)'),COLORYELLOW;主力买力度:=LARGEINTRDVOL*1000/VOL;主力卖力度:=LARGEOUTTRDVOL*1000/VOL;AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;DRAWRECTREL(0,515,CONST(ABS(主力买力度)*560/AAD),568,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*560/AAD),623,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0)));DRAWTEXT_FIX(1,0,0.524,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW;DRAWTEXT_FIX(1,0,0.576,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW;{DDE显示}DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*1000/FINANCE(7);DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);DRAWRECTREL(150,500,192,540,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(150,545,192,585,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(150,590,192,630,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));DRAWTEXT_FIX(1,0.153,0.500,0,STRCAT('DDX:',CON2STR(DDX,1))),COLORYELLOW,COLORWHITE;DRAWTEXT_FIX(1,0.153,0.548,0,STRCAT('DDY:',CON2STR(DDY,1))),COLORYELLOW,COLORWHITE;DRAWTEXT_FIX(1,0.153,0.596,0,STRCAT('DDZ:',CON2STR(DDZ,1))),COLORYELLOW,COLORWHITE;T1:=IF (DDX>0 AND REF(DDX,1)<0,1,0);T2:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)<0,2,T1);T3:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)<0,3,T2);T4:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)<0,4,T3);T5:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)<0,5,T4);T6:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)<0,6,T5);T7:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)<0,7,T6);T8:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)<0,8,T7);T9:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)<0,9,T8);T:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)>0,10,T9);DRAWTEXT_FIX(1,0.190,0.500,0,STRCAT(STRCAT(' ',CON2STR(T,0)),' [天] ')),COLORYELLOW;T11:=IF (DDY>0 AND REF(DDY,1)<0,1,0);T21:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)<0,2,T11);T31:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)<0,3,T21);T41:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)<0,4,T31);T51:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)<0,5,T41);T61:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)<0,6,T51);T71:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)<0,7,T61);T81:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)<0,8,T71);T91:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)<0,9,T81);TY01:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)>0,10,T91);DRAWTEXT_FIX(1,0.190,0.548,0,STRCAT(STRCAT(' ',CON2STR(TY01,0)),' [天] ')),COLORYELLOW;T1Z:=IF (DDZ>0 AND REF(DDZ,2)<0,1,0);T2Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)<0,2,T1Z);T3Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)<0,3,T2Z);T4Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)<0,4,T3Z);T5Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)<0,5,T4Z);T6Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)<0,6,T5Z);T7Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)<0,7,T6Z);T8Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)<0,8,T7Z);T9Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)<0,9,T8Z);TZ:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)>0,10,T9Z);DRAWTEXT_FIX(1,0.190,0.596,0,STRCAT(STRCAT(' ',CON2STR(TZ,0)),' [天] ')),COLORYELLOW;

    浏览2332次浏览
    2022-11-03 13:56
  • 神奇指标

    通达信股票指标公式私募都在用,主图指标波段操作之王

    通达信 私募都在用,主图指标波段操作之王很清晰的主图指标信号,建议结合其他副图指标一起使用!这里归纳的,全是十年来实战中错误理解的领悟,是自己十年交易心血总结,比干货实在,我是一个崇尚实干的人,实盘不断修正融合的归纳总结,因为我相信总结的力量,也信任自己的总结能力。总结:发现未知,填补自身认知空白,修正以前片面的理解,用于实盘中操作的纠偏,让思维和操作更趋向和当时市场的契合,最终达成能力提升的愿想。在交易中不断总结。寻求犯错的本质所在,这是总结最大的意义。没有百分百成功的指标,但百分百的努力投入,超越百分之九十的人,你就能收获股市的成功!通达信  主图指标波段操作之王 主图指标公式源码:JL01:=MA(C,3);   LJL07:=(3*C+L+O+H)/6;   牛线:(20*LJL07+19*REF(LJL07,1)+18*REF(LJL07,2)+17*REF(LJL07,3)+16*REF(LJL07,4)+15*REF(LJL07,5)+14*REF(LJL07,6)+13*REF(LJL07,7)+12*REF(LJL07,8)+11*REF(LJL07,9)+10*REF(LJL07,10)+9*REF(LJL07,11)+8*REF(LJL07,12)+7*REF(LJL07,13)+6*REF(LJL07,14)+5*REF(LJL07,15)+4*REF(LJL07,16)+3*REF(LJL07,17)+2*REF(LJL07,18)+REF(LJL07,20))/210,COLORRED;   马线:MA(牛线,6),COLORYELLOW,LINETHICK4,POINTDOT;   上限:马线+3*STD(CLOSE,20),COLORMAGENTA,CROSSDOT;  下限:马线-2.9*STD(CLOSE,20),COLOR2693FF,CROSSDOT;   买:马线-2*STD(CLOSE,20),LINETHICK2,COLORFF937F;   卖:马线+2*STD(CLOSE,20),LINETHICK2,COLOR00FF00;   等待:IF(JL01<=牛线,马线,DRAWNULL),COLORRED,LINETHICK4,POINTDOT;   VAR1:=(C>REF(C,1) AND C>REF(C,2));   VAR2:=(REF(VAR1,1) AND C<=ref(c,1) and="" c="">=REF(C,2));   VAR3:=(REF(VAR2,1) AND C>=REF(C,1) AND C<=REF(C,2));   VAR4:=(REF(VAR3,1) AND C<=ref(c,1) and="" c="">=REF(C,2));   VAR5:=(REF(VAR4,1) AND C>=REF(C,1) AND C<=REF(C,2));   VAR6:=(REF(VAR5,1) AND C<=ref(c,1) and="" c="">=REF(C,2));   VAR7:=(REF(VAR6,1) AND C>=REF(C,1) AND C<=REF(C,2));   VAR8:=(REF(VAR7,1) AND C<=ref(c,1) and="" c="">=REF(C,2));   VAR9:=(REF(VAR8,1) AND C>=REF(C,1) AND C<=REF(C,2));   VARA:=(REF(VAR9,1) AND C<=ref(c,1) and="" c="">=REF(C,2));   VARB:=(REF(VARA,1) AND C>=REF(C,1) AND C<=REF(C,2));   VARC:=(REF(VARB,1) AND C<=ref(c,1) and="" c="">=REF(C,2));   持股:IF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,牛线,DRAWNULL),COLORRED,LINETHICK1;   VARD:=(C<REF(C,1) AND C<REF(C,2));   VARE:=(REF(VARD,1) AND C>=REF(C,1) AND C<=REF(C,2));   VARF:=(REF(VARE,1) AND C<=ref(c,1) and="" c="">=REF(C,2));   VAR10:=(REF(VARF,1) AND C>=REF(C,1) AND C<=REF(C,2));   VAR11:=(REF(VAR10,1) AND C<=ref(c,1) and="" c="">=REF(C,2));   VAR12:=(REF(VAR11,1) AND C>=REF(C,1) AND C<=REF(C,2));   VAR13:=(REF(VAR12,1) AND C<=ref(c,1) and="" c="">=REF(C,2));   VAR14:=(REF(VAR13,1) AND C>=REF(C,1) AND C<=REF(C,2));   VAR15:=(REF(VAR14,1) AND C<=ref(c,1) and="" c="">=REF(C,2));   VAR16:=(REF(VAR15,1) AND C>=REF(C,1) AND C<=REF(C,2));   VAR17:=(REF(VAR16,1) AND C<=ref(c,1) and="" c="">=REF(C,2));   VAR18:=(REF(VAR17,1) AND C>=REF(C,1) AND C<=REF(C,2));   持币:IF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,牛线,DRAWNULL),COLORLIGRAY,LINETHICK1;   STICKLINE(C>=O,C,O,3,0),COLOR000045;   STICKLINE(C>=O,C,O,2.5,0),COLOR000065;   STICKLINE(C>=O,C,O,2,0),COLOR000085;   STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5;   STICKLINE(C>=O,C,O,1,0),COLOR0000C5;   STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5;   STICKLINE(C>=O,H,L,0,0),COLOR0000F5;   STICKLINE(C<O,C,O,3,0),COLOR353500;   STICKLINE(C<O,C,O,2.5,0),COLOR454500;   STICKLINE(C<O,C,O,2,0),COLOR555500;   STICKLINE(C<O,C,O,1.5,0),COLOR656500;   STICKLINE(C<O,C,O,1,0),COLOR757500;   STICKLINE(C<O,C,O,0.5,0),COLOR858500;   STICKLINE(C<O,H,L,0,0),COLOR959500;   LW05:=MA(C,5);   LW10:=MA(C,10);   LW30:=MA(C,30);   五日乖离率:=(C-LW05)/LW05*100;   三拾日乖离率:=(C-LW30)/LW30*100;   JL05:=ATAN((LW05/REF(LW05,1)-1)*100)*180/3.1416;   JL10:=ATAN((LW10/REF(LW10,1)-1)*100)*180/3.1416;   JL30:=ATAN((LW30/REF(LW30,1)-1)*100)*180/3.1416;   速度5:=SMA(EMA((LW05-REF(LW05,1))/REF(LW05,1),3)*100,3,1);   加速度5:=EMA((速度5-REF(速度5,1)),3);   强势狙击:=FILTER(JL30>30 AND JL10>45 AND CROSS(JL05,60),10);   加仓:=FILTER(COUNT(CROSS(JL05,30),5)>=1 AND LW05>REF(LW05,1)  AND 三拾日乖离率>REF(三拾日乖离率,1) AND LW10>REF(LW10,1)AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1)  ,10) ;   清仓:=FILTER(COUNT(CROSS(30,JL05),5)>=1 AND (C>LW30 OR O>LW30) AND LW05<REF(LW05,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND LW10<REF(LW10,1),10);   MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND LW05>REF(LW05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<LW30;   JL:=CROSS(0,五日乖离率) AND 三拾日乖离率>REF(LW10,1) ;   减仓:=FILTER(JL,10);   买入:=FILTER(MR,10);   DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORFF99FF;   DRAWTEXT(加仓 ,LOW*0.98,'←加仓'),COLORRED;   DRAWTEXT(买入,LOW*0.98,'←买入'),COLORYELLOW;   DRAWTEXT(清仓,HIGH*1.02,'←清仓'),COLORGREEN;   DRAWTEXT(强势狙击,LOW*0.98,'←强势狙击'),COLORYELLOW;   DRAWICON(减仓,HIGH*1.02,18);   DRAWICON(加仓 ,LOW*0.98,23);   DRAWICON(买入,LOW*0.98,5);   DRAWICON(清仓 ,HIGH*1.02,6);   DRAWICON(强势狙击,LOW*0.98,15);

    浏览11663次浏览
    2022-10-31 10:55
  • 神奇指标

    同花顺 私募自用强势股--WAN哥均线主图

    同花顺 私募自用强势股--WAN哥均线主图炒股其实就是一个流程:不断地去弱留强,让利润最大化。而无强可买,则提前规避风险。今天想分享一个多年前一位私募大哥分享给我的强势股反弹做法,附上配套的均线系统和使用方法。强势股:16日开十分一仓,如果破,在32日线补十分一,弹到16日线出场,再破32线,在64日线补,弹到32日线出。前提:大盘在16日线上.个股特别是创新高后的回落,找上涨波幅度要大,量要放大。整根线跌到16日前不能中间有反弹,要单波直跌。"该强势股做法的要点在于选股和时机的把握,选股一定要根据上述条件筛选。其次一定是要按照具体的均线做对应的仓位调整。 这样做有优有劣,大家也可以根据自身性格进行改进,不过既然是私募大哥给我分享出来,必然是这个条件即最优解,所以不断选股操作并复利就行了。弄好了指标大家可以在软件上翻下前期的强势股,观察位置和力度。源码:U8:=SUM(VOL*CLOSE,8)/SUM(VOL,8);UU8:=IF(U8<=0,CLOSE,U8);MS8:UU8,colorblack;DRAWTEXT(ISLASTBAR,MS8,'8'),ALIGN0,SHIFT2,colorblack;U16:=SUM(VOL*CLOSE,16)/SUM(VOL,16);UU16:=IF(U16<=0,CLOSE,U16);MS16:UU16,coloryellow,LINETHICK1;DRAWTEXT(ISLASTBAR,MS16,'16'),ALIGN0,SHIFT2,coloryellow;U32:=SUM(VOL*CLOSE,32)/SUM(VOL,32);UU32:=IF(U32<=0,CLOSE,U32);MS32:UU32,colorred,LINETHICK1;DRAWTEXT(ISLASTBAR,MS32,'32'),ALIGN0,SHIFT2,colorred;U64:=SUM(VOL*CLOSE,64)/SUM(VOL,64);UU64:=IF(U64<=0,CLOSE,U64);MS64:UU64,COLORCC9900,LINETHICK2;DRAWTEXT(ISLASTBAR,MS64,'64'),ALIGN0,SHIFT2,COLORCC9900;U128:=SUM(VOL*CLOSE,128)/SUM(VOL,128);UU128:=IF(U128<=0,CLOSE,U128);MS128:UU128,COLOR6666CC,LINETHICK1;DRAWTEXT(ISLASTBAR,MS128,'128'),ALIGN0,SHIFT2,COLOR6666CC;U256:=SUM(VOL*CLOSE,256)/SUM(VOL,256);UU256:=IF(U256<=0,CLOSE,U256);MS256:UU256,LINETHICK1;DRAWTEXT(ISLASTBAR,MS256,'256'),ALIGN0,SHIFT2,colorwhite;U512:=SUM(VOL*CLOSE,512)/SUM(VOL,512);UU512:=IF(U512<=0,CLOSE,U512);MS512:UU512,LINETHICK1;DRAWTEXT(ISLASTBAR,MS512,'512'),ALIGN0,SHIFT2,colorblack;WS:=MOD(REF(C,1)*100,10)/100;FD:=REF(C,1)/10-IF(WS<0.05,WS,WS-0.10)/10;涨停:=C=REF(C,1)+FD;跌停:=C=REF(C,1)-FD;STICKLINE(涨停,L,C,2,1),colorred;STICKLINE(跌停,L,O,2,1),colorgreen;

    浏览19281次浏览
    2022-10-28 17:23
  • 神奇指标

    诈称是私募内部专用不便外泄的东西

    以下是诈称是私募内部专用不便外泄的东西DRAWKLINE(H,O,L,C); ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL); ZSP:=IF(C>REF(C,1),C,DRAWNULL); DKP:=IF(C<=REF(C,1),REF(C,1),DRAWNULL); DSP:=IF(C<=REF(C,1),C,DRAWNULL); DRAWKLINE(H,DKP,L,DSP); STICKLINE(C<=REF(C,1),DKP,DSP,3.05,0),COLORBLUE; STICKLINE(C<=REF(C,1),DKP,DSP,2.2,0),COLORFF7700; STICKLINE(C<=REF(C,1),DKP,DSP,1.5,0),COLORFF9900; STICKLINE(C<=REF(C,1),DKP,DSP,0.5,0),COLORFFBB00; DRAWKLINE(H,ZKP,L,ZSP); STICKLINE(C>REF(C,1),ZKP,ZSP,3.05,0),COLOR000099; STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC; STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF; STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF; STICKLINE(V/REF(V,1)>2 AND CLOSE>=OPEN,ZKP,ZSP,1,0),COLORYELLOW; VAR111:=ZIG(3,13); STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,3,0),COLOR66FF00; DRAWTEXT_FIX(STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,5,0),0.00,0.11,0,''),COLOR00FF00,LINETHICK1; MA5:MA(C,5)LINETHICK3,COLOR00CCFF; MA10:=MA(C,10); MA20:=MA(C,20); MA30:=MA(C,30); TY:=C; A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10); A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);前期高位:REF(C,BARSLAST(HD)),COLOR8000FF,POINTDOT; STICKLINE(C,前期高位,前期高位,8,0),COLOR8000FF; JRH:=HHV(C,2); JRL:=LLV(C,2); VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2)); VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARA:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2)); VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01); VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD); 红色持股:=VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;离场:=IF(红色持股,JRL,DRAWNULL); 明离场价:=离场,COLORFF99FF,NODRAW;青色观望:=VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW; 进:=IF(青色观望,JRH,DRAWNULL);今离场价:REF(离场,1),COLOR0000FF,NODRAW; 明进场价:=进,COLOR33AACC,NODRAW; 今进场价:REF(明进场价,1),COLORGREEN,NODRAW;上涨家数:INDEXADV,COLOR0080FF,NODRAW;下跌家数:INDEXDEC,COLORGREEN,NODRAW;五日乖离率:=(C-MA5)/MA5*100; BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1);加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW; IF(BB5>30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK3,COLORRED; BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416; IF(BB5<0 AND MA5<REF(MA5,1), MA5,DRAWNULL),LINETHICK3,COLORGREEN;三拾日乖离率:=(C-MA30)/MA30*100,NODRAW; VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1); VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1); BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB5,60),10);加仓:=FILTER(COUNT(CROSS(BB5,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1),10);清仓:=FILTER(COUNT(CROSS(30,BB5),5)>=1 AND (C>MA30 OR O>MA30) AND MA5<REF(MA5,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10); DRAWTEXT(加仓 ,LOW*0.96,'加'),COLORYELLOW; JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;减仓:=FILTER(JC,10); MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;买入:=FILTER(MR,10); DRAWTEXT(减仓,HIGH*1.01,'←风险'),COLORCYAN; DRAWTEXT(买入,LOW*0.99,'买'),COLORYELLOW; DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN; DRAWTEXT(强势狙击,LOW*0.98,'←狙击'),COLORWHITE; VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW)); VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100); MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;压力:MA(REF(HHV(C,30),1),2),COLORABFF46; 支撑:MA(REF(LLV(C,30),1),2),COLOR9DFFFF;总额:=AMOUNT;买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));买%:=买/AMOUNT*100;流入:=AMOUNT*买%/10000000000;流出:=AMOUNT/100000000-流入;净流:=(流入-流出);总额3:=SUM(AMOUNT,3);流入3:=SUM(流入,3);流出3:=SUM(流出,3);净流3:=SUM(流入-流出,3);总额5:=SUM(AMOUNT,5);流入5:=SUM(流入,5);流出5:=SUM(流出,5);净流5:=SUM(流入-流出,5);总额10:=SUM(AMOUNT,10);流入10:=SUM(流入,10);流出10:=SUM(流出,10);净流10:=SUM(流入-流出,10);画:=CONST(FINDHIGH(总额10,0,190,1)); DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR00FFFF; DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK)COLOR00FFFF; DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF; DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK)COLOR00FFFF; DRAWTEXT_FIX(1,0.30,0.00,0,'主题投资:')COLOR00FFFF; DRAWTEXT_FIX(1,0.36,0.00,0,EXTERNSTR(0,2))COLOR00FFFF; DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:')COLOR00FFFF; DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3))COLOR00FFFF; DRAWTEXT_FIX(1,0.00,0.10,0,'解禁日期:')COLOR00FFFF; DRAWTEXT_FIX(1,0.06,0.10,0,EXTERNSTR(0,4))COLOR00FFFF; DRAWTEXT_FIX(1,0.00,0.15,0,'莸利比例:'),COLORYELLOW; DRAWNUMBER_FIX(1,0.06,0.15,0,CONST(WINNER(C )*100)),COLOR0080FF; DRAWTEXT_FIX(1,0.12,0.15,0,'动态PE:'),COLORYELLOW; DRAWNUMBER_FIX(1,0.17,0.15,0,CONST(DYNAINFO(39))),COLOR0080FF; DRAWTEXT_FIX(1,0.22,0.15,0,'市值:'),COLORYELLOW; DRAWNUMBER_FIX(1,0.26,0.15,0,FINANCE(40)/100000000),COLOR0080FF; DRAWTEXT_FIX (1,0.31,0.15,0,'公积金(股):'),COLORYELLOW; DRAWNUMBER_FIX(1,0.38,0.15,0,FINANCE(18)),COLOR0080FF; DRAWTEXT_FIX (1,0.43,0.15,0,'收益:'),COLORYELLOW; DRAWNUMBER_FIX(1,0.47,0.15,0,FINANCE(33)),COLOR0080FF; DRAWTEXT_FIX(1,0.00,0.19,0,'净流入(亿):'),COLORYELLOW; DRAWTEXT_FIX(1,0.06,0.19,0,'1日'),COLORYELLOW; DRAWTEXT_FIX(1,0.12,0.19,0,'3日'),COLORYELLOW; DRAWTEXT_FIX(1,0.18,0.19,0,'5日'),COLORYELLOW; DRAWTEXT_FIX(1,0.24,0.19,0,'10日'),COLORYELLOW; DRAWNUMBER_FIX(1,0.08,0.19,0,CONST((净流))),COLOR0080FF; DRAWNUMBER_FIX(1,0.14,0.19,0,CONST((净流3))),COLOR0080FF; DRAWNUMBER_FIX(1,0.20,0.19,0,CONST((净流5))),COLOR0080FF; DRAWNUMBER_FIX(1,0.265,0.19,0,CONST((净流10))),COLOR0080FF; DRAWTEXT_FIX(1,0.00,0.23,0,'愚民导向:'),COLOR00FFFF; DRAWTEXT_FIX(1,0.06,0.23,0,EXTERNSTR(0,5)),COLOR00FFFF; DRAWRECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0)); 超B:=L2_AMO(0,2)/10000.0;大B:=L2_AMO(1,2)/10000.0;中B:=L2_AMO(2,2)/10000.0;小B:=L2_AMO(3,2)/10000.0;超S:=L2_AMO(0,3)/10000.0;大S:=L2_AMO(1,3)/10000.0;中S:=L2_AMO(2,3)/10000.0;小S:=L2_AMO(3,3)/10000.0; TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);大宗进:=(超B)+(大B),NODRAW;大宗出:=(超S)+(大S),NODRAW;非大宗进:=(中B)+(小B),NODRAW;非大宗出:=(中S)+(小S),NODRAW;大宗进限制:=IF((超B+大B)=0,0,大宗进);大宗出限制:=IF((超S+大S)=0,0,大宗出);非大宗进限制:=IF(中B+小B=0,0,非大宗进);非大宗出限制:=IF(中S+小S=0,0,非大宗出);主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;大单强度限制:=IF(大单强度=0,-100,大单强度);大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;超单强度限制:=IF(超单强度=0,-100,超单强度);超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW; DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW; DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255))); DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0))); DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255))); DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0))); DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50))); DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW; DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW; DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW; DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW; DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW; DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA; DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN; DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,0.99,0,'净流入:(万)'),COLORYELLOW;主力买力度:=LARGEINTRDVOL*1000/VOL;主力卖力度:=LARGEOUTTRDVOL*1000/VOL; AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW; DRAWRECTREL(0,515,CONST(ABS(主力买力度)*560/AAD),568,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0))); DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*560/AAD),623,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0))); DRAWTEXT_FIX(1,0,0.524,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW; DRAWTEXT_FIX(1,0,0.576,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW; {DDE显示}DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*1000/FINANCE(7); DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0); DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0); DRAWRECTREL(150,500,192,540,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0))); DRAWRECTREL(150,545,192,585,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0))); DRAWRECTREL(150,590,192,630,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0))); DRAWTEXT_FIX(1,0.153,0.500,0,STRCAT('DDX:',CON2STR(DDX,1))),COLORYELLOW,COLORWHITE; DRAWTEXT_FIX(1,0.153,0.548,0,STRCAT('DDY:',CON2STR(DDY,1))),COLORYELLOW,COLORWHITE; DRAWTEXT_FIX(1,0.153,0.596,0,STRCAT('DDZ:',CON2STR(DDZ,1))),COLORYELLOW,COLORWHITE; T1:=IF (DDX>0 AND REF(DDX,1)<0,1,0); T2:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)<0,2,T1); T3:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)<0,3,T2); T4:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)<0,4,T3); T5:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)<0,5,T4); T6:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)<0,6,T5); T7:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)<0,7,T6); T8:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)<0,8,T7); T9:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)<0,9,T8); T:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)>0,10,T9); DRAWTEXT_FIX(1,0.190,0.500,0,STRCAT(STRCAT(' ',CON2STR(T,0)),' [天] ')),COLORYELLOW; T11:=IF (DDY>0 AND REF(DDY,1)<0,1,0); T21:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)<0,2,T11); T31:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)<0,3,T21); T41:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)<0,4,T31); T51:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)<0,5,T41); T61:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)<0,6,T51); T71:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)<0,7,T61); T81:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)<0,8,T71); T91:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)<0,9,T81); TY01:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)>0,10,T91); DRAWTEXT_FIX(1,0.190,0.548,0,STRCAT(STRCAT(' ',CON2STR(TY01,0)),' [天] ')),COLORYELLOW; T1Z:=IF (DDZ>0 AND REF(DDZ,2)<0,1,0); T2Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)<0,2,T1Z); T3Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)<0,3,T2Z); T4Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)<0,4,T3Z); T5Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)<0,5,T4Z); T6Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)<0,6,T5Z); T7Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)<0,7,T6Z); T8Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)<0,8,T7Z); T9Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)<0,9,T8Z); TZ:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)>0,10,T9Z); DRAWTEXT_FIX(1,0.190,0.596,0,STRCAT(STRCAT(' ',CON2STR(TZ,0)),' [天] ')),COLORYELLOW;

    浏览5057次浏览
    2022-10-27 11:26
  • 神奇指标

    通达信私募内部专用主图公式

    以下是通达信私募内部专用主图公式通达信私募内部专用主图公式东西是很好,忽悠受不了。今日分享源码源码:DRAWKLINE(H,O,L,C); ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL); ZSP:=IF(C>REF(C,1),C,DRAWNULL); DKP:=IF(C<=REF(C,1),REF(C,1),DRAWNULL); DSP:=IF(C<=REF(C,1),C,DRAWNULL); DRAWKLINE(H,DKP,L,DSP); STICKLINE(C<=REF(C,1),DKP,DSP,3.05,0),COLORBLUE; STICKLINE(C<=REF(C,1),DKP,DSP,2.2,0),COLORFF7700; STICKLINE(C<=REF(C,1),DKP,DSP,1.5,0),COLORFF9900; STICKLINE(C<=REF(C,1),DKP,DSP,0.5,0),COLORFFBB00; DRAWKLINE(H,ZKP,L,ZSP); STICKLINE(C>REF(C,1),ZKP,ZSP,3.05,0),COLOR000099; STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC; STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF; STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF; STICKLINE(V/REF(V,1)>2 AND CLOSE>=OPEN,ZKP,ZSP,1,0),COLORYELLOW; VAR111:=ZIG(3,13); STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,3,0),COLOR66FF00; DRAWTEXT_FIX(STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,5,0),0.00,0.11,0,''),COLOR00FF00,LINETHICK1; MA5:MA(C,5)LINETHICK3,COLOR00CCFF; MA10:=MA(C,10); MA20:=MA(C,20); MA30:=MA(C,30); TY:=C; A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10); A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10);前期高位:REF(C,BARSLAST(HD)),COLOR8000FF,POINTDOT; STICKLINE(C,前期高位,前期高位,8,0),COLOR8000FF; JRH:=HHV(C,2);     JRL:=LLV(C,2);     VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));     VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     VARA:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2)); VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));     VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));     VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01);     VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD);     红色持股:=VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;离场:=IF(红色持股,JRL,DRAWNULL);     明离场价:=离场,COLORFF99FF,NODRAW;青色观望:=VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW;     进:=IF(青色观望,JRH,DRAWNULL);今离场价:REF(离场,1),COLOR0000FF,NODRAW;     明进场价:=进,COLOR33AACC,NODRAW;     今进场价:REF(明进场价,1),COLORGREEN,NODRAW;上涨家数:INDEXADV,COLOR0080FF,NODRAW;下跌家数:INDEXDEC,COLORGREEN,NODRAW;五日乖离率:=(C-MA5)/MA5*100; BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1);加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW; IF(BB5>30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK3,COLORRED; BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416; IF(BB5<0 AND MA5<REF(MA5,1), MA5,DRAWNULL),LINETHICK3,COLORGREEN;三拾日乖离率:=(C-MA30)/MA30*100,NODRAW; VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1); VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1); BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB5,60),10);加仓:=FILTER(COUNT(CROSS(BB5,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1),10);清仓:=FILTER(COUNT(CROSS(30,BB5),5)>=1 AND (C>MA30 OR O>MA30) AND MA5<REF(MA5,1)  AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10); DRAWTEXT(加仓 ,LOW*0.96,'加'),COLORYELLOW; JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;减仓:=FILTER(JC,10); MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;买入:=FILTER(MR,10); DRAWTEXT(减仓,HIGH*1.01,'←风险'),COLORCYAN; DRAWTEXT(买入,LOW*0.99,'买'),COLORYELLOW; DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN; DRAWTEXT(强势狙击,LOW*0.98,'←狙击'),COLORWHITE; VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW)); VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100); MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;压力:MA(REF(HHV(C,30),1),2),COLORABFF46; 支撑:MA(REF(LLV(C,30),1),2),COLOR9DFFFF;总额:=AMOUNT;买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));买%:=买/AMOUNT*100;流入:=AMOUNT*买%/10000000000;流出:=AMOUNT/100000000-流入;净流:=(流入-流出);总额3:=SUM(AMOUNT,3);流入3:=SUM(流入,3);流出3:=SUM(流出,3);净流3:=SUM(流入-流出,3);总额5:=SUM(AMOUNT,5);流入5:=SUM(流入,5);流出5:=SUM(流出,5);净流5:=SUM(流入-流出,5);总额10:=SUM(AMOUNT,10);流入10:=SUM(流入,10);流出10:=SUM(流出,10);净流10:=SUM(流入-流出,10);画:=CONST(FINDHIGH(总额10,0,190,1)); DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR00FFFF; DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK)COLOR00FFFF; DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF; DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK)COLOR00FFFF; DRAWTEXT_FIX(1,0.30,0.00,0,'主题投资:')COLOR00FFFF; DRAWTEXT_FIX(1,0.36,0.00,0,EXTERNSTR(0,2))COLOR00FFFF; DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:')COLOR00FFFF; DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3))COLOR00FFFF; DRAWTEXT_FIX(1,0.00,0.10,0,'解禁日期:')COLOR00FFFF; DRAWTEXT_FIX(1,0.06,0.10,0,EXTERNSTR(0,4))COLOR00FFFF; DRAWTEXT_FIX(1,0.00,0.15,0,'莸利比例:'),COLORYELLOW; DRAWNUMBER_FIX(1,0.06,0.15,0,CONST(WINNER(C )*100)),COLOR0080FF; DRAWTEXT_FIX(1,0.12,0.15,0,'动态PE:'),COLORYELLOW; DRAWNUMBER_FIX(1,0.17,0.15,0,CONST(DYNAINFO(39))),COLOR0080FF; DRAWTEXT_FIX(1,0.22,0.15,0,'市值:'),COLORYELLOW; DRAWNUMBER_FIX(1,0.26,0.15,0,FINANCE(40)/100000000),COLOR0080FF; DRAWTEXT_FIX  (1,0.31,0.15,0,'公积金(股):'),COLORYELLOW; DRAWNUMBER_FIX(1,0.38,0.15,0,FINANCE(18)),COLOR0080FF; DRAWTEXT_FIX  (1,0.43,0.15,0,'收益:'),COLORYELLOW; DRAWNUMBER_FIX(1,0.47,0.15,0,FINANCE(33)),COLOR0080FF; DRAWTEXT_FIX(1,0.00,0.19,0,'净流入(亿):'),COLORYELLOW; DRAWTEXT_FIX(1,0.06,0.19,0,'1日'),COLORYELLOW; DRAWTEXT_FIX(1,0.12,0.19,0,'3日'),COLORYELLOW; DRAWTEXT_FIX(1,0.18,0.19,0,'5日'),COLORYELLOW; DRAWTEXT_FIX(1,0.24,0.19,0,'10日'),COLORYELLOW; DRAWNUMBER_FIX(1,0.08,0.19,0,CONST((净流))),COLOR0080FF; DRAWNUMBER_FIX(1,0.14,0.19,0,CONST((净流3))),COLOR0080FF; DRAWNUMBER_FIX(1,0.20,0.19,0,CONST((净流5))),COLOR0080FF; DRAWNUMBER_FIX(1,0.265,0.19,0,CONST((净流10))),COLOR0080FF; DRAWTEXT_FIX(1,0.00,0.23,0,'愚民导向:'),COLOR00FFFF; DRAWTEXT_FIX(1,0.06,0.23,0,EXTERNSTR(0,5)),COLOR00FFFF; DRAWRECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0)); 超B:=L2_AMO(0,2)/10000.0;大B:=L2_AMO(1,2)/10000.0;中B:=L2_AMO(2,2)/10000.0;小B:=L2_AMO(3,2)/10000.0;超S:=L2_AMO(0,3)/10000.0;大S:=L2_AMO(1,3)/10000.0;中S:=L2_AMO(2,3)/10000.0;小S:=L2_AMO(3,3)/10000.0; TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);大宗进:=(超B)+(大B),NODRAW;大宗出:=(超S)+(大S),NODRAW;非大宗进:=(中B)+(小B),NODRAW;非大宗出:=(中S)+(小S),NODRAW;大宗进限制:=IF((超B+大B)=0,0,大宗进);大宗出限制:=IF((超S+大S)=0,0,大宗出);非大宗进限制:=IF(中B+小B=0,0,非大宗进);非大宗出限制:=IF(中S+小S=0,0,非大宗出);主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;大单强度限制:=IF(大单强度=0,-100,大单强度);大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;超单强度限制:=IF(超单强度=0,-100,超单强度);超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW; DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW; DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255))); DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0))); DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255))); DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0))); DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50))); DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW; DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW; DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW; DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW; DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW; DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA; DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN; DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,0.99,0,'净流入:(万)'),COLORYELLOW;主力买力度:=LARGEINTRDVOL*1000/VOL;主力卖力度:=LARGEOUTTRDVOL*1000/VOL; AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW; DRAWRECTREL(0,515,CONST(ABS(主力买力度)*560/AAD),568,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0))); DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*560/AAD),623,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0))); DRAWTEXT_FIX(1,0,0.524,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW; DRAWTEXT_FIX(1,0,0.576,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW; {DDE显示}DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*1000/FINANCE(7); DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0); DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0); DRAWRECTREL(150,500,192,540,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0))); DRAWRECTREL(150,545,192,585,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0))); DRAWRECTREL(150,590,192,630,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0))); DRAWTEXT_FIX(1,0.153,0.500,0,STRCAT('DDX:',CON2STR(DDX,1))),COLORYELLOW,COLORWHITE; DRAWTEXT_FIX(1,0.153,0.548,0,STRCAT('DDY:',CON2STR(DDY,1))),COLORYELLOW,COLORWHITE; DRAWTEXT_FIX(1,0.153,0.596,0,STRCAT('DDZ:',CON2STR(DDZ,1))),COLORYELLOW,COLORWHITE; T1:=IF (DDX>0 AND REF(DDX,1)<0,1,0); T2:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)<0,2,T1); T3:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)<0,3,T2); T4:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)<0,4,T3); T5:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)<0,5,T4); T6:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)<0,6,T5); T7:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)<0,7,T6); T8:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)<0,8,T7); T9:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)<0,9,T8); T:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)>0,10,T9); DRAWTEXT_FIX(1,0.190,0.500,0,STRCAT(STRCAT(' ',CON2STR(T,0)),' [天] ')),COLORYELLOW; T11:=IF (DDY>0 AND REF(DDY,1)<0,1,0); T21:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)<0,2,T11); T31:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)<0,3,T21); T41:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)<0,4,T31); T51:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)<0,5,T41); T61:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)<0,6,T51); T71:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)<0,7,T61); T81:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)<0,8,T71); T91:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)<0,9,T81); TY01:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)>0,10,T91); DRAWTEXT_FIX(1,0.190,0.548,0,STRCAT(STRCAT(' ',CON2STR(TY01,0)),' [天] ')),COLORYELLOW; T1Z:=IF (DDZ>0 AND REF(DDZ,2)<0,1,0); T2Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)<0,2,T1Z); T3Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)<0,3,T2Z); T4Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)<0,4,T3Z); T5Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)<0,5,T4Z); T6Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)<0,6,T5Z); T7Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)<0,7,T6Z); T8Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)<0,8,T7Z); T9Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)<0,9,T8Z); TZ:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)>0,10,T9Z); DRAWTEXT_FIX(1,0.190,0.596,0,STRCAT(STRCAT(' ',CON2STR(TZ,0)),' [天] ')),COLORYELLOW;

    浏览10612次浏览
    2022-10-25 13:42
  • 神奇指标

    揭密主力资金和私募进场

    以下是揭密主力资金和私募进场大智慧主力进场加仓公式:C/C++ 股票公式指标网提供 Code复制内容到剪贴板A:=(VOL * CLOSE); B:=(SUM(A,1) / SUM(VOL,1)); B1:=EMA(B,17); 趋势线:(B - B1) * 100 / B,COLORFF00FF; 强弱分界线:0,COLORFFFFCC; AA:=(WINNER((CLOSE + ((CLOSE * 15) / 100))) * 100); BB:=(WINNER((CLOSE + ((CLOSE * 0) / 100))) * 100); CC:=(AA - BB); DD:=((WINNER((CLOSE - ((CLOSE * 0.1) / 100))) - WINNER((CLOSE - ((CLOSE * 15) / 100)))) * 100); EE:=(((CC < 3) AND (DD < 0.5)) AND (OPEN <> LOW)); A1:=DYNAINFO(6); A2:=IF((LOW > A1),0,IF((HIGH < A1),1,(((A1 - LOW) + 0.01) / ((HIGH - LOW) + 0.01)))); A3:=(VOL / WINNER(LOW)); A4:=REF(HHV(CLOSE,120),1); A5:=REF(LLV(CLOSE,120),1); A6:=((100 * (CLOSE - A5)) / (A4 - A5)); A7:=((A2 > 0) OR (A2 = 1)); A8:=((A7 AND ((A3 / REF(A3,3)) >= 3)) AND (A6 < 80)); A9:=(((REF(A8,1) OR REF(A8,2)) OR REF(A8,3)) OR REF(A8,4)); A10:=(A8 AND A9); A11:=IF(FILTER(A8,3),5,0); A12:=IF((FILTER(A10,3) OR EE),10,0); 进场:STICKLINE(A11,0,5,5,0),COLORFF7700; 加仓:STICKLINE(A12,0,15,5,0),COLORFF00FF; STICKLINE(A11,0,5,5,0),COLORFF7700; STICKLINE(A11,0,5,4.5,0),COLORFF8800; STICKLINE(A11,0,5,4,0),COLORFF9900; STICKLINE(A11,0,5,3.5,0),COLORFFAA00; STICKLINE(A11,0,5,3,0),COLORFFBB00; STICKLINE(A11,0,5,2.5,0),COLORFFCC00; STICKLINE(A11,0,5,2,0),COLORFFDD00; STICKLINE(A11,0,5,1,0),COLORFFEE00; STICKLINE(A12,0,15,4.5,0),COLOR102099; STICKLINE(A12,0,15,4,0),COLOR1020AA; STICKLINE(A12,0,15,3.5,0),COLOR1020BB; STICKLINE(A12,0,15,3,0),COLOR1020CC; STICKLINE(A12,0,15,2.5,0),COLOR1020DD; STICKLINE(A12,0,15,2,0),COLOR1020EE; STICKLINE(A12,0,15,1,0),COLOR1020FF; DRAWTEXT(A11,8,'进场'),COLORFFFF00; DRAWTEXT(A12,17,'加仓'),COLORFFFFFF; 大智慧私募资金进场公式: C/C++ 股票公式指标网提供 Code复制内容到剪贴板A01:=DYNAINFO( 7.000); A02:=MA(AMOUNT / VOL / 100.000,VOL / CAPITAL); A03:=BARSCOUNT(CLOSE); A04:=SMA(CLOSE / HHV(HIGH, 120.000), 3.000, 1.000) * 100.000; A05:=IF((A03 > 20.000),A04,0); A06:=IF(((LOW > A01)),0,IF(((HIGH < A01)), 1.000,((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))); A07:=DMA(A06,VOL / CAPITAL) * 100.000; A08:=IF((A02 > A01),( 100.000 - A07),A07); A09:=IF(((((A07 > 0) and (A07 > REF(A07, 1.000)))) and (A05 <= 88.000)),A07,0); stickline((A09 > 0),0,A09,7,0),CulorFF00FF; 私募机构建仓区:IF(((CROSS(A09,0) and (OPEN <> LOW)) and (CLOSE <> LOW)), 88.000,0),CulorFF00FF, LINETHICK0; 私募机构黄金线:A09,COLORYELLOW,LINETHICK2; DRAWTEXT(CROSS(A09, 0.009),4,'-----注意'),Culor00FF00; DRAWICON(CROSS(A09, 0.009), 4.000, 1.000);

    浏览7713次浏览
    2022-10-21 13:15
  • 神奇指标

    通达信[私募三宝]彻底解决看盘烦恼,量价异动源码附图

    以下是通达信[私募三宝]彻底解决看盘烦恼,量价异动源码附图[私募三宝]彻底解决看盘烦恼,量价异动【通达信】DD:=(BB / CC); 价异动排序:IF(AA,(DD / REF(DD,1)),0),STICK,COLOR0000FF; EE:=(CC / BB); 量异动排序:IF(AA,(EE / REF(EE,1)),0),STICK,COLORFFFF00; AAA:=((XMA(CLOSE,5) - REF(XMA(CLOSE,5),1)) / REF(XMA(CLOSE,5),1)); BBB:=((XMA(INDEXC,5) - REF(XMA(INDEXC,5),1)) / REF(XMA(INDEXC,5),1)); CCC:=REF(HHV(CLOSE,120),1); DDD:=REF(LLV(CLOSE,120),1); WW:=((100 * (CLOSE - DDD)) / (CCC - DDD)); 今日资金流:(AMOUNT/100000000); 五日资金流:(EMA(今日资金流,5)/REF(EMA(今日资金流,5),5)); 庄股:=((((((五日资金流 >= 2) AND (AAA > BBB)) AND (WW < 35)) AND AA) AND (BARSCOUNT(CLOSE) > 30)) OR (((((五日资金流 >= 2) AND (AAA > BBB)) AND (WW < 100)) AND AA) AND (BARSCOUNT(CLOSE) < 50))); 庄家显形:IF(庄股,888,0),LINETHICK1,COLORFF00FF; A01:=DYNAINFO(7); A02:=MA(AMOUNT / VOL / 100.000,VOL / CAPITAL); A03:=BARSCOUNT(CLOSE); A04:=SMA(CLOSE / HHV(HIGH, 120.000), 3.000, 1.000) * 100.000; A05:=IF((A03 > 20.000),A04,0); A06:=IF(((LOW > A01)),0,IF(((HIGH < A01)), 1.000,((A01 - LOW) + 0.009) / ((HIGH - LOW) + 0.009))); A07:=DMA(A06,VOL / CAPITAL) * 100.000; A08:=IF((A02 > A01),( 100.000 - A07),A07); A09:IF(((((A07 > 0) AND (A07 > REF(A07, 1.000)))) AND (A05 <= 88.000)),A07,0),COLORYELLOW,LINETHICK1; STICKLINE(A09 > 0,0,A09,0,0),COLORMAGENTA;

    浏览3329次浏览
    2022-10-21 10:20
  • 神奇指标

    自编公式 (发现私募拉升的票 源码)

    以下是自编公式 (发现私募拉升的票 源码) 提供 Code复制内容到剪贴板AA:=VOL<HHV(VOL,7)/3; BB:="BBE排序.N日BBX飘红">5; CC:="BBX.BBX">0; XG:AA AND BB AND CC ; drawtextrel( 0,25,'近期明显放量 放量后回调'),COLOR00FFFF;

    浏览650次浏览
    2022-10-20 14:48
  • 神奇指标

    通达信私募不传主图指标 源码 贴图

    以下是通达信私募不传主图指标 源码 贴图 私募不传主图指标DRAWKLINE(H,O,L,C);ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL);ZSP:=IF(C>REF(C,1),C,DRAWNULL);DKP:=IF(C<=REF(C,1),REF(C,1),DRAWNULL);DSP:=IF(C<=REF(C,1),C,DRAWNULL);DRAWKLINE(H,DKP,L,DSP);STICKLINE(C<=REF(C,1),DKP,DSP,3.05,0),COLORBLUE;STICKLINE(C<=REF(C,1),DKP,DSP,2.2,0),COLORFF7700;STICKLINE(C<=REF(C,1),DKP,DSP,1.5,0),COLORFF9900;STICKLINE(C<=REF(C,1),DKP,DSP,0.5,0),COLORFFBB00;DRAWKLINE(H,ZKP,L,ZSP);STICKLINE(C>REF(C,1),ZKP,ZSP,3.05,0),COLOR000099;STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC;STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF;STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF;STICKLINE(V/REF(V,1)>2 AND CLOSE>=OPEN,ZKP,ZSP,1,0),COLORYELLOW;VAR111:=ZIG(3,13);STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,3,0),COLOR66FF00;DRAWTEXT_FIX(STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,5,0),0.00,0.11,0,''),COLOR00FF00,LINETHICK1;MA5:MA(C,5)LINETHICK3,COLOR00CCFF;MA10:=MA(C,10);MA20:=MA(C,20);MA30:=MA(C,30);TY:=C;A1:=REF(TY,10)=HHV(TY,2*10+1);B1:=FILTER(A1,10);C1:=BACKSET(B1,10+1);HD:=FILTER(C1,10);A2:=REF(TY,10)=LLV(TY,2*10+1);B2:=FILTER(A2,10);C2:=BACKSET(B2,10+1);LD:=FILTER(C2,10);前期高位:REF(C,BARSLAST(HD)),COLOR8000FF,POINTDOT;STICKLINE(C,前期高位,前期高位,8,0),COLOR8000FF;JRH:=HHV(C,2);JRL:=LLV(C,2);VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));VARA:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01);VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD);红色持股:=VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;离场:=IF(红色持股,JRL,DRAWNULL);明离场价:=离场,COLORFF99FF,NODRAW;青色观望:=VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW;进:=IF(青色观望,JRH,DRAWNULL);今离场价:REF(离场,1),COLOR0000FF,NODRAW;明进场价:=进,COLOR33AACC,NODRAW;今进场价:REF(明进场价,1),COLORGREEN,NODRAW;上涨家数:INDEXADV,COLOR0080FF,NODRAW;下跌家数:INDEXDEC,COLORGREEN,NODRAW;五日乖离率:=(C-MA5)/MA5*100;BB5:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1);加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW;IF(BB5>30 AND MA5>REF(MA5,1), MA5,DRAWNULL),LINETHICK3,COLORRED;BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416;IF(BB5<0 AND MA5<REF(MA5,1), MA5,DRAWNULL),LINETHICK3,COLORGREEN;三拾日乖离率:=(C-MA30)/MA30*100,NODRAW;VAR1:=(MA20-MA30)>REF((MA20-MA30),1) AND MA20>REF(MA20,1) AND MA30>REF(MA30,1);VAR2:=(MA30-MA20)<REF((MA30-MA20),1) AND MA20<REF(MA20,1) AND MA30<REF(MA30,1);BB30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;强势狙击:=FILTER(BB30>30 AND BB10>45 AND CROSS(BB5,60),10);加仓:=FILTER(COUNT(CROSS(BB5,30),5)>=1 AND MA5>REF(MA5,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA10>REF(MA10,1)AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1),10);清仓:=FILTER(COUNT(CROSS(30,BB5),5)>=1 AND (C>MA30 OR O>MA30) AND MA5<REF(MA5,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10<REF(MA10,1),10);DRAWTEXT(加仓 ,LOW*0.96,'加'),COLORYELLOW;JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND MA10>REF(MA10,1) ;减仓:=FILTER(JC,10);MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND MA5>REF(MA5,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<MA30;买入:=FILTER(MR,10);DRAWTEXT(减仓,HIGH*1.01,'←风险'),COLORCYAN;DRAWTEXT(买入,LOW*0.99,'买'),COLORYELLOW;DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;DRAWTEXT(强势狙击,LOW*0.98,'←狙击'),COLORWHITE;VAR21:=MAX(ABS(HIGH-AMOUNT/VOL/100),ABS(AMOUNT/VOL/100-LOW));VAR3:=ABS((OPEN+CLOSE)/2-AMOUNT/VOL/100);MV:=(VAR21+VAR3)/AMOUNT*VOL*100*50;压力:MA(REF(HHV(C,30),1),2),COLORABFF46;支撑:MA(REF(LLV(C,30),1),2),COLOR9DFFFF;总额:=AMOUNT;买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));买%:=买/AMOUNT*100;流入:=AMOUNT*买%/10000000000;流出:=AMOUNT/100000000-流入;净流:=(流入-流出);总额3:=SUM(AMOUNT,3);流入3:=SUM(流入,3);流出3:=SUM(流出,3);净流3:=SUM(流入-流出,3);总额5:=SUM(AMOUNT,5);流入5:=SUM(流入,5);流出5:=SUM(流出,5);净流5:=SUM(流入-流出,5);总额10:=SUM(AMOUNT,10);流入10:=SUM(流入,10);流出10:=SUM(流出,10);净流10:=SUM(流入-流出,10);画:=CONST(FINDHIGH(总额10,0,190,1));DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK)COLOR00FFFF;DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK)COLOR00FFFF;DRAWTEXT_FIX(1,0.30,0.00,0,'主题投资:')COLOR00FFFF;DRAWTEXT_FIX(1,0.36,0.00,0,EXTERNSTR(0,2))COLOR00FFFF;DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:')COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3))COLOR00FFFF;DRAWTEXT_FIX(1,0.00,0.10,0,'解禁日期:')COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0.10,0,EXTERNSTR(0,4))COLOR00FFFF;DRAWTEXT_FIX(1,0.00,0.15,0,'莸利比例:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.06,0.15,0,CONST(WINNER(C )*100)),COLOR0080FF;DRAWTEXT_FIX(1,0.12,0.15,0,'动态PE:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.17,0.15,0,CONST(DYNAINFO(39))),COLOR0080FF;DRAWTEXT_FIX(1,0.22,0.15,0,'市值:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.26,0.15,0,FINANCE(40)/100000000),COLOR0080FF;DRAWTEXT_FIX (1,0.31,0.15,0,'公积金(股):'),COLORYELLOW;DRAWNUMBER_FIX(1,0.38,0.15,0,FINANCE(18)),COLOR0080FF;DRAWTEXT_FIX (1,0.43,0.15,0,'收益:'),COLORYELLOW;DRAWNUMBER_FIX(1,0.47,0.15,0,FINANCE(33)),COLOR0080FF;DRAWTEXT_FIX(1,0.00,0.19,0,'净流入(亿):'),COLORYELLOW;DRAWTEXT_FIX(1,0.06,0.19,0,'1日'),COLORYELLOW;DRAWTEXT_FIX(1,0.12,0.19,0,'3日'),COLORYELLOW;DRAWTEXT_FIX(1,0.18,0.19,0,'5日'),COLORYELLOW;DRAWTEXT_FIX(1,0.24,0.19,0,'10日'),COLORYELLOW;DRAWNUMBER_FIX(1,0.08,0.19,0,CONST((净流))),COLOR0080FF;DRAWNUMBER_FIX(1,0.14,0.19,0,CONST((净流3))),COLOR0080FF;DRAWNUMBER_FIX(1,0.20,0.19,0,CONST((净流5))),COLOR0080FF;DRAWNUMBER_FIX(1,0.265,0.19,0,CONST((净流10))),COLOR0080FF;DRAWTEXT_FIX(1,0.00,0.23,0,'愚民导向:'),COLOR00FFFF;DRAWTEXT_FIX(1,0.06,0.23,0,EXTERNSTR(0,5)),COLOR00FFFF;DRAWRECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0));超B:=L2_AMO(0,2)/10000.0;大B:=L2_AMO(1,2)/10000.0;中B:=L2_AMO(2,2)/10000.0;小B:=L2_AMO(3,2)/10000.0;超S:=L2_AMO(0,3)/10000.0;大S:=L2_AMO(1,3)/10000.0;中S:=L2_AMO(2,3)/10000.0;小S:=L2_AMO(3,3)/10000.0;TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);大宗进:=(超B)+(大B),NODRAW;大宗出:=(超S)+(大S),NODRAW;非大宗进:=(中B)+(小B),NODRAW;非大宗出:=(中S)+(小S),NODRAW;大宗进限制:=IF((超B+大B)=0,0,大宗进);大宗出限制:=IF((超S+大S)=0,0,大宗出);非大宗进限制:=IF(中B+小B=0,0,非大宗进);非大宗出限制:=IF(中S+小S=0,0,非大宗出);主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;大单强度限制:=IF(大单强度=0,-100,大单强度);大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;超单强度限制:=IF(超单强度=0,-100,超单强度);超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW;DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50)));DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW;DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,0.99,0,'净流入:(万)'),COLORYELLOW;主力买力度:=LARGEINTRDVOL*1000/VOL;主力卖力度:=LARGEOUTTRDVOL*1000/VOL;AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;DRAWRECTREL(0,515,CONST(ABS(主力买力度)*560/AAD),568,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*560/AAD),623,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0)));DRAWTEXT_FIX(1,0,0.524,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW;DRAWTEXT_FIX(1,0,0.576,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW;{DDE显示}DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*1000/FINANCE(7);DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);DRAWRECTREL(150,500,192,540,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(150,545,192,585,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(150,590,192,630,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));DRAWTEXT_FIX(1,0.153,0.500,0,STRCAT('DDX:',CON2STR(DDX,1))),COLORYELLOW,COLORWHITE;DRAWTEXT_FIX(1,0.153,0.548,0,STRCAT('DDY:',CON2STR(DDY,1))),COLORYELLOW,COLORWHITE;DRAWTEXT_FIX(1,0.153,0.596,0,STRCAT('DDZ:',CON2STR(DDZ,1))),COLORYELLOW,COLORWHITE;T1:=IF (DDX>0 AND REF(DDX,1)<0,1,0);T2:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)<0,2,T1);T3:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)<0,3,T2);T4:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)<0,4,T3);T5:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)<0,5,T4);T6:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)<0,6,T5);T7:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)<0,7,T6);T8:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)<0,8,T7);T9:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)<0,9,T8);T:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)>0,10,T9);DRAWTEXT_FIX(1,0.190,0.500,0,STRCAT(STRCAT(' ',CON2STR(T,0)),' [天] ')),COLORYELLOW;T11:=IF (DDY>0 AND REF(DDY,1)<0,1,0);T21:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)<0,2,T11);T31:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)<0,3,T21);T41:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)<0,4,T31);T51:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)<0,5,T41);T61:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)<0,6,T51);T71:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)<0,7,T61);T81:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)<0,8,T71);T91:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)<0,9,T81);TY01:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)>0,10,T91);DRAWTEXT_FIX(1,0.190,0.548,0,STRCAT(STRCAT(' ',CON2STR(TY01,0)),' [天] ')),COLORYELLOW;T1Z:=IF (DDZ>0 AND REF(DDZ,2)<0,1,0);T2Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)<0,2,T1Z);T3Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)<0,3,T2Z);T4Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)<0,4,T3Z);T5Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)<0,5,T4Z);T6Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)<0,6,T5Z);T7Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)<0,7,T6Z);T8Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)<0,8,T7Z);T9Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)<0,9,T8Z);TZ:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)>0,10,T9Z);DRAWTEXT_FIX(1,0.190,0.596,0,STRCAT(STRCAT(' ',CON2STR(TZ,0)),' [天] ')),COLORYELLOW;

    浏览7644次浏览
    2022-10-19 17:13
  • 神奇指标

    通达信私募机构资金指标 副图 无未来 据说网上卖1800元

    以下是通达信私募机构资金指标 副图 无未来 据说网上卖1800元私募机构资金指标 副图 无未来 据说网上卖1800元具体不多说了。资金指标与私募指标同时变红,为主力资金介入。反之亦然。 本指标并非原创,我只不过是加以修改了一下参数。有没有参考价值,见仁见智。指标仅供参考学习,不构成买卖依据。

    浏览545次浏览
    2022-10-19 10:11
  • 神奇指标

    通达信大私募主图公式 附选股幅图 赢利就是这样的简单

    以下是通达信大私募主图公式 附选股幅图 赢利就是这样的简单大私募主图公式 附选股幅图 赢利就是这样的简单无未来指标码源:MA10:MA(CLOSE,10),LINETHICK1,COLORYELLOW;MA20:MA(CLOSE,20),LINETHICK1,COLORMAGENTA;MA60:MA(CLOSE,60),LINETHICK1,COLORGREEN;MA120:MA(CLOSE,120),LINETHICK1,COLORGRAY;MA250:MA(CLOSE,250),LINETHICK1,COLORBLUE;买线:=EMA(C,4); 卖线:=EMA(SLOPE(C,20)*10+C,35); DRAWTEXT(CROSS(买线,卖线),LOW*0.98,'买'),COLORRED,LINETHICK2;DRAWTEXT(CROSS(卖线,买线),HIGH*1.02,'卖'),COLORGREEN;STICKLINE(买线>=卖线,LOW,HIGH,0,0),COLORLIRED; STICKLINE(买线>=卖线,CLOSE,OPEN,3,2),COLORLIRED; STICKLINE(买线<卖线,LOW,HIGH,0,0),COLORCYAN; STICKLINE(买线<卖线,CLOSE,OPEN,3,2),COLORCYAN; STICKLINE(OPEN>CLOSE,CLOSE,OPEN,2.5,0),COLORCYAN;

    浏览7696次浏览
    2022-10-19 09:21
  • 神奇指标

    通达信监控庄家和私募的利器(源码) 无未来函数!

    以下是通达信监控庄家和私募的利器(源码) 无未来函数!监控庄家和私募的利器(源码) 无未来函数!公式源码:VAR1:=REF(LOW,1);VAR2:=(SMA(ABS(LOW-VAR1),13,1))/(SMA(MAX(LOW-VAR1,0),13,1))*4;VAR3:=EMA(VAR2,13);VAR4:=LLV(LOW,34);VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);VAR6:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);VAR7:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);VAR8:=VAR6<REF(VAR7,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,8,0),COLORAA00BB;{粉色住}STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,8,0),COLORBB11BB;STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,5,0),COLORCC22BB;STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,3,0),COLORDD33BB;STICKLINE(VAR8 AND COUNT(VAR8,18)=1,0,18,1,0),COLOREE44BB;DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,16,'●↙大资金进场'),COLOR0099FF;DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,12,'●↙择机买入'),COLOR0033FF;DRAWTEXT(VAR8 AND COUNT(VAR8,18)=1,8,'●↙多数会涨'),COLORFFFFAA;

    浏览1153次浏览
    2022-10-18 17:16
  • 神奇指标

    通达信资金监控庄家和私募和主力的优化主图 源码 再次优化

    以下是通达信资金监控庄家和私募和主力的优化主图 源码 再次优化资金监控庄家和私募和主力的优化主图 源码 再次优化公式源码:ZT:=C>REF(C,1)*1.090 AND C<REF(C,1)*1.105;DT:=C<REF(C,1)*0.901 AND C>REF(C,1)*0.898;STICKLINE(ZT,C,O,4,0),COLORRED;STICKLINE(DT,C,O,4,0),COLORBLUE;DRAWTEXT(ZT,L-0.1,'涨停'),COLORRED;DRAWTEXT(DT,H+0.3,'跌停'),COLORBLUE;STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORYELLOW;DRAWTEXT_FIX(C>0,0.17,0.0,0,DYBLOCK),COLORYELLOW,LINETHICK2;DRAWTEXT_FIX(C>0,0.25,0.0,0,HYBLOCK),COLORRED,LINETHICK2;DRAWTEXT_FIX(C>0,0.36,0.0,0,GNBLOCK)COLORWHITE;DRAWTEXT_FIX(1,0,0.0,0,'【莸利比例】'),COLORWHITE;DRAWNUMBER_FIX(1,0.10,0.0,0,CONST(WINNER(C )*100)),COLORYELLOW;DRAWTEXT_FIX(1,0.0,0.06,0,EXTERNSTR(0,2));上涨家数:INDEXADV,COLOR0080FF,NODRAW;下跌家数:INDEXDEC,COLORGREEN,NODRAW;DRAWKLINE(H,O,L,C);MA5:=MA(CLOSE,5),COLORWHITE;MA10:=MA(CLOSE,10),COLORYELLOW;MA30:=MA(CLOSE,30),COLORMAGENTA;MA60:=MA(CLOSE,60),COLORGREEN;MA120:=MA(CLOSE,120),COLORLIMAGENTA;MA240:=MA(CLOSE,240),COLORBLUE,NODRAW; VOL5:=MA(VOL,5),COLORWHITE;VOL10:=MA(VOL,10),COLORYELLOW;VOL40:=MA(VOL,40),COLORFF00FF ;量托:=VOL5>=VOL40 AND CROSS(VOL10,VOL40) AND REF(VOL10,1)<REF(VOL40,1);DRAWTEXT(量托,L-0.012,''),COLORWHITE;AA1:=BARSLAST(MA60>MA30 AND (MA30=MA10 OR MA30>MA10));BB1:=REF(COUNT(C<MA60,AA1)=AA1,1);CC1:=CROSS(C,MA60) AND VOL>MA(VOL,5) AND (C-REF(C,1))/REF(C,1)*100>3;芙蓉出水:=BB1 AND CC1,COLOR00FF00;DRAWTEXT(芙蓉出水,H+0.3,''),COLORFF00FF;STICKLINE(芙蓉出水,H,L,1,1),COLORFF00FF;STICKLINE(芙蓉出水,O,C,3,1),LINETHICK2,COLORFF00FF;MA1:=MA(CLOSE,5);MA2:=MA(CLOSE,10);MA3:=MA(CLOSE,20);ZJ:=AMOUNT/10000;TM:=V-MA(V,10);一穿三:=MA1>O AND MA2>O AND MA3>O AND MA1<C AND MA2<C AND MA3<C AND CLOSE>OPEN ;DRAWTEXT(一穿三,L-0.012,''),COLORFF00FF;STICKLINE(一穿三,OPEN,CLOSE,1,0),COLORFF00FF;三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));三日价涨A:=C>=REF(C,1);三日价涨B:=C<REF(C,1);三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);TIM:=IF(DATE<1140214,1,0);缩倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;百日低量:=(VOL=LLV(VOL,100))*TIM;倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;黄金柱:=倍量黄金柱 OR 高量黄金柱;次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;将军柱:=倍量将军柱 OR 高量将军柱;次倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;次高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;次将军柱:=次倍量将军柱 OR 次高量将军柱;准倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立;准高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立;准将军柱:=准倍量将军柱 OR 准高量将军柱;BACKSET100:=BACKSET(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱 OR 准将军柱,4);FILTER100:=FILTER(BACKSET100,3),NODRAW;BACKSET101:=BACKSET(黄金柱,4);FILTER101:=FILTER(BACKSET101,3);BACKSET102:=BACKSET(次黄金柱,4);FILTER102:=FILTER(BACKSET102,3);BACKSET103:=BACKSET(准黄金柱,4);FILTER103:=FILTER(BACKSET103,3);BACKSET104:=BACKSET(将军柱,4);FILTER104:=FILTER(BACKSET104,3);BACKSET105:=BACKSET(次将军柱,4);FILTER105:=FILTER(BACKSET105,3);BACKSET106:=BACKSET(准将军柱,4);FILTER106:=FILTER(BACKSET106,3);黄金线下影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=REF(L,3);黄金线实体下端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=MIN(REF(C,3),REF(O,3)) AND MIN(MIN(L,REF(L,1)),REF(L,2))>REF(L,3),LINETHICK0;黄金线上影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(H,3);黄金线实体上端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<REF(H,3);黄金线实体中间:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3));黄金线实体中间1:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,2)=MIN(MIN(L,REF(L,1)),REF(L,2));黄金线实体中间2:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,1)=MIN(MIN(L,REF(L,1)),REF(L,2));黄金线实体中间3:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND L=MIN(MIN(L,REF(L,1)),REF(L,2));BACKSET201:=BACKSET(黄金线下影线,4);FILTER201:=FILTER(BACKSET201,3),NODRAW;BACKSET202:=BACKSET(黄金线实体下端,4);FILTER202:=FILTER(BACKSET202,3),NODRAW;BACKSET203:=BACKSET(黄金线上影线,4);FILTER203:=FILTER(BACKSET203,3),NODRAW;BACKSET204:=BACKSET(黄金线实体上端,4);FILTER204:=FILTER(BACKSET204,3),NODRAW;BACKSET205:=BACKSET(黄金线实体中间,4);FILTER205:=FILTER(BACKSET205,3),NODRAW;BACKSET2051:=BACKSET(黄金线实体中间1,4);FILTER2051:=FILTER(BACKSET2051,3),NODRAW;BACKSET2052:=BACKSET(黄金线实体中间2,4);FILTER2052:=FILTER(BACKSET2052,3),NODRAW;BACKSET2053:=BACKSET(黄金线实体中间3,4);FILTER2053:=FILTER(BACKSET2053,3),NODRAW;BT201:=IF(BARSLAST(FILTER201)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER201));BT202:=IF(BARSLAST(FILTER202)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER202));BT203:=IF(BARSLAST(FILTER203)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER203));BT204:=IF(BARSLAST(FILTER204)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER204));BT205:=IF(BARSLAST(FILTER205)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER205));BT2051:=IF(BARSLAST(FILTER2051)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2051));BT2052:=IF(BARSLAST(FILTER2052)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2052));BT2053:=IF(BARSLAST(FILTER2053)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2053));DAY1:=SUMBARS(FILTER100,1),NODRAW;HJX1_1:=IF(SUMBARS(FILTER201,1)=DAY1,IF(DAY1=1,LOW,REF(LOW,DAY1-1)),0),NODRAW;HJX1_2:=IF(SUMBARS(FILTER202,1)=DAY1,IF(DAY1=1,MIN(C,O),MIN(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;HJX1_3:=IF(SUMBARS(FILTER203,1)=DAY1,IF(DAY1=1,HIGH,REF(HIGH,DAY1-1)),0),NODRAW;HJX1_4:=IF(SUMBARS(FILTER204,1)=DAY1,IF(DAY1=1,MAX(C,O),MAX(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;HJX1_51:=IF(SUMBARS(FILTER2051,1)=DAY1,IF(DAY1=2,LOW,IF(DAY1<2,DRAWNULL,REF(LOW,DAY1-2))),0),NODRAW;HJX1_52:=IF(SUMBARS(FILTER2052,1)=DAY1,IF(DAY1=3,LOW,IF(DAY1<3,DRAWNULL,REF(LOW,DAY1-3))),0),NODRAW;HJX1_53:=IF(SUMBARS(FILTER2053,1)=DAY1,IF(DAY1=4,LOW,IF(DAY1<4,DRAWNULL,REF(LOW,DAY1-4))),0),NODRAW;黄金线:=HJX1_1+HJX1_2+HJX1_3+HJX1_4+HJX1_51+HJX1_52+HJX1_53,COLORYELLOW,NODRAW;立桩量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);立桩量三日突破:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));立桩量三日不破:=BARSLAST(立桩量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));BACKSET300:=BACKSET(立桩量三日不破,4);BACKSET301:=BACKSET(立桩量三日突破,4);立桩量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立桩量;DRAWTEXT(立桩量成立,HIGH*1.01,' '),COLOR00FF00;DRAWTEXT(FILTER101,LOW*0.986,'↖黄金柱'),COLORRED;STICKLINE(FILTER101,OPEN,CLOSE,0.5,0),COLORYELLOW;DRAWTEXT(FILTER102,LOW*0.986,'��'),COLORYELLOW;DRAWTEXT(FILTER104,LOW*0.986,'↖将军柱'),COLORYELLOW;STICKLINE(FILTER104,OPEN,CLOSE,1.5,0),COLORYELLOW;K1:=SUMBARS(FILTER104,1);STICKLINE(K1,REF(L,K1-2),REF(L,K1-2),10,0),COLORYELLOW; K2:=SUMBARS(FILTER101,1);STICKLINE(K2,REF(L,K2-2),REF(L,K2-2),10,0),COLORYELLOW;倍量攻击:=V>REF(V,1)*2 AND (C>=O OR C>REF(C,1)),COLORRED,NODRAW;STICKLINE(倍量攻击,C,O,0.5,0),COLORYELLOW;DRAWRECTREL(0,625,250,1000,IF(100,RGB(0,15,15),0));超B:=L2_AMO(0,2)/10000.0;大B:=L2_AMO(1,2)/10000.0;中B:=L2_AMO(2,2)/10000.0;小B:=L2_AMO(3,2)/10000.0;超S:=L2_AMO(0,3)/10000.0;大S:=L2_AMO(1,3)/10000.0;中S:=L2_AMO(2,3)/10000.0;小S:=L2_AMO(3,3)/10000.0;大宗净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;净流入:=(超B+大B+中B+小B)+(超S+大S+中S+小S);大宗进:=(超B)+(大B);大宗出:=(超S)+(大S);非大宗进:=(中B)+(小B);非大宗出:=(中S)+(小S);主力买力度:=LARGEINTRDVOL*100/VOL,NODRAW;主力卖力度:=LARGEOUTTRDVOL*100/VOL,NODRAW;AA:=CONST(MAX(ABS(净流入),MAX(ABS(大宗净流入),MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出)))))))*3,NODRAW;DRAWRECTREL(0,CONST(855-(ABS(大宗进)*500/AA)),38,965,IF(CONST(大宗进)>0,RGB(255,0,0),RGB(23,125,255)));DRAWRECTREL(45,CONST(855-(ABS(大宗出)*500/AA)),83,965,IF(CONST(大宗出)<0,RGB(0,50,0),RGB(0,50,0)));DRAWRECTREL(100,CONST(855-(ABS(非大宗进)*500/AA)),140,965,IF(CONST(非大宗进)>0,RGB(255,0,0),RGB(23,125,255)));DRAWRECTREL(150,CONST(855-(ABS(非大宗出)*500/AA)),189,965,IF(CONST(非大宗出)<0,RGB(0,50,0),RGB(0,50,0)));DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,1,0,'  进   主力   出             进   散户  出'),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.005,0.88,0,INTPART(大宗进)),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.043,0.88,0,INTPART(大宗出)),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.102,0.88,0,INTPART(非大宗进)),COLORWHITE;DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.156,0.88,0,INTPART(非大宗出)),COLORWHITE;主买A:=ACTINVOL,COLORRED,NODRAW;主卖A:=ACTOUTVOL,COLORGREEN,NODRAW;主买:主买A*100/(主买A+主卖A),NODRAW,COLORRED;主卖:主卖A*100/(主买A+主卖A),NODRAW,COLORGREEN;DRAWRECTREL(0,620,194,675,RGB(0,75,200));DRAWRECTREL(0,620,194,675,RGB(0,250,50));DRAWRECTREL(0,620,80+CONST(主买*160/100),675,RGB(175,50,250));DRAWTEXT_FIX(1,0.00,0.63,0,STRCAT(STRCAT('主动买卖比 ',CON2STR(主买,2)),' %')),COLORYELLOW;DRAWTEXT_FIX(1,0.14,0.63,0,STRCAT(STRCAT(' ',CON2STR(主卖,2)),' %')),COLORYELLOW;DRAWRECTREL(0,730,194,680,RGB(0,75,200));DRAWRECTREL(0,730,194,680,RGB(0,250,50));DRAWRECTREL(0,730,80+CONST(主力买力度*160/100),680,RGB(200,0,50));DRAWTEXT_FIX(1,0.00,0.69,0,STRCAT(STRCAT('主动买卖力 ',CON2STR(主力买力度,2)),'%')),COLORYELLOW;DRAWTEXT_FIX(1,0.14,0.69,0,STRCAT(STRCAT(' ',CON2STR(主力卖力度,2)),'%')),COLORYELLOW;DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*100000/FINANCE(7),NODRAW;DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);DRAWRECTREL(197,620,250,660,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(197,665,250,700,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(197,738,250,792,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(197,782,250,822,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(197,872,250,912,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));DRAWRECTREL(197,918,250,962,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));DRAWTEXT_FIX(1,0.20,0.62,0,STRCAT('',CON2STR(DDX,3))),COLORYELLOW;DRAWTEXT_FIX(1,0.20,0.74,0,STRCAT('',CON2STR(DDY,3))),COLORYELLOW;DRAWTEXT_FIX(1,0.20,0.87,0,STRCAT('',CON2STR(DDZ,3))),COLORYELLOW;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.20,0.70,0,'大单动向'),COLORWHITE;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.20,0.83,0,'涨跌动因'),COLORWHITE;DRAWTEXT_FIX(CURRBARSCOUNT=1,0.20,0.98,0,'大单差分'),COLORWHITE;T1:=IF (DDX>0 AND REF(DDX,1)<0,1,0);T2:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)<0,2,T1);T3:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)<0,3,T2);T4:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)<0,4,T3);T5:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)<0,5,T4);T6:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)<0,6,T5);T7:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)<0,7,T6);T8:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)<0,8,T7);T9:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)<0,9,T8);T:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)>0,10,T9);DRAWTEXT_FIX(1,0.20,0.66,0,STRCAT(STRCAT(' ',CON2STR(T,0)),' [天] ')),COLORYELLOW;T11:=IF (DDY>0 AND REF(DDY,1)<0,1,0);T21:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)<0,2,T11);T31:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)<0,3,T21);T41:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)<0,4,T31);T51:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)<0,5,T41);T61:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)<0,6,T51);T71:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)<0,7,T61);T81:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)<0,8,T71);T91:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)<0,9,T81);TY:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)>0,10,T91);DRAWTEXT_FIX(1,0.20,0.79,0,STRCAT(STRCAT(' ',CON2STR(TY,0)),' [天] ')),COLORYELLOW;T1Z:=IF (DDZ>0 AND REF(DDZ,1)<0,1,0);T2Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)<0,2,T1Z);T3Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)<0,3,T2Z);T4Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)<0,4,T3Z);T5Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)<0,5,T4Z);T6Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)<0,6,T5Z);T7Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)<0,7,T6Z);T8Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)<0,8,T7Z);T9Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)<0,9,T8Z);TZ:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)>0,10,T9Z);DRAWTEXT_FIX(1,0.20,0.92,0,STRCAT(STRCAT(' ',CON2STR(TZ,0)),' [天] ')),COLORYELLOW;

    浏览6717次浏览
    2022-10-18 16:55
  • 神奇指标

    大智慧私募机构副图指标

    以下是大智慧私募机构副图指标大智慧私募机构副图指标源码A:=IF((CLOSE > 126.32),(AMOUNT / 100000),VOL);主力:MA(A,4),LINETHICK0,culor00FFFF;游资:MA(A,8),LINETHICK0,culor00FF00;大户:MA(A,16),LINETHICK0,culor0000FF;散户:MA(A,32),LINETHICK0,culorFFFF00;主动参与比例:CEILING(((主力 / (((主力 + 游资) + 大户) + 散户)) * 100)),LINETHICK0,culor00FFFF;游资参与比例:CEILING(((游资 / (((主力 + 游资) + 大户) + 散户)) * 100)),LINETHICK0,culor00FF00;大户参与比例:CEILING(((大户 / (((主力 + 游资) + 大户) + 散户)) * 100)),LINETHICK0,culor0000FF;散户参与比例:CEILING(((散户 / (((主力 + 游资) + 大户) + 散户)) * 100)),LINETHICK0,culorFFFF00;警戒线:MA(A,180),culorFF00FF;STICKLINE((主力 > 0),0,主力,8,0),culor0000FF;STICKLINE((主力 > 0),0,主力,7.8,0),culor0018FF;STICKLINE((主力 > 0),0,主力,7.5,0),culor001BFF;STICKLINE((主力 > 0),0,主力,7.3,0),culor0022FF;STICKLINE((主力 > 0),0,主力,7,0),culor0035FF;STICKLINE((主力 > 0),0,主力,6.8,0),culor0041FF;STICKLINE((主力 > 0),0,主力,6.5,0),culor0050FF;STICKLINE((主力 > 0),0,主力,6.3,0),culor0059FF;STICKLINE((主力 > 0),0,主力,6,0),culor0062FF;STICKLINE((主力 > 0),0,主力,5.7,0),culor006CFF;STICKLINE((主力 > 0),0,主力,5.5,0),culor007AFF;STICKLINE((主力 > 0),0,主力,5.3,0),culor0080FF;STICKLINE((主力 > 0),0,主力,5,0),culor0089FF;STICKLINE((主力 > 0),0,主力,4.5,0),culor0095FF;STICKLINE((主力 > 0),0,主力,3.5,0),culor009CFF;STICKLINE((主力 > 0),0,主力,3,0),culor00ABFF;STICKLINE((主力 > 0),0,主力,2.5,0),culor00C0FF;STICKLINE((主力 > 0),0,主力,1.5,0),culor00D1FF;STICKLINE((主力 > 0),0,主力,1,0),culor00EAFF;STICKLINE((主力 > 0),0,主力,0.7,0),culor00FFFF;STICKLINE((游资 > 0),0,游资,8,0),culor006800;STICKLINE((游资 > 0),0,游资,7.8,0),culor007F00;STICKLINE((游资 > 0),0,游资,7,5),culor008B00;STICKLINE((游资 > 0),0,游资,7,3),culor008B00;STICKLINE((游资 > 0),0,游资,7,0),culor009000;STICKLINE((游资 > 0),0,游资,6.8,0),culor009500;STICKLINE((游资 > 0),0,游资,6.5,0),culor009C00;STICKLINE((游资 > 0),0,游资,6.3,0),culor00A300;STICKLINE((游资 > 0),0,游资,6,0),culor00AB00;STICKLINE((游资 > 0),0,游资,5.7,0),culor00AF00;STICKLINE((游资 > 0),0,游资,5.5,0),culor00B900;STICKLINE((游资 > 0),0,游资,5.3,0),culor00C000;STICKLINE((游资 > 0),0,游资,5,0),culor00C100;STICKLINE((游资 > 0),0,游资,4.5,0),culor00CA00;STICKLINE((游资 > 0),0,游资,3.5,0),culor00D300;STICKLINE((游资 > 0),0,游资,3,0),culor00DB00;STICKLINE((游资 > 0),0,游资,2.5,0),culor00EA00;STICKLINE((游资 > 0),0,游资,1.5,0),culor00FF00;STICKLINE((大户 > 0),0,大户,8,0),culor102088;STICKLINE((大户 > 0),0,大户,7,0),culor102099;STICKLINE((大户 > 0),0,大户,6,0),culor1020AA;STICKLINE((大户 > 0),0,大户,5,0),culor1020BB;STICKLINE((大户 > 0),0,大户,4,0),culor1020CC;STICKLINE((大户 > 0),0,大户,3,0),culor1020DD;STICKLINE((大户 > 0),0,大户,2,0),culor1020EE;STICKLINE((大户 > 0),0,大户,1,0),culor1020FF;STICKLINE((大户 > 0),0,大户,8,0),culor102088;STICKLINE((大户 > 0),0,大户,7,0),culor102099;STICKLINE((大户 > 0),0,大户,6,0),culor1020AA;STICKLINE((大户 > 0),0,大户,5,0),culor1020BB;STICKLINE((大户 > 0),0,大户,4,0),culor1020CC;STICKLINE((大户 > 0),0,大户,3,0),culor1020DD;STICKLINE((大户 > 0),0,大户,2,0),culor1020EE;STICKLINE((大户 > 0),0,大户,1,0),culor1020FF;STICKLINE((散户 > 0),0,散户,8,0),culorFF7700;STICKLINE((散户 > 0),0,散户,7,0),culorFF8800;STICKLINE((散户 > 0),0,散户,6,0),culorFF9900;STICKLINE((散户 > 0),0,散户,5,0),culorFFAA00;STICKLINE((散户 > 0),0,散户,4,0),culorFFBB00;STICKLINE((散户 > 0),0,散户,3,0),culorFFCC00;STICKLINE((散户 > 0),0,散户,2,0),culorFFDD00;STICKLINE((散户 > 0),0,散户,1,0),culorFFEE00;STICKLINE((散户 > 0),0,散户,8,0),culorFF7700;STICKLINE((散户 > 0),0,散户,7,0),culorFF8800;STICKLINE((散户 > 0),0,散户,6,0),culorFF9900;STICKLINE((散户 > 0),0,散户,5,0),culorFFAA00;STICKLINE((散户 > 0),0,散户,4,0),culorFFBB00;STICKLINE((散户 > 0),0,散户,3,0),culorFFCC00;STICKLINE((散户 > 0),0,散户,2,0),culorFFDD00;STICKLINE((散户 > 0),0,散户,1,0),culorFFEE00;

    浏览9177次浏览
    2022-10-18 14:50