神奇指标网

通达信季移动平均线 比常规移动平均线更为优秀源码副图无未来

浏览 2538次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-05

以下是通达信季移动平均线 比常规移动平均线更为优秀源码副图无未来

季移动平均线是本人对股价的形态分析总结所得精髓,指标简洁清爽比常规移动平均线更为优秀。是否符合你所需只有你去慢慢研究。

指标原理解析,让大家真正明白指标:

1、常规移动平均线只是对每日股价做一段时间内的一个移动平均(软件自带指标MA),比如:5日MA(CLOSE,5),10日MA(CLOSE,10),20日MA(CLOSE,20),60日MA(CLOSE,60)等等,通常而我们在分析股票时是以周,月,季等周期来观察它的趋势。在周期日线下看月,季自然就不方便合理,这是指标的局限性造成的。

2、季移动平均线是由当季的天数来做移动平均,股价在当季的开始时移动平均变化不大,股价变化更能明显反应,可以直观看出大涨的活跃票票;股价在当季的中部或者尾部时移动平均变化跟随当季的天数变化做移动平均,反应出股价的长期趋势变化;如股票长时间调整会在季移动平均线上下浮动也很容易看出来,此时自然弃它换票。一条季移动平均线即可看出当月当季是否上涨,不用老换其他周期观看趋势,此指标同理可用于月天数,个人觉得季比月更好些。

 

JD:=MONTH=1 OR MONTH=4 OR MONTH=7 OR MONTH=10;
JA:=JD AND DAY<REF(DAY,1);
JT:=BARSLAST(JA)+1;
季MA:MA(C,JT),COLORFF0000;
季MA1:季MA*1.1,COLORFF0000;
{季L:TMA(季MA,0.9,0.1);
季H:TMA(季MA,0.9,0.11);}
NOTEXT1:IF(季MA>REF(季MA,1),季MA,DRAWNULL),COLORRED;
NOTEXT2:IF(季MA1>REF(季MA1,1),季MA1,DRAWNULL),COLORRED;
EMA(C,5);

DRAWKLINE(H,O,L,C);
上涨:=(C/REF(C,1)-1)*100;
红柱:=IF(PERIOD>=6,9.9,IF(PERIOD=5,4.9,IF(PERIOD=4,3.9,IF(PERIOD>=3,2.9,IF(PERIOD=2,1.9,IF(PERIOD<=1,0.8,0))))));
STICKLINE(上涨>=红柱,OPEN,CLOSE,3,0),COLORRED;
绿柱:=IF(PERIOD>=6,-9.9,IF(PERIOD=5,-4.9,IF(PERIOD<=4,-2,0)));
STICKLINE(上涨<绿柱,OPEN,CLOSE,3,1),COLORLIBLUE;

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论