神奇指标网
神奇指标网

通达信KDJ RSI MACD背离买卖指标公式

浏览 2648次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-05

以下是通达信KDJ RSI MACD背离买卖指标公式

J1:MA(C,7),COLORWHITE;
 J2:MA(C,21),COLORYELLOW;
 DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
 DEA:=EMA(DIFF,9);
 A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
 B1:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
 A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
 B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
 A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
 B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
 DRAWICON(B1>0,L-0.20,5); 

 DRAWTEXT(B1,L-0.30,'MACD底背'),COLORWHITE;
 DRAWICON(B2>0,L-0.20,4);
 DRAWTEXT(B2,L-0.30,'KDJ底背'),COLORFF00FF;
 DRAWICON(B3>0,L-0.20,3);
 DRAWTEXT(B3,L-0.30,'RSI底背'),COLORYELLOW;
 DRAWICON(CROSS(DIFF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),L-0.20,6);
 DRAWTEXT(CROSS(DIFF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),L-0.30,'金叉共振'),COLOR0099FF;

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论