神奇指标网
神奇指标网

通达信自用MACD背离 副图源码 无未来

浏览 7215次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-10-19




以下是通达信自用MACD背离 副图源码 无未来




自用MACD背离 副图源码



DIF:EMA(CLOSE,12)-EMA(CLOSE,26),COLORRED,LINETHICK2;

DEA:EMA(DIF,9),COLORWHITE,LINETHICK2;

持仓段:=0,COLOR00CFFF;

空仓段:=0,COLORFFCCFF;

STICKLINE(DIF>DEA,-0.5,-0.6,10,1),COLOR00CFFF;

STICKLINE(DIF<DEA,-0.5,-0.6,10,1),COLORFFCCFF;

MACD:(DIF-DEA)*2,COLORSTICK;

STICKLINE(((MACD<REF(MACD,1)) AND (MACD>0)),0,MACD,1,0),COLORLIBLUE,LINETHICK2;

STICKLINE(((MACD>REF(MACD,1)) AND (MACD<0)),0,MACD,1,0),COLORFF00FF,LINETHICK2;

建仓:IF(DIF<0,DIF,0),COLORYELLOW,LINETHICK2;

加仓:IF(DIF<0,0,DIF),COLORRED,LINETHICK2;

白线破仓:IF(DIF<DEA,DIF,DEA),COLORWHITE,LINETHICK2;

趋势强弱:IF(DIF>DEA,DEA,DEA),COLORFF937F,LINETHICK2;



AA:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(AA=2,21)=1;

DRAWTEXT(二次金叉,0.2,' 二次金叉'),COLORYELLOW;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

STICKLINE(底背离,0,0.03,6,0),COLOR00FF00;

底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,LINETHICK4;

DRAWTEXT(底背离,0.12,' 底背离'),COLORFF00FF;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);

顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,LINETHICK4;



自用MACD背离 副图源码 无未来



神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论