神奇指标网

用了3年多的主图 适用于短线 抓涨停的好主图

浏览 7975次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-10-21




以下是用了3年多的主图 适用于短线涨停的好主图




用了3年多的主图 适用于短线 抓涨停的好主图



源码



m:=80;

n:=3;

DRAWKLINE(HIGH,OPEN,LOW,CLOSE);

VAR11:=MA(C,9),COLORRED;

上升通道:IF(VAR11>REF(VAR11,1),VAR11,DRAWNULL),LINETHICK5,COLORRED;

下降通道:IF(VAR11<REF(VAR11,1),VAR11,DRAWNULL),LINETHICK4,COLORGREEN;

A0:=(L+H+C*2)/4;

AA:=EMA(A0,14)COLORYELLOW,LINETHICK1;

BB:=EMA(A0,25)COLORYELLOW,LINETHICK2;

A1X:=(AA-REF(AA,1))/REF(AA,1)*100;

A2X:=(BB-REF(BB,1))/REF(BB,1)*100;

G:=BARSLAST(CROSS(A1X,0));

CC:=IF(CURRBARSCOUNT<18,CONST(REF(C,1)),DRAWNULL),COLORBLUE;

DRAWKLINE(H,O,L,C);

ZKP:=IF(C>REF(C,1),REF(C,1),DRAWNULL);

ZSP:=IF(C>REF(C,1),C,DRAWNULL);

DKP:=IF(C<=REF(C,1),REF(C,1),DRAWNULL);

DSP:=IF(C<=REF(C,1),C,DRAWNULL);

DRAWKLINE(H,DKP,L,DSP);

STICKLINE(C<=REF(C,1),DKP,DSP,3.05,0),COLORBLUE;

STICKLINE(C<=REF(C,1),DKP,DSP,2.2,0),COLORFF7700;

STICKLINE(C<=REF(C,1),DKP,DSP,1.5,0),COLORFF9900;

STICKLINE(C<=REF(C,1),DKP,DSP,0.5,0),COLORFFBB00;

DRAWKLINE(H,ZKP,L,ZSP);

STICKLINE(C>REF(C,1),ZKP,ZSP,3.05,0),COLOR000099;

STICKLINE(C>REF(C,1),ZKP,ZSP,2.2,0),COLOR0000CC;

STICKLINE(C>REF(C,1),ZKP,ZSP,1.5,0),COLOR0000FF;

STICKLINE(C>REF(C,1),ZKP,ZSP,0.5,0),COLORCC66FF;

STICKLINE(V/REF(V,1)>2 AND CLOSE>=OPEN,ZKP,ZSP,1,0),COLORYELLOW;

TY:=C;

A1:=REF(TY,10)=HHV(TY,2*10+1);

B1:=FILTER(A1,10);

C1:=BACKSET(B1,10+1);

HD:=FILTER(C1,10);

A2:=REF(TY,10)=LLV(TY,2*10+1);

B2:=FILTER(A2,10);

C2:=BACKSET(B2,10+1);

LD:=FILTER(C2,10);

前期高位:REF(C,BARSLAST(HD)),COLOR8000FF,POINTDOT;

STICKLINE(C,前期高位,前期高位,8,0),COLOR8000FF;

JRH:=HHV(C,2);    

JRL:=LLV(C,2);    

VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));    

VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    

VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    

VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    

VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    

VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    

VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    

VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    

VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    

VARA:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    

VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    

VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    

VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    

VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    

VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    

VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    

VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    

VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    

VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    

VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    

VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    

VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));    

VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));    

VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01);    

VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD);    

红色持股:=VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;

离场:=IF(红色持股,JRL,DRAWNULL);    

明离场价:=离场,COLORFF99FF,NODRAW;

青色观望:=VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW;    

进:=IF(青色观望,JRH,DRAWNULL);

今离场价:REF(离场,1),COLOR0000FF,NODRAW;    

明进场价:进,COLOR33AACC,NODRAW;    

今进场价:REF(明进场价,1),COLORGREEN,NODRAW;

必卖止损价位:REF(A0,G),COLORFFFFFF,LINETHICK4;

总额:=AMOUNT;

买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));

买%:=买/AMOUNT*100;

流入:=AMOUNT*买%/10000000000;

流出:=AMOUNT/100000000-流入;

净流:=(流入-流出);

总额3:=SUM(AMOUNT,3);

流入3:=SUM(流入,3);

流出3:=SUM(流出,3);

净流3:=SUM(流入-流出,3);

总额5:=SUM(AMOUNT,5);

流入5:=SUM(流入,5);

流出5:=SUM(流出,5);

净流5:=SUM(流入-流出,5);

总额10:=SUM(AMOUNT,10);

流入10:=SUM(流入,10);

流出10:=SUM(流出,10);

净流10:=SUM(流入-流出,10);

画:=CONST(FINDHIGH(总额10,0,190,1));

DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR00FFFF;

DRAWTEXT_FIX(1,0.06,0,0,HYBLOCK)COLOR00FFFF;

DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;

DRAWTEXT_FIX(1,0.20,0,0,DYBLOCK)COLOR00FFFF;

DRAWTEXT_FIX(1,0.30,0.00,0,'主题投资:')COLOR00FFFF;

DRAWTEXT_FIX(1,0.36,0.00,0,EXTERNSTR(0,2))COLOR00FFFF;

DRAWTEXT_FIX(1,0.00,0.05,0,'主营业务:')COLOR00FFFF;

DRAWTEXT_FIX(1,0.06,0.05,0,EXTERNSTR(0,3))COLOR00FFFF;

DRAWTEXT_FIX(1,0.00,0.10,0,'解禁日期:')COLOR00FFFF;

DRAWTEXT_FIX(1,0.06,0.10,0,EXTERNSTR(0,4))COLOR00FFFF;

DRAWTEXT_FIX(1,0.00,0.15,0,'莸利比例:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.06,0.15,0,CONST(WINNER(C )*100)),COLOR0080FF;

DRAWTEXT_FIX(1,0.12,0.15,0,'动态PE:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.17,0.15,0,CONST(DYNAINFO(39))),COLOR0080FF;

DRAWTEXT_FIX(1,0.22,0.15,0,'市值:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.26,0.15,0,FINANCE(40)/100000000),COLOR0080FF;

DRAWTEXT_FIX  (1,0.31,0.15,0,'公积金(股):'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.38,0.15,0,FINANCE(18)),COLOR0080FF;

DRAWTEXT_FIX  (1,0.43,0.15,0,'收益:'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.47,0.15,0,FINANCE(33)),COLOR0080FF;

DRAWTEXT_FIX(1,0.00,0.19,0,'净流入(亿):'),COLORYELLOW;

DRAWTEXT_FIX(1,0.06,0.19,0,'1日'),COLORYELLOW;

DRAWTEXT_FIX(1,0.12,0.19,0,'3日'),COLORYELLOW;

DRAWTEXT_FIX(1,0.18,0.19,0,'5日'),COLORYELLOW;

DRAWTEXT_FIX(1,0.24,0.19,0,'10日'),COLORYELLOW;

DRAWNUMBER_FIX(1,0.08,0.19,0,CONST((净流))),COLOR0080FF;

DRAWNUMBER_FIX(1,0.14,0.19,0,CONST((净流3))),COLOR0080FF;

DRAWNUMBER_FIX(1,0.20,0.19,0,CONST((净流5))),COLOR0080FF;

DRAWNUMBER_FIX(1,0.265,0.19,0,CONST((净流10))),COLOR0080FF;

DRAWTEXT_FIX(1,0.00,0.23,0,'愚民导向:'),COLOR00FFFF;

DRAWTEXT_FIX(1,0.06,0.23,0,EXTERNSTR(0,5)),COLOR00FFFF;

VAR111:=ZIG(3,13);

STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,3,0),COLOR66FF00;

DRAWTEXT_FIX(STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,5,0),0.00,0.11,0,''),COLOR00FF00,LINETHICK1;

DRAWRECTREL(0,500,147,999.4,IF(120,RGB(10,0,0),0));

超B:=L2_AMO(0,2)/10000.0;

大B:=L2_AMO(1,2)/10000.0;

中B:=L2_AMO(2,2)/10000.0;

小B:=L2_AMO(3,2)/10000.0;

超S:=L2_AMO(0,3)/10000.0;

大S:=L2_AMO(1,3)/10000.0;

中S:=L2_AMO(2,3)/10000.0;

小S:=L2_AMO(3,3)/10000.0;

TESTSKIP(NOT(超B OR 大B OR 中B OR 小B OR 超S OR 大S OR 中S OR 小S)!=0);

大宗进:=(超B)+(大B),NODRAW;

大宗出:=(超S)+(大S),NODRAW;

非大宗进:=(中B)+(小B),NODRAW;

非大宗出:=(中S)+(小S),NODRAW;

大宗进限制:=IF((超B+大B)=0,0,大宗进);

大宗出限制:=IF((超S+大S)=0,0,大宗出);

非大宗进限制:=IF(中B+小B=0,0,非大宗进);

非大宗出限制:=IF(中S+小S=0,0,非大宗出);

主力净流入:=(超B+大B)-(超S+大S),COLORRED,NODRAW;

散户净流入:=(中B+小B)-(中S+小S),COLORRED,NODRAW;

净流入:=(超B+大B+中B+小B)-(超S+大S+中S+小S),COLORRED,NODRAW;

大单流入:=(超B+大B)/(超B+大B+超S+大S)*100,NODRAW;

大单流入限制:=IF((超B+大B+超S+大S)=0,0,大单流入);

大单流出比:=(超S+大S)/(超B+大B+超S+大S)*100,NODRAW;

大单流出限制:=IF((超B+大B+超S+大S)=0,0,大单流出比);

总流入比:=(超B+大B+中B+小B)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;

总流出比:=(超S+大S+中S+小S)/(超B+大B+中B+小B+超S+大S+中S+小S)*100,NODRAW;

成交总量:=(超B+大B+中B+小B+超S+大S+中S+小S),NODRAW;

机构参与度:=(超B+超S+大B+大S)/成交总量*100,COLORYELLOW,NODRAW;

大单强度:=(超B+大B-超S-大S)/成交总量*100,COLORYELLOW,NODRAW;

大单强度限制:=IF(大单强度=0,-100,大单强度);

大单强度比:=IF(大单强度>=0,(大单强度限制+100)/2,100-ABS((大单强度限制-100)/2)),NODRAW;

超单强度:=(超B-超S)/(超B+超S)*100,COLORYELLOW,NODRAW;

超单强度限制:=IF(超单强度=0,-100,超单强度);

超单强度比:=IF(超单强度>0,(超单强度限制+100)/2,IF(超单强度<0,100-ABS((超单强度限制-100)/2),0)),NODRAW;

DAZHIV:=CONST(MAX(ABS(大宗进),MAX(ABS(大宗出),MAX(ABS(非大宗进),ABS(非大宗出))))),NODRAW;

DRAWRECTREL(0,CONST(930-(ABS(大宗进)*250/DAZHIV)),35,950,IF(CONST(大宗进>0),RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(37,CONST(930-(ABS(大宗出)*250/DAZHIV)),72,950,IF(CONST(大宗出>0),RGB(23,125,255),RGB(255,0,0)));

DRAWRECTREL(75,CONST(930-(ABS(非大宗进)*250/DAZHIV)),110,950,IF(CONST(非大宗进>0),RGB(255,0,0),RGB(23,125,255)));

DRAWRECTREL(112,CONST(930-(ABS(非大宗出)*250/DAZHIV)),147,950,IF(CONST(非大宗出>0),RGB(23,125,255),RGB(255,0,0)));

DRAWRECTREL(150,CONST(940-(ABS(净流入)*250/DAZHIV))-20,190,950,IF(CONST(净流入>0),RGB(200,0,0),RGB(0,125,50)));

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.0001,0.9,0,STRCAT('',CON2STR(大宗进/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.036,0.9,0,STRCAT('',CON2STR(大宗出/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.074,0.9,0,STRCAT('',CON2STR(非大宗进/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.111,0.9,0,STRCAT('',CON2STR(非大宗出/1,0))),COLORYELLOW;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.150,0.9,0,STRCAT('',CON2STR(净流入/1,0))),COLORYELLOW;

DRAWTEXT_FIX(1,0.000,0.99,0,STRCAT(STRCAT('主力 ',CON2STR(主力净流入,0)),'万')),COLORMAGENTA;

DRAWTEXT_FIX(1,0.078,0.99,0,STRCAT(STRCAT('散户 ',CON2STR(散户净流入,0)),'万')),COLORCYAN;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.145,0.99,0,'净流入:(万)'),COLORYELLOW;

主力买力度:=LARGEINTRDVOL*1000/VOL;

主力卖力度:=LARGEOUTTRDVOL*1000/VOL;

AAD:=CONST(MAX(ABS(主力买力度),ABS(主力卖力度)))*4,NODRAW;

DRAWRECTREL(0,515,CONST(ABS(主力买力度)*560/AAD),568,IF(CONST(主力买力度)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWRECTREL(0,570,CONST(ABS(主力卖力度)*560/AAD),623,IF(CONST(主力卖力度)>0,RGB(0,50,0),RGB(255,0,0)));

DRAWTEXT_FIX(1,0,0.524,0,STRCAT('主买力度:',CON2STR(主力买力度,0))),COLORYELLOW;

DRAWTEXT_FIX(1,0,0.576,0,STRCAT('主卖力度:',CON2STR(主力卖力度,0))),COLORYELLOW;

{DDE显示}

DDX:=(LARGEINTRDVOL-LARGEOUTTRDVOL)*1000/FINANCE(7);

DDY:=IF(TRADENUM>0,(TRADEOUTNUM-TRADEINNUM)*100/TRADENUM,0);

DDZ:=IF(TRADENUM>0,(LARGETRDINNUM-LARGETRDOUTNUM)/TRADENUM*100,0);

DRAWRECTREL(150,500,192,540,IF(CONST(DDX)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWRECTREL(150,545,192,585,IF(CONST(DDY)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWRECTREL(150,590,192,630,IF(CONST(DDZ)>0,RGB(255,0,0),RGB(0,50,0)));

DRAWTEXT_FIX(1,0.153,0.500,0,STRCAT('DDX:',CON2STR(DDX,1))),COLORYELLOW,COLORWHITE;

DRAWTEXT_FIX(1,0.153,0.548,0,STRCAT('DDY:',CON2STR(DDY,1))),COLORYELLOW,COLORWHITE;

DRAWTEXT_FIX(1,0.153,0.596,0,STRCAT('DDZ:',CON2STR(DDZ,1))),COLORYELLOW,COLORWHITE;

T1:=IF (DDX>0 AND REF(DDX,1)<0,1,0);

T2:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)<0,2,T1);

T3:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)<0,3,T2);

T4:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)<0,4,T3);

T5:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)<0,5,T4);

T6:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)<0,6,T5);

T7:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)<0,7,T6);

T8:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)<0,8,T7);

T9:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)<0,9,T8);

T:=IF (DDX>0 AND REF(DDX,1)>0 AND REF(DDX,2)>0 AND REF(DDX,3)>0 AND REF(DDX,4)>0 AND REF(DDX,5)>0 AND REF(DDX,6)>0 AND REF(DDX,7)>0 AND REF(DDX,8)>0 AND REF(DDX,9)>0,10,T9);

DRAWTEXT_FIX(1,0.190,0.500,0,STRCAT(STRCAT(' ',CON2STR(T,0)),' [天] ')),COLORYELLOW;

T11:=IF (DDY>0 AND REF(DDY,1)<0,1,0);

T21:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)<0,2,T11);

T31:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)<0,3,T21);

T41:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)<0,4,T31);

T51:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)<0,5,T41);

T61:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)<0,6,T51);

T71:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)<0,7,T61);

T81:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)<0,8,T71);

T91:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)<0,9,T81);

TY01:=IF (DDY>0 AND REF(DDY,1)>0 AND REF(DDY,2)>0 AND REF(DDY,3)>0 AND REF(DDY,4)>0 AND REF(DDY,5)>0 AND REF(DDY,6)>0 AND REF(DDY,7)>0 AND REF(DDY,8)>0 AND REF(DDY,9)>0,10,T91);

DRAWTEXT_FIX(1,0.190,0.548,0,STRCAT(STRCAT(' ',CON2STR(TY01,0)),' [天] ')),COLORYELLOW;

T1Z:=IF (DDZ>0 AND REF(DDZ,2)<0,1,0);

T2Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)<0,2,T1Z);

T3Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)<0,3,T2Z);

T4Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)<0,4,T3Z);

T5Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)<0,5,T4Z);

T6Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)<0,6,T5Z);

T7Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)<0,7,T6Z);

T8Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)<0,8,T7Z);

T9Z:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)<0,9,T8Z);

TZ:=IF (DDZ>0 AND REF(DDZ,1)>0 AND REF(DDZ,2)>0 AND REF(DDZ,3)>0 AND REF(DDZ,4)>0 AND REF(DDZ,5)>0 AND REF(DDZ,6)>0 AND REF(DDZ,7)>0 AND REF(DDZ,8)>0 AND REF(DDZ,9)>0,10,T9Z);

DRAWTEXT_FIX(1,0.190,0.596,0,STRCAT(STRCAT(' ',CON2STR(TZ,0)),' [天] ')),COLORYELLOW;

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

VAR113:=HHV(HIGH,60);

VAR114:=LLV(LOW,30);

VAR115:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

VAR116:=(VAR113+VAR114+VAR115)/3;

VAR117:=EMA(VAR116,5);

K01:=EMA(VAR117,5)*2, COLORFF00FF;

D01:=EMA(K01,5),  COLORWHITE;

J01:=K01*3-D01*2, COLORYELLOW;

ENTERLONG:=CROSS(K01,D01);

EXITLONG:=CROSS(D01,K01);

B01:=(DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2))

AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),L*0.98,1))*D01*2/3;

B02:=IF(TROUGHBARS(3,15,1)=1 AND HIGH>LOW+0.01,20,0);

必买:=(B01 AND B02) AND 净流入>0;

必卖:=IF(PEAKBARS(3,15,1)=1,80,100),COLORGREEN,LINETHICK1;

QQ:=必卖=80;

B03:=((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)));

V1:=EMA(CLOSE,60)-EMA(CLOSE,300);

V2:=EMA(V1,300);

V3:=(CLOSE-(LOW,8))/((HIGH,8)-LLV(LOW,8))*100;

V4:=SMA(V3,2,1),NODRAW;

V5:=SMA(V4,2,1),NODRAW;

V6:=CLOSE/REF(CLOSE,3)>=1.1;

V7:=BACKSET(V6,3);

大涨:=(V7 AND COUNT(V7,3)=1);

DRAWICON(必买,L-0.16,11);

DRAWICON(大涨 AND 必买,L-0.16,9);

DRAWICON(大涨,L-0.18,1);

DRAWICON(QQ,H+0.1,6);



用了3年多的主图 适用于短线 抓涨停的好主图



神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论