神奇指标网
神奇指标网

通达信突破20均线 主图/选股源码贴图

浏览 5000次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-05

以下是通达信突破20均线 主图/选股源码贴图

股价突破20均线后回调洗盘,再次上攻后一般又一波涨幅。


 主图源码

M20:MA(C,20),COLORLIRED,DOTLINE;
 T1:=BARSLAST(CROSS(C>=M20,0.5));
 T2:=BARSLAST(CROSS(C<M20,0.5));
 T3:=SUMBARS(T1=0,2);
 ZF:=(C-REF(C,T1+1))/REF(C,T1+1)*100;
 HZF:=REF(HHV(ZF,T1+1),T2);
 DF:=(C-REF(C,T2+1))/REF(C,T2+1)*100;
 LDF:=LLV(DF,T2+1);
 L1:=LLV(L,T2+1);
 L2:=REF(L1,T3-1);
 AC:=COUNT(T2=0,T3)=1;
 AC1:=O<M20 AND C>=M20 AND HZF<15 AND LDF>-25 AND LDF<-10;
 AC2:=REF(T1,T2)>1 AND T2>1 AND MACD.DIF>MACD.DEA AND MACD.MACD>REF(HHV(MACD.DIF,2),1);
 AC3:=HSL<REF(HSL,T2) AND LLV(L,T2+1)>BOLL.LB*0.9 AND HHV(L,T2+1)<M20;
 AC4:=AMOUNT>REF(AMOUNT,1);
 XG:=AC AND AC1 AND AC2 AND AC3 AND AC4;
 DRAWICON(XG,L,1);

选股源码

M20:=MA(C,20);
 T1:=BARSLAST(CROSS(C>=M20,0.5));
 T2:=BARSLAST(CROSS(C<M20,0.5));
 T3:=SUMBARS(T1=0,2);
 ZF:=(C-REF(C,T1+1))/REF(C,T1+1)*100;
 HZF:=REF(HHV(ZF,T1+1),T2);
 DF:=(C-REF(C,T2+1))/REF(C,T2+1)*100;
 LDF:=LLV(DF,T2+1);
 L1:=LLV(L,T2+1);
 L2:=REF(L1,T3-1);
 AC:=COUNT(T2=0,T3)=1;
 AC1:=O<M20 AND C>=M20 AND HZF<15 AND LDF>-25 AND LDF<-10;
 AC2:=REF(T1,T2)>1 AND T2>1 AND MACD.DIF>MACD.DEA AND MACD.MACD>REF(HHV(MACD.DIF,2),1);
 AC3:=HSL<REF(HSL,T2) AND LLV(L,T2+1)>BOLL.LB*0.9 AND HHV(L,T2+1)<M20;
 AC4:=AMOUNT>REF(AMOUNT,1);
 XG:AC AND AC1 AND AC2 AND AC3 AND AC4;

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论