神奇指标网
神奇指标网

很好的短线 中线参考 无双波段风暴 副图指标

浏览 9350次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-05

以下是很好的短线 中线参考 无双波段风暴 副图指标

{无双波段风暴}

{改编 BY SHUHONG}

{背景}
DRAWGBK(C>0, RGB(1,1,1),RGB(1,1,1),0,'0',0);

{大机构MACD}
 DIFFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
 DEAAA:=EMA(DIFFF,9);
 MACD2:=2*(DIFFF-DEAAA);
 (CLOSE<0 AND CROSS(DIFFF,0),H*1.3),COLOR000080,NODRAW;
 (CLOSE<0 AND CROSS(MACD2,0),H*1.3),COLOR000080,NODRAW;
 (CLOSE<0 AND CROSS(0,DIFFF),H*1.3),COLOR808080,NODRAW;
 (CLOSE<0 AND CROSS(0,MACD2),H*1.3),COLOR808080,NODRAW;
 DU0:=CROSS(DIFFF,0);
 UD0:=CROSS(0,DIFFF);
 TDU0:=BARSLAST(DU0);
 TUD0:=BARSLAST(UD0);
 DU3:=REF(DU0,1);
 UD3:=REF(UD0,1);
 TDU3:=BARSLAST(DU3);
 TUD3:=BARSLAST(UD3);
 UDGLINE:=IF(TDU3<TUD3,REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3));
 JDU0:=REF(CLOSE,1)<=REF(UDGLINE,1) AND CLOSE>UDGLINE AND TDU0<TUD0;
 JUD0:=REF(CLOSE,1)>=REF(UDGLINE,1) AND CLOSE<UDGLINE AND TUD0<TDU0;
 JDU1:=JDU0 AND COUNT(JDU0,TDU0)=1;
 JUD1:=JUD0 AND COUNT(JUD0,TUD0)=1;
 JDU2:=JDU1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
 JUD2:=JUD1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
 JDU3:=JDU1 AND REF(BARSLAST(JUD1),1)>REF(BARSLAST(JDU1),1);
 JUD3:=JUD1 AND REF(BARSLAST(JUD1),1)<REF(BARSLAST(JDU1),1);
 BSLINE:=IF(BARSLAST(JDU2)<BARSLAST(JUD2),IF(REF(CROSS(0,MACD2),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS(0,MACD2),1)))),IF(REF(CROSS(MACD2,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD2,0),1)))));
 {}
 STICKLINE(MACD2>=0,0,MACD2,2,0),COLORYELLOW;{0轴上升}
STICKLINE(MACD2>=0 AND MACD2<REF(MACD2,1),0,MACD2,2,1),COLORCYAN;{0轴上跌}
STICKLINE(MACD2<0,0,MACD2,2,0),COLORCYAN;{0轴下跌}
STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,2,1),COLORYELLOW;{0轴下升}


 {包络均线—知博陋室交易系统副图指标(21)}
 0,DOTLINE,COLORGRAY;
 MID:=(7*CLOSE+LOW+OPEN+HIGH)/10;
 MA0:=MA(MID,40);
 MA1:=MA(MID,1);
 A1:=MA1-MA0;
 MA2:=MA(MID,2);
 A2:=MA2-MA0;
 MA3:=MA(MID,3);
 A3:=MA3-MA0;
 MA4:=MA(MID,4);
 A4:=MA4-MA0;
 MA5:=MA(MID,5);
 A5:=MA5-MA0;
 MA6:=MA(MID,6);
 A6:=MA6-MA0;
 MA7:=MA(MID,7);
 A7:=MA7-MA0;
 MA8:=MA(MID,8);
 A8:=MA8-MA0;
 MA9:=MA(MID,9);
 A9:=MA9-MA0;
 MA10:=MA(MID,10);
 A10:=MA10-MA0;
 MA11:=MA(MID,11);
 A11:=MA11-MA0;
 MA12:=MA(MID,12);
 A12:=MA12-MA0;
 MA13:=MA(MID,13);
 A13:=MA13-MA0;
 MA14:=MA(MID,14);
 A14:=MA14-MA0;
 MA15:=MA(MID,15);
 A15:=MA15-MA0;
 MA16:=MA(MID,16);
 A16:=MA16-MA0;
 MA17:=MA(MID,17);
 A17:=MA17-MA0;
 MA18:=MA(MID,18);
 A18:=MA18-MA0;
 MA19:=MA(MID,19);
 A19:=MA19-MA0;
 MA20:=MA(MID,20);
 A20:=MA20-MA0;
 MA21:=MA(MID,21);
 A21:=MA21-MA0;
 MA22:=MA(MID,22);
 A22:=MA22-MA0;
 MA23:=MA(MID,23);
 A23:=MA23-MA0;
 MA24:=MA(MID,24);
 A24:=MA24-MA0;
 MA25:=MA(MID,25);
 A25:=MA25-MA0;
 MA26:=MA(MID,26);
 A26:=MA26-MA0;
 MA27:=MA(MID,27);
 A27:=MA27-MA0;
 MA28:=MA(MID,28);
 A28:=MA28-MA0;
 MA29:=MA(MID,29);
 A29:=MA29-MA0;
 MA30:=MA(MID,30);
 A30:=MA30-MA0;
 MA31:=MA(MID,31);
 A31:=MA31-MA0;
 MA32:=MA(MID,32);
 A32:=MA32-MA0;
 MA33:=MA(MID,33);
 A33:=MA33-MA0;
 MA34:=MA(MID,34);
 A34:=MA34-MA0;
 MA35:=MA(MID,35);
 A35:=MA35-MA0;
 MA36:=MA(MID,36);
 A36:=MA36-MA0;
 MA37:=MA(MID,37);
 A37:=MA37-MA0;
 MA38:=MA(MID,38);
 A38:=MA38-MA0;
 MA39:=MA(MID,39);
 A39:=MA39-MA0;
 MA40:=MA(MID,40);
 A40:=MA40-MA0;
 LC:=(A6+A7+A8+A9+A10+A11+A12+A13+A14+A15+A16+A17+A18+A19+A20)/15,LINETHICK0;
 VAR1:=LC;
 VAR2:=REF(LC,1);
 VAR3:=VAR1>VAR2 AND REF(LC,1)<REF(LC,2);
 VAR4:=VAR1<VAR2 AND REF(LC,1)>REF(LC,2);
 {}
均线发散:STICKLINE(VAR1>VAR2,LC,REF(LC,1),3,0),COLORRED;
均线粘合:STICKLINE(VAR1<VAR2,LC,REF(LC,1),3,0),COLORGREEN;
 {}
 EMA5:MA(VAR1,5),COLORWHITE;
 EMA10:MA(VAR1,10),COLORYELLOW;

{DJG波段风暴}
DIFF:=EMA(CLOSE,21)-EMA(CLOSE,34);
 DEAA:=EMA(DIFF,8);
 MACDD:=8*(DIFF-DEAA);
 MARDD:=SMA(MACDD,2,1);
 {柱线形式}
STICKLINE(MACDD>MARDD,MACDD,MARDD,1.8,0),COLORMAGENTA;
 STICKLINE(MACDD<MARDD,MACDD,MARDD,1.8,0),COLORFF8000;
 {彩条形式}
 {DRAWBAND(MACDD,RGB(255,0,255),MARDD,RGB(0,128,255));}

{说明}
DRAWRECTREL(0,0,190,350,RGB(36,36,36));{矩形大小底色};
DRAWTEXT_FIX(C>0,0,0.03,0,' 洋红和天蓝柱线是DJG波段风暴指标,看短线;'),COLORGRAY;
 DRAWTEXT_FIX(C>0,0,0.13,0,' 红绿色柱线是知博包络均线指标,看中长线;'),COLORGRAY;
 DRAWTEXT_FIX(C>0,0,0.23,0,' 0轴上下柱线是DJG_MACD指标的柱线;'),COLORGRAY;


神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论