神奇指标网
神奇指标网

通达信资金强度黑马 副图源码

浏览 6678次浏览
标签: macd 缠论
来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-05

以下是通达信资金强度黑马 副图源码

ZLCM:=EMA(WINNER(CLOSE)*70,3);{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);{//散户筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;{//散户套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;{//主力控盘筹码比率}
ZCMZL:=MA(ZLCM+SHCM,13);{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);{//散户警戒}
ZZLJJ:=EMA(ZZLKP,89);{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);{//资金流入强度}
SH8:=EMA(ZSHTL,8);
 DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
 {散户套牢筹码}
STICKLINE(C>0,ZSHTL,ZZLKP,0,0),COLOREEEEEE;
 {散户筹码警戒}
STICKLINE(ZSHJJ>REF(ZSHJJ,1),ZSHTL,ZSHJJ,1,0),COLORAAAAAA;
 {主力控盘筹码}
STICKLINE(C>0,ZZLKP,0,0,0),COLORBLUE;
 {铸顶风险区}
STICKLINE(ZZLKP>75,ZZLKP,0,2,0),COLORFFFFFF;
 {顶部:(ZZLKP>75),COLORFFFFFF;}
 {主力筹码警戒}
STICKLINE(ZZLJJ>REF(ZZLJJ,1),ZZLKP,ZZLJJ,4,0),COLORRED;
 {筑底散兵坑}
STICKLINE(ZSHTL>=90,ZZLKP,0,5,0),COLOR66FFCC;
 {底部:(ZSHTL>=90),COLOR66FFCC;}
 {筹码总量上升}
IF(ZCMZL,ZCMZL>REF(ZCMZL,1),DRAWNULL),COLOR0066FF,LINETHICK1;
 {增量资金};
 {//------【数值显示】}
散户套牢系数:INTPART(ZSHTL),COLORYELLOW;
主力控盘系数:INTPART(ZZLKP),COLORCYAN;
资金流入强度:ZJLRQD,LINETHICK2,COLORRED;
市场筹码总量:INTPART(ZCMZL),COLORWHITE,NODRAW;
轴:50,COLORGREEN,DOTLINE,LINETHICK1;
 DRAWTEXT(CROSS(主力控盘系数,轴),轴+10,'高度控盘'),COLORYELLOW;
 {指标说明:资金流入强度下穿0轴,股票必抛};

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论