神奇指标网
神奇指标网

通达信百分等比尺 +黄金分割 + 斐波那契周期源码主图说明 )

浏览 7210次浏览
标签: 大盘 dmi
来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-05

以下是通达信百分等比尺 +黄金分割 + 斐波那契周期源码主图说明 )

又是一翻牛熊,由此得到这次的最牛股
 根据其涨幅作出,以近期最低点百分之十的递增作尺,用四种色彩分标四个区间。 (涨停价为尺码)
下跌同样以最高点的百之十,二十,三十----标尺码。
 另指标优化黄金分割,取当前屏的高低位分割。
 斐波那契周期也可在小周期正常显示无压缩。
 更多的优化,自我体会。


{高点 1 999 22
 低点 1 999 1}
GD:=CONST(FINDHIGH(H,0,高点*10,1));
DD:=CONST(FINDLOW(L,0,低点*10,1));
GT:=CONST(BARSLAST(GD=H))+1;
DT:=CONST(BARSLAST(DD=L))+1;
SH:=CONST(IF(GT=1,H,REF(H,GT-1)));
SL:=CONST(IF(DT=1,L,REF(L,DT-1)));
下跌周期:BARSLAST(GD=H),COLORWHITE,NODRAW;
下跌幅:IF(CURRBARSCOUNT<=GT,C/SH*100-100,DRAWNULL),NODRAW,COLORGREEN;
下跌均价:IF(CURRBARSCOUNT<=GT,SUM(AMOUNT,GT)/SUM(V,GT)/100,DRAWNULL),NODRAW,COLORLIGRAY;
跌换手%:IF(CURRBARSCOUNT<=GT,SUM(HSL.HSL,GT),DRAWNULL),COLORCYAN,NODRAW;
上涨周期:IF(CURRBARSCOUNT<=DT,BARSLAST(DD=L),DRAWNULL),COLORWHITE,NODRAW;
上涨幅:IF(CURRBARSCOUNT<=DT,C/SL*100-100,DRAWNULL),NODRAW,COLORRED;
上涨均价:IF(CURRBARSCOUNT<=DT,SUM(AMOUNT,DT)/SUM(V,DT)/100,DRAWNULL),NODRAW,COLORLIGRAY;
涨换手%:IF(CURRBARSCOUNT<=DT,SUM(HSL.HSL,DT),DRAWNULL),COLORLIMAGENTA,NODRAW;
星期:=VARCAT(VARCAT('(',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五','')))))),')');
日期:=VARCAT(VARCAT(VARCAT(VARCAT(VARCAT(VARCAT(VAR2STR(YEAR,0),'年'),VAR2STR(MONTH,0)),'月'),VAR2STR(DAY,0)),'日'),星期);
{黄金分割  普通 等系坐标}
DRAWRECTREL(990,2,998,188,RGB(0,150,180)),NOFRAME;
DRAWRECTREL(990,188,998,375,RGB(200,200,0)),NOFRAME;
DRAWRECTREL(990,375,998,491,RGB(100,200,0)),NOFRAME;
DRAWRECTREL(990,491,998,607,RGB(200,10,80)),NOFRAME;
DRAWRECTREL(990,607,998,794,RGB(150,0,0)),NOFRAME;
DRAWRECTREL(990,794,998,982,RGB(150,150,150)),NOFRAME;
DRAWKLINE(H,O,L,C);
DRAWTEXT_FIX(1,0.005,0.01,0,'云枫添外 2016/05/09'),COLORLIGRAY;
{斐波那契周期}
DRAWTEXT(CURRBARSCOUNT=GT-2 ,L,'3'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GT-4 ,L,'5'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GT-7 ,L,'8'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GT-12 ,L,'13'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GT-20 ,L,'21'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GT-33 ,L,'34 '),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GT-54 ,L,'55'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GT-88 ,L,'89'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GT-143 ,L,'144'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GT-232 ,L,'233'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=GT-376 ,L,'377'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=DT-2,H,'3'),DRAWABOVE,COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT-4,H,'5'),DRAWABOVE,COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT-7,H,'8'),DRAWABOVE,COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT-12,H,'13'),DRAWABOVE,COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT-20,H,'21'),DRAWABOVE,COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT-33,H,'34'),DRAWABOVE,COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT-54,H,'55'),DRAWABOVE,COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT-88,H,'89'),DRAWABOVE,COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT-143,H,'144'),DRAWABOVE,COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT-232,H,'233'),DRAWABOVE,COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT-376,H,'377'),DRAWABOVE,COLORRED;
{幅度尺}
A1:=ZTPRICE(REF(SL,1),0.1);
A2:=ZTPRICE(REF(A1,1),0.1);
A3:=ZTPRICE(REF(A2,1),0.1);
A4:=ZTPRICE(REF(A3,1),0.1);
A5:=ZTPRICE(REF(A4,1),0.1);
A6:=ZTPRICE(REF(A5,1),0.1);
A7:=ZTPRICE(REF(A6,1),0.1);
A8:=ZTPRICE(REF(A7,1),0.1);
A9:=ZTPRICE(REF(A8,1),0.1);
A10:=ZTPRICE(REF(A9,1),0.1);
A11:=ZTPRICE(REF(A10,1),0.1);
A12:=ZTPRICE(REF(A11,1),0.1);
A13:=ZTPRICE(REF(A12,1),0.1);
A14:=ZTPRICE(REF(A13,1),0.1);
A15:=ZTPRICE(REF(A14,1),0.1);
A16:=ZTPRICE(REF(A15,1),0.1);
A17:=ZTPRICE(REF(A16,1),0.1);
A18:=ZTPRICE(REF(A17,1),0.1);
A19:=ZTPRICE(REF(A18,1),0.1);
A20:=ZTPRICE(REF(A19,1),0.1);
A21:=ZTPRICE(REF(A20,1),0.1);
A22:=ZTPRICE(REF(A21,1),0.1);
A23:=ZTPRICE(REF(A22,1),0.1);
A24:=ZTPRICE(REF(A23,1),0.1);
A25:=ZTPRICE(REF(A24,1),0.1);
A26:=ZTPRICE(REF(A25,1),0.1);
A27:=ZTPRICE(REF(A26,1),0.1);
A28:=ZTPRICE(REF(A27,1),0.1);
A29:=ZTPRICE(REF(A28,1),0.1);
A30:=ZTPRICE(REF(A29,1),0.1);
A31:=ZTPRICE(REF(A30,1),0.1);
A32:=ZTPRICE(REF(A31,1),0.1);
STICKLINE(CURRBARSCOUNT=DT,SH,SL,0,-1),COLORRED;
STICKLINE(CURRBARSCOUNT=GT,SH,SL,0,-1),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=DT ,(SL+A1)/2,日期),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT ,GD*0.97,日期),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.1,'一10%'),COLORBLUE;
DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.15,'一15%'),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.2,'一20%'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.3,'一30%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.4,'一40%'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.5,'一50%'),COLORRED;
DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.6,'一60%'),COLORLIMAGENTA;
DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.7,'一70%'),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.8,'一80%'),COLORWHITE;
DRAWTEXT(CURRBARSCOUNT=GT,SH-SH*0.9,'一90%'),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=DT,A1,STRCAT('一 ',CON2STR(A1,2)));
DRAWTEXT(CURRBARSCOUNT=DT,A2,STRCAT('一 ',CON2STR(A2,2)));
DRAWTEXT(CURRBARSCOUNT=DT,A3,STRCAT('一 ',CON2STR(A3,2)));
DRAWTEXT(CURRBARSCOUNT=DT,A4,STRCAT('一 ',CON2STR(A4,2)));
DRAWTEXT(CURRBARSCOUNT=DT,A5,STRCAT('一 ',CON2STR(A5,2)));
DRAWTEXT(CURRBARSCOUNT=DT,A6,STRCAT('一 ',CON2STR(A6,2)));
DRAWTEXT(CURRBARSCOUNT=DT,A7,STRCAT('一 ',CON2STR(A7,2)));
DRAWTEXT(CURRBARSCOUNT=DT,A8,STRCAT('一 ',CON2STR(A8,2)));
DRAWTEXT(CURRBARSCOUNT=DT,A9,STRCAT('一 ',CON2STR(A9,2))),COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT,A10,STRCAT('一 ',CON2STR(A10,2))),COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT,A11,STRCAT('一 ',CON2STR(A11,2))),COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT,A12,STRCAT('一 ',CON2STR(A12,2))),COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT,A13,STRCAT('一 ',CON2STR(A13,2))),COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT,A14,STRCAT('一 ',CON2STR(A14,2))),COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT,A15,STRCAT('一 ',CON2STR(A15,2))),COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT,A16,STRCAT('一 ',CON2STR(A16,2))),COLORRED;
DRAWTEXT(CURRBARSCOUNT=DT,A17,STRCAT('一 ',CON2STR(A17,2))),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,A18,STRCAT('一 ',CON2STR(A18,2))),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,A19,STRCAT('一 ',CON2STR(A19,2))),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,A20,STRCAT('一 ',CON2STR(A20,2))),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,A21,STRCAT('一 ',CON2STR(A21,2))),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,A22,STRCAT('一 ',CON2STR(A22,2))),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,A23,STRCAT('一 ',CON2STR(A23,2))),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,A24,STRCAT('一 ',CON2STR(A24,2))),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=DT,A25,STRCAT('一 ',CON2STR(A25,2))),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=DT,A26,STRCAT('一 ',CON2STR(A26,2))),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=DT,A27,STRCAT('一 ',CON2STR(A27,2))),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=DT,A28,STRCAT('一 ',CON2STR(A28,2))),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=DT,A29,STRCAT('一 ',CON2STR(A29,2))),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=DT,A30,STRCAT('一 ',CON2STR(A30,2))),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=DT,A31,STRCAT('一 ',CON2STR(A31,2))),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=DT,A32,STRCAT('一 ',CON2STR(A32,2))),COLORGREEN;

 

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论