神奇指标网
神奇指标网

通达信突破前高主图指标 源码 倍量突破 涨停突破 跳空突破选股

浏览 9809次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-05

以下是通达信突破前高主图指标 源码 倍量突破 涨停突破 跳空突破选股

{突破前高线}
VAR1:=CLOSE-LOW;
 VAR2:=HIGH-LOW;
 VAR3:=CLOSE-HIGH;
 VAR4:=IF(HIGH>LOW,(VAR1/VAR2+VAR3/VAR2)*VOL,0);
 HPTP:=SUM(VAR4,10)/10000,COLORSTICK;
 TKXL:=-1;
 XVYO:=UPNDAY(TKXL,1),NODRAW;
 G:=MA(C,5);
 D:=MA(C,10);
 HH:=REF(H,5)=HHV(H,11);
 LL:=REF(L,5)=LLV(L,11);
 FG01:=BACKSET(HH,6)>BACKSET(HH,5);
 FD01:=BACKSET(LL,6)>BACKSET(LL,5);
 FG02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND G>D,FG01,
 IF(BARSLAST(FD01)>BARSLAST(FG01),FG01,0));
 FD02:=IF(BARSLAST(FG01)=BARSLAST(FD01) AND D>G,FD01,
 IF(BARSLAST(FG01)>BARSLAST(FD01),FD01,0));
 FG0:=FG02 AND H=HHV(H,BARSLAST(FD02));
 FD0:=FD02 AND L=LLV(L,BARSLAST(FG02));
 GQ:=L>REF(H,1) AND DAY!=REF(DAY,1);
 DQ:=H<REF(L,1) AND DAY!=REF(DAY,1);
 FGH:=REF(H,BARSLAST(FG0));
 FGL:=REF(L,BARSLAST(FG0));
 FGH1:=REF(H,BARSLAST(FG0)+1);
 FGL1:=REF(L,BARSLAST(FG0)+1);
 FGL2:=REF(L,BARSLAST(FG0)+2);
 FDH2:=REF(H,BARSLAST(FD0)+2);
 FDH:=REF(H,BARSLAST(FD0));
 FDL:=REF(L,BARSLAST(FD0));
 FDH1:=REF(H,BARSLAST(FD0)+1);
 FDL1:=REF(L,BARSLAST(FD0)+1);
 FGZL:=IF(FGH1<FGL,FGL,IF(FGL<=FGL1,FGL2,FGL1));
 FDZH:=IF(FDL1>FDH,FDH,IF(FDH>=FDH1,FDH2,FDH1));
 FG1:=FGH>FDZH AND FG0;
 FD1:=FDL<FGZL AND FD0;
 FG:=FG1 AND FGH>FDH AND FGL>FDL AND FGL1>FDL;
 FD:=FD1 AND FDL<FGL AND FDH<FGH AND FDH1<FGH;
 BH0:=(H<=REF(H,1) AND L>=REF(L,1)) OR (H>=REF(H,1) AND L<=REF(L,1));
 BHG:=COUNT(BH0,BARSLAST(FD0));
 BHD:=COUNT(BH0,BARSLAST(FG0));
 BGQ:=COUNT(GQ,BARSLAST(FD0));
 BDQ:=COUNT(DQ,BARSLAST(FG0));
 BK0:=IF(BHG>0,BHG+2,IF(BHD,BHD+2,3));
 BK:=IF(BGQ,BK0-BGQ,IF(BDQ,BK0-BDQ,BK0));
 G1X:=(FG AND BARSLAST(FD)>BK),NODRAW;
 D1X:=(FD AND BARSLAST(FG)>BK),NODRAW;
 G1:=(FG0 AND REF(H,BARSLAST(FG0))>=REF(H,BARSLAST(G1X)) AND BARSLAST(D1X)>BARSLAST(G1X))
 OR (FG1 AND COUNT(GQ,BARSLAST(FD1))>0 AND REF(H,BARSLAST(FG1))>REF(H,BARSLAST(G1X)));
 {W:=IF(DATE<1201231,C,DRAWNULL);}
 D1:=(FD0 AND REF(L,BARSLAST(FD0))<=REF(L,BARSLAST(D1X)) AND BARSLAST(G1X)>BARSLAST(D1X))
 OR (FD1 AND COUNT(DQ,BARSLAST(FG1))>0 AND REF(L,BARSLAST(FD1))<REF(H,BARSLAST(D1X)));
 G1H:=IF(BARSLAST(D1)>BARSLAST(G1),REF(H,BARSLAST(G1)),REF(H,BARSLAST(D1))),NODRAW;
 D1L:=IF(BARSLAST(G1)>BARSLAST(D1),REF(L,BARSLAST(D1)),REF(L,BARSLAST(G1))),NODRAW;
 G2:=G1 AND H=HHV(G1H,BARSLAST(D1)+1) AND H>REF(H,1) AND BARSLAST(D1)>BARSLAST(G1);
 D2:=D1 AND L=LLV(D1L,BARSLAST(G1)+1) AND L<REF(L,1) AND BARSLAST(G1)>BARSLAST(D1);
 NN:=G2 OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2))
 AND BARSLAST(D2)>BARSLAST(G2));
 UU:=D2 OR (FD0 AND REF(L,BARSLAST(FD0))<REF(L,BARSLAST(D2))
 AND BARSLAST(G2)>BARSLAST(D2));
找顶线:DRAWLINE(NN,H,REF(NN,1),REF(H,1),1),COLORGREEN,DOTLINE;
找底线:DRAWLINE(UU,L,REF(UU,1),REF(L,1),1),COLORRED,DOTLINE;
 ZT:=C=ZTPRICE(REF(C,1),0.1);
 STICKLINE(ZT,C,O,2,0),COLORMAGENTA;

DRAWICON(CROSS(C,找顶线),找顶线*1.01,34);

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论