神奇指标网
神奇指标网

通达信九金叉共振 捕捉大牛股 主图副图/选股预警 源码

浏览 8523次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-13

以下是通达信九金叉共振 捕捉大牛股  主图副图/选股预警 源码


通达信指标公式源码概况:


指标类别: 通达信指标公式


授权方式: 免费版


指标评级: ★★★★★★


指标分类: 策略


画线方法: 主图

共振主图源码

日K:="KDJ.K#DAY"(9,3,3);
日D:="KDJ.D#DAY"(9,3,3);
日DIF:="MACD.DIF#DAY"(12,26,9);
日DEA:="MACD.DEA#DAY"(12,26,9);
日RSI:="RSI.RSI1#DAY"(9);
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
周DIF:="MACD.DIF#WEEK"(12,26,9);
周DEA:="MACD.DEA#WEEK"(12,26,9);
周RSI:="RSI.RSI1#WEEK"(9);
月K:="KDJ.K#MONTH"(9,3,3);
月D:="KDJ.D#MONTH"(9,3,3);
月DIF:="MACD.DIF#MONTH"(12,26,9);
月DEA:="MACD.DEA#MONTH"(12,26,9);
月RSI:="RSI.RSI1#MONTH"(9);
X1:=日K>日D;
X2:=日DIF>日DEA;
X3:=日RSI>50;
X4:=周K>周D;
X5:=周DIF>周DEA;
X6:=周RSI>50;
X7:=月K>月D;
X8:=月DIF>月DEA;
X9:=月RSI>50;
黑马初显:=X1 AND X2 AND X3 AND X4 AND X5 AND X6 AND X7 AND X8 AND X9;
XG1:=黑马初显,COLORWHITE;
共振:XG1 AND REF(XG1,1)=0,NODRAW;
DRAWICON(共振,L*0.99,9);

 

{九金叉共振副}
DD11:0.95,COLOR5C4033;
DD22:2,COLOR8FBC8F;
-1,COLOR333333;
{KDJ日金}
日K:="KDJ.K#DAY"(9,3,3);
日D:="KDJ.D#DAY"(9,3,3);
STICKLINE(日K>日D,2,10,3,0),COLOR5C4033 ,LINETHICK2;
STICKLINE(日K<日D,2,10,3,0),COLORBLACK ,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,4,' 日K>日D'),COLORFFFFFF;
{MACD日金}
日DIF:="MACD.DIF#DAY"(12,26,9);
日DEA:="MACD.DEA#DAY"(12,26,9);
STICKLINE(日DIF>日DEA,12,20,3,0),COLOR5C4033,LINETHICK2;
STICKLINE(日DIF<日DEA,12,20,3,0),COLORBLACK  ,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,16,' 日M日DIF>日DEA'),COLORFFFFFF;
{RSI日}
日RSI:="RSI.RSI1#DAY"(9);
STICKLINE(日RSI>50,22,30,3,0),COLOR5C4033,LINETHICK2;
STICKLINE(日RSI<50,22,30,3,0),COLORBLACK  ,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,26,' 日RSI>50'),COLORFFFFFF;
{KDJ周金}
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
STICKLINE(周K>周D,32,40,3,0),COLOR5C4033,LINETHICK2;
STICKLINE(周K<周D,32,40,3,0), COLORBLACK ,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,36,' 周K'),COLORFFFFFF;
{MACD周金}
周DIF:="MACD.DIF#WEEK"(12,26,9);
周DEA:="MACD.DEA#WEEK"(12,26,9);
STICKLINE(周DIF>周DEA,42,50,3,0),COLOR5C4033,,LINETHICK2;
STICKLINE(周DIF<周DEA,42,50,3,0),COLORBLACK ,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,46,' 周M'),COLORFFFFFF;
{RSI周}
周RSI:="RSI.RSI1#WEEK"(9);
STICKLINE(周RSI>50,52,60,3,0),COLOR5C4033,LINETHICK2;
STICKLINE(周RSI<50,52,60,3,0),COLORBLACK ,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,56,' 周R'),COLORFFFFFF;
{KDJ月金}
月K:="KDJ.K#MONTH"(9,3,3);
月D:="KDJ.D#MONTH"(9,3,3);
STICKLINE(月K>月D,62,70,3,0),COLOR5C4033,LINETHICK2;
STICKLINE(月K<月D,62,70,3,0),COLORBLACK ,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,66,' 月K'),COLORFFFFFF;
{MACD月金}
月DIF:="MACD.DIF#MONTH"(12,26,9);
月DEA:="MACD.DEA#MONTH"(12,26,9);
STICKLINE(月DIF>月DEA,72,80,3,0),COLOR5C4033,LINETHICK2;
STICKLINE(月DIF<月DEA,72,80,3,0),COLORBLACK ,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,76,' 月M'),COLORFFFFFF;
{RSI月}
月RSI:="RSI.RSI1#MONTH"(9);
STICKLINE(月RSI>50,82,90,3,0),COLOR5C4033,LINETHICK2;
STICKLINE(月RSI<50,82,90,3,0),COLORBLACK ,LINETHICK2;
DRAWTEXT(ISLASTBAR=1,86,' 月R'),COLORFFFFFF;
X1:=日K>日D;
X2:=日DIF>日DEA;
X3:=日RSI>50;
X4:=周K>周D;
X5:=周DIF>周DEA;
X6:=周RSI>50;
X7:=月K>月D;
X8:=月DIF>月DEA;
X9:=月RSI>50;
共振:=X1 AND X2 AND X3 AND X4 AND X5 AND X6 AND X7 AND X8 AND X9;
STICKLINE(共振,0,5,1,0),COLORBLUE;
STICKLINE(共振 AND C/REF(C,1)>1.095,0,5,2,0),COLOR8FBC8F;
STICKLINE(共振 AND C/REF(C,1)>1.095,0,5,1,0),COLORRED;
DRAWTEXT(共振,1.90,'振'),COLORWHITE;
 

共振第1天源码

日K:="KDJ.K#DAY"(9,3,3);
日D:="KDJ.D#DAY"(9,3,3);
日DIF:="MACD.DIF#DAY"(12,26,9);
日DEA:="MACD.DEA#DAY"(12,26,9);
日RSI:="RSI.RSI1#DAY"(9);
周K:="KDJ.K#WEEK"(9,3,3);
周D:="KDJ.D#WEEK"(9,3,3);
周DIF:="MACD.DIF#WEEK"(12,26,9);
周DEA:="MACD.DEA#WEEK"(12,26,9);
周RSI:="RSI.RSI1#WEEK"(9);
月K:="KDJ.K#MONTH"(9,3,3);
月D:="KDJ.D#MONTH"(9,3,3);
月DIF:="MACD.DIF#MONTH"(12,26,9);
月DEA:="MACD.DEA#MONTH"(12,26,9);
月RSI:="RSI.RSI1#MONTH"(9);
X1:=日K>日D;
X2:=日DIF>日DEA;
X3:=日RSI>50;
X4:=周K>周D;
X5:=周DIF>周DEA;
X6:=周RSI>50;
X7:=月K>月D;
X8:=月DIF>月DEA;
X9:=月RSI>50;
黑马初显:=X1 AND X2 AND X3 AND X4 AND X5 AND X6 AND X7 AND X8 AND X9;
XG1:=黑马初显,COLORWHITE;
XG:XG1 AND REF(XG1,1)=0;

通达信九金叉共振 捕捉大牛股  主图副图/选股预警 源码

通达信九金叉共振 捕捉大牛股  主图副图/选股预警 源码

 

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论