神奇指标网

通达信MACD EXPMA共振主图 幅图 选股 思路 源码

浏览 3921次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-30

以下是通达信MACD EXPMA共振主图 幅图 选股 思路 源码

MACD EXPMA共振主图 幅图 选股 思路 源码

再次整合几个指标,可以的,我现在是这样安排的,早期已经整合20个指标,我分别放在幅图的两个窗口,注意观察信号出现的准确性和指标的共振性。发现有许多牛股我们20个指标都管它不住,还是漏选了,至于选股,牛市来了,建议大家操盘不要太频繁,拿稳一只票,上升就别动,整盘  调整50%仓位高抛低吸(个人意见)。主图也不要太华丽了,有附图监视信号就可以了。所以  今天再次从另一角度继续寻找一些漏选的牛股。前期很多都是形态  走势  今天写个指标共振吧。
指标简单了,MACD金叉  收盘价上穿8日均线共振,PSY(心理线指标)金叉多日。因为PSY变化频繁,我就选他上次金叉后距今天时间大于15天,意思就等他近期再次金叉。

主图
E8:EXPMA(C,8),COLORLIRED;
P:=PSY.PSY;
MP:=PSY.PSYMA;
T:=BARSLAST(CROSS(P,MP));
T8:=BARSLAST(CROSS(C,E8));
TM:=BARSLAST(CROSS(MACD.DIF,MACD.DEA));
XG1:=T>15 AND T8=0 AND TM=0;
STICKLINE(XG1,L,H,0,0),COLORFF0088;
STICKLINE(XG1,CLOSE,OPEN,3,0),COLORFF0011;
STICKLINE(XG1,CLOSE,OPEN,2.8,0),COLORFF0022;
STICKLINE(XG1,CLOSE,OPEN,2.5,0),COLORFF0033;
STICKLINE(XG1,CLOSE,OPEN,2.2,0),COLORFF0044;
STICKLINE(XG1,CLOSE,OPEN,1.7,0),COLORFF0055;
STICKLINE(XG1,CLOSE,OPEN,1.2,0),COLORFF0066;
STICKLINE(XG1,CLOSE,OPEN,0.7,0),COLORFF0077;
STICKLINE(XG1,CLOSE,OPEN,0.2,0),COLORFF0088;
DRAWICON(XG1,L*0.94,7);
幅图


E8:=EXPMA(C,8);
P:=PSY.PSY;
MP:=PSY.PSYMA;
T:=BARSLAST(CROSS(P,MP));
T8:=BARSLAST(CROSS(C,E8));
TM:=BARSLAST(CROSS(MACD.DIF,MACD.DEA));
XG1:=T>15 AND T8=0 AND TM=0;
STICKLINE(XG1,0,8,3,0),COLORFF0011;
STICKLINE(XG1,0,8,2.8,0),COLORFF0022;
STICKLINE(XG1,0,8,2.5,0),COLORFF0033;
STICKLINE(XG1,0,8,2.2,0),COLORFF0044;
STICKLINE(XG1,0,8,1.7,0),COLORFF0055;
STICKLINE(XG1,0,8,1.2,0),COLORFF0066;
STICKLINE(XG1,0,8,0.7,0),COLORFF0077;
STICKLINE(XG1,0,8,0.2,0),COLORFF0088;


选股

E8:=EXPMA(C,8);
P:=PSY.PSY;
MP:=PSY.PSYMA;
T:=BARSLAST(CROSS(P,MP));
T8:=BARSLAST(CROSS(C,E8));
TM:=BARSLAST(CROSS(MACD.DIF,MACD.DEA));
T>15 AND T8=0 AND TM=0;

MACD EXPMA共振主图 幅图 选股 思路 源码

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论