神奇指标网
  • 神奇指标

    通达信上下界限boll改编主图

    通达信上下界限boll改编主图技术指标只是作为一种分析方法,可以辅佐自己的判断,帮助构建自己的交易系统,切勿盲目相信一个技术指标且有的技术指标已经被创造出来几十年了,或许有的已经不适用了,本指标仅探讨学习,抛砖引玉布林线利用统计原理,求出价格的标准差及其信赖区间,从而确定价格的波动范围及未来走势,利用波带显示价格的安全高低价位,因而也被称为布林带。其上下限范围不固定,随价格的滚动而变化。布林指标属路径指标,价格波动在上限和下限的区间之内,这条带状区的宽窄,随着价格波动幅度的大小而变化,价格涨跌幅度加大时,带状区变宽,涨跌幅度狭小盘整时,带状区则变窄。强弱分界: MA(CLOSE,27),COLOR0000FF,,LINETHICK2; 上极限: 强弱分界+3*STD(CLOSE,21),COLORFF0080; 下极限:强弱分界-2.9*STD(CLOSE,21),COLOR4080FF; 风标:EMA((EMA(CLOSE,3)+EMA(CLOSE,5)+EMA(CLOSE,8)+EMA(CLOSE,13))/4,2),COLOR00FF00; VAR1:=(2*CLOSE+HIGH+LOW)/4; VAR2:=LLV(LOW,34); VAR3:=HHV(HIGH,34); VAR4:=EMA((VAR1-VAR2)/(VAR3-VAR2)*100,13); VAR5:=REF(CLOSE,1); VAR6:=SMA(MAX(CLOSE-VAR5,0),7,1)/SMA(ABS(CLOSE-VAR5),7,1)*100; VAR7:=EMA((CLOSE-LLV(CLOSE,55))/(HHV(CLOSE,55)-LLV(LOW,55))*100,7); VAR8:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*100,5); VAR9:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*100,20); VAR10:=FILTER(CROSS(VAR8,VAR9) AND VAR9<30 ,5)AND VAR7>REF(VAR7,1)AND C<强弱分界 AND C>O AND VAR4>REF(VAR4,1); DRAWICON(REF(L,1)<下极限 AND L>下极限 AND C>O OR VAR10,下极限 ,10); DRAWTEXT(VAR10,下极限,'下买'); DRAWICON(FILTER(REF(H,1)<风标 AND CROSS(C,风标) AND 风标>REF(风标,1) AND 风标<强弱分界,3)AND C>O,L,1); DRAWICON(REF(H,1)>上极限 AND H<上极限 AND L<风标 AND C<O,上极限 ,11); DRAWICON( CROSS(80,VAR6)AND L<风标,H*1.03,5); DRAWTEXT(CROSS(H,上极限)AND L>风标 AND C/REF(C,10)>1.2 AND VAR8>80,H+0.12,'上卖'),COLOR00FFFF;

    浏览7242次浏览
    2024-05-08 16:50
  • 神奇指标

    通达信MA均线金叉三角画线

    通达信MA均线金叉三角画线MA 均线的实用性不必多说,大道至简。该指标简单实用还可以搭配其他主图指标一起使用,精确画出5日线后出现金叉区域,也方便判断后续周期均线的走向。1、所有的上涨,最低价都是围绕5均线,向上慢慢抬高的;2、所有的下跌,最高价都是围绕5均线,向下慢慢降低的;3、5均线向上或者向下改变实际取决于第一天和第六天收盘价的高低4、如果第六天收盘价比第一天低,那么5均线会向下拐头;5、如果第六天收盘价比第一天高,那么5均线会向上运动;6、如果你能够提前预判明天5均线向上,那么今天在5均线下的价格,都是买点;7、如果你能够提前预判明天5均线向下,那么今天在5均线上的价格,都是卖点;M5:=MA(C,5); M10:=MA(C,10); M20:=MA(C,20); MM:=MIN(M5,M20); MM2:=MIN(M10,M20); HM:=MAX(M5,M20); HM2:=MAX(M10,M20); DRAWBAND(MM,RGB(255,0,0),MM2,0); DRAWBAND(HM2,RGB(0,255,255),HM,0); DRAWKLINE(H,O,L,C); MA5:MA(C,5); MA10:MA(C,10); MA20:MA(C,20); M60:=MA(C,60);

    浏览7664次浏览
    2024-04-10 17:26
  • 神奇指标

    通达信金波指示主图源码

    通达信金波指示主图源码本指标使用方便可主图可副图,主要看金色带的转变后形成金叉可抄底。一只个股走强往往经过几个阶段:低位换手分歧,一致,再分歧,再一致。分歧,一致为一个循环。何为分歧,即场内资金和筹码对后市预期的不一致,买盘看高一线,而卖盘则不看好个股。这个时候需要通过换手消化掉分歧,当量能足够,即换手足够后,说明场内不看好个股后市的筹码都卖给了场外看好个股后市的资金,两方交易后,这只股票的持筹码的人通通看好后市,只有这样的筹码结构,拉升是最容易的。而持筹码的人通通看好后市时。称为一致,此时拉升是阻力最小方向。一只个股往往在拉升后的第一个分歧区,不能有效的承接场内筹码的抛压,淡出人们视线。而有些个股则在分歧区顺利完成换手,良好的承接没有破坏股价形态,后市大概率走出一波 上攻。HR:=HHV(HIGH,55); HRY:=LLV(LOW,55); HRY11:=HR*HRY; HRY33:SQRT(HRY11),COLORGREEN,LINETHICK2; IF(C>HRY33 AND HRY33 >=REF(HRY33 ,1), HRY33 ,DRAWNULL),LINETHICK2,COLORRED; WLT1:=EMA(C,3); WLT2:=EMA(C,5); WLT3:=EMA(WLT2,5); DRAWBAND(WLT1,RGB(255,255,0),WLT2,RGB(0,0,220)); X1:=(C+L+H)/3; BB5:=ATAN(EMA(X1,7)-REF(EMA(X1,7),1))*3.1416*10; EMA3:=EMA(C,3); DRAWTEXT(FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10), LOW*0.99,'★∠45'),COLORFFFFFF; TT:=FILTER(BB5>1 AND EMA(X1,7)>REF(EMA(X1,7),1),10); MM:=WLT1>REF(WLT1,1) AND REF(WLT1,1)<REF(WLT1,2) ; GG1:=crOSS(WLT1,WLT2); 超买:=MA(C,10)*IF(CAPITAL=0,1.04,1.1),POINTDOT,COLORGREEN,LINETHICK2; 超卖:=MA(C,10)*IF(CAPITAL=0,0.95,0.9),POINTDOT,COLORRED,LINETHICK2; TEND:EMA(((SLOPE(CLOSE,21) * 20) + CLOSE),42),POINTDOT,COLORFF00FF,LINETHICK4; DD:=TEND>REF(TEND,1) AND REF(TEND,1) >REF(TEND,2); GG2:=CROSS(WLT1,TEND); HRY1:=LLV(LOW,55); HRY2:=HHV(HIGH,21); GG3:=C<HRY2*0.8 AND C>HRY33; JJ1:=C<HRY1*1.62; TJ1:=GG1; TJ2:=GG2 AND JJ1; TJ3:=GG1 AND GG3 ; XG:=TJ1 OR TJ3 ; DRAWICON(XG,LOW*0.97,23); STICKLINE(XG,C,O,4,0),COLOR009999; STICKLINE(XG,C,O,3,0),COLOR00BBBB; STICKLINE(XG,C,O,1.5,0),COLOR00DDDD; STICKLINE(XG,C,O,0.3,0),COLOR00FFFF; SAL1:=HIGH>超买; SAL2:=C<O AND (O-C)/C>0.03; QQ:= C<WLT2; QQ1:=CROSS(WLT2,WLT1); QQ3:=HIGH>HRY1*1.38; SAL01:= SAL1 AND SAL2 AND QQ AND QQ3; SAL02:=QQ3 AND QQ1; SAL:=SAL01 OR SAL02; DRAWICON(SAL,HIGH*1.03,15); STICKLINE(SAL,C,O,4,0),COLOR009900; STICKLINE(SAL,C,O,3,0),COLOR00BB00; STICKLINE(SAL,C,O,1.5,0),COLOR00DD00; STICKLINE(SAL,C,O,0.3,0),COLOR00FF00; GET:ZIG(3,5),COLORFFFFFF; PL5:=ZIG(3,5); EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3); EX1:=ZIG(3,5)<REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)>=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3); PL10:=ZIG(3,10); EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3); EX2:=ZIG(3,10)<REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)>=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3); PL20:=ZIG(3,20); EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3); EX3:=ZIG(3,20)<REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)>=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3); PL40:=ZIG(3,40); 走强1:=BARSLAST(PL5<REF(PL5,1)); 走弱1:=BARSLAST(PL5>REF(PL5,1)); 走强2:=BARSLAST(PL10<REF(PL10,1)); 走弱2:=BARSLAST(PL10>REF(PL10,1)); 走强3:=BARSLAST(PL20<REF(PL20,1)); 走弱3:=BARSLAST(PL20>REF(PL20,1)); ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0); ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0); DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0); DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0); ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0); ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0); DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0); DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0); DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'(A)'),COLORFFFF00; DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'(B)'),COLORFF00FF; DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'(C)'),COLOR0000FF; DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'⑴'),COLOR0000FF; DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'⑵'),COLOR0000FF; DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'⑶'),COLOR0000FF; DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'⑷'),COLOR0000FF; DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'⑸'),COLOR0000FF; DRAWTEXT(EN2 AND DTJZ10=1,L*0.93,'Ⅰ'),COLORFF00FF; DRAWTEXT(EX2 AND DTJD10=2,H*1.05,'Ⅱ'),COLORFFFF00; DRAWTEXT(EN3 AND ZTJZ10=1,L*0.93,'Ⅲ'),COLOR0000FF; DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.03,'①'),LINETHICK3,COLOR00FFFF; DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.95,'②'),LINETHICK3,COLOR00FFFF; DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.03,'③'),LINETHICK3,COLOR00FFFF; DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.95,'④'),LINETHICK3,COLOR00FFFF; WLT11:=EN1 AND DTJZ5=1; WLT22:=EN2 AND ZTJZ5=1; WLT33:=WLT11 OR WLT22; WLT01:=EN2 AND DTJZ10=1; WLT02:=EN3 AND ZTJZ10=1; WLT03:=WLT01 OR WLT02; WLT:=WLT33 AND WLT03;

    浏览1876次浏览
    2024-03-22 14:45
  • 神奇指标

    通达信支撑压力自动画线

    通达信支撑压力自动画线每一次风格的切换都要交很多学费,因为思维还受到过去风格的绑架,没有认同这种变化,而当认同之后,还需要学新的风格的玩法,以为自己懂了,实际还是没有抓到根本,继续交学费。本质还是没有看清最强赚钱效应的核心,没有无时无刻的紧紧跟随最强赚钱效应,没有完全按照市场最强表现进行客观的、无我的分析。而是被一些表面的、非核心的表现、甚至自我操作的盈亏心理占据,这里面心态占据很大原因,都知道跟随最强赚钱效应,但是因为主观的心态,会建立不客观的预期,会主观的认定市场应该怎么走,但市场是不以个人的意志为转移的,是会超预期或者不及预期的,当市场和自己预判的不一样,需要以市场为准,而不是完全不顾及市场的表现,强行按照按照自己的预判操作。介绍:根据函数返回数据,判断当前与历史价位的位置,自动画出延迟线对应压力位和支撑位。并且识别当日K线变化值添加对应颜色识别。可与其他主图指标共同使用,有其他影响主图K线的语句需要删除后共同使用。N:=5; STICKLINE(C>O,O,C,3,1),COLORRED; STICKLINE(C>O,H,C,0,0),COLORRED; STICKLINE(C>O,O,L,0,0),COLORRED; STICKLINE(C<O,O,C,3,1),COLORFF901E; STICKLINE(C<O,H,O,0,0),COLORFF901E; STICKLINE(C<O,C,L,0,0),COLORFF901E; STICKLINE(C=O,O,C,3,1),COLORLIGRAY; STICKLINE(C=O,H,L,0,0),COLORLIGRAY; TY1:=H; A1:=REF(TY1,N)=HHV(TY1,2*N+1),NODRAW; B1:=FILTER(A1,N),NODRAW; C1:=BACKSET(B1,N+1),NODRAW; HD1:=FILTER(C1,N),NODRAW; 前高:REF(H,BARSLAST(HD1)),COLORYELLOW,POINTDOT; TY2:=L; A2:=REF(TY2,N)=LLV(TY2,2*N+1),NODRAW; B2:=FILTER(A2,N),NODRAW; C2:=BACKSET(B2,N+1),NODRAW; HD2:=FILTER(C2,N),NODRAW; 前低:REF(L,BARSLAST(HD2)),COLORGREEN,POINTDOT; 前低起点:=TFILTER(BACKSET(L>前低,BARSLAST(C2)+2),L<=前低,1); 初阴胜阳:=C<=O AND REF(C,1)>REF(O,1) AND V>REF(V,1),NODRAW; ZQ1:=BARSLAST(初阴胜阳); FZ1:=BACKSET(前低,ZQ1); STICKLINE(初阴胜阳,O,C,3,0),COLOR00FF7F; STICKLINE(初阴胜阳,H,L,0,0),COLOR00FF7F; 初阳胜阴:=C>O AND REF(C,1)<REF(O,1) AND V>REF(V,1),NODRAW; ZQ2:=BARSLAST(初阳胜阴); FZ2:=BACKSET(前低,ZQ2); STICKLINE(初阳胜阴,O,C,3,0),COLORLIRED; STICKLINE(初阳胜阴,L,H,0,0),COLORLIRED; 高:=MAX(C,O); 低:=MIN(C,O); DRAWLINE(前低起点,MIN(O,C),L>前低 AND (初阴胜阳 OR 初阳胜阴),IF(C>=O,高*0.999,IF(C=O,C*0.999,低*1.001)),1),COLORWHITE; DRAWLINE(前低起点,MIN(O,C),L>前低,IF(C>O,高*0.999,IF(C=O,C*0.999,低*1.001)),1),COLORWHITE,DOTLINE;

    浏览2189次浏览
    2024-02-23 17:31
  • 神奇指标

    通达信实体变色K线参考主图

    通达信实体变色K线参考主图市场是永远不会变的,经历过2015年或2018年行情的朋友应该都知道,当时还有比这更难的行情,现在所发生的一切都是都是曾经的缩影,未来也会再发生。市场不变的逻辑是基于人性的不变,熊市刚开始的时候,热点尚且具备赚钱效应,交易者还是会不遗余力地挖掘可能产生赚钱效应的地方,随着市场的下跌,部分资金因为赚不到钱开始进入休息,随着行情的缩量,也越来越多的资金休息了,市场进入恶性循环,热点补跌,低位题材不停的切换和轮动,因为资金减少,导致题材没有持续性,最终就是多杀多,大家都没钱赚,所以不管四千家还是五千家股票下跌,本质上都是市场在熊市里的一个必然特征。M3:MA(CLOSE,3); M13:MA(CLOSE,13); M34:MA(CLOSE,34),COLORRED,LINETHICK2; IF(M34<REF(M34,1),M34,DRAWNULL),COLORGREEN,LINETHICK2; STICKLINE(M3>=M13 AND M34>=REF(M34,1) ,H ,L ,0.4,0),COLOR0000DD;{红} STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,3,1),COLOR000077; STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,2.5,1),COLOR000099; STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,1.9,1),COLOR0000BB; STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,1.2,1),COLOR0000DD; STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,0.4,1),COLOR0000FF; STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,3 ,0),COLOR000077; STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,2.5 ,0),COLOR000099; STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,1.9 ,0),COLOR0000BB; STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,1.2 ,0),COLOR0000DD; STICKLINE(M3>=M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,0.4 ,0),COLOR0000FF; STICKLINE(M3<M13 AND M34>=REF(M34,1) ,H ,L ,0.4 ,0 ),COLORFFBB00;{天兰} STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,3,1 ),COLORFF3300; STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,2.5,1 ),COLORFF5500; STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,1.9,1 ),COLORFF7700; STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,1.2,1 ),COLORFF9900; STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C>=O ,O ,C ,0.4,1 ),COLORFFBB00; STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,3,0 ),COLORFF1100; STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,2.5,0 ),COLORFF3300; STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,1.9,0 ),COLORFF5500; STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,1.2,0 ),COLORFF7700; STICKLINE(M3<M13 AND M34>=REF(M34,1) AND C<O ,O ,C ,0.4,0 ),COLORFF9900; STICKLINE(M3<M13 AND M34<REF(M34,1) ,H ,L ,0.4 ,0 ),COLOR00FF00;{绿} STICKLINE(M3<M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,3,0 ),COLOR007700; STICKLINE(M3<M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,2.5,0 ),COLOR009900; STICKLINE(M3<M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,1.9 ,0 ),COLOR00BB00; STICKLINE(M3<M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,1.2 ,0 ),COLOR00DD00; STICKLINE(M3<M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,0.4 ,0 ),COLOR00FF00; STICKLINE(M3<M13 AND M34<REF(M34,1) AND C<O ,O ,C ,3,1 ),COLOR006600; STICKLINE(M3<M13 AND M34<REF(M34,1) AND C<O ,O ,C ,2.4,1 ),COLOR009900; STICKLINE(M3<M13 AND M34<REF(M34,1) AND C<O ,O ,C ,1.8,1 ),COLOR00BB00; STICKLINE(M3<M13 AND M34<REF(M34,1) AND C<O ,O ,C ,1.2 ,1 ),COLOR00DD00; STICKLINE(M3<M13 AND M34<REF(M34,1) AND C<O ,O ,C ,0.4 ,1 ),COLOR00FF00; STICKLINE(M3>=M13 AND M34<REF(M34,1) ,H ,L ,0.4 ,0 ),COLORFF66FF;{粉} STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,3 ,1 ),COLOR0000BB; STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,2.4 ,1 ),COLOR0000DD; STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,1.8 ,1 ),COLORCC11FF; STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,1.2 ,1 ),COLORCC44FF; STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C>=O ,O ,C ,0.4 ,1 ),COLORCC66FF; STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C<O ,O ,C ,3 ,0 ),COLOR9900FF; STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C<O ,O ,C ,2.4 ,0 ),COLORFF22FF; STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C<O ,O ,C ,1.8 ,0 ),COLORFF66FF; STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C<O ,O ,C ,1.2 ,0 ),COLORFF99FF; STICKLINE(M3>=M13 AND M34<REF(M34,1) AND C<O ,O ,C ,0.4 ,0 ),COLORFFCCFF;今天给粉丝分享主图源码,大盘飘摇不定,上下忐忑,好的操盘利器更显重要性,仔细研究一下主图会有感悟。出现彩色实心K线柱就是即将变盘,多对比个股会有领悟收获。

    浏览4171次浏览
    2024-01-22 15:51
  • 神奇指标

    雁升指标-上升通道持股下降通道绝不补仓!

    做这个指标的缘由是,一个亏掉40%的那位朋友向我请教。每当大跌后看到心里暗无天日的朋友总想起以前的自己。曾经25W亏掉50%,当然是分10年亏掉的,给自己定了一个规矩,一年内如果亏掉12000,那就清盘,那一年里剩下的日子就不准再玩了,坚决。仔细想想,每次开始都是小亏甚至还有些赚,从赚到亏,从小亏到大亏,。。。最大的祸首是补仓。常常跌了一些就补,总补得太早,补了又跌再补,再大跌继续补,直到没有子弹了,股票依然还会跌?!有时候大盘连续跌十几天都有,亏1000时再等等,亏10000多时实在受不了了终于狠狠心割肉,割了13000~17000的这样的有3次。      所以,避免大亏,必须:忘记补仓这回事!!下降通道绝不补仓下面送出我多年的主图指标参考:sg:ema(hhv(h,1),8),culorMAGENTA; x1:EMA(CLOSE,8),culoryellow; VAR4:=(LOW+HIGH+CLOSE)/3; jj:=(h+l+3*c)/5; Var21:=eMA(jj,5);Var22:=eMA(jj,13);Var23:=eMA(jj,21);Var24:=eMA(jj,34);h1a:=(var21+var22+var23+var24)/4; 成本和谐:=ma(h1a,5),culorred,linethick2; X6:EMA(X1,50*3),culorgray,circledot,linethick2; X7:EMA(X1,50*5),culormagenta,linethick4; ll:=llv(c,100),culorgray; X11:stickline(成本和谐>ref(成本和谐,1) , 成本和谐*0.998,成本和谐*1.002,8,0),culorred,linethick2; x30:=x1<ref(x1,1) and c<x1; X31:stickline(sg<ref(sg,1) or x30, sg*0.998,sg*1.01,8,0),culorblue,linethick3; X21:stickline(成本和谐<ref(成本和谐,1) , 成本和谐*0.998,成本和谐*1.002,8,0),culorgray,linethick4; stickline(成本和谐<ref(成本和谐,1) , 成本和谐*0.998,成本和谐*1.002,8,0),culorgray; 基础1:=(1-C/SMA(C,13,1))*100; 基础2:=EMA(C,13); 股道分时拐点:=EMA(基础1*C/100+基础2,3),COLORgreen,linethick2; stickline(成本和谐>股道分时拐点,股道分时拐点,成本和谐,10,0),COLORred; stickline(成本和谐<股道分时拐点,股道分时拐点,成本和谐,10,0),COLORgreen;1.刚蓝色、绿色乌云盖顶时(日线将要形成当日收盘前)应该减仓,不妨先出来看看(这时候不要去想亏了多少),如果后面蓝色、绿色乌云消失了(股价修复了)我再买回来嘛。2.下降趋势形成时不宜补仓!!!3.小死--死在不走,大死--死在错误补仓!!!你同意吗?4.在股市可以锦上添花,不能雪中送炭解放别人去套牢自己。这个公式提倡随时溜,刚蓝色、绿色乌云盖顶至少应该减仓、至少不能补仓,以防套死越来越被动。但愿朋友们能少套牢、防防身。

    浏览6401次浏览
    2024-01-02 10:22
  • 神奇指标

    通达信三线捉牛强势主图

    通达信三线捉牛强势主图股市的炒作就是做差价,要说差价的种类那就太多了,光一个中国股市就有够你折腾的差价模式。这些差价模式在股市大部分时候都会以合适的方式体现出来。大盘的涨涨跌跌中个股的起起落落就更加复杂化。如果要在股市中赚钱就得有自己的原则,而原则的形成,首先要的就是一种操作思路,你不应该想赚取所有类型的差价那是做不到的而且极易受到各种负面信息引诱而发生错误的操作,我们唯一能够做好的就是形成自己专一的操作思路。说明白些就是:你应该先学会赚其中某一种差价模式产生的差价,不应该贪多、贪全。 {三线捉牛} 买股线:EMA(COST(99),120),COLORMAGENTA,LINETHICK1; 持股线:MA(C,5)DOTLINE,COLORWHITE; M170:MA(C,170); {涨停板} ZT1:=C/REF(C,1)>1.095 AND C=H;{10%涨停} ZT2:=C/REF(C,1)>1.19 AND C=H;{20%涨停} CYB:=CODELIKE('30');{创业板股票} KCB:=CODELIKE('68');{科创板股票} ZT:=IF(CYB OR KCB, ZT2, ZT1);{如果是创业板、科创板股票,20%涨停,否则10%涨停}; A1:=EVERY(ZT,1) ; A2:= REF(O,1)>REF(C,1) AND C>O AND C<REF(O,1) AND EXIST(A1,3); DRAWSL(A2,H,0,5,0),COLORWHITE LINETHICK2; DRAWNUMBER(A2=1,H,H); X_1:=150; X_2:=3; X_3:=REF(HHV(HIGH,X_1),X_2); X_4:=REF(LLV(LOW,X_1),X_2); X_5:=X_3-(X_3-X_4)*0.618; X_6:=REFDATE(X_5,DATE); 横盘天数:=BARSLASTCOUNT(CLOSE<X_6),COLORGREEN; X_7:=crOSS(CLOSE,X_6); X_8:=横盘天数>100; X_9:=REF(X_8,1); X_10:=X_9 AND X_7; X11:=BARSLAST(X_10>0); X12:REF(H,X11)COLORWHITE,LINETHICK1,DOTLINE; A88:=vol*CLOSE; B88:=SUM(A88,1)/SUM(VOL,1); B188:=EMA(B88,17); 数值8:=(B88-B188)*1500/B88; 越强势区黄线8:=数值8>=300; 首越黄线:=BARSLASTCOUNT(越强势区黄线8)=1; DRAWTEXT(首越黄线,L*0.92,'牛'),COLORMAGENTA; DRAWTEXT(ISLASTBAR,X12,'强区')COLORYELLOW; 上升:IF(M170>=REF(M170,1),M170,DRAWNULL),LINETHICK2 COLORRED; 下降:IF(M170<REF(M170,1),M170,DRAWNULL),LINETHICK2,COLORGREEN; XA1:=IF(DATE<99999999,1,DRAWNULL); MXD:=IF((DATETODAY(DATE))<99999999,1,DRAWNULL); WH1:=IF(L=LLV(L,9),L,0)*MXD; WH2:=CONST(BARSLAST(WH1!=0))*MXD; WH3:=CONST(IF(WH2=0,H,REF(H,WH2)))*MXD; WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1)*MXD; WH5:=CONST(IF(WH4=0,H,REF(H,WH4)))*MXD; WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1)*MXD; WH7:IF(CURRBARSCOUNT<=WH2+10,CONST(IF(WH6=0,H,REF(H,WH6))),DRAWNULL)*MXD,COLORYELLOW,DOTLINE; DRAWTEXT(ISLASTBAR,WH7,'进场')*XA1,COLORMAGENTA; {热点主升} N:=9; ABC8:=3; ABC9:=3; 股民指标:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100; K:=SMA(股民指标,ABC8,1); D:=SMA(K,ABC9,1); J:=3*K-2*D; 金叉:=kdj.K>kdJ.D AND KDJ.J>KDJ.D AND KDJ.J>KDJ.K; 流通市值:=CAPITAL*C/1000000; 涨幅:=(C-REF(C,1))/REF(C,1)*100; 价格:=C; CBA0:=NOT(NAMELIKE('ST') OR NAMELIKE('*ST') OR NAMELIKE('S') OR DYNAINFO(4)=0 OR INBLOCK('创业板') OR INBLOCK('科创板')) OR BARSCOUNT(C)>1; CBA1:=流通市值>0 AND 流通市值<80; CBA2:=涨幅>9.8 AND 涨幅<10.99 AND C=H; CBA3:=价格>2 AND 价格<22; CBA4:=COUNT(CBA2,2)=1; 热点:=金叉 AND CBA0 AND CBA1 AND CBA2 AND CBA3 AND CBA4; STICKLINE(热点,H,L,0,0),COLOR0000FF; STICKLINE(热点,C,O,3,0),COLOR000099; STICKLINE(热点,C,O,2,0),COLORYELLOW; STICKLINE(热点,C,O,1,0),COLORYELLOW; STICKLINE(热点,C,O,0.3,0),COLOR0000FF; DRAWTEXT(热点,L*0.99,'←热点'),COLORYELLOW; DRAWICON(热点,L*0.999,9); ZF:=(C/REF(C,1)-1)*100; 高开:=(O/REF(C,1)-1)*100; ABC1:=DYNAINFO(15)/O/100; 尊重市场1:=ABC1/REF(V,1)*100; ABC2:=(EMA(O,20)-REF(EMA(O,20),1))/REF(EMA(O,20),1)*100; ABC3:=REF(L,BARSLAST(CROSS(ABC2,0))); 主升值:=(O-ABC3)/ABC3*100; ABC4:=CODELIKE('60') OR CODELIKE('00'); ABC5:=(C/REF(C,1)-1)*100>9.8 AND H=C; ABC6:=EVERY(ABC5,4)<3; 主升:=主升值<=20 AND REF(ZF>9.80,1) AND 高开>=2 AND 高开<=7.5 AND ABC4 AND ABC6; STICKLINE(主升,H,L,0,0),COLORFF00FF; STICKLINE(主升,C,O,3,0),COLOR990099; STICKLINE(主升,C,O,2,0),COLORRED; STICKLINE(主升,C,O,1,0),COLORRED; STICKLINE(主升,C,O,0.3,0),COLORRED; DRAWTEXT(主升,L*0.99,'←主升'),COLORWHITE; DRAWICON(主升,L*0.999,28); 成交量:=V,COLORYELLOW,NODRAW; 主力抢筹:ABC1/REF(V,1)*100,COLORRED,NODRAW; DRAWTEXT_FIX( CURRBARSCOUNT=1 AND V>0,0.001,0.19,0,'主力抢筹:'),COLORRED; DRAWNUMBER_FIX(CURRBARSCOUNT=1 AND V>0,0.18,0.19,0,主力抢筹),COLORRED; DRAWTEXT_FIX(1,0.001,0.005,0,'【概念板块】:'),COLORMAGENTA; DRAWTEXT_FIX(1,0.15,0.005,0,GNBLOCK),COLORMAGENTA;

    浏览9442次浏览
    2023-12-11 16:24
  • 神奇指标

    通达信强悍低吸波段主图

    通达信强悍低吸波段主图原则:每年都有不同的感悟,或叫原则吧!进化的一种总结! 1真正的投资不是首先考虑回报,而是首先考虑风险,即如何不输钱。所以,先选好品种,低价可转债,我的认知不高,我只知道跨跃一尺的栏杆,因为七尺的栏杆对我来说太难,同样挣100元,不会因为你的难度大,市场会给你200元!当你亏钱,市场不会因为你难度大或借钱上杠杆而让你少赔!!如何不输钱,则取决于准确的自我认知和有效的安全带。在投资领域,赚钱谁都能赚,但是,尽量减少回撤,才是真能力。这才是高手与大师的真正区别所在。因为跟其他行业不同,在这如果你够激进,有时一次就让你输光。2克服人性的弱点据青泽先生的数据,在期货领域,真正有系统的人,或者说有真正系统的人不到全体投资者的十分之一,系统经过大样本回测能取得正期望值的不到百分之一;有正期望值系统且能长期坚守的人就只剩下千分之一了。这也能说明为什么股票市场长期稳定获利者大约10%,而期货市场不到1%。期货是放大器。它放大不仅是盈亏倍数,更是人性的弱点。3我简单总结我的方法,先打安全垫,趋势和保守思路共存,择时和满仓轮动共存,趋势交易思路和逆势交易思路共存,因为不同时机需不同的方法应对。没有固定的套路的,左右互博,顺势而为,逆人性交易并存。相应的方法就是大跌大买,小跌小买,不跌不买,大涨大卖,小涨小卖,不涨不卖。如果卖飞绝不再追,耐心等下一次,哪怕很久也等,中间就理财,打新,套利等维持理财收益,甚至放在惰性债中。EMA13:=EMA(C,13),COLORWHITE; EMA21:=EMA(C,21),COLORYELLOW; EMA34:=EMA(C,34),COLORFF00FF; EMA60:=MA(C,60),COLORFFCC66; VAR2:=(2*CLOSE+HIGH+LOW)/4; VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1); VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4); 散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3; 庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3; DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLORLIRED; DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),COLORGREEN; DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1); DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2); VAR9:=CLOSE-REF(CLOSE,5); VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5); VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20); 卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100); DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2); 卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42); B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA; S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW; VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3; S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN; A0:=(L+H+C*2)/4; A1:EMA(A0,14)COLORBLUE,LINETHICK2; A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2; A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW; A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW; 看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2}; 逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2}; 买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK3; 卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK3; STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF; STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC; STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF; STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;

    浏览9289次浏览
    2023-11-23 16:04
  • 神奇指标

    通达信波浪趋势画线突破

    通达信波浪趋势画线突破弱者体系就是假定自己在信息获取、理解深度、时间精力、情绪控制、人脉资源等方面都处于这个市场的最差水平,能依靠的只有时间、赔率与常识,我的整个投资框架都是立足于这个基本假设而建立起来的。我把市场分为看得见的和看不见的两种,强者是要深度研究,让盲区消失,所有方面都要看见,弱者是只要不呈现就看不见。我的投资风格是不择时、不对冲、不用杠杆、不做空、不做复杂的衍生品,始终保持高仓位单边做多,赔率优先情况下的分散潜伏,以及在概率与赔率统一时的重点突破。逆向为主,但不见得经常集中投资,因为我是赔率优先体系,一定是分散介入。持有的股票数量也非常多,首先要满足高仓位原则,所以在概率不足的时候我会在很多赔率高的股票上做分散投资,当确定性大的时候再换仓提升比例,所以叫“重点突破”应该比较恰当。笔周期:=3; 画趋势:=0; A1:=REF(HIGH,3)=HHV(HIGH,笔周期*3+1); B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1); D1:=FILTER(C1,3); A2:=REF(LOW,3)=LLV(LOW,笔周期*3+1); B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1); D2:=FILTER(C2,3); E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍} H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1; H2:=D1 AND NOT(D2 AND E1>=E2); L1:=D2 AND NOT(D1 AND E1=E2); X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1)); G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点} L2:=LD OR BARSTATUS=2 OR BARSCOUNT(CLOSE)=1; X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2)); G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);{过滤后高点} DRAWLINE(LD,L,HD,H,0),COLORYELLOW,LINETHICK1; DRAWLINE(HD,H,LD,L,0),COLORYELLOW,LINETHICK1; J1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HD),BARSLAST(LD))+1); J2:=J1>REF(J1,1); A3:=H; B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2)),COLOR666666; D3:=A3 AND B3 AND HD; E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2); HH:=E3>REF(E3,1);{找出全部长期高点} A4:=L>REF(L,REF(BARSLAST(LD),1)+1); B4:=REF(L,REF(BARSLAST(LD),1)+1); D4:=A4 AND B4 AND LD; E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2); LL:=E4>REF(E4,1);{找出全部长期低点} H3:=HH OR BARSTATUS=2 OR BARSCOUNT(C)=1; {后面进行过滤,方法同前。只是不用考虑高低点出现在同一K线} X3:=REF(BARSLAST(H3),1)+1; F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3)); G3:=F3>REF(F3,1); I3:=BACKSET(G3,2); LZ:=I3>REF(I3,1); {长期低点,也可供引用} L4:=LZ OR BARSTATUS=2 OR BARSCOUNT(C)=1; X4:=REF(BARSLAST(L4),1)+1; F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4)); G4:=F4>REF(F4,1); I4:=BACKSET(G4,2); HZ:=I4>REF(I4,1);{长期高点,也可供引用} K1:=BACKSET(BARSTATUS=2,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1); UU:=BACKSET(BARSTATUS=2,BARSLAST(LD)+1); VV:=UU>REF(UU,1); WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2); XX:=WW>REF(WW,1); WWQ:=BACKSET(XX,REF(BARSLAST(LD),1)+2); XXQ:=WWQ>REF(WWQ,1); 下轨:=DRAWLINE(XX,L,VV,L,1),COLORMAGENTA,LINETHICK2;{画趋势线} UU2:=BACKSET(BARSTATUS=2,BARSLAST(HD)+1); VV2:=UU2>REF(UU2,1); WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2); XX2:=WW2>REF(WW2,1); WW3Q:=BACKSET(XX2,REF(BARSLAST(HD),1)+2); XX3Q:=WW3Q>REF(WW3Q,1); WW4Q:=BACKSET(XX3Q,REF(BARSLAST(HD),1)+2); XX4Q:=WW4Q>REF(WW4Q,1); 上轨:=DRAWLINE(XX2,H,VV2,H,1),COLORMAGENTA,LINETHICK2;{画趋势线}; 上轨1:=DRAWLINE(XX2,H,VV2,H,1); Q0:=BARSLAST(XX2>0); Q1:=BARSLAST(XX>0); Q2:=BARSLAST(WW2>0); Q3:=BARSLAST(VV>0); Q4:=BARSLAST(XXQ>0); Q5:=BARSLAST(XX3Q>0); Q6:=BARSLAST(XX4Q>0); 近期低:REF(L,BARSLAST(VV)),DOTLINE,COLOR99FF66; 近期高:REF(H,BARSLAST(VV2)),DOTLINE,COLOR99FF66; 上次低:REF(L,BARSLAST(XX)),DOTLINE,COLORFF66FF; 上次高:REF(H,BARSLAST(XX2)),DOTLINE,COLORFF66FF; ABC:=IF(Q5>Q4,REF(L,BARSLAST(XXQ)),0),DOTLINE,COLORCYAN; ①②③:=IF(Q5<Q4,REF(H,BARSLAST(XX3Q)),0),DOTLINE,COLORCYAN; 笔:DRAWLINE(J2,IF(HD,H,L),BARSTATUS=2,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),DOTLINE,COLORYELLOW,LINETHICK1; DRAWTEXT( VV=1 AND Q0>Q1,L,'C')COLORMAGENTA; DRAWTEXT(VV2=1 AND Q0>Q1,H,'B')COLORMAGENTA; DRAWTEXT( XX=1 AND Q0>Q1,L,'A')COLORMAGENTA; DRAWTEXT(XX2=1 AND Q5>Q4 ,H,'◆2')COLORMAGENTA; DRAWTEXT(XXQ=1 AND Q5>Q4 ,L,'◆1')COLORMAGENTA; DRAWTEXT( VV=1 AND Q0<Q1,L,'B-')COLORMAGENTA; DRAWTEXT(VV2=1 AND Q0<Q1,H,'C-')COLORMAGENTA; DRAWTEXT(XX2=1 AND Q0<Q1,H,'A-')COLORMAGENTA; DRAWTEXT(XX=1 AND Q5<Q4,L,'◆2')COLORMAGENTA; DRAWTEXT(XX3Q=1 AND Q5<Q4,H,'◆1')COLORMAGENTA; V00:=HIGH<REF(HIGH,1) AND LOW<REF(LOW,1); V01:=HIGH>REF(LOW,1); V02:=HIGH>REF(HIGH,1) AND LOW<REF(LOW,1); V03:=HIGH>REF(HIGH,1) AND LOW>REF(LOW,1); V04:=REF(HIGH,2)<HIGH AND REF(LOW,2)<REF(HIGH,1) AND REF(LOW,2) < REF(LOW,1); V1:=COUNT(V00,3)>=1 AND LLVBARS(LOW,3)=1 AND V03; V2:=COUNT(V00,4)>=1 AND LLVBARS(LOW,4)=2 AND V04; V3:=COUNT(V00,4)>=1 AND COUNT(V01 OR V02,4)=1 AND LLVBARS(LOW,4)=1 AND V03; V4:=COUNT(V00,5)>=1 AND COUNT(V01 OR V02,5)=2 AND LLVBARS(LOW,5)=2 AND V04; XG1:=V1 OR V2 OR V3 OR V4; XG2:=C>REF(HIGH,1); XG:=XG1 AND XG2; 收敛突破:=上次低<近期低 AND 上次高>近期高 AND CROSS(C,上轨) AND C>O; DRAWTEXT(收敛突破=1,L,'收敛突破'),COLORYELLOW; 突破:=CROSS(C,近期高) AND C>O; STICKLINE(突破,OPEN,CLOSE,2.8,0),COLORMAGENTA; 强势突破:=上次低<近期低 AND 上次高<近期高 AND C>O; STICKLINE(强势突破,OPEN,CLOSE,2.8,0),COLORMAGENTA; DRAWTEXT(强势突破=1,H,'强势突破'),COLORYELLOW; 反弹突破:=CROSS(C,上次低) AND C>O; STICKLINE(反弹突破,OPEN,CLOSE,2.8,1),COLORMAGENTA; STICKLINE(反弹突破,OPEN,CLOSE,1,1),COLORWHITE; DRAWTEXT(反弹突破=1,L,'反弹突破'),COLORYELLOW; DRAWTEXT(突破=1,L,' 突破'),COLORYELLOW; 一阳定势:=CROSS(C,近期高) AND CROSS(C,上次高) AND C>O; STICKLINE(一阳定势,OPEN,CLOSE,2.8,0),COLORMAGENTA; DRAWTEXT(一阳定势=1,(OPEN+CLOSE)/2,' 一阳定势'),COLORRED; STICKLINE(一阳定势,OPEN,CLOSE,1,0),COLORYELLOW; STICKLINE(强势突破,OPEN,CLOSE,1,0),COLORYELLOW;

    浏览3090次浏览
    2023-11-09 14:26
  • 神奇指标

    通达信V型反转分多空主图

    通达信V型反转分多空主图复杂的行情下,操作有时完全是为了交易而交易,这是对于超短线做T的我们而言。没有办法,既然是波段中讨生活的人,就要面对。成功需要长时间的积累,长期的勤奋,以及一点点天赋。波段操作想要好,一定要学会判断主力的动向。 量能就好比战争双方军力拼斗的实力,形态好比军阵,基本面就是底气,新增资金就是后续部队,我们通过观察这些最真实最直接的数据,才能对这个股的主力脉络构建出来。 而很多指标都是二次使用数据,具有延迟性。但是今天我要分享的指标不同,直接作用于成交量和资金流入情况。出现信号的机会比较少,但是一出现就意味着大资金入场布局,耐心等待后续必有拉升。DRAWTEXT_FIX(1,0.88,5,0,'~☆~神奇指标网出品~☆~'),COLORRED; HAN:=DATE<1141230; 当前获利筹码:=IF(WINNER(CLOSE),WINNER(CLOSE)*100,0); DRAWKLINE(H,O,L,C); 九十成本集中:=(COST(95)-COST(5))/(COST(95)+COST(5))*100; 成本价:COST(九十成本集中),LINETHICK2,COLORMAGENTA; 入1:IF(成本价>REF(成本价,1),成本价,DRAWNULL),COLORRED,LINETHICK2; 出1:IF(成本价<REF(成本价,1),成本价,DRAWNULL),COLORGREEN,LINETHICK2; STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),3.2,0)*HAN,COLOR0077FF; STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),2.5,0)*HAN,COLOR0099FF; STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),1.9,0)*HAN,COLOR00BBFF; STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),1.2,0)*HAN,COLOR00DDFF; STICKLINE(成本价>LOW AND 成本价<HIGH,成本价,MIN(MIN(OPEN,CLOSE),成本价),0.3,0)*HAN,COLOR00FFFF; STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),3.2,0)*HAN,COLOR0077FF; STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),2.5,0)*HAN,COLOR0099FF; STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),1.9,0)*HAN,COLOR00BBFF; STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),1.2,0)*HAN,COLOR00DDFF; STICKLINE(成本价>MIN(C,O) AND 成本价<MAX(C,O),成本价,MIN(OPEN,CLOSE),0.3,0)*HAN,COLOR00FFFF; STICKLINE(成本价>HIGH,CLOSE,OPEN,3.2,0)*HAN,COLOR0077FF; STICKLINE(成本价>HIGH,CLOSE,OPEN,2.5,0)*HAN,COLOR0099FF; STICKLINE(成本价>HIGH,CLOSE,OPEN,1.9,0)*HAN,COLOR00BBFF; STICKLINE(成本价>HIGH,CLOSE,OPEN,1.2,0)*HAN,COLOR00DDFF; STICKLINE(成本价>HIGH,CLOSE,OPEN,0.3,0)*HAN,COLOR00FFFF; STICKLINE(成本价>HIGH,HIGH,LOW,0,0),COLORGREEN; DF2:=(C-REF(C,1))/REF(C,1)*100>5; DF3:=(C-O)/O*100>4; 当天涨幅:(C-O)/O*100,NODRAW; V型反转:=L<成本价 AND DF2; V型反转2:=CROSS(C,成本价) AND DF2; V型反转3:=L<成本价 AND DF3; DRAWTEXT(V型反转,L*0.98,'狙击'),COLORCYAN; DRAWTEXT(V型反转2,L*0.98,'狙击'),COLORCYAN; DRAWTEXT(V型反转3,L*0.98,'狙击'),COLORCYAN; STICKLINE(V型反转=1,C,O,3.2,0),COLORRED; STICKLINE(V型反转2=1,C,O,3.2,0),COLORRED; STICKLINE(V型反转3=1,C,O,3.2,0),COLORRED;

    浏览11952次浏览
    2023-10-09 17:46
  • 神奇指标

    通达信牛回头简单判断副图指标

    通达信牛回头简单判断副图指标高手的刀,其实就是杰出的心性。对我们低手来说,这需要长时间相当痛苦的积累过程才能达到,和一个人智商的高低、理论知识掌握的多寡无关。我相信,只有你到了拥有高手之心的那一天,你自然同时拥有了高手的眼界。K线虽然还是那些K线,波浪虽然还是那些波浪,但从这一刻起才会真正变得鲜活、生动起来;招数虽然还是那些招数,也只有从这一刻起才能对你有实际意义。在质变的临界点没有达到之前,即便你满腹经纶、绝顶聪明,被人性弱点蒙蔽的双眼又怎能看见遍地的黄金呢?“当财富来到的时候,它将来得如此急,如此快,使人奇怪在那艰难的岁月,这些财富都躲到哪里去了?”这句话现在明白了吗?一将功成万骨枯,古来征战几人还?只有战场才能成就英雄,只有苦难才能造就杰出的心性。股海无情,要走上投机之路却没有一条可以投机的捷径,我希望有缘人能领会这事实上很简单的道理,不要缘木求鱼、舍本逐末,免得越努力,反而离成功越遥远,最终落得个聪明反被聪明误的下场!心性偏颇的人,一心只想靠投机取巧拿走别人钱财的人,他自己存在股市里的银子或迟或早注定要被别人拿去!正所谓六根不净,何以股为?股道精华,实在股外!NOTEXTHC:MA(CLOSE,22),COLORMAGENTA; X_1:=MA(CLOSE,21); NOTEXTMA60:MA(CLOSE,60),COLORYELLOW; X_2:=EMA(CLOSE,5); X_3:=EMA(X_2,0); X_4:=HHV(MA(HIGH,3),2); NOTEXTX2:LLV(MA(HIGH,3),1),COLORRED; X_5:=X_4=NOTEXTX2 AND REF(X_4>NOTEXTX2,1); DRAWICON(X_5 AND NOTEXTX2>=REF(NOTEXTX2,1) AND CLOSE>OPEN,LOW,1); X_6:=FILTER(X_3>REF(X_3,1) AND X_4>REF(CLOSE,1),11); X_7:=RANGE(CLOSE/X_1,0.97,1.15) OR RANGE(OPEN/X_1,0.97,1.15); X_8:=X_6 AND CLOSE>MA(CLOSE,21) AND EVERY(X_1>REF(X_1,1),7) AND X_7; DRAWICON(X_8>=1 AND NOTEXTX2>REF(NOTEXTX2,1),LOW*0.99,7); X_9:=NOTEXTX2>NOTEXTHC AND NOTEXTHC>NOTEXTMA60; X_10:=X_5 AND X_9; DRAWICON(X_10 AND CLOSE>OPEN,LOW*0.98,11); X_11:=NOTEXTHC>NOTEXTMA60 AND NOTEXTX2>NOTEXTMA60; X_12:=X_5 AND X_11; DRAWICON(X_12 AND CLOSE>OPEN,LOW*0.98,11); X_13:=X_5 AND NOTEXTMA60>NOTEXTHC AND LOW<=NOTEXTHC AND HIGH>=NOTEXTMA60; X_14:=X_5 AND NOTEXTMA60<NOTEXTHC AND LOW<=NOTEXTMA60 AND HIGH>=NOTEXTHC; X_15:=X_13 OR X_14; DRAWICON(X_15,LOW*0.97,34); DRAWICON(crOSS(NOTEXTX2,NOTEXTHC) AND REF(X_5,1) AND NOTEXTHC>REF(NOTEXTHC,1),LOW*0.96,25); X_16:=NOTEXTMA60>=NOTEXTHC AND NOTEXTX2>=NOTEXTMA60 AND HIGH>=NOTEXTX2 AND LOW<=NOTEXTMA60; X_17:=NOTEXTMA60>=NOTEXTHC AND NOTEXTX2>=NOTEXTHC AND NOTEXTX2<NOTEXTMA60 AND HIGH>=NOTEXTMA60 AND LOW<=NOTEXTX2; X_18:=NOTEXTMA60<=NOTEXTHC AND NOTEXTX2>=NOTEXTMA60 AND NOTEXTX2<NOTEXTHC AND HIGH>=NOTEXTHC AND LOW<=NOTEXTX2; X_19:=NOTEXTMA60<=NOTEXTHC AND NOTEXTX2>=NOTEXTHC AND HIGH>=NOTEXTX2 AND LOW<=NOTEXTHC; X_20:=X_16 OR X_17 OR X_18 OR X_19; X_21:=X_20 AND CLOSE>OPEN; STICKLINE(X_21,OPEN,CLOSE,3,0),COLORRED; X_22:=NOTEXTX2>=NOTEXTMA60 AND NOTEXTMA60>=NOTEXTHC AND HIGH>=NOTEXTX2 AND LOW<=NOTEXTHC; X_23:=NOTEXTX2>=NOTEXTHC AND NOTEXTHC>=NOTEXTMA60 AND HIGH>=NOTEXTX2 AND LOW<=NOTEXTMA60; X_24:=NOTEXTMA60>=NOTEXTHC AND NOTEXTHC>=NOTEXTX2 AND HIGH>=NOTEXTMA60 AND LOW<=NOTEXTX2; X_25:=NOTEXTMA60>=NOTEXTX2 AND NOTEXTX2>=NOTEXTHC AND HIGH>=NOTEXTMA60 AND LOW<=NOTEXTHC; X_26:=NOTEXTHC>=NOTEXTMA60 AND NOTEXTMA60>=NOTEXTX2 AND HIGH>=NOTEXTMA60 AND LOW<=NOTEXTHC; X_27:=NOTEXTHC>=NOTEXTX2 AND NOTEXTX2>=NOTEXTMA60 AND HIGH>=NOTEXTHC AND LOW<=NOTEXTMA60; X_28:=X_22 OR X_23 OR X_24 OR X_25 OR X_26 OR X_27; X_29:=X_28 AND CLOSE>OPEN; STICKLINE(X_29,OPEN,CLOSE,3,0),COLORMAGENTA; X_30:=NOTEXTHC>NOTEXTMA60 AND NOTEXTX2>NOTEXTMA60 AND NOTEXTX2<NOTEXTHC; X_31:=NOTEXTHC<NOTEXTMA60 AND NOTEXTX2>NOTEXTHC AND NOTEXTX2<NOTEXTMA60; X_32:=NOTEXTX2<NOTEXTMA60 AND NOTEXTX2<NOTEXTHC; X_33:=X_30 OR X_31 OR X_32 AND NOTEXTX2>=REF(NOTEXTX2,1) AND (NOTEXTMA60>=REF(NOTEXTMA60,1) OR NOTEXTHC>=REF(NOTEXTHC,1)); X_34:=CLOSE<=NOTEXTX2 AND CLOSE>OPEN AND X_33; STICKLINE(X_34,CLOSE,OPEN,3.05,0),COLOR000099; STICKLINE(X_34,CLOSE,OPEN,2.2,0),COLOR0000CC; STICKLINE(X_34,CLOSE,OPEN,1.5,0),COLORRED; STICKLINE(X_34,CLOSE,OPEN,0.5,0),COLORYELLOW; X_35:=CROSS(NOTEXTMA60,NOTEXTX2) OR CROSS(NOTEXTHC,NOTEXTX2); X_36:=CROSS(NOTEXTX2,NOTEXTMA60) OR CROSS(NOTEXTX2,NOTEXTHC); X_37:=X_36 AND EXIST(X_35,10); STICKLINE(X_37,CLOSE,OPEN,3.05,0),COLOR000099; STICKLINE(X_37,CLOSE,OPEN,2.2,0),COLOR0000CC; STICKLINE(X_37,CLOSE,OPEN,1.5,0),COLORRED; STICKLINE(X_37,CLOSE,OPEN,0.5,0),COLORYELLOW;

    浏览10911次浏览
    2023-09-13 11:31
  • 神奇指标

    通达信主图宽带金叉加仓点

    通达信主图宽带金叉加仓点目前大家烦恼的是政策底框架的失效,或许经济见底才是真的右侧底。年初至今以为在买右侧,回头还是左侧,传统策略“三底”框架已失效,三年大疫下的跨周期设计,无法说清哪次会议是我们定义的“政策底”,多数投资者思路转为左侧易被埋,守株待右侧。库存是供需调节器,见底就意味着经济自然触底,打消通缩和业绩最悲观担忧。只是从来都没有完美底部,每次底部都担心需求,谷底看不到花,海底望不见月,库存是周期位置的注脚,能看到的只是赔率,商品领先权益,是每轮库存见底的共性,此刻也很像。因此对中国有信心(Q4开启补库)对美国有信心(明年初补库)。从安全边际来看老乔最近都在加仓前期提到的隐性冠军,因为这些个股均属于顺周期板块。在此轮回调中仍有相对收益,低库存低估值低持仓,以及足够高的赔率,都会形成未来最确定的回报,此时的下跌应做到逐步加仓。AAA:=(3*C+H+L+O)/6; VAR1:(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36,LINETHICK2,COLORRED; VAR2:=(HHV(VAR1,2)+HHV(VAR1,4)+HHV(VAR1,8))/3; VAR3:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3; VAR4:(HHV(VAR2,2)+HHV(VAR2,4)+HHV(VAR2,8))/3; VAR5:(LLV(VAR3,2)+LLV(VAR3,4)+LLV(VAR3,8))/3,COLORWHITE; VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3; {DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));} IF((VAR1 <= REF(VAR1,1)),VAR1,DRAWNULL),COLORGREEN,LINETHICK3; IF((VAR1 >= REF(VAR1,1)),VAR1,DRAWNULL),COLORRED,LINETHICK3; STICKLINE(VAR4>VAR1,VAR4,VAR1,0,0),COLORBLUE; DRAWTEXT_FIX(1,0.88,5,0,'~☆~神奇指标网出品~☆~'),COLORRED; DRAWKLINE(H,O,L,C); DRAWTEXT(REF(VAR5,1)=REF(VAR1,1) AND VAR5<VAR1,L*0.99,'买点'),COLORRED; DRAWTEXT(REF(VAR6,1)=REF(VAR1,1) AND VAR6<VAR1,L*0.98,'加仓'),COLORYELLOW; DRAWTEXT(REF(VAR4,1)=REF(VAR1,1) AND VAR4>VAR1,H,'卖点'),COLORGREEN; ZT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停}; 突破:=CROSS(C,VAR4) AND ZT; DRAWTEXT(突破,L,'爆点'); STICKLINE(突破,CLOSE,OPEN,3.2,0),COLOR0077FF; STICKLINE(突破,CLOSE,OPEN,2.5,0),COLOR0099FF; STICKLINE(突破,CLOSE,OPEN,1.9,0),COLOR00BBFF; STICKLINE(突破,CLOSE,OPEN,1.2,0),COLOR00DDFF; STICKLINE(突破,CLOSE,OPEN,0.3,0),COLOR00FFFF;

    浏览10876次浏览
    2023-08-23 16:19
  • 神奇指标

    通达信技术T+0 日内高低点

    通达信技术T+0 日内高低点当个股股价突破前期价格高点,解套盘没有使股价回落往往意味着股价已经打开上行空间,在阻力大幅度减少的情况下,比较容易出现强劲上升行情。因此,股价突破的位置完全可能是最佳追涨的位置。 股民在追涨时要清醒地了解,追涨的高收益中同时暗藏着高风险,追涨对投资者的短线操作能力、对趋势研判的准确度、对准备追涨个股的熟悉程度以及投资者看盘经验和条件都有极高的要求。选择追涨时要注意: ①当市场整体趋势处于调整格局中的反弹行情中,不宜追涨。 ②股价上行至前期高点的成交密集区时,需仔细观察该股是否具有突破前期股价阻力位的成交量,再决定是否追涨。 ③当盘中热点转换频率过快,热点炒作持续性不强,缺乏有凝聚力、有号召力的龙头板块时,千万不能追涨。 ④在追涨热门板块时,要注意选择领涨股,不宜选择跟风股票。 ⑤对于前期涨幅过大,当前成交量很大而股价却不再上涨的个股不宜追涨,这时庄家出货的几率很大。 ⑥当市场趋势发展方向不明朗,或投资者无法清晰认识未来趋势的发展变化时,不要盲目追涨。N:=27;PP:=0.03; AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0); AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0); AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0); BB1:=0; B1万元:=DVOL*DCLOSE/100; B1差:=B1万元-REF(B1万元,1); B2万元:=DVOL*DCLOSE/100; B2比:=B2万元/REF(B2万元,1); 净流入万元:=(AAA2-AAA3-0.5*AAA4); PM:=MA(净流入万元,1); PMA:=PM/REF(PM,1)>1; PMB:=REF(PMA,1)<1 AND PMA; 数字:(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW; 二日比:=数字/REF(数字,1); 选股:PMB AND 数字>REF(数字,1) AND 二日比>1,COLORRED,NODRAW; MA5:MA(C,5);MA10:MA(C,10);MA30:MA(C,30); DRAWNUMBER(选股=1 ,L,数字),COLORYELLOW; DRAWICON(选股,L*0.975,1); {预测当天最低价公式} A1:=REF(O,1); A2:=ABS((REF(C,1)-A1)/A1); A3:=ABS((REF(H,1)-A1)/A1); A4:=ABS((REF(L,1)-A1)/A1); B1:=ABS((A2+A3+A4)/3); B2:=O*B1; 预测低一:=O-B2; 预测高一:=O+B2; 今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLOR4080FF,NODRAW; 开盘价1:=OPEN; 开盘价2:=REF(OPEN,1); 最高价1:=HIGH; 最高价2:=REF(HIGH,1); 最低价1:=LOW; 最低价2:=REF(LOW,1); 收盘价1:=CLOSE; 收盘价2:=REF(CLOSE,1); AA:=最高价2; BB:=最低价2; CC:=开盘价2; DD:=收盘价2; EE:=(AA+BB+CC+2*DD)/5; AAA:=EE+(AA-BB); BBB:=2*EE-BB; CCC:=2*EE-AA; DDD:=EE-(AA-BB); 上升突破价:=AAA; 上升阻力价:=BBB; 下跌支撑价:=CCC; 下跌反转价:=DDD; EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5; 心理价:=EEE; FFF:=(EEE+开盘价1)/2; GGG:=(预测低一+FFF)/2; 预测低二:=GGG; {预测今日最高价公式} 预测高二:=MA(REF(HIGH,1)/REF(CLOSE,2),N)*REF(CLOSE,1); DRAWTEXT_FIX(1,0.04,0.15,0,'预测低一:'),COLORYELLOW; DRAWNUMBER_FIX(1,0.10,0.15,0,CONST(预测低一)),COLORYELLOW; DRAWTEXT_FIX(1,0.15,0.15,0,'元'),COLORYELLOW,LINETHICK1; DRAWTEXT_FIX(1,0.04,0.20,0,'预测高一:'),COLORFFFFFF; DRAWNUMBER_FIX(1,0.10,0.20,0,CONST(预测高一)),COLORFFFFFF; DRAWTEXT_FIX(1,0.15,0.20,0,'元'),COLORYELLOW,LINETHICK1; DRAWTEXT_FIX(1,0.18,0.15,0,'预测低二:'),COLORYELLOW; DRAWNUMBER_FIX(1,0.24,0.15,0,CONST(预测低二)),COLORYELLOW; DRAWTEXT_FIX(1,0.29,0.15,0,'元'),COLORYELLOW,LINETHICK1; DRAWTEXT_FIX(1,0.18,0.20,0,'预测高二:'),COLORFFFFFF; DRAWNUMBER_FIX(1,0.24,0.20,0,CONST(预测高二)),COLORFFFFFF; DRAWTEXT_FIX(1,0.29,0.20,0,'元'),COLORYELLOW,LINETHICK1; 买回价:=预测低二*1.015; 卖出价:=买回价*(1+PP); DRAWTEXT_FIX(1,0.04,0.10,0,'卖出价:'),COLORRED,LINETHICK1; DRAWNUMBER_FIX(1,0.10,0.10,0,CONST(卖出价)),COLOR8080FF; DRAWTEXT_FIX(1,0.15,0.10,0,'元'),COLORRED,LINETHICK1; DRAWTEXT_FIX(1,0.18,0.10,0,'买回价:'),COLORRED,LINETHICK1; DRAWNUMBER_FIX(1,0.24,0.10,0,CONST(买回价)),COLOR8080FF; DRAWTEXT_FIX(1,0.29,0.10,0,'元'),COLORRED,LINETHICK1; DRAWTEXT_FIX(1,0.01,0.02,0,'★=========================================== ★'),COLORRED; DRAWTEXT_FIX(1,0.15,0.05,0,'T+1 操 作'),COLORFFFFFF; DRAWTEXT_FIX(1,0.01,0.08,0,'操 '),COLOR0000FF; DRAWTEXT_FIX(1,0.01,0.12,0,'盘 '),COLOR0000FF; DRAWTEXT_FIX(1,0.01,0.16,0,'铁'),COLOR0000FF; DRAWTEXT_FIX(1,0.01,0.20,0,'律'),COLOR0000FF; DRAWTEXT_FIX(1,0.32,0.08,0,'坚 '),COLOR0000FF; DRAWTEXT_FIX(1,0.32,0.12,0,'决 '),COLOR0000FF; DRAWTEXT_FIX(1,0.32,0.16,0,'执'),COLOR0000FF; DRAWTEXT_FIX(1,0.32,0.20,0,'行'),COLOR0000FF; DRAWTEXT_FIX(1,0.01,0.24,0,'★=========================================== ★'),COLORRED; STICKLINE(C>=O,C,O,3.4,0),COLOR0000AA; STICKLINE(C>=O,C,O,3.0,0),COLOR0000BB; STICKLINE(C>=O,C,O,2.4,0),COLOR0000CC; STICKLINE(C>=O,C,O,2.0,0),COLOR0000DD; STICKLINE(C>=O,C,O,1.6,0),COLOR0000EE; STICKLINE(C>=O,C,O,1.2,0),COLOR0000FF; STICKLINE(C>=O,C,O,0.6,0),COLOR0000FF; STICKLINE(C>=O,H,L,0,0),COLORRED; STICKLINE(C<=O,C,O,3.4,0),COLORAAAA00; STICKLINE(C<=O,C,O,3.0,0),COLORBBBB00; STICKLINE(C<=O,C,O,2.4,0),COLORCCCC00; STICKLINE(C<=O,C,O,2.0,0),COLORDDDD00; STICKLINE(C<=O,C,O,1.6,0),COLOREEEE00; STICKLINE(C<=O,C,O,1.2,0),COLORFFFF00; STICKLINE(C<=O,C,O,0.6,0),COLORFFFF00; STICKLINE(C<=O,H,L,0,0),COLORFFFF00;

    浏览6536次浏览
    2023-08-04 13:54
  • 神奇指标

    通达信主力天眼控盘主图

    通达信主力天眼控盘主图散户跟主力的差别,无非就两点。第一是信息获取的速度,第二是对消息的解读能力。所以,他们赚的是信息差。而散户跟游资的差别,是对情绪的理解,热点的把握上,所以,他们赚的是情绪差。炒股,我们要知道,股价上涨的背后是逻辑,逻辑的背后是信息,谁能掌握信息差跟预期差,谁就能快人一步。这就好比做生意,第一批下海的人,往往都赚的盆满钵满,当大家都去做的时候,那自然利润就会变少,生财之道变得一文不值。所以我们除了学技术以外,多花一点时间去获得资讯信息,了解热点同样也非常重要。可以帮助我们更好的感受市场的脉搏以及热点的轮动,大大的提高炒股的成功率。DRAWGBK(C>0, RGB(0,0,00),RGB(0,0,0),0,'11',0); MA10:MA(C,10); MA60:MA(C,60); VAR6:=(( ABS((OPEN-CLOSE))/(HIGH-LOW))*VOL); VAR7:=(( (HIGH-IF((CLOSE>OPEN),CLOSE,OPEN))/(HIGH-LOW))*VOL); VAR8:=(( (IF((CLOSE>OPEN),OPEN,CLOSE)-LOW)/(HIGH-LOW))*VOL); VAR9:=IF(((VOL/CAPITAL)>0.001),1,EXP(ABS(LOG(((VOL/CAPITAL)*100))))); 加仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,NODRAW,COLORRED; 减仓:VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,NODRAW,COLORBLUE; 洗盘:VAR8>VAR6 AND VAR8>VAR7,NODRAW,COLORWHITE; 高抛:VAR7>VAR6 AND VAR7>VAR8,NODRAW,COLORMAGENTA; 地量:VAR9>2 AND VOL<MA(VOL,5)/2,NODRAW,COLORGREEN; DRAWKLINE(H,O,L,C); TY:=C; A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10); A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10); 前期高位:REF(H,BARSLAST(HD)), COLORFF00FF,POINTDOT,LINETHICK3; 前期低位:REF(L,BARSLAST(LD)), COLORGREEN,POINTDOT,LINETHICK3; STICKLINE(加仓,O,C,1,0),COLORRED; STICKLINE(洗盘,O,C,1,0),COLORWHITE; STICKLINE(减仓,O,C,1,0),COLORBLUE; STICKLINE(高抛,O,C,1,0),COLORMAGENTA; STICKLINE(地量,O,C,1,0),COLORGREEN; JJ:=(3*C+H+L+O)/6; VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36; TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1); LJL:=FILTER(TJ1,5); STICKLINE(CLOSE,REF(LOW,BARSLAST(LJL)),REF(LOW,BARSLAST(LJL)),1,0),COLORRED; STICKLINE(CLOSE,REF(CLOSE,BARSLAST(LJL)),REF(CLOSE,BARSLAST(LJL)),1,0),COLORYELLOW; STICKLINE(LJL,OPEN,CLOSE,1,0),COLORYELLOW; DRAWTEXT_FIX(1,0.0,0.0,0,'蓝芯-主力低位深度洗盘或高位出货坚决'),COLORBLUE,LINETHICK1; DRAWTEXT_FIX(1,0.00,0.06,0,'白芯-主力轻度洗盘'),COLORWHITE,LINETHICK1; DRAWTEXT_FIX(1,0.00,0.12,0,'棕芯-出现了近期相对地量'),COLORGREEN,LINETHICK1; DRAWTEXT_FIX(1,0.00,0.18,0,'粉芯-主力在做高抛低吸或低吸高抛'),COLORFF00FF,LINETHICK1; DRAWTEXT_FIX(1,0.00,0.24,0,'红芯-主力吸筹进货积极主动'),COLORRED,LINETHICK1; DRAWTEXT_FIX(1,0.00,0.3,0,'黄芯-主力吸筹进货强并且成交量出现黄金柱'),COLORYELLOW,LINETHICK1; DRAWTEXT_FIX(C>0,0.004,1,0,DYBLOCK),COLORYELLOW,LINETHICK2; DRAWTEXT_FIX(C>0,0.06,1,0,HYBLOCK),COLORRED,LINETHICK2; DRAWTEXT_FIX(C>0,0.12,1,0,EXTERNSTR(0,1)),COLORWHITE,LINETHICK2; EN1:=ZIG(3,5)>REF(ZIG(3,5),1) AND REF(ZIG(3,5),1)<=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)<=REF(ZIG(3,5),3); PL10:=ZIG(3,10); 走强2:=BARSLAST(PL10<REF(PL10,1)); ZTJZ5:=IF(PL10>REF(PL10,1),COUNT(EN1,走强2),0); 追2:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2; 追4:=EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3; DRAWTEXT(追2 OR 追4,LOW*0.978,'追'),COLORYELLOW; PL5:=ZIG(3,5); EX1:=ZIG(3,5)=REF(ZIG(3,5),2) AND REF(ZIG(3,5),2)>=REF(ZIG(3,5),3); EN2:=ZIG(3,10)>REF(ZIG(3,10),1) AND REF(ZIG(3,10),1)<=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)<=REF(ZIG(3,10),3); EX2:=ZIG(3,10)=REF(ZIG(3,10),2) AND REF(ZIG(3,10),2)>=REF(ZIG(3,10),3); PL20:=ZIG(3,20); EN3:=ZIG(3,20)>REF(ZIG(3,20),1) AND REF(ZIG(3,20),1)<=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)<=REF(ZIG(3,20),3); EX3:=ZIG(3,20)=REF(ZIG(3,20),2) AND REF(ZIG(3,20),2)>=REF(ZIG(3,20),3); PL40:=ZIG(3,40); 走强1:=BARSLAST(PL5<REF(PL5,1)); 走弱1:=BARSLAST(PL5>REF(PL5,1)); 走弱2:=BARSLAST(PL10>REF(PL10,1)); 走强3:=BARSLAST(PL20<REF(PL20,1)); 走弱3:=BARSLAST(PL20>REF(PL20,1)); ZTJD5:=IF(PL10>REF(PL10,1),COUNT(EX1,走强2),0); DTJZ5:=IF(PL10<REF(PL10,1),COUNT(EN1,走弱2),0); DTJD5:=IF(PL10<REF(PL10,1),COUNT(EX1,走弱2),0); ZTJZ10:=IF(PL20>REF(PL20,1),COUNT(EN2,走强3),0); ZTJD10:=IF(PL20>REF(PL20,1),COUNT(EX2,走强3),0); DTJZ10:=IF(PL20<REF(PL20,1),COUNT(EN2,走弱3),0); DTJD10:=IF(PL20<REF(PL20,1),COUNT(EX2,走弱3),0); DRAWTEXT(EN1 AND DTJZ5=1,L*0.98,'反弹低点'),COLORLIRED; DRAWTEXT(EX1 AND DTJD5=2,H*1.02,'反弹高点!'),COLORLIBLUE; DRAWTEXT(EN2 AND ZTJZ5=1,L*0.98,'底'),COLORYELLOW; DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJD5=1,H*1.02,'减仓'),COLORFFFF00; DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=2,L*0.98,'----买'),COLOR0000FF; DRAWTEXT(EX1 AND PL10>REF(PL10,1) AND ZTJZ5=2,H*1.02,'短卖'),COLORGREEN; DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.98,'----短买'),COLOR0000FF; DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.02,'短卖'),COLORGREEN; DRAWTEXT(EN2 AND DTJZ10=1,L*0.96,'Ⅰ'),COLORFF00FF; DRAWTEXT(EX2 AND DTJD10=2,H*1.03,'Ⅱ'),COLORFF6000; DRAWTEXT(EN3 AND ZTJZ10=1,L*0.95,'Ⅲ'),COLORYELLOW; DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=1,H*1.06,'①'),LINETHICK3,COLORFFFF00; DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=2,L*0.96,'②'),LINETHICK3,COLORYELLOW; DRAWTEXT(EX2 AND PL20>REF(PL20,1) AND ZTJD10=2 OR (ZTJD10=0 OR ZTJD10=2) AND EX2,H*1.02,'清仓!'),LINETHICK3,COLORWHITE; DRAWTEXT(EN2 AND PL20>REF(PL20,1) AND ZTJZ10=3,L*0.96,'④'),LINETHICK3,COLORYELLOW; DRAWTEXT(EN1 AND PL10>REF(PL10,1) AND ZTJZ5=3,L*0.95,'⑷'),COLORYELLOW; EMA13:=EMA(C,13); EMA34:=EMA(C,34); EMA55:=EMA(C,55); EMA120:=EMA(C,120); CR1:=(C-REF(C,1))/REF(C,1)*100>0.5; CR2:=V>MA(V,5)*0.6; CR3:=COUNT(CROSS(EMA13,EMA55),3)=1; CR4:=ABS(EMA34-EMA55)/EMA55<0.03; CR5:=EMA55<=EMA120 AND EMA55>=REF(EMA55,1); CR6:=FILTER(CR1 AND CR2 AND CR3 AND CR4 AND CR5,2); DRAWTEXT(CR6,C*0.98,'风险'),COLORWHITE;

    浏览6592次浏览
    2023-07-19 17:01
  • 神奇指标

    通达信愚公移山主图解盘

    通达信愚公移山主图解盘牛市熊市思维!基本观点是:所谓牛市思维,也就是对于一个牛市市场,就不能想着会回调太多,让你轻松上车,差不多就可以参与了,另外,不能因为涨多了就怕。好好持股,有钱就买才是赚大钱的根本。反之,对于一个熊市市场,不能有太高期待,有差不多的反弹,就应该卖。平时要谨慎参与,不能因为觉得跌多了就可以放心大买特买。本质上,也就是顺势而为。投资不能只能凭自己的想象来参与,而是要看市场的势,也就是赚钱的路在哪儿?小的就是一个市场的某个板块,大的就是看全球资金去哪儿。越是大的越是容易判断,因为一旦起势,很难逆转,从而你参与的机会成功率就高。A001:=CLOSE-REF(CLOSE,6); A002:=MA(A001,6); A003:=((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*100; A004:=SMA(A003,3,1); A005:=SMA(A004,3,1); A006:=EMA((3*A004-2*A005),2); A007:=(HIGH+LOW+CLOSE)/3; A008:=((A007-MA(A007,14))/(0.015*AVEDEV(A007,14)))/2; A009:=(A008+(EMA(((0-(100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14))))+100)/100,3)*200-100))/2; A010:=A009-REF(A009,14); A011:=A009-REF(A009,26); A012:=(A009+A010+A011)/3; KKM:=EMA(A012,4); A013:=HHV(HIGH,34); A014:=(2*CLOSE+HIGH+LOW)/4; A015:=LLV(LOW,34); A016:=EMA(((A014-A015)/(A013-A015))*100,13); A017:=EMA(0.667*REF(A016,1)+0.333*A016,2); KKMD:=A016-A017>1 AND A016<30 AND A017<30; KKML:=A016-A017<0 AND A016>80 AND A017>80 AND REF(A016-A017,1)>0; KKMQ:=COUNT(A016-A017>0,2)=2; KKAL:=(A016-A017)<0; 生命线:MA(CLOSE,20),COLOR0000FF; 取舍线:MA(CLOSE,10); DRAWTEXT(FILTER(KKMD,30),L,'最佳买入时机★'),COLOR00FFFF; DRAWTEXT(FILTER(KKML,30),H,'最佳卖出时机'),COLORFFFF00; DRAWTEXT(FILTER(KKMQ,30),C,'持仓区'),COLOR00FF00; DRAWTEXT(FILTER(KKAL,30),H,'空仓区'),COLORFF8080; DRAWTEXT(FILTER(CLOSE/REF(CLOSE,1)>INDEXC/REF(INDEXC,1),30),L*0.95,'该股强于大盘'),COLORFF00FF; DRAWTEXT(crOSS(MA(CLOSE,5),MA(CLOSE,10)),L*0.92,'可出手'),COLORFF00FF; DRAWTEXT(CROSS(MA(CLOSE,10),MA(CLOSE,5)),H*1.08,'收手了'),COLORFF0000; DRAWTEXT(FILTER(KKM>EMA(KKM,4) AND KKM>REF(KKM,1),30),L*0.98,'快速介入'); DRAWTEXT(FILTER(KKM<EMA(KKM,4) AND KKM<REF(KKM,1),30),H*1.02,'风险较大'); DRAWTEXT(FILTER(KKM>EMA(KKM,4) AND KKM<REF(KKM,1),30),H,'休息观望~'),COLORAA8800; DRAWTEXT(FILTER(KKM<EMA(KKM,4) AND KKM>REF(KKM,1),30),L,'有防御能力') ,COLORAA00AA;

    浏览8861次浏览
    2023-07-03 16:48