神奇指标网
神奇指标网

这个月K线没有上下影线指标公式

浏览 7203次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-05

以下是这个月K线没有上下影线指标公式

月K引用
ND1970:=(YEAR-1970)*365+INTPART((YEAR-1972)/4)-IF(INTPART(YEAR/4)=YEAR/4,1,0)+DAY+(MONTH-1)*30+IF(MONTH<=8,INTPART(MONTH/2),INTPART((MONTH-7)/2)+4)-IF(MONTH>2 AND INTPART(YEAR/4)=YEAR/4,1,IF(MONTH>2 AND NOT(INTPART(YEAR/4)=YEAR/4),2,0));
 C1:C;
 O2:REF(O,BARSLAST(ND1970-REF(ND1970,1)>MONTH-REF(MONTH,1)));
 H2:HHV(H,BARSLAST(ND1970-REF(ND1970,1)>MONTH-REF(MONTH,1))+1);
 L2:LLV(L,BARSLAST(ND1970-REF(ND1970,1)>MONTH-REF(MONTH,1))+1);

 

月K线
 月开盘1:="月K引用.O2#MONTH",LINETHICK0;
月收盘:="月K引用.C1#MONTH",LINETHICK0;
月最高:"月K引用.H2#MONTH",LINETHICK0;
月最低:"月K引用.L2#MONTH",LINETHICK0;

 K1M:=月开盘1=REF(月开盘1,1) AND 月收盘=REF(月收盘,1) AND 月最高=REF(月最高,1) AND 月最低=REF(月最低,1);
 K3M:=REF(C,1)=DYNAINFO(3) AND O=DYNAINFO(4) AND C=DYNAINFO(7) AND H=DYNAINFO(5) AND L=DYNAINFO(6);
 DDM:=REF(BARSLAST(K1M=0)+1,1),LINETHICK0;
 DD1M:=CROSS(BACKSET((K1M=0 OR K3M) AND DDM=5,4),0.5),LINETHICK0;
 DD2M:=CROSS(BACKSET((K1M=0 OR K3M) AND (DDM=4 OR DDM=3),3),0.5),LINETHICK0;
 DD3M:=CROSS(BACKSET((K1M=0 OR K3M) AND DDM<=2,2),0.5),LINETHICK0;
 BK1M:=DD1M OR DD2M OR DD3M;
 BK2M:=CROSS(BACKSET(K1M=0,2),0.5);
 BK3M:=CROSS(BACKSET(K1M=0 AND REF(K1M=0,1),2),0.5);
月开盘:IF(BARSLAST(K1M=0)=0,O,REF(O,BARSLAST(K1M=0))),LINETHICK0;
 K0M:=月收盘>月开盘 OR (月收盘=月开盘 AND 月收盘>REF(月收盘,BARSLAST(K1M=0)+1));
 STICKLINE(K0M AND BK1M,月最高,月收盘,0.2,0),COLORLIRED;
 STICKLINE(K0M AND ((K1M AND BK2M=0 AND K3M=0) OR BK3M),月开盘,月收盘,8,0),COLORLIRED;
 STICKLINE(NOT(K0M) AND BK1M,月最高,月最低,0.2,0),COLORLIGREEN;
 STICKLINE(NOT(K0M) AND ((K1M AND BK2M=0 AND K3M=0) OR BK3M),月开盘,月收盘,8,0),COLORLIGREEN;

 

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论