神奇指标网
  • 神奇指标

    通达信双色分水岭框架提示点

    通达信双色分水岭框架提示点围绕市场的热点,涨停做文章,是我的交易系统的选股策略。不同的个性,理解会出现各自 不同的重点参与阶段。有的做拉升,有的做高位盘整,有的做第二波。还是细化到各个阶段的每个细节,这里绝对是有规律性的东西,变化很多,但是有共性的东西存在。温故而知新,看过历史上几千张K线图的,经历过无数次同类型的战斗,就有明确的心得。至于盘中实施操作,的确更多时候靠即时盘感与条件反射。掌握市场的根本,胜利接踵而至;如果被别人掌握了根,就会失败。买卖那一刻的冷静不仅是对股票走势的信心,更是自身境界的体现。小资金做大需要一些天赋和理解,不是每个人都能做到。短期内可以做到的核心是,首先,如果你的模式是正确的,你就不能没有模式,也不能走弯路。你需要不断地尝试和犯错误,比如经常看你的交割单,哪些赚了钱,哪些赔了钱,你需要不断地纠正和调节自己。 在这个指标中,红K波段持有上升趋势,绿顶冲高减仓,蓝k下跌卖出,上轨不减仓,下轨超卖反弹,中线分水岭,形态清晰,信号明显。N:=17; M:=18; 红K波段升势持股:0,COLORRED,NODRAW; 绿顶冲高减仓:0,COLOR00FF88,NODRAW; 蓝K波段跌势卖出:0,COLORFF6D00,NODRAW; 上轨不过减仓:0,COLOR00FF00,NODRAW; 下轨超跌反弹:0,COLORWHITE,NODRAW; CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20); BB:=ABS((CLOSE+2*HIGH+LOW)/4-MA(CLOSE,17))/MA(CLOSE,17); DD:=DMA(CLOSE,CC); EE:=DMA(CLOSE,BB); 低吸:=REF((1-3/100)*EE,2); 强弱分界线:=EMA(低吸,7),LINETHICK2,COLORFF6C00; 短支撑:=EMA((LLV((C+L)/2,6)+LLV((C+L)/2,5)+LLV((C+L)/2,4)+LLV((C+L)/2,3)+LLV((C+L)/2,2)+2*(C+L+H)/3)/7,3),COLORWHITE; 波段趋势:=EMA(短支撑,4); 涨幅:=(C-REF(C,1))/REF(C,1)*100; 走平支撑线:=LLV((HIGH+2*LOW+OPEN+CLOSE)/5*2.03-H,30)*1.006,COLORABFF40,LINETHICK2; 穿两线:=((CROSS(C,短支撑) AND CROSS(C,波段趋势)) OR (L<短支撑 AND C>波段趋势 AND 短支撑<波段趋势 ))AND 短支撑>REF(短支撑,1) AND C>REF(C,1)*1.02 AND (C-O>H-C) AND V>REF(V,1) AND (C>强弱分界线 OR C<强弱分界线 AND C>REF(C,1)*1.07); DRAWTEXT(穿两线,L*0.985,'上攻'),COLORFF00FF; STICKLINE(穿两线,H,L,0,1),COLORYELLOW,LINETHICK2; STICKLINE(穿两线,O,C,4.5,1),COLORYELLOW,LINETHICK2; B1:=MA(CLOSE,N)+MA(CLOSE,N)-REF(MA(CLOSE,N),1); 分水岭:IF(MA(CLOSE,N)<B1,B1,MA(CLOSE,N)),COLORRED,LINETHICK2; IF(分水岭<REF(分水岭,1),分水岭,DRAWNULL),COLOR00FF00,LINETHICK2; IF(分水岭>REF(分水岭,1)*0.999,分水岭,DRAWNULL),COLORRED,LINETHICK3; DRAWTEXT(ISLASTBAR,分水岭,'【分水岭】'),COLORRED; DDD:=分水岭<REF(分水岭,1); IF(DDD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2; 操作线:=分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2; IF((操作线<REF(操作线,1) AND C<操作线) OR (操作线>REF(操作线,1) AND C<操作线),操作线,DRAWNULL),COLORFF6C00,LINETHICK2; B2:=MA(CLOSE,M)+MA(CLOSE,M)-REF(MA(CLOSE,M),1); 分水岭2:=IF(MA(CLOSE,M)<B2,B2,MA(CLOSE,M)); 操作线2:=分水岭2-(EMA(C,3)-分水岭2); 短线:=MA(C,5),COLORWHITE,LINETHICK2; IF(短线>=REF(短线,1),短线,DRAWNULL),COLORFF00FF,LINETHICK2; IF(短线<REF(短线,1),短线,DRAWNULL),COLORFF9900,LINETHICK2; CC0:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20); DD0:=DMA(CLOSE,CC0); 上轨:(1+8/100)*DD0,POINTDOT,COLORYELLOW; IF(H>上轨,上轨,DRAWNULL),POINTDOT,LINETHICK4,COLOR00FF00; 下轨:(1-8/100)*DD0,POINTDOT,COLORFF00FF; S:=(短线>操作线); IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4; 买入红箭头:=CROSS(分水岭,操作线) AND C-O>H-C AND 涨幅>1; DRAWICON(买入红箭头,L*0.985,1); 白K转折点:=(CROSS(C,分水岭) AND CROSS(C,操作线)) OR (L<操作线 AND CROSS(C,分水岭) AND C>MA(C,6) AND C>操作线) OR (L<操作线 AND C>操作线 AND C>分水岭 AND C>MA(C,6)) OR (分水岭>操作线 AND CROSS(C,分水岭) AND CROSS(C,MA(C,6) )); STICKLINE(白K转折点,OPEN,CLOSE,3.5,0),COLOR0055FF; STICKLINE(白K转折点,OPEN,CLOSE,3,0),COLOR0099FF; STICKLINE(白K转折点,OPEN,CLOSE,2.2,0),COLOR00BBFF; STICKLINE(白K转折点,OPEN,CLOSE,1.5,0),COLOR00DDFF; STICKLINE(白K转折点,OPEN,CLOSE,0.4,0),COLOR00FFFF; STICKLINE( C>操作线 AND 操作线>REF(操作线,1)*0.99 ,HIGH,LOW,0,1 ),COLORRED; STICKLINE( C>操作线 AND 操作线>REF(操作线,1)*0.99,OPEN,CLOSE,3,1 ),COLOR0000CC; STICKLINE(C>操作线 AND 操作线>REF(操作线,1),HIGH,LOW,0,0 ),COLORRED; STICKLINE(C>操作线 AND 操作线>REF(操作线,1) ,OPEN,CLOSE,2.8,0 ),COLOR0000AA; STICKLINE((C<操作线2) AND C<O AND 涨幅<7 AND NOT(白K转折点) ,CLOSE,OPEN,3,0),COLORFF6C00; STICKLINE((C<操作线2) AND C>O AND 涨幅<7 AND NOT(白K转折点) ,CLOSE,OPEN,3,1),COLORFF6C00; STICKLINE((C<操作线2) AND 涨幅<7 AND NOT(白K转折点) ,C,H,0.1,0),COLORFF6C00; STICKLINE((C<操作线2) AND 涨幅<7 AND NOT(白K转折点) ,O,L,0.1,0),COLORFF6C00; 波段卖出:=短线>分水岭 AND CROSS(操作线2,C) OR (COUNT(白K转折点 OR 买入红箭头,3)>0 AND CROSS(操作线2,C)) OR (CROSS(分水岭,短线)AND REF(H,1)>分水岭 AND C<短线 AND REF(H,1)>分水岭) ; 卖出:=COUNT(CROSS(分水岭,短线),4)>=1 AND CROSS(短线,C) AND C<操作线2; 段头铡刀:= (CROSS(短线,C) AND 涨幅<-7 AND 短线>分水岭); DRAWTEXT((白K转折点 OR 买入红箭头) AND 分水岭>REF(分水岭,1)*0.998 AND 涨幅>2.4 ,L*0.92,'买入'),COLORYELLOW; DRAWTEXT(波段卖出 AND REF(波段卖出,1)=0 OR 卖出 ,H*1.02,'卖出'),COLOR00FF00; DRAWTEXT(段头铡刀,H*1.035,'断头铡刀'),COLORF0F900; 洗盘回升:=(REF(段头铡刀,1)>0 AND 涨幅>9) OR (REF(段头铡刀,1)>0 AND C>REF(O,1) AND 涨幅>5); DRAWTEXT(洗盘回升,L*0.98,'洗盘回升'),COLOR00FFFF; STICKLINE(CROSS(短线,C) AND 涨幅<-7 AND 短线>分水岭 ,OPEN,CLOSE,3,0 ),COLOR00FF00; A2:=(C-REF(C,1))/REF(C,1)*100<1.02; A3:=H>MA(C,5)*1.12; AA:= A2 AND A3; DRAWTEXT(AA,H*1.02,'高减'),COLORWHITE; STICKLINE(AA,H,L,0.3,0),COLORFF0000; LC:=REF(CLOSE,1); RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100); DRAWTEXT(CROSS(88,RSI) AND H>分水岭*1.2 AND H>MA(C,5)*1.09 ,(HIGH * 1.035),'高抛'),COLORYELLOW; VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20; VAR12:=(HIGH+LOW+CLOSE)/3; VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14)); VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70)); VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

    浏览2378次浏览
    2022-11-29 17:24
  • 神奇指标

    通达信主图新趋势低级买点

    通达信主图新趋势低级买点12年夏天我在云南玩,看到微博的hotmoneyking,被超短理念和文采深深折服。然后我在tgb知道了asking,龙飞虎,炒股养家,不足道之。特别要说的还是炒股养家。12年,他就写出了养家心法。很多人认为养家心法是照搬武侠小说的xx心法,为了酷炫一点,其实,养家的心法指的是,他是开辟了一条用大众心理学(行为学)来分析股市的新路。这个路子以前大家也在用,但是没人总结到他这个高度,他的心法,指的是是心理学分析法。和所有散户一样,我把养家的所有帖子一遍遍看,看了几十遍总归有的。身边朋友还有人每天早期读了30-50遍的时候,感觉养家很多地方遮遮掩掩,不愿意说透,还有点地方是有点故意繁复,搪塞之感。现在明白之后,一条条翻出来读,原来,养家把机密全部都说出来了。哇塞,他是真敢说。把那些藏在家里床底下小鞋子里连老鼠都找不到的东西,都放大庭广众说了。另外,看着养家的语录,十多年后还在被大家理解,传颂,解读,我认为是养家的巨大福报。造福很多人和家庭,也给自己和家人积累了很大的福报。悟道是自己的,比海更深处的曦光。分享是快乐的,比钱更温暖的福报。希望我的小故事,可以给每一个熊市深处,迷茫中的你,一点小微光。临摹抄写,大家都很欣赏养家,但是,又学不到。公式: EMA13:=EMA(C,13),COLORWHITE; EMA21:=EMA(C,21),COLORYELLOW; EMA34:=EMA(C,34),COLORFF00FF; EMA60:=MA(C,60),COLORFFCC66; VAR2:=(2*CLOSE+HIGH+LOW)/4; VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1); VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4); 散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3; 庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3; DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLORLIRED; DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),COLORGREEN; DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1); DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2); VAR9:=CLOSE-REF(CLOSE,5); VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5); VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20); 卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100); DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2); 卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42); B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA; S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW; VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3; S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN; A0:=(L+H+C*2)/4; A1:EMA(A0,14)COLORBLUE,LINETHICK2; A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2; A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW; A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW; 看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2}; 逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2}; 买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK3; 卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK3; STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF; STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC; STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF; STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;

    浏览4425次浏览
    2022-11-21 11:34
  • 神奇指标

    通达信多空精品提示主图

    通达信多空精品提示主图短线炒手第一原则,弱市不做。无论水平多高的短线炒手,只要做不到这一点,都逃脱部了亏损的命运。市场上有很多水平、经验、盘感都有过人之处的高手,大部分的利润回吐都是没有做好这一点。我们短线资金再遇到大跌,特别市在单边下跌的时候,对我们来说,基本上是毫发无伤的。因为我们的模式就是不长时间持股,在大跌中不会亏钱。每轮行情的实质就是场外资金蜂拥而来,呼啸而去。股票市场遵从的是生成发展,适者生存,弱者淘汰。这是自然界的大道。是真理,于道德无关。源码: VAR1:=(4*CLOSE+LOW+HIGH)/6; VAR2:=EMA(SLOPE(CLOSE,25)*20+CLOSE,73); VAR3:=(2*CLOSE+LOW+HIGH)/5; 均价:EMA(VAR1,1),LINETHICK1; 买卖:EMA(VAR1,6),COLORBLUE,LINETHICK1; 动能:EMA(VAR1,14),COLORYELLOW,LINETHICK1; 多空:2*(买卖+动能)/4,COLORRED,LINETHICK1; 强弱:MA(CLOSE,38),COLORGREEN,LINETHICK1; 阻力:MA(CLOSE,73),COLORMAGENTA,LINETHICK1; 重压:MA(CLOSE,267),COLORCYAN,LINETHICK1; DRAWICON(CROSS(动能,(均价*1.003)),(HIGH*1.01),8),LINETHICK2,COLORCYAN; DRAWICON(CROSS(强弱,H),(HIGH*1.02),6),LINETHICK2,COLORGREEN; DRAWICON(CROSS(L,强弱),(LOW*0.98),5),LINETHICK2,COLORYELLOW; DRAWICON(CROSS(均价,(多空*1.002)),(LOW*0.98),7),LINETHICK2,COLORMAGENTA; DRAWTEXT(CROSS(买卖,(动能*1.0045)),(LOW*0.98),'←加仓'),LINETHICK2,COLORMAGENTA; LC:=REF(CLOSE,1); RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100; DRAWICON(CROSS(80,RSI) ,( HIGH*1.01),2) ,COLORBLUE; DRAWICON(CROSS(RSI,22),(LOW*0.98),1),LINETHICK2,COLORMAGENTA; DRAWICON(CROSS(RSI,82.5),(HIGH*1.01),9),COLORBROWN; RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;炒股就是炒概率,其实就是这个回事。打板也是打概率,有高成功率的方法也可以不打板,低吸也行。所有的操作方法都是在概率原理上总结,然后又高成功率保证,自然就进入赚钱的行列。

    浏览4553次浏览
    2022-11-14 17:26
  • 神奇指标

    通达信缘起悟道升天主图

    通达信缘起悟道升天主图小资金需要一些天赋和理解,不是每个人都能做到的。短期内能做到的核心是,首先,你就不能没有模式,你的模式是要正确的,你就不能走弯路。你需要不断地用模式来尝试和犯错误,比如经常看到你的交割单,哪里是赚钱,哪里是赔钱,你需要不断地纠正和控制自己。如何处理每个阶段,每一次撤退都是可控的,自己要确定,长期坚持,自己会越来越自信,需要给自己一个积极的反馈,这样最终才能成功悟道。祝大家都能赢出来,不要心急。 代码源:C2:=REF(C,1); 涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0); STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED; STICKLINE(涨停,H,L,0,0),COLORRED; 跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0); STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN; STICKLINE(跌停,H,L,0,1),COLORGREEN; 圣:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10; 灵:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100; 仙:=CEILING(SMA(灵,13,8)); 编著:=SMA(圣,21,8); AABB:=IF(L,CONST(L),DRAWNULL); 启动:STICKLINE(仙-编著>75,AABB,AABB*0.99,15,1),COLOR0000FF; VARZT:=BARSLAST(启动); {DRAWTEXT(VARZT=1,0.99*(AABB+AABB*0.98)/2,'平台启动'),COLORYELLOW;} AAA:=(3*C+H+L+O)/6; VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36; VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3; VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3; VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3; VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3; VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3; DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0)); 短线:VAR1,COLORWHITE; 中线:VAR6,COLORYELLOW; 下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN; TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1; 立桩量:=FILTER(TJ1,5); TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0))); 突破:=TJ2=1; STICKLINE(CLOSE,REF(HIGH,BARSLAST(立桩量)),REF(HIGH,BARSLAST(立桩量)),1,0),COLORCYAN; STICKLINE(CLOSE,REF(LOW,BARSLAST(立桩量)),REF(LOW,BARSLAST(立桩量)),1,0),COLORYELLOW; TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0))); 三天法则:=TJ3=1; 成立:=三天法则 AND 突破; 条件成立:=FILTER(成立,3); DRAWTEXT(条件成立,L*0.99,'悟道'),COLORYELLOW; STICKLINE(C>=O,C,O,3,0),COLOR000045; STICKLINE(C>=O,C,O,2.5,0),COLOR000065; STICKLINE(C>=O,C,O,2,0),COLOR000085; STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5; STICKLINE(C>=O,C,O,1,0),COLOR0000C5; STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5; STICKLINE(C>=O,H,L,0,0),COLOR0000F5; STICKLINE(C<O,C,O,3,0),COLOR353500; STICKLINE(C<O,C,O,2.5,0),COLOR454500; STICKLINE(C<O,C,O,2,0),COLOR555500; STICKLINE(C<O,C,O,1.5,0),COLOR656500; STICKLINE(C<O,C,O,1,0),COLOR757500; STICKLINE(C<O,C,O,0.5,0),COLOR858500; STICKLINE(C<O,H,L,0,0),COLOR959500; HIGHN:=10; LOWN:=10; HIGHDISPLAY:=0; LOWDISPLAY:=0; ZGDISPLAY:=0; MADISPLAY:=0; AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1); QY:=BACKSET(AA,HIGHN+1); CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1); DRAWICON(CC,H*1.02,2); DDD:=BARSLAST(CC); GDTS:=IF(CC,CURRBARSCOUNT,0); DINGBU:=IF(DDD,REF(H,DDD),H);{顶部} DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS); DINGBU1:=REF(DINGBU,DDD+1); GDCS1:=CONST(DINGBUTS); DINGBUTS1:=REF(DINGBUTS,DDD+1); GDCS2:=CONST(DINGBUTS1); DINGBU2:=REF(DINGBU1,DDD+1); MM:=IF(CURRBARSCOUNT>GDCS2,0,1); 上轨:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORBLUE,LINETHICK1; DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT; DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT; AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1); QY1:=BACKSET(AA1,LOWN+1); CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1); DRAWICON(CC1,L*0.98,1); DD1:=BARSLAST(CC1); DDTS:=IF(CC1,CURRBARSCOUNT,0); YDB:=IF(DD1,REF(L,DD1),L); DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS); DDCS1:=CONST(DDTS1); ZDB:=REF(YDB,DD1+1); DDTS2:=REF(DDTS1,DD1+1); DDCS2:=CONST(DDTS2); 下轨:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK1; ZGSTAR:=(上轨+下轨)/2; ZGEND:=CONST((上轨+下轨)/2); STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2); 中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK1; DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT; DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT; VAR7:=0; VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100; VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100; VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0); VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3); VAR12:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3); VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3); VAR14:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3); VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3); VAR16:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3); VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3); VAR18:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3); VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150); 买1:=VAR10; 买2:=(VAR11+VAR13+VAR15+VAR17); 卖1:=(VAR12+VAR14+VAR16+VAR18); B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW; DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'缘起'),COLORRED; S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN; DRAWTEXT(卖1>0,HIGH*1.02,'轮回'),COLORGREEN; DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1) ; DRAWICON((ZIG(3,5)=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2); ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK; VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0); K:=EMA(VAR7,5)*2, , COLORFF00FF; D:=EMA(K,5), , COLORWHITE; J:=K*3-D*2, ,COLORYELLOW; VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10; HS:=VOL/CAPITAL*100, , COLORGREEN; VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20; VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1); DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'众仙归位'),LINETHICK1,COLORFF00FF; VAR1A:=IF(VARE>0,VARE,0); VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60; VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100; DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,'大限') COLORWHITE; 指标王:=CROSS(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),SMA(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),3,1)) AND SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1)<20; DRAWTEXT(指标王,L,'八仙过海'),COLORYELLOW; DRAWTEXT(VAR1,L*0.98,'顿悟'),COLORYELLOW; DRAWTEXT(CROSS(MA(C,3),MA(C,9)) AND C>=REF(C,1) AND C>O,L*0.98,'鸡犬升天'),COLORMAGENTA; 下降压力线:DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),LINETHICK2; STICKLINE(CURRBARSCOUNT=2,L,L,10,0),COLORGREEN,; DRAWNUMBER(ISLASTBAR,REF(L,1),REF(L,1));

    浏览7548次浏览
    2022-11-09 15:22
  • 神奇指标

    通达信主图网格趋势多重买点提示

    通达信主图网格趋势多重买点提示交易的本质是简化复杂的事物,重复正确的操作。没有必要迷信太多的参考,严格执行纪律,努力提高控制力,使交易更加稳定,了解市场偏好,是大票市场还是小票市场,是价值趋势还是主题炒作,是高加速还是低超卖,你要做的就是理解和跟随。不管熊牛,永远七亏一平两胜。日利10%,月利10%。稳定永远是我们追求的最终目标。复利是世界第八大奇迹,稳定的交易是最终目的地。经历了迷茫和痛苦,背负着生活的压力,是信念让我走到了今天,所以我非常重视信念这个词。怀着诚实和感恩的心,用科学的方法不断学习,你的机会就会比别人多。把复杂的事情做简单,把简单的事情做细致!回头检视自己的投资历程,进行回顾,分析消化、理解改善会是一个更好的经历,去更清楚了解自己可以改善的地方以及长处。盈利的为什么盈利,亏损的为什么亏损,指定计划再执行,承前启后,才能继续进步。红绿网格判断多空趋势 公式:LOCK:=1;M8:=EMA(CLOSE,8);M13:=EMA(M8,13);   VAR1:=EMA(M13,62);VAR2:=(CLOSE+HIGH+LOW)/3;   VAR3:=EMA(VAR2,10)*LOCK;VAR4:=REF(VAR3,1)*LOCK;   STICKLINE(VAR3>VAR4,VAR3,VAR4,4,1),colorred;STICKLINE(VAR3<VAR4,VAR3,VAR4,4,1),COLOR00CC33;   DRAWTEXT(CROSS(VAR3,VAR4),L-0.0,'←顺'),colorred;   DRAWTEXT(CROSS(VAR4,VAR3),H+0.0,'←逆'),colorgreen;    C3:=REF(C,1); 涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),2,0);   STICKLINE(涨停,OPEN,CLOSE,1,0),coloryellow;   跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),2,0);   STICKLINE(跌停,OPEN,CLOSE,1,0),colorblue;    QC:=REF(CLOSE,1);   RSV:=(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*100);   K:=SMA(RSV,3,1);   D:=SMA(K,3,1);   YX:=((CLOSE>QC) AND C>O);   KK:=HHV(K,5);   HH:=HHV(D,5);   D1:=REF(D,1);   K1:=REF(K,1);   DRAWTEXT((((D1<30) AND CROSS(K,D)) AND YX),(LOW * 0.99),'●←短买!'),coloryellow;   压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;   支撑:MA(REF(LLV(C,30),1),2),COLORABFF46; AA1:=AMOUNT/V;BB1:=L<AA1*0.9;   DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;   DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;   DRAWTEXT(CROSS(DA-DB,0),L*0.98,'★B'),colormagenta;   AF:=CROSS(AA1,BB1);   DRAWTEXT(AF,LLV(L,4),'止损线'),coloryellow;   TYP1:=(HIGH+LOW+CLOSE)/3;   C1:=(TYP1-MA(TYP1,14))/(0.015*AVEDEV(TYP1,14));   C2:=(TYP1-MA(TYP1,55))/(0.015*AVEDEV(TYP1,55));   CCI背:=IF(LLV(CCI,2)>LLV(CCI,7) AND LLV(L,2)<=LLV(L,7) AND LLV(CCI,2)>MA(CLOSE,60),1,0),colorwhite;   DRAWICON(CCI背 AND REF(CCI,1)<-150 AND C>O,L*0.98,1);   DRAWTEXT(CCI背 AND REF(CCI,1)<-150 AND C>O,L*0.9,'杀'),colorgreen;   XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));   DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'●买点');   XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);   XL3:=CROSS(XL2,(0 - 20));   DRAWTEXT((XL3 > 0),(LOW - 0.2),'●绝对底部');  

    浏览9128次浏览
    2022-10-31 14:13
  • 神奇指标

    通达信涨停起爆点主图均线指标

    通达信涨停起爆点主图均线指标如何建立自己的交易系统。围绕市场的热点,涨停做文章,是我的交易系统的选股策略。不同的个性,理解会出现各自 不同的重点参与阶段。有的做拉升,有的做高位盘整,有的做第二波。还是细化到各个阶段的每个细节,这里绝对是有规律性的东西,变化很多,但是有共性的东西存在。温故而知新,看过历史上几千张K线图的,经历过无数次同类型的战斗,就有明确的心得。至于盘中实施操作,的确更多时候靠即时盘感与条件反射。盘后的复盘也很重要,我比较喜欢去揣摩强势股的运行思路,看参与者的进出角度并在不断的验证中,逐步接近主流游资的思维,理念。当你高效的跟随了市场,机会几乎是接踵而至。真正改变你命运的是你的性格与学习能力,前提是你还能坚持下来。源码:P:=6;P1:=8;M:=2;M1:=3;N:=11;{=================k线柱=================}{红}stICKLINE(C>O,C,O,1,0),COLORYELLOW ;STICKLINE(C>O,H,L,0,0),COLORRED;{绿}STICKLINE(C<O,C,O,2,0),COLORCYAN;STICKLINE(C<O,H,L,0,0),COLORCYAN;{=================板块、行业、概念=================}DRAWTEXT_FIX(C>0,0.0,0.0,0,STRCAT(' ---所属行业---:',HYBLOCK)),COLORFFFFFF;DRAWTEXT_FIX(C>0,0.30,0.0,0,STRCAT(' ---所属地区---:',DYBLOCK)),COLORFFFFFF;DRAWTEXT_FIX(C>0,0.30,0.1,0,STRCAT('-------=======横盘做T+0坚决莫贪=======--------:',GNBLOCK)),COLORCYAN;DRAWTEXT_FIX(ISLASTBAR,0.20,0.90,0,ZSBLOCK),COLORYELLOW;DRAWTEXT_FIX(ISLASTBAR,0.20,0.99,0,FGBLOCK),COLORYELLOW;{=================多空布林=================}C2:=REF(C,1);涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;STICKLINE(涨停,H,L,0,0),COLORmaGENTA;bbi:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORBLacK,LINETHICK1;UPR:BBI+P*STD(BBI,N),COLORCYAN,LINETHICK1;DWN:BBI-P*STD(BBI,N),COLORBLUE ,NODRAW , ;MA1:MA(CLOSE,P1),COLORRED,LINETHICK1;买线:=EMA(C,2);卖线:=EMA(SLOPE(C,21)*20+C,42);指导线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),COLORYELLOW,LINETHICK1;界: MA(CLOSE,27),COLORMAGENTA ,LINETHICK1;BU:=crOSS(指导线,界);DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA:=EMA(DIF,9);AAA:=(DIF-DEA)*2;ZT1:=C>=REF(C,1)*1.097 ;起爆:=AAA>=2*REF(AAA,1) AND ZT1 AND Abs(AAA)<=1 AND C>MA(C,20) AND C<MA(C,20)*1.2 ;DRAWTEXT(起爆,L*0.99,'暴涨'),COLORYELLOW,LINETHICK3;VAR1:=EMA(EMA(EMA((CLOSE*6+LOW*2+HIGH+OPEN)/10,M),M),M);短线:= VAR1-REF(VAR1,1)+VAR1;中短:= MA(短线,M1);DRAWTEXT(CROSS(短线,中短),(LOW * 0.995),'★'),COLORYELLOW,LINETHICK3;{=================量柱=================}TJ:=vol>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;DRAWTEXT(TJ,LOW*1.1,'量'),COLORMAGENTA ;STICKLINE(TJ,OPEN,CLOSE,2.2,2),COLORMAGENTA ;K1:=SUMBARS(TJ,1);{================走强线 ================};HM1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,20))/EMA(CLOSE,20));HM2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),HM1);走强线:EMA(HM2,200)*1.118 ,LINETHICK1,COLORRED;DRAWTEXT(ISLASTBAR,走强线,' ←走强线'),COLORRED;{=================必升=================};VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.90),'★波段开始 '),COLORMAGENTA;DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.8),'★强势拉升'),COLOR00FFFF;{============操作线:分水岭================}B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);分水岭:IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),COLORFF00FF,NODRAW;操作线:分水岭-(EMA(C,3)-分水岭),COLORGREEN ,LINETHICK1;DRAWTEXT(ISLASTBAR,操作线,' ←拐点线'),COLORGREEN;{========超级主升==========}VAR4:=(((((REF(C,1)) * (1.1)) - C) < (0.01)) AND (H = C));E5:(EMA(C,5)),LINETHICK0 ,COLORWHITE;R:=(20 * H + 19 * (REF(H,1)) + 18 * (REF(H,2)) + 17 * (REF(H,3)));R1:=16*(REF(H,4)) +15*(REF(H,5))+14 * (REF(H,6)) + 13 * (REF(H,7));R2:=12*(REF(H,8))+11*(REF(H,9))+10 * (REF(H,10)) + 9 * (REF(H,11));R3:=8 * (REF(H,12)) + 7 * (REF(H,13)) +6*(REF(H,14))+5*(REF(H,15));R4:=4 * (REF(H,16)) + 3 * (REF(H,17)) +2 * (REF(H,18)) + REF(H,20);VAR5:=(R+R1+R2+R3+R4)/(210);VAR6:=(EMA(VAR5,90));妖股线:(VAR6 + (((C - (VAR6)) * C) - (VAR6)) / (VAR6)),LINETHICK0 ;VAR8:=(CROSS(妖股线,E5));DRAWTEXT((VAR8) AND (VAR4),L,'后市有牛'),LINETHICK3,COLORRED ;{===================A级起暴点=====================}DOWN:=OPEN>CLOSE;F:=COUNT(DOWN,6)=6;AD:=COUNT(C<REF(C,1) ,6)=6;BB:=(C<MA(C,30)*0.9);E:=F AND AD AND BB;AA:="macd.DEA"(12,26,9)<=0.6;ZT4:=C>=REF(C,1)*1.099 AND C< MA(C,20)*1.15 AND C>MA(C,20) AND "MACD.DEA"(12,26,9)<=0.3 AND"MACD.DEA"(12,26,9)>=0;ZT3:=C>=REF(C,1)*1.099 AND C< MA(C,20)*1.16 AND C>MA(C,20) AND AA AND C>=HHV(C,20) { AND V>REF(V,1)*1.3 } ;DRAWTEXT(ZT4 ,L*0.84,'C级起暴点');DRAWTEXT(ZT3,L*0.90,'A级起暴点');

    浏览5644次浏览
    2022-10-31 11:27
  • 神奇指标

    通达信红绿K线轨道波段主图

    通达信红绿K线轨道波段主图简化复杂的问题,反复做简单的事情,做细致的事情,做极端的事情。这是盈利和复利的基本方法。重复赚钱模式,详细研究,限制条件,果断操作信号。另外,我想说的是,执行比指标准确性更重要。你的行为与你的认知相匹配。行为是人类的本能控制,认知是人脑的控制。当你的行为与你的实际认知相匹配时,你可以做出最合理的行为。知识和行动之所以难以统一,主要是因为你对行为的结果没有深刻的理解。当后果越来越接近你时,你会感到一种危机感。当你不断意识到痛苦时,你会逐渐成为知识和行动的统一。 真正的损失会让你从痛苦中学习。 在这个指标中,红K波段持有上升趋势,绿顶冲高减仓,蓝k下跌卖出,上轨不减仓,下轨超卖反弹,中线分水岭,形态清晰,信号明显。先设置{参数:N:5,30,17,M:5,30,18}N:=17;M:=18;红K波段升势持股:0,COLORRED,NODRAW;绿顶冲高减仓:0,COLOR00FF88,NODRAW;蓝K波段跌势卖出:0,COLORFF6D00,NODRAW;上轨不过减仓:0,COLOR00FF00,NODRAW;下轨超跌反弹:0,COLORWHITE,NODRAW;CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);BB:=ABS((CLOSE+2*HIGH+LOW)/4-MA(CLOSE,17))/MA(CLOSE,17);DD:=DMA(CLOSE,CC);EE:=DMA(CLOSE,BB);低吸:=REF((1-3/100)*EE,2);强弱分界线:=EMA(低吸,7),LINETHICK2,COLORFF6C00;短支撑:=EMA((LLV((C+L)/2,6)+LLV((C+L)/2,5)+LLV((C+L)/2,4)+LLV((C+L)/2,3)+LLV((C+L)/2,2)+2*(C+L+H)/3)/7,3),COLORWHITE;波段趋势:=EMA(短支撑,4);涨幅:=(C-REF(C,1))/REF(C,1)*100;走平支撑线:=LLV((HIGH+2*LOW+OPEN+CLOSE)/5*2.03-H,30)*1.006,COLORABFF40,LINETHICK2;穿两线:=((CROSS(C,短支撑) AND CROSS(C,波段趋势)) OR (L<短支撑 AND C>波段趋势 AND 短支撑<波段趋势 ))AND 短支撑>REF(短支撑,1) AND C>REF(C,1)*1.02 AND (C-O>H-C) AND V>REF(V,1) AND (C>强弱分界线 OR C<强弱分界线 AND C>REF(C,1)*1.07);DRAWTEXT(穿两线,L*0.985,'上攻'),COLORFF00FF;STICKLINE(穿两线,H,L,0,1),COLORYELLOW,LINETHICK2;STICKLINE(穿两线,O,C,4.5,1),COLORYELLOW,LINETHICK2;B1:=MA(CLOSE,N)+MA(CLOSE,N)-REF(MA(CLOSE,N),1);分水岭:IF(MA(CLOSE,N)<B1,B1,MA(CLOSE,N)),COLORRED,LINETHICK2;IF(分水岭<REF(分水岭,1),分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;IF(分水岭>REF(分水岭,1)*0.999,分水岭,DRAWNULL),COLORRED,LINETHICK3;DRAWTEXT(ISLASTBAR,分水岭,'【分水岭】'),COLORRED;DDD:=分水岭<REF(分水岭,1);IF(DDD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;操作线:=分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;IF((操作线<REF(操作线,1) AND C<操作线) OR (操作线>REF(操作线,1) AND C<操作线),操作线,DRAWNULL),COLORFF6C00,LINETHICK2;B2:=MA(CLOSE,M)+MA(CLOSE,M)-REF(MA(CLOSE,M),1);分水岭2:=IF(MA(CLOSE,M)<B2,B2,MA(CLOSE,M));操作线2:=分水岭2-(EMA(C,3)-分水岭2);短线:=MA(C,5),COLORWHITE,LINETHICK2;IF(短线>=REF(短线,1),短线,DRAWNULL),COLORFF00FF,LINETHICK2;IF(短线<REF(短线,1),短线,DRAWNULL),COLORFF9900,LINETHICK2;CC0:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);DD0:=DMA(CLOSE,CC0);上轨:(1+8/100)*DD0,POINTDOT,COLORYELLOW;IF(H>上轨,上轨,DRAWNULL),POINTDOT,LINETHICK4,COLOR00FF00;下轨:(1-8/100)*DD0,POINTDOT,COLORFF00FF;S:=(短线>操作线);IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;买入红箭头:=CROSS(分水岭,操作线) AND C-O>H-C AND 涨幅>1;DRAWICON(买入红箭头,L*0.985,1);白K转折点:=(CROSS(C,分水岭) AND CROSS(C,操作线)) OR (L<操作线 AND CROSS(C,分水岭) AND C>MA(C,6) AND C>操作线)OR (L<操作线 AND C>操作线 AND C>分水岭 AND C>MA(C,6)) OR (分水岭>操作线 AND CROSS(C,分水岭) AND CROSS(C,MA(C,6) ));STICKLINE(白K转折点,OPEN,CLOSE,3.5,0),COLOR0055FF;STICKLINE(白K转折点,OPEN,CLOSE,3,0),COLOR0099FF;STICKLINE(白K转折点,OPEN,CLOSE,2.2,0),COLOR00BBFF;STICKLINE(白K转折点,OPEN,CLOSE,1.5,0),COLOR00DDFF;STICKLINE(白K转折点,OPEN,CLOSE,0.4,0),COLOR00FFFF;STICKLINE( C>操作线 AND 操作线>REF(操作线,1)*0.99 ,HIGH,LOW,0,1 ),COLORRED;STICKLINE( C>操作线 AND 操作线>REF(操作线,1)*0.99,OPEN,CLOSE,3,1 ),COLOR0000CC;STICKLINE(C>操作线 AND 操作线>REF(操作线,1),HIGH,LOW,0,0 ),COLORRED;STICKLINE(C>操作线 AND 操作线>REF(操作线,1) ,OPEN,CLOSE,2.8,0 ),COLOR0000AA;STICKLINE((C<操作线2) AND C<O AND 涨幅<7 AND NOT(白K转折点) ,CLOSE,OPEN,3,0),COLORFF6C00;STICKLINE((C<操作线2) AND C>O AND 涨幅<7 AND NOT(白K转折点) ,CLOSE,OPEN,3,1),COLORFF6C00;STICKLINE((C<操作线2) AND 涨幅<7 AND NOT(白K转折点) ,C,H,0.1,0),COLORFF6C00;STICKLINE((C<操作线2) AND 涨幅<7 AND NOT(白K转折点) ,O,L,0.1,0),COLORFF6C00;波段卖出:=短线>分水岭 AND CROSS(操作线2,C) OR (COUNT(白K转折点 OR 买入红箭头,3)>0 AND CROSS(操作线2,C)) OR (CROSS(分水岭,短线)AND REF(H,1)>分水岭 AND C<短线 AND REF(H,1)>分水岭) ;卖出:=COUNT(CROSS(分水岭,短线),4)>=1 AND CROSS(短线,C) AND C<操作线2;段头铡刀:= (CROSS(短线,C) AND 涨幅<-7 AND 短线>分水岭);DRAWTEXT((白K转折点 OR 买入红箭头) AND 分水岭>REF(分水岭,1)*0.998 AND 涨幅>2.4 ,L*0.92,'买入'),COLORYELLOW;DRAWTEXT(波段卖出 AND REF(波段卖出,1)=0 OR 卖出 ,H*1.02,'卖出'),COLOR00FF00;DRAWTEXT(段头铡刀,H*1.035,'断头铡刀'),COLORF0F900;洗盘回升:=(REF(段头铡刀,1)>0 AND 涨幅>9) OR (REF(段头铡刀,1)>0 AND C>REF(O,1) AND 涨幅>5);DRAWTEXT(洗盘回升,L*0.98,'洗盘回升'),COLOR00FFFF;STICKLINE(CROSS(短线,C) AND 涨幅<-7 AND 短线>分水岭 ,OPEN,CLOSE,3,0 ),COLOR00FF00;A2:=(C-REF(C,1))/REF(C,1)*100<1.02;A3:=H>MA(C,5)*1.12;AA:= A2 AND A3;DRAWTEXT(AA,H*1.02,'高减'),COLORWHITE;STICKLINE(AA,H,L,0.3,0),COLORFF0000;LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);DRAWTEXT(CROSS(88,RSI) AND H>分水岭*1.2 AND H>MA(C,5)*1.09 ,(HIGH * 1.035),'高抛'),COLORYELLOW;VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;VAR12:=(HIGH+LOW+CLOSE)/3;VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

    浏览8125次浏览
    2022-10-31 11:27
  • 神奇指标

    通达信高抛低吸趋势提示主图

    通达信高抛低吸趋势提示主图为什么知行合一很难。这主要时对行为所带来的结果没有深刻的认识。人人都知道抽烟喝酒有害身体健康,却很少有人因为这一点而去戒除,这是因为他们没有感受到戒除所带来的益处,或者说他们没有深刻体会到不戒除带来的后果。生命都有一种适应环境的能力,活在当下是一种天性,大部分人是不会考虑长期的事。人生有很多事情可以有不少试错的机会,当不断体会到痛苦后,在一件事上就会慢慢知行合一,不要忘记痛苦这会让你变得随心所欲。、希望大家都可以建立起自己的交易系统并且深刻落实贯彻它,否则别无用处,只有知行合一才能成功。下面分享一个主图指标,十分简单好用。关注重点:1. 主力线是否翻红2. 主力线相对位置3. 多重提示且主力线为红EMA13:=EMA(C,13),COLORWHITE; EMA21:=EMA(C,21),COLORYELLOW; EMA34:=EMA(C,34),COLORFF00FF; EMA60:=MA(C,60),COLORFFCC66; VAR2:=(2*CLOSE+HIGH+LOW)/4; VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1); VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3; DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),COLORLIRED; DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),COLORGREEN; DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1); DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2); VAR9:=CLOSE-REF(CLOSE,5); VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5); VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100); DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2);卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42); B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORMAGENTA; S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW;VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3; S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN; A0:=(L+H+C*2)/4; A1:EMA(A0,14)COLORBLUE,LINETHICK2; A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2; A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW; A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA{,LINETHICK2};逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,{LINETHICK2};买入持股:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK3;卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK3; STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF; STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC; STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF; STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;

    浏览7121次浏览
    2022-10-31 11:27
  • 神奇指标

    通达信主图精品进阶-多空提示

    通达信主图精品进阶-多空提示决定你收益的是:你是否不断精进,你的交易手法是否具有大局观,你的盘面阅读能力是否足够强大,强大到无限接近主流资金。太多的人喜欢术的庄严,而放弃了道的修炼。最近的生活,最近的城市,让我感受不到自己。潜意识,他象一件衣服,被默默藏在了房间的衣柜里。他依然在,但是我进门,好像到了家,却找不到心。这次修行,一方面,在现实世界,继续验证我悟道的内容。另一方面,找到内心,本真随即可见。低能量的全球经济,没有安全感的世界,未来的出路,就在自己的心里。和市场的回报里。让我们一起,拿到市场的回报,找到自己的心。下面这套指标用法奉献给大家1. 红色箭头表示多头,首先留意这个信号2. B S 为买卖点,B点可以逐步建仓,s点可以离场3. 留意加仓和笑脸信号。加仓代表进攻强势,笑脸是指多头趋势。4. 钱袋出现可以止盈离场,若多头强势则可以继续持股,扩大收益5. 哭脸出现坚决离场,以上特点反之亦然。源码:VAR1:=(4*CLOSE+LOW+HIGH)/6;VAR2:=EMA(SLOPE(CLOSE,25)*20+CLOSE,73);VAR3:=(2*CLOSE+LOW+HIGH)/5;均价:EMA(VAR1,1),LINETHICK1;买卖:EMA(VAR1,6),COLORBLUE,LINETHICK1;动能:EMA(VAR1,14),COLORYELLOW,LINETHICK1;多空:2*(买卖+动能)/4,COLORRED,LINETHICK1;强弱:MA(CLOSE,38),COLORGREEN,LINETHICK1;阻力:MA(CLOSE,73),COLORMAGENTA,LINETHICK1;重压:MA(CLOSE,267),COLORCYAN,LINETHICK1;DRAWICON(CROSS(动能,(均价*1.003)),(HIGH*1.01),8),LINETHICK2,COLORCYAN;DRAWICON(CROSS(强弱,H),(HIGH*1.02),6),LINETHICK2,COLORGREEN;DRAWICON(CROSS(L,强弱),(LOW*0.98),5),LINETHICK2,COLORYELLOW;DRAWICON(CROSS(均价,(多空*1.002)),(LOW*0.98),7),LINETHICK2,COLORMAGENTA;DRAWTEXT(CROSS(买卖,(动能*1.0045)),(LOW*0.98),'←加仓'),LINETHICK2,COLORMAGENTA;LC:=REF(CLOSE,1);RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;DRAWICON(CROSS(80,RSI) ,( HIGH*1.01),2) ,COLORBLUE;DRAWICON(CROSS(RSI,22),(LOW*0.98),1),LINETHICK2,COLORMAGENTA; DRAWICON(CROSS(RSI,82.5),(HIGH*1.01),9),COLORBROWN;RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

    浏览7578次浏览
    2022-10-31 11:27
  • 神奇指标

    通达信 众仙归位悟道趋势主图源码

    通达信 众仙归位悟道趋势主图源码大道至简,好用的强势股公式就是这么简单,出现信号的关键点就短线建仓,卖出的话就是根据自己原则,自己把握就好。不管是在什么时候,我都有耐心等待市场到达我称为“关键点”的那个位置,只有到了这个时候,我才开始进场交易,在我的操作中,只要我是这样的,总能赚到钱。因为我是在一个趋势刚开始的心理时刻开始交易的,我不用担心亏钱,原因很简单,我恰好是在我个人的原则告诉我立刻采取行动的时候果断进场开始跟进的,因此,我要做的就是,坐着不动,静观市场按照它的行情发展。我知道,如果我这样做了,市场本身的表现会在恰当的时机给我发出让我获利平仓的信号。 注意强势股短期出现信号后不是一定立刻大涨,切勿贪心。有了这个指标,机会多的是。也可以一次不要重仓一只个股,多股建仓,分仓位建仓,最好每次出手20%仓位,同时3-4只个股,平滑收益,心态会更好。源码:C2:=REF(C,1);涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0); STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED; STICKLINE(涨停,H,L,0,0),COLORRED;跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0); STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN; STICKLINE(跌停,H,L,0,1),COLORGREEN;圣:=(HHV(HIGH,21)-CLOSE)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;灵:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;仙:=CEILING(SMA(灵,13,8));编著:=SMA(圣,21,8); AABB:=IF(L,CONST(L),DRAWNULL);启动:STICKLINE(仙-编著>75,AABB,AABB*0.99,15,1),COLOR0000FF; {VARZT:=BARSLAST(平台启动);} {DRAWTEXT(VARZT=1,0.99*(AABB+AABB*0.98)/2,'平台启动'),COLORYELLOW;} AAA:=(3*C+H+L+O)/6; VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36; VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3; VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3; VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3; VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3; VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3; DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));短线:VAR1,COLORWHITE;中线:VAR6,COLORYELLOW;下跌:IF(VAR1=VAR6,VAR6,DRAWNULL),COLORGREEN; TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1;立桩量:=FILTER(TJ1,5); TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));突破:=TJ2=1; STICKLINE(CLOSE,REF(HIGH,BARSLAST(立桩量)),REF(HIGH,BARSLAST(立桩量)),1,0),COLORCYAN; STICKLINE(CLOSE,REF(LOW,BARSLAST(立桩量)),REF(LOW,BARSLAST(立桩量)),1,0),COLORYELLOW; TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));三天法则:=TJ3=1;成立:=三天法则 AND 突破;条件成立:=FILTER(成立,3); DRAWTEXT(条件成立,L*0.99,'悟道'),COLORYELLOW; STICKLINE(C>=O,C,O,3,0),COLOR000045; STICKLINE(C>=O,C,O,2.5,0),COLOR000065; STICKLINE(C>=O,C,O,2,0),COLOR000085; STICKLINE(C>=O,C,O,1.5,0),COLOR0000A5; STICKLINE(C>=O,C,O,1,0),COLOR0000C5; STICKLINE(C>=O,C,O,0.5,0),COLOR0000E5; STICKLINE(C>=O,H,L,0,0),COLOR0000F5; STICKLINE(C<O,C,O,3,0),COLOR353500; STICKLINE(C<O,C,O,2.5,0),COLOR454500; STICKLINE(C<O,C,O,2,0),COLOR555500; STICKLINE(C<O,C,O,1.5,0),COLOR656500; STICKLINE(C<O,C,O,1,0),COLOR757500; STICKLINE(C<O,C,O,0.5,0),COLOR858500; STICKLINE(C<O,H,L,0,0),COLOR959500; HIGHN:=10; LOWN:=10; HIGHDISPLAY:=0; LOWDISPLAY:=0; ZGDISPLAY:=0; MADISPLAY:=0; AA:=REF(H,HIGHN)=HHV(H,2*HIGHN+1); QY:=BACKSET(AA,HIGHN+1); CC:=FILTER(QY,HIGHN) AND H=HHV(H,HIGHN+1); DRAWICON(CC,H*1.02,2); DDD:=BARSLAST(CC); GDTS:=IF(CC,CURRBARSCOUNT,0); DINGBU:=IF(DDD,REF(H,DDD),H);{顶部}DINGBUTS:=IF(DDD,REF(GDTS,DDD),GDTS); DINGBU1:=REF(DINGBU,DDD+1); GDCS1:=CONST(DINGBUTS); DINGBUTS1:=REF(DINGBUTS,DDD+1); GDCS2:=CONST(DINGBUTS1); DINGBU2:=REF(DINGBU1,DDD+1); MM:=IF(CURRBARSCOUNT>GDCS2,0,1);上轨:DRAWLINE(CURRBARSCOUNT=GDCS2,H,CURRBARSCOUNT=GDCS1,H,1) COLORBLUE,LINETHICK1; DRAWLINE(CURRBARSCOUNT=GDCS2,H,ISLASTBAR,REF(H,GDCS2-1),1),COLOR0055FF,POINTDOT; DRAWLINE(CURRBARSCOUNT=GDCS1,H,ISLASTBAR,REF(H,GDCS1-1),1),COLORYELLOW,POINTDOT; AA1:=REF(L,LOWN)=LLV(L,2*LOWN+1); QY1:=BACKSET(AA1,LOWN+1); CC1:=FILTER(QY1,LOWN) AND L=LLV(L,LOWN+1); DRAWICON(CC1,L*0.98,1); DD1:=BARSLAST(CC1); DDTS:=IF(CC1,CURRBARSCOUNT,0); YDB:=IF(DD1,REF(L,DD1),L); DDTS1:=IF(DD1,REF(DDTS,DD1),DDTS); DDCS1:=CONST(DDTS1); ZDB:=REF(YDB,DD1+1); DDTS2:=REF(DDTS1,DD1+1); DDCS2:=CONST(DDTS2);下轨:DRAWLINE(CURRBARSCOUNT=DDCS2,L,CURRBARSCOUNT=DDCS1,L,1) COLORRED,LINETHICK1; ZGSTAR:=(上轨+下轨)/2; ZGEND:=CONST((上轨+下轨)/2); STARDAY:=IF(DDCS2<GDCS2,DDCS2,GDCS2);中轨:DRAWLINE(CURRBARSCOUNT=STARDAY,ZGSTAR,ISLASTBAR,ZGEND,1),COLORFF55BB,LINETHICK1; DRAWLINE(CURRBARSCOUNT=DDCS1,L,ISLASTBAR,REF(L,DDCS1-1),1),COLORMAGENTA,POINTDOT; DRAWLINE(CURRBARSCOUNT=DDCS2,L,ISLASTBAR,REF(L,DDCS2-1),1),COLORCYAN,POINTDOT; VAR7:=0; VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100; VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100; VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0); VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3); VAR12:=ZIG(3,6)=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3); VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3); VAR14:=ZIG(3,22)=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3); VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3); VAR16:=ZIG(3,51)=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3); VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3); VAR18:=ZIG(3,72)=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3); VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);买1:=VAR10;买2:=(VAR11+VAR13+VAR15+VAR17);卖1:=(VAR12+VAR14+VAR16+VAR18); B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK3,COLORYELLOW; DRAWTEXT(买1>0 OR 买2>0,LOW*0.99,'缘起'),COLORRED; S:IF(卖1>0,HIGH*1.01,DRAWNULL),CROSSDOT,LINETHICK3,COLORGREEN; DRAWTEXT(卖1>0,HIGH*1.02,'轮回'),COLORGREEN; DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.98,1) ; DRAWICON((ZIG(3,5)=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,2); ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK; VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0); K:=EMA(VAR7,5)*2, , COLORFF00FF; D:=EMA(K,5), , COLORWHITE; J:=K*3-D*2, ,COLORYELLOW; VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10; HS:=VOL/CAPITAL*100, , COLORGREEN; VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20; VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1); DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.95,'众仙归位'),LINETHICK1,COLORFF00FF; VAR1A:=IF(VARE>0,VARE,0); VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60; VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100; DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,'大限') COLORWHITE;指标王:=CROSS(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),SMA(SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1),3,1)) AND SMA((CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100,3,1)<20; DRAWTEXT(指标王,L,'八仙过海'),COLORYELLOW; DRAWTEXT(VAR1,L*0.98,'顿悟'),COLORYELLOW; DRAWTEXT(CROSS(MA(C,3),MA(C,9)) AND C>=REF(C,1) AND C>O,L*0.98,'鸡犬升天'),COLORMAGENTA;下降压力线:DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),LINETHICK2; STICKLINE(CURRBARSCOUNT=2,L,L,10,0),COLORGREEN,; DRAWNUMBER(ISLASTBAR,REF(L,1),REF(L,1));

    浏览13627次浏览
    2022-10-31 11:27
  • 神奇指标

    通达信强悍信号提示主图源码

    通达信强悍信号提示主图源码我分析的这份源码其中含有多个指标和提示可以根据自己的需要再优化,图中以主力线基础来判断走势,再结合提示进行买卖。(成功率特高,没有未来函数,好指标一个就够了)关注重点:1. 主力线是否翻红2. 主力线相对位置3. 多重提示且主力线为红我们做短线的,就是发现机会,参与机会。 不会去考虑这个行情启动时什么原因,不要站在发起者的角度去考虑,我们做追随者。指标一定就要跟上市场的节拍,跟上市场的切换,一旦动作慢下来,就会亏钱。源码:EMA13:=EMA(C,13),colorwhite; EMA21:=EMA(C,21),coloryellow; EMA34:=EMA(C,34),COLORFF00FF; EMA60:=MA(C,60),COLORFFCC66; VAR2:=(2*CLOSE+HIGH+LOW)/4; VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1); VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3; DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.05,'←低吸'),colorlired; DRAWTEXT(CROSS(庄家,散户) AND 散户>70,H+0.05,'←高抛'),colorgreen; DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.05,1); DRAWICON(CROSS(庄家,散户) AND 散户>70,H+0.05,2); VAR9:=CLOSE-REF(CLOSE,5); VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5); VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100); DRAWICON(卖出<0,H+0.05,2); 买线:=EMA(CLOSE,2);卖线:=EMA(SLOPE(CLOSE,21)*20+CLOSE,42); B1:IF(CROSS(买线,卖线),L-0.02,DRAWNULL),CROSSDOT,LINETHICK3,colormagenta; S1:IF(CROSS(80,RSI)*30,H+0.02,DRAWNULL),CROSSDOT,LINETHICK3,coloryellow; VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3; S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,colorgreen; A0:=(L+H+C*2)/4; A1:EMA(A0,14)colorblue,LINETHICK2; A2:=EMA(A0,25)colorliblue,LINETHICK2; A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW; A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;看多:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),colormagenta{,LINETHICK2};逃顶:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),colorcyan,{LINETHICK2};买入持股:IF(A1X>=0,A1,DRAWNULL)colorred,LINETHICK3;卖出空仓:IF(A1X<0 AND A2X<0,A1,DRAWNULL)colorgreen,LINETHICK3; STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF; STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC; STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF; STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;

    浏览8074次浏览
    2022-10-31 11:27
  • 神奇指标

    通达信波段潜伏-上出下买 副图

    通达信波段潜伏-上出下买 副图我们做短线的,就是发现机会,参与机会。 不会去考虑这个行情启动时什么原因,不要站在发起者的角度去考虑,我们做追随者。炒股就是炒心态,不急躁,不恐惧,无侥幸,这是我总结十年的经验。良好的心态很重要,大凡炒股的人都知道心态的重要性,但是需要衡量自己心态所处的境界,仁者见仁智者见智!指标一定就要跟上市场的节拍,跟上市场的切换,一旦动作慢下来,就会亏钱。炒股一旦顿悟,生涯就像开了挂。这个指标,红K 波段升势持股,绿顶冲高减仓,蓝k跌势卖出,上轨不过减仓,下轨超跌反弹,中线分水岭,形态明确,信号明显。源码:N:=17;{参数:N:5,30,17,M:5,30,18}M:=18;红K波段升势持股:0,COLORRED,NODRAW;绿顶冲高减仓:0,COLOR00FF88,NODRAW;蓝K波段跌势卖出:0,COLORFF6D00,NODRAW;上轨不过减仓:0,COLOR00FF00,NODRAW;下轨超跌反弹:0,COLORWHITE,NODRAW;CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);BB:=ABS((CLOSE+2*HIGH+LOW)/4-MA(CLOSE,17))/MA(CLOSE,17);DD:=DMA(CLOSE,CC);EE:=DMA(CLOSE,BB);低吸:=REF((1-3/100)*EE,2);强弱分界线:=EMA(低吸,7),LINETHICK2,COLORFF6C00;短支撑:=EMA((LLV((C+L)/2,6)+LLV((C+L)/2,5)+LLV((C+L)/2,4)+LLV((C+L)/2,3)+LLV((C+L)/2,2)+2*(C+L+H)/3)/7,3),COLORWHITE;波段趋势:=EMA(短支撑,4);涨幅:=(C-REF(C,1))/REF(C,1)*100;走平支撑线:=LLV((HIGH+2*LOW+OPEN+CLOSE)/5*2.03-H,30)*1.006,COLORABFF40,LINETHICK2;穿两线:=((CROSS(C,短支撑) AND CROSS(C,波段趋势)) OR (L<短支撑 AND C>波段趋势 AND 短支撑<波段趋势 ))AND 短支撑>REF(短支撑,1) AND C>REF(C,1)*1.02 AND (C-O>H-C) AND V>REF(V,1) AND (C>强弱分界线 OR C<强弱分界线 AND C>REF(C,1)*1.07);DRAWTEXT(穿两线,L*0.985,'上攻'),COLORFF00FF;STICKLINE(穿两线,H,L,0,1),COLORYELLOW,LINETHICK2;STICKLINE(穿两线,O,C,4.5,1),COLORYELLOW,LINETHICK2;B1:=MA(CLOSE,N)+MA(CLOSE,N)-REF(MA(CLOSE,N),1);分水岭:IF(MA(CLOSE,N)<B1,B1,MA(CLOSE,N)),COLORRED,LINETHICK2;IF(分水岭<REF(分水岭,1),分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;IF(分水岭>REF(分水岭,1)*0.999,分水岭,DRAWNULL),COLORRED,LINETHICK3;DRAWTEXT(ISLASTBAR,分水岭,'【分水岭】'),COLORRED;DDD:=分水岭<REF(分水岭,1);IF(DDD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;操作线:=分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;IF((操作线<REF(操作线,1) AND C<操作线) OR (操作线>REF(操作线,1) AND C<操作线),操作线,DRAWNULL),COLORFF6C00,LINETHICK2;B2:=MA(CLOSE,M)+MA(CLOSE,M)-REF(MA(CLOSE,M),1);分水岭2:=IF(MA(CLOSE,M)<B2,B2,MA(CLOSE,M));操作线2:=分水岭2-(EMA(C,3)-分水岭2);短线:=MA(C,5),COLORWHITE,LINETHICK2;IF(短线>=REF(短线,1),短线,DRAWNULL),COLORFF00FF,LINETHICK2;IF(短线<REF(短线,1),短线,DRAWNULL),COLORFF9900,LINETHICK2;CC0:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);DD0:=DMA(CLOSE,CC0);上轨:(1+8/100)*DD0,POINTDOT,COLORYELLOW;IF(H>上轨,上轨,DRAWNULL),POINTDOT,LINETHICK4,COLOR00FF00;下轨:(1-8/100)*DD0,POINTDOT,COLORFF00FF;S:=(短线>操作线);IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;买入红箭头:=CROSS(分水岭,操作线) AND C-O>H-C AND 涨幅>1;DRAWICON(买入红箭头,L*0.985,1);白K转折点:=(CROSS(C,分水岭) AND CROSS(C,操作线)) OR (L<操作线 AND CROSS(C,分水岭) AND C>MA(C,6) AND C>操作线)OR (L<操作线 AND C>操作线 AND C>分水岭 AND C>MA(C,6)) OR (分水岭>操作线 AND CROSS(C,分水岭) AND CROSS(C,MA(C,6) ));STICKLINE(白K转折点,OPEN,CLOSE,3.5,0),COLOR0055FF;STICKLINE(白K转折点,OPEN,CLOSE,3,0),COLOR0099FF;STICKLINE(白K转折点,OPEN,CLOSE,2.2,0),COLOR00BBFF;STICKLINE(白K转折点,OPEN,CLOSE,1.5,0),COLOR00DDFF;STICKLINE(白K转折点,OPEN,CLOSE,0.4,0),COLOR00FFFF;STICKLINE( C>操作线 AND 操作线>REF(操作线,1)*0.99 ,HIGH,LOW,0,1 ),COLORRED;STICKLINE( C>操作线 AND 操作线>REF(操作线,1)*0.99,OPEN,CLOSE,3,1 ),COLOR0000CC;STICKLINE(C>操作线 AND 操作线>REF(操作线,1),HIGH,LOW,0,0 ),COLORRED;STICKLINE(C>操作线 AND 操作线>REF(操作线,1) ,OPEN,CLOSE,2.8,0 ),COLOR0000AA;STICKLINE((C<操作线2) AND C<O AND 涨幅<7 AND NOT(白K转折点) ,CLOSE,OPEN,3,0),COLORFF6C00;STICKLINE((C<操作线2) AND C>O AND 涨幅<7 AND NOT(白K转折点) ,CLOSE,OPEN,3,1),COLORFF6C00;STICKLINE((C<操作线2) AND 涨幅<7 AND NOT(白K转折点) ,C,H,0.1,0),COLORFF6C00;STICKLINE((C<操作线2) AND 涨幅<7 AND NOT(白K转折点) ,O,L,0.1,0),COLORFF6C00;波段卖出:=短线>分水岭 AND CROSS(操作线2,C) OR (COUNT(白K转折点 OR 买入红箭头,3)>0 AND CROSS(操作线2,C)) OR (CROSS(分水岭,短线)AND REF(H,1)>分水岭 AND C<短线 AND REF(H,1)>分水岭) ;卖出:=COUNT(CROSS(分水岭,短线),4)>=1 AND CROSS(短线,C) AND C<操作线2;段头铡刀:= (CROSS(短线,C) AND 涨幅<-7 AND 短线>分水岭);DRAWTEXT((白K转折点 OR 买入红箭头) AND 分水岭>REF(分水岭,1)*0.998 AND 涨幅>2.4 ,L*0.92,'买入'),COLORYELLOW;DRAWTEXT(波段卖出 AND REF(波段卖出,1)=0 OR 卖出 ,H*1.02,'卖出'),COLOR00FF00;DRAWTEXT(段头铡刀,H*1.035,'断头铡刀'),COLORF0F900;洗盘回升:=(REF(段头铡刀,1)>0 AND 涨幅>9) OR (REF(段头铡刀,1)>0 AND C>REF(O,1) AND 涨幅>5);DRAWTEXT(洗盘回升,L*0.98,'洗盘回升'),COLOR00FFFF;STICKLINE(CROSS(短线,C) AND 涨幅<-7 AND 短线>分水岭 ,OPEN,CLOSE,3,0 ),COLOR00FF00;A2:=(C-REF(C,1))/REF(C,1)*100<1.02;A3:=H>MA(C,5)*1.12;AA:= A2 AND A3;DRAWTEXT(AA,H*1.02,'高减'),COLORWHITE;STICKLINE(AA,H,L,0.3,0),COLORFF0000;LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);DRAWTEXT(CROSS(88,RSI) AND H>分水岭*1.2 AND H>MA(C,5)*1.09 ,(HIGH * 1.035),'高抛'),COLORYELLOW;VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;VAR12:=(HIGH+LOW+CLOSE)/3;VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

    浏览7968次浏览
    2022-10-31 11:27
  • 神奇指标

    通达信上出下买波段操作 主图公式

    通达信上出下买波段操作主图公式交易的本质,是复杂的东西简单化,正确的操作重复化。不需要迷信太多的参考,严格执行纪律,努力提高控制力,让交易更加稳定,并读懂市场喜好,是大票行情还是小票行情,是价值趋势还是题材炒作,是高位加速还是低位超跌,你要做的就是看懂并跟随。坚守自己的底线和处理单子的一致性原则,盈利有时不是自己能决定的,也需要运气,这就是交易的魅力。不过所谓一致性就是你在任何时候都按照自己的规则做,不被别人和行情所左右则可以保持稳定性,盈利依靠于你的整个策略状况。红K 波段升势持股,绿顶冲高减仓,蓝k跌势卖出,上轨不过减仓,下轨超跌反弹,中线分水岭先设置{参数:N:5,30,17,M:5,30,18}源码:红K波段升势持股:0,COLORRED,NODRAW;绿顶冲高减仓:0,COLOR00FF88,NODRAW;蓝K波段跌势卖出:0,COLORFF6D00,NODRAW;上轨不过减仓:0,COLOR00FF00,NODRAW;下轨超跌反弹:0,COLORWHITE,NODRAW;CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);BB:=ABS((CLOSE+2*HIGH+LOW)/4-MA(CLOSE,17))/MA(CLOSE,17);DD:=DMA(CLOSE,CC);EE:=DMA(CLOSE,BB);低吸:=REF((1-3/100)*EE,2);强弱分界线:=EMA(低吸,7),LINETHICK2,COLORFF6C00;短支撑:=EMA((LLV((C+L)/2,6)+LLV((C+L)/2,5)+LLV((C+L)/2,4)+LLV((C+L)/2,3)+LLV((C+L)/2,2)+2*(C+L+H)/3)/7,3),COLORWHITE;波段趋势:=EMA(短支撑,4);涨幅:=(C-REF(C,1))/REF(C,1)*100;走平支撑线:=LLV((HIGH+2*LOW+OPEN+CLOSE)/5*2.03-H,30)*1.006,COLORABFF40,LINETHICK2;穿两线:=((CROSS(C,短支撑) AND CROSS(C,波段趋势)) OR (L<短支撑 AND C>波段趋势 AND 短支撑<波段趋势 ))AND 短支撑>REF(短支撑,1)} AND C>REF(C,1)*1.02 AND (C-O>H-C) AND V>REF(V,1) AND (C>强弱分界线 OR C<强弱分界线 AND C>REF(C,1)*1.07);DRAWTEXT(穿两线,L*0.985,'上攻'),COLORFF00FF;STICKLINE(穿两线,H,L,0,1),COLORYELLOW{YELLOW},LINETHICK2;STICKLINE(穿两线,O,C,4.5,1),COLORYELLOW{00FFFF},LINETHICK2;B1:=MA(CLOSE,N)+MA(CLOSE,N)-REF(MA(CLOSE,N),1);分水岭:IF(MA(CLOSE,N)<b1,b1,ma(close,n)),colorred,linethick2;IF(分水岭<ref(分水岭,1),分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;IF(分水岭>REF(分水岭,1)*0.999,分水岭,DRAWNULL),COLORRED,LINETHICK3;DRAWTEXT(ISLASTBAR,分水岭,'【分水岭】'),COLORRED;DDD:=分水岭<ref(分水岭,1);IF(DDD,分水岭,DRAWNULL),COLOR00FF00,LINETHICK2;操作线:=分水岭-(EMA(C,3)-分水岭),COLOR00FFFF,LINETHICK2;IF((操作线<ref(操作线,1) AND C<操作线) OR (操作线>REF(操作线,1) AND C<操作线),操作线,DRAWNULL),COLORFF6C00,LINETHICK2;B2:=MA(CLOSE,M)+MA(CLOSE,M)-REF(MA(CLOSE,M),1);分水岭2:=IF(MA(CLOSE,M)<b2,b2,ma(close,m));< span="">操作线2:=分水岭2-(EMA(C,3)-分水岭2);短线:=MA(C,5),COLORWHITE,LINETHICK2;IF(短线>=REF(短线,1),短线,DRAWNULL),COLORFF00FF,LINETHICK2;IF(短线<ref(短线,1),短线,DRAWNULL),COLORFF9900,LINETHICK2;CC0:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);DD0:=DMA(CLOSE,CC0);上轨:(1+8/100)*DD0,POINTDOT,COLORYELLOW;IF(H>上轨,上轨,DRAWNULL),POINTDOT,LINETHICK4,COLOR00FF00;下轨:(1-8/100)*DD0,POINTDOT,COLORFF00FF;S:=(短线>操作线);IF(S,分水岭,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;买入红箭头:=CROSS(分水岭,操作线) AND C-O>H-C AND 涨幅>1;DRAWICON(买入红箭头,L*0.985,1);{买入红箭头}白K转折点:=(CROSS(C,分水岭) AND CROSS(C,操作线)) OR (L<操作线 AND CROSS(C,分水岭) AND C>MA(C,6) AND C>操作线)OR (L<操作线 AND C>操作线 AND C>分水岭 AND C>MA(C,6)) OR (分水岭>操作线 AND CROSS(C,分水岭) AND CROSS(C,MA(C,6) )); STICKLINE(白K转折点,OPEN,CLOSE,3.5,0),COLOR0055FF;STICKLINE(白K转折点,OPEN,CLOSE,3,0),COLOR0099FF;STICKLINE(白K转折点,OPEN,CLOSE,2.2,0),COLOR00BBFF;STICKLINE(白K转折点,OPEN,CLOSE,1.5,0),COLOR00DDFF;STICKLINE(白K转折点,OPEN,CLOSE,0.4,0),COLOR00FFFF;STICKLINE( C>操作线 AND 操作线>REF(操作线,1)*0.99 ,HIGH,LOW,0,1 ),COLORRED;STICKLINE( C>操作线 AND 操作线>REF(操作线,1)*0.99,OPEN,CLOSE,3,1 ),COLOR0000CC;STICKLINE(C操作线 AND 操作线>REF(操作线,1),HIGH,LOW,0,0 ),COLORRED;STICKLINE(C操作线 AND 操作线>REF(操作线,1) ,OPEN,CLOSE,2.8,0 ),COLOR0000AA;STICKLINE((C<操作线2) AND C<o and  涨幅<7 AND NOT(白K转折点) ,CLOSE,OPEN,3,0),COLORFF6C00;="">STICKLINE((C<操作线2) AND C>O AND 涨幅<7 AND NOT(白K转折点) ,CLOSE,OPEN,3,1),COLORFF6C00;STICKLINE((C<操作线2) AND 涨幅<7 AND NOT(白K转折点) ,C,H,0.1,0),COLORFF6C00;STICKLINE((C<操作线2) AND 涨幅<7 AND NOT(白K转折点) ,O,L,0.1,0),COLORFF6C00;波段卖出:=短线>分水岭 AND CROSS(操作线2,C) OR (COUNT(白K转折点 OR 买入红箭头,3)>0 AND CROSS(操作线2,C)) OR (CROSS(分水岭,短线)AND REF(H,1)>分水岭 AND C<短线 AND REF(H,1)>分水岭) ;卖出:=COUNT(CROSS(分水岭,短线),4)>=1 AND CROSS(短线,C) AND C<操作线2;段头铡刀:= (CROSS(短线,C) AND 涨幅<-7 AND 短线>分水岭);DRAWTEXT((白K转折点 OR 买入红箭头) AND 分水岭>REF(分水岭,1)*0.998 AND 涨幅>2.4 ,L*0.92,'买入'),COLORYELLOW;DRAWTEXT(波段卖出 AND REF(波段卖出,1)=0 OR 卖出 ,H*1.02,'卖出'),COLOR00FF00;DRAWTEXT(段头铡刀,H*1.035,'断头铡刀'),COLORF0F900;洗盘回升:=(REF(段头铡刀,1)>0 AND 涨幅>9) OR (REF(段头铡刀,1)>0 AND C>REF(O,1) AND 涨幅>5);DRAWTEXT(洗盘回升,L*0.98,'洗盘回升'),COLOR00FFFF;STICKLINE(CROSS(短线,C) AND 涨幅<-7 AND 短线>分水岭 ,OPEN,CLOSE,3,0 ),COLOR00FF00;A2:=(C-REF(C,1))/REF(C,1)*100<1.02;A3:=H>MA(C,5)*1.12;AA:= A2 AND A3;DRAWTEXT(AA,H*1.02,'高减'),COLORWHITE;STICKLINE(AA,H,L,0.3,0),COLORFF0000;LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);DRAWTEXT(CROSS(88,RSI) AND H>分水岭*1.2 AND H>MA(C,5)*1.09 ,(HIGH * 1.035),'高抛'),COLORYELLOW;VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;VAR12:=(HIGH+LOW+CLOSE)/3;VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));VAR15:=IF(VAR13>=150 AND VAR13<200 and  var14>=150 AND VAR14<200,10,0);

    浏览2729次浏览
    2022-10-31 11:27
  • 神奇指标

    擒庄起爆多重提示--通达信主图指标公式

    通达信擒庄起爆主图指标公式源码  市场中,存在着阴魂不散的墨菲定律:即一个事情只要可能变坏,就一定会朝着那个方向发展。股市的短线涨跌是由交易驱动的,交易的本质是买和卖两个群体的博弈,同时买和卖群体又具备相互转化的潜在,因为买了的人下一步是卖,而卖了的人下一步是买。我们必须得随时衡量,场外的潜在买入者的力量和场内筹码的买卖倾向。当前者大于后者,短线就酝酿着这机会,但前者小于后者,短线就酝酿了风险。为了抗衡这个定律,我们一般引入龙头战法。 原理就在于,龙头可以延续龙头地位,获得领先的收益。所以资金体系相较其他强,板块同理,内部品种也一样。经过多次选择才会确定稳定的龙头品种。 龙头战法的依据在于相对差别和趋势:相对差别即对龙头对羽翼的领先性。趋势,即这种差别始终存在的惯性。如果继续保持趋势,则称为趋势延续。这里存在的相对确定性就是获取超额利润的关键。  分享代码:P:=6;P1:=8;M:=2;M1:=3;N:=11;{=================k线柱=================}{红}stICKLINE(C>O,C,O,1,0),COLORYELLOW ;STICKLINE(C>O,H,L,0,0),COLORRED;{绿}STICKLINE(C<O,C,O,2,0),COLORCYAN;STICKLINE(C<O,H,L,0,0),COLORCYAN;{=================板块、行业、概念=================}DRAWTEXT_FIX(C>0,0.0,0.0,0,STRCAT(' ---所属行业---:',HYBLOCK)),COLORFFFFFF;DRAWTEXT_FIX(C>0,0.30,0.0,0,STRCAT(' ---所属地区---:',DYBLOCK)),COLORFFFFFF;DRAWTEXT_FIX(C>0,0.30,0.1,0,STRCAT('-------=======横盘做T+0坚决莫贪=======--------:',GNBLOCK)),COLORCYAN;DRAWTEXT_FIX(ISLASTBAR,0.20,0.90,0,ZSBLOCK),COLORYELLOW;DRAWTEXT_FIX(ISLASTBAR,0.20,0.99,0,FGBLOCK),COLORYELLOW;{=================多空布林=================}C2:=REF(C,1);涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);STICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;STICKLINE(涨停,H,L,0,0),COLORmaGENTA;bbi:(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORBLacK,LINETHICK1;UPR:BBI+P*STD(BBI,N),COLORCYAN,LINETHICK1;DWN:BBI-P*STD(BBI,N),COLORBLUE ,NODRAW , ;MA1:MA(CLOSE,P1),COLORRED,LINETHICK1;买线:=EMA(C,2);卖线:=EMA(SLOPE(C,21)*20+C,42);指导线: EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2),COLORYELLOW,LINETHICK1;界: MA(CLOSE,27),COLORMAGENTA ,LINETHICK1;BU:=crOSS(指导线,界);DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA:=EMA(DIF,9);AAA:=(DIF-DEA)*2;ZT1:=C>=REF(C,1)*1.097 ;起爆:=AAA>=2*REF(AAA,1) AND ZT1 AND Abs(AAA)<=1 AND C>MA(C,20) AND C<MA(C,20)*1.2 ;DRAWTEXT(起爆,L*0.99,'↖暴涨'),COLORYELLOW,LINETHICK3;VAR1:=EMA(EMA(EMA((CLOSE*6+LOW*2+HIGH+OPEN)/10,M),M),M);短线:= VAR1-REF(VAR1,1)+VAR1;中短:= MA(短线,M1);DRAWTEXT(CROSS(短线,中短),(LOW * 0.995),'★'),COLORYELLOW,LINETHICK3;{=================量柱=================}TJ:=vol>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;DRAWTEXT(TJ,LOW*1.1,'量'),COLORMAGENTA ;STICKLINE(TJ,OPEN,CLOSE,2.2,2),COLORMAGENTA ;K1:=SUMBARS(TJ,1);{================走强线 ================};HM1:=ABS(((3.48*CLOSE+HIGH+LOW)/4-EMA(CLOSE,20))/EMA(CLOSE,20));HM2:=DMA(((2.15*CLOSE+LOW+HIGH)/4),HM1);走强线:EMA(HM2,200)*1.118 ,LINETHICK1,COLORRED;DRAWTEXT(ISLASTBAR,走强线,' ←走强线'),COLORRED;{=================必升=================};VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.90),'★波段开始 '),COLORMAGENTA;DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.8),'★强势拉升'),COLOR00FFFF;{============操作线:分水岭================}B:=MA(CLOSE,17)+MA(CLOSE,17)-REF(MA(CLOSE,17),1);分水岭:IF(MA(CLOSE,17)<B,B,MA(CLOSE,17)),COLORFF00FF,NODRAW;操作线:分水岭-(EMA(C,3)-分水岭),COLORGREEN ,LINETHICK1;DRAWTEXT(ISLASTBAR,操作线,' ←拐点线'),COLORGREEN;{========超级主升==========}VAR4:=(((((REF(C,1)) * (1.1)) - C) < (0.01)) AND (H = C));E5:(EMA(C,5)),LINETHICK0 ,COLORWHITE;R:=(20 * H + 19 * (REF(H,1)) + 18 * (REF(H,2)) + 17 * (REF(H,3)));R1:=16*(REF(H,4)) +15*(REF(H,5))+14 * (REF(H,6)) + 13 * (REF(H,7));R2:=12*(REF(H,8))+11*(REF(H,9))+10 * (REF(H,10)) + 9 * (REF(H,11));R3:=8 * (REF(H,12)) + 7 * (REF(H,13)) +6*(REF(H,14))+5*(REF(H,15));R4:=4 * (REF(H,16)) + 3 * (REF(H,17)) +2 * (REF(H,18)) + REF(H,20);VAR5:=(R+R1+R2+R3+R4)/(210);VAR6:=(EMA(VAR5,90));妖股线:(VAR6 + (((C - (VAR6)) * C) - (VAR6)) / (VAR6)),LINETHICK0 ;VAR8:=(CROSS(妖股线,E5));DRAWTEXT((VAR8) AND (VAR4),L,'↖后市有牛'),LINETHICK3,COLORRED ;{===================A级起暴点=====================}DOWN:=OPEN>CLOSE;F:=COUNT(DOWN,6)=6;AD:=COUNT(C<REF(C,1) ,6)=6;BB:=(C<MA(C,30)*0.9);E:=F AND AD AND BB;AA:="macd.DEA"(12,26,9)<=0.6;ZT4:=C>=REF(C,1)*1.099 AND C< MA(C,20)*1.15 AND C>MA(C,20) AND "MACD.DEA"(12,26,9)<=0.3 AND"MACD.DEA"(12,26,9)>=0;ZT3:=C>=REF(C,1)*1.099 AND C< MA(C,20)*1.16 AND C>MA(C,20) AND AA AND C>=HHV(C,20) { AND V>REF(V,1)*1.3 } ;DRAWTEXT(ZT4 ,L*0.84,'C级起暴点');DRAWTEXT(ZT3,L*0.90,'A级起暴点');

    浏览15784次浏览
    2022-10-31 10:55
  • 神奇指标

    通达信趋势信号主图--红柱出击绿柱休息

    通达信趋势信号主图--红柱出击绿柱休息 交易的本质,是复杂的东西简单化,正确的操作重复化。不需要迷信太多的参考,严格执行纪律,努力提高控制力,让交易更加稳定,并读懂市场喜好,是大票行情还是小票行情,是价值趋势还是题材炒作,是高位加速还是低位超跌,你要做的就是看懂并跟随。不管熊牛,永远的七亏一平两胜。日盈利10%者众,月盈利10%者寡。稳定性永远是我们追求的最终目标。复利是世界的第八大奇迹,稳定的交易是最终归宿。经历了迷茫和痛苦,背负着生活的压力,是信念让我走到了今天,所以我非常看重信念二字。怀着坦诚和感恩的心,用科学的方法不断地研究,你的机会就会比别人多。把复杂的事情搞简单,把简单的事情搞细致!公式:LOCK:=1;M8:=EMA(CLOSE,8);M13:=EMA(M8,13);   VAR1:=EMA(M13,62);VAR2:=(CLOSE+HIGH+LOW)/3;   VAR3:=EMA(VAR2,10)*LOCK;VAR4:=REF(VAR3,1)*LOCK;   STICKLINE(VAR3>VAR4,VAR3,VAR4,4,1),colorred;STICKLINE(VAR3<VAR4,VAR3,VAR4,4,1),COLOR00CC33;   DRAWTEXT(CROSS(VAR3,VAR4),L-0.0,'←顺'),colorred;   DRAWTEXT(CROSS(VAR4,VAR3),H+0.0,'←逆'),colorgreen;    C3:=REF(C,1); 涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),2,0);   STICKLINE(涨停,OPEN,CLOSE,1,0),coloryellow;   跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),2,0);   STICKLINE(跌停,OPEN,CLOSE,1,0),colorblue;    QC:=REF(CLOSE,1);   RSV:=(((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9)))*100);   K:=SMA(RSV,3,1);   D:=SMA(K,3,1);   YX:=((CLOSE>QC) AND C>O);   KK:=HHV(K,5);   HH:=HHV(D,5);   D1:=REF(D,1);   K1:=REF(K,1);   DRAWTEXT((((D1<30) AND CROSS(K,D)) AND YX),(LOW * 0.99),'●←短买!'),coloryellow;   压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;   支撑:MA(REF(LLV(C,30),1),2),COLORABFF46; AA1:=AMOUNT/V;BB1:=L<AA1*0.9;   DA:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,4))/4;   DB:=(EMA(C,10)+EMA(C,20)+EMA(C,40)+EMA(C,80))/4;   DRAWTEXT(CROSS(DA-DB,0),L*0.98,'★B'),colormagenta;   AF:=CROSS(AA1,BB1);   DRAWTEXT(AF,LLV(L,4),'止损线'),coloryellow;   TYP1:=(HIGH+LOW+CLOSE)/3;   C1:=(TYP1-MA(TYP1,14))/(0.015*AVEDEV(TYP1,14));   C2:=(TYP1-MA(TYP1,55))/(0.015*AVEDEV(TYP1,55));   CCI背:=IF(LLV(CCI,2)>LLV(CCI,7) AND LLV(L,2)<=LLV(L,7) AND LLV(CCI,2)>MA(CLOSE,60),1,0),colorwhite;   DRAWICON(CCI背 AND REF(CCI,1)<-150 AND C>O,L*0.98,1);   DRAWTEXT(CCI背 AND REF(CCI,1)<-150 AND C>O,L*0.9,'杀'),colorgreen;   XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));   DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'●买点');   XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);   XL3:=CROSS(XL2,(0 - 20));   DRAWTEXT((XL3 > 0),(LOW - 0.2),'●绝对底部');  

    浏览16054次浏览
    2022-10-31 10:55
神奇指标提问

求助编写

神奇指标

神奇指标

神奇指标
关注官方
抖音号
神奇指标抖音号