神奇指标网
神奇指标网

短线收割机选股指标公式

浏览 357次浏览 来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15

  

精准短线指示公式 ,尾盘买进准确率达92%以上 ,希望大家多多支持


    相关简介: 短线收割机选股指标公式                                


     短线收割机选股指标公式源码概况:


  指标类别:选股指标公式


  授权方式:免费版


  指标评级:★★★★★


  指标分类:策略


  画线方法:副图




短线收割机选股指标公式源码:



    D3:=REF(C,2)<ZTPRICE(REF(C,3),0.1);
    D2:=RANGE(REF(O,1)/REF(C,2),0.96,1.04)ANDREF(C,1)=ZTPRICE(REF(C,2),0.1)AND
    RANGE((REF(H,1)-REF(L,1))/REF(L,1),0.1,0.15)ANDV>REF(V,1);
    D1:=C=ZTPRICE(REF(C,1),0.1);
    D1ANDD2ANDD3;
    X_1:=REF(CLOSE,1);
    X_2:=SMA(MAX(CLOSE-X_1,0),6,1)/SMA(ABS(CLOSE-X_1),6,1)*100;
    X_3:=(2*CLOSE+HIGH+LOW)/4;
    X_4:=LLV(LOW,34);
    X_5:=HHV(HIGH,34);
    Y:EMA((X_3-X_4)/(X_5-X_4)*100,13),COLORRED;
    D:EMA(0.667*REF(Y,1)+0.333*Y,2),COLORYELLOW;
    X_6:=CROSS(Y,D);
    STICKLINE(D<Y,Y,D,2,0),COLORRED;
    DRAWICON(CROSS(Y,D),Y,23);
    买:CROSS(Y,D),NODRAW,COLORRED;
    DRAWTEXT(买>0,D*1.1,'买'),COLORRED;
    卖:CROSS(D,Y),NODRAW,COLORGREEN;
    GOODGUPIAO:SMA(MAX(CLOSE-C,0),7,1)/SMA(ABS(CLOSE-C),7,1)*100,NODRAW;
    DRAWTEXT(卖>0,Y*1.1,'卖'),COLORGREEN;
    逃:CROSS(80,X_2),NODRAW,COLORYELLOW;
    DRAWTEXT(CROSS(80,X_2),Y*1,'逃'),COLORYELLOW;
    短线:Y<50ANDD<50,NODRAW,COLORMAGENTA;
    中线:Y>=50ANDD>=50ANDY<80ANDD<80,NODRAW,COLORLIRED;
    长线:Y>=80ANDD>=80ANDY<110ANDD<110,NODRAW,COLORRED;
    50,COLORGRAY;
    100,COLORGRAY;





[源码注释]短线收割机选股指标公式翻译结果



    D3赋值:2日前的收盘价<
    计算涨停价
    D2赋值:1日前的开盘价/2日前的收盘价位于0.96和1.04之间ANDREF(收盘价,1)=计算涨停价AND(1日前的最高价-1日前的最低价)/1日前的最低价位于0.1和0.15之间ANDV>
    1日前的成交量(手)
    D1赋值:收盘价=计算涨停价
    D1ANDD2ANDD3
    X_1赋值:1日前的收盘价
    X_2赋值:收盘价-X_1和0的较大值的6日[1日权重]移动平均/收盘价-X_1的绝对值的6日[1日权重]移动平均*100
    X_3赋值:(2*收盘价+最高价+最低价)/4
    X_4赋值:34日内最低价的最低值
    X_5赋值:34日内最高价的最高值
    输出Y:(X_3-X_4)/(X_5-X_4)*100的13日指数移动平均,画红色
    输出D:0.667*1日前的Y+0.333*Y的2日指数移动平均,画黄色
    X_6赋值:Y上穿D
    当满足条件D<Y时,在Y和D位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
    当满足条件Y上穿D时,在Y位置画23号图标
    输出买:Y上穿D,NODRAW,画红色
    当满足条件买>0时,在D*1.1位置书写文字,画红色
    输出卖:D上穿Y,NODRAW,画绿色
    输出GOODGUPIAO:收盘价-收盘价和0的较大值的7日[1日权重]移动平均/收盘价-收盘价的绝对值的7日[1日权重]移动平均*100,NODRAW
    当满足条件卖>0时,在Y*1.1位置书写文字,画绿色
    输出逃:80上穿X_2,NODRAW,画黄色
    当满足条件80上穿X_2时,在Y*1位置书写文字,画黄色
    输出短线:Y<50ANDD<50,NODRAW,画洋红色
    输出中线:Y>=50ANDD>=50ANDY<80ANDD<80,NODRAW,画淡红色
    输出长线:Y>=80ANDD>=80ANDY<110ANDD<110,NODRAW,画红色
    50,画深灰色
    100,画深灰色



神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论