神奇指标网
神奇指标网

通达信五行成交量指标公式

浏览 320次浏览
标签: 成交量
来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15



成交量最重要的炒股秘诀 必须掌握

    相关简介:     通达信五行成交量指标公式                            


     源码概况:通达信五行成交量指标公式


指标类别:通达信成交量指标公式


授权方式:免费版


指标评级:★★★★★


指标分类:策略


画线方法:副图





通达信五行成交量指标公式未来函数检测结果:

           暂未发现存在未来函数





通达信五行成交量指标公式源码:



    TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
    MTIME:=MOD(FROMOPEN,TOTAL);
    CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
    预估成交量:IF((CURRBARSCOUNT=1ANDDYNAINFO(8)>1),vol*TOTAL/CTIME,DRAWNULL),NODRAW;
    STICKLINE((CURRBARSCOUNT=1ANDDYNAINFO(8)>1),预估成交量,0,-1,-1),COLOR00C0C0;
    成交量:VOL,VOLSTICK;
    量:IF(C>200,vol/1000000,VOL/100),LINETHICK0;
    亿:AMOUNT/100000000LINETHICK0;
    换手率:VOL/CAPITAL*100,LINETHICK0;
    振幅:((H-L)/L)*100,LINETHICK0;
    流通:CAPITAL/1000000,LINETHICK0;
    业绩:FINANCE(33),LINETHICK0;
    净资产:FINANCE(34),LINETHICK0;
    VAR1:=HIGH-LOW;
    VAR2:=Abs(OPEN-CLOSE);
    VAR3:=HIGH-IF(CLOSE>OPEN,CLOSE,O);
    VAR4:=IF(CLOSE>OPEN,O,CLOSE)-LOW;
    VAR5:=(VAR2/VAR1)*VOL;
    VAR6:=(VAR3/VAR1)*VOL;
    VAR7:=(VAR4/VAR1)*VOL;
    VAR8:=IF(VOL/CAPITAL>0.001,1,EXP(ABS(LOG(VOL/CAPITAL*100))));
    VAR9:=(C-ma(C,5))/MA(C,5)*100;
    VAR10:=MA(C,5)>MA(C,10)ANDMA(C,10)>MA(C,30)ANDMA(C,30)>MA(C,60);
    VAR11:=MA(C,5)<MA(C,10)ANDMA(C,10)<MA(C,30);
    VAR12:=100*(1-WINNER(C)){套劳筹码};
    VAR13:=100*WINNER(C){获利盘筹码};
    多头:stICKLINE(C>MA(C,30),0,VOL,2,1),COLORRED;
    空头:STICKLINE(C<MA(C,30),0,VOL,2,1),COLORGREEN;
    上攻:STICKLINE(VAR5>=VAR6ANDVAR5>=VAR7ANDC>O,0,VAR5,2,0),COLORRED;
    下攻:STICKLINE(VAR5>=VAR6ANDVAR5>=VAR7ANDC<O,0,VAR5,2,0),COLORGREEN;
    上探:STICKLINE(VAR6>VAR5ANDVAR6>VAR7,0,VAR6,2,0),COLORCYAN;
    下探:STICKLINE(VAR7>VAR5ANDVAR7>VAR6,0,VAR7,2,0),COLORFF6600;
    相对地量:=STICKLINE(VAR8>2ANDVOL<MA(VOL,5)/2,0,VOL,2,0),COLOR00FFFF;
    DRAWTEXT(VAR8>2ANDV<MA(V,5)/2,V*3,'地量'),COLOR00FFFF;
    放量:STICKLINE(VOL>MA(VOL,5)*1.5,VOL,VOL+VOL*0.1,2,0),COLORWHITE;
    V1:=H-L;
    V2:=ABS(O-C);
    V3:=H-IF(C>O,C,O);
    V4:=IF(C>O,O,C)-L;
    V5:=V2/V1*V;
    V6:=V3/V1*V;
    V7:=V4/V1*V;
    M5:MA(V,5),COLORWHITE;
    M10:MA(V,10),COLORYELLOW;
    V8:=IF(V/CAPITAL>0.001,1,EXP(ABS(LOG(V/CAPITAL*100))));
    金指:EMA(IF(L<=LLV(L,30),1,0),3)*2*V,COLORWHITE,LINETHICK2;
    RSV1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
    K1:=SMA(RSV1,3,1);
    D1:=SMA(K1,3,1);
    J1:=3*K1-2*D1;
    RSV:=(C-LLV(L,26))/(HHV(H,26)-LLV(L,26))*100;
    K:=SMA(RSV,6,1);
    D:=SMA(K,3,1);
    J:=3*K-2*D;
    LC:=REF(C,1);
    XA:=IF(crOSS(J1,J)ANDJ<20,-1,0)+IF(CROSS(J,J1)ANDJ>80,1,0);
    TYP:=(H+L+C)/3;
    CCJ:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14))/2;
    rsi1:=SMA(MAX(C-LC,0),6,1)/SMA(ABS(C-LC),6,1)*100;
    K2:=EMA((C-LLV(L,36))/(HHV(H,36)-LLV(L,36))*100,9);
    XB:=IF(CCJ>100ANDK2>50ANDC>O,0.5,0)+IF(RSI1>80ANDK2>50ANDC>O,0.5,0);
    RSV3:=(C-LLV(L,100))/(HHV(H,100)-LLV(L,100))*100;
    K13:=SMA(RSV3,21,1);
    D13:=SMA(K1,3,1);
    J13:=3*K13-2*D13;
    XC:=IF(J13>80ANDRSI1>85,0.5,0);
    警戒:V*(XA+XB+XC>0),COLOR009000,LINETHICK2;
    选股:IF(V5>MA(V,5)*2ANDV5>=V6ANDV5>=V7ANDC>OORV>MA(V,5)*3,V/2,0),COLORRED,LINETHICK2;
    DRAWICON(CROSS(M5,M10),V,1);
    DRAWICON(CROSS(M10,M5),V,2);
    DRAWICON(CROSS(4000,金指),V,4);
    DRAWICON(CROSS(M5,警戒),V,5);
    DRAWTEXT(V7>V5ANDV7>V6ANDC<MA(C,30)ANDV7<MA(V,5)/2ANDMA(V,5)<MA(V,10),VOL*2,'逢低跟进'),COLORMAGENTA;
    DRAWTEXT(FILTER(V5>MA(V,5)*2ANDV5>=V6ANDV5>=V7ANDC>OORV>MA(VOL,5)*3,2),1.2*V,'强势参与'),COLORRED;
    DRAWTEXT(V5>=V6ANDV5>=V7ANDC<OANDV5/VOL>0.7ANDV5>MA(V,5),HHV(V,5),'空头释放'),COLORWHITE;
    DRAWTEXT(V6>V5ANDV6>V7ANDC>MA(C,5)ANDC>MA(C,34)ANDH>MA(C,55)ANDV>M5ANDV6>MA(V,5),V,'逢高出货'),COLORGREEN;
    低量:FINANCE(7)/5000,LINETHICK1,COLORBLUE,POINTDOT;
    活跃量:FINANCE(7)/1000,LINETHICK1,COLORYELLOW,POINTDOT;
    危险成交量:FINANCE(7)/500,LINETHICK1,COLORRED,POINTDOT;





[源码注释]通达信五行成交量指标公式翻译结果



    TOTAL赋值:如果周期类型=1,返回5,否则返回如果周期类型=2,返回15,否则返回如果周期类型=3,返回30,否则返回如果周期类型=4,返回60,否则返回如果周期类型=5,返回总分钟数,否则返回1
    MTIME赋值:当前离开盘分钟数关于TOTAL的模
    CTIME赋值:如果MTIME<,返回?,否则返回?
    0.5,TOTAL,MTIME)
    输出预估成交量:如果(到最后交易的周期=1ANDDYNAINFO(8)>,返回?,否则返回?
    1),成交量(手)*TOTAL/CTIME,无效数),NODRAW
    当满足条件(到最后交易的周期=1ANDDYNAINFO(8)>时,在?和?位置之间画柱状线,宽度为?,?不为0则画空心柱.
    1),预估成交量,0,-1,-1),COLOR00C0C0
    输出成交量:成交量(手),VOLSTICK
    输出量:如果收盘价>200,返回成交量(手)/1000000,否则返回成交量(手)/100,线宽为0
    输出亿:成交额(元)/100000000LINETHICK0
    输出换手率:成交量(手)/当前流通股本(手)*100,线宽为0
    输出振幅:((最高价-最低价)/最低价)*100,线宽为0
    输出流通:当前流通股本(手)/1000000,线宽为0
    输出业绩:每股收益(全年折算),线宽为0
    输出净资产:每股净资产,线宽为0
    VAR1赋值:最高价-最低价
    VAR2赋值:开盘价-收盘价的绝对值
    VAR3赋值:最高价-如果收阳线,返回收盘价,否则返回开盘价
    VAR4赋值:如果收阳线,返回开盘价,否则返回收盘价-最低价
    VAR5赋值:(VAR2/VAR1)*成交量(手)
    VAR6赋值:(VAR3/VAR1)*成交量(手)
    VAR7赋值:(VAR4/VAR1)*成交量(手)
    VAR8赋值:如果成交量(手)/当前流通股本(手)>0.001,返回1,否则返回成交量(手)/当前流通股本(手)*100的对数的绝对值的指数
    VAR9赋值:(收盘价-收盘价的5日简单移动平均)/收盘价的5日简单移动平均*100
    VAR10赋值:收盘价的5日简单移动平均>收盘价的10日简单移动平均ANDMA(收盘价,10)>收盘价的30日简单移动平均ANDMA(收盘价,30)>收盘价的60日简单移动平均
    VAR11赋值:收盘价的5日简单移动平均<收盘价的10日简单移动平均ANDMA(收盘价,10)<收盘价的30日简单移动平均
    VAR12赋值:100*(1-以收盘价计算的获利盘比例)
    VAR13赋值:100*以收盘价计算的获利盘比例
    输出多头:当满足条件收盘价>收盘价的30日简单移动平均时,在0和成交量(手)位置之间画柱状线,宽度为2,1不为0则画空心柱.,画红色
    输出空头:当满足条件收盘价<收盘价的30日简单移动平均时,在0和成交量(手)位置之间画柱状线,宽度为2,1不为0则画空心柱.,画绿色
    输出上攻:当满足条件VAR5>=VAR6ANDVAR5>=VAR7ANDC>开盘价时,在0和VAR5位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
    输出下攻:当满足条件VAR5>=VAR6ANDVAR5>=VAR7ANDC<开盘价时,在0和VAR5位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色
    输出上探:当满足条件VAR6>VAR5ANDVAR6>VAR7时,在0和VAR6位置之间画柱状线,宽度为2,0不为0则画空心柱.,画青色
    输出下探:当满足条件VAR7>VAR5ANDVAR7>VAR6时,在0和VAR7位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLORFF6600
    相对地量赋值:当满足条件VAR8>2ANDVOL<成交量(手)的5日简单移动平均/2时,在0和成交量(手)位置之间画柱状线,宽度为2,0不为0则画空心柱.,COLOR00FFFF
    当满足条件VAR8>2ANDV<成交量(手)的5日简单移动平均/2时,在成交量(手)*3位置书写文字,COLOR00FFFF
    输出放量:当满足条件成交量(手)>成交量(手)的5日简单移动平均*1.5时,在成交量(手)和成交量(手)+成交量(手)*0.1位置之间画柱状线,宽度为2,0不为0则画空心柱.,画白色
    V1赋值:最高价-最低价
    V2赋值:开盘价-收盘价的绝对值
    V3赋值:最高价-如果收阳线,返回收盘价,否则返回开盘价
    V4赋值:如果收阳线,返回开盘价,否则返回收盘价-最低价
    V5赋值:V2/V1*成交量(手)
    V6赋值:V3/V1*成交量(手)
    V7赋值:V4/V1*成交量(手)
    输出M5:成交量(手)的5日简单移动平均,画白色
    输出M10:成交量(手)的10日简单移动平均,画黄色
    V8赋值:如果成交量(手)/当前流通股本(手)>0.001,返回1,否则返回成交量(手)/当前流通股本(手)*100的对数的绝对值的指数
    输出金指:如果最低价<=30日内最低价的最低值,返回1,否则返回0的3日指数移动平均*2*成交量(手),画白色,线宽为2
    RSV1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
    K1赋值:RSV1的3日[1日权重]移动平均
    D1赋值:K1的3日[1日权重]移动平均
    J1赋值:3*K1-2*D1
    RSV赋值:(收盘价-26日内最低价的最低值)/(26日内最高价的最高值-26日内最低价的最低值)*100
    K赋值:RSV的6日[1日权重]移动平均
    D赋值:K的3日[1日权重]移动平均
    J赋值:3*K-2*D
    LC赋值:1日前的收盘价
    XA赋值:如果J1上穿JANDJ<20,返回-1,否则返回0+如果J上穿J1ANDJ>80,返回1,否则返回0
    TYP赋值:(最高价+最低价+收盘价)/3
    CCJ赋值:(TYP-TYP的14日简单移动平均)/(0.015*TYP的14日平均绝对偏差)/2
    RSI1赋值:收盘价-LC和0的较大值的6日[1日权重]移动平均/收盘价-LC的绝对值的6日[1日权重]移动平均*100
    K2赋值:(收盘价-36日内最低价的最低值)/(36日内最高价的最高值-36日内最低价的最低值)*100的9日指数移动平均
    XB赋值:如果CCJ>100ANDK2>50ANDC>开盘价,返回0.5,否则返回0+如果RSI1>80ANDK2>50ANDC>开盘价,返回0.5,否则返回0
    RSV3赋值:(收盘价-100日内最低价的最低值)/(100日内最高价的最高值-100日内最低价的最低值)*100
    K13赋值:RSV3的21日[1日权重]移动平均
    D13赋值:K1的3日[1日权重]移动平均
    J13赋值:3*K13-2*D13
    XC赋值:如果J13>80ANDRSI1>85,返回0.5,否则返回0
    输出警戒:成交量(手)*(XA+XB+XC>0),COLOR009000,线宽为2
    输出选股:如果V5>成交量(手)的5日简单移动平均*2ANDV5>=V6ANDV5>=V7ANDC>OORV>成交量(手)的5日简单移动平均*3,返回成交量(手)/2,否则返回0,画红色,线宽为2
    当满足条件M5上穿M10时,在成交量(手)位置画1号图标
    当满足条件M10上穿M5时,在成交量(手)位置画2号图标
    当满足条件4000上穿金指时,在成交量(手)位置画4号图标
    当满足条件M5上穿警戒时,在成交量(手)位置画5号图标
    当满足条件V7>V5ANDV7>V6ANDC<收盘价的30日简单移动平均ANDV7<成交量(手)的5日简单移动平均/2ANDMA(成交量(手),5)<成交量(手)的10日简单移动平均时,在成交量(手)*2位置书写文字,画洋红色
    当满足条件V5>成交量(手)的5日简单移动平均*2ANDV5>=V6ANDV5>=V7ANDC>OORV>成交量(手)的5日简单移动平均*3的2日过滤时,在1.2*成交量(手)位置书写文字,画红色
    当满足条件V5>=V6ANDV5>=V7ANDC<OANDV5/成交量(手)>0.7ANDV5>成交量(手)的5日简单移动平均时,在5日内成交量(手)的最高值位置书写文字,画白色
    当满足条件V6>V5ANDV6>V7ANDC>收盘价的5日简单移动平均ANDC>收盘价的34日简单移动平均ANDH>收盘价的55日简单移动平均ANDV>M5ANDV6>成交量(手)的5日简单移动平均时,在成交量(手)位置书写文字,画绿色
    输出低量:流通股本(股)/5000,线宽为1,画蓝色,POINTDOT
    输出活跃量:流通股本(股)/1000,线宽为1,画黄色,POINTDOT
    输出危险成交量:流通股本(股)/500,线宽为1,画红色,POINTDOT



神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论