神奇指标网

发现黑马指标公式

浏览 251次浏览
标签: 黑马
来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15

  



     相关简介: 发现黑马指标公式                                


  授权方式:免费版


  指标评级:★★★★★


  指标分类:策略


  画线方法:副图/主图





未来函数检测结果:

         暂未发现存在未来函数





发现黑马指标公式源码:



    X_1:=EMA(CLOSE,12/4)-EMA(CLOSE,26/4);
    X_2:=EMA(X_1,9/4);
    STICKLINE(X_1>=X_2,42,46,5,0),COLORWHITE;
    STICKLINE(X_1<X_2,42,46,5,1),COLOR696969;
    X_3:=EMA(CLOSE,6)-EMA(CLOSE,80);
    X_4:=EMA(X_3,40);
    STICKLINE(X_3>=X_4,36,40,5,0),COLORCYAN;
    STICKLINE(X_3<X_4,36,40,5,1),COLOR696969;
    X_5:=macd.DIF#WEEK;
    X_6:=MacD.DEA#WEEK;
    STICKLINE(X_5>=X_6,30,34,5,0),COLORGREEN;
    STICKLINE(X_5<X_6,30,34,5,1),COLOR696969;
    X_7:=MACD.DIF#MONTH;
    X_8:=MACD.DEA#MONTH;
    STICKLINE(X_7>=X_8,24,28,5,0),COLORBLUE;
    STICKLINE(X_7<X_8,24,28,5,1),COLOR696969;
    X_9:=(CLOSE-LLV(LOW,72))/(HHV(HIGH,72)-LLV(LOW,72));
    X_10:=SMA(X_9,3,1);
    X_11:=SMA(X_10,3,1);
    STICKLINE(X_10>=X_11,18,22,5,0),COLORYELLOW;
    STICKLINE(X_10<X_11,18,22,5,1),COLOR696969;
    X_12:=(CLOSE-LLV(LOW,89))/(HHV(HIGH,89)-LLV(LOW,89));
    X_13:=SMA(X_12,3,1);
    X_14:=SMA(X_13,3,1);
    X_15:=3*X_13-2*X_14;
    STICKLINE(X_13>=X_14,12,16,5,0),COLORRED;
    STICKLINE(X_13<X_14,12,16,5,1),COLOR696969;
    X_16:=kdj.K#WEEK;
    X_17:=kdJ.D#WEEK;
    STICKLINE(X_16>=X_17,6,10,5,0),COLORMAGENTA;
    STICKLINE(X_16<X_17,6,10,5,1),COLOR696969;
    X_18:=KDJ.K#MONTH;
    X_19:=KDJ.D#MONTH;
    STICKLINE(X_18>=X_19,0,4,5,0),COLOR880088;
    STICKLINE(X_18<X_19,0,4,5,1),COLOR696969;
    X_20:=REF(HIGH,1)=HHV(HIGH,10);
    X_21:=crOSS(X_20,0.9);
    X_22:=REF(LOW,1)=LLV(LOW,10);
    X_23:=CROSS(X_22,0.9);
    X_24:=REF(HIGH,BArslAST(X_21));
    X_25:=REF(LOW,BARSLAST(X_23));
    X_26:=(CLOSE+HIGH+LOW)/3;
    X_27:=EMA(X_26,10);
    X_28:=REF(X_27,1);
    X_29:=MA(CLOSE,5);
    X_30:=MA(CLOSE,10);
    X_31:=MA(CLOSE,20);
    X_32:=MA(CLOSE,60);
    X_33:=MA(CLOSE,120);
    X_34:=MA(CLOSE,250);
    X_35:=EMA(CLOSE,500);
    X_36:=X_1>=X_2ANDX_3>=X_4ANDX_5>=X_6ANDX_7>=X_8ANDX_10>=X_11ANDX_13>=X_14ANDX_16>=X_17ANDX_18>=X_19ANDCLOSE>REF(CLOSE,1)*1.05;
    STICKLINE(FILTER(CLOSE>=OPENANDX_36ANDCLOSE>X_27ANDCLOSE>X_24ANDOPEN/X_32<1.2ANDOPEN/X_33<2.2ANDCLOSE>REF(CLOSE,1)*1.05,10),0,46,2,0),COLORRED;
    X_37:=SUM(MAX(MAX(HIGH-LOW,Abs(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),10);
    X_38:=HIGH-REF(HIGH,1);
    X_39:=REF(LOW,1)-LOW;
    X_40:=SUM(IF(X_38>0ANDX_38>X_39,X_38,0),20);
    X_41:=SUM(IF(X_39>0ANDX_39>X_38,X_39,0),20);
    X_42:=LLV(LOW,240);
    X_43:=HHV(HIGH,240);
    20;
    X_44:=X_40/X_37/2*100;
    DH:(CLOSE-X_42)/X_42*100,COLORYELLOW,LINETHICK2;
    X_45:=X_41/X_37/2*100;
    X_46:=(X_43-CLOSE)/CLOSE*100;
    X_47:=(-(0.05-WINNER(CLOSE/1.12)))*300;
    ZQ:IF(DH>15ANDDH>X_45ANDDH>X_46,DH,DRAWNULL),COLORYELLOW,LINETHICK2;
    QS:IF(DH>30ANDDH>X_45ANDDH>X_46,DH,DRAWNULL),COLORRED,LINETHICK2;
    CQ:IF(X_47>DH,DH,DRAWNULL),COLORBLUE,LINETHICK2;
    DRAWICON(FILTER(X_47>DHANDX_36ANDCLOSE>X_27ANDCLOSE>X_24ANDOPEN/X_32<1.2ANDOPEN/X_33<2.2ANDCLOSE>REF(CLOSE,1)*1.05,10),60,44);
    STICKLINE(FILTER(X_47>DHANDX_36ANDCLOSE>X_27ANDCLOSE>X_24ANDOPEN/X_32<1.2ANDOPEN/X_33<2.2ANDCLOSE>REF(CLOSE,1)*1.05,10),0,46,2,0),COLORMAGENTA;





发现黑马指标公式源码注释翻译结果



    X_1赋值:收盘价的12/4日指数移动平均-收盘价的26/4日指数移动平均
    X_2赋值:X_1的9/4日指数移动平均
    当满足条件X_1>=X_2时,在42和46位置之间画柱状线,宽度为5,0不为0则画空心柱.,画白色
    当满足条件X_1<X_2时,在42和46位置之间画柱状线,宽度为5,1不为0则画空心柱.,COLOR696969
    X_3赋值:收盘价的6日指数移动平均-收盘价的80日指数移动平均
    X_4赋值:X_3的40日指数移动平均
    当满足条件X_3>=X_4时,在36和40位置之间画柱状线,宽度为5,0不为0则画空心柱.,画青色
    当满足条件X_3<X_4时,在36和40位置之间画柱状线,宽度为5,1不为0则画空心柱.,COLOR696969
    X_5赋值:平滑异同平均线的DIF[取周线数据]
    X_6赋值:平滑异同平均线的DEA[取周线数据]
    当满足条件X_5>=X_6时,在30和34位置之间画柱状线,宽度为5,0不为0则画空心柱.,画绿色
    当满足条件X_5<X_6时,在30和34位置之间画柱状线,宽度为5,1不为0则画空心柱.,COLOR696969
    X_7赋值:平滑异同平均线的DIF[取月线数据]
    X_8赋值:平滑异同平均线的DEA[取月线数据]
    当满足条件X_7>=X_8时,在24和28位置之间画柱状线,宽度为5,0不为0则画空心柱.,画蓝色
    当满足条件X_7<X_8时,在24和28位置之间画柱状线,宽度为5,1不为0则画空心柱.,COLOR696969
    X_9赋值:(收盘价-72日内最低价的最低值)/(72日内最高价的最高值-72日内最低价的最低值)
    X_10赋值:X_9的3日[1日权重]移动平均
    X_11赋值:X_10的3日[1日权重]移动平均
    当满足条件X_10>=X_11时,在18和22位置之间画柱状线,宽度为5,0不为0则画空心柱.,画黄色
    当满足条件X_10<X_11时,在18和22位置之间画柱状线,宽度为5,1不为0则画空心柱.,COLOR696969
    X_12赋值:(收盘价-89日内最低价的最低值)/(89日内最高价的最高值-89日内最低价的最低值)
    X_13赋值:X_12的3日[1日权重]移动平均
    X_14赋值:X_13的3日[1日权重]移动平均
    X_15赋值:3*X_13-2*X_14
    当满足条件X_13>=X_14时,在12和16位置之间画柱状线,宽度为5,0不为0则画空心柱.,画红色
    当满足条件X_13<X_14时,在12和16位置之间画柱状线,宽度为5,1不为0则画空心柱.,COLOR696969
    X_16赋值:KDJ的K[取周线数据]
    X_17赋值:KDJ的D[取周线数据]
    当满足条件X_16>=X_17时,在6和10位置之间画柱状线,宽度为5,0不为0则画空心柱.,画洋红色
    当满足条件X_16<X_17时,在6和10位置之间画柱状线,宽度为5,1不为0则画空心柱.,COLOR696969
    X_18赋值:KDJ的K[取月线数据]
    X_19赋值:KDJ的D[取月线数据]
    当满足条件X_18>=X_19时,在0和4位置之间画柱状线,宽度为5,0不为0则画空心柱.,COLOR880088
    当满足条件X_18<X_19时,在0和4位置之间画柱状线,宽度为5,1不为0则画空心柱.,COLOR696969
    X_20赋值:1日前的最高价=10日内最高价的最高值
    X_21赋值:X_20上穿0.9
    X_22赋值:1日前的最低价=10日内最低价的最低值
    X_23赋值:X_22上穿0.9
    X_24赋值:上次X_21距今天数日前的最高价
    X_25赋值:上次X_23距今天数日前的最低价
    X_26赋值:(收盘价+最高价+最低价)/3
    X_27赋值:X_26的10日指数移动平均
    X_28赋值:1日前的X_27
    X_29赋值:收盘价的5日简单移动平均
    X_30赋值:收盘价的10日简单移动平均
    X_31赋值:收盘价的20日简单移动平均
    X_32赋值:收盘价的60日简单移动平均
    X_33赋值:收盘价的120日简单移动平均
    X_34赋值:收盘价的250日简单移动平均
    X_35赋值:收盘价的500日指数移动平均
    X_36赋值:X_1>=X_2ANDX_3>=X_4ANDX_5>=X_6ANDX_7>=X_8ANDX_10>=X_11ANDX_13>=X_14ANDX_16>=X_17ANDX_18>=X_19ANDCLOSE>1日前的收盘价*1.05
    当满足条件收盘价>=OPENANDX_36ANDCLOSE>X_27ANDCLOSE>X_24ANDOPEN/X_32<1.2ANDOPEN/X_33<2.2ANDCLOSE>1日前的收盘价*1.05的10日过滤时,在0和46位置之间画柱状线,宽度为2,0不为0则画空心柱.,画红色
    X_37赋值:最高价-最低价和最高价-1日前的收盘价的绝对值的较大值和1日前的收盘价-最低价的绝对值的较大值的10日累和
    X_38赋值:最高价-1日前的最高价
    X_39赋值:1日前的最低价-最低价
    X_40赋值:如果X_38>0ANDX_38>X_39,返回X_38,否则返回0的20日累和
    X_41赋值:如果X_39>0ANDX_39>X_38,返回X_39,否则返回0的20日累和
    X_42赋值:240日内最低价的最低值
    X_43赋值:240日内最高价的最高值
    20
    X_44赋值:X_40/X_37/2*100
    输出DH:(收盘价-X_42)/X_42*100,画黄色,线宽为2
    X_45赋值:X_41/X_37/2*100
    X_46赋值:(X_43-收盘价)/收盘价*100
    X_47赋值:(-(0.05-以收盘价/1.12计算的获利盘比例))*300
    输出ZQ:如果DH>15ANDDH>X_45ANDDH>X_46,返回DH,否则返回无效数,画黄色,线宽为2
    输出QS:如果DH>30ANDDH>X_45ANDDH>X_46,返回DH,否则返回无效数,画红色,线宽为2
    输出CQ:如果X_47>DH,返回DH,否则返回无效数,画蓝色,线宽为2
    当满足条件X_47>DHANDX_36ANDCLOSE>X_27ANDCLOSE>X_24ANDOPEN/X_32<1.2ANDOPEN/X_33<2.2ANDCLOSE>1日前的收盘价*1.05的10日过滤时,在60位置画44号图标
    当满足条件X_47>DHANDX_36ANDCLOSE>X_27ANDCLOSE>X_24ANDOPEN/X_32<1.2ANDOPEN/X_33<2.2ANDCLOSE>1日前的收盘价*1.05的10日过滤时,在0和46位置之间画柱状线,宽度为2,0不为0则画空心柱.,画洋红色



神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论