神奇指标网
神奇指标网

大智慧大盘趋势指标公式_大智慧指标公式

浏览 100次浏览 来源:神奇指标网 编辑:神奇指标网 发布日期:2024-01-10

  

以下是大智慧大盘趋势指标公式源码和截图


大智慧大盘趋势指标公式源码:

   BYX:WMA(CLOSE,8),COLORYELLOW,LINETHICK3;

   IF(BYX>REF(BYX,1),BYX,DRAWNULL),COLORYELLOW,LINETHICK3;

   IF(BYX<REF(BYX,1),BYX,DRAWNULL),LINETHICK3;

   气温:=DYNAINFO(60)/(DYNAINFO(60)+DYNAINFO(61))*100;

   量能饱和度:=380-((DYNAINFO(60)/(DYNAINFO(61)+DYNAINFO(60))*100)*3);

   DRAWRECTREL(997,80,984,380,RGB(30,30,30)),COLORWHITE;

   DRAWRECTREL(997,量能饱和度,984,380,RGB(255,0,0));

   DRAWTEXT_FIX(1483,0,0,0,STRCAT(STRCAT('大盘今天人气:',CON2STR(气温,2)),'%')),COLORRED;

   大盘5日:=(INDEXC-MA(INDEXC,5))/MA(INDEXC,5)*10;

   大盘7日:=(INDEXC-MA(INDEXC,7))/MA(INDEXC,7)*10;

   大盘13日:=(INDEXC-MA(INDEXC,13))/MA(INDEXC,13)*10;

   大盘:(大盘5日+大盘7日+大盘13日)/3;

   平衡:0,COLORYELLOW;

   stICKLINE(大盘>平衡,大盘,平衡,8,0),colorred;

   STICKLINE(大盘<平衡,大盘,平衡,8,0),COLORWHITE;

   {STICKLINE(个股>大盘,个股,大盘,3,0),COLORRED;

   STICKLINE(个股<平衡,个股,平衡,3,0),COLORWHITE;};

   趋势线黑马:SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100);

   AA10:MA(CLOSE,8),COLOR0000FF;

   AA12:MA(CLOSE,12),COLOR0000FF;

   BB10:=((ATAN((AA10-REF(AA10,1)))*3.1416)*10);

   BB12:=((ATAN((AA12-REF(AA12,1)))*3.1416)*10);

   MA13:=MA(CLOSE,13);

   {STICKLINE((((AA12<=AA10)AND(BB12>=1))AND(BB10>=1)),AA10,AA12,4,0),COLOR0080FF;}

   DRAWBAND(AA10,RGB(150,0,100),AA12,RGB(256,96,96));

   {STICKLINE((((AA12>=AA10)AND(BB10<=1))AND(BB10<=1)),AA10,AA12,4,0),COLOR00FF00;}

   STICKLINE(CLOSE>REF(CLOSE,1),HIGH,LOW,0,1),colorred;

   STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,3,0),COLOR000055;

   STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLOR000077;

   STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLOR000099;

   STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLOR0000BB;

   STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLOR0000DD;

   STICKLINE(CLOSE>REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLOR0000FF;

   STICKLINE(CLOSE=REF(CLOSE,1),HIGH,LOW,0,1),colorwhite;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,3,0),COLOR555555;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLOR777777;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLOR999999;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLORBBBBBB;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLORDDDDDD;

   STICKLINE(CLOSE=REF(CLOSE,1),OPEN,CLOSE,0.3,0),COLORFFFFFF;

   STICKLINE(CLOSE<REF(CLOSE,1),HIGH,LOW,0,1),colorcyan;

   STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,3,0),COLOR990000;

   STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,2.7,0),COLORCC0000;

   STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,2.1,0),COLORFF4400;

   STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,1.5,0),COLORFF8800;

   STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,0.9,0),COLORFFCC00;

   STICKLINE(CLOSE<REF(CLOSE,1),OPEN,CLOSE,0.3,0),colorcyan;

   X1:=(C+L+H)/3;BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;

   EMA8:=EMA(C,8);DRAWTEXT(FILTER(BB13>1ANDEMA(X1,13)>REF(EMA(X1,8),1),10),

   EMA8,'∠45上升'),colorwhite;压力:MA(REF(HHV(C,30),1),2),COLOR9DFFFF;

   支撑:MA(REF(LLV(C,30),1),2),COLORABFF46;AA1:=AMOUNT/V;BB1:=L1.2;DD1:=L<MA(C,5)*0.921;EE1:=V<MA(V,5)*1.5;

   FF1:=BB1ANDCC1ANDDD1ANDEE1;DRAWTEXT(FF1,(LOW*0.99),'老鼠仓'),COLOR4080FF;

   A51:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);

   黑马线:=EMA(A51,5);A54:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;

   趋势线:=(MA(3*SMA(A54,6,1)-2*SMA(SMA(A54,5,1),5,1),2));

   DRAWTEXT(CROSS(趋势线,0)AND黑马线<40,(HIGH*0.97),'▲大黑马'),coloryellow;

   LC:=REF(CLOSE,1);RSI:=((SMA(MAX((CLOSE-LC),0),3,1)/SMA(ABS((CLOSE-LC)),3,1))*100);

   FF:=EMA(CLOSE,3);MA15:=EMA(CLOSE,21);DRAWTEXT(CROSS(FF,MA15),(LOW*0.99),'底背离'),COLORA6E500;

   DRAWTEXT(CROSS(88,RSI),(HIGH*1.02),'顶背离'),COLOR1880FF;

   VAR2:=LLV(LOW,27);VAR3:=HHV(HIGH,34);VAR4:=EMA((CLOSE-VAR2)/(VAR3-VAR2)*4,4)*25;

   注意买:=IF((VAR4<10),80,100);RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;

   K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;超跌:=IF(J<0,10,0);BDDD:=LLV(J,2)=LLV(J,8);

   买入:=IF(CROSS(J,REF(J+0.01,1))ANDBDDDANDJ<20,30,0);

   DRAWTEXT(买入AND注意买=100AND超跌=0,LOW,'短线'),COLOR8000FF;

   MTM:=C-REF(C,1);DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

   买:=IF(LLV(DX,2)=LLV(DX,7)ANDCOUNT(DX<0,2)ANDCROSS(DX,MA(DX,2)),1,0);

   DRAWTEXT(FILTER(买=1,5),LOW-0.03,'拉升'),COLORFFDE00;




大智慧大盘趋势指标公式截图

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论