神奇指标网
神奇指标网

通达信自己珍藏的抓住主升浪主图源码-通达信指标公式

浏览 413次浏览
标签: 主升浪
来源:神奇指标网 编辑:神奇指标网 发布日期:2024-02-06

  

以下是通达信自己珍藏的抓住主升浪主图源码和截图


通达信自己珍藏的抓住主升浪主图源码:

   ma1:=MA(V,5);

   MA2:=MA(V,60);

   MA5:=MA(C,5);

   MA10:=MA(CLOSE,10);

   MA13:=MA(C,13);

   MA20:=MA(C,20);

   MA30:=MA(C,30);

   MA60:=MA(C,60);

   MA120:=MA(C,120);

   MA250:=MA(C,250);

   MA530:=MA(C,530);

   V1:=240/FROMOPEN*DYNAINFO(8);

   D:=MA(C,5);

   A:=D>=REF(D,1);

   B1:=C>DAND(C-D)/D<=0.08;

   DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

   DEA:=EMA(DIF,9);

   macd:=(DIF-DEA)*2;

   MID:=MA(CLOSE,26);

   UPPER:=MID+2*stD(CLOSE,26);

   LOWER:=MID-2*STD(CLOSE,26);

   S2:=IF(NAMELIKE('S'),0,1);

   S3:=IF(NAMELIKE('*'),0,1);

   S4:=DYNAINFO(17)>0;

   GX:=DIF>0ANDDEA>0ANDDIF>DEAANDS2ANDS3ANDS4ANDMA5>MA13ANDMA13>MA20ANDMA20>MA30ANDMA20>REF(MA20,1)ANDMA13>REF(MA13,1)ANDMA30>REF(MA30,1)ANDMA5>REF(MA5,1)ANDC>REF(C,1)ANDvol>REF(VOL,1)ANDC>MA60ANDC>MA120ANDC>MA250ANDC>REF(HHV(C,150),1)ANDC>UPPERANDUPPER>REF(UPPER,1)ANDcrOSS(CLOSE,UPPER);

   ENTERLONG:=DIF>0ANDDEA>0ANDDIF>DEAANDS2ANDS3ANDS4ANDMA5>MA13ANDWINNER(C)>0.9ANDMA13>MA20ANDMA20>MA30ANDMA20>REF(MA20,1)ANDMA13>REF(MA13,1)ANDMA30>REF(MA30,1)ANDMA5>REF(MA5,1)ANDC>REF(C,1)ANDVOL>REF(VOL,1)ANDC>MA60ANDC>MA120ANDC>MA250ANDC>REF(HHV(C,50),1)ANDC>UPPERANDUPPER>REF(UPPER,1)ANDCROSS(CLOSE,UPPER)ANDCOUNT(C>MA(C,5),3)=3ANDLOW<MA(CLOSE,3)ANDCLOSE>MA(CLOSE,5)ANDMA5>MA20ANDMA5>MA60ANDMA13>MA60ANDV1>MA(V,60)ANDV1>MA(V,5);

   ENTERLONG1:=VOL>MA1ANDVOL>MA2ANDC>MA13ANDC>MA20ANDC>MA30ANDC>MA60ANDC>MA120ANDC>MA250ANDAANDB1ANDDIF=HHV(DIF,30)ANDMacD=HHV(MACD,2)ANDWINNER(C)>0.9ANDS2ANDS3ANDS4ANDMA5>MA13ANDWINNER(C)>0.9ANDMA13>MA20ANDMA20>MA30ANDMA20>REF(MA20,1)ANDMA13>REF(MA13,1)ANDMA30>REF(MA30,1)ANDMA5>REF(MA5,1)ANDC>REF(C,1)ANDVOL>REF(VOL,1)ANDC>REF(HHV(C,50),1)ANDC>UPPERANDUPPER>REF(UPPER,1)ANDCROSS(CLOSE,UPPER);

   YY2:=V>MA(V,135);

   YY3:=WINNER(C)>=0.85;

   换手:=VOL/CAPITAL*100;

   A1:=REF(CLOSE,1)<MA5ORREF(CLOSE,1)<MA10ORREF(CLOSE,1)<MA20ORREF(CLOSE,1)<MA60ORREF(CLOSE,1)<MA120ANDMA60>MA120;

   A2:=CLOSE>OPENANDVOL>REF(VOL,1)ANDCLOSE>MAX(MA5,MAX(MA10,MAX(MA20,MAX(MA60,MA120))));

   去除停牌:=DYNAINFO(13)>0;

   DIF1:=EMA(CLOSE,10)-EMA(CLOSE,22);

   DEA1:=EMA(DIF1,9);

   MACD1:=(DIF1-DEA1)*2;

   XG:=A1ANDA2ANDYY2ANDYY3AND换手>2.7ANDMACD1>REF(MACD,1)AND去除停牌;

   GXORENTERLONGORENTERLONG1ORXG;

   A:EMA(C,21)COLORBLUE,LINETHICK3;

   B:=A<REF(A,1);

   IF(B-1,A,DRAWNULL)COLORRED,LINETHICK3;

   AA:=EMA(C,3)>EMA(C,21);

   BB:=EMA(C,3)<EMA(C,21);

   CC:=EMA(C,3)>EMA(C,8);

   CC1:=EMA(C,3)<EMA(C,8);

   DD:=CLOSE<OPEN;

   STICKLINE(AA,H,L,0,0),COLOR007FFF;

   STICKLINE(AA,O,C,3,1),COLOR007FFF;

   STICKLINE(AAANDDD,O,C,3,0),COLOR007FFF;

   STICKLINE(BB,H,L,0,0),COLORGREEN;

   STICKLINE(BB,O,C,3,1),COLORGREEN;

   STICKLINE(BBANDDD,O,C,3,0),COLORGREEN;

   STICKLINE(BBANDCC,H,L,0,1),COLORF00FF0;

   STICKLINE(BBANDCC,O,C,3,1),COLORF00FF0;

   STICKLINE(BBANDCCANDDD,O,C,3,0),COLORF00FF0;

   STICKLINE(AAANDCC1,H,L,0,0),COLORBLUE;

   STICKLINE(AAANDCC1,O,C,3,1),COLORBLUE;

   STICKLINE(AAANDCC1ANDDD,O,C,3,0),COLORBLUE;

   买线:=MA(CLOSE,9),LINETHICK2;

   卖线:=MA(CLOSE,20);

   BU:=CROSS(买线,卖线);

   SEL:=CROSS(卖线,买线);

   DRAWTEXT(BU,L-0.1,'建仓')COLORYELLOW;

   DRAWTEXT(SEL,H+0.1,'空仓');

   A2:=(C-REF(C,1))/REF(C,1)*100<1.02;

   A3:=H>MA(C,5)*1.12;

   AAA:=A2ANDA3;

   DRAWTEXT(AAA,H*1.05,'卖点'),COLORWHITE;

   EMA13:=EMA(C,13),COLOR0000FF,LINETHICK2;

   EMA34:=EMA(C,34),COLORYELLOW;

   EMA55:=EMA(C,55),COLORFF00FF;

   EMA120:=EMA(C,120),COLORFFCC66;

   AR1:=EMA55>EMA34ANDEMA34>EMA13;

   AR2:=BARSLAST((C-EMA13)/EMA13*100<-6);

   AR3:=EMA13>=REF(EMA13,2);

   AR4:=COUNT(CROSS(C,EMA13),AR2)=1;

   AR5:=AR1ANDAR2ANDAR3ANDAR4;

   AR6:=AR5ANDFILTER(AR5,10);

   DRAWTEXT(AR6,L-0.09,'启动'),COLORYELLOW;

   STICKLINE(AR6,H,L,3,0),LINETHICK2,COLORYELLOW;

   BR1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5),5)=5;

   BR2:=ABS((EMA13-EMA34)+(EMA34-EMA55))/C<0.2;

   BR3:=C>EMA55AND(REF(C,1)<REF(EMA55,1)ORREF(C,2)<REF(EMA55,2)ORREF(C,3)<REF(EMA55,3)ORREF(C,4)<REF(EMA55,4)ORREF(C,5)<REF(EMA55,5));

   BR4:=BR1ANDBR2ANDBR3;

   DRAWTEXT(BR4ANDFILTER(BR4,10),L-0.09,'上升'),COLOR00C5FF;

   STICKLINE(BR4ANDFILTER(BR4,10),O,C,3,1),LINETHICK2,COLOR00C5FF;

   CR1:=(C-REF(C,1))/REF(C,1)*100>0.5;

   CR2:=V>MA(V,5)*0.6;

   CR3:=COUNT(CROSS(EMA13,EMA55),3)=1;

   CR4:=ABS(EMA34-EMA55)/EMA55<0.03;

   CR5:=EMA55<=EMA120ANDEMA55>=REF(EMA55,1);

   CR6:=FILTER(CR1ANDCR2ANDCR3ANDCR4ANDCR5,2);

   STICKLINE(CR6,O,C,3,1),LINETHICK2,COLORF00FF0;

   DRAWTEXT(CR6,L-0.09,'涨升'),COLORF00FF0;

   DR1:=EMA13>EMA34ANDEMA34<EMA55;

   DR2:=BARSLAST(CROSS(C,EMA55));

   DR3:=H=HHV(H,DR2);

   DR4:=BARSLAST(DR3);

   DR5:=COUNT(O>CANDC<REF(C,1)ANDC>EMA55ANDBETWEEN((C-EMA55)/EMA55,0,0.02),DR4)=1;

   DR6:=C>REF(C,1);

   DR7:=DR1ANDDR5ANDDR6;

   DR8:=DR7ANDFILTER(DR7,10);

   DRAWTEXT(DR8,L-0.09,'出击'),COLORD6BA63;

   ER:=BARSLAST(REF(CROSS(EMA55,EMA34),1))ANDCROSS(EMA34,EMA55);

   DRAWTEXT(ER,L-0.09,'金叉'),COLOR0099FF;

   FR:=BARSLAST(REF(CROSS(EMA34,EMA13),1))ANDCROSS(EMA13,EMA34);

   DRAWTEXT(FR,L-0.09,'加仓'),COLORWHITE;

   GR1:=BARSLAST(BETWEEN("BIAS.BIAS2"(6,13,24),0,5));

   GR2:=EMA13>EMA34ANDEMA34>EMA55ANDEMA13>REF(EMA13,1);

   GR3:=COUNT("BIAS.BIAS2"(6,13,24)>10ANDH=HHV(H,GR1),GR1);

   GR4:=H=HHV(H,GR1);

   GR5:="MACD.MACD"(12,26,9)<REF("MACD.MACD"(12,26,9),1);

   GR6:=GR2ANDGR3ANDGR4;

   GR7:=GR2ANDGR3ANDGR4ANDGR5;

   DRAWTEXT(GR6ANDGR7,H+0.13,'了结'),COLOR00FF00;

   HR2:=EMA13>=REF(EMA13,3)ANDEMA34>=REF(EMA34,1)ANDEMA55>=REF(EMA55,1)ANDCROSS(C,EMA13)ANDCROSS(C,EMA34)ANDCROSS(C,EMA55);

   DRAWTEXT(HR2ANDFILTER(HR2,10),L-0.3,'推进'),COLORFFC8FF;

   STICKLINE(HR2ANDFILTER(HR2,10),O,C,3,1),LINETHICK2,COLORFFC8FF;

   VAR1:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);

   VAR2:=CROSS(VAR1,0.9);

   VAR3:=BACKSET(REF(LOW,2)=LLV(LOW,5),3);

   VAR4:=CROSS(VAR3,0.9);

   压力:=REF(HIGH,BARSLAST(VAR2)),POINTDOT,COLOREA91B5;

   STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2)),REF(HIGH,BARSLAST(VAR2)),2,1),COLOREA91B5,LINETHICK3;

   支撑:=REF(LOW,BARSLAST(VAR4)),POINTDOT,COLOR00B4FF;

   STICKLINE(CLOSE,REF(LOW,BARSLAST(VAR4)),REF(LOW,BARSLAST(VAR4)),2,1),COLOR00B4FF,LINETHICK3;

   下档线:=(((CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13)))*100);

   ARSV:=SMA(下档线,3,1);

   AK:=SMA(ARSV,3,1);

   AD:=((3*ARSV)-(2*AK));

   AJ12:=(((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55)))*100);

   ARSV24:=SMA(AJ12,3,1);

   AK24:=SMA(ARSV24,3,1);

   AD24:=((3*ARSV24)-(2*AK24));

   撑:=IF(CROSS(AD24,AD),HIGH,REF(HIGH,BARSLAST(CROSS(AD24,AD))));

   撑压位:=IF(ISLASTBAR,撑,DRAWNULL);

   底底:=LLV(HIGH,30);

   底:=IF(ISLASTBAR,底底,DRAWNULL);

   STICKLINE(ISLASTBAR,撑压位,撑压位,100,1),LINETHICK1,COLORFFFFFF;

   STICKLINE(ISLASTBAR,底,底,80,1),COLOR00FF00,LINETHICK1;

   空间:=15;阳线:=103;VAR1:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;VAR2:=SMA(VAR1,3,1);VAR3:=SMA(VAR2,3,1);VAR4:=SMA(VAR3,3,1);趋势线:VAR3,,LINETHICK2,COLORRED;人气线:VAR4,,LINETHICK2,COLORYELLOW;VAR5:=CROSS(VAR2,VAR3)ANDVAR3<25;STICKLINE(VAR5,0,VAR3+5,1,1),,LINETHICK2,COLORRED;VAR6:=CROSS(VAR3,VAR4)ANDVAR3<25;VAR7:=VAR6ANDVOL>REF(VOL,1)*2ANDVOL>REF(MA(VOL,5),1)*2;STICKLINE(VAR6,0,VAR3+5,1,1),,LINETHICK2,COLORWHITE;DRAWTEXT(VAR6ANDCOUNT(VAR6,10)=1,VAR3+15,'买点'),,LINETHICK2,COLORWHITE;STICKLINE(VAR7,0,VAR3+5,1,1),,LINETHICK2,COLORRED;DRAWTEXT(VAR7ANDCOUNT(VAR7,10)=1,VAR3+5,'机构异动'),,LINETHICK2,COLORRED;VAR8:=CROSS(VAR2,VAR3)ANDVAR3>80ANDVAR3>VAR4;STICKLINE(VAR8ANDCOUNT(VAR8,5)=1,VAR3-5,100,1,1),,LINETHICK2,COLORGREEN;VAR9:=CROSS(VAR4,VAR3)ANDVAR3>80;STICKLINE(VAR9,VAR3-5,100,1,1),,LINETHICK2,COLORYELLOW;DRAWTEXT(VAR9ANDCOUNT(VAR9,10)=1,VAR3-15,'卖点'),,LINETHICK2,COLORYELLOW;




通达信自己珍藏的抓住主升浪主图截图

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论