神奇指标网
神奇指标网

通达信妖起来副图指标一妖起来就是连板不停源码-通达信指标公式

浏览 494次浏览
标签: 指标公式
来源:神奇指标网 编辑:神奇指标网 发布日期:2024-02-19

  

以下是通达信妖起来副图指标一妖起来就是连板不停源码和截图


通达信妖起来副图指标一妖起来就是连板不停源码:

   MA20:=MA(C,20);MA30:=MA(C,30);LC:=REF(C,1);RSI1:=SMA(MAX(C-LC,0),6,1)/SMA(Abs(C-LC),6,1)*100;RSI2:=SMA(MAX(C-LC,0),12,1)/SMA(ABS(C-LC),12,1)*100;RSI3:=SMA(MAX(C-LC,0),24,1)/SMA(ABS(C-LC),24,1)*100;RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;K:=SMA(RSV,3,1);D:=SMA(K,3,1);D>REF(D,1)ANDREF(D,1)<REF(D,2)ANDMA20>MA30ANDMA(RSI1,3)>50ANDCROSS(RSI1,50);

   X_1:=IF(NAMELIKE(2),0,1);

   X_2:=IF(NAMELIKE(3),0,1);

   X_3:=DYNAINFO(4)>0;

   X_4:=FINANCE(7)<=8000000000;

   X_5:=CLOSE/REF(CLOSE,1)>1.0975ANDHIGH=OPEN;

   X_6:=X_1ANDX_2ANDX_3ANDX_4ANDNOT(X_5);

   X_7:=IF(HIGH=LOW,1,HIGH-MAX(OPEN,CLOSE));

   X_8:=(HIGH+LOW+CLOSE)/3;

   X_9:=IF(CLOSE>OPENANDHIGH>REF(CLOSE,1),ATAN((HIGH-REF(CLOSE,1))/REF(CLOSE,1)),0);

   X_10:=IF(CLOSE>OPENANDHIGH<REF(CLOSE,1),-ATAN((REF(CLOSE,1)-HIGH)/REF(CLOSE,1)),0);

   X_11:=IF(CLOSE>OPENANDHIGH=REF(CLOSE,1),0,0);

   X_12:=IF(CLOSE<OPENANDHIGH>REF(CLOSE,1),ATAN((HIGH-REF(CLOSE,1))/REF(CLOSE,1)),0);

   X_13:=IF(CLOSE<OPENANDHIGH<REF(CLOSE,1),-ATAN((REF(CLOSE,1)-HIGH)/REF(CLOSE,1)),0);

   X_14:=IF(CLOSE<OPENANDHIGH=REF(CLOSE,1),0,0);

   X_15:=X_9+X_10+X_11+X_12+X_13+X_14;

   X_16:=MA(X_15,9);

   X_17:=MA(X_15,5);

   X_18:=MA(X_15,3);

   X_19:=ATAN((HIGH-REF(HIGH,1))/REF(HIGH,1)/0.1)/6.28*360;

   X_20:=ATAN((LOW-REF(LOW,1))/REF(LOW,1)/0.1)/6.28*360;

   X_21:=ATAN((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)/0.1)/6.28*360;

   X_22:=ATAN((OPEN-REF(OPEN,1))/REF(OPEN,1)/0.1)/6.28*360;

   X_23:=MIN(MIN(MIN(X_21,X_22),X_19),X_20);

   X_24:=MAX(MAX(MAX(X_21,X_22),X_19),X_20);

   X_25:=MIN(X_21,X_22);

   X_26:=MAX(X_21,X_22);

   X_27:=IF(HIGH=LOW,1,MAX(CLOSE,OPEN)-X_8);

   X_28:=IF(CLOSE>OPENANDLOW>REF(CLOSE,1),ATAN((LOW-REF(CLOSE,1))/REF(CLOSE,1)),0);

   X_29:=IF(CLOSE>OPENANDLOW<REF(CLOSE,1),-(ATAN(REF(CLOSE,1)-LOW)/REF(CLOSE,1)),0);

   X_30:=IF(CLOSE>OPENANDLOW=REF(CLOSE,1),0,0);

   X_31:=IF(CLOSE<OPENANDLOW>REF(CLOSE,1),ATAN((LOW-REF(CLOSE,1))/REF(CLOSE,1)),0);

   X_32:=IF(CLOSE<OPENANDLOW<REF(CLOSE,1),-ATAN((REF(CLOSE,1)-LOW)/REF(CLOSE,1)),0);

   X_33:=IF(CLOSE<OPENANDLOW=REF(CLOSE,1),0,0);

   X_34:=X_28+X_29+X_30+X_31+X_32+X_33;

   X_35:=MA(X_34,9);

   X_36:=IF(HIGH=LOW,1,MIN(OPEN,CLOSE)-LOW);

   X_37:=MA(X_34,5);

   X_38:=MA(X_34,3);

   X_39:=ATAN(X_16/0.09);

   X_40:=ATAN(X_17/0.05);

   X_41:=ATAN(X_18/0.03);

   X_42:=ATAN((-X_35)/0.09);

   X_43:=ATAN((-X_37)/0.05);

   X_44:=ATAN((-X_38)/0.03);

   X_45:=CLOSE/REF(CLOSE,1)>1.028ANDCLOSE=HIGHANDBETWEEN(FORCAST(VOL,4),0.2*FORCAST(VOL,12),2.1*FORCAST(VOL,12));

   X_46:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),15);

   X_47:=IF(HIGH=LOW,1,X_8-MIN(CLOSE,OPEN));

   X_48:=VOL/IF(HIGH=LOW,4,HIGH-LOW);

   X_49:=IF(X_26>0ANDX_25>0,X_26,0);

   X_50:=IF(X_26<0ANDX_25<0,X_25,0);

   X_51:=IF(X_26>0ANDX_25<0,X_26,0);

   X_52:=IF(X_26>0ANDX_25<0,X_25,0);

   X_53:=X_7*X_48;

   X_54:=X_48*X_27;

   X_55:=X_36*X_48;

   X_56:=X_47*X_48;

   X_57:=X_56+X_55;

   X_58:=X_53+X_54;

   X_59:=X_57-X_58;

   X_60:=X_59;

   X_61:=FILTER(X_45,28);

   X_62:=(X_41+X_40+X_39)/3/6.28*360;

   X_63:=X_62-REF(X_62,1)>0;

   X_64:=EMA(CLOSE,5);

   X_65:=MA(X_49+X_51,1);

   X_66:=MA(X_50+X_52,1);

   X_67:=X_65+X_66;

   X_68:=FINDHIGH(X_24,1,3,1);

   X_69:=FINDHIGH(X_24,1,3,2);

   X_70:=BARSCOUNT(X_68)<BARSCOUNT(X_69);

   X_71:=IF(X_70,X_68,0);

   X_72:=IF(X_70,X_69,0);

   X_73:=X_71-X_72;

   X_74:=MA(REF(X_68+X_73,1),5);

   X_75:=X_74-REF(X_74,1)>0;

   X_76:=(CLOSE-X_64)/X_64*100;

   X_77:=ATAN((X_64/REF(X_64,1)-1)*100)*180/3.1416;

   X_78:=EMA(CLOSE,30);

   X_79:=HIGH-REF(HIGH,1);

   X_80:=REF(LOW,1)-LOW;

   X_81:=EXPMEMA(IF(X_79>0ANDX_79>X_80,X_79,0),15);

   X_82:=X_81*100/X_46;

   X_83:=X_82-REF(X_82,1)>0;

   X_84:=(CLOSE-X_78)/X_78*100;

   X_85:=COUNT(CROSS(X_76,0),3)>=1ANDX_84>REF(X_84,1)ANDX_64>REF(X_64,1)AND(CLOSE/REF(CLOSE,1)-1)*100>2ANDREF(CLOSE,1)<X_78;

   X_86:=FILTER(X_85,10);

   X_87:=MA(X_59,5)*20;

   X_88:=SMA(X_87,3,1);

   X_89:=X_88-REF(X_88,1)>0;

   准备:=X_61ANDX_63ANDX_62>30ANDX_6ANDX_75ANDX_83ANDX_89;

   启航:=FILTER(CROSS(CLOSE,EMA(HIGH,3)*1.03)AND(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.04,13);

   妖起来:准备AND启航;

   M:=4;

   N:=3;

   1,COLORBLACK;

   二缩:0.7*(BARSLAST(C/REF(C,1)>=1.09)=(M-1)

   ANDCOUNT(V<=REF(V,1),(N-1))=(N-1)),COLORWHITE;

   三缩:0.7*(BARSLAST(C/REF(C,1)>=1.09)=M

   ANDCOUNT(V<=REF(V,1),N)=N),COLORYELLOW;

   四缩:0.7*(BARSLAST(C/REF(C,1)>=1.09)=(M+1)

   ANDCOUNT(V<=REF(V,1),(N+1))=(N+1)),COLORCYAN;

   五缩:0.7*(BARSLAST(C/REF(C,1)>=1.09)=(M+2)

   ANDCOUNT(V<=REF(V,1),(N+2))=(N+2)),COLORMAGENTA;

   六缩:0.7*(BARSLAST(C/REF(C,1)>=1.09)=(M+3)

   ANDCOUNT(V<=REF(V,1),(N+3))=(N+3)),COLORGREEN;

   {剔除:=NOT(JGDX3.趋势线>10ANDJGDX3.趋势线<REF(JGDX3.趋势线,1));}

   {上升趋势中的上涨段、板后M日中连缩N日为"首选"}

   首选:BARSLAST(C/REF(C,1)>=1.09)=M

   ANDCOUNT(V<=REF(V,1),N)=N

   AND(JGDX3.趋势线>=REF(JGDX3.趋势线,1)ORJGDX3.趋势线>=55)

   ANDJGDX3.上行>50,COLORRED;

   {下降趋势中的上涨段、板后M+1日中连缩N+1日为"次选"}

   次选:BARSLAST(C/REF(C,1)>=1.09)=(M+1)

   ANDCOUNT(V<=REF(V,1),(N+1))=(N+1)

   AND(JGDX3.趋势线>=REF(JGDX3.趋势线,1)ORJGDX3.趋势线<=10)

   ANDJGDX3.上行<50,COLOR0099EE;

   {真正选股时使用下面一个式子选出"首选"与"次选"股}

   {XG:首选OR次选;};




通达信妖起来副图指标一妖起来就是连板不停截图

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论