神奇指标网
神奇指标网
  • 神奇指标

    通达信MA02主图 较全面的看盘主图,带K线注释(右键选择)

    以下是通达信MA02主图 较全面的看盘主图,带K线注释(右键选择)通达信MA02主图 较全面的看盘主图,带K线注释(右键选择)M5:MA(C,5),COLORWHITE;M10:MA(C,10),COLORYELLOW;M20:MA(C,20),COLORCYAN;M60:MA(C,60),COLORGREEN,LINETHICK2;M120:MA(C,120),COLORRED,LINETHICK2;VAR6:=(( ABS((OPEN-CLOSE))/(HIGH-LOW))*VOL);VAR7:=(( (HIGH-IF((CLOSE>OPEN),CLOSE,OPEN))/(HIGH-LOW))*VOL);VAR8:=(( (IF((CLOSE>OPEN),OPEN,CLOSE)-LOW)/(HIGH-LOW))*VOL);VAR9:=IF(((VOL/CAPITAL)>0.001),1,EXP(ABS(LOG(((VOL/CAPITAL)*100)))));加仓:=VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,NODRAW,COLORRED;减仓:=VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,NODRAW,COLORBLUE;洗盘:=VAR8>VAR6 AND VAR8>VAR7,NODRAW,COLORWHITE;高抛:=VAR7>VAR6 AND VAR7>VAR8,NODRAW,COLORMAGENTA;地量:=VAR9>2 AND VOL<MA(VOL,5)/2,NODRAW,COLORGREEN;TY:=C;A1:=REF(TY,10)=HHV(TY,2*10+1); B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1); HD:=FILTER(C1,10); A2:=REF(TY,10)=LLV(TY,2*10+1); B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1); LD:=FILTER(C2,10); 前期高位:=REF(H,BARSLAST(HD)), COLORLIRED,LINETHICK1;前期低位:=REF(L,BARSLAST(LD)), COLORGREEN,LINETHICK1;JRH:=HHV(C,2); JRL:=LLV(C,2); VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2)); VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARA:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2)); VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01); VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD); 红色持股:=VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;离场:=IF(红色持股,JRL,DRAWNULL); 明离场价:=离场,COLORFF99FF,NODRAW;青色观望:=VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW; 进:=IF(青色观望,JRH,DRAWNULL);今离场价:REF(离场,1),COLOR0000FF,NODRAW; 明进场价:=进,COLOR33AACC,NODRAW; 今进场价:REF(明进场价,1),COLORGREEN,NODRAW;上涨家数:INDEXADV,COLOR0080FF,NODRAW;下跌家数:INDEXDEC,COLORGREEN,NODRAW;DRAWKLINE(H,O,L,C);STICKLINE(加仓,O,C,0.5,0),COLORRED;STICKLINE(洗盘,O,C,1,0),COLORWHITE;STICKLINE(高抛,O,C,1,0),COLORMAGENTA;STICKLINE(地量,O,C,1,0),COLORGREEN;STICKLINE(减仓,O,C,1,0),COLORBLUE;JJ:=(3*C+H+L+O)/6;VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);LJL:=FILTER(TJ1,5);DRAWTEXT_FIX(1,0.00,0.02,0,'所属行业:'),COLORYELLOW;DRAWTEXT_FIX(1,0.07,0.02,0,HYBLOCK),COLORYELLOW;DRAWTEXT_FIX(1,0.14,0.02,0,'所属地区:'),COLORYELLOW;DRAWTEXT_FIX(1,0.21,0.02,0,DYBLOCK),COLORYELLOW;N:=IF(TOTALBARSCOUNT>=120,120,TOTALBARSCOUNT);HH0:=HHV(H,N);LL0:=LLV(L,N);MM0:=CONST((HH0+LL0)*0.5);S01:=CONST(IF(REF(C,N-15)>MM0,1.00,-0.08));S02:=CONST(IF(REF(C,N-15)>MM0,-1,1));S1:=IF(FINDSTR(EXTERNSTR(0,13),'万元'),S01+(0.08*S02),S01),NODRAW;S2:=IF(FINDSTR(EXTERNSTR(0,12),'。'),S1+(0.08*S02),S1),NODRAW;S3:=IF(FINDSTR(EXTERNSTR(0,8),'公告'),S2+(0.08*S02),S2),NODRAW;S4:=IF(FINDSTR(EXTERNSTR(0,10),','),S3+(0.08*S02),S3);S5:=IF(FINDSTR(EXTERNSTR(0,15),'-'),S4+(0.08*S02),S4);S6:=IF(FINDSTR(EXTERNSTR(0,1),','),S5+(0.08*S02),S5);S7:=IF(FINDSTR(EXTERNSTR(0,14),'-'),S6+(0.08*S02),S6);S8:=IF(FINDSTR(EXTERNSTR(0,11),'-'),S7+(0.08*S02),S7);S9:=IF(FINDSTR(EXTERNSTR(0,9),'-'),S8+(0.08*S02),S8);K:=IF(S1<=0,0.05,IF(S1>=0,-0.05,0));T1:=IF(FINDSTR(EXTERNSTR(0,13),'万元'),STRCAT('敢死队席位:',EXTERNSTR(0,13)),'');T2:=IF(FINDSTR(EXTERNSTR(0,12),'。'),STRCAT('智能诊断:',EXTERNSTR(0,12)),'');T3:=IF(FINDSTR(EXTERNSTR(0,8),'公告'),STRCAT('年报业绩:',EXTERNSTR(0,8)),'');T4:=IF(FINDSTR(EXTERNSTR(0,10),','),STRCAT('主题投资:',EXTERNSTR(0,10)),'');T5:=IF(FINDSTR(EXTERNSTR(0,15),'-'),STRCAT('解禁日期:',EXTERNSTR(0,15)),'');T6:=IF(FINDSTR(EXTERNSTR(0,1),','),STRCAT('千股千评:',EXTERNSTR(0,1)),'');T7:=IF(FINDSTR(EXTERNSTR(0,14),'-'),STRCAT('业绩预报:',EXTERNSTR(0,14)),'');T8:=IF(FINDSTR(EXTERNSTR(0,11),'-'),STRCAT('机构评级:',EXTERNSTR(0,11)),'');T9:=IF(FINDSTR(EXTERNSTR(0,9),'-'),STRCAT('中报业绩:',EXTERNSTR(0,9)),'');{DRAWTEXT_FIX(1,0,S1+K,0,T1)COLOR00FFFF;}DRAWTEXT_FIX(1,0.00,0.12,0,T2),COLOR00FF00;{DRAWTEXT_FIX(1,0.00,0.1,0,T3),COLORFF00FF;}DRAWTEXT_FIX(1,0.30,0.02,0,T4),COLOR0088FF;DRAWTEXT_FIX(1,0.30,0.07,0,T5)COLOR00FF00;DRAWTEXT_FIX(1,0.00,0.92,0,T6),COLOR00FFFF;DRAWTEXT_FIX(1,0.00,0.07,0,T7),COLOR00CCFF;{DRAWTEXT_FIX(1,0,S8+K,0,T8)COLORFF88FF;}{DRAWTEXT_FIX(1,0,S9+K,0,T9)COLORBBFFFF;}{DRAWTEXT_FIX(1,0.00,0.25,0,'绿芯-高位出货坚决撤离为佳'),COLOR00FF00,LINETHICK1;}{DRAWTEXT_FIX(1,0.00,0.3,0,'蓝芯-主力低位深度洗盘或高位出货坚决'),COLORFF0000,LINETHICK1;DRAWTEXT_FIX(1,0.00,0.35,0,'白芯-主力轻度洗盘'),COLORFFFFFF,LINETHICK1;DRAWTEXT_FIX(1,0.00,0.4,0,'粉芯-主力在做高抛低吸或低吸高抛'),COLORFF00FF,LINETHICK1;DRAWTEXT_FIX(1,0.00,0.45,0,'红芯-主力吸筹进货积极主动'),COLOR0000FF,LINETHICK1;DRAWTEXT_FIX(1,0.00,0.5,0,'黄芯-主力吸筹进货强并且成交量出现黄金柱'),COLORYELLOW,LINETHICK1;} VAR111:=ZIG(3,13);STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,3,0),COLOR66FF00;DRAWTEXT_FIX(STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,5,0),0.00,0.11,0,''),COLOR00FF00,LINETHICK1;天线:=MA(REF(HHV(C,30),1),2),LINETHICK3,COLORMAGENTA;地线:=MA(REF(LLV(C,30),1),2),COLORGREEN,LINETHICK3;

    浏览4010次浏览
    2022-11-03 15:19
  • 神奇指标

    同花顺 指标公式 神奇均线-九大绝招(主图 源码 无未来 用法)

    同花顺 指标公式 神奇均线-九大绝招(主图 源码 无未来 用法)该均线系统视角独特,操作简便,实战性强。系统13个买卖点:超买,超卖,主线突破,强力主线,均线金叉,均线死叉等等;同花顺  副图,叠加主图  指标公式:主线:EMA(C,13),colorred,linethick2;月线雷打不动:EMA(C,34),coloryellow;超跌大胆跟进:EMA(C,55),colorff00ff;年线参考不大:EMA(C,120),colorffcc66;ar1:=超跌大胆跟进>月线雷打不动 AND 月线雷打不动>主线;ar2:=BARSLAST((C-主线)/主线*100<-6);ar3:=主线>=REF(主线,2);ar4:=COUNT(CROSS(C,主线),ar2)=1;ar5:=ar1 AND ar2 AND ar3 AND ar4;ar6:=ar5 ANDFILTER(ar5,10);DRAWTEXT(ar6,L-0.09,'← 超卖'),coloryellow;STICKLINE(ar6,H,L,0.5,1),coloryellow;STICKLINE(ar6,O,C,6,1),linethick2,coloryellow;br1:=COUNT(BETWEEN((C-REF(C,1))/REF(C,1)*100,0,5),5)=5;br2:=ABS((主线-月线雷打不动)+(月线雷打不动-超跌大胆跟进))/C<0.2;br3:=C>超跌大胆跟进 AND(REF(C,1)<REF(超跌大胆跟进,1) OR REF(C,2)<REF(超跌大胆跟进,2) ORREF(C,3)<REF(超跌大胆跟进,3) OR REF(C,4)<REF(超跌大胆跟进,4) ORREF(C,5)<REF(超跌大胆跟进,5));br4:=br1 AND br2 AND br3;DRAWTEXT(br4 ANDFILTER(br4,10),L-0.09,'蚂蚁上树'),color00C5FF;STICKLINE(br4 ANDFILTER(br4,10),H,L,0.5,1),color00C5FF;STICKLINE(br4 ANDFILTER(br4,10),O,C,6,1),linethick2,color00C5FF;cr1:=(C-REF(C,1))/REF(C,1)*100>0.5;cr2:=V>MA(V,5)*0.6;cr3:=COUNT(CROSS(主线,超跌大胆跟进),3)=1;cr4:=ABS(月线雷打不动-超跌大胆跟进)/超跌大胆跟进<0.03;cr5:=超跌大胆跟进<=年线参考不大AND 超跌大胆跟进>=REF(超跌大胆跟进,1);cr6:=FILTER(cr1 AND cr2 AND cr3 AND cr4 ANDcr5,2);STICKLINE(cr6,H,L,0.5,1),colorf00ff0;STICKLINE(cr6,O,C,6,1),linethick2,colorf00ff0;dr1:=主线>月线雷打不动 AND 月线雷打不动<超跌大胆跟进;dr2:=BARSLAST(CROSS(C,超跌大胆跟进));dr3:=H=HHV(H,dr2);dr4:=BARSLAST(dr3);dr5:=COUNT(O>C AND C<REF(C,1)AND C>超跌大胆跟进 AND BETWEEN((C-超跌大胆跟进)/超跌大胆跟进,0,0.02),dr4)=1;dr6:=C>REF(C,1);dr7:= dr1 AND dr5 AND dr6 ;dr8:=dr7 AND FILTER(dr7,10);STICKLINE(dr8,H,L,0.5,1),colord6ba63;STICKLINE(dr8,O,C,6,1),linethick2,colord6ba63;er:=BARSLAST(REF(CROSS(超跌大胆跟进,月线雷打不动),1))ANDCROSS(月线雷打不动,超跌大胆跟进);DRAWTEXT(er,L-0.09,'均线互换'),color0099ff;STICKLINE(er,H,L,0.5,1),color0099ff;STICKLINE(er,O,C,6,1),linethick2,color0099ff;fr:=BARSLAST(REF(CROSS(月线雷打不动,主线),1))ANDCROSS(主线,月线雷打不动);DRAWTEXT(fr,L-0.09,'梅开二度'),colorwhite;STICKLINE(fr,H,L,0.5,1),colorwhite;STICKLINE(fr,O,C,6,1),linethick2,colorwhite;gr1:=BARSLAST(BETWEEN("bias.bias2"(6,13,24),0,5));gr2:=主线>月线雷打不动 AND 月线雷打不动>超跌大胆跟进 AND主线>REF(主线,1);gr3:=COUNT("bias.bias2"(6,13,24)>10 ANDH=HHV(H,gr1),gr1);gr4:=H=HHV(H,gr1);gr5:="macd.macd"(12,26,9)<REF("macd.macd"(12,26,9),1);gr6:=gr2AND gr3 AND gr4;gr7:=gr2 AND gr3 AND gr4 AND gr5;DRAWTEXT(gr6 AND gr7,H+0.13,'← 超买'),color00ff00;STICKLINE(gr6 AND gr7,H,H+0.09,4,0),color00ff00;hr2:=主线>=REF(主线,3) AND 月线雷打不动>=REF(月线雷打不动,1) AND 超跌大胆跟进>=REF(超跌大胆跟进,1) AND CROSS(C,主线) ANDCROSS(C,月线雷打不动) AND CROSS(C,超跌大胆跟进);DRAWTEXT(hr2 AND FILTER(hr2,10),L-0.09,'三线推进'),colorFFC8FF;STICKLINE(hr2 AND FILTER(hr2,10),H,L,0.5,1),colorFFC8FF;STICKLINE(hr2 AND FILTER(hr2,10),O,C,6,1),linethick2,colorFFC8FF;

    浏览1453次浏览
    2022-10-28 17:23
  • 神奇指标

    这个未来主图很不错___组合主图 显示年月日时间

    以下是这个未来主图很不错___组合主图 显示年月日时间这个未来主图很不错 这个未来主图很不错,只是没有选股公式,哪位朋友帮下忙,把出现红色箭号的个股选出来,在此不胜感激!!!!!!!!!!!右上角还显示  显示年月日时间 NA:=STRCAT(CON2STR(YEAR,0),' 年 ');YA:=STRCAT(CON2STR(MONTH,0),' 月 ');RA:=STRCAT(CON2STR(DAY,0),' 日 ');SJ:=STRCAT(STRCAT(NA,YA), RA);DRAWTEXT_FIX(C>0,0.88,0,0,SJ);{箱体线}N:=7;T1:=CONST(LLVBARS(LOW,N));T1HIGH:=CONST(REF(HIGH,T1));CC:=CONST(CURRBARSCOUNT);T2:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T1)) AND (HIGH>T1HIGH)));T2HIGH:=CONST(REF(HIGH,T2));T3:=CONST(BARSLAST((CURRBARSCOUNT >(CC+T2)) AND (HIGH>T2HIGH)));T3HIGH:=CONST(REF(HIGH,T3));        突破杀入线:DRAWLINE(CURRBARSCOUNT=T3+1, T3HIGH, ISLASTBAR, T3HIGH, 1),LINETHICK1,COLORYELLOW;DRAWTEXT(ISLASTBAR, T3HIGH, '                   杀入线!'),LINETHICK1,COLORYELLOW;AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);BA:=EMA(AB,5);A1{高}:=REFDATE(REF(HHV(H,96),5),DATE);B1{低}:=REFDATE(REF(LLV(L,96),5),DATE);DY{中}:=((A1)+(B1))/2;箱顶:IF(AB>0 AND AB-BA<=0,A1,A1),COLORGREEN,DOTLINE;箱腰:IF(AB>0 AND AB-BA<=0,DY,DY),COLORYELLOW,DOTLINE;箱低:IF(AB>0 AND AB-BA<=0,B1,B1),COLORRED,DOTLINE; VARAA:=IF(CLOSE>150,91.3,0.913);突破:INTPART(CLOSE/VARAA )*VARAA,POINTDOT,LINETHICK4,COLORRED;再突破:突破+VARAA,POINTDOT,LINETHICK4,COLOR00FF00 ;回踩:(突破+再突破)/2,POINTDOT,COLORWHITE,LINETHICK4; STICKLINE(CROSS(ZIG(3,5),REF(ZIG(3,5),1)),箱低,箱腰,0.1,-1),COLORRED;STICKLINE(CROSS(REF(ZIG(3,5),1),ZIG(3,5)),箱顶,箱腰,0.1,-1),COLORGREEN;DRAWICON(CROSS(ZIG(3,5),REF(ZIG(3,5),1)),箱腰,1);DRAWICON(CROSS(REF(ZIG(3,5),1),ZIG(3,5)),箱腰,2); EE:=(H+L+O+2*C)/5;CRTP:=EE+(H-L);CRZL:=2*EE-L;CRZC:=2*EE-H;CRFZ:=EE-(H-L);高:CONST(CRTP),COLORRED;阻:CONST(CRZL),COLORC7C9FF;支:CONST(CRZC),COLOR7C9CFF;反:CONST(CRFZ),COLORDD00DD;DRAWTEXT(ISLASTBAR,      反, '    反转价'),LINETHICK1,COLORDD00DD;DRAWTEXT(ISLASTBAR,      支, '    支撑'),LINETHICK1,COLOR7C9CFF;DRAWTEXT(ISLASTBAR,      阻, '    阻力'),LINETHICK1,COLORC7C9FF;DRAWTEXT(ISLASTBAR,      高, '                高破线'),LINETHICK1,COLORGREEN; 均线:=EXPMA(C,12),COLORGRAY,LINETHICK2;日:=50;昨前:=3;  高2:=REF(HHV(H,日),昨前);  低2:=REF(LLV(L,日),昨前);  H4:=高2-(高2-低2)*0.618;  H5:=高2-(高2-低2)*0.809;  支撑80.9%:REFDATE(H5,DATE),COLORRED;  支撑61.8%:REFDATE(H4,DATE),COLORGREEN,; STICKLINE(CURRBARSCOUNT=1,支撑80.9%,支撑80.9%,300,-1),COLORGREEN;STICKLINE(CURRBARSCOUNT=1,支撑61.8%,支撑61.8%,300,-1),COLORRED; WH1:=IF(L=LLV(L,9),L,0);WH2:=CONST(BARSLAST(WH1!=0));WH3:=CONST(IF(WH2=0,H,REF(H,WH2)));WH4:=CONST(REF(BARSLAST(H>WH3),WH2+1)+WH2+1);WH5:=CONST(IF(WH4=0,H,REF(H,WH4)));WH6:=CONST(REF(BARSLAST(H>WH5),WH4+1)+WH4+1);WH7:IF(CURRBARSCOUNT<=WH2+10,CONST(IF(WH6=0,H,REF(H,WH6))),DRAWNULL),COLORRED,DOTLINE;STICKLINE(CURRBARSCOUNT<=WH2+1 AND L=LLV(L,9),O,C,3,0),COLORRED;DRAWTEXT(CURRBARSCOUNT=WH2+10,WH7,'LINE'),COLORRED;DRAWTEXT(ISLASTBAR,WH7,'          进场'),COLORRED;WH8:IF(CURRBARSCOUNT<=WH2+1,IF(L=LLV(L,9),L,DRAWNULL),DRAWNULL),CIRCLEDOT;H81:=IF(H=HHV(H,9),H,DRAWNULL);H82:=CONST(BARSLAST(H81!=DRAWNULL));H83:=CONST(IF(H82=0,L,REF(L,H82)));H84:=CONST(REF(BARSLAST(L<H83),H82+1)+H82+1);H85:=CONST(IF(H84=0,L,REF(L,H84)));H86:=CONST(REF(BARSLAST(L<H85),H84+1)+H84+1);H87:=IF(CURRBARSCOUNT<=H82+10,CONST(IF(H86=0,L,REF(L,H86))),DRAWNULL),DOTLINE;H88:=IF(CURRBARSCOUNT<=H82+1,IF(H=HHV(H,9),H,DRAWNULL),DRAWNULL),CIRCLEDOT;DRAWTEXT(CURRBARSCOUNT=H82+10,H87,'LINE'),COLORYELLOW;DRAWTEXT(ISLASTBAR,H87,'止损'),COLORYELLOW; DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);DEA:=EMA(DIF,9);AAA:=(DIF-DEA)*2*60;起爆:=CROSS(AAA-REF(AAA,1),15);DRAWTEXT(起爆,MA(L,3),'↖........ 暴涨'),COLORYELLOW,LINETHICK2; LC:=REF((O+H+L+2*C)/5,1); {绝密买点}A81:=EMA(C,3),COLORWHITE;A82:=EMA(C,5),COLORYELLOW;A83:=EMA(C,7),COLORMAGENTA;A84:=EMA(C,12),COLORGREEN;A85:=EMA(C,20),COLORRED;A86:=EMA(C,50),COLORBLUE,LINETHICK2;SS8:=CROSS(A81,A85)  AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018 ;SSS8:=CROSS(A81,A85)  AND C>O AND C>REF(C,1) AND C/REF(C,1)>=1.018;DRAWICON(SS8 ,MA(L,3),5);DRAWTEXT(SS8,MA(L,3),'↖绝密买点'),COLORYELLOW; ZYX1:="DMI.PDI"(12,6);ZYX2:="DMI.MDI"(12,6);ZYX3:=ZYX1>65 AND ZYX1>REF(ZYX1,1);ZYX4:=LLV(ZYX1,0);ZYX5:=BARSLAST(ZYX4=ZYX1);ZYX6:=(0-REF(ZYX2,4))/(ZYX4-REF(ZYX2,ZYX5))>2;ZYX7:=ZYX1>REF(ZYX1,1);ZYX8:=VOL>2*MA(VOL,30);ZYX9:="DMI.ADX"(12,6);ZYXA:="DMI.ADXR"(12,6);ZYXB:=CLOSE>MA(CLOSE,30) AND CLOSE<MA(CLOSE,30)*1.04;ZYXC:=MA(CLOSE,30)>REF(MA(CLOSE,30),1);ZYXD:=BARSLAST(CROSS(MA(CLOSE,5),MA(CLOSE,10)))<BARSLAST(CROSS(MA(CLOSE,10),MA(CLOSE,5)));{ZYXE:=0-"MACD.DIFF"(7,21,3);}ZYXF:=TROUGHBARS(3,15,1)<4;ZYX10:=EMA(CLOSE,30)>REF(EMA(CLOSE,30),2);ZYX11:=IF(ZYXF=1,50,0);ZYX12:=CROSS(ZYX2,ZYX1) AND CROSS(ZYXA,ZYX9);ZYX13:=CROSS(ZYX2,ZYX1) AND CROSS(ZYX9,ZYXA);ZYX14:=ZYXB AND ZYXC AND ZYXD AND ZYX10 AND ZYX6 AND ZYX7 AND ZYX8*50;ZYX15:=BARSLAST(CROSS(ZYX2,ZYX1)=1);ZYX16:=BARSLAST(CROSS(ZYX1,ZYX2)=1);ZYX17:=HHV(ZYX1,ZYX16);ZYX18:=BARSLAST(ZYX1=ZYX17);{STICKLINE(FILTER(ZYXF=1,5),50,0,10,0),COLORRED;}ZYX19:=ZYX3 OR ZYX12 OR ZYX13*100;ZYX1A:=ZYX13*100;DRAWICON(FILTER(ZYXF=1,3),MA(L,3),23);DRAWTEXT(FILTER(ZYXF=1,3),箱低,'■■铁底■■'),COLORGREEN; {量能平台}ND:=10;PTD:=CONST(LLVBARS(V,ND));TDPX:IF(CURRBARSCOUNT<=ND,CONST(IF(PTD=0,O,REF(O,PTD))),DRAWNULL),COLORFF0000;IF(CURRBARSCOUNT=PTD+1,TDPX,DRAWNULL),CIRCLEDOT,COLORFF0000,LINETHICK2;DRAWTEXT(ISLASTBAR,TDPX,'          【地平线】'),COLORFF0000;G21:=30;T112:=CONST(HHVBARS(V,G21));T122:=IF(CURRBARSCOUNT<=G21+7,CONST(IF(T112=0,H,REF(H,T112))),DRAWNULL);T122A:=IF(CURRBARSCOUNT=T112+1,T122,DRAWNULL),CIRCLEDOT,COLORWHITE;DRAWTEXT(ISLASTBAR,T122,'            30天量能平台'),COLORWHITE;W10:=10;TW1:=CONST(HHVBARS(V,W10));TW0:=IF(CURRBARSCOUNT<=W10+7,CONST(IF(TW1=0,C,REF(C,TW1))),DRAWNULL);TW0A:=IF(CURRBARSCOUNT=TW1+1,TW0,DRAWNULL),CIRCLEDOT,COLORWHITE;DRAWTEXT(ISLASTBAR,TW0,'            10量能平台'),COLORWHITE;W20:=20;TW20:=CONST(HHVBARS(V,W20));TW22:=IF(CURRBARSCOUNT<=W20+7,CONST(IF(TW20=0,C,REF(C,TW20))),DRAWNULL);TW22A:=IF(CURRBARSCOUNT=TW20+1,TW22,DRAWNULL),COLORWHITE;DRAWTEXT(ISLASTBAR,TW22,'           20量能平台'),COLORWHITE;MW:=10;MW1:=CONST(LLVBARS(V,MW));MW0:=IF(CURRBARSCOUNT<=MW+7,CONST(IF(MW1=0,O,REF(O,MW1))),DRAWNULL);MW0A:=IF(CURRBARSCOUNT=MW1+1,MW0,DRAWNULL),CIRCLEDOT,COLORWHITE;DRAWTEXT(ISLASTBAR,MW0,'              地量反弹量能平台'),COLORWHITE; {N1:=18;N2:=36;N3:=55;}EM1:=EMA(C,18),NODRAW;EM2:=EMA(C,36),COLORRED;EM3:=EMA(C,55),COLORGREEN;TJ8:=BETWEEN(EM2,EM1,EM3);{DRAWICON(TJ8=0,L,14);}B18:='<-----------------财富平台';DRAWTEXT(VOL=HHV(VOL,20),C ,B18),COLORRED; {超跌反弹}RSV:=(CLOSE-LLV(LOW,11))/(HHV(HIGH,11)-LLV(LOW,11))*100;短期底部:=LLV(OPEN,30);K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=(3*K-2*D),LINETHICK2;D2:=SMA(J,3,1)*0.82;VAR72:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;VAR73:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;VAR74:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;VAR75:=(VAR72+2*VAR73+3*VAR74)/6;DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA2:=EMA(DIFF,6);MACD超跌2:=(COUNT(DIFF<DEA2,19))=10;DRAWTEXT(CROSS(J,-3),MA(L,3),'↖.................. 超跌反弹'),COLORGREEN;{DRAWICON( FILTER(CROSS(J,D2),20),D2+0.02 ,1);}; {突破盘整}W1:=C=HHV(C,20);W2:=BARSLAST(W1);W3:=IF(W2>0,REF(C,W2),REF(C,W2));W4:=CROSS(C,REF(W3,1));突破盘整:=W4 AND COUNT(W4,5)=1;DRAWTEXT(突破盘整>0,MA(L,3),'↙....... 突破盘整'),COLORRED; C6:=REF(C,1);涨停:=IF((C-C6)*100/C6>=(10-0.01*100/C6),1,0);STICKLINE(涨停,OPEN,CLOSE,1,0),COLORYELLOW;STICKLINE(涨停,H,L,0,0),COLORYELLOW;DRAWTEXT(涨停,MA(H,3),'   ↙. .  ..涨停'),COLORYELLOW; RSI1:=SMA(MAX(CLOSE-LC,0),3,1)/SMA(ABS(CLOSE-LC),3,1)*100;SELL2:=(CROSS(88,RSI1));DRAWTEXT(SELL2,MA(H,3),'↙★出'),COLOR00FF00;VB1:=C-REF(C,1);VB2:=100*EMA(EMA(VB1,6),6)/EMA(EMA(ABS(VB1),6),6);VB3:=IF(LLV(VB2,2)=LLV(VB2,7) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);VB4:=FILTER(VB3=1,5);DRAWTEXT(VB4,MA(L,3),'↖★买'),COLOR00FFFF; {N 1 100 20  M 1 100 32 P1 1 100 80 P2 1 100 100}VARD1:=(C+H+O+L)/4;卖出:=XMA(VARD1,20)*(1+80/1000),COLORFFFFFF,LINETHICK3;买入:=XMA(VARD1,32)*(1-100/1000),COLOR0000FF,LINETHICK3;机会来临:=REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),COLORF00FF0,LINETHICK2;RSV2:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K2:=REF(MA(RSV2,3),1)+(RSV2-REF(MA(RSV2,3),1))/3;DD2:=REF(MA(K2,3),1)+(K2-REF(MA(K2,3),1))/3;J2:=3*K2-2*DD2;BB1:=EMA(J2,5);BB2:=REF(BB1,1);金叉:=CROSS(BB1,BB2);DRAWTEXT(CROSS(C,卖出),MA(H,3),'  ↙卖出'),COLOR00FFFF;DRAWTEXT(CROSS(C,买入) AND BB1>BB2 AND C>REF(O,2),MA(L,3),'↖买入'),COLOR0000FF;DRAWICON(CROSS(C,买入) AND  金叉 AND 机会来临 ,MA(L,3),13);DRAWTEXT(CROSS(C,买入) AND  金叉 AND 机会来临,MA(L,3),'↖【绝杀点】'),COLOR00FF00;{绝杀}F:=EMA(CLOSE,10)-EMA(CLOSE,21);A:=EMA(F,8);MD:=(F-A)*2;ZQ:=BARSLAST(CROSS(F,A) AND A<=0.05)+1;LZ:=BARSLASTCOUNT(MD<REF(MD,1))>1;HZ:=BARSLASTCOUNT(MD>REF(MD,1))>1;LZQ:=BARSLASTCOUNT(LZ);HZQ:=BARSLASTCOUNT(HZ);LZQTJ:=COUNT(LZQ,ZQ);HZQTJ:=COUNT(HZQ,ZQ);NQR:=REF(CLOSE,4);SRZF:=((CLOSE-NQR)/NQR)*100,NODRAW;绝杀黑马:=REF(LZQTJ,1)>=2 AND REF(HZQTJ,1)>=3 AND HZQTJ=0 AND LZQTJ=0 AND SRZF>2,LINETHICK2;DRAWTEXT(绝杀黑马,MA(L,3),'↖★绝杀黑马'),COLOR00FFFF;箱顶@:箱顶+箱顶*0.02,COLORBLACK;

    浏览7858次浏览
    2022-10-26 11:13
  • 神奇指标

    通达信决策主图 源码

    以下是通达信决策主图 源码通达信决策主图 源码源码DRAWGBK(OPEN>0,RGB(8,88,188),RGB(0,0,0),0,'02',0); VAR3:=LLV(HIGH,240); VAR4:=100*(CLOSE-VAR3)/VAR3; VAR5:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100; VAR6:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100; VAR7:=0; VAR8:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100; VAR9:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100; VAR10:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0); VAR11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3); VAR12:=ZIG(3,6)<REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3); VAR13:=ZIG(3,22)>REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3); VAR14:=ZIG(3,22)<REF(ZIG(3,22),1) AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2) AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3); VAR15:=ZIG(3,51)>REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3); VAR16:=ZIG(3,51)<REF(ZIG(3,51),1) AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3); VAR17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3); VAR18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2) AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3); VAR19:=EMA(CLOSE,2)-EMA(CLOSE,150);买1:=VAR10;买2:=(VAR11+VAR13+VAR15+VAR17);卖1:=(VAR12+VAR14+VAR16+VAR18); B:IF(买1>0 OR 买2>0,LOW*0.99,DRAWNULL),CROSSDOT,LINETHICK5,COLOR0800FF; DRAWTEXT(买1>0 OR 买2>0,LOW*0.98,'↖深筹'),COLORRED; S:IF(卖1>0,HIGH*1.03,DRAWNULL),CROSSDOT,LINETHICK5,COLOR008800; DRAWTEXT(卖1>0,HIGH*1.03,'↙卖出'),COLORGREEN; DRAWICON((ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)<=REF(ZIG(3,5),3)),LOW*0.97,34) ; DRAWICON((ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG(3,5),2)>=REF(ZIG(3,5),3)),HIGH*1.01,35); ZB:=EMA(EMA(VAR3,5),5)*3, COLORSTICK; VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0); K:=EMA(VAR7,5)*2, , COLORFF00FF; D:=EMA(K,5), , COLORWHITE; J:=K*3-D*2, ,COLORYELLOW; VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10; HS:=VOL/CAPITAL*100, , COLORGREEN; VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20; VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1); DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,LOW*0.96,'↖股海'),LINETHICK1,COLORFF00FF; VAR1A:=IF(VARE>0,VARE,0); VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60; VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100; DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,LOW*0.95,'关注') COLORWHITE; N:=IF(BARSCOUNT(C)>=8,8,BARSCOUNT(C)); AMOV:=VOL*(C+L+H)/3; MN:=SUM(AMOV,N)/SUM(VOL,N); NOTEXT1:IF(C>=MN,MN,DRAWNULL),LINETHICK3,COLORRED; NOTEXT2:IF(C<MN,MN,DRAWNULL),LINETHICK3,COLORGREEN; DRAWBAND(MA(CLOSE,3),RGB(188,0,43),MA(CLOSE,24),RGB(0,72,46)); QQ2:=(CLOSE-LLV(LOW, 18))/(HHV(HIGH, 18)-LLV(LOW, 18))*100; QQ3:=SMA(QQ2, 9, 1); QQ4:=SMA(QQ3, 3, 1); 长趋势:=3*QQ3-2*QQ4,COLORWHITE,LINETHICK3; 趋势线:=EMA(QQ3, 3),COLORRED,LINETHICK3; 金叉:= CROSS(长趋势,趋势线);AAAA1:=AMOUNT/V; BBB1:=L<AAAA1*0.9; CCC1:=(C-REF(C,1))/REF(C,1)*100>1.2; DDD1:=L<MA(C,5)*0.921; EEE1:=V<MA(V,5)*1.5;老鼠仓:=BBB1 AND CCC1 AND DDD1 AND EEE1,,NODRAW; DRAWICON(老鼠仓 OR 金叉,(LOW - (LOW * 0.01)),9); AA05:=MA(C,5),COLOR0099CC; BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;速度5:=SMA(EMA((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW; AA10:=MA(C,10); AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416; AA30:=MA(C,30);三拾日乖离率:=(C-AA30)/AA30*100;加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ; DRAWICON(加仓,L*0.99,23); DRAWKLINE(H,O,L,C); TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01; DRAWTEXT(TJ,L,'↖亮箭'),COLORYELLOW; STICKLINE(TJ,OPEN,CLOSE,1.5,0),COLORYELLOW; K1:=SUMBARS(TJ,1); STICKLINE(K1,REF(C,K1-1),REF(C,K1-1),10,0),COLORYELLOW; MA30:=MA(C,30);支撑价:MA(REF(LLV(C,30),1),2),DOTLINE,COLORFF00FF; DRAWTEXT(ISLASTBAR,支撑价,'↖支撑'),COLORFF00FF;现价:CLOSE,COLORWHITE,LINETHICK1;压力价:MA(REF(HHV(C,30),1),2),DOTLINE,COLORGREEN; DRAWTEXT(ISLASTBAR,压力价,'↖压力'),COLORGREEN;短线交易:MA(REF(LLV(C,3),1),2),DOTLINE,COLORRED; DRAWTEXT(ISLASTBAR,短线交易,'↖交易'),COLORRED; B1:=REF(CLOSE,1); B2:=REF(CLOSE,2); B3:=REF(CLOSE,3); B4:=REF(CLOSE,4); CMAX:=MAX(MAX(MAX(CLOSE,B1),B2),B3); CMIN:=MIN(MIN(MIN(CLOSE,B1),B2),B3); 持股:=(CLOSE=CMAX AND (B1>=B2 OR B1>=B3)) OR ((B1=CMAX AND (B2=CMIN OR B3=CMIN)) AND CLOSE>=B2) OR (B2=CMAX AND B3=CMIN AND CLOSE>=B1) OR (B3=CMAX AND CLOSE>=B1 AND CLOSE>=B2);变盘:=CLOSE=CMAX AND B1=CMIN; STICKLINE(变盘,B2,CLOSE,2,0),COLORFF88FF;下跌:=(CLOSE=CMIN AND (B1<B2 OR B1<B3)) OR ((B1=CMIN AND (B2=CMAX OR B3=CMAX)) AND CLOSE<B2) OR (B2=CMIN AND B3=CMAX AND CLOSE<B1) OR (B3=CMIN AND CLOSE<B1 AND CLOSE<B2);买入:=(B1=CMIN AND CLOSE>=B2) OR ((B2=CMIN AND B1<=B3) OR (B3=CMIN AND B1<=B2) AND B2<B4 AND CLOSE>=B1); STICKLINE(买入,B1,B2,3.0,0),COLOR000033; STICKLINE(买入,B1,B2,2.5,0),COLOR000055; STICKLINE(买入,B1,B2,2.0,0),COLOR000077; STICKLINE(买入,B1,B2,1.5,0),COLOR0000BB; STICKLINE(买入,B1,B2,1.0,0),COLOR0000DD; STICKLINE(买入,B1,B2,0.5,0),COLORCC66FF; DRAWTEXT(HIGH>=REF(CLOSE,1)*1.095,H*1.02,'←涨停'),COLORMAGENTA; STICKLINE(V/REF(V,1)>2,OPEN,CLOSE,1,0),COLOR00FFFF; DRAWTEXT(REF(CLOSE,1)>=LOW*1.095,LOW,'←跌停'),COLORGREEN; DRAWTEXT_FIX(1,0,0,0,'【KS】㊣千股千评:'),COLORYELLOW; DRAWTEXT_FIX(C>0,0.12,0,0,EXTERNSTR(0,1)),COLORRED,LINETHICK2; DRAWTEXT_FIX(1,0,0.05,0,'【总股本(万股)】'),COLORWHITE; DRAWNUMBER_FIX(1,0.12,0.05,0,CONST(FINANCE(1)/10000)),COLORMAGENTA; DRAWTEXT_FIX(1,0,0.1,0,'【所属板块】'),COLORWHITE; DRAWTEXT_FIX(1,0.12,0.1,0,HYBLOCK),COLORYELLOW; DRAWTEXT_FIX(1,0.21,0.1,0,DYBLOCK),COLOR0080FF; DRAWTEXT_FIX(1,0,0.25,0,'【莸利比例】'),COLORWHITE; DRAWNUMBER_FIX(1,0.12,0.25,0,CONST(WINNER(C )*100)),COLORYELLOW; DRAWTEXT_FIX(1,0,0.30,0,'【每股收益(元)】'),COLORWHITE; DRAWNUMBER_FIX(1,0.12,0.30,0,CONST(FINANCE(33))),COLORYELLOW; DRAWTEXT_FIX(1,0,0.2,0,'【市盈率】'),COLORWHITE; DRAWNUMBER_FIX(1,0.12,0.20,0,CONST(DYNAINFO(39))),COLORYELLOW; SAT:=IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100); DRAWTEXT_FIX(1,0,0.15,0,'【量能饱和度】')COLORWHITE; DRAWNUMBER_FIX(1,0.12,0.15,0,CONST(SAT)),COLORYELLOW;

    浏览7944次浏览
    2022-10-25 15:41
  • 神奇指标

    通达信精品看盘主图 卖点信号 买入信号 主力成本 短期支撑

    以下是通达信精品看盘主图 卖点信号 买入信号 主力成本 短期支撑通达信精品看盘主图 卖点信号 买入信号 主力成本 短期支撑源码{移动平均线}EMA13:EMA(C,5),COLORWHITE; {13-21-34-60} EMA21:EMA(C,13),COLORYELLOW; EMA34:EMA(C,21),COLORFF00FF; EMA60:MA(C,60),COLORFFCC66; {大阴线:大跌超2.3} C2:=REF(C,1); BG:=IF((C2-C)*100/C2>=2.3,1,0) OR IF((O-C)*100/O>=5,1,0){ OR IF((H-L)*100/REF(C,1)>5,1,0)};{第二个条件开盘价过高掉下来}BG2:=IF((H-L)*100/C2>=3.58,1,0); BB1:=L<REF(L,1); {卖点信号}SELL1:=BG AND BB1 ; {大阳线:升幅超2.64} BR:=IF((C-C2)*100/C2>=2.59,1,0) OR IF((C-O)*100/O>=4.5,1,0) OR IF((C-L)*100/L>5,1,0);{第二个条件开盘价太低升上来}STICKLINE(BR,O,C,3,0),COLORRED; {以下条件记住最近一次卖出点}DAY1:=BARSLAST(SELL1); JIA1:=REF(O,DAY1); JIA2:=REF(O,1); BB4:=C>JIA2; BB2:=H>JIA1; {买入信号}BUY1:=BR AND BB2 AND BB4; {记住最后一次买点}DAY2:=BARSLAST(BUY1); {买卖谁先}S1:=DAY1<DAY2; B1:=DAY2<DAY1; {画出卖出信号} {DRAWTEXT(S1,H*1.05,'S'),COLORGREEN;} STICKLINE(S1,O,C,3,0),COLORGREEN; {画出买入信号} {DRAWTEXT(B1,L-0.2,'B'),COLORRED;} STICKLINE(B1,H,L,0.3,0),COLORRED; STICKLINE(B1,O,C,3,1),LINETHICK2,COLORRED; {其它补充1:买点}AA2:=AMOUNT/VOL; BB3:=L<AA2*0.9; CC2:=(C-REF(C,1))/REF(C,1)*100>1.2; DD2:=L<MA(C,6)*0.921; DD1:=L<MA(C,5)*0.921; EE2:=VOL<MA(V,5)*1.5; FF2:=BB3 AND CC2 AND DD2 AND EE2;老鼠仓:=BB3 AND CC2 AND DD1 AND EE2,LINETHICK0,COLOR0099FF; DRAWTEXT(老鼠仓,L*0.97,'老鼠仓'),COLOR0099FF; {DRAWTEXT(FF2,L*0.99,'买点'),COLOR00FFFF;} STICKLINE(FF2,H,L,0.3,0),COLOR00FFFF; {STICKLINE(FF2,O,C,3,1),LINETHICK2,COLOR00FFFF;} {检查买点是否成立}B4:=BARSLAST(FF2);{底点日期}E4:=B4<5;{5日内的线}F4:=E4 AND C>REF(C,1); STICKLINE(F4,H,L,0.3,0),COLOR00FFFF; {其它补充2:卖点}A2:=(C-REF(C,1))/REF(C,1)*100<1.02; A3:=H>MA(C,5)*1.12; AA:= A2 AND A3; DRAWTEXT(AA,H*1.05,'卖点'),COLORFF0000; STICKLINE(AA,H,L,0.3,0),COLORFF0000; {STICKLINE(AA,H,L,3,0),COLORFF0000;}; {补充阳光买点}VAR1:=4*SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1)- 3*SMA(SMA((CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,5,1),3.2,1); VAR2:=8; CC:=CROSS(VAR1,VAR2); CCC:=CROSS(VAR1,VAR2) AND H>REF(H,1) AND C>REF(C,1) ; DRAWICON(CCC,L*0.99,1); STICKLINE(CC,H,L,0.3,0),COLORRED; STICKLINE(CC,O,C,3,1),LINETHICK2,COLORRED; {加强买点后续升势}CF1:=BARSLAST(CC);{买点日期}CF2:=CF1<3;{5日内的线}CF3:=CF2 AND C>REF(C,1); STICKLINE(CF3,O,C,3,0),COLOR00FFFF;CD:=CROSS(VAR2,VAR1); STICKLINE(CD,H,L,0.3,0),COLORYELLOW; STICKLINE(CD,O,C,3,1),LINETHICK2,COLORYELLOW; DRAWTEXT(CD,H*1.01,'准备'),COLORYELLOW; DRAWTEXT(CC,L*0.98,'买'),COLORFF00FF;{输出粉红色的买字}; {牛窝}VAR1A:=LLV(LOW,21); VAR2A:=HHV(HIGH,21); AK1:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 100),5); AK:=EMA((((CLOSE - VAR1A) / (VAR2A - VAR1A)) * 50),13); AB:=CROSS(AK1,AK); DRAWTEXT((AB = 1),(LOW * 0.95),'○牛窝'),COLORYELLOW; {主力成本及短期支撑}A:=(3*C+L+O+H)/6; X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+ 14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12) +7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+ REF(A,20))/210; S2:=SMA(C,3,1); S6:=SMA(C,5,1); DK:=2*(S2-S6);主力成本:EMA(X,13),LINETHICK1,COLORLIGRAY;短期支撑:LLV(HIGH,30),LINETHICK2,COLORFFCC00; {大胆博、加仓、小心变盘、逃顶}VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0); VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0); DRAWTEXT(FILTER((VAR4AA>90),45),(LOW)*(0.93),'★大胆搏 '),COLOR00FFFF; DRAWTEXT(FILTER((VAR4AA>90),35),(LOW)*(0.99000001),'★加仓'),COLOR00FFFF; A1AA:=9; A2AA:=(REF(CLOSE,A1AA+1)<CLOSE); DRAWTEXT(FILTER((A2AA>-0.5),84),(HIGH)*(1.05),'小心变盘'),COLORFFFFFF; VAR6:=REF(C,1); VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100; DRAWTEXT(CROSS(82,VAR7),H*1.02,'逃顶'),COLORYELLOW; VAR9:=((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100); VAR10:=SMA(VAR9,3,1); VAR11:=SMA(VAR10,3,1); VAR12:=SMA(VAR11,3,1);主力出现:DRAWICON(CROSS(VAR11,VAR12) AND (VAR11<40),L*0.98,1); {股票}A1A:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1),COLOR330066; A5A:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1; DRAWTEXT(CROSS(A1A,EMA(A1A,5))AND EMA(A1A,5)<A5A,L*0.98,'股票'),COLORYELLOW; {波段上行和买入};多:EMA(C,3),COLORYELLOW;空:EMA(C,5),COLOR00FF00;均衡:EMA(空,5),COLORWHITE,; VVARF1:=COUNT(CROSS(多,均衡),2)=1; VVARF2:=COUNT(CROSS(空,均衡),2)=1; ZAI:=FILTER(VVARF1 AND VVARF2,2); DRAWTEXT(ZAI,均衡*0.985,' ▲'),COLORRED; VV2:=REF(CLOSE,1); VV3:=SMA((CLOSE-VV2),6,1)/SMA(ABS(CLOSE-VV2),6,1)*100; DRAWICON(REF(VV3,1)>81 AND VV3<80,HIGH,2); VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2; DRAWTEXT(IF(CLOSE<VF1 AND VOL/240>MA(VOL,5)/240 AND CLOSE>=REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'☆'),COLORRED; VVARA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100; VVARB:=EMA(0.667*REF(VVARA,1)+0.333*VVARA,5); DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VVARA>=VVARB AND VVARA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入');VVARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100; DRAWICON(CROSS(82,VVARR1),HIGH,2); DRAWTEXT(CROSS(82,VVARR1),HIGH,''),COLORYELLOW; VVAR1:=(HIGH+LOW+OPEN+2*CLOSE)/5; VVAR2:=REF(VVAR1,1); VVAR3:=SMA(MAX(VVAR1-VVAR2,0),10,1)/SMA(ABS(VVAR1-VVAR2),10,1)*100; HY3:=IF(COUNT(VVAR3<20,5)>=1 AND COUNT(VVAR1=LLV(VVAR1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0); DRAWTEXT(HY3,LOW,' 注意买入'),COLORRED;

    浏览8637次浏览
    2022-10-25 11:27
  • 神奇指标

    主K3 把握趋势 牛熊通用(主图 源码 趋势线 牛熊分界线 能量线)

    以下是主K3 把握趋势 牛熊通用(主图 源码 趋势线 牛熊分界线 能量线)MMS:=MA(SMA((L+H+2*C)/4-REF((L+H+2*C)/4,1),5,1)/SMA(ABS((L+H+2*C)/4-REF((L+H+2*C)/4,1)),5,1)*100,1)+50; G1:=IF(-MMS>95,0,20); UOO:=(-(((CLOSE-LLV(CLOSE,7))/(HHV(CLOSE,7)-LLV(CLOSE,7))*100=100)>0 AND G1)+1); KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100)); KS1:=IF(BARSCOUNT(C)=1,C/10000,(1-C/SMA(C,13,1))*100);趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3); AA:=-100*(趋势线-CLOSE)/趋势线;AC:=(EMA(AA,5) ); SSL:=EMA(CLOSE,3); MMV:=EMA(((SLOPE(CLOSE,22) * 20) + CLOSE),55); MM:=MA(MMV,1); {STICKLINE(((SSL>MM)),SSL,MM,0.01,0),COLORRED;} SA:=(MM*0.985); SS:=(MA(CLOSE,5)); DD:=(MA(CLOSE,13)); GG:=(MA(CLOSE,21));牛熊分界线:IF(((SSL>MM)),MM,SA),LINETHICK2,COLORFF00FF; IF(SSL<MM,牛熊分界线,DRAWNULL),LINETHICK2,COLORGREEN;能量线:=DMA(((CLOSE + OPEN) / 2),(VOL / (SMA(VOL,4,1) *4)));上开:=O;上收:=C;上高:=H;上低:=L; JJ:=(上开+上高+上低)/3; A:=EMA(JJ,4);黄金线:=A,COLORYELLOW,LINETHICK1; B:=REF(A,1); VA1:=EMA(上收,8); VA2:=EMA(上收,20); DRAWTEXT(CROSS(ZIG(3,8),REF(ZIG(3,8),1)),LOW*0.98,'★抄底有未来,牛市准') ,LINETHICK2,COLORRED; DRAWTEXT(CROSS(REF(ZIG(3,10),1),ZIG(3,10)),HIGH*1.03,'★卖有未来,熊市卖准,高卖低补!'),COLORGREEN; DRAWTEXT(CROSS(VA1,VA2)AND(C>=O)AND 黄金线>REF(黄金线,1),VA1*0.985,'★追涨'),COLORYELLOW;选手A:=MA(上收,3);孤烟A:=MA(REF(HHV(上收,6),1),3);孤泉A:=MA(REF(LLV(上收,3),1),3); T1:=MA(上收,20)>=REF(MA(上收,20),1); T2:=CROSS(选手A,孤泉A) AND 孤烟A/孤泉A>100/100 AND T1; T3:=CROSS(孤烟A,选手A) AND 孤烟A/孤泉A>100/100;选手:=MA(上收,2);压力:MA(REF(HHV(上收,30),1),2),COLORABFF46,LINETHICK2;支撑:MA(REF(LLV(上收,30),1),2),COLORMAGENTA,LINETHICK1; T4:=CROSS(选手,支撑) AND 压力/支撑>110/100; T5:=CROSS(支撑,选手) AND 压力/支撑>110/100; VAR1:=(上收-LLV(上低,27))/(HHV(上高,27)-LLV(上低,27))*100; VAR2:=SMA(VAR1,3,1); VAR3:=SMA(VAR2,3,1); VAR4:=SMA(VAR3,3,1); {所以压力线是前期一个月甚至半年的最大阻力位。如果主力突然有一天突破了半年甚至以上的阻力位了,这就说明主力解放了前面很多被套投资者。这时个股前面还有一定涨幅!};阳涨幅:=5;{可自调4-10}阳倍量:=1.90;{王子倍量倍数}单阳:=C>O*(1+阳涨幅/100) AND VOL>REF(VOL,1)*阳倍量;LS0:=BARSLAST(单阳);不破价:=REF(L,LS0); DRAWTEXT(单阳,L,'阳'),COLOR00FFFF; {老鼠仓}AA1:=AMOUNT/V; BB1:=L<AA1*0.9; CC1:=(C-REF(C,1))/REF(C,1)*100>1.2; DD1:=L<MA(C,5)*0.921; EE1:=V<MA(V,5)*1.5; FF1:=BB1 AND CC1 AND DD1 AND EE1; DRAWTEXT(FF1,LOW*0.96,'老鼠仓'),COLOR4080FF; {预测明天}XXS:=MA(LOW,5)*(1-5/100); XXS1:=MA(HIGH,5)*(1+5/100);均线:=C,COLORGREEN; AAAA:=CLOSE/REF(CLOSE,3)<=0.85 AND CROSS(C,XXS) AND C>REF(C,1),LINETHICK1 ; DRAWTEXT(AAAA,LOW*0.95,'下影买'),COLORRED; BBAA:=CROSS(XXS1,C); DRAWTEXT(CROSS(XXS1,C),HIGH*1.04,'开盘逃'),COLORGREEN; DDDD:=CROSS(C,XXS1); DRAWTEXT(DDDD,HIGH*1.03,'明日走'),COLORYELLOW; {加仓一出,当日就会出高点,在高点不能加仓,要当日逢高全出,所以把加仓改成了慎追涨,安全第一!}MA5:MA(CLOSE,5); MA10:=MA(CLOSE,10); MA30:MA(CLOSE,30),LINETHICK1;五日乖离率:=(C-MA5)/MA5*100; BB05:=ATAN((MA5/REF(MA5,1)-1)*100)*180/3.1416;速度5:=SMA(EMA((MA5-REF(MA5,1))/REF(MA5,1),3)*100,3,1);加速度5:=EMA((速度5-REF(速度5,1)),3),NODRAW; SSR:=(C-MA30)/MA30*100,NODRAW;加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND MA5>REF(MA5,1) AND SSR>REF(SSR,1) AND MA10>REF(MA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ; DRAWTEXT(加仓 ,LOW*0.96,'◆慎追涨'),COLORYELLOW; {彩色攻击线}攻击线:MA(C,5),LINETHICK2,COLOR00CCFF; MA05:=MA(C,5); IF(BB05>30 AND MA05>REF(MA05,1), MA05,DRAWNULL),LINETHICK2,COLORRED; BB10:=ATAN((MA10/REF(MA10,1)-1)*100)*180/3.1416; IF(BB05<0 AND MA05<REF(MA05,1), MA05,DRAWNULL),LINETHICK2,COLORGREEN; {精准买卖点主图}MA18:=MA(CLOSE,18); MTM:=C-REF(C,1); DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);买:=LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)); DRAWTEXT(FILTER(买=1,5),LOW,'★精准买'),COLORRED;加1:=MA18>=REF(MA18,3) AND CROSS(CLOSE,MA18); DRAWTEXT(加1,LOW,'★精准加'),COLORCC66FF;卖一:=HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX); DRAWTEXT(FILTER(卖一=1,1),HIGH*1.01,'★精准卖'),COLORGREEN; {板块市值业绩}所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT(' [行业]—',HYBLOCK),STRCAT(' [地域]—',DYBLOCK)),STRCAT(' [概念]—',GNBLOCK)));总股本:=STRCAT(STRCAT(' 总股本:',CON2STR(TOTALCAPITAL/1000000,2)),'亿');流通盘:=STRCAT(STRCAT(' 流通盘:',CON2STR(CAPITAL/1000000,2)),'亿');全流通:=STRCAT(STRCAT(' 全流通:',CON2STR(CAPITAL/TOTALCAPITAL*100,2)),'%');市值:=STRCAT(STRCAT(' 流通市值:',CON2STR((CAPITAL/1000000)*C,2)),'亿');上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));股本市值:=STRCAT('【股本市值】',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市日期));市盈率:=STRCAT(' 市盈率:',CON2STR(C/FINANCE(33),2));市销率:=STRCAT(' 市销率:',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));市净率:=STRCAT(' 市净率:',CON2STR(C/FINANCE(34),2));净资收益率:=STRCAT(' 净资收益率:',CON2STR(FINANCE(33)/FINANCE(34)*100,2));毛利率:=STRCAT(' 毛利率:',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));净利润率:=STRCAT(' 净利率:',CON2STR(FINANCE(30)/FINANCE(20)*100,2));主营利润率:=STRCAT(' 主营利润率:',CON2STR(FINANCE(23)/FINANCE(20)*100,2));当前业绩:=STRCAT('【当前业绩】',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));DRAWTEXT_FIX(ISLASTBAR,0.005,0.02,0,所属板块),COLORMAGENTA; DRAWTEXT_FIX(ISLASTBAR,0.005,0.07,0,股本市值),COLORMAGENTA; DRAWTEXT_FIX(ISLASTBAR,0.005,0.12,0,当前业绩),COLORMAGENTA;{未来函数 平台突破}TD:=BARSLAST(H<REF(L,1)); TDJ:=HHV(H,TD+1); TDJ1:=CROSS(C,REF(L,TD+1)); TDJ2:=TDJ<REF(L,TD+1);突破幅度:=(C/REF(L,TD+1)-1)*100;突破量:=VOL/REF(VOL,1); ZF:=(REF(L,TD+1)-LLV(L,TD+1))/LLV(L,TD+1)*100; XG:=REF(TDJ2,1) AND TDJ1 AND 突破量>2 AND ZF<10 AND 突破幅度>3; QF:=BACKSET(XG=1,TD+2); QFTD:=BARSLAST(CROSS(QF=1,0.5)); DRAWLINE(QFTD=0,L,XG,REF(L,QFTD),0),COLORYELLOW; STICKLINE(XG=1,C,O,2,0),COLORLIRED; STICKLINE(XG=1,H,L,0,0),COLORLIRED; DRAWICON(XG=1,L*0.95,38);

    浏览9505次浏览
    2022-10-24 13:39
  • 神奇指标

    通达信短线狙击(主图 指标)

    以下是通达信短线狙击(主图 指标)JRH:=HHV(C,2); JRL:=LLV(C,2); MA3:=MA(CLOSE,3); YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6; VAR1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2)); VAR2:=(REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR3:=(REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR4:=(REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR5:=(REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR6:=(REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR7:=(REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR8:=(REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR9:=(REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARA:=(REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR10:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR11:=(REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR12:=(REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR13:=(REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR14:=(REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR15:=(REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR16:=(REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR17:=(REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2)); VAR18:=(REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2)); VAR19:=((REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1)) AND VAR1); VAR1A:=((REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1)) AND VARD); 红色持股:VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW; 离场:=IF(红色持股,JRL,DRAWNULL); 明离场价:=离场,COLORFF99FF,NODRAW; 今离场价:REF(离场,1)COLOR0000FF,NODRAW; 青色观望:VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,COLORFFFF00,NODRAW; 进:=IF(青色观望,JRH,DRAWNULL); 明进场价:=进,COLOR33AACC,NODRAW; 今进场价:REF(明进场价,1),COLORFF0000,NODRAW; 短买:VAR19,COLOR33AACC,NODRAW;品红离场:VAR1A,COLORFF99FF,NODRAW; 急速超跌:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100<-14,COLORFFFFFF,NODRAW; 上市日期年:REF(YEAR,BARSCOUNT(CLOSE)-1),NODRAW,COLOR0000FF; 月:REF(MONTH,BARSCOUNT(CLOSE)-1),NODRAW,COLORFF00FF; 日:REF(DAY,BARSCOUNT(CLOSE)-1),NODRAW,COLOR00FFFF; 辰星线:(20*YTSL+19*REF(YTSL,1)+18*REF(YTSL,2)+17*REF(YTSL,3)+16*REF(YTSL,4)+15*REF(YTSL,5)+14*REF(YTSL,6)+13*REF(YTSL,7)+12*REF(YTSL,8)+11*REF(YTSL,9)+10*REF(YTSL,10)+9*REF(YTSL,11)+8*REF(YTSL,12)+7*REF(YTSL,13)+6*REF(YTSL,14)+5*REF(YTSL,15)+4*REF(YTSL,16)+3*REF(YTSL,17)+2*REF(YTSL,18)+REF(YTSL,20))/211,COLOR0000FF; 牵牛线:MA(CLOSE,26),COLORFF00FF; 等待:=IF(MA3>辰星线,辰星线,MA3); IF(等待>REF(等待,1),等待,DRAWNULL),LINETHICK2,COLOR00FFFF; IF(辰星线>REF(辰星线,1),辰星线,DRAWNULL),LINETHICK2,COLOR0000FF; IF(辰星线<REF(辰星线,1),辰星线,DRAWNULL),COLOR00FF00; IF(牵牛线>REF(牵牛线,1),牵牛线,DRAWNULL),LINETHICK1,COLORFF00FF; IF(牵牛线<REF(牵牛线,1),牵牛线,DRAWNULL),COLOR669933; STICKLINE(ISLASTBAR AND (红色持股 OR REF(红色持股,1)=1),今离场价,今离场价,30,1),COLOR0000FF; STICKLINE(ISLASTBAR AND (青色观望 OR REF(青色观望,1)=1),今进场价,今进场价,30,1),COLOR00FF00; STICKLINE(C>=O,L,H,0,0),COLOR0000CC; STICKLINE(C<O,L,H,0,0),COLOR999900; STICKLINE(1,C,O,3.5,0),COLOR858500; STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5; STICKLINE(红色持股,CLOSE,O,2.8,0),COLOR000055; STICKLINE(红色持股,CLOSE,O,2,0),COLOR000088; STICKLINE(红色持股,CLOSE,O,1.5,0),COLOR0000AA; STICKLINE(红色持股,CLOSE,O,1,0),COLOR0000CC; STICKLINE(红色持股,CLOSE,O,0.5,0),COLOR0000EE; STICKLINE(青色观望,CLOSE,O,2.8,0),COLOR555500; STICKLINE(青色观望,CLOSE,O,2,0),COLOR888800; STICKLINE(青色观望,CLOSE,O,1.5,0),COLORAAAA00; STICKLINE(青色观望,CLOSE,O,1,0),COLORCCCC00; STICKLINE(青色观望,CLOSE,O,0.5,0),COLOREEEE00; CO:=(C-O); STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555; STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888; STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA; STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC; STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE; STICKLINE(短买,O,O+CO/3,2.8,0),COLOR335555; STICKLINE(短买,O,O+CO/3,2,0),COLOR338888; STICKLINE(短买,O,O+CO/3,1.5,0),COLOR33AAAA; STICKLINE(短买,O,O+CO/3,1,0),COLOR33CCCC; STICKLINE(短买,O,O+CO/3,0,0),COLOR33EEEE; DRAWTEXT(短买,REF(CLOSE,1),'←低吸'),COLOR33FFCC; STICKLINE(品红离场,O,O+CO/3,2.8,0),COLOR550055; STICKLINE(品红离场,O,O+CO/3,2,0),COLOR880088; STICKLINE(品红离场,O,O+CO/3,1.5,0),COLORAA00AA; STICKLINE(品红离场,O,O+CO/3,1,0),COLORCC00CC; STICKLINE(品红离场,O,O+CO/3,0.5,0),COLOREE00EE; DRAWTEXT(品红离场,REF(CLOSE,1)+0.1,'←高抛'),COLORFF99FF;

    浏览2377次浏览
    2022-10-24 13:24
  • 神奇指标

    无敌轨道主图 抄底幅图公式 一并奉上!

    以下是无敌轨道主图 抄底幅图公式 一并奉上!无敌轨道主图 抄底幅图公式 一并奉上!无敌轨道主图源码上轨:MA(HIGH,30);下轨:MA(LOW,30);日上轨:"引用MA.MA_H#DAY"(30);日下轨:"引用MA.MA_L#DAY"(30);S:=CROSS(CLOSE,日上轨);X:=CROSS(日下轨,CLOSE);WS:=BARSLAST(S)+1;WX:=BARSLAST(X)+1;SS:=CROSS(SUM(S,WX),0.5);XX:=CROSS(SUM(X,WS),0.5);DRAWICON(SS,LOW-0.1,1);DRAWTEXT(SS,LOW-0.2,'买入'),COLORRED;DRAWICON(XX,HIGH+0.1,2);DRAWTEXT(XX,HIGH+0.2,'卖出'),COLORGREEN;周上轨:"引用MA.MA_H#WEEK"(30);周下轨:"引用MA.MA_L#WEEK"(30);STICKLINE(CLOSE>日上轨,日上轨,日下轨,2,1),COLORGRAY;STICKLINE(CLOSE<日下轨,日下轨,日上轨,2,1),COLORFF0000;STICKLINE(CLOSE>周上轨,周上轨,周下轨,2,1),COLORGRAY;STICKLINE(CLOSE<周下轨,周下轨,周上轨,2,1),COLORFF0000;IF(CLOSE>上轨,上轨,DRAWNULL),COLORRED;IF(CLOSE<上轨,上轨,DRAWNULL),COLORGREEN;IF(CLOSE<下轨,下轨,DRAWNULL),COLORGREEN;IF(CLOSE>日上轨,日上轨,DRAWNULL),COLORRED;IF(CLOSE<日上轨,日上轨,DRAWNULL),COLORGREEN;IF(CLOSE>日下轨,日下轨,DRAWNULL),COLORRED;IF(CLOSE<日下轨,日下轨,DRAWNULL),COLORGREEN;IF(CLOSE>周上轨,周上轨,DRAWNULL),COLORRED;IF(CLOSE<周上轨,周上轨,DRAWNULL),COLORGREEN;IF(CLOSE>周下轨,周下轨,DRAWNULL),COLORRED;IF(CLOSE<周下轨,周下轨,DRAWNULL),COLORGREEN;STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,3,0),COLORFF5B00;STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.8,0),COLORFF6C00;STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.5,0),COLORFF7B00;STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2.2,0),COLORFF9C00;STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,2,0),COLORFFBE00;STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1.5,0),COLORFFCC00;STICKLINE(OPEN>=CLOSE,CLOSE,OPEN,1,0),COLORFFFF00;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3,0),COLORRED;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,2.5,0),COLORRED;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,2.2,0),COLORRED;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1.8,0),COLORRED;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1.5,0),COLORRED;STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1,0),COLORRED;MA20:=MA(C,20),COLORWHITE,LINETHICK2;MA120:=MA(C,120),COLORFFCCCC,LINETHICK2;MA250:=MA(C,250),COLORFFCC66,LINETHICK2;乖离线:=((C-REF(MA20,1))/20+MA20)*1.20;TT1:=CROSS(MA20,MA120)  AND CROSS(MA20,MA250) AND V>REF(V,1);TT2:=MA20>REF(MA20,2) AND V>REF(V,1) AND CROSS(C,MA20);STICKLINE(TT1,L,L-0.09,4,0),COLORYELLOW;DRAWTEXT(TT1,L-0.13,'金叉'),COLORYELLOW;STICKLINE(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L,L-0.09,4,0),COLORYELLOW;DRAWTEXT(CROSS(C,MA120) AND CROSS(C,MA250) AND CROSS(C,MA20),L-0.13,'并线开花'),COLORYELLOW;STICKLINE(TT2,L,L-0.09,4,0),COLORYELLOW;DRAWTEXT(TT2,L-0.13,'买点1'),COLORYELLOW;STICKLINE(CROSS(C,乖离线),H,H+0.09,4,0),COLOR00FF00;DRAWTEXT(CROSS(C,乖离线) ,H+0.13,'卖点'),COLOR00FF00;STICKLINE(MA250>=REF(MA250,1) AND MA20>=REF(MA20,1) AND CROSS(C,MA250),L,L-0.09,4,0),COLORFFCC66;DRAWTEXT(MA250>=REF(MA250,1) AND  MA20>=REF(MA20,1) AND CROSS(C,MA250),L-0.13,'牛象'),COLORFFCC66;STICKLINE(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L,L-0.09,4,0),COLORFF00FF;DRAWTEXT(MA120>=REF(MA120,1) AND CROSS(C,MA20) AND CROSS(C,MA120) AND V>REF(V,1),L-0.13,'买点2'),COLORFF00FF; 抄底幅图公式源码VAR1:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100; VAR2:=SMA(VAR1,3,1); VAR3:=SMA(VAR2,3,1); VAR4:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1); VAR5:=CROSS(VAR4,10) AND VAR3<80; 抄底:VAR5;

    浏览5174次浏览
    2022-10-24 09:40
  • 神奇指标

    主图 实战必胜(收费源码)

    以下是主图 实战必胜(收费源码) C/C++ Code复制内容到剪贴板[大智慧主图]实战必胜(收费源码) 上线:=sma(c,6.5,1); 下线:=sma(c,13.5,1); 上线1:=sma(c,3,1); 下线1:=sma(c,8,1); STICKLINE(上线>下线 , 上线,下线 ,2.5, 0),culorred,linethick2; stickline(下线>上线,上线,下线,2.5,0),culoryellow,linethick2; DRAWTEXT( cross(上线,下线),low *0.98,'全仓买' ),Culor00FFFF; 全仓买: cross(上线,下线); drawtext(cross(下线1,上线1),h*1.02,'清仓'),Culor80FF00; BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4; UPR:=BBI+3*STD(BBI,13); DWN:=BBI-3*STD(BBI,13); 安全:=MA(CLOSE,60); LC:=REF(CLOSE,1); RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100; DRAWTEXT( CROSS(82,RSI) , HIGH*1.02,'减仓') ,COLORff9966,linethick2; A7:=(2*C+H+L)/4; 操作:MA(a7,5),linethick2; 操作1:=MA(a7,5)*1.03; 操作2:=MA(a7,5)*0.97; Var1:LLV(a7,21); Var2:HHV(a7,21); SK:=EMA((A7-Var1)/(Var2-Var1)*100,7); SD:=EMA(0.667*REF(SK,1)+0.333*SK,5); DRAWTEXT(IF(count(close<ref(close,1),8)/8>6/10 and vul>=1.5*ma(vul,5) and count(sk>=sd,3) and ref(low,1)=LLV(Low,120),1,0),LOW*0.98,'买进') ,COLOR0099ff; 买进:sk>=sd;3; DRAWTEXT(IF(count(close<ref(close,1),13)/13>6/10 and count(sk>sd,6) and ref(low,5)=LLV(Low,120) and ref(close>=open,4) and ref(close>open,3) and REF(CLOSE>OPEN,2) AND ref(open>close,1) and open>ref(close,1),1,0),LOW*0.98,'买进') ,COLOryellow; D:=MA(CLOSE,80)-MA(CLOSE,10)/3; DRAWTEXT(if(CLOSE<D and VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.98,'抄底'),culoryellow; 抄底: CLOSE<D

    浏览3540次浏览
    2022-10-21 15:55
  • 神奇指标

    主图 实战必胜(收费源码)无偿奉献

    以下是主图 实战必胜(收费源码)无偿奉献 C/C++ Code复制内容到剪贴板上线:=sma(c,6.5,1); 下线:=sma(c,13.5,1); 上线1:=sma(c,3,1); 下线1:=sma(c,8,1); STICKLINE(上线>下线 , 上线,下线 ,2.5, 0),culorred,linethick2; stickline(下线>上线,上线,下线,2.5,0),culoryellow,linethick2; DRAWTEXT( cross(上线,下线),low *0.98,'全仓买' ),Culor00FFFF; 全仓买: cross(上线,下线); drawtext(cross(下线1,上线1),h*1.02,'清仓'),Culor80FF00; BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4; UPR:=BBI+3*STD(BBI,13); DWN:=BBI-3*STD(BBI,13); 安全:=MA(CLOSE,60); LC:=REF(CLOSE,1); RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100; DRAWTEXT( CROSS(82,RSI) , HIGH*1.02,'减仓') ,COLORff9966,linethick2; A7:=(2*C+H+L)/4; 操作:MA(a7,5),linethick2; 操作1:=MA(a7,5)*1.03; 操作2:=MA(a7,5)*0.97; Var1:LLV(a7,21); Var2:HHV(a7,21); SK:=EMA((A7-Var1)/(Var2-Var1)*100,7); SD:=EMA(0.667*REF(SK,1)+0.333*SK,5); DRAWTEXT(IF(count(close<ref(close,1),8)/8>6/10 and vul>=1.5*ma(vul,5) and count(sk>=sd,3) and ref(low,1)=LLV(Low,120),1,0),LOW*0.98,'买进') ,COLOR0099ff; 买进:sk>=sd;3; DRAWTEXT(IF(count(close<ref(close,1),13)/13>6/10 and count(sk>sd,6) and ref(low,5)=LLV(Low,120) and ref(close>=open,4) and ref(close>open,3) and REF(CLOSE>OPEN,2) AND ref(open>close,1) and open>ref(close,1),1,0),LOW*0.98,'买进') ,COLOryellow; D:=MA(CLOSE,80)-MA(CLOSE,10)/3; DRAWTEXT(if(CLOSE<D and VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW*0.98,'抄底'),culoryellow; 抄底: CLOSE<D

    浏览1704次浏览
    2022-10-21 14:40
  • 神奇指标

    实战参考之价格通道主图 修改版

    以下是实战参考之价格通道主图 修改版 C/C++ 股票公式指标网提供 Code复制内容到剪贴板A:=(CLOSE+OPEN)/2; 平衡线:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6) +13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12) +7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18) +1*REF(A,19))/208; 平仓:平衡线*1.16; 风险:平衡线*1.11; 回档:平衡线*1.053; 平衡:平衡线*1,LINETHICK2; 反弹:平衡线*0.93; 超跌:平衡线*0.9; 满仓:平衡线*0.841; TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3); TYX4:=MA((C+L+O+H)/4,13); TYX5:=EMA((C+L+O+H)/4,21); {空心红} STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED; STICKLINE(C<TYX5 AND C>O,C,O,3,1),COLORRED; {深绿} STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700; STICKLINE(C<TYX5 AND C<O,C,O,3,0),COLOR005500; STICKLINE(C<TYX5 AND C<O,C,O,2,0),COLOR006600; STICKLINE(C<TYX5 AND C<O,C,O,1,0),COLOR007700; {蓝} STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44; STICKLINE(C>TYX5 AND C<O,C,O,3,0 ),COLORFF7700; STICKLINE(C>TYX5 AND C<O,C,O,2,0 ),COLORFFAA22; STICKLINE(C>TYX5 AND C<O,C,O,1 ,0 ),COLORFFDD44; {黄} STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF; STICKLINE(C>TYX5 AND C>O,C,O,3,0 ),COLOR00AAFF; STICKLINE(C>TYX5 AND C>O,C,O,2,0 ),COLOR00CCFF; STICKLINE(C>TYX5 AND C>O,C,O,1,0 ),COLOR00EEFF; {粉红} STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA; STICKLINE(C>TYX4 AND C>O,C,O,3,0 ),COLORFF11FF; STICKLINE(C>TYX4 AND C>O,C,O,2,0 ),COLORFF44FF; STICKLINE(C>TYX4 AND C>O,C,O,1,0 ),COLORFF66FF; {亮灰} STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999; STICKLINE(C>TYX4 AND C<O,C,O,3,0),COLOR555555; STICKLINE(C>TYX4 AND C<O,C,O,2,0),COLOR777777; STICKLINE(C>TYX4 AND C<O,C,O,1,0),COLOR999999; {深红} STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD; STICKLINE(C>TYX3 AND C>O,C,O,3,0),COLOR000099; STICKLINE(C>TYX3 AND C>O,C,O,2,0),COLOR0000BB; STICKLINE(C>TYX3 AND C>O,C,O,1,0),COLOR0000DD; MA(CLOSE,3);MA(CLOSE,13);

    浏览811次浏览
    2022-10-21 13:41
  • 神奇指标

    暴涨启动 主图 无未来

    以下是暴涨启动 主图 无未来 C/C++ 股票公式指标网提供 Code复制内容到剪贴板MA5:MA(C,5); MA10 :MA(close,10); MA60 : MA(close,60); GJTJ1:=100*(C-LLV(L,5))/(HHV(C,5)-LLV(L,5)); GJTJ2:=100*(C-LLV(L,10))/(HHV(C,10)-LLV(L,10)); GJTJ3:=100*(C-LLV(L,20))/(HHV(C,20)-LLV(L,20)); GJTJ4:=100*(C-LLV(L,30))/(HHV(C,30)-LLV(L,30)); baijin1:=BARSLAST(CROSS(30,GJTJ1))<2 AND BARSLAST(CROSS(GJTJ1,50))<2; baijin2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4; baijin3:=GJTJ1>60 AND GJTJ4>70; drawtext(baijin1 AND baijin2 AND baijin3,l-0.02,'白金'); huangjin1:=BARSLAST(CROSS(50,GJTJ1))<3 AND BARSLAST(CROSS(GJTJ1,50))<3; huangjin2:=BARSLAST(CROSS(GJTJ4,GJTJ1))<2 AND GJTJ1>GJTJ4; DRAWTEXT(huangjin1 AND huangjin2,l-0.03,'黄金'); XG:=BARSLAST(CROSS(GJTJ4,GJTJ1))<5 AND GJTJ1>GJTJ4; drawtext(COUNT(XG,3)=1 AND XG and c>ma(c,20),l-0.02,'暴涨启动'),culorred; zhencang1:=BARSLAST(CROSS(GJTJ4,GJTJ1))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3; zhencang2:=BARSLAST(CROSS(GJTJ4,GJTJ2)); zhencang3:=GJTJ3<GJTJ4 AND GJTJ2<GJTJ4; zhencang4:=BARSLAST(CROSS(GJTJ4,GJTJ3))>3 AND BARSLAST(CROSS(GJTJ1,GJTJ4))<3; zhencang5:=GJTJ2<GJTJ3 AND GJTJ2<GJTJ4 AND GJTJ2<GJTJ1 AND GJTJ1=100; zcB1:=zhencang1>0 AND REF(zhencang1,1)=0 AND REF(zhencang1,2)>0; drawtext(zhencang1 AND zhencang2 AND zhencang3 AND zhencang4 AND zhencang5,l-0.05,'震仓启点'); Aa:=BARSLAST(CROSS(97,GJTJ1))<=1 AND BARSLAST(CROSS(GJTJ1,85))<=1; Bb:=BARSLAST(CROSS(97,GJTJ2))<=1 AND BARSLAST(CROSS(GJTJ2,85))<=1; Aa1:=Aa AND Bb; AAa:=BARSLAST(CROSS(97,GJTJ1))<=2 AND BARSLAST(CROSS(GJTJ1,85))<=1; BAa:=BARSLAST(CROSS(97,GJTJ2))<=2 AND BARSLAST(CROSS(GJTJ2,85))<=1; Aa2:=AA AND Bb ; AAAa:=BARSLAST(CROSS(97,GJTJ1))<=3 AND BARSLAST(CROSS(GJTJ1,85))<=1; BAAa:=BARSLAST(CROSS(97,GJTJ2))<=3 AND BARSLAST(CROSS(GJTJ2,85))<=1; Aa3:=AAAa AND BAAa ; Bb1:=REF(Aa1,1); Bb2:=REF(Aa2,1); Bb3:=REF(Aa3,1); Dd1:=GJTJ1=100 AND GJTJ2=100 AND Aa1 ; Dd2:=GJTJ1=100 AND GJTJ2=100 AND Aa2 ; Dd3:=GJTJ1=100 AND GJTJ2=100 AND Aa3 ; drawtext(Dd1 OR Dd2 OR Dd3,l-0.02,'短线追涨'); Aw:=BARSLAST(CROSS(95,GJTJ1))<=2; Bw:=BARSLAST(CROSS(95,GJTJ2))<=2; Ew:= GJTJ4<GJTJ1 AND GJTJ1<GJTJ2 AND GJTJ1<GJTJ3; Fw:=GJTJ2>50 AND GJTJ3>50; Gw:=GJTJ1=100 AND GJTJ2=100; TXw:=COUNT(Gw,2)=1; drawtext(Aw AND Bw AND Ew AND Fw AND TXw,l-0.03,'起涨首日'); Aq:=GJTJ3=100; Bq:=GJTJ4<90; drawtext(COUNT(Aq,2) = 2 AND Bq,l-0.02,'波启前兆');

    浏览9062次浏览
    2022-10-21 13:38
  • 神奇指标

    大智慧BS主图 改进版!

    以下是大智慧BS主图 改进版! C/C++ 股票公式指标网提供 Code复制内容到剪贴板a:="[email=LTFunc4@FORLT2]LTFunc4@FORLT2[/email]"; s1:="[email=LTFunc4@LT_S1]LTFunc4@LT_S1[/email]"; hs:="[email=LTFunc4@LT_HS]LTFunc4@LT_HS[/email]"; ls:="[email=LTFunc4@LT_LS]LTFunc4@LT_LS[/email]"; p1:="[email=LTFunc4@LT_P1]LTFunc4@LT_P1[/email]"; upp:="[email=LTFunc4@LT_UPP]LTFunc4@LT_UPP[/email]"; udd:="[email=LTFunc4@LT_UDD]LTFunc4@LT_UDD[/email]"; d1:=ema(abs("ddx.ddx"),60); d2:=max("ddx.ddx"/d1+7.5,7.5); d3:=min("ddx.ddx"/d1,10); fb:=if(s1=0,hs,ls); tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点','若明日收盘价>'+numtostrn(upp,2)+',出现B点'); tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会'); tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币')); tr3:=ifs(s1=0,'向下,','向上,'); tr4:='3.能量级别:'+numtostrn(d3,1)+'级'; bs:='1.BS点:'+tr2+','+tr0+'2.短线:'+tr3+tr1+''+tr4; drawflagtext(1,fb,bs); STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),culor5454ff; STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),culorblack; STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),culor5454ff; STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),culor5454ff; STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),culor5454ff; STICKLINE(p1=1 and c<=o,o,c,7.5,1),culor5454ff; STICKLINE(p1=1 and c<=o,l,c,0.5,1),culor5454ff; STICKLINE(p1=1 and c<=o,h,o,0.5,1),culor5454ff; STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),culorffff54; STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),culorffff54; STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),culorffff54; drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0; drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2; drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0; drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2; ma0:ma(c,1),culorblack; 操盘线:ma(c,7); 生命线:ma(c,21),culorff00ff; 二次生命:ma(c,55),culorwhite; 牛熊线:ma(c,144),culorgray,linethick2; PARTLINE(操盘线,c>=操盘线 and 操盘线>=ref(操盘线,1),RGB(255,0,0),c<操盘线,RGB(0,255,0)),LINETHICK2; DRAWTEXTABS(0,10,'所属板块:'+BKNAME),Culorwhite; DRAWTEXTREL(0,80,'每股收益:'+NUMTOSTRN(FINANCE2(3),3)+'元'+' 市盈率:'+NUMTOSTRN(DYNAINFO(39),2)+'元'+' 市净率:'+NUMTOSTRN((CLOSE / FINANCE2(4)),2)+'元'+' 净资产:'+NUMTOSTRN(FINANCE2(4),2)+'元'),Culor00C0FF; x1:=(C+L+H)/3; bb13:=atan(ema(x1,13)-ref(ema(x1,13),1))*3.1416*10; ema8:=ema(c,8); DRAWTEXT(filter(bb13>1 and ema(x1,13)>ref(ema(x1,8),1),10), ema8,'∠45°'),culorwhite; 压力:MA(REF(HHV(C,30),1),2),LINETHICK2,CulorAFFF00; 支撑:MA(REF(LLV(C,30),1),2),LINETHICK2,Culoryellow; gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100); 明日阻力:=l+(gj-l)+(c-l); 明日支撑:=l+(c-gj); 今日阻力:=REF(明日阻力 , 1); 今日支撑:=REF(明日支撑 , 1); STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,20,0),Culor0000FF; STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,20,0),Culor00FF00; STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,20,0),CulorFF00FF; STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,20,0),CulorFF9900; DRAWTEXTREL(0,130,'今日支撑:'+NUMTOSTRN(今日支撑 ,2 )),Culorred; DRAWTEXTREL(0,170,'今日阻力:'+NUMTOSTRN(今日阻力 ,2 )),CulorGREEN; VAR2:=(2*CLOSE+HIGH+LOW)/4; VAR3:=IF(YEAR>=2099 AND MONTH>2,0,1); VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4); 散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3; 庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3; DRAWTEXT(CROSS(散户,庄家) AND 散户<30,L-0.08,'←吸'),COLORRED; DRAWICON(CROSS(散户,庄家) AND 散户<30,L-0.1,1); 指标使用的几点感悟: 1、股价下探支撑线(黄线)后反弹并站稳支撑线,可以在支撑线附近出现笑脸、B点或小红点提示时逢低买入,操盘线变红时加仓;2、股价上碰压力线要注意风险,此时会两极分化,不上则下!请在操盘线变绿时考虑减仓或清仓!如果连续三天以上站在压力线之上,可以做下波段,高抛一下,在操盘线不变绿的情况下,在回踩操盘线附近时接回,一直持股到操盘线变绿;3、生命线、二次生命线很重要,是股票运行的重要支撑价位,也可以看做是二次启动位和最低止损位,跌破这两根线的票,应该期待它跌得更彻底,一直跌到黄色支撑线才好;4、牛熊线之下的股票受到的压力比较大,只有突破了牛熊线的票才有可能迎来美好的春天;5、开盘竞价在“今日阻力”下方2%以内,或者高于“今日阻力”3%以内的票,当日涨的可能性大于跌的可能性;6、人是活的,指标是死的,信心是自己给自己的,祝各位投资顺利!

    浏览7683次浏览
    2022-10-21 13:19
  • 神奇指标

    K线+KDJ主图 超牛全屏界面,附源码

    以下是K线+KDJ主图 超牛全屏界面,附源码 C/C++ 股票公式指标网提供 Code复制内容到剪贴板{K线+MACD副图} DIFF : EMA(CLOSE,12) - EMA(CLOSE,26),culorred; DEA : EMA(DIFF,9),culorgreen; MACD :4*(DIFF-DEA), COLORSTICK; D1:=EMA(C,3)-EMA(C,8); D3:=EMA(H,3)-EMA(H,8); D4:=EMA(L,3)-EMA(L,8); DRAWICON(cross(d1,diff) and diff<-0.05 ,d4,9); DRAWICON(cross(diff,d1) and diff>0.1 ,d3,10); Var1:=REF(MA(C,20),10); 开:=O-Var1; 高:=H-Var1; 低:=L-Var1; 收:=C-Var1; MID:=MA(C,20); UPPER:=MID+2*STD(C,20); LOWER:=MID-2*STD(C,20); V1:=(C-LOWER)/(UPPER-LOWER)*100; V2:=V1-EMA(V1,5); K1:=SUM(LLV(V2,4),4)/4; V3:=EMA(V2,64)*10; V4:=EMA(0.4*V2*(-1),3); V5:=-1*EMA(V2,39)*10; A:=V3>10; B:=V2>V4; D:=V5>10; E:=V3<=10 OR V2<=V4 OR V5<=10; STICKLINE(C,0,0,6,0),culoryellow; STICKLINE(收>=开 AND E,高,低,0,0), COLORred; STICKLINE(收>=开 AND E,收,开,8,0) ,COLORred; STICKLINE(收< 开 AND E,高,低,0,0) ,COLORgreen; STICKLINE(收< 开 AND E,收,开,8,0) ,COLORgreen; STICKLINE(开> 收 AND A,低,高,0,0),COLORYELLOW; STICKLINE(开> 收 AND A,收,开,8,0),COLORYELLOW; STICKLINE(开<=收 AND A,低,高,0,0),COLORYELLOW; STICKLINE(开<=收 AND A,收,开,8,1),COLORYELLOW; STICKLINE(开> 收 AND B,低,高,0,0),COLORRED; STICKLINE(开> 收 AND B,收,开,8,0),COLORRED; STICKLINE(开<=收 AND B,低,高,0,0),COLORRED; STICKLINE(开<=收 AND B,收,开,8,1),COLORRED; STICKLINE(开> 收 AND D,低,高,0,0),COLORGREEN; STICKLINE(开> 收 AND D,收,开,8,0),COLORGREEN; STICKLINE(开<=收 AND D,低,高,0,0),COLORGREEN; STICKLINE(开<=收 AND D,收,开,8,1),COLORGREEN; KS:=(C-SMA(C,13,1))/SMA(C,13,1)*(-100); RKS:=REF(KS,1); MLS:=RKS/KS>1.23 AND RKS>13 AND C/REF(C,1)>1.03; 超跌:STICKLINE(KS>13,高,低,0,1),culorwhite,linethick2; 反弹:STICKLINE(MLS=1,高,低,0,1),culormagenta,linethick2; STICKLINE(KS>13,开,收,8,1),culorwhite,linethick2; STICKLINE(MLS=1,开,收,8,1),culormagenta,linethick2; 开盘价:c,linethick0,precis2,culoryellow; 最高价:h,linethick0,precis2,culorred; 最低价:L,linethick0,precis2,culorcyan; 即时价:c,linethick0,precis2,culorgreen; DRAWTEXTABS(10,5,'所属板块:'+BKNAME),COLOR00FF00,linethick1; DRAWGBK(DATE>900101,STRIP(RGB(18,160,0),RGB(25,8,0),0)); C/C++ 股票公式指标网提供 Code复制内容到剪贴板{K线+KDJ主图} gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100); 明日阻力:=l+(gj-l)+(c-l); 明日支撑:=l+(c-gj); 明日阻力:=l+(gj-l)+(c-l); 明日支撑:=l+(c-gj); 今日阻力:=REF(明日阻力 , 1); 今日支撑:=REF(明日支撑 , 1); STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,30,0),Culor00FF00; STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,30,0),Culor00FF00; STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,30,0),Culor00FF00; STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,30,0),Culor00FF00; DRAWTEXTREL(600,10,'------------------------------------'),CulorFFFFFF; IF BARSTATUS=2 and c>=今日支撑 THEN DRAWTEXTREL(600,40,'今日支撑=:'+NUMTOSTRN(今日支撑 ,2 )),Culor00FF00; IF BARSTATUS=2 and c<今日支撑 THEN DRAWTEXTREL(600,40,'今日支撑=:'+NUMTOSTRN(今日支撑 ,2 )),CulorFF0000; IF BARSTATUS=2 and c>=今日阻力 THEN DRAWTEXTREL(600,80,'今日阻力=:'+NUMTOSTRN(今日阻力 ,2 )),Culor00FF00; IF BARSTATUS=2 and c<今日阻力 THEN DRAWTEXTREL(600,80,'今日阻力=:'+NUMTOSTRN(今日阻力 ,2 )),Culor00FF00; IF BARSTATUS=2 and c>=明日支撑 THEN DRAWTEXTREL(750,40,'明日支撑=:'+NUMTOSTRN(明日支撑 ,2 )),Culor00FF00; IF BARSTATUS=2 and c<明日阻力 THEN DRAWTEXTREL(750,80,'明日阻力=:'+NUMTOSTRN(明日阻力 ,2 )),Culor00FF00; DRAWTEXTREL(600,110,'------------------------------------'),CulorFFFFFF; IF BARSTATUS=2 and v>ref(v,1) and ma(v,5)>ref(ma(v,5),1) THEN DRAWTEXTREL(600,150,'今日成交量大于昨日,且有继续增大趋势'),Culor8285FF; IF BARSTATUS=2 and v<ref(v,1) and ma(v,5)>ref(ma(v,5),1) THEN DRAWTEXTREL(600,150,'今日成交量小于昨日,但有放大迹象'),Culor8285FF; IF BARSTATUS=2 and v>ref(v,1)and ma(v,5)<ref(ma(v,5),1) THEN DRAWTEXTREL(600,150,'今日成交量大于昨日, 但有缩小迹象'),Culor8285FF; IF BARSTATUS=2 and v<ref(v,1)and ma(v,5)<ref(ma(v,5),1) THEN DRAWTEXTREL(600,150,'今日成交量小于昨日,且有缩小迹象'),Culor8285FF; DRAWGBK(c>=0),Culor2B5516;平衡:EMA(C,20),CIRCLEDOT,COLORwhite; STICKLINE((CLOSE >平衡),平衡,平衡,1,0),LINETHICK6,culor0000ff; STICKLINE((平衡 > CLOSE),平衡,平衡,1,0),LINETHICK6,culorff6600; DRAWGBKLAST(v>1,STRIP(RGB(0,0,205),RGB(60,179,113),0)); DRAWTEXTREL(350,35,''+STKLABEL+' '+STKNAME),LINETHICK4,COLORyellow; DRAWTEXTABS(2,10,'现价:'+CLOSE),LINETHICK3,COLOR0000ff; DRAWTEXTABS(95,10,'涨幅:'+NUMTOSTRN(DYNAINFO(14)*100,2){(c-ref(c,1))/ref(c,1)*100}+'%'),LINETHICK3,COLOR0000ff; DRAWTEXTABS(2,40,IFS(DYNAINFO(51)>DYNAINFO(3),'卖五:'+NUMTOSTRN(DYNAINFO(51),2),'')),LINETHICK3,COLOR0000FF; DRAWTEXTABS(2,40,IFS(DYNAINFO(51)=DYNAINFO(3),'卖五:'+NUMTOSTRN(DYNAINFO(51),2),'')),LINETHICK3,COLORFFFFFF; DRAWTEXTABS(2,40,IFS(DYNAINFO(51)<DYNAINFO(3),'卖五:'+NUMTOSTRN(DYNAINFO(51),2),'')),LINETHICK3,COLOR00FF00; DRAWTEXTABS(95,45,''+DYNAINFO(50)),COLORffffff; DRAWTEXTABS(2,60,IFS(DYNAINFO(44)>DYNAINFO(3),'卖四:'+NUMTOSTRN(DYNAINFO(44),2),'')),LINETHICK3,COLOR0000FF; DRAWTEXTABS(2,60,IFS(DYNAINFO(44)=DYNAINFO(3),'卖四:'+NUMTOSTRN(DYNAINFO(44),2),'')),LINETHICK3,COLORFFFFFF; DRAWTEXTABS(2,60,IFS(DYNAINFO(44)<DYNAINFO(3),'卖四:'+NUMTOSTRN(DYNAINFO(44),2),'')),LINETHICK3,COLOR00FF00; DRAWTEXTABS(95,65,''+DYNAINFO(43)),COLORffffff; DRAWTEXTABS(2,80,IFS(DYNAINFO(36)>DYNAINFO(3),'卖三:'+NUMTOSTRN(DYNAINFO(36),2),'')),LINETHICK3,COLOR0000FF; DRAWTEXTABS(2,80,IFS(DYNAINFO(36)=DYNAINFO(3),'卖三:'+NUMTOSTRN(DYNAINFO(36),2),'')),LINETHICK3,COLORFFFFFF; DRAWTEXTABS(2,80,IFS(DYNAINFO(36)<DYNAINFO(3),'卖三:'+NUMTOSTRN(DYNAINFO(36),2),'')),LINETHICK3,COLOR00FF00; DRAWTEXTABS(95,85,''+DYNAINFO(33)),COLORffffff; DRAWTEXTABS(2,100,IFS(DYNAINFO(35)>DYNAINFO(3),'卖二:'+NUMTOSTRN(DYNAINFO(35),2),'')),LINETHICK3,COLOR0000FF; DRAWTEXTABS(2,100,IFS(DYNAINFO(35)=DYNAINFO(3),'卖二:'+NUMTOSTRN(DYNAINFO(35),2),'')),LINETHICK3,COLORFFFFFF; DRAWTEXTABS(2,100,IFS(DYNAINFO(35)<DYNAINFO(3),'卖二:'+NUMTOSTRN(DYNAINFO(35),2),'')),LINETHICK3,COLOR00FF00; DRAWTEXTABS(95,105,''+DYNAINFO(32)),COLORffffff; DRAWTEXTABS(2,120,IFS(DYNAINFO(34)>DYNAINFO(3),'卖一:'+NUMTOSTRN(DYNAINFO(34),2),'')),LINETHICK3,COLOR0000FF; DRAWTEXTABS(2,120,IFS(DYNAINFO(34)=DYNAINFO(3),'卖一:'+NUMTOSTRN(DYNAINFO(34),2),'')),LINETHICK3,COLORFFFFFF; DRAWTEXTABS(2,120,IFS(DYNAINFO(34)<DYNAINFO(3),'卖一:'+NUMTOSTRN(DYNAINFO(34),2),'')),LINETHICK3,COLOR00FF00; DRAWTEXTABS(95,125,''+DYNAINFO(31)),COLORffffff; DRAWTEXTABS(2,130,'---------------'),LINETHICK3,COLOR00ff00; DRAWTEXTABS(2,140,IFS(DYNAINFO(28)>DYNAINFO(3),'买一:'+NUMTOSTRN(DYNAINFO(28),2),'')),LINETHICK3,COLOR0000FF; DRAWTEXTABS(2,140,IFS(DYNAINFO(28)=DYNAINFO(3),'买一:'+NUMTOSTRN(DYNAINFO(28),2),'')),LINETHICK3,COLORFFFFFF; DRAWTEXTABS(2,140,IFS(DYNAINFO(28)<DYNAINFO(3),'买一:'+NUMTOSTRN(DYNAINFO(28),2),'')),LINETHICK3,COLOR00FF00; DRAWTEXTABS(95,145,''+DYNAINFO(25)),COLORffffff; DRAWTEXTABS(2,160,IFS(DYNAINFO(29)>DYNAINFO(3),'买二:'+NUMTOSTRN(DYNAINFO(29),2),'')),LINETHICK3,COLOR0000FF; DRAWTEXTABS(2,160,IFS(DYNAINFO(29)=DYNAINFO(3),'买二:'+NUMTOSTRN(DYNAINFO(29),2),'')),LINETHICK3,COLORFFFFFF; DRAWTEXTABS(2,160,IFS(DYNAINFO(29)<DYNAINFO(3),'买二:'+NUMTOSTRN(DYNAINFO(29),2),'')),LINETHICK3,COLOR00FF00; DRAWTEXTABS(95,165,''+DYNAINFO(26)),COLORffffff; DRAWTEXTABS(2,180,IFS(DYNAINFO(30)>DYNAINFO(3),'买三:'+NUMTOSTRN(DYNAINFO(30),2),'')),LINETHICK3,COLOR0000FF; DRAWTEXTABS(2,180,IFS(DYNAINFO(30)=DYNAINFO(3),'买三:'+NUMTOSTRN(DYNAINFO(30),2),'')),LINETHICK3,COLORFFFFFF; DRAWTEXTABS(2,180,IFS(DYNAINFO(30)<DYNAINFO(3),'买三:'+NUMTOSTRN(DYNAINFO(30),2),'')),LINETHICK3,COLOR00FF00; DRAWTEXTABS(95,185,''+DYNAINFO(27)),COLORffffff; DRAWTEXTABS(2,200,IFS(DYNAINFO(42)>DYNAINFO(3),'买四:'+NUMTOSTRN(DYNAINFO(42),2),'')),LINETHICK3,COLOR0000FF; DRAWTEXTABS(2,200,IFS(DYNAINFO(42)=DYNAINFO(3),'买四:'+NUMTOSTRN(DYNAINFO(42),2),'')),LINETHICK3,COLORFFFFFF; DRAWTEXTABS(2,200,IFS(DYNAINFO(42)<DYNAINFO(3),'买四:'+NUMTOSTRN(DYNAINFO(42),2),'')),LINETHICK3,COLOR00FF00; DRAWTEXTABS(95,205,''+DYNAINFO(41)),COLORffffff; DRAWTEXTABS(2,220,IFS(DYNAINFO(49)>DYNAINFO(3),'买五:'+NUMTOSTRN(DYNAINFO(49),2),'')),LINETHICK3,COLOR0000FF; DRAWTEXTABS(2,220,IFS(DYNAINFO(49)=DYNAINFO(3),'买五:'+NUMTOSTRN(DYNAINFO(49),2),'')),LINETHICK3,COLORFFFFFF; DRAWTEXTABS(2,220,IFS(DYNAINFO(49)<DYNAINFO(3),'买五:'+NUMTOSTRN(DYNAINFO(49),2),'')),LINETHICK3,COLOR00FF00; DRAWTEXTABS(95,225,''+DYNAINFO(48)),COLORffffff; 上轨:(SMA(HIGH,21,2) * 1.092),POINTDOT,culorFFFFFF; 中轨道:(SMA(HIGH,21,2) * 1.017),POINTDOT,culorFFFFFF; 下轨道:(SMA(LOW,21,2) * 0.969),POINTDOT,culor00FFFF; WCW:=BARSLAST(WEEKDAY>REF(WEEKDAY,1));{周} CAW:=IF(WCW>0,LLV(C,WCW),LLV(C,WEEKDAY));{周} 周涨幅:=(C/CAW-1)*100; WCM:=BARSLAST(MONTH>REF(MONTH,1));{月} CAM:=IF(WCM>0,LLV(C,WCM),LLV(C,MONTH));{月} 月涨幅:=(C/CAM-1)*100; WCY:=BARSLAST(YEAR>REF(YEAR,1));{年} CAY:=IF(WCY>0,LLV(C,WCY),LLV(C,YEAR));{年} 年涨幅:=(C/CAY-1)*100; DRAWFLAGTEXT(周涨幅,LOW*0.95,'周涨幅:'+NUMTOSTRN(周涨幅,2)+'%'); DRAWFLAGTEXT(月涨幅,LOW*0.95,'月涨幅:'+NUMTOSTRN(月涨幅,2)+'%'); DRAWFLAGTEXT(年涨幅,LOW*0.95,'年涨幅:'+NUMTOSTRN(年涨幅,2)+'%'); JJ:=(OPEN+LOW+HIGH+CLOSE*2)/5; JJ2:=MA(JJ,2); V2:=MA(VOL,2); D:sMA((JJ*VOL+JJ2*V2)/(VOL+V2),3,1),LINETHICK2,culormagenta; K:6*D-5*sMA(JJ2,3,1),COLORyellow; J:5*K-4*D,culorgreen; 买入:=ref(J,1)<ref(D ,1) and J>=D; drawicon(买入,J*1,1); partline(J,J>=ref(J,1),rgb(255,0,0),J<ref(J,1),rgb(0,250,0)),linethick3; a:="LTFunc5@FORLT2"; {计算BS点} s1:="LTFunc5@LT_S1"; {s1=0,向下; s1=1,向上} hs:="LTFunc5@LT_HS"; {短线买入机会} ls:="LTFunc5@LT_LS"; {短线卖出机会} p1:="LTFunc5@LT_P1"; {p1=1,显示BS,p1上穿0线,B点 ; p1下穿1线,S点} upp:="LTFunc5@LT_UPP";{明日B点预测} udd:="LTFunc5@LT_UDD";{明日S点预测} drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0; drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2; drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0; drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2; C/C++ 股票公式指标网提供 Code复制内容到剪贴板{星期显示} yy1:=WEEKDAY; IF BARSTATUS=2 and (yy1=5) THEN BEGIN DRAWTEXTREL(10,950,'■星期五■'),LINETHICK2,Culor191970;end; IF BARSTATUS=2 and (yy1=4) THEN BEGIN DRAWTEXTREL(10,950,'■星期四■'),LINETHICK2,CulorEEE8AA;end; IF BARSTATUS=2 and (yy1=3) THEN BEGIN DRAWTEXTREL(10,950,'■星期三■'),LINETHICK2,CulorBA55D3;end; IF BARSTATUS=2 and (yy1=2) THEN BEGIN DRAWTEXTREL(10,950,'■星期二■'),LINETHICK2,Culor0000CD;end; IF BARSTATUS=2 and (yy1=1) THEN BEGIN DRAWTEXTREL(10,950,'■星期一■'),LINETHICK2,CulorADFF2F;end; IF BARSTATUS=2 and (yy1=6) THEN BEGIN DRAWTEXTREL(10,950,'■星期六■'),LINETHICK2,Culor00008B;end; IF BARSTATUS=2 and (yy1=0) THEN BEGIN DRAWTEXTREL(10,950,'■星期日■'),LINETHICK2,CulorFF0000;end;

    浏览7349次浏览
    2022-10-21 13:15
  • 神奇指标

    通达信超准完美买卖主图 副图及选股公式

    以下是通达信超准完美买卖主图 副图及选股公式通达信超准完美买卖主图 副图及选股公式{超准完美买卖主图}DRAWTEXT(CROSS(MA(C,10),MA(C,20)),H,'-------------'),LINETHICK2;DRAWBAND(MA(C,3),RGB(230,0,250),HHV(MA(C,5),10),RGB(0,100,150));MA5:MA(CLOSE,5);MA10:MA(CLOSE,10);MA20:MA(CLOSE,20);MA30:MA(CLOSE,30);MA60:MA(CLOSE,60),CIRCLEDOT;MA120:MA(CLOSE,120),CIRCLEDOT;RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;X:=LLV(J,2)=LLV(J,8);Y:=IF(CROSS(J,REF(J+0.01,1)) AND X AND J<20,30,0);主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);VAR2:=LLV(LOW,10);VAR3:=HHV(HIGH,25);动能趋势线:=100*EMA((CLOSE-VAR2)/(VAR3-VAR2),4);DRAWTEXT(CROSS(动能趋势线,70),HIGH*1.02,'险'),COLORGREEN;DRAWTEXT(CROSS(动能趋势线,80),HIGH*1.02,'减'),COLOR00FF00;DRAWTEXT(CROSS(动能趋势线,87.5),HIGH*1.02,'出局'),COLORWHITE;DRAWTEXT(CROSS(J,REF(J+0.01,1)) AND X AND J<20,LOW,'短进'),COLORFF00FF;DRAWTEXT(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,'见底'),COLORRED;DRAWICON(CROSS(主力,散户) AND 主力<0 AND 散户<0,LOW,1);涨家数:INDEXADV,NODRAW,COLORRED;跌家数:INDEXDEC,NODRAW,COLORGREEN;{涨跌停显示}涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);STICKLINE(涨停,O,C,3,0),COLORYELLOW;ZDF:=(C-REF(C,1))/REF(C,1)*100;STICKLINE(ZDF<-9.9,O,C,3,0),COLORGREEN;{以下为K线上色}STICKLINE(CLOSE> REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORRED;STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR000055;STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR000077;STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR000099;STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLOR0000BB;STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLOR0000DD;STICKLINE(CLOSE> REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLOR0000FF;STICKLINE(CLOSE= REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORWHITE;STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR555555;STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLOR777777;STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLOR999999;STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORBBBBBB;STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORDDDDDD;STICKLINE(CLOSE= REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORFFFFFF;STICKLINE(CLOSE< REF(CLOSE,1) ,HIGH,LOW,0,1 ),COLORCYAN;STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,3,0 ),COLOR990000;STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.7,0 ),COLORCC0000;STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,2.1,0 ),COLORFF4400;STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,1.5,0 ),COLORFF8800;STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.9,0 ),COLORFFCC00;STICKLINE(CLOSE< REF(CLOSE,1) ,OPEN,CLOSE,0.3,0 ),COLORCYAN; 副图选股公式:{超准完美买卖选股1短进}RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;X:=LLV(J,2)=LLV(J,8);超准选股短进:=CROSS(J,REF(J+0.01,1)) AND X AND J<20,COLORYELLOW;{超准完美买卖选股2见底}主力:=EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);散户:=EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7);VAR2:=LLV(LOW,10);VAR3:=HHV(HIGH,25);动能趋势线:=100*EMA((CLOSE-VAR2)/(VAR3-VAR2),4);超准选股见底:CROSS(主力,散户) AND 主力<0 AND 散户<0,COLORRED;

    浏览6588次浏览
    2022-10-21 10:26