神奇指标网

通达信MA02主图 较全面的看盘主图,带K线注释(右键选择)

浏览 4244次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-11-03




以下是通达信MA02主图 较全面的看盘主图,带K线注释(右键选择)




通达信MA02主图 较全面的看盘主图,带K线注释(右键选择)



M5:MA(C,5),COLORWHITE;

M10:MA(C,10),COLORYELLOW;

M20:MA(C,20),COLORCYAN;

M60:MA(C,60),COLORGREEN,LINETHICK2;

M120:MA(C,120),COLORRED,LINETHICK2;

VAR6:=(( ABS((OPEN-CLOSE))/(HIGH-LOW))*VOL);

VAR7:=(( (HIGH-IF((CLOSE>OPEN),CLOSE,OPEN))/(HIGH-LOW))*VOL);

VAR8:=(( (IF((CLOSE>OPEN),OPEN,CLOSE)-LOW)/(HIGH-LOW))*VOL);

VAR9:=IF(((VOL/CAPITAL)>0.001),1,EXP(ABS(LOG(((VOL/CAPITAL)*100)))));

加仓:=VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE>OPEN,NODRAW,COLORRED;

减仓:=VAR6>=VAR7 AND VAR6>=VAR8 AND CLOSE<OPEN,NODRAW,COLORBLUE;

洗盘:=VAR8>VAR6 AND VAR8>VAR7,NODRAW,COLORWHITE;

高抛:=VAR7>VAR6 AND VAR7>VAR8,NODRAW,COLORMAGENTA;

地量:=VAR9>2 AND VOL<MA(VOL,5)/2,NODRAW,COLORGREEN;

TY:=C;

A1:=REF(TY,10)=HHV(TY,2*10+1);

B1:=FILTER(A1,10); C1:=BACKSET(B1,10+1);

HD:=FILTER(C1,10);

A2:=REF(TY,10)=LLV(TY,2*10+1);

B2:=FILTER(A2,10); C2:=BACKSET(B2,10+1);

LD:=FILTER(C2,10);

前期高位:=REF(H,BARSLAST(HD)), COLORLIRED,LINETHICK1;

前期低位:=REF(L,BARSLAST(LD)), COLORGREEN,LINETHICK1;

JRH:=HHV(C,2);

JRL:=LLV(C,2);

VAR01:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));

VAR02:=(REF(VAR01,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR03:=(REF(VAR02,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR04:=(REF(VAR03,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR05:=(REF(VAR04,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR06:=(REF(VAR05,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR07:=(REF(VAR06,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR08:=(REF(VAR07,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR09:=(REF(VAR08,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARA:=(REF(VAR09,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VARB:=(REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARC:=(REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VARD:=(CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2));

VARE:=(REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VARF:=(REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR010:=(REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR011:=(REF(VAR010,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR012:=(REF(VAR011,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR013:=(REF(VAR012,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR014:=(REF(VAR013,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR015:=(REF(VAR014,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR016:=(REF(VAR015,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR017:=(REF(VAR016,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2));

VAR018:=(REF(VAR017,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2));

VAR019:=((REF(VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,1)) AND VAR01);

VAR1A:=((REF(VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,1)) AND VARD);

红色持股:=VAR01 OR VAR02 OR VAR03 OR VAR04 OR VAR05 OR VAR06 OR VAR07 OR VAR08 OR VAR09 OR VARA OR VARB OR VARC,COLOR0000FF,NODRAW;

离场:=IF(红色持股,JRL,DRAWNULL);

明离场价:=离场,COLORFF99FF,NODRAW;

青色观望:=VARD OR VARE OR VARF OR VAR010 OR VAR011 OR VAR012 OR VAR013 OR VAR014 OR VAR015 OR VAR016 OR VAR017 OR VAR018,COLORFFFF00,NODRAW;

进:=IF(青色观望,JRH,DRAWNULL);

今离场价:REF(离场,1),COLOR0000FF,NODRAW;

明进场价:=进,COLOR33AACC,NODRAW;

今进场价:REF(明进场价,1),COLORGREEN,NODRAW;


上涨家数:INDEXADV,COLOR0080FF,NODRAW;

下跌家数:INDEXDEC,COLORGREEN,NODRAW;

DRAWKLINE(H,O,L,C);

STICKLINE(加仓,O,C,0.5,0),COLORRED;

STICKLINE(洗盘,O,C,1,0),COLORWHITE;

STICKLINE(高抛,O,C,1,0),COLORMAGENTA;

STICKLINE(地量,O,C,1,0),COLORGREEN;

STICKLINE(减仓,O,C,1,0),COLORBLUE;


JJ:=(3*C+H+L+O)/6;

VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;

TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);

LJL:=FILTER(TJ1,5);


DRAWTEXT_FIX(1,0.00,0.02,0,'所属行业:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.07,0.02,0,HYBLOCK),COLORYELLOW;

DRAWTEXT_FIX(1,0.14,0.02,0,'所属地区:'),COLORYELLOW;

DRAWTEXT_FIX(1,0.21,0.02,0,DYBLOCK),COLORYELLOW;

N:=IF(TOTALBARSCOUNT>=120,120,TOTALBARSCOUNT);

HH0:=HHV(H,N);

LL0:=LLV(L,N);

MM0:=CONST((HH0+LL0)*0.5);

S01:=CONST(IF(REF(C,N-15)>MM0,1.00,-0.08));

S02:=CONST(IF(REF(C,N-15)>MM0,-1,1));

S1:=IF(FINDSTR(EXTERNSTR(0,13),'万元'),S01+(0.08*S02),S01),NODRAW;

S2:=IF(FINDSTR(EXTERNSTR(0,12),'。'),S1+(0.08*S02),S1),NODRAW;

S3:=IF(FINDSTR(EXTERNSTR(0,8),'公告'),S2+(0.08*S02),S2),NODRAW;

S4:=IF(FINDSTR(EXTERNSTR(0,10),','),S3+(0.08*S02),S3);

S5:=IF(FINDSTR(EXTERNSTR(0,15),'-'),S4+(0.08*S02),S4);

S6:=IF(FINDSTR(EXTERNSTR(0,1),','),S5+(0.08*S02),S5);

S7:=IF(FINDSTR(EXTERNSTR(0,14),'-'),S6+(0.08*S02),S6);

S8:=IF(FINDSTR(EXTERNSTR(0,11),'-'),S7+(0.08*S02),S7);

S9:=IF(FINDSTR(EXTERNSTR(0,9),'-'),S8+(0.08*S02),S8);

K:=IF(S1<=0,0.05,IF(S1>=0,-0.05,0));

T1:=IF(FINDSTR(EXTERNSTR(0,13),'万元'),STRCAT('敢死队席位:',EXTERNSTR(0,13)),'');

T2:=IF(FINDSTR(EXTERNSTR(0,12),'。'),STRCAT('智能诊断:',EXTERNSTR(0,12)),'');

T3:=IF(FINDSTR(EXTERNSTR(0,8),'公告'),STRCAT('年报业绩:',EXTERNSTR(0,8)),'');

T4:=IF(FINDSTR(EXTERNSTR(0,10),','),STRCAT('主题投资:',EXTERNSTR(0,10)),'');

T5:=IF(FINDSTR(EXTERNSTR(0,15),'-'),STRCAT('解禁日期:',EXTERNSTR(0,15)),'');

T6:=IF(FINDSTR(EXTERNSTR(0,1),','),STRCAT('千股千评:',EXTERNSTR(0,1)),'');

T7:=IF(FINDSTR(EXTERNSTR(0,14),'-'),STRCAT('业绩预报:',EXTERNSTR(0,14)),'');

T8:=IF(FINDSTR(EXTERNSTR(0,11),'-'),STRCAT('机构评级:',EXTERNSTR(0,11)),'');

T9:=IF(FINDSTR(EXTERNSTR(0,9),'-'),STRCAT('中报业绩:',EXTERNSTR(0,9)),'');

{DRAWTEXT_FIX(1,0,S1+K,0,T1)COLOR00FFFF;}

DRAWTEXT_FIX(1,0.00,0.12,0,T2),COLOR00FF00;

{DRAWTEXT_FIX(1,0.00,0.1,0,T3),COLORFF00FF;}

DRAWTEXT_FIX(1,0.30,0.02,0,T4),COLOR0088FF;

DRAWTEXT_FIX(1,0.30,0.07,0,T5)COLOR00FF00;

DRAWTEXT_FIX(1,0.00,0.92,0,T6),COLOR00FFFF;

DRAWTEXT_FIX(1,0.00,0.07,0,T7),COLOR00CCFF;

{DRAWTEXT_FIX(1,0,S8+K,0,T8)COLORFF88FF;}

{DRAWTEXT_FIX(1,0,S9+K,0,T9)COLORBBFFFF;}

{DRAWTEXT_FIX(1,0.00,0.25,0,'绿芯-高位出货坚决撤离为佳'),COLOR00FF00,LINETHICK1;}

{DRAWTEXT_FIX(1,0.00,0.3,0,'蓝芯-主力低位深度洗盘或高位出货坚决'),COLORFF0000,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.35,0,'白芯-主力轻度洗盘'),COLORFFFFFF,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.4,0,'粉芯-主力在做高抛低吸或低吸高抛'),COLORFF00FF,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.45,0,'红芯-主力吸筹进货积极主动'),COLOR0000FF,LINETHICK1;

DRAWTEXT_FIX(1,0.00,0.5,0,'黄芯-主力吸筹进货强并且成交量出现黄金柱'),COLORYELLOW,LINETHICK1;}



VAR111:=ZIG(3,13);

STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,3,0),COLOR66FF00;

DRAWTEXT_FIX(STICKLINE((REF(VAR111,2) < REF(VAR111,1)) AND (VAR111 < REF(VAR111,1)),CLOSE,OPEN,5,0),0.00,0.11,0,''),COLOR00FF00,LINETHICK1;


天线:=MA(REF(HHV(C,30),1),2),LINETHICK3,COLORMAGENTA;

地线:=MA(REF(LLV(C,30),1),2),COLORGREEN,LINETHICK3;



通达信MA02主图 较全面的看盘主图,带K线注释(右键选择)





神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论