神奇指标网
神奇指标网

通达信乖离通道幅图公式 精准判断趋势 希望对你有帮助

浏览 2629次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-10-18




以下是通达信乖离通道幅图公式 精准判断趋势 希望对你有帮助




乖离通道幅图公式 精准判断趋势 希望对你有帮助



这是一个55日、34日和13日的乖离率的指标,黄色、粉色和红色柱分别代表这3个日期的正乖离,白色、青色和兰色分别代表3个日期负乖离。通过成交量换手率计算出中期负乖离,在图上显示绿色空心柱。上下通道是20日短期乖离率正负1.618*20日长期乖离率估算标准差的移动平均线,生命轨迹是短期13日乖离率线。通过分析,可以推断负乖离下破下通道有绿色空心柱出现,则负的乖离率愈大,则空头回补的可能性愈高。正乖离突破上通道,表示短期获利愈大,则获利回吐的可能性愈高



公式源码



长期乖离:(CLOSE-MA(CLOSE,55))/MA(CLOSE,55)*100,COLORYELLOW,STICK,LINETHICK3;

IF(长期乖离<=0,长期乖离,0),COLORWHITE,STICK,LINETHICK3;

中期乖离:(CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100,COLORFF00FF,STICK,LINETHICK3;

IF(中期乖离<=0,中期乖离,0),COLORFFFF33,STICK,LINETHICK3;

短期乖离:(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100,COLORRED,STICK,LINETHICK3;

IF(短期乖离<=0,短期乖离,0),COLORBLUE,STICK,LINETHICK3;

VAR2:=REF(HIGH,1)*1.1;{{昨日最高价*系数}

VAR3:=HIGH*1.1;{当日最高价*系数}

VAR4:=(VAR3*VOL+VAR2*(CAPITAL-VOL))/CAPITAL;

VAR5:=REF(LOW,1)*0.9; {昨日最低价*系数}

VAR6:=LOW*0.9;{当日最低价*系数}

VAR7:=(VAR6*VOL+VAR5*(CAPITAL-VOL))/CAPITAL;

VAR8:=EMA(VAR7,30);{求30日VAR7的移动平均}

VAR9:=EMA(VAR4,30);{求30日VAR4的移动平均}

VAR10:=VAR9-2;

VAR11:=IF(CLOSE<=VAR8,VAR10,VAR9);

VAR12:=VAR11*2.5;

VAR13:=VAR10*2.5;

STICKLINE(VAR12=VAR13,中期乖离,0,2,1),COLOR408000;

通道上:MA(短期乖离,20)+1.618*STD(长期乖离,20),COLOR0099FF,LINETHICK2;

通道下:MA(短期乖离,20)-1.618*STD(长期乖离,20),COLOR0099FF,LINETHICK2;

轨迹:短期乖离,COLOR00FF00,LINETHICK2;



乖离通道幅图公式 精准判断趋势 希望对你有帮助



神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论