神奇指标网
神奇指标网

【基准K线画线 主图及选股 通达信版本 贴图 源码】

浏览 4426次浏览
标签: rsi 涨停
来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-05

以下是【基准K线画线 主图及选股 通达信版本 贴图 源码】

我设置的标准K线是振幅大于10%。你只要修改ZF其他不要动就可以随心所欲了。比喻  设置涨停为标准K线:zf:=c>ref(c,1)*1.095 and c=h;


大振幅主图


ZF:=(H-L)/REF(C,1)*100;
T:=BARSLAST(ZF>10);
A:=EVERY(H<=REF(H,T) AND L>=REF(L,T),T) AND T>3;
XG:=REF(A,1) AND C>REF(REF(H,T),1);
Q:=BACKSET(XG,REF(T,1)+2);
QT:=BARSLAST(CROSS(Q=1,0.5));
HH:IF(Q=1,REF(H,QT),DRAWNULL),COLORYELLOW;
LL:IF(Q=1,REF(L,QT),DRAWNULL),COLORYELLOW;
STICKLINE(QT=0,C,O,2,0),COLORYELLOW;
STICKLINE(QT=0,H,L,0,0),COLORYELLOW;
DRAWICON(XG,L*0.98,1);

 

{选股}

ZF:=(H-L)/REF(C,1)*100;
T:=BARSLAST(ZF>10);
A:=EVERY(H<=REF(H,T) AND L>=REF(L,T),T) AND T>3;
XG:REF(A,1) AND C>REF(REF(H,T),1);

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论