神奇指标网
神奇指标网

通达信手机版MACD (源码、副图、通达信、贴图)

浏览 3470次浏览
标签: 画线 dmi
来源:通达信公式 编辑:神奇指标网 发布日期:2022-09-27

以下是手机版macd (源码、副图、通达信、贴图)

手机版MACD (源码、副图、通达信、贴图)

该指标在红色柱子最高点出现小人逃跑的图形说明指标顶背离了,下方出现红色箭头,或者是出现钱袋的图形可以参考买入。

源码

SHORT:=12;
LONG:=26;
MID:=9;
DIF:EMA(CLOSE,SHORT)-EMA(CLOSE,LONG);
DEA:EMA(DIF,MID);
MACD:(DIF-DEA)*2,COLORSTICK;
DRAWICON(REF(DIF,1)REF(DIF,1) AND DIF<0 AND DIF<DEA,DIF*1.1,1),COLORRED;
HJ_2:=BARSLAST(REF(MACD,1)<0 and="" macd="">0);
HJ_3:=LLVBARS(MACD,HJ_2+20);
HJ_4:=IF(HJ_3>HJ_2,REF(MACD,HJ_3),0);
HJ_5:=MACD<0 and="" macd="">HJ_4 AND LOW=LLV(LOW,HJ_2+20) AND HJ_4<0;
HJ_6:=REF(HJ_5,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,HJ_3)<0 AND MACD<0;
底背:DRAWLINE(HJ_4=HJ_3,MACD,HJ_6,MACD,0),COLORRED,DOTLINE;
DRAWICON(HJ_6,MACD*1.2,9);
HJ_7:=HHVBARS(MACD,HJ_2+20);
HJ_8:=IF(HJ_7>HJ_2,REF(MACD,HJ_7),0);
HJ_9:=MACD>0 AND MACD0;
HJ_10:=REF(HJ_9,1)=1 AND MACD>REF(MACD,1) AND REF(DIF,HJ_7)>0;
顶背:DRAWLINE(HJ_8=HJ_7,MACD,HJ_10,MACD,0),COLOR1D7300,DOTLINE;
DRAWICON(HJ_10,MACD*1.2,15);
HJ_11:=CLOSE/MA(CLOSE,40)*100<78;
HJ_12:=CLOSE/MA(CLOSE,60)*100<74;
HJ_13:=HIGH>LOW*1.051;
HJ_14:=HJ_13 AND COUNT(HJ_13,5)>1;
HJ_15:=IF(HJ_14 AND (HJ_11 OR HJ_12),2,0);
HJ_16:=CLOSE/REF(CLOSE,25)<=1.1;
HJ_17:=SMA(MAX(CLOSE-REF(CLOSE,2),0),7,1)/SMA(ABS(CLOSE-REF(CLOSE,2)),7,1)*100<15;
HJ_18:=(CLOSE-LLV(LOW,8))/(HHV(HIGH,8)-LLV(LOW,8))*100;
HJ_19:=SMA(HJ_18,2,1);
HJ_20:=SMA(HJ_19,2,1);
HJ_21:=IF(HJ_19>REF(HJ_19,1) AND REF(HJ_19,1)<REF(HJ_19,2) AND HJ_19<23,1.5,0);
HJ_22:=100-100*(HHV(HIGH,5*8)-CLOSE)/(HHV(HIGH,5*8)-LLV(LOW,5*8));
HJ_23:=MA(CLOSE,5);
HJ_24:=IF(CLOSE>SAR(10,2,20),1,0);
HJ_25:=IF(CLOSE<SAR(10,2,20),(-1),0);
HJ_26:=ATAN((HJ_23/REF(HJ_23,1)-1)*100)*180/3.1416;
HJ_27:=IF(HJ_26>30,1,0);
HJ_28:=IF(HJ_26<(-30),(-1),0);
HJ_29:=HJ_24+HJ_27+HJ_25+HJ_28;
IF(HJ_29<(-1) OR HJ_22<25.01,DIF,DRAWNULL),COLOR1D7300;
IF(HJ_22>74.989998 OR HJ_29>0,DIF,DRAWNULL),COLORRED;0,COLORBROWN,POINTDOT;


 

手机版MACD (源码、副图、通达信、贴图)


神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论