神奇指标网
神奇指标网

通达信起爆点主图指标公式

浏览 279次浏览
标签: 主图 起爆
来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15

  



       相关简介:    通达信起爆点主图指标公式                              

 

       源码概况:通达信起爆点主图指标公式


  指标类别:起爆点指标公式


  授权方式:免费版


  指标评级:★★★★★


  指标分类:策略


  画线方法:主图





通达信起爆点主图指标公式未来函数检测结果:

         暂未发现存在未来函数





通达信起爆点主图指标公式源码:


    ma20:=MA(C,20);
    MA30:=MA(C,30);
    MA60:=MA(C,60);
    MA120:=MA(C,120);
    MA200:=MA(C,200);
    角度MA20:=ATAN((MA20/REF(MA20,1)-1)*100)*180/3.1416;
    角度MA30:=ATAN((MA30/REF(MA30,1)-1)*100)*180/3.1416;
    角度MA60:=ATAN((MA60/REF(MA60,1)-1)*100)*180/3.1416;
    角度MA120:=ATAN((MA120/REF(MA120,1)-1)*100)*180/3.1416;
    角度MA200:=ATAN((MA200/REF(MA200,1)-1)*100)*180/3.1416;
    X1:=MA20>MA30ANDMA30>MA60ANDMA60>MA120ANDMA120>MA200;
    X2:=角度MA20>0AND角度MA30>0AND角度MA60>0AND角度MA120>0AND角度MA200>0;
    X3:=C/REF(C,1)>=1.04ANDC>OANDC>MA20ANDC<MA20*1.2;
    X4:=V/MA(V,5)>2;
    XG:X1ANDX2ANDX3ANDX4;
    均线:=EXPMA(C,12),COLORGRAY,LINETHICK2;
    日:=50;
    昨前:=3;
    高2:=REF(HHV(H,日),昨前);
    低2:=REF(LLV(L,日),昨前);
    H4:=高2-(高2-低2)*0.618;
    H5:=高2-(高2-低2)*0.809;
    支撑80.9%:REFDATE(H5,DATE),COLORGREEN;
    支撑61.8%:REFDATE(H4,DATE),COLORGREEN,LINETHICK1;
    STICKLINE(CURRBARSCOUNT=1,支撑80.9%,支撑80.9%,300,-1),COLORRED;
    STICKLINE(CURRBARSCOUNT=1,支撑61.8%,支撑61.8%,300,-1),COLORRED;
    DRAWTEXT(CURRBARSCOUNT=1AND支撑80.9%,支撑80.9%,'准备买入'),COLORGREEN;
    DRAWTEXT(CURRBARSCOUNT=1AND支撑61.8%,支撑61.8%,'命运转折线'),COLORRED;
    AB:=EMA(((2*C+H+L)/4-LLV(LOW,30))/(HHV(HIGH,30)-LLV(LOW,30))*100,8);
    BA:=EMA(AB,5);
    A1{高}:=REFDATE(REF(HHV(H,96),5),DATE);
    B1{低}:=REFDATE(REF(LLV(L,96),5),DATE);
    DY{中}:=((A1)+(B1))/2;
    箱顶:IF(AB>0ANDAB-BA<=0,A1,A1),LINETHICK1,COLORYELLOW;
    箱腰:IF(AB>0ANDAB-BA<=0,DY,DY),LINETHICK1,COLORYELLOW;
    箱低:IF(AB>0ANDAB-BA<=0,B1,B1),LINETHICK1,COLORYELLOW;
    高1:IF(AB>0ANDAB-BA>0,A1,DRAWNULL),LINETHICK1,COLORRED;
    中1:IF(AB>0ANDAB-BA>0,DY,DRAWNULL),LINETHICK1,COLORRED;
    低1:IF(AB>0ANDAB-BA>0,B1,DRAWNULL),LINETHICK1,COLORRED;
    VARAA:=IF(CLOSE>150,91.3,0.913);
    突破:INTPART(CLOSE/VARAA)*VARAANODRAW;
    再突破:突破+VARAANODRAW;
    回踩:(突破+再突破)NODRAW;
    MA5:=MA(C,5);
    MA10:=MA(C,10);
    MA20:=MA(C,20)COLORFF00FF;
    MA60:=MA(C,60)COLOR00FF00;
    MA120:=MA(C,120);
    MA250:=MA(C,250);
    DRAWKLINE(H,O,L,C);



[源码注释]通达信起爆点主图指标公式翻译结果



    MA20赋值:收盘价的20日简单移动平均
    MA30赋值:收盘价的30日简单移动平均
    MA60赋值:收盘价的60日简单移动平均
    MA120赋值:收盘价的120日简单移动平均
    MA200赋值:收盘价的200日简单移动平均
    角度MA20赋值:(MA20/1日前的MA20-1)*100的反正切*180/3.1416
    角度MA30赋值:(MA30/1日前的MA30-1)*100的反正切*180/3.1416
    角度MA60赋值:(MA60/1日前的MA60-1)*100的反正切*180/3.1416
    角度MA120赋值:(MA120/1日前的MA120-1)*100的反正切*180/3.1416
    角度MA200赋值:(MA200/1日前的MA200-1)*100的反正切*180/3.1416
    X1赋值:MA20>MA30ANDMA30>MA60ANDMA60>MA120ANDMA120>MA200
    X2赋值:角度MA20>0AND角度MA30>0AND角度MA60>0AND角度MA120>0AND角度MA200>0
    X3赋值:收盘价/1日前的收盘价>=1.04ANDC>OANDC>MA20ANDC<MA20*1.2
    X4赋值:成交量(手)/成交量(手)的5日简单移动平均>2
    输出XG:X1ANDX2ANDX3ANDX4
    均线赋值:收盘价的12日指数移动平均,画深灰色,线宽为2
    日赋值:50
    昨前赋值:3
    高2赋值:昨前日前的日日内最高价的最高值
    低2赋值:昨前日前的日日内最低价的最低值
    H4赋值:高2-(高2-低2)*0.618
    H5赋值:高2-(高2-低2)*0.809
    输出支撑80.9%:日期日H5,画绿色
    输出支撑61.8%:日期日H4,画绿色,线宽为1
    当满足条件到最后交易的周期=1时,在支撑80.9%和支撑80.9%位置之间画柱状线,宽度为300,-1不为0则画空心柱.,画红色
    当满足条件到最后交易的周期=1时,在支撑61.8%和支撑61.8%位置之间画柱状线,宽度为300,-1不为0则画空心柱.,画红色
    当满足条件到最后交易的周期=1AND支撑80.9%时,在支撑80.9%位置书写文字,画绿色
    当满足条件到最后交易的周期=1AND支撑61.8%时,在支撑61.8%位置书写文字,画红色
    AB赋值:((2*收盘价+最高价+最低价)/4-30日内最低价的最低值)/(30日内最高价的最高值-30日内最低价的最低值)*100的8日指数移动平均
    BA赋值:AB的5日指数移动平均
    A1赋值:日期日5日前的96日内最高价的最高值
    B1赋值:日期日5日前的96日内最低价的最低值
    DY赋值:((A1)+(B1))/2
    输出箱顶:如果AB>,返回?,否则返回?
    0ANDAB-BA<
    =0,A1,A1),线宽为1,画黄色
    输出箱腰:如果AB>,返回?,否则返回?
    0ANDAB-BA<
    =0,DY,DY),线宽为1,画黄色
    输出箱低:如果AB>,返回?,否则返回?
    0ANDAB-BA<
    =0,B1,B1),线宽为1,画黄色
    输出高1:如果AB>,返回?,否则返回?
    0ANDAB-BA>
    0,A1,无效数),线宽为1,画红色
    输出中1:如果AB>,返回?,否则返回?
    0ANDAB-BA>
    0,DY,无效数),线宽为1,画红色
    输出低1:如果AB>,返回?,否则返回?
    0ANDAB-BA>
    0,B1,无效数),线宽为1,画红色
    VARAA赋值:如果收盘价>,返回?,否则返回?
    150,91.3,0.913)
    输出突破:收盘价/VARAA的整数部分*VARAANODRAW
    输出再突破:突破+VARAANODRAW
    输出回踩:(突破+再突破)NODRAW
    MA5赋值:收盘价的5日简单移动平均
    MA10赋值:收盘价的10日简单移动平均
    MA20赋值:收盘价的20日简单移动平均COLORFF00FF
    MA60赋值:收盘价的60日简单移动平均COLOR00FF00
    MA120赋值:收盘价的120日简单移动平均
    MA250赋值:收盘价的250日简单移动平均
    K线



神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论