神奇指标网
神奇指标网

通达信KD共振指标详解指标公式

浏览 183次浏览
标签: 指标公式
来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15

  


通达信KD共振指标详解指标公式源码:


    RSV2:=(CLOSE-LLV(LOW,168))/(HHV(HIGH,168)-LLV(LOW,168))*100;
    K2:=SMA(RSV2,30,1);D2:=SMA(K2,12,1);
    HY:=crOSS(K2,D2)ANDK2<35;CC:=CROSS(K2,D2);DD:=CROSS(D2,K2);
    RSV1:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
    K1:=SMA(RSV1,6,1);D1:=SMA(K1,3,1);
    RSV3:=(INDEXC-LLV(INDEXL,15))/(HHV(INDEXH,15)-LLV(INDEXL,15))*100;
    {以下为显示}
    DRAWBAND(K2,RGB(155,50,50),D2,RGB(0,100,50));
    DRAWBAND(K1,RGB(255,0,5),D1,RGB(20,100,250));
    快K:K1,COLOR009999;快D:D1,COLOR999900;
    大盘K:SMA(RSV3,6,1),COLORDD00EE;
    DRAWTEXT(HY,K2+5,'有戏'),COLOR00DDDD;
    {警戒:STICKLINE(C,90,90,4,0),COLOR00DDDD;
    极底:STICKLINE(C,10,10,-1,0),COLOR999900;
    强势线:STICKLINE(C,78,78,-1,0),COLOREEEE00;
    0,COLOR00FFFF;}




通达信KD共振指标详解指标公式源码注释翻译结果


    RSV2赋值:(收盘价-168日内最低价的最低值)/(168日内最高价的最高值-168日内最低价的最低值)*100
    K2赋值:RSV2的30日[1日权重]移动平均
    D2赋值:K2的12日[1日权重]移动平均
    HY赋值:K2上穿D2ANDK2<35
    CC赋值:K2上穿D2
    DD赋值:D2上穿K2
    RSV1赋值:(收盘价-15日内最低价的最低值)/(15日内最高价的最高值-15日内最低价的最低值)*100
    K1赋值:RSV1的6日[1日权重]移动平均
    D1赋值:K1的3日[1日权重]移动平均
    RSV3赋值:(大盘的收盘价-15日内大盘的最低价的最低值)/(15日内大盘的最高价的最高值-15日内大盘的最低价的最低值)*100
    画带状线
    画带状线
    输出快K:K1,COLOR009999
    输出快D:D1,COLOR999900
    输出大盘K:RSV3的6日[1日权重]移动平均,COLORDD00EE
    当满足条件HY时,在K2+5位置书写文字,COLOR00DDDD




神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论