神奇指标网

通达信均线上升指标公式

浏览 1485次浏览
标签: 均线
来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15

  

以下是通达信均线上升指标公式源码和注释翻译结果


使用说明:

   当均线上升指标(UP)为真时,表示价格趋势呈上升趋势,这是一个买入信号。

   投资者可以使用该指标作为辅助工具,在其他分析方法和指标的支持下,判断价格的走势,并做出买入或卖出决策。

   该指标可以应用于股票、期货、外汇等市场的分析和交易中,但需要注意结合其他指标和市场情况进行综合判断。

   对于长期投资者,可以使用该指标来判断趋势的变化,并根据趋势的持续性做出长期持有或卖出的决策。

   在使用该指标时,还应结合风险管理和止损策略,以控制风险和保护投资资金

通达信均线上升指标公式源码:


    M5:=ma(C,5);
    M10:=MA(C,10);
    M20:=MA(C,20);
    M60:=MA(C,60);
    A:=M5>=M60ANDM10>=M60ANDM20>=M60;
    T:=BArslAst(crOSS(A,0.5));
    HT:=HHVBARS(H,T+1);
    NOTEXT1:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),ISLASTBAR,REF(H,T),0),COLORRED;
    NOTEXT2:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),HT=0,REF(H,HT),1),COLORRED;
    NOTEXT3:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),HT=0,(REF(H,HT)-REF(H,T))*0.382+REF(H,T),1),DOTLINE,COLORMAGENTA;
    NOTEXT4:DRAWLINE(CURRBARSCOUNT=CONST(T)+1,REF(H,T),HT=0,(REF(H,HT)-REF(H,T))*0.618+REF(H,T),1),DOTLINE,COLORGREEN;
    压力:NOTEXT2,NODRAW,COLORYELLOW;
    支撑1:NOTEXT3,NODRAW,COLORMAGENTA;
    支撑2:NOTEXT4,NODRAW,COLORGREEN;
    DRAWTEXT(CURRBARSCOUNT=CONST(T)+1,NOTEXT1*0.96,VARCAT(VARCAT('底部支撑价:',VAR2STR(NOTEXT1,2)),'元')),COLORRED;
    LT0:=FINDLOWBARS(L,0,30,1);
    HT0:=FINDHIGHBARS(H,LT0=0,60,1);
    LL:=REF(L,LT0);
    HH:=REF(H,HT0);
    NOTEXT01:DRAWLINE(HT0=0,HH,LT0=0,HH,1),COLORYELLOW;
    NOTEXT02:DRAWLINE(HT0=0,HH,LT0=0,LL,1),COLORYELLOW;
    NOTEXT03:DRAWLINE(HT0=0,HH,LT0=0,(HH-LL)*0.382+LL,1),DOTLINE,COLORLIMAGENTA;
    NOTEXT04:DRAWLINE(HT0=0,HH,LT0=0,(HH-LL)*0.618+LL,1),DOTLINE,COLORLIBLUE;
    TA:=BARSLAST(REF(NOTEXT01,1)=DRAWNULLANDHT=0);
    X支撑线:REF(L,LT0),COLORYELLOW,NODRAW;
    X阻力1:(HH-LL)*0.382+LL,COLORLIMAGENTA,NODRAW;
    X阻力2:(HH-LL)*0.618+LL,COLORLIBLUE,NODRAW;
    DRAWTEXT(TA=0,NOTEXT01*1.03,VARCAT(VARCAT('最高价:',VAR2STR(HH,2)),'元'))COLORYELLOW;
    ma5:=EMA(C,5);
    ma10:=EMA(C,10);
    mv5:=EMA(V,5);
    mv10:=EMA(V,10);
    k:="kdj.k"(9,3,3);
    d:="kdj.d"(9,3,3);
    DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
    DEA:=EMA(DIF,9);
    aa1:=CROSS(k,d);aa2:=CROSS(ma5,ma10);aa3:=CROSS(mv5,mv10);aa4:=CROSS(dif,dea);
    xg2:aa1ANDaa2ANDaa3ANDaa4;






通达信均线上升指标公式源码注释翻译结果


    M5赋值:收盘价的5日简单移动平均
    M10赋值:收盘价的10日简单移动平均
    M20赋值:收盘价的20日简单移动平均
    M60赋值:收盘价的60日简单移动平均
    A赋值:M5>=M60ANDM10>=M60ANDM20>=M60
    T赋值:上次A上穿0.5距今天数
    HT赋值:T+1日内最高价距今天数
    输出NOTEXT1:当满足条件到最后交易的周期=T的最后一日取值设为常数+1时,在T日前的最高价位置画直线起点,当满足条件是否最后一个周期时,在T日前的最高价位置画直线终点,0表示是否延长.,画红色
    输出NOTEXT2:当满足条件到最后交易的周期=T的最后一日取值设为常数+1时,在T日前的最高价位置画直线起点,当满足条件HT=0时,在HT日前的最高价位置画直线终点,1表示是否延长.,画红色
    输出NOTEXT3:当满足条件到最后交易的周期=T的最后一日取值设为常数+1时,在T日前的最高价位置画直线起点,当满足条件HT=0时,在(HT日前的最高价-T日前的最高价)*0.382+T日前的最高价位置画直线终点,1表示是否延长.,DOTLINE,画洋红色
    输出NOTEXT4:当满足条件到最后交易的周期=T的最后一日取值设为常数+1时,在T日前的最高价位置画直线起点,当满足条件HT=0时,在(HT日前的最高价-T日前的最高价)*0.618+T日前的最高价位置画直线终点,1表示是否延长.,DOTLINE,画绿色
    输出压力:NOTEXT2,NODRAW,画黄色
    输出支撑1:NOTEXT3,NODRAW,画洋红色
    输出支撑2:NOTEXT4,NODRAW,画绿色
    当满足条件到最后交易的周期=T的最后一日取值设为常数+1时,在NOTEXT1*0.96位置书写文字,画红色
    LT0赋值:最低价在0日前的30天内第1个最低价到当前周期的周期数
    HT0赋值:最高价在LT0=0日前的60天内第1个最高价到当前周期的周期数
    LL赋值:LT0日前的最低价
    HH赋值:HT0日前的最高价
    输出NOTEXT01:当满足条件HT0=0时,在HH位置画直线起点,当满足条件LT0=0时,在HH位置画直线终点,1表示是否延长.,画黄色
    输出NOTEXT02:当满足条件HT0=0时,在HH位置画直线起点,当满足条件LT0=0时,在LL位置画直线终点,1表示是否延长.,画黄色
    输出NOTEXT03:当满足条件HT0=0时,在HH位置画直线起点,当满足条件LT0=0时,在(HH-LL)*0.382+LL位置画直线终点,1表示是否延长.,DOTLINE,画淡洋红色
    输出NOTEXT04:当满足条件HT0=0时,在HH位置画直线起点,当满足条件LT0=0时,在(HH-LL)*0.618+LL位置画直线终点,1表示是否延长.,DOTLINE,画淡蓝色
    TA赋值:上次1日前的NOTEXT01=DRAWNULLANDHT=0距今天数
    输出X支撑线:LT0日前的最低价,画黄色,NODRAW
    输出X阻力1:(HH-LL)*0.382+LL,画淡洋红色,NODRAW
    输出X阻力2:(HH-LL)*0.618+LL,画淡蓝色,NODRAW
    当满足条件TA=0时,在NOTEXT01*1.03位置书写文字画黄色
    MA5赋值:收盘价的5日指数移动平均
    MA10赋值:收盘价的10日指数移动平均
    MV5赋值:成交量(手)的5日指数移动平均
    MV10赋值:成交量(手)的10日指数移动平均
    K赋值:"
    KDJ的K"
    (9,3,3)
    D赋值:"
    KDJ的D"
    (9,3,3)
    DIF赋值:收盘价的12日指数移动平均-收盘价的26日指数移动平均
    DEA赋值:DIF的9日指数移动平均
    AA1赋值:K上穿D
    AA2赋值:MA5上穿MA10
    AA3赋值:MV5上穿MV10
    AA4赋值:DIF上穿DEA
    输出XG2:AA1ANDAA2ANDAA3ANDAA4





通达信均线上升指标公式截图


神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论