神奇指标网
神奇指标网

大智慧考夫曼自适应变色均线主图指标公式_大智慧指标公式

浏览 96次浏览 来源:神奇指标网 编辑:神奇指标网 发布日期:2024-01-10

  

以下是大智慧考夫曼自适应变色均线主图指标公式源码和截图


大智慧考夫曼自适应变色均线主图指标公式源码:

   傅吾豪均线:EMA(C,18),COLORYELLOW,LINETHICK3;

   红升:IF(傅吾豪均线>REF(傅吾豪均线,1),傅吾豪均线,DRAWNULL),COLORRED,LINETHICK3;

   绿降:IF(傅吾豪均线<REF(傅吾豪均线,1),傅吾豪均线,DRAWNULL),COLORGREEN,LINETHICK3;

   MA1:EMA(CLOSE,3),COLORRED;

   MA2:EMA(CLOSE,5),COLOR778899;

   MA3:EMA(CLOSE,8),COLOR778899;

   MA4:EMA(CLOSE,10),COLOR778899;

   MA5:EMA(CLOSE,12),COLOR778899;

   MA6:EMA(CLOSE,15),COLOR778899;

   MA7:EMA(CLOSE,30),COLOR108090;

   MA8:EMA(CLOSE,35),COLOR108090;

   MA9:EMA(CLOSE,40),COLOR108090;

   MA10:EMA(CLOSE,45),COLOR108090;

   MA11:EMA(CLOSE,50),COLOR108090;

   MA12:EMA(CLOSE,60),COLOR108090;

   DIR1:=Abs(CLOSE-REF(CLOSE,5));

   VIR1:=SUM(ABS(CLOSE-REF(CLOSE,1)),5);

   ER1:=DIR1/VIR1;

   CS1:=ER1*(0.8-2/8)+2/8;

   CQ1:=CS1*CS1;

   AMA1:EMA(DMA(CLOSE,CQ1),2),COLORWHITE;

   DIR2:=ABS(CLOSE-REF(CLOSE,10));

   VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),10);

   ER2:=DIR2/VIR2;

   CS2:=ER2*(0.8-2/24)+2/24;

   CQ2:=CS2*CS2;

   AMA2:EMA(DMA(CLOSE,CQ2),2),COLORGREEN,LINETHICK2;

   Partline(ama2,AMA2/REF(AMA2,1)>0.997),COLORBLUE,LINETHICK2;

   Partline(ama2,AMA2/REF(AMA2,1)>1.001),COLORRED,LINETHICK2;

   N:=120;

   ma1:EMA(CLOSE,3),COLORBLUE;

   MA2:EMA(CLOSE,5),COLORBLUE;

   MA3:EMA(CLOSE,8),COLORBLUE;

   MA4:EMA(CLOSE,10),COLORBLUE;

   MA5:EMA(CLOSE,12),COLORBLUE;

   MA6:EMA(CLOSE,15),COLORBLUE;

   MA7:EMA(CLOSE,30),COLORRED;

   MA8:EMA(CLOSE,35),COLORRED;

   MA9:EMA(CLOSE,40),COLORRED;

   MA10:EMA(CLOSE,45),COLORRED;

   MA11:EMA(CLOSE,50),COLORRED;

   MA12:EMA(CLOSE,60),COLORRED;

   获利盘90均线:MA(COst(90),N);

   获利盘50均线:MA(COST(50),N);

   获利盘30均线:MA(COST(30),N);

   获利盘10均线:MA(COST(10),N);




大智慧考夫曼自适应变色均线主图指标公式截图

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论