神奇指标网

大智慧决策曲线指标公式_大智慧指标公式

浏览 416次浏览
标签: 决策
来源:神奇指标网 编辑:神奇指标网 发布日期:2024-01-10

  

以下是大智慧决策曲线指标公式源码和截图


大智慧决策曲线指标公式源码:

   AVX:=(((((IF(C>MA(C,5),10,(0-10))+IF(MA(C,5)>MA(C,10),10,(0-10)))+IF(C>MA(C,10),10,(0-10)))+IF(MA(C,5)>MA(C,20),10,(0-10)))+IF((C>MA(C,20)),10,(0-10)))+IF

   (MA(C,20)>REF(MA(C,20),1),10,(0-10)));

   DSLX:=(C/INDEXC);

   DSLX1:=MA(DSLX,5);

   TJTS1:=BARSTATUS=2ANDC<200;

   TJTS2:=BARSTATUS=2ANDC>200;

   V1:=MA(V,3);

   V2:=MA(V,8);

   K2:=HHV(H*0.99,BARSLAST(BARSTATUS=1));

   DRAWTEXT_FIX(TJTS1AND((CROSS(AVX,1)AND(V1>=V2))AND(DSLX>=DSLX1)),0.5,0,0,'量能稳定,有走强迹象,根据指数线性关系布局分批介入.'),COLORRED,LINETHICK1;

   DRAWTEXT_FIX(TJTS1AND((CROSS(AVX,1)AND(V1<V2))AND(DSLX>=DSLX1)),0.5,0,0,'走势趋强,量能不足,根据指数线性关系布局分批买入.'),COLORRED,LINETHICK1;

   DRAWTEXT_FIX(TJTS1AND((CROSS(AVX,1)AND(V1>V2))AND(DSLX<DSLX1)),0.5,0,0,'量价配合良好,没有明显走强,根据指数线性关系考虑进入与否.'),COLORYELLOW,LINETHICK1;

   DRAWTEXT_FIX(TJTS1AND((CROSS(AVX,1)AND(V1<=V2))AND(DSLX<DSLX1)),0.5,0,0,'形态尚可,量能不足,未完全走强,根据指数线性关系考虑是否进入.'),COLORGREEN,LINETHICK1;

   DRAWTEXT_FIX(TJTS1AND((CROSS(1,AVX)AND(V1>=V2))AND(DSLX>=DSLX1)),0.5,0,0,'形态变坏,减持或者卖出观望.'),COLORGREEN,LINETHICK2;

   DRAWTEXT_FIX(TJTS1AND((CROSS(1,AVX)AND(V1<V2))AND(DSLX>=DSLX1)),0.5,0,0,'明显缩量走势,根据指数线性关系减持或清仓,等待机会.'),COLORWHITE,LINETHICK1;

   DRAWTEXT_FIX(TJTS1AND((CROSS(1,AVX)AND(V1>=V2))AND(DSLX<DSLX1)),0.5,0,0,'走势偏弱,谨慎操作.'),COLORGREEN,LINETHICK1;

   DRAWTEXT_FIX(TJTS1AND((CROSS(1,AVX)AND(V1<V2))AND(DSLX<DSLX1)),0.5,0,0,'缩量下跌,走势偏弱,离场观望.'),COLORGREEN,LINETHICK1;

   DRAWTEXT_FIX(TJTS1AND((((AVX>=1)AND(REF(AVX,1)>0))AND(V1>=V2))AND(DSLX>=DSLX1)),0.5,0,0,'强势明显,量能充足,注意前期平台和指数影响.'),COLORRED,LINETHICK1;

   DRAWTEXT_FIX(TJTS1AND((((AVX>=1)AND(REF(AVX,1)>0))AND(V1<V2))AND(DSLX>=DSLX1)),0.5,0,0,'强势依然,量能转弱,高抛低吸做好布局.'),COLORCYAN,LINETHICK2;

   DRAWTEXT_FIX(TJTS1AND((((AVX>=1)AND(REF(AVX,1)>0))AND(V1>=V2))AND(DSLX<DSLX1)),0.5,0,0,'具备上涨潜力,根据线性关系操作.'),COLORCYAN,LINETHICK2;

   DRAWTEXT_FIX(TJTS1AND((((AVX>=1)AND(REF(AVX,1)>0))AND(V1<V2))AND(DSLX<DSLX1)),0.5,0,0,'走势趋弱,量能不足,减持筹码.'),COLORCYAN,LINETHICK2;

   DRAWTEXT_FIX(TJTS1AND((((AVX<1)AND(REF(AVX,1)<0))AND(V1>=V2))AND(DSLX>=DSLX1)),0.5,0,0,'形态不佳,注意量能变化,跟踪分析确认.'),LINETHICK2;

   DRAWTEXT_FIX(TJTS1AND((((AVX<1)AND(REF(AVX,1)<0))AND(V1<V2))AND(DSLX>=DSLX1)),0.5,0,0,'走势虽弱,关注线性关系和量能变化,确认业绩、题材.'),COLORYELLOW,LINETHICK2;

   DRAWTEXT_FIX(TJTS1AND((((AVX<1)AND(REF(AVX,1)<0))AND(V1>=V2))AND(DSLX<DSLX1)),0.5,0,0,'有走强迹象,上涨压力大,根据大盘情况操作.'),COLORYELLOW,LINETHICK2;

   DRAWTEXT_FIX(TJTS1AND((((AVX<1)AND(REF(AVX,1)<0))AND(V1<V2))AND(DSLX<DSLX1)),0.5,0,0,'走势太弱,整理后关注量能和信号提示.'),LINETHICK2,COLORYELLOW;

   DRAWTEXT_FIX(TJTS2AND(CROSS(AVX,1)AND(V1>=V2)),0.5,0,0,'量能稳定,有明显走强迹象,可以考虑布局.'),COLORWHITE,LINETHICK2;

   DRAWTEXT_FIX(TJTS2AND(CROSS(AVX,1)AND(V1>=V2)),0.5,0,0,'如前期经过一轮下跌,此时为最佳买点,但前期有过一段涨幅则介入需谨慎.'),COLORWHITE,LINETHICK2;

   DRAWTEXT_FIX(TJTS2AND(CROSS(AVX,1)AND(V1<V2)),0.5,0,0,'虽然走势趋强,量能还显不足,根据线性关系操作.'),COLORWHITE,LINETHICK2;

   DRAWTEXT_FIX(TJTS2AND(CROSS(AVX,1)AND(V1<V2)),0.5,0,0,'可以谨慎布局,控制仓位,一旦量能放大可以重仓买入.'),COLORWHITE,LINETHICK2;

   DRAWTEXT_FIX(TJTS2AND(CROSS(1,AVX)AND(V1>=V2)),0.5,0,0,'大盘形态走坏,减仓或者抛光.'),COLORGREEN,LINETHICK2;

   DRAWTEXT_FIX(TJTS2AND(CROSS(1,AVX)AND(V1<V2)),0.5,0,0,'弱势缩量调整,清仓观望,寻找可布局股票.'),COLORWHITE,LINETHICK2;

   DRAWTEXT_FIX(TJTS2AND(((AVX>=1)AND(REF(AVX,1)>0))AND(V1>=V2)),0.5,0,0,'走势良好,量能稳定,可以继续持有强势股.'),COLORWHITE,LINETHICK2;

   DRAWTEXT_FIX(TJTS2AND(((AVX>=1)AND(REF(AVX,1)>0))AND(V1<V2)),0.5,0,0,'形态良好,量能稍显不足,线性关系顶部背离,随时准备清仓.'),COLORWHITE,LINETHICK2;

   DRAWTEXT_FIX(TJTS2AND(((AVX<1)AND(REF(AVX,1)<0))AND(V1>=V2)),0.5,0,0,'趋势不明,注意量能和线性关系变化,减少操作.'),LINETHICK2,COLORWHITE;

   DRAWTEXT_FIX(TJTS2AND(((AVX<1)AND(REF(AVX,1)<0))AND(V1<V2)),0.5,0,0,'趋势向下,量能萎缩,关注线性关系变化,减少操作.'),LINETHICK2,COLORWHITE;

   RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;

   K1:=SMA(RSV,3,1);

   D1:=SMA(K1,3,1);

   高1:=HHV(H,150);

   低1:=LLV(L,150);

   QR:=(H+L+2*C)/4;

   强弱分界线:=EMA(QR,55),COLORFFFF00;

   TFXXS:=INTPART(K1)+INTPART(D1);

   TGL:=(TFXXS-REF(TFXXS,1));

   DRAWTEXT_FIX(ISLASTBARANDTGL>=0ANDTGL>REF(TGL,1),0.99,0.01,1,'资金状况:流入加快'),COLOR0202FF;

   DRAWTEXT_FIX(ISLASTBARANDTGL>=0ANDTGL<=REF(TGL,1),0.99,0.01,1,'资金状况:流入减慢'),COLOR1876E9;

   DRAWTEXT_FIX(ISLASTBARANDTGL<0ANDTGL>REF(TGL,1),0.99,0.01,1,'资金状况:流出减慢'),COLOR13B79A;

   DRAWTEXT_FIX(ISLASTBARANDTGL<0ANDTGL<=REF(TGL,1),0.99,0.01,1,'资金状况:流出加快'),COLOR00CA00;

   VAR1E:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);

   VAR2E:=SMA(ABS(LOW-VAR1E),13,1)/SMA(MAX(LOW-VAR1E,0),10,1);

   VAR3E:=EMA(VAR2E,10);

   VAR4E:=LLV(LOW,33);

   VAR5E:=EMA(IF(LOW<=VAR4E,VAR3E,0),3);

   VAR21E:=SMA(ABS(HIGH-VAR1E),13,1)/SMA(MIN(HIGH-VAR1E,0),10,1);

   VAR31E:=EMA(VAR21E,10);

   VAR41E:=HHV(HIGH,33);

   VAR51E:=EMA(IF(HIGH>=VAR41E,VAR31E,0),3);

   DRAWTEXT_FIX(ISLASTBARANDVAR51E<REF(VAR51E,1),0.99,0.08,1,'主力正在拉高'),COLOR0202FF;

   DRAWTEXT_FIX(ISLASTBARANDVAR5E>REF(VAR5E,1),0.99,0.15,1,'典型吸筹行为'),COLOR1876E9;

   DRAWTEXT_FIX(ISLASTBARANDVAR5E<REF(VAR5E,1),0.99,0.15,1,'典型洗盘行为'),COLORC08000;

   DRAWTEXT_FIX(ISLASTBARANDVAR5E=REF(VAR5E,1),0.99,0.15,1,'无特殊行为'),COLORC0C0C0;

   DRAWTEXT_FIX(ISLASTBARANDVAR51E>REF(VAR51E,1),0.99,0.08,1,'主力正在出货'),COLOR00CA00;

   DRAWTEXT_FIX(ISLASTBARANDVAR51E=REF(VAR51E,1),0.99,0.08,1,'主力无大动作'),COLORC0C0C0;

   {拉升潜力}

   VAR78:=C/EXPMA(C,5);

   A1:=COST(1.91);

   A2:=COST(3.82);

   A3:=COST(5);

   A4:=COST(6.18);

   A5:=COST(8.09);

   COSTT:=(A1+A2+A3+A4+A5)/5;

   COSTT1:=C/COSTT;

   VARD1:=(2*INDEXC+INDEXH+INDEXL)/4;

   VARD2:=LLV(INDEXL,21);

   VARD3:=HHV(INDEXH,8);

   MIJI:=EMA((VARD1-VARD2)/(VARD3-VARD2)*100,9);

   MIJI1:=MIJI-VAR78;

   MIJI2:=MIJI1-REF(MIJI1,1);

   MIJI3:=MIJI-REF(MIJI,1);

   DAPAN:=COSTT1-(MIJI3+0.618*MIJI2)/16.18;

   DRAWTEXT_FIX(ISLASTBARANDDAPAN<COSTT1,0.99,0.8,1,'受大盘拉动'),COLOR0202FF;

   DRAWTEXT_FIX(ISLASTBARANDDAPAN>=COSTT1,0.99,0.8,1,'受大盘压制'),COLOR00CA00;

   X1E:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;

   X2E:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;

   X3E:=FINANCE(23)/FINANCE(10)*3.3;

   X4E:=FINANCE(19)/FINANCE(15)*0.6;

   X5E:=FINANCE(20)/FINANCE(15)*0.999;

   YAOGU:=X1E+X2E+X3E+X4E+X5E;

   XJF:=CON2STR(FINANCE(25)/FINANCE(15),3);

   YZZ:=CON2STR((FINANCE(19)-FINANCE(22)-FINANCE(27))/FINANCE(19),2);

   DRAWTEXT_FIX(YAOGU<=0,0.99,0.99,1,'拉升潜力:难于登天'),COLOR00FF00;

   DRAWTEXT_FIX(YAOGU>0ANDYAOGU<=1.2,0.99,0.99,1,'拉升潜力:难度较大'),COLOR3A8B5C;

   DRAWTEXT_FIX(YAOGU>1.2ANDYAOGU<=2.6,0.99,0.99,1,'拉升潜力:尚可一试'),COLOR4747B8;

   DRAWTEXT_FIX(YAOGU>2.6ANDYAOGU<=5.8,0.99,0.99,1,'拉升潜力:较为容易'),COLOR2424DB;

   DRAWTEXT_FIX(YAOGU>5.8,0.99,0.99,1,'拉升潜力:轻而易举'),COLOR0000FF;

   DRAWTEXT_FIX(XJF>=1618,0.99,0.86,1,'过于保守'),COLOR4747B8;

   DRAWTEXT_FIX(XJF>=618ANDXJF<1618,0.99,0.86,1,'保守求稳'),COLOR4747B8;

   DRAWTEXT_FIX(XJF>=100ANDXJF<618,0.99,0.86,1,'收支平衡'),,COLOR0000FF;

   DRAWTEXT_FIX(XJF<100,0.99,0.86,1,'负债过多'),COLOR00FF00;

   DRAWTEXT_FIX(YZZ<85,0.99,0.86,1,'资产质地差'),COLOR00FF00;

   快线:=EMA(C,7)-EMA(C,21),LINETHICK2,COLORRED;

   慢线:=MA(快线,4),COLORGREEN,LINETHICK2;

   数值:=EMA((0.668*REF(快线,1)+0.333*快线),1),COLORSTICK;

   X1:=V/SUM(V,13);

   X2:=DMA(C,X1);

   X3:=(C-X2)/X2*40;

   L2:=MA(AMOUNT/(100*V),13);

   CYS13:=(C-L2)/L2*100;

   做多:=IF(快线>=数值,快线,数值);

   做空:=IF(数值-快线,数值,快线);

   强庄:STICKLINE(CYS13>5,L-0.22,L-0.35,2,0),COLORCYAN;

   AAA:=(3*C+H+L+O)/6;

   VAR1:(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36,LINETHICK2,COLORRED;

   VAR2:=(HHV(VAR1,2)+HHV(VAR1,4)+HHV(VAR1,8))/0;

   VAR3:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;

   VAR4:=(HHV(VAR2,2)+HHV(VAR2,4)+HHV(VAR2,8))/0;

   VAR5:(LLV(VAR3,2)+LLV(VAR3,4)+LLV(VAR3,8))/3,COLORRED;

   VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;

   {DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));}

   IF((VAR1<=REF(VAR1,1)),VAR1,DRAWNULL),COLORGREEN,LINETHICK3;

   IF((VAR1>=REF(VAR1,1)),VAR1,DRAWNULL),COLORRED,LINETHICK3;

   STICKLINE(VAR4>VAR1,VAR4,VAR1,0,0),COLORBLUE;

   DRAWKLINE(H,O,L,C);

   DRAWTEXT(REF(VAR5,1)=REF(VAR1,1)ANDVAR5<VAR1,L*0.99,'↖买入'),COLORYELLOW;

   DRAWTEXT(REF(VAR6,1)=REF(VAR1,1)ANDVAR6<VAR1,L*0.98,'↖加仓'),COLORYELLOW;

   CC:=((HIGH+LOW+CLOSE)/3-EMA((HIGH+LOW+CLOSE)/3,5))/(0.015*AVEDEV((HIGH+LOW+CLOSE)/3,5));

   STICKLINE(CC>=0,LOW,HIGH,0.0,0),COLORRED;

   STICKLINE(CC>=0,CLOSE,OPEN,3,1),COLORRED;

   STICKLINE(CC<0,LOW,HIGH,0.0,0),COLORGREEN;

   STICKLINE(CC<0,CLOSE,OPEN,3,1),COLORGREEN;

   月DI:="MACD.DIF#MONTH";

   月DE:="MACD.DEA#MONTH";

   周DI:="MACD.DIF#WEEK";

   周DE:="MACD.DEA#WEEK";

   日DI:="MACD.DIF";

   日DE:="MACD.DEA";

   日金叉:=CROSS(日DI,日DE);

   周金叉:=CROSS(周DI,周DE);

   月金叉:=CROSS(月DI,月DE);

   日穿0:=CROSS(日DI,0);

   周穿0:=CROSS(周DI,0);

   月穿0:=CROSS(月DI,0);

   DRAWTEXT(日穿0,LOW-0.48,'↖日穿0'),COLORCYAN;

   DRAWTEXT(周穿0,L*0.94,'↖周穿0'),COLORCYAN;

   DRAWTEXT(月穿0,L*0.99,'↖月穿0'),COLORCYAN;

   DRAWTEXT(日金叉,LOW-0.3,'↖日金叉'),COLORCYAN;

   DRAWTEXT(周金叉,L*0.92,'↖周金叉'),COLORCYAN;

   DRAWTEXT(月金叉,L*0.90,'↖月金叉'),COLORCYAN;

   {穿三线}

   MA2:=EMA(C,2);

   MA05:=EMA(C,5);

   MA010:=EMA(C,10);

   MA020:=EMA(C,20);

   MA030:=EMA(C,30);

   YC0X:=MA05>=REF(MA05,1);

   H01:=MAX(MAX(MA05,MA010),MA020);

   L01:=MIN(MIN(MA05,MA010),MA020);

   一穿三线:=H01<CANDO<L01ANDYC0XANDMA2>REF(MA2,1);

   STICKLINE(一穿三线,O,C,0.3,0),COLORYELLOW;

   DRAWTEXT(一穿三线,L-0.62,'←穿三线'),COLORGREEN;

   {资金净流入监控}

   总额:=AMOUNT;

   买A:=IF(O=CAND(C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));

   买%:=买A/AMOUNT*100;

   流入:=AMOUNT*买%/10000000000;

   流出:=AMOUNT/100000000-流入;

   净流:=(流入-流出);

   总额3:=SUM(AMOUNT,3);

   流入3:=SUM(流入,3);

   流出3:=SUM(流出,3);

   净流3:=SUM(流入-流出,3);

   总额5:=SUM(AMOUNT,5);

   流入5:=SUM(流入,5);

   流出5:=SUM(流出,5);

   净流5:=SUM(流入-流出,5);

   总额10:=SUM(AMOUNT,10);

   流入10:=SUM(流入,10);

   流出10:=SUM(流出,10);

   净流10:=SUM(流入-流出,10);

   画:=CONST(FINDHIGH(总额10,0,190,1));

   DRAWTEXT_FIX(1,0,0.37,0,'净流(亿):'),COLORMAGENTA,LINETHICK1;

   DRAWTEXT_FIX(1,0,0.45,0,'1日'),COLORMAGENTA,LINETHICK1;

   DRAWTEXT_FIX(1,0,0.55,0,'3日'),COLORMAGENTA,LINETHICK1;

   DRAWTEXT_FIX(1,0,0.65,0,'5日'),COLORMAGENTA,LINETHICK1;

   DRAWTEXT_FIX(1,0,0.75,0,'10日'),COLORMAGENTA,LINETHICK1;

   DRAWNUMBER_FIX(1,0.05,0.45,0,CONST((净流))),COLORYELLOW;

   DRAWNUMBER_FIX(1,0.05,0.55,0,CONST((净流3))),COLORYELLOW;

   DRAWNUMBER_FIX(1,0.05,0.65,0,CONST((净流5))),COLORYELLOW;

   DRAWNUMBER_FIX(1,0.05,0.75,0,CONST((净流10))),COLORYELLOW;

   MA01:=MA(CLOSE,5);

   MA02:=MA(CLOSE,8);

   P01:=IF(crOSS(MA01,MA02),1,0);

   P02:=IF(CROSS(MA02,MA01),-1,0);

   P0:=P01+P02;

   MA11:=MA(CLOSE,8);

   MA12:=MA(CLOSE,21);

   P11:=IF(CROSS(MA11,MA12),1,0);

   P12:=IF(CROSS(MA12,MA11),-1,0);

   P1:=P11+P12;

   RSV:=(CLOSE-LLV(LOW,6))/(HHV(HIGH,6)-LLV(LOW,6))*100;

   K:=SMA(RSV,12,1);

   D:=SMA(K,24,1);

   J:=3*K-2*D;

   P21:=IF(CROSS(K,D)ANDD<20,1,0);

   P22:=IF(CROSS(D,K)ANDK>80,-1,0);

   P23:=IF(CROSS(J,0),0.5,0);

   P24:=IF(CROSS(100,J),-0.5,0);

   P2:=P21+P22+P23+P24;

   DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);

   DEA:=EMA(DIFF,9);

   P31:=IF(CROSS(DIFF,DEA)ANDDEA<0,1,0);

   P32:=IF(CROSS(DEA,DIFF)ANDDIFF>0,-1,0);

   P3:=P31+P32;

   wr1:=100*(HHV(HIGH,13)-CLOSE)/(HHV(HIGH,13)-LLV(LOW,113));

   P41:=IF(WR1>80,1,0);

   P42:=IF(WR1<20,-1,0);

   P4:=P41+P42;

   OB:=SUM(IF(CLOSE>REF(CLOSE,1),vol,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0);

   P51:=IF("obv">REF(EMA("OBV",24),1),1.5,0);

   P52:=IF("OBV"<REF(EMA("OBV",24),1),-1.5,0);

   P5:=P51+P52;

   BR:=SUM(MAX(0,HIGH-REF(CLOSE,1)),26)/SUM(MAX(0,REF(CLOSE,1)-LOW),26)*100;

   AR:=SUM(HIGH-OPEN,26)/SUM(OPEN-LOW,26)*100;

   P61:=IF(BR>350,3,0);

   P62:=IF(BR<45,-3,0);

   P63:=IF(AR>180,3,0);

   P64:=IF(AR<45,-3,0);

   P6:=P61+P62+P63+P64;

   TH:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,0),26);

   TL:=SUM(IF(CLOSE<REF(CLOSE,1),VOL,0),26);

   TQ:=SUM(IF(CLOSE=REF(CLOSE,1),VOL,0),26);

   VR:=100*(TH*2+TQ)/(TL*2+TQ);

   P71:=IF(VR>350,3,0);

   P72:=IF(VR<45,-3,0);

   P7:=P71+P72;

   MASS:=SUM(MA(HIGH-LOW,9)/MA(MA(HIGH-LOW,9),9),25);

   P81:=IF(MASS<27ANDCROSS(MASS,26.5),2,0);

   P82:=IF(MASS>27ANDCROSS(MASS,26.5),-2,0);

   P8:=P81+P82;

   WVAD:=SUM((CLOSE-OPEN)/(HIGH-LOW)*VOL,24)/10000;

   MAWVAD:=MA(WVAD,6);

   P91:=IF(WVAD>0,1,0);

   P92:=IF(WVAD<0,-1,0);

   P9:=P91+P92;

   VOLUME:=MA(VOL,10)/VOL;

   MID:=100*(HIGH+LOW-REF(HIGH+LOW,1))/(HIGH+LOW);

   emv:=MA(MID*VOLUME*(HIGH-LOW)/MA(HIGH-LOW,14),14);

   Q11:=IF(EMV>0,1.5,0);

   Q12:=IF(EMV<0,-1.5,0);

   Q1:=Q11+Q12;

   TR:=EMA(EMA(EMA(CLOSE,13),13),13);

   trix:=(TR-REF(TR,1))/REF(TR,1)*100;

   Q21:=IF(CROSS(TRIX,TR),1.5,0);

   Q22:=IF(CROSS(TR,TRIX),-1.5,0);

   Q2:=Q21+Q22;

   LC:=REF(CLOSE,1);

   rsi:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(Abs(CLOSE-LC),13,1)*100;

   Q31:=IF(RSI>80,1,0);

   Q32:=IF(RSI<20,-1,0);

   Q3:=Q31+Q32;

   OSC:=100*(CLOSE-MA(CLOSE,20));

   MaoSC:=wMA(OSC,6);

   Q41:=IF(CROSS(OSC,MAOSC),1,0);

   Q42:=IF(CROSS(MAOSC,OSC),-1,0);

   Q4:=Q41+Q42;

   TYP:=(HIGH+LOW+CLOSE)/3;

   cci:=(TYP-MA(TYP,13))/(0.015*AVEDEV(TYP,13));

   Q51:=IF(CCI>180,2,0);

   Q52:=IF(CCI<-180,-2,0);

   Q5:=Q51+Q52;

   TR1:=WMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);

   HD:=HIGH-REF(HIGH,1);

   LD:=REF(LOW,1)-LOW;

   DMP:=WMA(IF(HD>0ORHD>LD,HD,0),14);

   DMM:=WMA(IF(LD>0ORLD>HD,LD,0),14);

   pdi:=DMP*100/TR1;

   mdi:=DMM*100/TR1;

   Q61:=IF(CROSS(PDI,MDI),2,0);

   Q62:=IF(CROSS(MDI,PDI),-2,0);

   Q6:=Q61+Q62;

   dpo:=CLOSE-REF(MA(CLOSE,21),21/2+1);

   Q71:=IF(DPO>0,1,0);

   Q72:=IF(DPO<0,-1,0);

   Q7:=Q71+Q72;

   mtm:CLOSE-REF(CLOSE,12);

   MAMTM:=MA(MTM,6);

   Q81:=IF(CROSS(MTM,MAMTM),1,0);

   Q82:=IF(CROSS(MAMTM,MTM),-1,0);

   Q8:=Q81+Q82;

   MID1:=SUM(VOL*(2*CLOSE-HIGH-LOW)/(HIGH+LOW),0);

   CHO:=MA(MID,10)-MA(MID,20);

   MacHO:=MA(CHO,6);

   Q91:=IF((CLOSE>MA(CLOSE,90))ANDCROSS(CLOSE,0),1.5,0);

   Q92:=IF((CLOSE<MA(CLOSE,90))ANDCROSS(0,CLOSE),-1.5,0);

   Q9:=Q91+Q92;

   PSY:=COUNT(CLOSE>REF(CLOSE,1),12)/12*100;

   PSYMA:=MA(PSY,6);

   R11:=IF(PSY>75,1.5,0);

   R12:=IF(PSY<25,-1.5,0);

   R1:=R11+R12;

   MID2:=MA(CLOSE,20);

   UPPER:=MID2+2*stD(CLOSE,20);

   LOWER:=MID2-2*STD(CLOSE,20);

   R21:=IF(CROSS(CLOSE,LOWER),2,0);

   R22:=IF(CROSS(UPPER,CLOSE),-2,0);

   R2:=R21+R22;

   TYP1:=(HIGH+LOW+CLOSE)/3;

   V1:=SUM(IF(TYP1>REF(TYP1,1),TYP1*VOL,0),14)/SUM(IF(TYP1<REF(TYP1,1),

   TYP1*VOL,0),14);

   mfi:=100-(100/(1+V1));

   R31:=IF(MFI>80,1,0);

   R32:=IF(MFI<20,-1,0);

   R3:=R31+R32;

   VARA:=R1+R2+R3+Q1+Q2+Q3+Q4+Q5+Q6+Q7+Q8+Q9+P0+P1+P2+P3+P4+P5+P6+P7+P8+P9;

   决策曲线:VARA;

   决策曲线A:EMA(决策曲线,5),LINETHICK2;

   主筹估算:=Ema(WINNER(C)*70,3),COLORRED;

   散筹估算:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*70,3),COLOR009900;

   买:crOSS(主筹估算,散筹估算);

   筹码集中度:=COst(10)/(COST(80)-COST(10));

   筹码1:EMA(筹码集中度,1)*10,LINETHICK2,COLOR3399ff;

   筹码3:EMA(筹码集中度,3)*10,LINETHICK2,COLORRED;

   筹码13:EMA(筹码集中度,13)*10,LINETHICK1;

   筹码34:EMA(筹码集中度,34)*10,LINETHICK1;

   筹码55:EMA(筹码集中度,55)*10,LINETHICK1;

   筹码90:EMA(筹码集中度,90)*10,LINETHICK1,COLORff00ff;

   筹码250:EMA(筹码集中度,250)*10,LINETHICK1,COLORblue;(COST(85)-COST(15))/(COST(85)+COST(15))*100;

   {70%、90%筹码集中度指标}

   F:=COST(5);

   J:=COST(95);

   M:=COST(15);

   N:=COST(85);

   筹码90%:(J-F)/(F+J);

   筹码70%:(N-M)/(N+M);




大智慧决策曲线指标公式截图

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论