神奇指标网
神奇指标网

通达信自用新编整合版KDJ 副图源码贴图

浏览 5138次浏览 来源:通达信公式 编辑:神奇指标网 发布日期:2022-10-12




以下是通达信自用新编整合版KDJ 副图源码贴图




非 常 好 用 , 多 周 期 K D J 同 图 !



STICKLINE(C>0,-20,5,4,0),COLORBLACK;F1:=ZIG(3,15);F2:=IF((F1> REF(F1,1)),100,80);

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:SMA(RSV,3,1);

D:SMA(K,3,1);

J:3*K-2*D,COLORRED;

MA势:=SMA(MAX(C-REF(C,1),0),8,1)/SMA(ABS(C-REF(C,1)),8,1)*100;

势:=EMA(MA势,5),COLORLIRED;

趋势:=3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*

SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1);

ZZ:=趋势>REF(趋势,1);K1:=DVOL/1000000;K2:=DCLOSE;V1:=EMA(K1,5);V2:=EMA(K2,5);

价异动:=K2>REF(V2,1)*1.06;

量异动:=K1>REF(V1,1)*1.6&&ZZ;

停牌:=DYNAINFO(17)>0;

M1:=SUM(价异动,2)>0 AND 停牌;

M2:=SUM(量异动,2)>0 AND REF(趋势,1)<89;

鸣:(F2=100 AND C>REF(C,1) AND FILTER(M1 AND M2,3))*120,COLORRED,LINETHICK3;

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=(DIF-DEA)*2;

低2:=IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL);

TX:=BARSLAST(C>REF(C,1)*1.095 AND C=H);

T2L:=BARSLAST(C<REF(C,1)*1.095 AND C>REF(C,1)*1.08);

T3L:=BARSLAST(C<REF(C,1)*1.08 AND C>REF(C,1)*1.07);

T4L:=BARSLAST(C<REF(C,1)*1.07 AND C>REF(C,1)*1.06);

T5L:=BARSLAST(C<REF(C,1)*1.06 AND C>REF(C,1)*1.05);

TJ1X:=COUNT(TX=0,100)=0;

TJ2:=COUNT(T2L=0,100)=0;

TJ3:=COUNT(T3L=0,100)=0;

TJ4:=COUNT(T4L=0,100)=0;

TJ5:=COUNT(T5L=0,100)=0;

TJA:=C>REF(C,1)*1.05;

AA:=REF(TX,1)>100 AND REF(T2L,1)>100 AND REF(T3L,1)>100 AND REF(T4L,1)>100 AND REF(T5L,1)>80 AND TJA;

HHM:=HHV(MACD.MACD*100,200);

LLM:=LLV(MACD.MACD*100,200);

M5:=MA(C,5);M10:=MA(C,10);M20:=MA(C,20);M60:=MA(C,60);

D3:=MIN(MIN(M5,M10),M20)>M60;

XGT:=BARSLAST(AA AND HHM<60 AND LLM>-55);

D6:=BARSSINCEN(MIN(MIN(M5,M10),M20)>M60,XGT+1);

XGX:=CROSS((XGT=0 AND D3) OR D6=0,0.5);

TJX:=COUNT(XGX,30)=2 AND XGX;

SR11:=REF(HIGH,10)=HHV(HIGH,2*10+1);

SR21:=FILTER(SR11,10);

SR31:=BACKSET(SR21,10+1);

HDH:=FILTER(SR31,10);

前高G:=REF(H,BARSLAST(HDH));

倍量G:=VOL/REF(VOL,1)>=1.9;

突破前高G:=CROSS(C,前高G);

YG:= 倍量G AND 突破前高G;

SJG:=BARSLAST(YG);

H300:=HHVBARS(DIF,300);

AL:=BOLL.UB;

TQ:=BARSLAST(CROSS(AL>=REF(AL,1),0.5));

E25:=EXPMA(C,25);

ZF:=EVERY(RANGE(C/REF(C,1),0.97,1.05),TQ+1);

ZFF:=(HHV(H,TQ+1)-LLV(L,TQ+1))/LLV(L,TQ+1)*100;

TJQ:=EVERY(MAX(C,O)/AL<1.02 ,TQ+1);

XL:=(ATAN((E25/REF(E25,TQ)-1)*100)*180/3.1415926);

TJ1Q:=CROSS(DIF>=REF(DIF,H300),0.5) AND ZFF<17 AND ZF AND TJQ;

起程:=TJ1Q AND XL>75;

A1F:=REF(C,1);

A3F:=(DCLOSE-A1F)/A1F*100;

AA1F:=(A3F-REF(A3F,1));

选股1:=CROSS(AA1F,9.8);

A11F:=REF(V,1);

A13F:=DVOL/A11F;

AA3F:=(A13F-REF(A13F,1));

选股2:=CROSS(AA3F,500);

潜伏:=选股1 AND 选股2;

爆发点:=(DCLOSE-REF(C,1))/REF(C,1)*100;

XB:=CROSS(爆发点,20);

TJ1L:=REF(CROSS(MA(C,5),C),1) AND CROSS(C,MA(C,5));

TJ2L:=REF(CROSS(MA(C,10),C),1) AND CROSS(C,MA(C,10));

TJ3L:=REF(CROSS(MA(C,20),C),1) AND CROSS(C,MA(C,20));

TJ4L:=TJ1L OR TJ2L OR TJ3L;

TJ5L:=REF(C,2)/REF(C,1)>=1.045 AND REF(C,1)<REF(O,1) AND C/REF(C,1)>1.09 AND C=H AND TJ4L;

A:=(3*C+L+O+H)/6;

X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+

14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)

+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+

REF(A,20))/210;

中线:=EMA(X,13);

KKA:=EMA(C,5);

KKB:=EMA(KKA,8);

KKC:=EMA(KKB,13);

长线1:=EMA(KKC,50);

KAAA3:=REF(C,1)<REF(中线,1) AND C>中线;

KBBB3:=C/REF(C,1)>1+0.01*9;

KCCC3:=中线/长线1<1+0.01*20;

大牛:=KAAA3 AND KBBB3 AND KCCC3 AND TJ5L;

VARAA:=LLV(LOW,5);

VARBA:=HHV(HIGH,5);

确:=EMA((CLOSE-VARAA)/(VARBA-VARAA)*100,4);

MA500:=MA(CLOSE,500);

MA250:=MA(CLOSE,250);

MA120:=MA(CLOSE,120);

MA30:=MA(CLOSE,33);

MA60:=MA(CLOSE,55);

涨停收盘:=(C-REF(C,1))*100/REF(C,1)>=4 AND H-C<0.02;

HD30:=FILTER(BACKSET(FILTER(REF(H,30)=HHV(H,2*30+1),30),30+1),30);

LD30:=FILTER(BACKSET(FILTER(REF(H,30)=LLV(H,2*30+1),30),30+1),30);

AX30:=REF(H,BARSLAST(HD30));

T300:=BARSLAST(HD30)<BARSLAST(LD30) AND NOT(HD30);

顶30:=IF(T300,AX30,AX30);

JZ:=(CROSS(C,顶30) AND DIF>=-0.21 AND DEA<=0.37 AND MA30>MA60 AND (CROSS(C,MA30)OR CROSS(C,MA120)OR CROSS(C,MA250)OR CROSS(C,MA500) OR LOW< MA30)) AND MA30- MA60<0.7 AND 涨停收盘 AND ABS((顶30-MA30)/顶30*100)<10;

信:IF(确>REF(确,1) AND DIF>DEA AND (JZ OR 大牛 OR XB OR 潜伏 OR 起程 OR CURRBARSCOUNT=CONST(SJG)+2 OR TJX OR (CCI<=100 AND L<=低2)),120,0)STICK,LINETHICK5,COLORLIMAGENTA;

卖警:=IF(PEAKBARS(3,15,1)=1,80,100),COLORGREEN;

泥淖:=IF((F1> REF(F1,1)),100,80),COLORFF9900;

Q_1:=C-REF(C,1);

Q_2:=100*EMA(EMA(Q_1,6),6)/EMA(EMA(ABS(Q_1),6),6);

Q_3:=CROSS(EMA(C,19),EMA(C,7));

Q_4:=CROSS(EMA(C,7),EMA(C,19));

Z1:=L=LLV(L,BARSLAST(Q_3)+1);

Z2:=LLV(L,BARSLAST(Q_3)+1);

Z3:=H=HHV(H,BARSLAST(Q_4)+1);

Z4:=HHV(H,BARSLAST(Q_4)+1);

上0:=DRAWLINE(Z1,Z2,Z3,Z4,0);

Y1:=H=HHV(H,BARSLAST(Q_4)+1);

Y2:=HHV(H,BARSLAST(Q_4)+1);

Y3:=L=LLV(L,BARSLAST(Q_3)+1);

Y4:=LLV(L,BARSLAST(Q_3)+1);

下0:=DRAWLINE(Y1,Y2,Y3,Y4,0);

TJ:=IF(上0<REF(上0,1) AND 下0=上0,1,0);

未来空柱:=IF(REF(TJ,1)=0 AND TJ>=1,100,0);

AVAR1:=(C-LLV(L,20))/(HHV(H,20)-LLV(L,20))*100;

AVAR2:=(C-LLV(L,10))/(HHV(H,10)-LLV(L,10))*100;

AVAR3:=(C-LLV(L,5))/(HHV(H,5)-LLV(L,5))*100;

AVAR4:=DMA(SMA((AVAR1+AVAR2+AVAR3)/3,2,1),3);

K0:=SMA(AVAR4,2,1),COLOR0000FF,LINETHICK2;

M0:=SMA(K0,2,1),COLORFFFFFF;

SR1:=REF(HIGH,10)=HHV(HIGH,2*10+1);

SR2:=FILTER(SR1,10);

SR3:=BACKSET(SR2,10+1);

HD:=FILTER(SR3,10);

前高:=REF(H,BARSLAST(HD));

倍量:=VOL/REF(VOL,1)>=1.9;

突破前高:=CROSS(C,前高);

Y:= 倍量 AND 突破前高;

SJ:=BARSLAST(Y);

DRAWTEXT(CURRBARSCOUNT=CONST(SJ)+2,45,'过左峰'),COLORYELLOW;

B:=ZIG(3,10);

G:=MA(B,2);

W:=CROSS(G,B);

DRAWTEXT(W=1,70,'卖' ),COLOR00FF00;

VARA1:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);

VARA2:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);

VARA3:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);

VARA4:=(((VARA1 + (2 * VARA2)) + (3 * VARA3)) / 6);

VARA5:=MA(VARA4,3);

底部反转:=CROSS(KDJ.J,0) AND (VARA5 <= (0 - 7));

DRAWTEXT(F2=100 AND 底部反转,50,'反转预警'),COLORRED;

值:=(EMA(((CLOSE-LLV(LOW,14))/(HHV(HIGH,35)-LLV(LOW,56)))*(4),4))*(25),COLORGREEN,LINETHICK2;

DRAWTEXT(FILTER(CROSS(值,5),10), 40,'超低'),COLORYELLOW;

DIFX:=(2*EMA(CLOSE, 12)-EMA(EMA(CLOSE,12),12))-(2*EMA(CLOSE, 26)-EMA(EMA(CLOSE, 26),26));

DEAX:=2*EMA(DIFX, 9) - EMA(EMA(DIFX, 9),9);

GG:= DEAX> REF(DEAX,1) AND REF(DEAX> REF(DEAX,1),1)=1;

LL:=C< REF(C,1) AND REF(C< REF(C,1),1)=1;

拐点出击:=(NOT(未来空柱=100) AND F2=100 AND LL AND GG)*DEAX;

VAR1:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;

VAR2:=SMA(VAR1,3,1);

VAR3:=SMA(VAR2,3,1);

VAR4:=SMA(VAR3,3,1);

山底:=IF(CLOSE>SAR(4,6,20),SAR(4,6,20),DRAWNULL),CIRCLEDOT,COLORGREEN;

山顶:=IF(CLOSE<SAR(4,6,20),SAR(4,6,20),DRAWNULL),CIRCLEDOT,COLORRED;

DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26),COLORWHITE;

DIFF变红:=IF(DIFF>=REF(DIFF,1),DIFF,DRAWNULL),COLORLIRED;

{DEA:=EMA(DIFF,9),COLORWHITE;}

DEA变红:=IF(DEA>=REF(DEA,1),DEA,DRAWNULL),COLORLIMAGENTA;

{MACD:=2*(DIFF-DEA),COLORSTICK;}

NOTEXT上买下卖:=CLOSE-REF(CLOSE,49),COLORWHITE;

NOTEXT红买绿卖:=MA(NOTEXT上买下卖,49),COLORGREEN;

上买下卖:=IF(NOTEXT上买下卖>NOTEXT红买绿卖,NOTEXT上买下卖,DRAWNULL),LINETHICK2,COLORMAGENTA;

红买绿卖:=IF(NOTEXT红买绿卖>=REF(NOTEXT红买绿卖,1) AND NOTEXT上买下卖>NOTEXT红买绿卖,NOTEXT红买绿卖,DRAWNULL),LINETHICK3,COLORRED;

红买:=上买下卖 AND 红买绿卖 AND DEA变红,COLORRED,NODRAW;

绿卖:=红买!=1,COLORGREEN,NODRAW;

底:=SMA(VAR2,3,1),COLORGREEN;

顶:=SMA(底,3,1),COLORRED;

方向:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,30))/MA(CLOSE,30);

方向向下:=(DMA((2*CLOSE+LOW+HIGH)/4,方向)),COLORGREEN;

红灯停:=IF(CLOSE<SAR(4,6,20),SAR(4,6,20),DRAWNULL),CIRCLEDOT,COLORRED;

向下:=方向向下 AND 红灯停,COLORGREEN,NODRAW;

空仓基因:=绿卖 AND 向下,COLORGREEN,NODRAW;

B2:=BARSLAST(REF(CROSS(顶,底),1));

背离:=空仓基因 AND REF(C,B2+1)<HHV(H,3) AND REF(底,B2+1)>底 AND CROSS(顶,底) AND 底>80 AND MA(C,5)>MA(C,377) AND 山顶;

DRAWTEXT(顶背离=1,85,'顶背'),COLORFFFF00;

DRAWTEXT(FILTER(拐点出击,30), 30,'拐点→'),COLORWHITE;

多空:118,COLOR0B0BFF,LINETHICK5;

红: IF(K0>M0,118,DRAWNULL),COLORFF00FF,LINETHICK5;

青: IF(K0<M0,118,DRAWNULL),COLOR00FF00,LINETHICK5;

STICKLINE(CROSS(90,J),88,100,1,0),COLOR00FF00;

DRAWTEXT(CROSS(90,J),100,'。逃'),COLORFFFFFF;

STICKLINE(CROSS(J,(0 - 5)),0,10,3,0);

DRAWTEXT(CROSS(J,(0 - 5)),(0 - 4),'----低吸'),COLORYELLOW;



{抄底加仓}

IF(REF(COUNT(K<REF(K,1),5)>=5,1) AND COUNT(K<30,5)>=2 AND COUNT(J<0,3)>0 AND CROSS(J,0),100,50),COLOR00FFFF;

TJ00:=BARSLAST(REF(CROSS(K,D) AND REF(K,1)<35,1));

TJ11:=C<REF(C,TJ00+1)*1.1 AND REF(K,1)<60 AND (TJ00+1)<25 AND (TJ00+1)>5 AND K>REF(K,TJ00+1) AND CROSS(K,D);

仓:=IF(TJ11,35,0),COLORLIRED;

A22:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));

DRAWICON(CROSS(K,D),K,1);

DRAWICON(CROSS(D,K),D,2);








VAR0002:="KDJ.K#DAY"(9,3,3);

VAR0003:="KDJ.D#DAY"(9,3,3);

VAR0004:="KDJ.K#WEEK"(9,3,3);

VAR0005:="KDJ.D#WEEK"(9,3,3);

VAR0006:="KDJ.K#MONTH"(9,3,3);

VAR0007:="KDJ.D#MONTH"(9,3,3);



日:IF(CROSS(VAR0002,VAR0003),15,0)LINESTICK,COLORGREEN;

周:IF(CROSS(VAR0004,VAR0005),60,0)LINESTICK,COLORMAGENTA;

月:IF(CROSS(VAR0006,VAR0007),90,0),LINETHICK2,COLORYELLOW;

DRAWTEXT(周,18,'周'),COLORYELLOW;

DRAWTEXT(月,20,'月'),COLORYELLOW;

周日:IF(CROSS(VAR0004,VAR0005) AND CROSS(VAR0002,VAR0003),70,0)LINETHICK2,COLORBLUE;






通达信自用新编整合版KDJ 副图源码贴图



神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论