神奇指标网
神奇指标网

通达信妖庄主图指标公式

浏览 201次浏览
标签: 主图
来源:神奇指标网 编辑:神奇指标网 发布日期:2023-06-15

  

以下是通达信妖庄主图指标公式源码和注释翻译结果


使用说明:1.白色短柱子是在提示大底已到准备银子建仓;2.红色高柱子在提示,买进信号出现可以开仓进货;3.蓝色趋势线到达上部蓝色区域表示风险已高,打起精神防范风险,相反到达下部蓝色区域表示风险已完全释放,不要再割肉。


通达信妖庄主图指标公式源码:


    RSVA1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
    RSVA2:=100*(HHV(HIGH,9)-CLOSE)/(HHV(HIGH,9)-LLV(LOW,9));
    VAR21:=SMA(RSVA2,9,1)+100;
    VAR1111:=Sma(RSVA1,3,1);
    VAR51:=SMA(VAR1111,3,1)+100;
    顶底线:=VAR51-VAR21+50;
    VAR2222:=LLV(LOW,33);
    VAR3333:=HHV(HIGH,21);
    VAR4444:=EMA((CLOSE-VAR2222)/(VAR3333-VAR2222)*100,10)*-1+100;
    趋势:=100-EMA(0.191*REF(VAR4444,1)+0.809*VAR4444,1);
    stICKLINE(C,100,90,4,0),COLORFFCC33;
    STICKLINE(C,90,80,4,0),COLORFF9933;
    STICKLINE(顶底线>REF(顶底线,1),20,80,4,0),COLORYELLOW;
    STICKLINE(顶底线<REF(顶底线,1),20,80,4,0),COLORYELLOW;
    STICKLINE((趋势>REF(趋势,1)AND顶底线<REF(顶底线,1)),20,80,4,0),COLORYELLOW;
    STICKLINE((趋势<REF(趋势,1)AND顶底线>REF(顶底线,1)),20,80,4,0),COLORYELLOW;
    STICKLINE(C,20,10,4,0),COLORFF6633;
    STICKLINE(C,10,0,4,0),COLORFF3333;
    辟地:10,COLORWHITE;
    开天:90,COLORWHITE;
    趋势线:100-EMA(0.191*REF(VAR4444,1)+0.809*VAR4444,1),LINETHICK2,COLORBLUE;
    当前安全度:=100-EMA(0.191*REF(VAR4444,1)+0.809*VAR4444,1),CIRCLEDOT,LINETHICK2,COLORRED;
    DRAWTEXT(CURRBARSCOUNT=6,5,'高安全区'),COLORWHITE;
    DRAWTEXT(CURRBARSCOUNT=6,15,'安全区'),COLORWHITE;
    DRAWTEXT(CURRBARSCOUNT=6,85,'风险区'),COLORWHITE;
    DRAWTEXT(CURRBARSCOUNT=6,95,'高风险区'),COLORWHITE;
    VAR11:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
    VAR22:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
    VAR33:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
    VAR44:=(VAR11+2*VAR22+3*VAR33)/6;
    VAR55:=MA(VAR44,3)-STD(VAR44,3);
    乖离6:=VAR55<-6ANDVAR55>-9;
    VAR111:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
    VAR222:=SMA(Abs(LOW-VAR111),13,1)/SMA(MAX(LOW-VAR111,0),10,1);
    VAR333:=EMA(VAR222,10);
    VAR444:=LLV(LOW,33);
    VAR555:=EMA(IF(LOW<=VAR444,VAR333,0),3);
    XG99:VAR555>REF(VAR555,1);
    STICKLINE(乖离6ORXG99,0,20,3,0),COLORFAE6E6;
    VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
    VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
    VAR3:=EMA(VAR2,10);
    VAR4:=LLV(LOW,33);
    VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3);
    进场:=VAR5>REF(VAR5,1);
    洗盘:=VAR5<REF(VAR5,1);
    钱袋子:=REF(进场,1)ANDREF(进场,2)AND洗盘AND(EXIST(乖离6ORXG99,6));
    MA18:=MA(CLOSE,18);
    mtm:=C-REF(C,1);
    DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
    买:=LLV(DX,2)=LLV(DX,7)ANDCOUNT(DX<0,2)ANDcrOSS(DX,MA(DX,2));
    TJ:=COUNT(买,3)=1AND买AND(EXIST(乖离6ORXG99,6));
    主力:=EMA((CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2)*5;
    散户:=EMA((CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7)*5;
    XG:=CROSS(主力,散户)AND主力<-10AND(EXIST(乖离6ORXG99,6));
    STICKLINE((XGOR钱袋子ORTJ),0,55,1,0),COLORRED;
    支撑线:Ema((O+C)/2,20),DOTLINE,COLORCYAN;
    妖股起爆:MA(CLOSE,25)+MA(CLOSE,25)*20/100*0.35,COLORRED,LINETHICK2;
    Z1:=stRCAT(HYBLOCK,'');
    Z2:=STRCAT(Z1,DYBLOCK);
    Z3:=STRCAT(Z2,'');
    DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
    压力线:(MA(MA(H,25),25)-MA(MA(L,25),25))*1+MA(MA(H,25),25),DOTLINE,COLORYELLOW;
    趋势:=MA(MA(L,25),25)-(MA(MA(H,25),25)-MA(MA(L,25),25))*1,LINETHICK2,COLORRED;
    STICKLINE(趋势>LOWAND趋势<HIGH,趋势,MIN(MIN(OPEN,CLOSE),趋势),2,0),COLORGREEN;
    STICKLINE(趋势>MIN(C,O)AND趋势<MAX(C,O),趋势,MIN(OPEN,CLOSE),2,0),COLORGREEN;
    STICKLINE(趋势>HIGH,OPEN,CLOSE,2,0),COLORGREEN;
    STICKLINE(趋势>HIGH,HIGH,LOW,0,0),COLORGREEN;
    VAR23:=100*MA(MA((C-REF(C,1)),6),6)/MA(MA(Abs((C-REF(C,1))),6),6);
    回调买:=LLV(VAR23,2)=LLV(VAR23,7)ANDCOUNT(VAR23<0,2)ANDcrOSS(VAR23,MA(VAR23,2));
    XG:=趋势>HIGHAND回调买ANDL<=趋势;
    DRAWLINE(XG,H,REF(XG,1),REF(H,1),1),COLORRED;
    DRAWLINE(XG,L,REF(XG,1),REF(L,1),1),COLORGREEN;
    STICKLINE(XG,C,O,3,0),COLORLIMAGENTA;
    DRAWICON(XG,L,28);
    DRAWTEXT(XG,LOW-0.075*LOW,'发现庄家关注'),COLORYELLOW;
    XXBB:=EMA((CLOSE-LLV(LOW,18))/(HHV(HIGH,18)-LLV(LOW,18))*4,5)*100;
    关注1:=REF(XXBB,1)>50ANDXXBB-REF(XXBB,1)>40;
    关注2:=REF(关注1,1)=0AND关注1;
    DRAWTEXT(关注2,LOW-0.075*LOW,'转强进场'),COLORRED;
    STICKLINE(关注2,C,O,3,0),COLORYELLOW;
    走妖:=REF(C<压力线ORC<妖股起爆,1)ANDC>压力线ANDC>妖股起爆ANDC/REF(C,1)>1.04ANDREF(C,1)/REF(C,2)<1.065;
    STICKLINE(走妖,C,O,3,0),COLORRED;
    DRAWTEXT(走妖,LOW-0.085*LOW,'走妖起爆或出局'),COLORCYAN;






通达信妖庄主图指标公式源码注释翻译结果


    RSVA1赋值:(收盘价-9日内最低价的最低值)/(9日内最高价的最高值-9日内最低价的最低值)*100
    RSVA2赋值:100*(9日内最高价的最高值-收盘价)/(9日内最高价的最高值-9日内最低价的最低值)
    VAR21赋值:RSVA2的9日[1日权重]移动平均+100
    VAR1111赋值:RSVA1的3日[1日权重]移动平均
    VAR51赋值:VAR1111的3日[1日权重]移动平均+100
    顶底线赋值:VAR51-VAR21+50
    VAR2222赋值:33日内最低价的最低值
    VAR3333赋值:21日内最高价的最高值
    VAR4444赋值:(收盘价-VAR2222)/(VAR3333-VAR2222)*100的10日指数移动平均*-1+100
    趋势赋值:100-0.191*1日前的VAR4444+0.809*VAR4444的1日指数移动平均
    当满足条件收盘价时,在100和90位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLORFFCC33
    当满足条件收盘价时,在90和80位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLORFF9933
    当满足条件顶底线>1日前的顶底线时,在20和80位置之间画柱状线,宽度为4,0不为0则画空心柱.,画黄色
    当满足条件顶底线<1日前的顶底线时,在20和80位置之间画柱状线,宽度为4,0不为0则画空心柱.,画黄色
    当满足条件(趋势>1日前的趋势AND顶底线<1日前的顶底线)时,在20和80位置之间画柱状线,宽度为4,0不为0则画空心柱.,画黄色
    当满足条件(趋势<1日前的趋势AND顶底线>1日前的顶底线)时,在20和80位置之间画柱状线,宽度为4,0不为0则画空心柱.,画黄色
    当满足条件收盘价时,在20和10位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLORFF6633
    当满足条件收盘价时,在10和0位置之间画柱状线,宽度为4,0不为0则画空心柱.,COLORFF3333
    输出辟地:10,画白色
    输出开天:90,画白色
    输出趋势线:100-0.191*1日前的VAR4444+0.809*VAR4444的1日指数移动平均,线宽为2,画蓝色
    当前安全度赋值:100-0.191*1日前的VAR4444+0.809*VAR4444的1日指数移动平均,CIRCLEDOT,线宽为2,画红色
    当满足条件到最后交易的周期=6时,在5位置书写文字,画白色
    当满足条件到最后交易的周期=6时,在15位置书写文字,画白色
    当满足条件到最后交易的周期=6时,在85位置书写文字,画白色
    当满足条件到最后交易的周期=6时,在95位置书写文字,画白色
    VAR11赋值:(收盘价-收盘价的6日简单移动平均)/收盘价的6日简单移动平均*100
    VAR22赋值:(收盘价-收盘价的12日简单移动平均)/收盘价的12日简单移动平均*100
    VAR33赋值:(收盘价-收盘价的24日简单移动平均)/收盘价的24日简单移动平均*100
    VAR44赋值:(VAR11+2*VAR22+3*VAR33)/6
    VAR55赋值:VAR44的3日简单移动平均-VAR44的3日估算标准差
    乖离6赋值:VAR55<-6ANDVAR55>-9
    VAR111赋值:1日前的(最低价+开盘价+收盘价+最高价)/4
    VAR222赋值:最低价-VAR111的绝对值的13日[1日权重]移动平均/最低价-VAR111和0的较大值的10日[1日权重]移动平均
    VAR333赋值:VAR222的10日指数移动平均
    VAR444赋值:33日内最低价的最低值
    VAR555赋值:如果最低价<=VAR444,返回VAR333,否则返回0的3日指数移动平均
    输出XG99:VAR555>1日前的VAR555
    当满足条件乖离6ORXG99时,在0和20位置之间画柱状线,宽度为3,0不为0则画空心柱.,COLORFAE6E6
    VAR1赋值:1日前的(最低价+开盘价+收盘价+最高价)/4
    VAR2赋值:最低价-VAR1的绝对值的13日[1日权重]移动平均/最低价-VAR1和0的较大值的10日[1日权重]移动平均
    VAR3赋值:VAR2的10日指数移动平均
    VAR4赋值:33日内最低价的最低值
    VAR5赋值:如果最低价<=VAR4,返回VAR3,否则返回0的3日指数移动平均
    进场赋值:VAR5>1日前的VAR5
    洗盘赋值:VAR5<1日前的VAR5
    钱袋子赋值:1日前的进场ANDREF(进场,2)AND洗盘AND(最近6日存在乖离6ORXG99)
    MA18赋值:收盘价的18日简单移动平均
    MTM赋值:收盘价-1日前的收盘价
    DX赋值:100*MTM的6日指数移动平均的6日指数移动平均/MTM的绝对值的6日指数移动平均的6日指数移动平均
    买赋值:2日内DX的最低值=7日内DX的最低值ANDCOUNT(DX<0,2)ANDCROSS(DX,DX的2日简单移动平均)
    TJ赋值:统计3日中满足买的天数=1AND买AND(最近6日存在乖离6ORXG99)
    主力赋值:(收盘价-收盘价的7日简单移动平均)/收盘价的7日简单移动平均*480的2日指数移动平均*5
    散户赋值:(收盘价-收盘价的11日简单移动平均)/收盘价的11日简单移动平均*480的7日指数移动平均*5
    XG赋值:主力上穿散户AND主力<-10AND(最近6日存在乖离6ORXG99)
    当满足条件(XGOR钱袋子ORTJ)时,在0和55位置之间画柱状线,宽度为1,0不为0则画空心柱.,画红色
    输出支撑线:(开盘价+收盘价)/2的20日指数移动平均,DOTLINE,画青色
    输出妖股起爆:收盘价的25日简单移动平均+收盘价的25日简单移动平均*20/100*0.35,画红色,线宽为2
    Z1赋值:字符串相加
    Z2赋值:字符串相加
    Z3赋值:字符串相加
    当满足条件是否最后一个周期时,在横轴0纵轴0位置书写文字,画红色
    输出压力线:(最高价的25日简单移动平均的25日简单移动平均-最低价的25日简单移动平均的25日简单移动平均)*1+最高价的25日简单移动平均的25日简单移动平均,DOTLINE,画黄色
    趋势赋值:最低价的25日简单移动平均的25日简单移动平均-(最高价的25日简单移动平均的25日简单移动平均-最低价的25日简单移动平均的25日简单移动平均)*1,线宽为2,画红色
    当满足条件趋势>LOWAND趋势<最高价时,在趋势和开盘价和收盘价的较小值和趋势的较小值位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色
    当满足条件趋势>收盘价和开盘价的较小值AND趋势<收盘价和开盘价的较大值时,在趋势和开盘价和收盘价的较小值位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色
    当满足条件趋势>最高价时,在开盘价和收盘价位置之间画柱状线,宽度为2,0不为0则画空心柱.,画绿色
    当满足条件趋势>最高价时,在最高价和最低价位置之间画柱状线,宽度为0,0不为0则画空心柱.,画绿色
    VAR23赋值:100*(收盘价-1日前的收盘价)的6日简单移动平均的6日简单移动平均/(收盘价-1日前的收盘价)的绝对值的6日简单移动平均的6日简单移动平均
    回调买赋值:2日内VAR23的最低值=7日内VAR23的最低值ANDCOUNT(VAR23<0,2)ANDCROSS(VAR23,VAR23的2日简单移动平均)
    XG赋值:趋势>HIGHAND回调买ANDL<=趋势
    当满足条件XG时,在最高价位置画直线起点,当满足条件1日前的XG时,在1日前的最高价位置画直线终点,1表示是否延长.,画红色
    当满足条件XG时,在最低价位置画直线起点,当满足条件1日前的XG时,在1日前的最低价位置画直线终点,1表示是否延长.,画绿色
    当满足条件XG时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画淡洋红色
    当满足条件XG时,在最低价位置画28号图标
    当满足条件XG时,在最低价-0.075*最低价位置书写文字,画黄色
    XXBB赋值:(收盘价-18日内最低价的最低值)/(18日内最高价的最高值-18日内最低价的最低值)*4的5日指数移动平均*100
    关注1赋值:1日前的XXBB>50ANDXXBB-1日前的XXBB>40
    关注2赋值:1日前的关注1=0AND关注1
    当满足条件关注2时,在最低价-0.075*最低价位置书写文字,画红色
    当满足条件关注2时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画黄色
    走妖赋值:1日前的收盘价<压力线ORC<妖股起爆ANDC>压力线ANDC>妖股起爆ANDC/1日前的收盘价>1.04ANDREF(收盘价,1)/2日前的收盘价<1.065
    当满足条件走妖时,在收盘价和开盘价位置之间画柱状线,宽度为3,0不为0则画空心柱.,画红色
    当满足条件走妖时,在最低价-0.085*最低价位置书写文字,画青色



通达信妖庄主图指标公式截图

神奇指标网(https://www.shenqizhibiao.com/)所有指标公式及文章来源于网络仅供学习研究

神奇指标收藏 收藏
神奇指标分享 分享

网友评论

已有0人评论

清除 发表评论